Top -- GNU Gnulib

GNU Gnulib

Menu

  • Brief Overview
  • Philosophy
  • Invoking gnulib-tool
  • Writing modules
  • Extending Gnulib
  • Miscellaneous Notes
  • POSIX Substitutes Library Building as a separate substitutes library.
  • Header File Substitutes Overriding system headers.
  • Function Substitutes Replacing system functions.
  • Legacy Function Substitutes Replacing system functions.
  • Glibc Header File Substitutes Overriding system headers.
  • Glibc Function Substitutes Replacing system functions.
  • Native Windows Support Support for the native Windows platforms.
  • Particular Modules Documentation of individual modules.
  • Regular expressions The regex module.
  • Build Infrastructure Modules Modules that extend the GNU Build System.
  • GNU Free Documentation License Copying and sharing this manual.
  • Index
    • The notation ``Gnulib module: ---'' means that Gnulib does not provide a module providing a substitute for the \thing\. When the list ``Portability problems not fixed by Gnulib'' is empty, such a module is not needed: No portability problems are known. Otherwise, it indicates that such a module would be useful but is not available: No one so far found this \thing\ important enough to contribute a substitute for it. If you need this particular \thing\, you may write to <bug-gnulib at gnu dot org>.


Brief Overview -- GNU Gnulib

Next: Philosophy Top: Top

1. Brief Overview

Gnulib is a source code library that provides basic functionality to programs and libraries. Many software packages make use of Gnulib to avoid reinventing the portability wheel.

Resources:

  • Gnulib is hosted at Savannah: https://savannah.gnu.org/projects/gnulib. Get the sources through Git from there.
  • The Gnulib home page: https://www.gnu.org/software/gnulib/.
Menu

  • Gnulib Basics
  • Git Checkout
  • Keeping Up-to-date
  • Contributing to Gnulib
  • Portability guidelines
  • High Quality

    • Next: Philosophy Top: Top


Gnulib Basics -- GNU Gnulib

Next: Git Checkout Up: Brief Overview Top: Top

1.1. Gnulib Basics

While portability across operating systems is not one of GNU's primary goals, it has helped introduce many people to the GNU system, and is worthwhile when it can be achieved at a low cost. This collection helps lower that cost.

Gnulib is intended to be the canonical source for most of the important ``portability'' and/or common files for GNU projects. These are files intended to be shared at the source level; Gnulib is not a typical library meant to be installed and linked against. Thus, unlike most projects, Gnulib does not normally generate a source tarball distribution; instead, developers grab modules directly from the source repository.

The easiest, and recommended, way to do this is to use the @command{gnulib-tool} script. Since there is no installation procedure for Gnulib, @command{gnulib-tool} needs to be run directly in the directory that contains the Gnulib source code. You can do this either by specifying the absolute filename of @command{gnulib-tool}, or by using a symbolic link from a place inside your @env{PATH} to the @command{gnulib-tool} file of your preferred Gnulib checkout. For example:

$ ln -s $HOME/gnu/src/gnulib.git/gnulib-tool $HOME/bin/gnulib-tool

Next: Git Checkout Up: Brief Overview Top: Top


Git Checkout -- GNU Gnulib

Next: Keeping Up-to-date Prev: Gnulib Basics Up: Brief Overview Top: Top

1.2. Git Checkout

Gnulib is available for anonymous checkout. In any Bourne-shell the following should work:

$ git clone git://git.sv.gnu.org/gnulib.git
For a read-write checkout you need to have a login on `savannah.gnu.org' and be a member of the Gnulib project at https://savannah.gnu.org/projects/gnulib. Then, instead of the URL git://git.sv.gnu.org/gnulib, use the URL `ssh://user@git.sv.gnu.org/srv/git/gnulib' where user is your login name on savannah.gnu.org.

git resources:

Overview:
https://en.wikipedia.org/wiki/Git_(software)
Homepage:
https://git-scm.com/
When you use git annotate or git blame with Gnulib, it's recommended that you use the @option{-w} option, in order to ignore massive whitespace changes that happened in 2009.

Next: Keeping Up-to-date Prev: Gnulib Basics Up: Brief Overview Top: Top


Keeping Up-to-date -- GNU Gnulib

Next: Contributing to Gnulib Prev: Git Checkout Up: Brief Overview Top: Top

1.3. Keeping Up-to-date

The best way to work with Gnulib is to check it out of git. To synchronize, you can use git pull.

Subscribing to the bug-gnulib@gnu.org mailing list will help you to plan when to update your local copy of Gnulib (which you use to maintain your software) from git. You can review the archives, subscribe, etc., via https://lists.gnu.org/mailman/listinfo/bug-gnulib.

Sometimes, using an updated version of Gnulib will require you to use newer versions of GNU Automake or Autoconf. You may find it helpful to join the autotools-announce mailing list to be advised of such changes.

Next: Contributing to Gnulib Prev: Git Checkout Up: Brief Overview Top: Top


Contributing to Gnulib -- GNU Gnulib

Next: Portability guidelines Prev: Keeping Up-to-date Up: Brief Overview Top: Top

1.4. Contributing to Gnulib

All software here is copyrighted by the Free Software Foundation---you need to have filled out an assignment form for a project that uses the module for that contribution to be accepted here.

If you have a piece of code that you would like to contribute, please email bug-gnulib@gnu.org.

Generally we are looking for files that fulfill at least one of the following requirements:

  • If your .c and .h files define functions that are broken or missing on some other system, we should be able to include it.

  • If your functions remove arbitrary limits from existing functions (either under the same name, or as a slightly different name), we should be able to include it.
If your functions define completely new but rarely used functionality, you should probably consider packaging it as a separate library.

Menu

  • Gnulib licensing
  • Indent with spaces not TABs
  • How to add a new module

    • Next: Portability guidelines Prev: Keeping Up-to-date Up: Brief Overview Top: Top


Gnulib licensing -- GNU Gnulib

Next: Indent with spaces not TABs Up: Contributing to Gnulib Top: Top

1.4.1. Gnulib licensing

Gnulib contains code both under GPL and LGPL. Because several packages that use Gnulib are GPL, the files state they are licensed under GPL. However, to support LGPL projects as well, you may use some of the files under LGPL. The ``License:'' information in the files under modules/ clarifies the real license that applies to the module source.

Keep in mind that if you submit patches to files in Gnulib, you should license them under a compatible license, which means that sometimes the contribution will have to be LGPL, if the original file is available under LGPL via a ``License: LGPL'' information in the projects' modules/ file.

Next: Indent with spaces not TABs Up: Contributing to Gnulib Top: Top


Indent with spaces not TABs -- GNU Gnulib

Next: How to add a new module Prev: Gnulib licensing Up: Contributing to Gnulib Top: Top

1.4.2. Indent with spaces not TABs

We use space-only indentation in nearly all files. This includes all *.h, *.c, *.y files, except for the regex module. Makefile and ChangeLog files are excluded, since TAB characters are part of their format.

In order to tell your editor to produce space-only indentation, you can use these instructions.

  • For Emacs: Add these lines to your Emacs initialization file ($HOME/.emacs or similar):

    ;; In Gnulib, indent with spaces everywhere (not TABs).
;; Exceptions: Makefile and ChangeLog modes.
(add-hook 'find-file-hook '(lambda ()
  (if (and buffer-file-name
           (string-match "/gnulib\\>" (buffer-file-name))
           (not (string-equal mode-name "Change Log"))
           (not (string-equal mode-name "Makefile")))
      (setq indent-tabs-mode nil))))
  • For vi (vim): Add these lines to your $HOME/.vimrc file:

    " Don't use tabs for indentation. Spaces are nicer to work with.
set expandtab
    For Makefile and ChangeLog files, compensate for this by adding this to your $HOME/.vim/after/indent/make.vim file, and similarly for your $HOME/.vim/after/indent/changelog.vim file:

    " Use tabs for indentation, regardless of the global setting.
set noexpandtab
  • For Eclipse: In the ``Window|Preferences'' dialog (or ``Eclipse|Preferences'' dialog on Mac OS),

    1. Under ``General|Editors|Text Editors'', select the ``Insert spaces for tabs'' checkbox.

    2. Under ``C/C++|Code Style'', select a code style profile that has the ``Indentation|Tab policy'' combobox set to ``Spaces only'', such as the ``GNU [built-in]'' policy.
    If you use the GNU indent program, pass it the option @option{--no-tabs}.

Next: How to add a new module Prev: Gnulib licensing Up: Contributing to Gnulib Top: Top


How to add a new module -- GNU Gnulib

Prev: Indent with spaces not TABs Up: Contributing to Gnulib Top: Top

1.4.3. How to add a new module

  • Add the header files and source files to lib/.

  • If the module needs configure-time checks, write an Autoconf macro for it in m4/module.m4. See m4/README for details.

  • Write a module description modules/module, based on modules/TEMPLATE.

  • If the module contributes a section to the end-user documentation, put this documentation in doc/module.texi and add it to the ``Files'' section of modules/module. Most modules don't do this; they have only documentation for the programmer (= Gnulib user). Such documentation usually goes into the lib/ source files. It may also go into doc/; but don't add it to the module description in this case.

  • Add the module to the list in MODULES.html.sh.
You can test that a module builds correctly with:

$ ./gnulib-tool --create-testdir --dir=/tmp/testdir module1 ... moduleN
$ cd /tmp/testdir
$ ./configure && make
Other things:

  • Check the license and copyright year of headers.

  • Check that the source code follows the GNU coding standards; see https://www.gnu.org/prep/standards.

  • Add source files to config/srclist* if they are identical to upstream and should be upgraded in Gnulib whenever the upstream source changes.

  • Include header files in source files to verify the function prototypes.

  • Make sure a replacement function doesn't cause warnings or clashes on systems that have the function.

  • Autoconf functions can use `gl_*' prefix. The `AC_*' prefix is for autoconf internal functions.

  • Build files only if they are needed on a platform. Look at the alloca and fnmatch modules for how to achieve this. If for some reason you cannot do this, and you have a .c file that leads to an empty .o file on some platforms (through some big #if around all the code), then ensure that the compilation unit is not empty after preprocessing. One way to do this is to #include <stddef.h> or <stdio.h> before the big #if.

Prev: Indent with spaces not TABs Up: Contributing to Gnulib Top: Top


Portability guidelines -- GNU Gnulib

Next: High Quality Prev: Contributing to Gnulib Up: Brief Overview Top: Top

1.5. Portability guidelines

Gnulib code is intended to be portable to a wide variety of platforms, not just GNU platforms. Gnulib typically attempts to support a platform as long as it is still supported by its provider, even if the platform is not the latest version. See Target Platforms.

Many Gnulib modules exist so that applications need not worry about undesirable variability in implementations. For example, an application that uses the malloc module need not worry about malloc (0) returning NULL on some Standard C platforms; and glob users need not worry about glob silently omitting symbolic links to nonexistent files on some platforms that do not conform to POSIX.

Gnulib code is intended to port without problem to new hosts, e.g., hosts conforming to recent C and POSIX standards. Hence Gnulib code should avoid using constructs that these newer standards no longer require, without first testing for the presence of these constructs. For example, because C11 made variable length arrays optional, Gnulib code should avoid them unless it first uses the vararrays module to check whether they are supported.

The following subsections discuss some exceptions and caveats to the general Gnulib portability guidelines.

Menu

  • C language versions
  • C99 features assumed
  • C99 features avoided
  • Other portability assumptions

    • Next: High Quality Prev: Contributing to Gnulib Up: Brief Overview Top: Top


C language versions -- GNU Gnulib

Next: C99 features assumed Up: Portability guidelines Top: Top

1.5.1. C language versions

Currently Gnulib assumes at least a freestanding C99 compiler, possibly operating with a C library that predates C99; with time this assumption will likely be strengthened to later versions of the C standard. Old platforms currently supported include AIX 6.1, HP-UX 11i v1 and Solaris 10, though these platforms are rarely tested. Gnulib itself is so old that it contains many fixes for obsolete platforms, fixes that may be removed in the future.

Because of the freestanding C99 assumption, Gnulib code can include <float.h>, <limits.h>, <stdarg.h>, <stdbool.h>, <stddef.h>, and <stdint.h> unconditionally. Gnulib code can also assume the existence of <ctype.h>, <errno.h>, <fcntl.h>, <locale.h>, <signal.h>, <stdio.h>, <stdlib.h>, <string.h>, and <time.h>. Similarly, many modules include <sys/types.h> even though it's not even in C11; that's OK since <sys/types.h> has been around nearly forever.

Even if the include files exist, they may not conform to the C standard. However, GCC has a @command{fixincludes} script that attempts to fix most C89-conformance problems. Gnulib currently assumes include files largely conform to C89 or better. People still using ancient hosts should use fixincludes or fix their include files manually.

Even if the include files conform, the library itself may not. For example, strtod and mktime have some bugs on some platforms. You can work around some of these problems by requiring the relevant modules, e.g., the Gnulib mktime module supplies a working and conforming mktime.

Next: C99 features assumed Up: Portability guidelines Top: Top


C99 features assumed -- GNU Gnulib

Next: C99 features avoided Prev: C language versions Up: Portability guidelines Top: Top

1.5.2. C99 features assumed by Gnulib

Although the C99 standard specifies many features, Gnulib code is conservative about using them, partly because Gnulib predates the widespread adoption of C99, and partly because many C99 features are not well-supported in practice. C99 features that are reasonably portable nowadays include:

  • A declarations after a statement, or as the first clause in a for statement.

  • long long int.

  • <stdbool.h>, assuming the stdbool module is used. See stdbool.h.

  • <stdint.h>, assuming the stdint module is used. See stdint.h.

  • Compound literals and designated initializers.

  • Variadic macros.

  • static inline functions.

  • __func__, assuming the func module is used. See func.

  • The restrict qualifier, assuming AC_REQUIRE([AC_C_RESTRICT]) is used.

  • Flexible array members (however, see the flexmember module).

Next: C99 features avoided Prev: C language versions Up: Portability guidelines Top: Top


C99 features avoided -- GNU Gnulib

Next: Other portability assumptions Prev: C99 features assumed Up: Portability guidelines Top: Top

1.5.3. C99 features avoided by Gnulib

Gnulib avoids some features even though they are standardized by C99, as they have portability problems in practice. Here is a partial list of avoided C99 features. Many other C99 features are portable only if their corresponding modules are used; Gnulib code that uses such a feature should require the corresponding module.

  • Variable length arrays, unless __STDC_NO_VLA__ is defined. See the vararrays module.

  • extern inline functions, without checking whether they are supported. See extern inline.

  • Type-generic math functions.

  • Universal character names in source code.

  • <iso646.h>, since GNU programs need not worry about deficient source-code encodings.

  • Comments beginning with `//'. This is mostly for style reasons.

Next: Other portability assumptions Prev: C99 features assumed Up: Portability guidelines Top: Top


Other portability assumptions -- GNU Gnulib

Prev: C99 features avoided Up: Portability guidelines Top: Top

1.5.4. Other portability assumptions made by Gnulib

The GNU coding standards allow one departure from strict C: Gnulib code can assume that standard internal types like size_t are no wider than long. POSIX requires implementations to support at least one programming environment where this is true, and such environments are recommended for Gnulib-using applications. When it is easy to port to non-POSIX platforms like MinGW where these types are wider than long, new Gnulib code should do so, e.g., by using ptrdiff_t instead of long. However, it is not always that easy, and no effort has been made to check that all Gnulib modules work on MinGW-like environments.

Gnulib code makes the following additional assumptions:

  • int and unsigned int are at least 32 bits wide. POSIX and the GNU coding standards both require this.

  • Signed integer arithmetic is two's complement.

    Previously, Gnulib code sometimes assumed that signed integer arithmetic wraps around, but modern compiler optimizations sometimes do not guarantee this, and Gnulib code with this assumption is now considered to be questionable. See Integer Properties.

    Although some Gnulib modules contain explicit support for the other signed integer representations allowed by the C standard (ones' complement and signed magnitude), these modules are the exception rather than the rule. All practical Gnulib targets use two's complement.

  • There are no ``holes'' in integer values: all the bits of an integer contribute to its value in the usual way.

  • Addresses and sizes behave as if objects reside in a flat address space. In particular:

    • If two nonoverlapping objects have sizes S and T represented as size_t values, then S + T cannot overflow.

    • A pointer P points within an object O if and only if (char *) &O <= (char *) P && (char *) P < (char *) (&O + 1).

    • If an existing object has size S, and if T is sufficiently small (e.g., 8 KiB), then S + T cannot overflow. Overflow in this case would mean that the rest of your program fits into T bytes, which can't happen in realistic flat-address-space hosts.

    • Objects with all bits zero are treated as 0 or NULL. For example, memset (A, 0, sizeof A) initializes an array A of pointers to NULL.

    • Adding zero to a null pointer does not change the pointer. For example, 0 + (char *) NULL == (char *) NULL.
The above assumptions are not required by the C or POSIX standards but hold on all practical porting targets that we're familiar with. If you have a porting target where these assumptions are not true, we'd appreciate hearing of any fixes. We need fixes that do not increase runtime overhead on standard hosts and that are relatively easy to maintain.

Prev: C99 features avoided Up: Portability guidelines Top: Top


High Quality -- GNU Gnulib

Prev: Portability guidelines Up: Brief Overview Top: Top

1.6. High Quality

We develop and maintain a testsuite for Gnulib. The goal is to have a 100% firm interface so that maintainers can feel free to update to the code in git at any time and know that their application will not break. This means that before any change can be committed to the repository, a test suite program must be produced that exposes the bug for regression testing. All experimental work should be done on branches to help promote this.

Prev: Portability guidelines Up: Brief Overview Top: Top


Philosophy -- GNU Gnulib

Next: Invoking gnulib-tool Prev: Brief Overview Top: Top

2. Philosophy

Gnulib's design and development philosophy is organized around steady, collaborative, and open development of reusable modules that are suitable for a reasonably wide variety of platforms.

Menu

  • Benefits
  • Library vs Reusable Code
  • Portability and Application Code
  • Target Platforms
  • Modules
  • Various Kinds of Modules
  • Collaborative Development
  • Copyright
  • Steady Development
  • Openness

    • Next: Invoking gnulib-tool Prev: Brief Overview Top: Top


Benefits -- GNU Gnulib

Next: Library vs Reusable Code Up: Philosophy Top: Top

2.1. Benefits of using Gnulib

Gnulib is useful to enhance various aspects of a package:

  • Portability: With Gnulib, a package maintainer can program against the POSIX and GNU libc APIs and nevertheless expect good portability to platforms that don't implement POSIX.

  • Maintainability: When a package uses modules from Gnulib instead of code written specifically for that package, the maintainer has less code to maintain.

  • Security: Gnulib provides functions that are immune against vulnerabilities that plague the uses of the corresponding commonplace functions. For example, asprintf, canonicalize_file_name are not affected by buffer sizing problems that affect sprintf, realpath. openat does not have the race conditions that open has. Etc.

  • Reliability: Gnulib provides functions that combine a call to a system function with a check of the result. Examples are xalloc, xprintf, xstrtod, xgetcwd.

  • Structure: Gnulib offers a way to structure code into modules, typically one include file, one source code file, and one autoconf macro for each functionality. Modularity helps maintainability.

Next: Library vs Reusable Code Up: Philosophy Top: Top


Library vs Reusable Code -- GNU Gnulib

Next: Portability and Application Code Prev: Benefits Up: Philosophy Top: Top

2.2. Library vs. Reusable Code

Classical libraries are installed as binary object code. Gnulib is different: It is used as a source code library. Each package that uses Gnulib thus ships with part of the Gnulib source code. The used portion of Gnulib is tailored to the package: A build tool, called gnulib-tool, is provided that copies a tailored subset of Gnulib into the package.


Portability and Application Code -- GNU Gnulib

Next: Target Platforms Prev: Library vs Reusable Code Up: Philosophy Top: Top

2.3. Portability and Application Code

One of the goals of Gnulib is to make portable programming easy, on the basis of the standards relevant for GNU (and Unix). The objective behind that is to avoid a fragmentation of the user community into disjoint user communities according to the operating system, and instead allow synergies between users on different operating systems.

Another goal of Gnulib is to provide application code that can be shared between several applications. Some people wonder: "What? glibc doesn't have a function to copy a file?" Indeed, the scope of a system's libc is to implement the relevant standards (ISO C, POSIX) and to provide access functions to the kernel's system calls, and little more.

There is no clear borderline between both areas.

For example, Gnulib has a facility for generating the name of backup files. While this task is entirely at the application level---no standard specifies an API for it---the na"@dotless{i}ve code has some portability problems because on some platforms the length of file name components is limited to 30 characters or so. Gnulib handles that.

Similarly, Gnulib has a facility for executing a command in a subprocess. It is at the same time a portability enhancement (it works on GNU, Unix, and Windows, compared to the classical fork/exec idiom which is not portable to Windows), as well as an application aid: it takes care of redirecting stdin and/or stdout if desired, and emits an error message if the subprocess failed.

Next: Target Platforms Prev: Library vs Reusable Code Up: Philosophy Top: Top


Target Platforms -- GNU Gnulib

Next: Modules Prev: Portability and Application Code Up: Philosophy Top: Top

2.4. Target Platforms

Gnulib supports a number of platforms that we call the ``reasonable portability targets''. This class consists of widespread operating systems, for three years after their last availability, or---for proprietary operating systems---as long as the vendor provides commercial support for it. Already existing Gnulib code for older operating systems is usually left in place for longer than these three years. So it comes that programs that use Gnulib run pretty well also on these older operating systems.

Some operating systems are not very widespread, but are Free Software and are actively developed. Such platforms are also supported by Gnulib, if that OS's developers community keeps in touch with the Gnulib developers, by providing bug reports, analyses, or patches. For such platforms, Gnulib supports only the versions of the last year or the last few months, depending on the maturity of said OS project, the number of its users, and how often these users upgrade.

Niche operating systems are generally unsupported by Gnulib, unless some of their developers or users contribute support to Gnulib.

The degree of support Gnulib guarantees for a platform depends on the amount of testing it gets from volunteers. Platforms on which Gnulib is frequently tested are the best supported. Then come platforms with occasional testing, then platforms which are rarely tested. Usually, we fix bugs when they are reported. Except that some rarely tested platforms are also low priority; bug fixes for these platforms can take longer.

As of 2016, the list of supported platforms is the following:

  • glibc systems. With glibc 2.15 or newer, they are frequently tested. About the kernels:
    • glibc on Linux is frequently tested.
    • glibc on kFreeBSD is rarely tested.
  • Mac OS X. In versions 10.11, it's occasionally tested. In version 10.5, it's rarely tested.
  • FreeBSD 9.1 or newer is occasionally tested.
  • OpenBSD 5.8 or newer is occasionally tested.
  • AIX 7.1 is occasionally tested.
  • Solaris 10 and 11 are occasionally tested. Solaris 9 and older are rarely tested and low priority.
  • Cygwin 2.6 is occasionally tested. Cygwin 1.7.x is rarely tested.
  • mingw is occasionally tested. But note that some modules are currently unsupported on mingw: mgetgroups, getugroups, idcache, userspec, openpty, login_tty, forkpty, pt_chown, grantpt, pty, savewd, mkancesdirs, mkdir-p, euidaccess, faccessat. The versions of Windows that are supported are Windows XP and newer. Only the latest version of mingw is tested; older versions are not supported.
  • GNU Hurd 0.7 is rarely tested.
  • NetBSD 7.0 or newer is rarely tested.
  • Native Windows, with MSVC as compiler, is rarely tested and low priority.
  • musl libc is rarely tested.
  • Minix 3.3.0 is rarely tested.
  • HP-UX 11.31 is very rarely tested.
  • IRIX 6.5 is no longer tested.
  • OSF/1 5.1 is no longer tested.
  • Interix 6.1 is no longer tested, and requires the suacomp library (https://sourceforge.net/projects/suacomp/) in version 0.6.8 or newer.
  • Haiku and BeOS are no longer tested.
  • uClibc on Linux is no longer tested.
  • QNX is no longer tested.
Gnulib supports these operating systems only in an unvirtualized environment. When you run an OS inside a virtual machine, you have to be aware that the virtual machine can bring in bugs of its own. For example, floating-point operations on Solaris can behave slightly differently in QEMU than on real hardware. And Haiku's @command{bash} program misbehaves in VirtualBox 3, whereas it behaves fine in VirtualBox 4.

Similarly, running native Windows binaries on GNU/Linux under WINE is rarely tested and low priority: WINE has a set of behaviours and bugs that is slightly different from native Windows.

The following platforms are not supported by Gnulib. The cost of supporting them would exceed the benefit because they are rarely used, or poorly documented, or have been supplanted by other platforms, or diverge too much from POSIX, or some combination of these and other factors. Please don't bother sending us patches for them.

  • Windows 95/98/ME.
  • DJGPP and EMX (the 32-bit operating systems running in DOS).
  • MSDOS (the 16-bit operating system).
  • Windows Mobile, Symbian OS, iOS.

Next: Modules Prev: Portability and Application Code Up: Philosophy Top: Top


Modules -- GNU Gnulib

Next: Various Kinds of Modules Prev: Target Platforms Up: Philosophy Top: Top

2.5. Modules

Gnulib is divided into modules. Every module implements a single facility. Modules can depend on other modules.

A module consists of a number of files and a module description. The files are copied by gnulib-tool into the package that will use it, usually verbatim, without changes. Source code files (.h, .c files) reside in the lib/ subdirectory. Autoconf macro files reside in the m4/ subdirectory. Build scripts reside in the build-aux/ subdirectory.

The module description contains the list of files; gnulib-tool copies these files. It contains the module's dependencies; gnulib-tool installs them as well. It also contains the autoconf macro invocation (usually a single line or nothing at all); gnulib-tool ensures this is invoked from the package's configure.ac file. And also a Makefile.am snippet; gnulib-tool collects these into a Makefile.am for the tailored Gnulib part. The module description and include file specification are for documentation purposes; they are combined into MODULES.html.

The module system serves two purposes:

  1. It ensures consistency of the used autoconf macros and Makefile.am rules with the source code. For example, source code which uses the getopt_long function---this is a common way to implement parsing of command line options in a way that complies with the GNU standards---needs the source code (lib/getopt.c and others), the autoconf macro which detects whether the system's libc already has this function (in m4/getopt.m4), and a few Makefile.am lines that create the substitute getopt.h if not. These three pieces belong together. They cannot be used without each other. The module description and gnulib-tool ensure that they are copied altogether into the destination package.

  2. It allows for scalability. It is well-known since the inception of the MODULA-2 language around 1978 that dissection into modules with dependencies allows for building large sets of code in a maintainable way. The maintainability comes from the facts that:

    • Every module has a single purpose; you don't worry about other parts of the program while creating, reading or modifying the code of a module.

    • The code you have to read in order to understand a module is limited to the source of the module and the .h files of the modules listed as dependencies. It is for this reason also that we recommend to put the comments describing the functions exported by a module into its .h file.
    In other words, the module is the elementary unit of code in Gnulib, comparable to a class in object-oriented languages like Java or C#.
The module system is the basis of gnulib-tool. When gnulib-tool copies a part of Gnulib into a package, it first compiles a module list, starting with the requested modules and adding all the dependencies, and then collects the files, configure.ac snippets and Makefile.am snippets.

Next: Various Kinds of Modules Prev: Target Platforms Up: Philosophy Top: Top


Various Kinds of Modules -- GNU Gnulib

Prev: Modules Up: Philosophy Top: Top

2.6. Various Kinds of Modules

There are modules of various kinds in Gnulib. For a complete list of the modules, see in MODULES.html.

2.6.1. Support for ISO C or POSIX functions.

When a function is not implemented by a system, the Gnulib module provides an implementation under the same name. Examples are the `snprintf' and `readlink' modules.

Similarly, when a function is not correctly implemented by a system, Gnulib provides a replacement. For functions, we use the pattern

#if !HAVE_WORKING_FOO
# define foo rpl_foo
#endif
and implement the foo function under the name rpl_foo. This renaming is needed to avoid conflicts at compile time (in case the system header files declare foo) and at link/run time (because the code making use of foo could end up residing in a shared library, and the executable program using this library could be defining foo itself).

For header files, such as stdbool.h or stdint.h, we provide the substitute only if the system doesn't provide a correct one. The template of this replacement is distributed in a slightly different name, with `.in' inserted before the `.h' extension, so that on systems which do provide a correct header file the system's one is used.

2.6.2. Enhancements of ISO C or POSIX functions

These are sometimes POSIX functions with GNU extensions also found in glibc---examples: `getopt', `fnmatch'---and often new APIs---for example, for all functions that allocate memory in one way or the other, we have variants which also include the error checking against the out-of-memory condition.

2.6.3. Portable general use facilities

Examples are a module for copying a file---the portability problems relate to the copying of the file's modification time, access rights, and extended attributes---or a module for extracting the tail component of a file name---here the portability to native Windows requires a different API than the classical POSIX basename function.

2.6.4. Reusable application code

Examples are an error reporting function, a module that allows output of numbers with K/M/G suffixes, or cryptographic facilities.

2.6.5. Object oriented classes

Examples are data structures like `list', or abstract output stream classes that work around the fact that an application cannot implement an stdio FILE with its logic. Here, while staying in C, we use implementation techniques like tables of function pointers, known from the C++ language or from the Linux kernel.

2.6.6. Interfaces to external libraries

Examples are the `iconv' module, which interfaces to the iconv facility, regardless whether it is contained in libc or in an external libiconv. Or the `readline' module, which interfaces to the GNU readline library.

2.6.7. Build / maintenance infrastructure

An example is the `maintainer-makefile' module, which provides extra Makefile tags for maintaining a package.

Prev: Modules Up: Philosophy Top: Top


Collaborative Development -- GNU Gnulib

Next: Copyright Up: Philosophy Top: Top

2.7. Collaborative Development

Gnulib is maintained collaboratively. The mailing list is <bug-gnulib at gnu dot org>. Be warned that some people on the list may be very active at some times and unresponsive at other times.

Every module has one or more maintainers. While issues are discussed collaboratively on the list, the maintainer of a module nevertheless has a veto right regarding changes in his module.

All patches should be posted the list, regardless whether they are proposed patches or whether they are committed immediately by the maintainer of the particular module. The purpose is not only to inform the other users of the module, but mainly to allow peer review. It is not uncommon that several people contribute comments or spot bugs after a patch was proposed.

Conversely, if you are using Gnulib, and a patch is posted that affects one of the modules that your package uses, you have an interest in proofreading the patch.

Next: Copyright Up: Philosophy Top: Top


Copyright -- GNU Gnulib

Next: Steady Development Prev: Collaborative Development Up: Philosophy Top: Top

2.8. Copyright

Most modules are under the GPL. Some, mostly modules which can reasonably be used in libraries, are under LGPL. The source files always say "GPL", but the real license specification is in the module description file. If the module description file says "GPL", it means "GPLv3+" (GPLv3 or newer, at the licensee's choice); if it says "LGPL", it means "LGPLv3+" (LGPLv3 or newer, at the licensee's choice).

More precisely, the license specification in the module description file applies to the files in lib/ and build-aux/. Different licenses apply to files in special directories:

modules/
Module description files are under this copyright:

Copyright © 20XX--20YY Free Software Foundation, Inc.* Copying and distribution of this file, with or without modification, in any medium, are permitted without royalty provided the copyright notice and this notice are preserved.
m4/
Autoconf macro files are under this copyright:

Copyright © 20XX--20YY Free Software Foundation, Inc.* This file is free software; the Free Software Foundation gives unlimited permission to copy and/or distribute it, with or without modifications, as long as this notice is preserved.
tests/
If a license statement is not present in a test module, the test files are under GPL. Even if the corresponding source module is under LGPL, this is not a problem, since compiled tests are not installed by ``make install''.

doc/
Documentation files are under this copyright:

Copyright © 2004--20YY Free Software Foundation, Inc.* Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled ``GNU Free Documentation License''.
If you want to use some Gnulib modules under LGPL, you can do so by passing the option `--lgpl' to gnulib-tool. This will replace the GPL header with an LGPL header while copying the source files to your package. Similarly, if you want some Gnulib modules under LGPLv2+ (Lesser GPL version 2.1 or newer), you can do so by passing the option `--lgpl=2' to gnulib-tool.

Keep in mind that when you submit patches to files in Gnulib, you should license them under a compatible license. This means that sometimes the contribution will have to be LGPL, if the original file is available under LGPL. You can find out about it by looking for a "License: LGPL" information in the corresponding module description.

Next: Steady Development Prev: Collaborative Development Up: Philosophy Top: Top


Steady Development -- GNU Gnulib

Next: Openness Prev: Copyright Up: Philosophy Top: Top

2.9. Steady Development

Gnulib modules are continually adapted, to match new practices, to be consistent with newly added modules, or simply as a response to build failure reports. Gnulib is available in two qualities:

  • There is the newest version of Gnulib from the Git repository.

  • We also make stable releases every two months, at https://erislabs.net/ianb/projects/gnulib/.
If you are willing to report an occasional regression, we recommend to use the newest version always, except in periods of major changes. Most Gnulib users do this. If you prefer stable releases, please use the newest stable release.

Next: Openness Prev: Copyright Up: Philosophy Top: Top


Openness -- GNU Gnulib

Prev: Steady Development Up: Philosophy Top: Top

2.10. Openness

Gnulib is open in the sense that we gladly accept contributions if they are generally useful, well engineered, and if the contributors have signed the obligatory papers with the FSF.

The module system is open in the sense that a package using Gnulib can

  1. locally patch or override files in Gnulib,
  2. locally add modules that are treated like Gnulib modules by gnulib-tool.
This is achieved by the `--local-dir' option of gnulib-tool (see Extending Gnulib).

Prev: Steady Development Up: Philosophy Top: Top


Invoking gnulib-tool -- GNU Gnulib

Next: Writing modules Prev: Philosophy Top: Top

3. Invoking gnulib-tool

The @command{gnulib-tool} command is the recommended way to import Gnulib modules. It is possible to borrow Gnulib modules in a package without using @command{gnulib-tool}, relying only on the meta-information stored in the modules/* files, but with a growing number of modules this becomes tedious. @command{gnulib-tool} simplifies the management of source files, Makefile.ams and configure.ac in packages incorporating Gnulib modules.

gnulib-tool is not installed in a standard directory that is contained in the PATH variable. It needs to be run directly in the directory that contains the Gnulib source code. You can do this either by specifying the absolute filename of gnulib-tool, or you can also use a symbolic link from a place inside your PATH to the gnulib-tool file of your preferred and most up-to-date Gnulib checkout, like this:

$ ln -s $HOME/gnu/src/gnulib.git/gnulib-tool $HOME/bin/gnulib-tool
Run `gnulib-tool --help' for information. To get familiar with @command{gnulib-tool} without affecting your sources, you can also try some commands with the option `--dry-run'; then gnulib-tool will only report which actions it would perform in a real run without changing anything.

Menu

  • Which modules? Determining the needed set of Gnulib modules
  • Initial import First import of Gnulib modules.
  • Modified imports Changing the import specification.
  • Simple update Tracking Gnulib development.
  • Source changes Impact of Gnulib on your source files.
  • Multiple instances Using Gnulib for both a library and a binary
  • gettextize and autopoint Caveat: gettextize and autopoint users!
  • Localization Handling Gnulib's own message translations.
  • VCS Issues Integration with Version Control Systems.
  • Unit tests Bundling the unit tests of the Gnulib modules.
  • Conditional dependencies Avoiding unnecessary checks and compilations.

    • Next: Writing modules Prev: Philosophy Top: Top


Which modules? -- GNU Gnulib

Next: Initial import Up: Invoking gnulib-tool Top: Top

3.1. Finding modules

There are three ways of finding the names of Gnulib modules that you can use in your package:

  • You have the complete module list, sorted according to categories, in https://www.gnu.org/software/gnulib/MODULES.html.

  • If you are looking for a particular POSIX header or function replacement, look in the chapters Header File Substitutes and Function Substitutes. For headers and functions that are provided by Glibc but not standardized by POSIX, look in the chapters Glibc Header File Substitutes and Glibc Function Substitutes.

  • If you have already found the source file in Gnulib and are looking for the module that contains this source file, you can use the command `gnulib-tool --find filename'.

Next: Initial import Up: Invoking gnulib-tool Top: Top


Initial import -- GNU Gnulib

Next: Modified imports Prev: Which modules? Up: Invoking gnulib-tool Top: Top

3.2. Initial import

Gnulib assumes that your project uses Autoconf. When using Gnulib, you will need to have Autoconf among your build tools.

Unless you use @command{gnulib-tool}'s @option{--gnu-make} option, Gnulib also assumes that your project uses Automake at least in a subdirectory of your project. While the use of Automake in your project's top level directory is an easy way to fulfil the Makefile conventions of the GNU coding standards, Gnulib does not require it.

Invoking `gnulib-tool --import' will copy source files, create a Makefile.am to build them, generate a file gnulib-comp.m4 with Autoconf M4 macro declarations used by configure.ac, and generate a file gnulib-cache.m4 containing the cached specification of how Gnulib is used.

Our example will be a library that uses Autoconf, Automake and Libtool. It calls strdup, and you wish to use gnulib to make the package portable to C99 and C11 (which don't have strdup).

~/src/libfoo$ gnulib-tool --import strdup
Module list with included dependencies:
  absolute-header
  extensions
  strdup
  string
File list:
  lib/dummy.c
  lib/strdup.c
  lib/string.in.h
  m4/absolute-header.m4
  m4/extensions.m4
  m4/gnulib-common.m4
  m4/strdup.m4
  m4/string_h.m4
Creating directory ./lib
Creating directory ./m4
Copying file lib/dummy.c
Copying file lib/strdup.c
Copying file lib/string.in.h
Copying file m4/absolute-header.m4
Copying file m4/extensions.m4
Copying file m4/gnulib-common.m4
Copying file m4/gnulib-tool.m4
Copying file m4/strdup.m4
Copying file m4/string_h.m4
Creating lib/Makefile.am
Creating m4/gnulib-cache.m4
Creating m4/gnulib-comp.m4
Finished.

You may need to add #include directives for the following .h files.
  #include <string.h>

Don't forget to
  - add "lib/Makefile" to AC_CONFIG_FILES in ./configure.ac,
  - mention "lib" in SUBDIRS in Makefile.am,
  - mention "-I m4" in ACLOCAL_AMFLAGS in Makefile.am,
  - invoke gl_EARLY in ./configure.ac, right after AC_PROG_CC,
  - invoke gl_INIT in ./configure.ac.
~/src/libfoo$
By default, the source code is copied into lib/ and the M4 macros in m4/. You can override these paths by using --source-base=DIRECTORY and --m4-base=DIRECTORY. Some modules also provide other files necessary for building. These files are copied into the directory specified by `AC_CONFIG_AUX_DIR' in configure.ac or by the --aux-dir=DIRECTORY option. If neither is specified, the current directory is assumed.

gnulib-tool can make symbolic links instead of copying the source files. The option to specify for this is `--symlink', or `-s' for short. This can be useful to save a few kilobytes of disk space. But it is likely to introduce bugs when gnulib is updated; it is more reliable to use `gnulib-tool --update' (see below) to update to newer versions of gnulib. Furthermore it requires extra effort to create self-contained tarballs, and it may disturb some mechanism the maintainer applies to the sources. For these reasons, this option is generally discouraged.

gnulib-tool will overwrite any pre-existing files, in particular Makefile.am. It is also possible to separate the generated Makefile.am content (for building the gnulib library) into a separate file, say gnulib.mk, that can be included by your handwritten Makefile.am, but this is a more advanced use of gnulib-tool.

Consequently, it is a good idea to choose directories that are not already used by your projects, to separate gnulib imported files from your own files. This approach is also useful if you want to avoid conflicts between other tools (e.g., gettextize that also copy M4 files into your package. Simon Josefsson successfully uses a source base of gl/, and a M4 base of gl/m4/, in several packages.

After the `--import' option on the command line comes the list of Gnulib modules that you want to incorporate in your package. The names of the modules coincide with the filenames in Gnulib's modules/ directory.

Some Gnulib modules depend on other Gnulib modules. gnulib-tool will automatically add the needed modules as well; you need not list them explicitly. gnulib-tool will also memorize which dependent modules it has added, so that when someday a dependency is dropped, the implicitly added module is dropped as well (unless you have explicitly requested that module).

If you want to cut a dependency, i.e., not add a module although one of your requested modules depends on it, you may use the option `--avoid=module' to do so. Multiple uses of this option are possible. Of course, you will then need to implement the same interface as the removed module.

A few manual steps are required to finish the initial import. gnulib-tool printed a summary of these steps.

First, you must ensure Autoconf can find the macro definitions in gnulib-comp.m4. Use the ACLOCAL_AMFLAGS specifier in your top-level Makefile.am file, as in:

ACLOCAL_AMFLAGS = -I m4
You are now ready to call the M4 macros in gnulib-comp.m4 from configure.ac. The macro gl_EARLY must be called as soon as possible after verifying that the C compiler is working. Typically, this is immediately after AC_PROG_CC, as in:

...
AC_PROG_CC
gl_EARLY
...
If you are using AC_PROG_CC_STDC, the macro gl_EARLY must be called after it, like this:

...
AC_PROG_CC
AC_PROG_CC_STDC
gl_EARLY
...
The core part of the gnulib checks are done by the macro gl_INIT. Place it further down in the file, typically where you normally check for header files or functions. It must come after other checks which may affect the compiler invocation, such as AC_MINIX. For example:

...
# For gnulib.
gl_INIT
...
gl_INIT will in turn call the macros related with the gnulib functions, be it specific gnulib macros, like gl_FUNC_ALLOCA or Autoconf or Automake macros like AC_FUNC_ALLOCA or AM_FUNC_GETLINE. So there is no need to call those macros yourself when you use the corresponding gnulib modules.

You must also make sure that the gnulib library is built. Add the Makefile in the gnulib source base directory to AC_CONFIG_FILES, as in:

AC_CONFIG_FILES(... lib/Makefile ...)
You must also make sure that make will recurse into the gnulib directory. To achieve this, add the gnulib source base directory to a SUBDIRS Makefile.am statement, as in:

SUBDIRS = lib
or if you, more likely, already have a few entries in SUBDIRS, you can add something like:

SUBDIRS += lib
Finally, you have to add compiler and linker flags in the appropriate source directories, so that you can make use of the gnulib library. Since some modules (`getopt', for example) may copy files into the build directory, top_builddir/lib is needed as well as top_srcdir/lib. For example:

...
AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
...
LDADD = lib/libgnu.a
...
Don't forget to #include the various header files. In this example, you would need to make sure that `#include <string.h>' is evaluated when compiling all source code files, that want to make use of strdup.

In the usual case where Autoconf is creating a config.h file, you should include config.h first, before any other include file. That way, for example, if config.h defines `restrict' to be the empty string on a non-C99 host, or a macro like `_FILE_OFFSET_BITS' that affects the layout of data structures, the definition is consistent for all include files. Also, on some platforms macros like `_FILE_OFFSET_BITS' and `_GNU_SOURCE' may be ineffective, or may have only a limited effect, if defined after the first system header file is included.

Finally, note that you cannot use AC_LIBOBJ or AC_REPLACE_FUNCS in your configure.ac and expect the resulting object files to be automatically added to lib/libgnu.a. This is because your AC_LIBOBJ and AC_REPLACE_FUNCS invocations from configure.ac augment a variable @LIBOBJS@ (and/or @LTLIBOBJS@ if using Libtool), whereas lib/libgnu.a is built from the contents of a different variable, usually @gl_LIBOBJS@ (or @gl_LTLIBOBJS@ if using Libtool).

Next: Modified imports Prev: Which modules? Up: Invoking gnulib-tool Top: Top


Modified imports -- GNU Gnulib

Next: Simple update Prev: Initial import Up: Invoking gnulib-tool Top: Top

3.3. Modified imports

You can at any moment decide to use Gnulib differently than the last time.

There are two ways to change how Gnulib is used. Which one you'll use, depends on where you keep track of options and module names that you pass to gnulib-tool.

  • If you store the options and module names in a file under your own control, such as autogen.sh, bootstrap, bootstrap.conf, or similar, simply invoke @command{gnulib-tool} again, with modified options and more or fewer module names.

  • gnulib-tool remembers which modules were used last time. If you want to rely on gnulib-tool's own memory of the last used options and module names, you can use the commands @command{gnulib-tool --add-import} and @command{gnulib-tool --remove-import}.

    So, if you only want to use more Gnulib modules, simply invoke @command{gnulib-tool --add-import new-modules}. The list of modules that you pass after `--add-import' is added to the previous list of modules.

    Similarly, if you want to use fewer Gnulib modules, simply invoke @command{gnulib-tool --remove-import unneeded-modules}. The list of modules that you pass after `--remove-import' is removed from the previous list of modules. Note that if a module is then still needed as dependency of other modules, it will be used nevertheless. If you want to really not use a module any more, regardless of whether other modules may need it, you need to use the `--avoid' option.

    For other changes, such as different choices of `--lib', `--source-base' or `--aux-dir', the normal way is to modify manually the file gnulib-cache.m4 in the M4 macros directory, then launch `gnulib-tool --add-import'.

    The only change for which this doesn't work is a change of the `--m4-base' directory. Because, when you pass a different value of `--m4-base', gnulib-tool will not find the previous gnulib-cache.m4 file any more. A possible solution is to manually copy the gnulib-cache.m4 into the new M4 macro directory.

    In the gnulib-cache.m4 file, the macros have the following meaning:

    gl_MODULES
    The argument is a space separated list of the requested modules, not including dependencies.

    gl_AVOID
    The argument is a space separated list of modules that should not be used, even if they occur as dependencies. Corresponds to the `--avoid' command line argument.

    gl_SOURCE_BASE
    The argument is the relative file name of the directory containing the gnulib source files (mostly *.c and *.h files). Corresponds to the `--source-base' command line argument.

    gl_M4_BASE
    The argument is the relative file name of the directory containing the gnulib M4 macros (*.m4 files). Corresponds to the `--m4-base' command line argument.

    gl_TESTS_BASE
    The argument is the relative file name of the directory containing the gnulib unit test files. Corresponds to the `--tests-base' command line argument.

    gl_LIB
    The argument is the name of the library to be created. Corresponds to the `--lib' command line argument.

    gl_LGPL
    The presence of this macro without arguments corresponds to the `--lgpl' command line argument. The presence of this macro with an argument (whose value must be 2 or 3) corresponds to the `--lgpl=arg' command line argument.

    gl_LIBTOOL
    The presence of this macro corresponds to the `--libtool' command line argument and to the absence of the `--no-libtool' command line argument. It takes no arguments.

    gl_MACRO_PREFIX
    The argument is the prefix to use for macros in the gnulib-comp.m4 file. Corresponds to the `--macro-prefix' command line argument.

Next: Simple update Prev: Initial import Up: Invoking gnulib-tool Top: Top


Simple update -- GNU Gnulib

Next: Source changes Prev: Modified imports Up: Invoking gnulib-tool Top: Top

3.4. Simple update

When you want to update to a more recent version of Gnulib, without changing the list of modules or other parameters, a simple call does it:

$ gnulib-tool --add-import
This will create, update or remove files, as needed.

Note: From time to time, changes are made in Gnulib that are not backward compatible. When updating to a more recent Gnulib, you should consult Gnulib's NEWS file to check whether the incompatible changes affect your project.

Next: Source changes Prev: Modified imports Up: Invoking gnulib-tool Top: Top


Source changes -- GNU Gnulib

Next: Multiple instances Prev: Simple update Up: Invoking gnulib-tool Top: Top

3.5. Changing your sources for use with Gnulib

Gnulib contains some header file overrides. This means that when building on systems with deficient header files in /usr/include/, it may create files named string.h, stdlib.h, stdint.h or similar in the build directory. In the other source directories of your package you will usually pass `-I' options to the compiler, so that these Gnulib substitutes are visible and take precedence over the files in /usr/include/.

These Gnulib substitute header files rely on <config.h> being already included. Furthermore <config.h> must be the first include in every compilation unit. This means that to all your source files and likely also to all your tests source files you need to add an `#include <config.h>' at the top. Which source files are affected? Exactly those whose compilation includes a `-I' option that refers to the Gnulib library directory.

This is annoying, but inevitable: On many systems, <config.h> is used to set system dependent flags (such as _GNU_SOURCE on GNU systems), and these flags have no effect after any system header file has been included.

Next: Multiple instances Prev: Simple update Up: Invoking gnulib-tool Top: Top


Multiple instances -- GNU Gnulib

Next: gettextize and autopoint Prev: Source changes Up: Invoking gnulib-tool Top: Top

3.6. Using Gnulib for both a library and a binary

Your project might build both a library and some accompanying binaries in the same source tree. In that case you might want to use different modules for the library than for the binaries. Typically the binaries might want to make use of getopt-posix or version-etc, while the library wants to stay clear of these modules for technical or licensing reasons.

Let's assume that your project contains a lib directory where the source of the library resides and a src directory for the sources of the binaries as follows.

.
|-- configure.ac
|-- lib
|   |-- foo.c
|   `-- Makefile.am
|-- Makefile.am
`-- src
    |-- bar.c
    `-- Makefile.am
You can now add two instances of Gnulib to your project in separate source trees:

~/src/libfoo$ gnulib-tool --import --lib=libgnu --source-base=gnulib \
              --m4-base=gnulib/m4 --macro-prefix=gl strndup
~/src/libfoo$ gnulib-tool --import --lib=libgnutools \
              --source-base=src/gnulib --m4-base=src/gnulib/m4 \
              --macro-prefix=gl_tools getopt-gnu
The first one will import the module strndup in gnulib and the second one will import getopt-gnu in src/gnulib and you will end up with the following source tree (many files omitted in the interest of brevity):

.
|-- configure.ac
|-- gnulib
|   |-- m4
|   |-- strndup.c
|-- lib
|   |-- foo.c
|   `-- Makefile.am
|-- Makefile.am
`-- src
    |-- bar.c
    |-- gnulib
    |   |-- getopt.c
    |   |-- getopt.in.h
    |   |-- m4
    `-- Makefile.am
Integration with your code is basically the same as outlined in Initial import with the one exception that you have to add both the macro gl_EARLY and the macro gl_tools_EARLY to your configure.ac (and of course also both macros gl_INIT and gl_tools_INIT). Obviously the name of the second macro is dependent on the value of the @option{--macro-prefix} option in your @command{gnulib-tool} invocation.

...
AC_PROG_CC
gl_EARLY
gl_tools_EARLY
...
# For gnulib.
gl_INIT
gl_tools_INIT
...
Also as outlined in Initial import you will have to add compiler and linker flags. For the library you might have to add something along the line of the following to your Makefile.am:

...
AM_CPPFLAGS = -I$(top_srcdir)/gnulib -I$(top_builddir)/gnulib
...
libfoo_la_LIBADD = $(top_builddir)/gnulib/libgnu.la
...
Correspondingly for the binary you will have to add something along the lines of to the following:

...
AM_CPPFLAGS = -I$(top_srcdir)/src/gnulib -I$(top_builddir)/src/gnulib
...
LIBADD = $(top_builddir)/src/gnulib/libgnutools.la
...
The name of the library that you have pass in the linker option depends on the @option{--lib} option in @command{gnulib-tool} invocation.

Next: gettextize and autopoint Prev: Source changes Up: Invoking gnulib-tool Top: Top


gettextize and autopoint -- GNU Gnulib

Next: Localization Prev: Multiple instances Up: Invoking gnulib-tool Top: Top

3.7. Caveat: gettextize and autopoint users

The programs gettextize and autopoint, part of GNU gettext, import or update the internationalization infrastructure. Some of this infrastructure, namely ca. 20 Autoconf macro files and the config.rpath file, is also contained in Gnulib and may be imported by gnulib-tool. The use of gettextize or autopoint will therefore overwrite some of the files that gnulib-tool has imported, and vice versa.

Avoiding to use gettextize (manually, as package maintainer) or autopoint (as part of a script like autoreconf or autogen.sh) is not the solution: These programs also import the infrastructure in the po/ and optionally in the intl/ directory.

The copies of the conflicting files in Gnulib are more up-to-date than the copies brought in by gettextize and autopoint. When a new gettext release is made, the copies of the files in Gnulib will be updated immediately.

The choice of which version of gettext to require depends on the needs of your package. For a package that wants to comply to GNU Coding Standards, the steps are:

  1. When you run gettextize, always use the gettextize from the matching GNU gettext release. For the most recent Gnulib checkout, this is the newest release found on https://ftp.gnu.org/gnu/gettext/. For an older Gnulib snapshot, it is the release that was the most recent release at the time the Gnulib snapshot was taken.

  2. After running gettextize, invoke gnulib-tool and import the gettext module. Also, copy the latest version of gnulib's build-aux/po/Makefile.in.in to your po/ directory (this is done for you if you use gnulib's bootstrap script).

  3. If you get an error message like *** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version ... but the Autoconf macros are from gettext version ..., it means that a new GNU gettext release was made, and its Autoconf macros were integrated into Gnulib and now mismatch the po/ infrastructure. In this case, fetch and install the new GNU gettext release and run gettextize followed by gnulib-tool.
On the other hand, if your package is not as concerned with compliance to the latest standards, but instead favors development on stable environments, the steps are:

  1. Determine the oldest version of gettext that you intend to support during development (at this time, gnulib recommends going no older than version 0.17). Run autopoint (not gettextize) to copy infrastructure into place (newer versions of gettext will install the older infrastructure that you requested).

  2. Invoke gnulib-tool, and import the gettext-h module.
Regardless of which approach you used to get the infrastructure in place, the following steps must then be used to preserve that infrastructure (gnulib's bootstrap script follows these rules):

  1. When a script of yours run autopoint, invoke gnulib-tool afterwards.

  2. When you invoke autoreconf after gnulib-tool, make sure to not invoke autopoint a second time, by setting the AUTOPOINT environment variable, like this:
    $ env AUTOPOINT=true autoreconf --install

Next: Localization Prev: Multiple instances Up: Invoking gnulib-tool Top: Top


Localization -- GNU Gnulib

Next: VCS Issues Prev: gettextize and autopoint Up: Invoking gnulib-tool Top: Top

3.8. Handling Gnulib's own message translations

Gnulib provides some functions that emit translatable messages using GNU gettext. The `gnulib' domain at the https://translationproject.org/, Translation Project collects translations of these messages, which you should incorporate into your own programs.

There are two basic ways to achieve this. The first, and older, method is to list all the source files you use from Gnulib in your own po/POTFILES.in file. This will cause all the relevant translatable strings to be included in your POT file. When you send this POT file to the Translation Project, translators will normally fill in the translations of the Gnulib strings from their ``translation memory'', and send you back updated PO files.

However, this process is error-prone: you might forget to list some source files, or the translator might not be using a translation memory and provide a different translation than another translator, or the translation might not be kept in sync between Gnulib and your package. It is also slow and causes substantial extra work, because a human translator must be in the loop for each language and you will need to incorporate their work on request.

For these reasons, a new method was designed and is now recommended. If you pass the --po-base=directory and --po-domain=domain options to gnulib-tool, then gnulib-tool will create a separate directory with its own POTFILES.in, and fetch current translations directly from the Translation Project (using @command{rsync} or @command{wget}, whichever is available). The POT file in this directory will be called domain-gnulib.pot, depending on the domain you gave to the --po-domain option (typically the same as the package name). This causes these translations to reside in a separate message domain, so that they do not clash either with the translations for the main part of your package nor with those of other packages on the system that use possibly different versions of Gnulib. When you use these options, the functions in Gnulib are built in such a way that they will always use this domain regardless of the default domain set by textdomain.

In order to use this method, you must---in each program that might use Gnulib code---add an extra line to the part of the program that initializes locale-dependent behavior. Where you would normally write something like:

  setlocale (LC_ALL, "");
  bindtextdomain (PACKAGE, LOCALEDIR);
  textdomain (PACKAGE);
you should add an additional bindtextdomain call to inform gettext of where the MO files for the extra message domain may be found:

  bindtextdomain (PACKAGE "-gnulib", LOCALEDIR);
(This example assumes that the domain that you specified to gnulib-tool is the same as the value of the PACKAGE preprocessor macro.)

Since you do not change the textdomain call, the default message domain for your program remains the same and your own use of gettext functions will not be affected.

Next: VCS Issues Prev: gettextize and autopoint Up: Invoking gnulib-tool Top: Top


VCS Issues -- GNU Gnulib

Next: Unit tests Prev: Localization Up: Invoking gnulib-tool Top: Top

3.9. Issues with Version Control Systems

If a project stores its source files in a version control system (VCS), such as CVS, Subversion, or Git, one needs to decide which files to commit.

In principle, all files created by gnulib-tool, except gnulib-cache.m4, can be treated like generated source files, like for example a parser.c file generated from parser.y. Alternatively, they can be considered source files and updated manually.

Here are the three different approaches in common use. Each has its place, and you should use whichever best suits your particular project and development methods.

  1. In projects which commit all source files, whether generated or not, into their VCS, the gnulib-tool generated files should all be committed. In this case, you should pass the option `--no-vc-files' to gnulib-tool, which avoids alteration of VCS-related files such as .gitignore.

    Gnulib also contains files generated by @command{make} (and removed by make clean), using information determined by @command{configure}. For a Gnulib source file of the form lib/foo.in.h, the corresponding lib/foo.h is such a @command{make}-generated file. These should not be checked into the VCS, but instead added to .gitignore or equivalent.

  2. In projects which customarily omit from their VCS all files that are generated from other source files, none of these files and directories are added into the VCS. As described in Modified imports, there are two ways to keep track of options and module names that are passed to gnulib-tool. The command for restoring the omitted files depends on it:

    • If they are stored in a file other than gnulib-cache.m4, such as autogen.sh, bootstrap, bootstrap.conf, or similar, the restoration command is the entire gnulib-tool ... --import ... invocation with all options and module names.

    • If the project relies on gnulib-tool's memory of the last used options and module names, then the file gnulib-cache.m4 in the M4 macros directory must be added to the VCS, and the restoration command is:

      $ gnulib-tool --update
      The `--update' option operates much like the `--add-import' option, but it does not offer the possibility to change the way Gnulib is used. Also it does not report in the ChangeLogs the files that it had to add because they were missing.

    Gnulib includes the file build-aux/bootstrap to aid a developer in using this setup. Furthermore, in projects that use git for version control, it is possible to use a git submodule containing the precise commit of the gnulib repository, so that each developer running bootstrap will get the same version of all gnulib-provided files. The location of the submodule can be chosen to fit the package's needs; here's how to initially create the submodule in the directory .gnulib:

    $ dir=.gnulib
$ git submodule add -- git://git.sv.gnu.org/gnulib.git $dir
$ git config alias.syncsub "submodule foreach git pull origin master"
    Thereafter, bootstrap can run this command to update the submodule to the recorded checkout level:

    git submodule update --init $dir
    and a developer can use this sequence to update to a newer version of gnulib:

    $ git syncsub
$ git add $dir
$ ./bootstrap
  3. Some projects take a ``middle road'': they do commit Gnulib source files as in the first approach, but they do not commit other derived files, such as a Makefile.in generated by Automake. This increases the size and complexity of the repository, but can help occasional contributors by not requiring them to have a full Gnulib checkout to do a build, and all developers by ensuring that all developers are working with the same version of Gnulib in the repository. It also supports multiple Gnulib instances within a project. It remains important not to commit the @command{make}-generated files, as described above.

Next: Unit tests Prev: Localization Up: Invoking gnulib-tool Top: Top


Unit tests -- GNU Gnulib

Next: Conditional dependencies Prev: VCS Issues Up: Invoking gnulib-tool Top: Top

3.10. Bundling the unit tests of the Gnulib modules

You can bundle the unit tests of the Gnulib modules together with your package, through the `--with-tests' option. Together with `--with-tests', you also specify the directory for these tests through the `--tests-base' option. Of course, you need to add this directory to the SUBDIRS variable in the Makefile.am of the parent directory.

The advantage of having the unit tests bundled is that when your program has a problem on a particular platform, running the unit tests may help determine quickly if the problem is on Gnulib's side or on your package's side. Also, it helps verifying Gnulib's portability, of course.

The unit tests will be compiled and run when the user runs `make check'. When the user runs only `make', the unit tests will not be compiled.

In the SUBDIRS variable, it is useful to put the Gnulib tests directory after the directory containing the other tests, not before:

SUBDIRS = gnulib-lib src man tests gnulib-tests
This will ensure that on platforms where there are test failures in either directory, users will see and report the failures from the tests of your program.

Note: In packages which use more than one invocation of gnulib-tool in the scope of the same configure.ac, you cannot use `--with-tests'. You will have to use a separate configure.ac in this case.

Next: Conditional dependencies Prev: VCS Issues Up: Invoking gnulib-tool Top: Top


Conditional dependencies -- GNU Gnulib

Prev: Unit tests Up: Invoking gnulib-tool Top: Top

3.11. Avoiding unnecessary checks and compilations

In some cases, a module is needed by another module only on specific platforms. But when a module is present, its Autoconf checks are always executed, and its Makefile.am additions are always enabled. So it can happen that some Autoconf checks are executed and some source files are compiled, although no other module needs them on this particular platform, just in case some other module would need them.

The option `--conditional-dependencies' enables an optimization of configure checks and Makefile.am snippets that avoids this. With this option, whether a module is considered ``present'' is no longer decided when gnulib-tool is invoked, but later, when configure is run. This applies to modules that were added as dependencies while gnulib-tool was run; modules that were passed on the command line explicitly are always ``present''.

For example, the timegm module needs, on platforms where the system's timegm function is missing or buggy, a replacement that is based on a function mktime_internal. The module mktime-internal that provides this function provides it on all platforms. So, by default, the file mktime-internal.c will be compiled on all platforms, even on glibc and BSD systems which have a working timegm function. When the option `--conditional-dependencies' is given, on the other hand, and if mktime-internal was not explicitly required on the command line, the file mktime-internal.c will only be compiled on the platforms where the timegm needs them.

Conditional dependencies are specified in the module description by putting the condition on the same line as the dependent module, enclosed in brackets. The condition is a boolean shell expression that can assume that the configure.ac snippet from the module description has already been executed. In the example above, the dependency from timegm to mktime-internal is written like this:

Depends-on:
...
mktime-internal [test $HAVE_TIMEGM = 0 || test $REPLACE_TIMEGM = 1]
...
Note: The option `--conditional-dependencies' cannot be used together with the option `--with-tests'. It also cannot be used when a package uses gnulib-tool for several subdirectories, with different values of `--source-base', in the scope of a single configure.ac file.

Prev: Unit tests Up: Invoking gnulib-tool Top: Top


Writing modules -- GNU Gnulib

Next: Extending Gnulib Prev: Invoking gnulib-tool Top: Top

4. Writing modules

This chapter explains how to write modules of your own, either to extend Gnulib for your own package (see Extending Gnulib), or for inclusion in gnulib proper.

The guidelines in this chapter do not necessarily need to be followed for using gnulib-tool. They merely represent a set of good practices. Following them will result in a good structure of your modules and in consistency with gnulib.

Menu

  • Source code files
  • Header files
  • Implementation files
  • Specification
  • Module description
  • Autoconf macros
  • Unit test modules
  • Incompatible changes

    • Next: Extending Gnulib Prev: Invoking gnulib-tool Top: Top


Source code files -- GNU Gnulib

Next: Header files Up: Writing modules Top: Top

4.1. Source code files

Every API (C functions or variables) provided should be declared in a header file (.h file) and implemented in one or more implementation files (.c files). The separation has the effect that users of your module need to read only the contents of the .h file and the module description in order to understand what the module is about and how to use it---not the entire implementation. Furthermore, users of your module don't need to repeat the declarations of the functions in their code, and are likely to receive notification through compiler errors if you make incompatible changes to the API (like, adding a parameter or changing the return type of a function).

Next: Header files Up: Writing modules Top: Top


Header files -- GNU Gnulib

Next: Implementation files Prev: Source code files Up: Writing modules Top: Top

4.2. Header files

The .h file should declare the C functions and variables that the module provides.

The .h file should be stand-alone. That is, it does not require other .h files to be included before. Rather, it includes all necessary .h files by itself.

It is a tradition to use CPP tricks to avoid parsing the same header file more than once, which might cause warnings. The trick is to wrap the content of the header file (say, foo.h) in a block, as in:

#ifndef FOO_H
# define FOO_H
...
body of header file goes here
...
#endif /* FOO_H */
Whether to use FOO_H or _FOO_H is a matter of taste and style. The C99 and C11 standards reserve all identifiers that begin with an underscore and either an uppercase letter or another underscore, for any use. Thus, in theory, an application might not safely assume that _FOO_H has not already been defined by a library. On the other hand, using FOO_H will likely lead the higher risk of collisions with other symbols (e.g., KEY_H, XK_H, BPF_H, which are CPP macro constants, or COFF_LONG_H, which is a CPP macro function). Your preference may depend on whether you consider the header file under discussion as part of the application (which has its own namespace for CPP symbols) or a supporting library (that shouldn't interfere with the application's CPP symbol namespace).

Adapting C header files for use in C++ applications can use another CPP trick, as in:

# ifdef __cplusplus
extern "C"
{
# endif
...
body of header file goes here
...
# ifdef __cplusplus
}
# endif
The idea here is that __cplusplus is defined only by C++ implementations, which will wrap the header file in an `extern "C"' block. Again, whether to use this trick is a matter of taste and style. While the above can be seen as harmless, it could be argued that the header file is written in C, and any C++ application using it should explicitly use the `extern "C"' block itself. Your preference might depend on whether you consider the API exported by your header file as something available for C programs only, or for C and C++ programs alike.

Note that putting a #include in an extern "C" { ... } block yields a syntax error in C++ mode on some platforms (e.g., glibc systems with g++ v3.3 to v4.2, AIX, OSF/1, IRIX). For this reason, it is recommended to place the #include before the extern "C" block.

Next: Implementation files Prev: Source code files Up: Writing modules Top: Top


Implementation files -- GNU Gnulib

Next: Specification Prev: Header files Up: Writing modules Top: Top

4.3. Implementation files

The .c file or files implement the functions and variables declared in the .h file.

Include ordering

Every implementation file must start with `#include <config.h>'. This is necessary for activating the preprocessor macros that are defined on behalf of the Autoconf macros. Some of these preprocessor macros, such as _GNU_SOURCE, would have no effect if defined after a system header file has already been included.

Then comes the `#include "..."' specifying the header file that is being implemented. Putting this right after `#include <config.h>' has the effect that it verifies that the header file is self-contained.

Then come the system and application headers. It is customary to put all the system headers before all application headers, so as to minimize the risk that a preprocessor macro defined in an application header confuses the system headers on some platforms.

In summary:

  • First comes #include <config.h>.
  • Second comes the #include "..." specifying the module being implemented.
  • Then come all the #include <...> of system or system-replacement headers, in arbitrary order.
  • Then come all the #include "..." of gnulib and application headers, in arbitrary order.

Next: Specification Prev: Header files Up: Writing modules Top: Top


Specification -- GNU Gnulib

Next: Module description Prev: Implementation files Up: Writing modules Top: Top

4.4. Specification

The specification of a function should answer at least the following questions:
  • What is the purpose of the function?
  • What are the arguments?
  • What is the return value?
  • What happens in case of failure? (Exit? A specific return value? Errno set?)
  • Memory allocation policy: If pointers to memory are returned, are they freshly allocated and supposed to be freed by the caller?
Where to put the specification describing exported functions? Three practices are used in gnulib:

  • The specification can be as comments in the header file, just above the function declaration.
  • The specification can be as comments in the implementation file, just above the function definition.
  • The specification can be in texinfo format, so that it gets included in the gnulib manual.
In any case, the specification should appear in just one place, unless you can ensure that the multiple copies will always remain identical.

The advantage of putting it in the header file is that the user only has to read the include file normally never needs to peek into the implementation file(s).

The advantage of putting it in the implementation file is that when reviewing or changing the implementation, you have both elements side by side.

The advantage of texinfo formatted documentation is that it is easily published in HTML or Info format.

Currently (as of 2010), half of gnulib uses the first practice, nearly half of gnulib uses the second practice, and a small minority uses the texinfo practice.

Next: Module description Prev: Implementation files Up: Writing modules Top: Top


Module description -- GNU Gnulib

Next: Autoconf macros Prev: Specification Up: Writing modules Top: Top

4.5. Module description

For the module description, you can start from an existing module's description, or from a blank one: module/TEMPLATE for a normal module, or module/TEMPLATE-TESTS for a unit test module. Some more fields are possible but rarely used. Use module/TEMPLATE-EXTENDED if you want to use one of them.

Module descriptions have the following fields. Absent fields are equivalent to fields with empty contents.

Description
This field should contain a concise description of the module's functionality. One sentence is enough. For example, if it defines a single function `frob', the description can be `frob() function: frobnication.' Gnulib's documentation generator will automatically convert the first part to a hyperlink when it has this form.

Status
This field is either empty/absent, or contains the word `obsolete'. In the latter case, @command{gnulib-tool} will, unless the option --with-obsolete is given, omit it when it used as a dependency. It is good practice to also notify the user about an obsolete module. This is done by putting into the `Notice' section (see below) text like `This module is obsolete.'

Notice
This field contains text that @command{gnulib-tool} will show to the user when the module is used. This can be a status indicator like `This module is obsolete.' or additional advice. Do not abuse this field.

Applicability
This field is either empty/absent, or contains the word `all'. It describes to which Makefile.am the module is applied. By default, a normal module is applied to source_base/Makefile.am (normally lib/Makefile.am), whereas a module ending in -tests is applied to tests_base/Makefile.am (normally tests/Makefile.am). If this field is `all', it is applied to both Makefile.ams. This is useful for modules which provide Makefile.am macros rather than compiled source code.

Files
This field contains a newline separated list of the files that are part of the module. gnulib-tool copies these files into the package that uses the module.

This list is typically ordered by importance: First comes the header file, then the implementation files, then other files.

It is possible to have the same file mentioned in multiple modules. That is, if the maintainers of that module agree on the purpose and future of said file.

Depends-on
This field contains a newline separated list of the modules that are required for the proper working of this module. gnulib-tool includes each required module automatically, unless it is specified with option --avoid or it is marked as obsolete and the option --with-obsolete is not given.

A test modules foo-tests implicitly depends on the corresponding non-test module foo. foo implicitly depends on foo-tests if the latter exists and if the option --with-tests has been given.

Tests modules can depend on non-tests modules. Non-tests modules should not depend on tests modules. (Recall that tests modules are built in a separate directory.)

Each listed required module may be declared a conditional dependency. This is indicated by placing the condition for the dependency on the same line, enclosed in brackets, after the name of the required module. The condition is a shell expression that is run after the module's configure.ac statements. For example:

strtoull   [test $ac_cv_func_strtoumax = no]
Lines starting with # are recognized as comments and are ignored.

configure.ac-early
This field contains configure.ac stuff (Autoconf macro invocations and shell statements) that are logically placed early in the configure.ac file: right after the AC_PROG_CC invocation. This section is adequate for statements that modify CPPFLAGS, as these can affect the results of other Autoconf macros.

configure.ac
This field contains configure.ac stuff (Autoconf macro invocations and shell statements).

It is forbidden to add items to the CPPFLAGS variable here, other than temporarily, as these could affect the results of other Autoconf macros.

We avoid adding items to the LIBS variable, other than temporarily. Instead, the module can export an Autoconf-substituted variable that contains link options. The user of the module can then decide to which executables to apply which link options. Recall that a package can build executables of different kinds and purposes; having all executables link against all libraries is inappropriate.

If the statements in this section grow larger than a couple of lines, we recommend moving them to a .m4 file of their own.

Makefile.am
This field contains Makefile.am statements. Variables like lib_SOURCES are transformed to match the name of the library being built in that directory. For example, lib_SOURCES may become libgnu_a_SOURCES (for a plain library) or libgnu_la_SOURCES (for a libtool library). Therefore, the normal way of having an implementation file lib/foo.c compiled unconditionally is to write
lib_SOURCES += foo.c
Include
This field contains the preprocessor statements that users of the module need to add to their source code files. Typically it's a single include statement. A shorthand is allowed: You don't need to write the word ``#include'', just the name of the include file in the way it will appear in an include statement. Example:
"foo.h"
Link
This field contains the set of libraries that are needed when linking libraries or executables that use this module. Often this will be written as a reference to a Makefile variable. Please write them one per line, so that @command{gnulib-tool} can remove duplicates when presenting a summary to the user. Example:
$(POW_LIBM)
$(LTLIBICONV) when linking with libtool, $(LIBICONV) otherwise
License
This field specifies the license that governs the source code parts of this module. See Copyright for details.

Maintainer
This field specifies the persons who have a definitive say about proposed changes to this module. You don't need to mention email addresses here: they can be inferred from the ChangeLog file.

Please put at least one person here. We don't like unmaintained modules.

Next: Autoconf macros Prev: Specification Up: Writing modules Top: Top


Autoconf macros -- GNU Gnulib

Next: Unit test modules Prev: Module description Up: Writing modules Top: Top

4.6. Autoconf macros

For a module foo, an Autoconf macro file m4/foo.m4 is typically created when the Autoconf macro invocations for the module are longer than one or two lines.

The name of the main entry point into this Autoconf macro file is typically gl_FOO. For modules outside Gnulib that are not likely to be moved into Gnulib, please use a prefix specific to your package: gt_ for GNU gettext, cu_ for GNU coreutils, etc.

For modules that define a function foo, the entry point is called gl_FUNC_FOO instead of gl_FOO. For modules that provide a header file with multiple functions, say foo.h, the entry point is called gl_FOO_H or gl_HEADER_FOO_H. This convention is useful because sometimes a header and a function name coincide (for example, fcntl and fcntl.h).

For modules that provide a replacement, it is useful to split the Autoconf macro into two macro definitions: one that detects whether the replacement is needed and requests the replacement using AC_LIBOBJ (this is the entry point, say gl_FUNC_FOO), and one that arranges for the macros needed by the replacement code lib/foo.c (typically called gl_PREREQ_FOO). The reason of this separation is

  1. to make it easy to update the Autoconf macros when you have modified the source code file: after changing lib/foo.c, all you have to review is the Depends-on section of the module description and the gl_PREREQ_FOO macro in the Autoconf macro file.
  2. The Autoconf macros are often large enough that splitting them eases maintenance.

Next: Unit test modules Prev: Module description Up: Writing modules Top: Top


Unit test modules -- GNU Gnulib

Next: Incompatible changes Prev: Autoconf macros Up: Writing modules Top: Top

4.7. Unit test modules

A unit test that is a simple C program usually has a module description as simple as this:

Files:
tests/test-foo.c
tests/macros.h

Depends-on:

configure.ac:

Makefile.am:
TESTS += test-foo
check_PROGRAMS += test-foo
The test program tests/test-foo.c often has the following structure:

  • First comes the obligatory `#include <config.h>'.

  • Second comes the include of the header file that declares the API being tested. Including it here verifies that said header file is self-contained.

  • Then come other includes. In particular, the file macros.h is often used here. It contains a convenient ASSERT macro.
The body of the test, then, contains many ASSERT invocations. When a test fails, the ASSERT macro prints the line number of the failing statement, thus giving you, the developer, an idea of which part of the test failed, even when you don't have access to the machine where the test failed and the reporting user cannot run a debugger.

Sometimes it is convenient to write part of the test as a shell script. (For example, in areas related to process control or interprocess communication, or when different locales should be tried.) In these cases, the typical module description is like this:

Files:
tests/test-foo.sh
tests/test-foo.c
tests/macros.h

Depends-on:

configure.ac:

Makefile.am:
TESTS += test-foo.sh
TESTS_ENVIRONMENT += FOO_BAR='@FOO_BAR@'
check_PROGRAMS += test-foo
Here, the TESTS_ENVIRONMENT variable can be used to pass values determined by configure or by the Makefile to the shell script, as environment variables. The Autoconf values EXEEXT and srcdir are already provided as environment variables, through an initial value of TESTS_ENVIRONMENT that gnulib-tool puts in place.

Regardless of the specific form of the unit test, the following guidelines should be respected:

  • A test indicates success by exiting with exit code 0. It should normally not produce output in this case. (Output to temporary files that are cleaned up at the end of the test are possible, of course.)
  • A test indicates failure by exiting with an exit code different from 0 and 77, typically 1. It is useful to print a message about the failure in this case. The ASSERT macro already does so.
  • A test indicates "skip", that is, that most of its interesting functionality could not be performed, through a return code of 77. A test should also print a message to stdout or stderr about the reason for skipping. For example:
      fputs ("Skipping test: multithreading not enabled\n", stderr);
  return 77;
    Such a message helps detecting bugs in the autoconf macros: A simple message `SKIP: test-foo' does not sufficiently catch the attention of the user.

Next: Incompatible changes Prev: Autoconf macros Up: Writing modules Top: Top


Incompatible changes -- GNU Gnulib

Prev: Unit test modules Up: Writing modules Top: Top

4.8. Incompatible changes

Incompatible changes to Gnulib modules should be mentioned in Gnulib's NEWS file. Incompatible changes here mean that existing source code may not compile or work any more.

We don't mean changes in the binary interface (ABI), since

  1. Gnulib code is used in source-code form.
  2. The user who distributes libraries that contain Gnulib code is supposed to bump the version number in the way described in the Libtool documentation before every release.

Prev: Unit test modules Up: Writing modules Top: Top


Extending Gnulib -- GNU Gnulib

Next: Miscellaneous Notes Prev: Writing modules Top: Top

5. Extending Gnulib

Gnulib modules are intended to be suitable for widespread use. Most problems with Gnulib can and should be fixed in a generic way, so that all of Gnulib's users can benefit from the change. But occasionally a problem arises that is difficult or undesirable to fix generically, or a project that uses Gnulib may need to work around an issue before the Gnulib maintainers commit a final fix. Maintainers may also want to add their own pools of modules to projects as Gnulib ``staging areas.''

The obvious way to make local changes to Gnulib modules is to use @command{gnulib-tool} to check out pristine modules, then to modify the results in-place. This works well enough for short-lived experiments. It is harder to keep modified versions of Gnulib modules for a long time, even though Git (or another distributed version control systems) can help out a lot with this during the development process.

Git, however, doesn't address the distribution issue. When a package ``foobar'' needs a modified version of, say, stdint.in.h, it either has to put a comment into foobar/autogen.sh saying ``Attention! This doesn't work with a pristine Gnulib, you need this and that patch after checking out Gnulib,'' or it has to use the `--avoid=stdint' option and provide the modified stdint module in a different directory.

The @option{--local-dir} option to @command{gnulib-tool} solves this problem. It allows the package to override or augment Gnulib. This means:

  • You can store files that are to override Gnulib files or modules.

  • You can store context diffs to be applied to Gnulib files.

  • You can add modules of your own, that are not (yet) in Gnulib.

  • You can also add unstructured amounts of code to the library, by grouping the non-Gnulib files of the library in a single kitchen-sink ``module.'' (This kind of kitchen-sink module is not needed when you use the @command{gnulib-tool} option `--makefile-name'.)
In a release tarball, you can distribute the contents of this @option{--local-dir} directory that will be combinable with newer versions of Gnulib, barring incompatible changes to Gnulib.

If the `--local-dir=directory' option is specified, then @command{gnulib-tool} looks in directory whenever it reads a file from the Gnulib directory. Suppose @command{gnulib-tool} is looking for file. Then:

  • If directory/file exists, then `gnulib-tool' uses it instead of the file included in Gnulib.

  • Otherwise, if directory/file.diff exists, then @command{gnulib-tool} uses the file from Gnulib after applying the diff using the @command{patch} program.

  • Otherwise, @command{gnulib-tool} uses the file included in Gnulib.
Please make wise use of this option. It also allows you to easily hold back modifications you make to Gnulib macros in cases it may be better to share them.

Next: Miscellaneous Notes Prev: Writing modules Top: Top


Miscellaneous Notes -- GNU Gnulib

Next: POSIX Substitutes Library Prev: Extending Gnulib Top: Top

6. Miscellaneous Notes

Menu

  • Out of memory handling
  • Obsolete modules
  • Extra tests modules
  • Modules that modify the way other modules work
  • A C++ namespace for gnulib A different way of using Gnulib in C++
  • Running self-tests under valgrind
  • License Texinfo sources
  • Building gnulib


Out of memory handling -- GNU Gnulib

Next: Obsolete modules Up: Miscellaneous Notes Top: Top

6.1. Out of memory handling

The gnulib API does not have a standard error code for the out of memory error condition. Instead of adding a non-standard error code, gnulib has chosen to adopt a different strategy. Out of memory handling happens in rare situations, but performing the out of memory error handling after almost all API function invocations pollute your source code and might make it harder to spot more serious problems. The strategy chosen improves code readability and robustness.

For most applications, aborting the application with an error message when the out of memory situation occurs is the best that can be wished for. This is how the library behaves by default (using the `xalloc-die' module).

However, we realize that some applications may not want to abort execution in any situation. Gnulib supports a hook to let the application regain control and perform its own cleanups when an out of memory situation has occurred. The application can define a function (having a void prototype, i.e., no return value and no parameters) and set the library variable xalloc_die to that function. The variable should be declared as follows.

extern void (*xalloc_die) (void);
Gnulib will invoke this function if an out of memory error occurs. Note that the function should not return. Of course, care must be taken to not allocate more memory, as that will likely also fail.

Next: Obsolete modules Up: Miscellaneous Notes Top: Top


Obsolete modules -- GNU Gnulib

Next: Extra tests modules Prev: Out of memory handling Up: Miscellaneous Notes Top: Top

6.2. Obsolete modules

Modules can be marked obsolete. This means that the problems they fix don't occur any more on the platforms that are reasonable porting targets now. gnulib-tool warns when obsolete modules are mentioned on the command line, and by default ignores dependencies from modules to obsolete modules. When you pass the option --with-obsolete to gnulib-tool, dependencies to obsolete modules will be included, however, unless blocked through an --avoid option. This option is useful if your package should be portable even to very old platforms.

In order to mark a module obsolete, you need to add this to the module description:

Status:
obsolete

Notice:
This module is obsolete.

Next: Extra tests modules Prev: Out of memory handling Up: Miscellaneous Notes Top: Top


Extra tests modules -- GNU Gnulib

Next: Modules that modify the way other modules work Prev: Obsolete modules Up: Miscellaneous Notes Top: Top

6.3. Extra tests modules

Test modules can be marked with some special status attributes. When a test module has such an attribute, gnulib-tool --import will not include it by default.

The supported status attributes are:

c++-test
Indicates that the test is testing C++ interoperability. Such a test is useful in a C++ or mixed C/C++ package, but is useless in a C package.

longrunning-test
Indicates that the test takes a long time to compile or execute (more than five minutes or so). Such a test is better avoided in a release that is made for the general public.

privileged-test
Indicates that the test will request special privileges, for example, ask for the superuser password. Such a test may hang when run non-interactively and is therefore better avoided in a release that is made for the general public.

unportable-test
Indicates that the test is known to fail on some systems, and that there is no workaround about it. Such a test is better avoided in a release that is made for the general public.
gnulib-tool --import --with-tests will not include tests marked with these attributes by default. When gnulib-tool is invoked with one of the options --with-c++-tests, --with-longrunning-tests, --with-privileged-tests, --with-unportable-tests, it will include tests despite the corresponding special status attribute. When gnulib-tool receives the option --with-all-tests, it will include all tests regardless of their status attributes.

gnulib-tool --create-testdir --with-tests and gnulib-tool --create-megatestdir --with-tests by default include all tests of modules specified on the command line, regardless of their status attributes. Tests of modules occurring as dependencies are not included by default if they have one of these status attributes. The options --with-c++-tests, --with-longrunning-tests, --with-privileged-tests, --with-unportable-tests are recognized here as well. Additionally, gnulib-tool also understands the options --without-c++-tests, --without-longrunning-tests, --without-privileged-tests, --without-unportable-tests.

In order to mark a module with a status attribute, you need to add it to the module description, like this:

Status:
longrunning-test
If only a part of a test deserves a particular status attribute, you can split the module into a primary and a secondary test module, say foo-tests and foo-extra-tests. Then add a dependency from foo-tests to foo-extra-tests, and mark the foo-extra-tests with the particular status attribute.

Next: Modules that modify the way other modules work Prev: Obsolete modules Up: Miscellaneous Notes Top: Top


Modules that modify the way other modules work -- GNU Gnulib

Next: A C++ namespace for gnulib Prev: Extra tests modules Up: Miscellaneous Notes Top: Top

6.4. Modules that modify the way other modules work

The normal way to design modules is that each module has its own code, and the module dependencies provide the facilities on which this code can rely. But sometimes it is necessary to use more advanced techniques. For example:
  • You may want to have optional module dependencies: Let module A use facilities provided by module B, if module B is present, but without requiring that module B is present.
  • A module can indicate support for particular behaviours. For example, Gnulib has a module `sigpipe' that requests POSIX compatible SIGPIPE behaviour from all other modules -- something that is not enabled by default. Or consider the `nonblocking' module, that is an indicator that all I/O functions should handle non-blocking file descriptors -- something that, equally, is not enabled by default.
  • A module can indicate to other modules that they can rely on certain guarantees, and thus omit specific code. For example, when Gnulib's `malloc-gnu' module is present, you can omit code that test n against zero when you call malloc (n).
Be aware that these advanced techniques likely cause breakage in the situation of multiple gnulib-tool invocations in the scope of a single configure file. This is because the question ``is module B present?'' does not have a unique answer in such situations. gnulib-tool has support for these techniques in the situation of --create-testdir --single-configure, which basically has two gnulib-tool invocations, one for a set of modules that end up in gllib, and one for the set of modules that end up in gltests. But you should be aware that this does not cover the general situation.

Which technique to use, depends on the answer to the question: ``If my module occurs among the modules of gltests, should it have an effect on the modules in gllib?''

If the answer is ``no'', your module description should invoke the Autoconf macro gl_MODULE_INDICATOR. This Autoconf macro takes one argument: the name of your module. The effect of gl_MODULE_INDICATOR([my-module]) is to define, in config.h, a C macro GNULIB_MY_MODULE that indicates whether your macro is considered to be present. This works even when your macro is used in gltests: GNULIB_MY_MODULE will then evaluate to 1 in gltests but to 0 in gllib.

If the answer is ``yes'', you have two techniques available. The first one is to invoke a similar Autoconf macro, named gl_MODULE_INDICATOR_FOR_TESTS. It works similarly. However, when your macro is used in gltests, GNULIB_MY_MODULE will evaluate to 1 both in gltests and in gllib.

The second one is to define a shell variable in the configure file that tells whether your module is present, through use of m4_divert_text. The Autoconf macros of a dependency module will initialize this shell variable, through `m4_divert_text([DEFAULTS], [my_shell_var=no])'. The Autoconf macros of your module will override this value, through `m4_divert_text([INIT_PREPARE], [my_shell_var=yes])'. Then you can use my_shell_var in the Autoconf macros of both modules. You can find more details about this technique in the Gnulib module getopt-gnu.

Reminder: These techniques are advanced. They have the potential to cause lots of headaches if you apply them incorrectly.

Next: A C++ namespace for gnulib Prev: Extra tests modules Up: Miscellaneous Notes Top: Top


A C++ namespace for gnulib -- GNU Gnulib

Next: Running self-tests under valgrind Prev: Modules that modify the way other modules work Up: Miscellaneous Notes Top: Top

6.5. A C++ namespace for gnulib

The function definitions provided by Gnulib (.c code) are meant to be compiled by a C compiler. The header files (.h files), on the other hand, can be used in either C or C++.

By default, when used in a C++ compilation unit, the .h files declare the same symbols and overrides as in C mode, except that functions defined by Gnulib or by the system are declared as `extern "C"'.

It is also possible to indicate to Gnulib to provide many of its symbols in a dedicated C++ namespace. If you define the macro GNULIB_NAMESPACE to an identifier, many functions will be defined in the namespace specified by the identifier instead of the global namespace. For example, after you have defined

#define GNULIB_NAMESPACE gnulib
at the beginning of a compilation unit, Gnulib's <fcntl.h> header file will make available the open function as gnulib::open. The symbol open will still refer to the system's open function, with its platform specific bugs and limitations.

The symbols provided in the Gnulib namespace are those for which the corresponding header file contains a _GL_CXXALIAS_RPL or _GL_CXXALIAS_SYS macro invocation.

The benefits of this namespace mode are:

  • Gnulib defines fewer symbols as preprocessor macros. For example, on a platform where open has to be overridden, Gnulib normally does #define open rpl_open. If your package has a class with a member open, for example a class foo with a method foo::open, then if you define this member in a compilation unit that includes <fcntl.h> and use it in a compilation unit that does not include <fcntl.h>, or vice versa, you will get a link error. Worse: You will not notice this problem on the platform where the system's open function works fine. This problem goes away in namespace mode.

  • It provides a safety check whether the set of modules your package requests from Gnulib is sufficient. For example, if you use the function gnulib::open in your code, and you forgot to request the module `open' from Gnulib, you will get a compilation error (regardless of the platform).
The drawback of this namespace mode is that the system provided symbols in the global namespace are still present, even when they contain bugs that Gnulib fixes. For example, if you call open (...) in your code, it will invoke the possibly buggy system function, even if you have requested the module `open' from gnulib-tool.

You can turn on the namespace mode in some compilation units and keep it turned off in others. This can be useful if your package consists of an application layer that does not need to invoke POSIX functions and an operating system interface layer that contains all the OS function calls. In such a situation, you will want to turn on the namespace mode for the application layer---to avoid many preprocessor macro definitions---and turn it off for the OS interface layer---to avoid the drawback of the namespace mode, mentioned above.

Next: Running self-tests under valgrind Prev: Modules that modify the way other modules work Up: Miscellaneous Notes Top: Top


Running self-tests under valgrind -- GNU Gnulib

Next: License Texinfo sources Prev: A C++ namespace for gnulib Up: Miscellaneous Notes Top: Top

6.6. Running self-tests under valgrind

For projects written in C or similar languages, running the self-tests under Valgrind can reveal hard to find memory issues. The valgrind-tests module searches for Valgrind and declares the VALGRIND automake variable for use with automake's TESTS_ENVIRONMENT.

After importing the valgrind-tests module to your project, you use it by adding the following to the Makefile.am that runs the self-tests:

TESTS_ENVIRONMENT = $(VALGRIND)
This will run all self-checks under valgrind. This can be wasteful if you have many shell scripts or other non-binaries. Using the Automake parallel-tests feature, this can be avoided by using the following instead:

AUTOMAKE_OPTIONS = parallel-tests
TEST_EXTENSIONS = .pl .sh
LOG_COMPILER = $(VALGRIND)
Then valgrind will only be used for the non-.sh and non-.pl tests. However, this means that binaries invoked through scripts will not be invoked under valgrind, which could be solved by adding the following:

TESTS_ENVIRONMENT = VALGRIND='$(VALGRIND)'
And then modify the shell scripts to invoke the binary prefixed with $VALGRIND.

Next: License Texinfo sources Prev: A C++ namespace for gnulib Up: Miscellaneous Notes Top: Top


License Texinfo sources -- GNU Gnulib

Next: Building gnulib Prev: Running self-tests under valgrind Up: Miscellaneous Notes Top: Top

6.7. License Texinfo sources

Gnulib provides copies of the GNU GPL, GNU LGPL, and GNU FDL licenses in Texinfo form. (The master location is https://www.gnu.org/licenses/). These Texinfo documents do not have any node names and structures built into them; for your manual, you should @include them in an appropriate @node.

The conventional name for the GPL node is `Copying' and for the FDL `GNU Free Documentation License'. The LGPL doesn't seem to have a conventional node name.

Of course the license texts themselves should not be changed at all.

Next: Building gnulib Prev: Running self-tests under valgrind Up: Miscellaneous Notes Top: Top


Building gnulib -- GNU Gnulib

Prev: License Texinfo sources Up: Miscellaneous Notes Top: Top

6.8. Building gnulib

If you wish to help the gnulib development effort with build logs for your favorite platform, you may perform these steps:

  1. Prerequisites tools Install the proper development tools. To build and test all of Gnulib, you will need development tools for the programming languages C, C++, Java, and Perl, along with standard POSIX utilities such as @command{awk}, @command{make} and @command{sh}. You will also need development tools that include Autoconf, Automake, Bison, Gettext, Git, GNU M4, Gperf, Libtool, and Texinfo. Some of these tools are needed only by some modules. More details can be found in Gnulib's DEPENDENCIES file.

  2. Obtain Gnulib See https://www.gnu.org/software/gnulib/ for how to get the current Gnulib sources via Git.

  3. Create gnulib directory On a machine with GNU development tools installed and with a gnulib git checkout, use

    gnulib-tool --create-megatestdir --with-tests --dir=...
    Note: The created directory uses ca. 512 MB on disk.

  4. Transfer gnulib directory Transfer this directory to a build machine (HP-UX, Cygwin, or whatever). Often it is easier to transfer one file, and this can be achieved by running, inside the directory the following commands:

    ./configure
make dist
    And then transferring the dummy-0.tar.gz file.

  5. Build modules On the build machine, run ./do-autobuild (or "nohup ./do-autobuild"). It creates a directory logs/ with a log file for each module.

Prev: License Texinfo sources Up: Miscellaneous Notes Top: Top


POSIX Substitutes Library -- GNU Gnulib

Next: Header File Substitutes Prev: Miscellaneous Notes Top: Top

7. Building the ISO C and POSIX Substitutes

This section shows a radically different way to use Gnulib.

You can extract the ISO C / POSIX substitutes part of gnulib by running the command

gnulib-tool --create-testdir --source-base=lib \
            --dir=/tmp/posixlib `posix-modules`
The command `posix-modules' is found in the same directory as gnulib-tool.

The resulting directory can be built on a particular platform, independently of the program being ported. Then you can configure and build any program, by setting CPPFLAGS and LDFLAGS at configure time accordingly: set CPPFLAGS="-I.../posixlib/lib", plus any essential type definitions and flags that you find in .../posixlib/config.h, and set LDFLAGS=".../posixlib/lib/libgnu.a".

This way of using Gnulib is useful when you don't want to modify the program's source code, or when the program uses a mix between C and C++ sources (requiring separate builds of the posixlib for the C compiler and for the C++ compiler).

Next: Header File Substitutes Prev: Miscellaneous Notes Top: Top


Header File Substitutes -- GNU Gnulib

Next: Function Substitutes Prev: POSIX Substitutes Library Top: Top

8. ISO C and POSIX Header File Substitutes

This chapter describes which header files specified by ISO C or POSIX are substituted by Gnulib, which portability pitfalls are fixed by Gnulib, and which (known) portability problems are not worked around by Gnulib.

Menu

  • aio.h
  • arpa/inet.h
  • assert.h
  • complex.h
  • cpio.h
  • ctype.h
  • dirent.h
  • dlfcn.h
  • errno.h
  • fcntl.h
  • fenv.h
  • float.h
  • fmtmsg.h
  • fnmatch.h
  • ftw.h
  • glob.h
  • grp.h
  • iconv.h
  • inttypes.h
  • iso646.h
  • langinfo.h
  • libgen.h
  • limits.h
  • locale.h
  • math.h
  • monetary.h
  • mqueue.h
  • ndbm.h
  • net/if.h
  • netdb.h
  • netinet/in.h
  • netinet/tcp.h
  • nl_types.h
  • poll.h
  • pthread.h
  • pwd.h
  • regex.h
  • sched.h
  • search.h
  • semaphore.h
  • setjmp.h
  • signal.h
  • spawn.h
  • stdalign.h
  • stdarg.h
  • stdbool.h
  • stddef.h
  • stdint.h
  • stdio.h
  • stdlib.h
  • stdnoreturn.h
  • string.h
  • strings.h
  • stropts.h
  • sys/ipc.h
  • sys/mman.h
  • sys/msg.h
  • sys/resource.h
  • sys/select.h
  • sys/sem.h
  • sys/shm.h
  • sys/socket.h
  • sys/stat.h
  • sys/statvfs.h
  • sys/time.h
  • sys/timeb.h
  • sys/times.h
  • sys/types.h
  • sys/uio.h
  • sys/un.h
  • sys/utsname.h
  • sys/wait.h
  • syslog.h
  • tar.h
  • termios.h
  • tgmath.h
  • time.h
  • trace.h
  • uchar.h
  • ucontext.h
  • ulimit.h
  • unistd.h
  • utime.h
  • utmpx.h
  • wchar.h
  • wctype.h
  • wordexp.h

    • Next: Function Substitutes Prev: POSIX Substitutes Library Top: Top


aio.h -- GNU Gnulib

Next: arpa/inet.h Up: Header File Substitutes Top: Top

8.1. aio.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/aio.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: arpa/inet.h Up: Header File Substitutes Top: Top


arpa/inet.h -- GNU Gnulib

Next: assert.h Prev: aio.h Up: Header File Substitutes Top: Top

8.2. arpa/inet.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/arpa_inet.h.html

Gnulib module: arpa_inet

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: assert.h Prev: aio.h Up: Header File Substitutes Top: Top


assert.h -- GNU Gnulib

Next: complex.h Prev: arpa/inet.h Up: Header File Substitutes Top: Top

8.3. assert.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/assert.h.html

Gnulib module: assert-h

See also the Gnulib module assert.

Portability problems fixed by Gnulib:

  • The C11 and C++11 static_assert, and the C11 _Static_assert, are not supported by many platforms. For example, GCC versions before 4.6.0 do not support _Static_assert, and G++ versions through at least 4.6.0 do not support static_assert.
Portability problems not fixed by Gnulib:
  • C11 _Static_assert and C++11 static_assert are keywords that can be used without including <assert.h>. The Gnulib substitutes are macros that require including <assert.h>.
  • The C11 static_assert and _Static_assert can also be used within a struct or union specifier, in place of an ordinary declaration of a member of the struct or union. The Gnulib substitute can be used only as an ordinary declaration.
  • In C99, assert can be applied to any scalar expression. In C89, the argument to assert is of type int.

Next: complex.h Prev: arpa/inet.h Up: Header File Substitutes Top: Top


complex.h -- GNU Gnulib

Next: cpio.h Prev: assert.h Up: Header File Substitutes Top: Top

8.4. complex.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/complex.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cpio.h Prev: assert.h Up: Header File Substitutes Top: Top


cpio.h -- GNU Gnulib

Next: ctype.h Prev: complex.h Up: Header File Substitutes Top: Top

8.5. cpio.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/cpio.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: ctype.h Prev: complex.h Up: Header File Substitutes Top: Top


ctype.h -- GNU Gnulib

Next: dirent.h Prev: cpio.h Up: Header File Substitutes Top: Top

8.6. ctype.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/ctype.h.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: dirent.h Prev: cpio.h Up: Header File Substitutes Top: Top


dirent.h -- GNU Gnulib

Next: dlfcn.h Prev: ctype.h Up: Header File Substitutes Top: Top

8.7. dirent.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/dirent.h.html

Gnulib module: dirent

Portability problems fixed by Gnulib:

  • The type ino_t is missing on some platforms: glibc 2.23 and others.

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: MSVC 14.

  • Although many systems define a struct dirent member named d_type and directory entry type macros like DT_DIR and DT_LNK, some do not: Minix 3.1.8, AIX 7.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, Interix 3.5, BeOS.

  • On systems with d_type, not every filesystem supports d_type, and those lacking support will set it to DT_UNKNOWN.

  • Some systems define a struct dirent member named d_namlen containing the string length of d_name, but others do not: glibc 2.23 on Linux, Minix 3.1.8, Solaris 11.3, Cygwin, BeOS. All of these, except Cygwin, have a member d_reclen instead, that has a different semantics.

  • Some systems define a struct dirent member named d_off containing a magic cookie suitable as an argument to seekdir, but others do not: glibc 2.23 on Hurd, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, Interix 3.5, BeOS.

  • Some systems define a struct dirent member named d_reclen containing the number of bytes in the directory entry record, but others do not. This member has limited utility, as it is an implementation detail.

Next: dlfcn.h Prev: ctype.h Up: Header File Substitutes Top: Top


dlfcn.h -- GNU Gnulib

Next: errno.h Prev: dirent.h Up: Header File Substitutes Top: Top

8.8. dlfcn.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/dlfcn.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: errno.h Prev: dirent.h Up: Header File Substitutes Top: Top


errno.h -- GNU Gnulib

Next: fcntl.h Prev: dlfcn.h Up: Header File Substitutes Top: Top

8.9. errno.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/errno.h.html

Gnulib module: errno

Portability problems fixed by Gnulib:

  • The macros EOVERFLOW, ENOLINK are not defined on some platforms: OpenBSD 4.0, OSF/1 5.1, mingw, MSVC 9.
  • The macro EMULTIHOP is not defined on some platforms: OpenBSD 4.0, OSF/1 5.1, mingw, MSVC 14.
  • The macro ECANCELED is not defined on some platforms: OpenBSD 4.0, Cygwin, mingw, MSVC 9.
  • The macros ENOMSG, EIDRM, EPROTO, EBADMSG, ENOTSUP are not defined on some platforms: OpenBSD 4.0, mingw, MSVC 9.
  • The macro ESTALE is not defined on some platforms: mingw, MSVC 14, Interix 3.5.
  • The macro EDQUOT is not defined on some platforms: NonStop Kernel, mingw, MSVC 14.
  • The macros ENETRESET, ECONNABORTED are not defined on some platforms: Minix 3.1.8, mingw, MSVC 9.
  • The macros EWOULDBLOCK, ETXTBSY, ELOOP, ENOTSOCK, EDESTADDRREQ, EMSGSIZE, EPROTOTYPE, ENOPROTOOPT, EPROTONOSUPPORT, EOPNOTSUPP, EAFNOSUPPORT, EADDRINUSE, EADDRNOTAVAIL, ENETDOWN, ENETUNREACH, ECONNRESET, ENOBUFS, EISCONN, ENOTCONN, ETIMEDOUT, ECONNREFUSED, EHOSTUNREACH, EALREADY, EINPROGRESS are not defined on some platforms: mingw, MSVC 9.
  • The macros EOWNERDEAD, ENOTRECOVERABLE are not defined on some platforms: glibc/Linux 2.3.6, glibc/Hurd 2.15, glibc/kFreeBSD 2.15, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw without pthreads-win32, MSVC 9, Interix 3.5, BeOS.
  • The macro EILSEQ is not defined on some platforms: LynxOS 178 2.2.2.
Portability problems not fixed by Gnulib:

Next: fcntl.h Prev: dlfcn.h Up: Header File Substitutes Top: Top


fcntl.h -- GNU Gnulib

Next: fenv.h Prev: errno.h Up: Header File Substitutes Top: Top

8.10. fcntl.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/fcntl.h.html

Gnulib module: fcntl-h

Portability problems fixed by Gnulib:

  • The type pid_t is not defined on some platforms: MSVC 14.

  • The type mode_t is not defined on some platforms: MSVC 14.

  • `O_CLOEXEC', `O_DIRECTORY', `O_DSYNC', `O_NOCTTY', `O_NOFOLLOW', `O_RSYNC', `O_SYNC', and `O_TTY_INIT' are not defined on some platforms. Gnulib defines these macros to 0, which is generally safe.

  • `O_NONBLOCK' is not defined on some platforms. If the `nonblocking' module is in use, gnulib guarantees a working non-zero value; otherwise, the gnulib replacement is 0.

  • `O_EXEC' and `O_SEARCH' are not defined on some platforms. Gnulib defines these macros to `O_RDONLY', which is typically 0. The `O_PATH' macro of GNU/Linux is not a suitable substitute, as fchmod fails with `errno==EBADF' when invoked on a file descriptor that was opened with `O_PATH'.

  • `O_ACCMODE' is not defined on some platforms: MSVC 14.

  • The `O_ACCMODE' mask mistakenly omits `O_SEARCH' and `O_EXEC' on some platforms: Cygwin.

  • `O_BINARY', `O_TEXT' (not specified by POSIX, but essential for portability to native Windows platforms) are defined on some platforms but not on others.

  • `O_CLOEXEC', `O_NOFOLLOW', and `O_TTY_INIT' are defined to values that are too large for an int on some platforms: AIX 7.1 with XL C 12.1.

  • `O_DIRECT', `O_IGNORE_CTTY', `O_NDELAY', `O_NOATIME', `O_NOLINK', `O_NOLINKS', and `O_NOTRANS' (not specified by POSIX) are defined on some platforms but not on others.

  • `FD_CLOEXEC', `F_DUPFD', and `F_GETFD' are not defined on some platforms: mingw, MSVC 14.

  • `F_DUPFD_CLOEXEC' is not defined on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.

  • `AT_FDCWD', `AT_EACCESS', `AT_SYMLINK_NOFOLLOW', `AT_SYMLINK_FOLLOW', and `AT_REMOVEDIR' are not defined on many platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

  • `AT_FDCWD' is defined with a value too large for an int on some platforms: Solaris 11.3.
Portability problems not fixed by Gnulib:
  • `F_SETFD', `F_GETFL', `F_SETFL', `F_GETLK', `F_SETLK', `F_SETLKW', `F_GETOWN', and `F_SETOWN' are not defined on some platforms: mingw, MSVC 14.

  • `POSIX_FADV_DONTNEED', `POSIX_FADV_NOREUSE', `POSIX_FADV_NORMAL', `POSIX_FADV_RANDOM', `POSIX_FADV_SEQUENTIAL', and `POSIX_FADV_WILLNEED' are not defined on some platforms.

Next: fenv.h Prev: errno.h Up: Header File Substitutes Top: Top


fenv.h -- GNU Gnulib

Next: float.h Prev: fcntl.h Up: Header File Substitutes Top: Top

8.11. fenv.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/fenv.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.7, MSVC 9, Interix 3.5, BeOS.

Next: float.h Prev: fcntl.h Up: Header File Substitutes Top: Top


float.h -- GNU Gnulib

Next: fmtmsg.h Prev: fenv.h Up: Header File Substitutes Top: Top

8.12. float.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/float.h.html

Gnulib module: float

Portability problems fixed by Gnulib:

  • The conversion from int to long double in incorrect on some platforms: glibc 2.7 on Linux/SPARC64.
  • The values of LDBL_* macros are incorrect on some platforms: On OpenBSD 4.0, MirBSD 10, and BeOS, they are the same as the values of the DBL_* macros, although `long double' is a larger type than `double'. On FreeBSD/x86 6.4, they represent the incorrect 53-bit precision assumptions in the compiler, not the real 64-bit precision at runtime. On Linux/PowerPC with GCC 4.4, on AIX 7.1 with GCC 4.2, and on IRIX 6.5, they don't reflect the ``double double'' representation of long double correctly.
Portability problems not fixed by Gnulib:
  • The macro FLT_ROUNDS is a constant expression and does not represent the current rounding mode on some platforms: glibc 2.11, HP-UX 11, mingw.

Next: fmtmsg.h Prev: fenv.h Up: Header File Substitutes Top: Top


fmtmsg.h -- GNU Gnulib

Next: fnmatch.h Prev: float.h Up: Header File Substitutes Top: Top

8.13. fmtmsg.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/fmtmsg.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fnmatch.h Prev: float.h Up: Header File Substitutes Top: Top


fnmatch.h -- GNU Gnulib

Next: ftw.h Prev: fmtmsg.h Up: Header File Substitutes Top: Top

8.14. fnmatch.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/fnmatch.h.html

Gnulib module: fnmatch-posix or fnmatch-gnu

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: ftw.h Prev: fmtmsg.h Up: Header File Substitutes Top: Top


ftw.h -- GNU Gnulib

Next: glob.h Prev: fnmatch.h Up: Header File Substitutes Top: Top

8.15. ftw.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/ftw.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 3.0, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: glob.h Prev: fnmatch.h Up: Header File Substitutes Top: Top


glob.h -- GNU Gnulib

Next: grp.h Prev: ftw.h Up: Header File Substitutes Top: Top

8.16. glob.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/glob.h.html

Gnulib module: glob

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: grp.h Prev: ftw.h Up: Header File Substitutes Top: Top


grp.h -- GNU Gnulib

Next: iconv.h Prev: glob.h Up: Header File Substitutes Top: Top

8.17. grp.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/grp.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14.

Next: iconv.h Prev: glob.h Up: Header File Substitutes Top: Top


iconv.h -- GNU Gnulib

Next: inttypes.h Prev: grp.h Up: Header File Substitutes Top: Top

8.18. iconv.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/iconv.h.html

Gnulib module: iconv

Portability problems fixed by Gnulib:

  • The <iconv.h> from GNU libiconv is not found if installed in $PREFIX/include.
Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS, when GNU libiconv is not installed.

Next: inttypes.h Prev: grp.h Up: Header File Substitutes Top: Top


inttypes.h -- GNU Gnulib

Next: iso646.h Prev: iconv.h Up: Header File Substitutes Top: Top

8.19. inttypes.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/inttypes.h.html

Gnulib module: inttypes

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: OSF/1 4.0, MSVC 9, Interix 3.5.
  • This header file is very incomplete on some platforms.
  • The PRI* macros are defined to non-string values on AIX 4.3.3.
  • The declarations of imaxabs and imaxdiv are missing on some platforms: NetBSD 3.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, BeOS.
  • The declarations of strtoimax and strtoumax are missing on some platforms: OpenBSD 3.8, AIX 4.3.2, AIX 5.1 (missing only strtoumax), OSF/1 5.1.
  • On some hosts that predate C++11, when using C++ one must define __STDC_FORMAT_MACROS to make visible the declarations of format macros such as PRIdMAX.
Portability problems not fixed by Gnulib:

Next: iso646.h Prev: iconv.h Up: Header File Substitutes Top: Top


iso646.h -- GNU Gnulib

Next: langinfo.h Prev: inttypes.h Up: Header File Substitutes Top: Top

8.20. iso646.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/iso646.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, OSF/1 4.0, Cygwin, mingw, BeOS.

Next: langinfo.h Prev: inttypes.h Up: Header File Substitutes Top: Top


langinfo.h -- GNU Gnulib

Next: libgen.h Prev: iso646.h Up: Header File Substitutes Top: Top

8.21. langinfo.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/langinfo.h.html

Gnulib module: langinfo

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • The constant CODESET is not defined on some platforms: glibc 2.0.6, OpenBSD 3.8.
  • The constants ERA, ERA_D_FMT, ERA_D_T_FMT, ERA_T_FMT, ALT_DIGITS are not defined on some platforms: OpenBSD 3.8.
  • The constants T_FMT_AMPM, YESEXPR, NOEXPR are not defined on some platforms: IRIX 5.3.
Portability problems not fixed by Gnulib:

Next: libgen.h Prev: iso646.h Up: Header File Substitutes Top: Top


libgen.h -- GNU Gnulib

Next: limits.h Prev: langinfo.h Up: Header File Substitutes Top: Top

8.22. libgen.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/libgen.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
The Gnulib module dirname provides similar API, with functions base_name and dir_name that also work with Windows file names.

Next: limits.h Prev: langinfo.h Up: Header File Substitutes Top: Top


limits.h -- GNU Gnulib

Next: locale.h Prev: libgen.h Up: Header File Substitutes Top: Top

8.23. limits.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/limits.h.html

Gnulib module: gethostname

Portability problems fixed by Gnulib:

  • The HOST_NAME_MAX macro is not defined on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • Macros like CHAR_WIDTH are not defined on some platforms: glibc 2.24, many others.
Portability problems not fixed by Gnulib:
  • The macros LLONG_MIN, LLONG_MAX, ULLONG_MAX are not defined on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OpenVMS, OSF/1 5.1 with gcc.
  • The macros WORD_BIT, LONG_BIT are not defined on some platforms: glibc 2.11 without -D_GNU_SOURCE, Cygwin, mingw, MSVC 14.
  • The macro SSIZE_MAX has the wrong type, albeit with the correct value: 32-bit glibc 2.24 (on some architectures), Cygwin 2.5.2.
  • The macro SSIZE_MAX is not defined on some platforms: MSVC 14.
For PATH_MAX, Gnulib provides a module pathmax with a header file "pathmax.h". It defines PATH_MAX to a constant on platforms with a file name length limit.

Next: locale.h Prev: libgen.h Up: Header File Substitutes Top: Top


locale.h -- GNU Gnulib

Next: math.h Prev: limits.h Up: Header File Substitutes Top: Top

8.24. locale.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/locale.h.html

Gnulib module: locale

Portability problems fixed by Gnulib:

  • The definition of `LC_MESSAGES' is missing on some platforms: mingw, MSVC 14.

  • The locale_t type is not defined on some platforms: glibc 2.11, Mac OS X 10.5.

  • The struct lconv type does not contain any members on some platforms: Android.

  • The struct lconv type does not contain the members int_p_cs_precedes, int_p_sign_posn, int_p_sep_by_space, int_n_cs_precedes, int_n_sign_posn, int_n_sep_by_space on some platforms: glibc, OpenBSD 4.9, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:

Next: math.h Prev: limits.h Up: Header File Substitutes Top: Top


math.h -- GNU Gnulib

Next: monetary.h Prev: locale.h Up: Header File Substitutes Top: Top

8.25. math.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/math.h.html

Gnulib module: math

Portability problems fixed by Gnulib:

  • The conversion from int to long double in incorrect on some platforms: glibc 2.7 on Linux/SPARC64.

  • The macro NAN is not defined on some platforms: OpenBSD 4.0, AIX 5.1, IRIX 6.5, OSF/1 5.1.

  • The macro NAN is not exposed outside of C99 compilation on some platforms: glibc.

  • The macros NAN and HUGE_VAL expand to a function address rather than a floating point constant on some platforms: Solaris 10.

  • The macros HUGE_VALF and HUGE_VALL are not defined on some platforms: glibc/HPPA, glibc/SPARC, AIX 5.1, IRIX 6.5, Solaris 9, MSVC 9.

  • The macros FP_ILOGB0 and FP_ILOGBNAN are not defined on some platforms: NetBSD 5.1, AIX 5.1, IRIX 6.5, Solaris 9, MSVC 9.

  • The macros NAN, HUGE_VALL, and INFINITY are not defined on some platforms: OpenVMS.
Portability problems not fixed by Gnulib:
  • NAN is not a compile time constant with some compilers: OSF/1 with Compaq (ex-DEC) C 6.4, OpenVMS.
  • The macro or variable math_errhandling is not defined on some platforms: glibc 2.11, OpenBSD 4.9, NetBSD 5.1, UP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.9, mingw, MSVC 9.

Next: monetary.h Prev: locale.h Up: Header File Substitutes Top: Top


monetary.h -- GNU Gnulib

Next: mqueue.h Prev: math.h Up: Header File Substitutes Top: Top

8.26. monetary.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/monetary.h.html

Gnulib module: monetary

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS, Android.

Next: mqueue.h Prev: math.h Up: Header File Substitutes Top: Top


mqueue.h -- GNU Gnulib

Next: ndbm.h Prev: monetary.h Up: Header File Substitutes Top: Top

8.27. mqueue.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/mqueue.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ndbm.h Prev: monetary.h Up: Header File Substitutes Top: Top


ndbm.h -- GNU Gnulib

Next: net/if.h Prev: mqueue.h Up: Header File Substitutes Top: Top

8.28. ndbm.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/ndbm.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: net/if.h Prev: mqueue.h Up: Header File Substitutes Top: Top


net/if.h -- GNU Gnulib

Next: netdb.h Prev: ndbm.h Up: Header File Substitutes Top: Top

8.29. net/if.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/net_if.h.html

Gnulib module: net_if

Portability problems fixed by Gnulib:

  • This header file is not self-contained on some platforms (needing <sys/socket.h> to be included first): FreeBSD 8.2, OpenBSD 5.2.
Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, Interix 3.5, BeOS.

Next: netdb.h Prev: ndbm.h Up: Header File Substitutes Top: Top


netdb.h -- GNU Gnulib

Next: netinet/in.h Prev: net/if.h Up: Header File Substitutes Top: Top

8.30. netdb.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/netdb.h.html

Gnulib module: netdb

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

  • This header file is incomplete on some platforms: Cygwin 1.5.x, Haiku.

  • This header file does not define the type socklen_t on some platforms: HP-UX 10.20, IRIX 6.5, OSF/1 4.0, Interix 3.5, BeOS.

  • This header file does not define AI_ALL, AI_V4MAPPED, AI_ADDRCONFIG on some platforms: NetBSD 5.0.
Portability problems not fixed by Gnulib:

Next: netinet/in.h Prev: net/if.h Up: Header File Substitutes Top: Top


netinet/in.h -- GNU Gnulib

Next: netinet/tcp.h Prev: netdb.h Up: Header File Substitutes Top: Top

8.31. netinet/in.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/netinet_in.h.html

Gnulib module: netinet_in

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
  • This header file is not self-contained on some platforms (it requires <sys/types.h> to be included first): OpenBSD 4.6.
Portability problems not fixed by Gnulib:

Next: netinet/tcp.h Prev: netdb.h Up: Header File Substitutes Top: Top


netinet/tcp.h -- GNU Gnulib

Next: nl_types.h Prev: netinet/in.h Up: Header File Substitutes Top: Top

8.32. netinet/tcp.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/netinet_tcp.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: nl_types.h Prev: netinet/in.h Up: Header File Substitutes Top: Top


nl_types.h -- GNU Gnulib

Next: poll.h Prev: netinet/tcp.h Up: Header File Substitutes Top: Top

8.33. nl_types.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/nl_types.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: poll.h Prev: netinet/tcp.h Up: Header File Substitutes Top: Top


poll.h -- GNU Gnulib

Next: pthread.h Prev: nl_types.h Up: Header File Substitutes Top: Top

8.34. poll.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/poll.h.html

Gnulib module: poll-h

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • This header file does not defined nfds_t on some platforms: IRIX 5.3.

Next: pthread.h Prev: nl_types.h Up: Header File Substitutes Top: Top


pthread.h -- GNU Gnulib

Next: pwd.h Prev: poll.h Up: Header File Substitutes Top: Top

8.35. pthread.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/pthread.h.html

Gnulib module: pthread

Portability problems fixed by Gnulib:

  • This header pollutes the namespace with some broken macro implementations for various functions such as strtok_r and gmtime_r: mingw 3.0.
Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms; the replacement does not offer threads, so much as lightweight stubs that make conditional compilation easier for fallbacks to single-threaded programs. Minix 3.1.8, mingw 2.x, MSVC 14, BeOS.

Next: pwd.h Prev: poll.h Up: Header File Substitutes Top: Top


pwd.h -- GNU Gnulib

Next: regex.h Prev: pthread.h Up: Header File Substitutes Top: Top

8.36. pwd.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/pwd.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14.

Next: regex.h Prev: pthread.h Up: Header File Substitutes Top: Top


regex.h -- GNU Gnulib

Next: sched.h Prev: pwd.h Up: Header File Substitutes Top: Top

8.37. regex.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/regex.h.html

Gnulib module: regex

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This header file is not self-contained on some platforms: it requires <sys/types.h> to be included first.

Next: sched.h Prev: pwd.h Up: Header File Substitutes Top: Top


sched.h -- GNU Gnulib

Next: search.h Prev: regex.h Up: Header File Substitutes Top: Top

8.38. sched.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sched.h.html

Gnulib module: sched

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This header file does not define the type pid_t on some platforms: glibc 2.11, Mac OS X 10.5.
  • struct sched_param is not defined on some platforms: Haiku.
  • SCHED_FIFO, SCHED_RR, SCHED_OTHER are not defined on some platforms: Haiku.
Portability problems not fixed by Gnulib:

Next: search.h Prev: regex.h Up: Header File Substitutes Top: Top


search.h -- GNU Gnulib

Next: semaphore.h Prev: sched.h Up: Header File Substitutes Top: Top

8.39. search.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/search.h.html

Gnulib module: search

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, BeOS.

Next: semaphore.h Prev: sched.h Up: Header File Substitutes Top: Top


semaphore.h -- GNU Gnulib

Next: setjmp.h Prev: search.h Up: Header File Substitutes Top: Top

8.40. semaphore.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/semaphore.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: setjmp.h Prev: search.h Up: Header File Substitutes Top: Top


setjmp.h -- GNU Gnulib

Next: signal.h Prev: semaphore.h Up: Header File Substitutes Top: Top

8.41. setjmp.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/setjmp.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: signal.h Prev: semaphore.h Up: Header File Substitutes Top: Top


signal.h -- GNU Gnulib

Next: spawn.h Prev: setjmp.h Up: Header File Substitutes Top: Top

8.42. signal.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/signal.h.html

Gnulib module: signal-h

Portability problems fixed by Gnulib:

  • volatile sig_atomic_t is rejected by older compilers on some platforms: AIX.
  • sigset_t is missing on some platforms: MSVC 14.
  • sigset_t is only declared in <sys/types.h> on some platforms: mingw.
  • struct sigaction and siginfo_t are missing on some platforms: mingw, MSVC 14.
  • struct sigaction lacks the sa_sigaction member on some platforms: Irix 5.3, Interix 3.5.
  • The type pid_t is not defined on some platforms: MSVC 14.
  • The signal SIGPIPE is not defined on some platforms: mingw, MSVC 14.
  • The macro SA_NODEFER is not defined on some platforms: Interix 3.5.
  • The macros SA_RESETHAND and SA_RESTART are not defined on some platforms: NonStop.
  • The type sighandler_t (a GNU extension) is not defined on most non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • Many signals are not defined on some platforms: mingw, MSVC 14.
  • The macros SIGRTMIN and SIGRTMAX expand to an expression of type long instead of int on some platforms: OSF/1 5.1.
  • The macro SIGBUS is set to the same value as SIGSEGV, rather than being a distinct signal, on some platforms: Haiku.

Next: spawn.h Prev: setjmp.h Up: Header File Substitutes Top: Top


spawn.h -- GNU Gnulib

Next: stdalign.h Prev: signal.h Up: Header File Substitutes Top: Top

8.43. spawn.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/spawn.h.html

Gnulib module: spawn

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: stdalign.h Prev: signal.h Up: Header File Substitutes Top: Top


stdalign.h -- GNU Gnulib

Next: stdarg.h Prev: spawn.h Up: Header File Substitutes Top: Top

8.44. stdalign.h

POSIX specification:* Not in POSIX yet, but we expect it will be. ISO C11 (latest free draft http://www.open-std.org/jtc1/sc22/wg14/www/docs/n1570.pdf) sections 6.5.3.4, 6.7.5, 7.15. C++11 (latest free draft http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2011/n3242.pdf) section 18.10.

Gnulib module: stdalign

Portability problems fixed by Gnulib:

  • This header file is missing on most circa-2011 platforms.
  • Clang 3.0's <stdalign.h> does not define alignof/_Alignof.
  • The alignof and _Alignof macros return too large values for the types double and long long in GCC 4.7.0.
Portability problems not fixed by Gnulib:
  • In ISO C11, the operand of alignof/_Alignof must be a parenthesized type. Recent versions of GCC support an extension in which the operand can also be a unary expression, as with sizeof. The Gnulib substitute does not support this extension.
  • On most pre-C11 platforms, the operand of alignof/_Alignof cannot be a structure type containing a flexible array member.
  • _Alignas and alignas are not always supported; on platforms lacking support, the macro __alignas_is_defined is not defined. Supported compilers include GCC, IBM C, Sun C 5.9 and later, and MSVC 7.0 and later.
  • Some compilers do not support alignment via alignas/_Alignas of auto variables (i.e., variables on the stack). They diagnose and ignore the alignment: Sun C 5.11.
  • Some linkers do not support operands of _Alignas/alignas that are greater than 8: mingw.
  • Some compilers require the operand of _Alignas/alignas to be a single integer constant, not an expression: MSVC 7.0 through at least 10.0.
  • The Sun C 5.11 compiler sometimes mishandles the alignment of multiple external variables that are declared close together with _Alignas/alignas. This compiler bug causes the Gnulib module stdalign-tests to fail. The Sun Studio Developer Bug Report Review Team assigned the internal review ID 2125432 (dated 2011-11-01) to this issue.
  • <stdalign.h> must be #included before _Alignas and _Alignof can be used.
  • You cannot assume that _Alignas and _Alignof are reserved words; they might be macros.

Next: stdarg.h Prev: spawn.h Up: Header File Substitutes Top: Top


stdarg.h -- GNU Gnulib

Next: stdbool.h Prev: stdalign.h Up: Header File Substitutes Top: Top

8.45. stdarg.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stdarg.h.html

Gnulib module: stdarg

Portability problems fixed by Gnulib:

  • Some compilers (e.g., AIX 5.3 cc) need to be in c99 mode for the builtin va_copy to work.
Portability problems not fixed by Gnulib:

Next: stdbool.h Prev: stdalign.h Up: Header File Substitutes Top: Top


stdbool.h -- GNU Gnulib

Next: stddef.h Prev: stdarg.h Up: Header File Substitutes Top: Top

8.46. stdbool.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stdbool.h.html

Gnulib module: stdbool

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1.
  • Some compilers have bugs relating to `bool'.
  • This header file defines true incorrectly on some platforms: OpenBSD 4.7 with gcc 2.95.
Portability problems not fixed by Gnulib:
  • `_Bool' cannot be used before <stdbool.h> is included, or if the program is intended to be compiled by a C++ compiler.
  • You cannot assume that _Bool is a typedef; it might be a macro.
  • Bit-fields of type `bool' are not supported. Portable code should use `unsigned int foo : 1;' rather than `bool foo : 1;'.
  • Casts and automatic conversions to `bool' don't test against the zero value or the null pointer, as they should. Such casts should only be used if the value is known to be equal to 0 or 1.
  • You cannot assume that casting a floating point literal to `bool' will result in a constant expression.

Next: stddef.h Prev: stdarg.h Up: Header File Substitutes Top: Top


stddef.h -- GNU Gnulib

Next: stdint.h Prev: stdbool.h Up: Header File Substitutes Top: Top

8.47. stddef.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stddef.h.html

Gnulib module: stddef

Portability problems fixed by Gnulib:

  • Some platforms fail to provide max_align_t, which was added in C11: Solaris 11.0 and others.

  • Some old platforms fail to provide wchar_t.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:
  • Some platforms provide an offsetof macro that cannot be used in arbitrary expressions: Solaris 11.3 This problem can be worked around by parenthesizing the offsetof expression in the unlikely case you use it with sizeof or `[]'.

Next: stdint.h Prev: stdbool.h Up: Header File Substitutes Top: Top


stdint.h -- GNU Gnulib

Next: stdio.h Prev: stddef.h Up: Header File Substitutes Top: Top

8.48. stdint.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stdint.h.html

Gnulib module: stdint

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: OpenBSD 3.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, MSVC 14, Interix 3.5, BeOS.
  • This header file is very incomplete on some platforms.
  • The values of SIG_ATOMIC_MIN and SIG_ATOMIC_MAX are incorrect on some platforms: FreeBSD 6.2 / ia64.
  • The value of WINT_MAX is incorrect on some platforms: mingw.
  • The values of INT8_MAX, UINT8_MAX etc. are not usable in preprocessor expressions on some platforms: HP-UX 11.23.
  • The values of INTPTR_MAX and UINTPTR_MAX, although correctly defined in <stdint.h>, are replaced by empty values when <limits.h> or <inttypes.h> gets included later on some platforms: Solaris 9 with GCC 4.5 or newer.
  • The macros WCHAR_MIN and WCHAR_MAX are not defined in <stdint.h> (only in <wchar.h>) on some platforms: Dragonfly, BSDI.
  • On some hosts that predate C++11, when using C++ one must define __STDC_CONSTANT_MACROS to make visible the definitions of constant macros such as INTMAX_C, and one must define __STDC_LIMIT_MACROS to make visible the definitions of limit macros such as INTMAX_MAX.
  • The macro SIZE_MAX has the wrong type, albeit with the correct value: 32-bit glibc 2.24 (on s390 architecture), Mac OS X 10.7.
  • Macros like INTMAX_WIDTH are not defined on some platforms: glibc 2.24, many others.
Portability problems not fixed by Gnulib:
  • {uint,int}_fast{8,16,32,64}_t may not correspond to the fastest types available on the system. Other <stdint.h> substitutes may define these types differently, so public header files should avoid these types.
  • Macros are used instead of typedefs.
  • Some C preprocessors mishandle constants that do not fit in long int. For example, as of 2007, Sun C mishandles #if LLONG_MIN < 0 on a platform with 32-bit long int and 64-bit long long int. Some older preprocessors mishandle constants ending in LL. To work around these problems, compute the value of expressions like LONG_MAX < LLONG_MAX at configure-time rather than at #if-time.
The stdint.h module uses #include_next. If you wish to install the generated stdint.h file under another name, typically in order to be able to use some of the types defined by stdint.h in your public header file, you could use the following Makefile.am-snippet:

BUILT_SOURCES += idn-int.h
DISTCLEANFILES += idn-int.h
nodist_include_HEADERS += idn-int.h

idn-int.h:
    if test -n "$(STDINT_H)"; then \
        sed -e s/include_next/include/ gl/stdint.h > idn-int.h; \
    else \
        echo '#include <stdint.h>' > idn-int.h; \
    fi

Next: stdio.h Prev: stddef.h Up: Header File Substitutes Top: Top


stdio.h -- GNU Gnulib

Next: stdlib.h Prev: stdint.h Up: Header File Substitutes Top: Top

8.49. stdio.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stdio.h.html

Gnulib module: stdio

Portability problems fixed by Gnulib:

  • The type off_t is missing on some platforms: glibc 2.8, eglibc 2.11.2 and others.
  • The type ssize_t is missing on some platforms: glibc 2.8, Mac OS X 10.5, Solaris 10, MSVC 14, and others.
  • The type va_list is missing on some platforms: glibc 2.8, OpenBSD 4.0, Solaris 11.3, and others.
  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:

Next: stdlib.h Prev: stdint.h Up: Header File Substitutes Top: Top


stdlib.h -- GNU Gnulib

Next: stdnoreturn.h Prev: stdio.h Up: Header File Substitutes Top: Top

8.50. stdlib.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stdlib.h.html

Gnulib module: stdlib, system-posix

Portability problems fixed by the Gnulib module stdlib:

  • The macros EXIT_SUCCESS and EXIT_FAILURE are not defined on some platforms.
  • The macro EXIT_FAILURE is incorrectly defined on Tandem/NSK.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems fixed by the Gnulib module system-posix:
  • The macros WIFSIGNALED, WIFEXITED, WIFSTOPPED, WTERMSIG, WEXITSTATUS, WNOHANG, WUNTRACED, WSTOPSIG are not defined in this header file (only in <sys/wait.h>) on some platforms: MirBSD 10.
Portability problems not fixed by Gnulib:
  • System status macros such as WEXITSTATUS require an lvalue argument on some platforms. Mac OS X 10.5.

Next: stdnoreturn.h Prev: stdio.h Up: Header File Substitutes Top: Top


stdnoreturn.h -- GNU Gnulib

Next: string.h Prev: stdlib.h Up: Header File Substitutes Top: Top

8.51. stdnoreturn.h

POSIX specification:* Not in POSIX yet, but we expect it will be. ISO C11 (latest free draft http://www.open-std.org/jtc1/sc22/wg14/www/docs/n1570.pdf) sections 7.23.

Gnulib module: stdnoreturn

Portability problems fixed by Gnulib:

  • This header file is missing on most circa-2012 platforms.
Portability problems not fixed by Gnulib:
  • <stdnoreturn.h> should be #included before `_Noreturn' is used.
  • You cannot assume that _Noreturn is a reserved word; it might be a macro.
  • When the macro lint is defined, standard headers define _Noreturn (and therefore noreturn) to be a macro that expands to the empty token sequence on some platforms: Cygwin 2.5.1, FreeBSD 10.3.
  • On Cygwin 1.7.30 and MSVC 14, noreturn expands to the empty token sequence, to avoid problems with standard headers that use noreturn in combination with __attribute__ or __declspec. Although the resulting code operates correctly, the compiler is not informed whether noreturn functions do not return, so it may generate incorrect warnings at compile-time, or code that is slightly less optimized. This problem does not occur with _Noreturn.
  • Circa 2012 bleeding-edge GCC with -Werror=old-style-declaration requires _Noreturn or noreturn before the returned type in a declaration, and therefore rejects valid but unusually-worded declarations such as void _Noreturn foo (void);.

Next: string.h Prev: stdlib.h Up: Header File Substitutes Top: Top


string.h -- GNU Gnulib

Next: strings.h Prev: stdnoreturn.h Up: Header File Substitutes Top: Top

8.52. string.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/string.h.html

Gnulib module: string

Portability problems fixed by Gnulib:

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:

Next: strings.h Prev: stdnoreturn.h Up: Header File Substitutes Top: Top


strings.h -- GNU Gnulib

Next: stropts.h Prev: string.h Up: Header File Substitutes Top: Top

8.53. strings.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/strings.h.html

Gnulib module: strings

Portability problems fixed by Gnulib:

  • This header file is not self-contained on some platforms: Minix 3.1.8.
Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: MSVC 14.
  • This header file defines symbols, such as `index', often used for variables, making debugging harder.

Next: stropts.h Prev: string.h Up: Header File Substitutes Top: Top


stropts.h -- GNU Gnulib

Next: sys/ipc.h Prev: strings.h Up: Header File Substitutes Top: Top

8.54. stropts.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/stropts.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: sys/ipc.h Prev: strings.h Up: Header File Substitutes Top: Top


sys/ipc.h -- GNU Gnulib

Next: sys/mman.h Prev: stropts.h Up: Header File Substitutes Top: Top

8.55. sys/ipc.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_ipc.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: sys/mman.h Prev: stropts.h Up: Header File Substitutes Top: Top


sys/mman.h -- GNU Gnulib

Next: sys/msg.h Prev: sys/ipc.h Up: Header File Substitutes Top: Top

8.56. sys/mman.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_mman.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: sys/msg.h Prev: sys/ipc.h Up: Header File Substitutes Top: Top


sys/msg.h -- GNU Gnulib

Next: sys/resource.h Prev: sys/mman.h Up: Header File Substitutes Top: Top

8.57. sys/msg.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_msg.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: sys/resource.h Prev: sys/mman.h Up: Header File Substitutes Top: Top


sys/resource.h -- GNU Gnulib

Next: sys/select.h Prev: sys/msg.h Up: Header File Substitutes Top: Top

8.58. sys/resource.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_resource.h.html

Gnulib module: sys_resource

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • On some platforms, this header file requires that <sys/types.h> and <sys/time.h> already be included: FreeBSD 5.0.
  • On some platforms, this header file does not define the RUSAGE_SELF and RUSAGE_CHILDREN constants: OpenVMS.
Portability problems not fixed by Gnulib:
  • On some platforms, this header does not define some or all of the symbolic constants required by POSIX. For example, OpenVMS and Android do not define RLIM_SAVED_CUR or RLIM_SAVED_MAX.

Next: sys/select.h Prev: sys/msg.h Up: Header File Substitutes Top: Top


sys/select.h -- GNU Gnulib

Next: sys/sem.h Prev: sys/resource.h Up: Header File Substitutes Top: Top

8.59. sys/select.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_select.h.html

Gnulib module: sys_select

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: HP-UX 11.11, NonStop Kernel, mingw, MSVC 14, BeOS.
  • This header file is not self-contained on some platforms: it requires <sys/types.h> to be included first.
  • This header file does not define struct timeval on some platforms: OSF/1 4.0.
  • This header file is not self-contained---it requires <string.h> before FD_ZERO can be used---on some platforms: AIX 7.1, Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: sys/sem.h Prev: sys/resource.h Up: Header File Substitutes Top: Top


sys/sem.h -- GNU Gnulib

Next: sys/shm.h Prev: sys/select.h Up: Header File Substitutes Top: Top

8.60. sys/sem.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_sem.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: sys/shm.h Prev: sys/select.h Up: Header File Substitutes Top: Top


sys/shm.h -- GNU Gnulib

Next: sys/socket.h Prev: sys/sem.h Up: Header File Substitutes Top: Top

8.61. sys/shm.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_shm.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: sys/socket.h Prev: sys/sem.h Up: Header File Substitutes Top: Top


sys/socket.h -- GNU Gnulib

Next: sys/stat.h Prev: sys/shm.h Up: Header File Substitutes Top: Top

8.62. sys/socket.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_socket.h.html

Gnulib module: sys_socket

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • This header file is not self-contained on some platforms: it requires <sys/types.h> to be included first.
  • This header file does not define the type socklen_t on some platforms: HP-UX 10.20, IRIX 6.5, OSF/1 4.0, Interix 3.5, BeOS.
  • This header file does not define the type struct iovec on some platforms: OpenBSD 4.4.
  • This header file is lacking the SHUT_RD, SHUT_WR, SHUT_RDWR macros on some platforms, despite having the shutdown functions: emx+gcc.
  • The struct sockaddr_storage type does not have a member ss_family on some platforms: AIX 7.1.
  • The CMSG_SPACE and CMSG_LEN macros are not provided on some platforms: OpenVMS.
Portability problems not fixed by Gnulib:
  • This header file does not declare the msg_control and msg_controllen members of struct msghdr on some platforms. This can be detected by the absence of the CMSG_FIRSTHDR macro: gnulib replacement header, old BSD

Next: sys/stat.h Prev: sys/shm.h Up: Header File Substitutes Top: Top


sys/stat.h -- GNU Gnulib

Next: sys/statvfs.h Prev: sys/socket.h Up: Header File Substitutes Top: Top

8.63. sys/stat.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_stat.h.html

Gnulib module: sys_stat

Portability problems fixed by Gnulib module sys_stat:

  • The type mode_t is not defined on some platforms: MSVC 14.
  • Some macros, such as S_IFMT or S_IFIFO, are missing on some platforms.
  • The macros S_ISBLK, S_ISCHR, S_ISDIR, S_ISFIFO, S_ISLNK, S_ISREG, S_ISSOCK are broken on some platforms.
  • Some platforms define macros, such as S_ISDOOR, that are not defined on other platforms.
  • The functions lstat and mkdir are not declared on some platforms: mingw, MSVC 14.
  • The macros UTIME_NOW and UTIME_OMIT are missing on some platforms.
  • On some platforms, struct stat does not include st_atim, st_mtim, or st_ctim members. Use the gnulib module `stat-time' for accessors to portably get at subsecond resolution.
Portability problems fixed by Gnulib module sys_stat, together with module windows-stat-inodes:
  • On Windows platforms (excluding Cygwin), st_ino is always 0.
Portability problems not fixed by Gnulib:
  • The macro S_IFBLK is missing on some platforms: MSVC 14.
  • On OpenVMS, st_ino is an array of three ino_t values, not a single value.
  • To partially work around the previous two problems, you can test for nonzero st_ino and use the Gnulib same-inode module to compare nonzero values. For example, SAME_INODE (a, b) is true if the struct stat values a and b are known to represent the same file, (a.st_ino && !SAME_INODE (a, b)) is true if they are known to represent different files, and !a.st_ino is true if it is not known whether they represent different files.
  • On some platforms, two different files may have the same st_dev and st_ino values, even when st_ino is nonzero:
    • GNU/Linux NFS servers that export all local file systems as a single NFS file system, if a local st_dev exceeds 255, or if a local st_ino exceeds 16777215.
    • Network Appliance NFS servers in snapshot directories; see Network Appliance bug #195.
    • ClearCase MVFS; see bug id ATRia04618.
    One partial workaround is to compare other file metadata such as st_mode and st_mtime to detect this bug, but this approach does not work on files whose metadata are being changed by other programs.
  • On some file systems, st_size contains bogus information for symlinks; use the Gnulib module areadlink-with-size for a better way to get symlink contents.

Next: sys/statvfs.h Prev: sys/socket.h Up: Header File Substitutes Top: Top


sys/statvfs.h -- GNU Gnulib

Next: sys/time.h Prev: sys/stat.h Up: Header File Substitutes Top: Top

8.64. sys/statvfs.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_statvfs.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, mingw, MSVC 14.

Next: sys/time.h Prev: sys/stat.h Up: Header File Substitutes Top: Top


sys/time.h -- GNU Gnulib

Next: sys/timeb.h Prev: sys/statvfs.h Up: Header File Substitutes Top: Top

8.65. sys/time.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_time.h.html

Gnulib module: sys_time

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: MSVC 14.
  • `struct timeval' is not defined on some platforms.
  • `struct timeval' is defined with a tv_sec type that is narrower than time_t on some native Windows platforms: mingw64 in 64-bit mode, mingw64 in 32-bit mode when __MINGW_USE_VC2005_COMPAT is defined, MSVC 14 in 64-bit mode, MSVC 14 in 32-bit mode when _USE_32BIT_TIME_T is not defined.
Portability problems not fixed by Gnulib:
  • `struct timeval' is defined with a tv_sec type that is wider than time_t: OpenBSD 5.1 in 64-bit mode.

Next: sys/timeb.h Prev: sys/statvfs.h Up: Header File Substitutes Top: Top


sys/timeb.h -- GNU Gnulib

Next: sys/times.h Prev: sys/time.h Up: Header File Substitutes Top: Top

8.66. sys/timeb.h

POSIX specification:* http://www.opengroup.org/susv3xbd/sys/timeb.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: sys/times.h Prev: sys/time.h Up: Header File Substitutes Top: Top


sys/times.h -- GNU Gnulib

Next: sys/types.h Prev: sys/timeb.h Up: Header File Substitutes Top: Top

8.67. sys/times.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_times.h.html

Gnulib module: sys_times

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: sys/types.h Prev: sys/timeb.h Up: Header File Substitutes Top: Top


sys/types.h -- GNU Gnulib

Next: sys/uio.h Prev: sys/times.h Up: Header File Substitutes Top: Top

8.68. sys/types.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_types.h.html

Gnulib module: sys_types

Portability problems fixed by Gnulib:

  • The type pid_t is not defined on some platforms: MSVC 14.
  • The type size_t is not defined in this file on some platforms: MSVC 14.
  • The type ssize_t is not defined on some platforms: MSVC 14.
  • The type mode_t is not defined on some platforms: MSVC 14.
  • Some systems leak definitions of major, minor, and makedev through this header; however, when sys/sysmacros.h exists, that file should also be included to avoid deprecation warnings from the versions in this header: glibc 2.25.
Portability problems not fixed by Gnulib:
  • On some platforms the types blksize_t and suseconds_t are signed integer types that are wider than long: glibc x32
This module, together with the module largefile, also defines the type off_t to a 64-bit integer type on some platforms: mingw, MSVC 14.

Next: sys/uio.h Prev: sys/times.h Up: Header File Substitutes Top: Top


sys/uio.h -- GNU Gnulib

Next: sys/un.h Prev: sys/types.h Up: Header File Substitutes Top: Top

8.69. sys/uio.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_uio.h.html

Gnulib module: sys_uio

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • This header file is not self-contained (it requires <sys/types.h> to be included first) on some platforms: OpenBSD 4.4.
Portability problems not fixed by Gnulib:

Next: sys/un.h Prev: sys/types.h Up: Header File Substitutes Top: Top


sys/un.h -- GNU Gnulib

Next: sys/utsname.h Prev: sys/uio.h Up: Header File Substitutes Top: Top

8.70. sys/un.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_un.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.
  • This header requires <code>sys/socket.h</code> to be included first on some platforms: Cygwin 1.7.18.

Next: sys/utsname.h Prev: sys/uio.h Up: Header File Substitutes Top: Top


sys/utsname.h -- GNU Gnulib

Next: sys/wait.h Prev: sys/un.h Up: Header File Substitutes Top: Top

8.71. sys/utsname.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_utsname.h.html

Gnulib module: sys_utsname

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • This header file is not self-contained on some platforms: Minix 3.1.8.
Portability problems not fixed by Gnulib:

Next: sys/wait.h Prev: sys/un.h Up: Header File Substitutes Top: Top


sys/wait.h -- GNU Gnulib

Next: syslog.h Prev: sys/utsname.h Up: Header File Substitutes Top: Top

8.72. sys/wait.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/sys_wait.h.html

Gnulib module: sys_wait

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • System status macros such as WEXITSTATUS require an lvalue argument on some platforms. Mac OS X 10.5.

Next: syslog.h Prev: sys/utsname.h Up: Header File Substitutes Top: Top


syslog.h -- GNU Gnulib

Next: tar.h Prev: sys/wait.h Up: Header File Substitutes Top: Top

8.73. syslog.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/syslog.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: tar.h Prev: sys/wait.h Up: Header File Substitutes Top: Top


tar.h -- GNU Gnulib

Next: termios.h Prev: syslog.h Up: Header File Substitutes Top: Top

8.74. tar.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/tar.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: termios.h Prev: syslog.h Up: Header File Substitutes Top: Top


termios.h -- GNU Gnulib

Next: tgmath.h Prev: tar.h Up: Header File Substitutes Top: Top

8.75. termios.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/termios.h.html

Gnulib module: termios

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • This header does not declare pid_t on all platforms: glibc on some architectures, FreeBSD 6.4, OpenBSD 4.9, Cygwin 1.7.11.
Portability problems not fixed by Gnulib:
  • The types struct termios, cc_t, speed_t, tcflag_t are not defined on some platforms: mingw, MSVC 14.

Next: tgmath.h Prev: tar.h Up: Header File Substitutes Top: Top


tgmath.h -- GNU Gnulib

Next: time.h Prev: termios.h Up: Header File Substitutes Top: Top

8.76. tgmath.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/tgmath.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: time.h Prev: termios.h Up: Header File Substitutes Top: Top


time.h -- GNU Gnulib

Next: trace.h Prev: tgmath.h Up: Header File Substitutes Top: Top

8.77. time.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/time.h.html

Gnulib module: time

Portability problems fixed by Gnulib:

  • `struct timespec' is not defined on some platforms.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:
  • On some platforms the tv_nsec member of struct timespec is not of type long, but is of type long long instead: glibc x32

Next: trace.h Prev: tgmath.h Up: Header File Substitutes Top: Top


trace.h -- GNU Gnulib

Next: uchar.h Prev: time.h Up: Header File Substitutes Top: Top

8.78. trace.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/trace.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: uchar.h Prev: time.h Up: Header File Substitutes Top: Top


uchar.h -- GNU Gnulib

Next: ucontext.h Prev: trace.h Up: Header File Substitutes Top: Top

8.79. uchar.h

Defines the types char16_t, char32_t and declares the functions mbrtoc16, c16rtomb, mbrtoc32, c32rtomb.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ucontext.h Prev: trace.h Up: Header File Substitutes Top: Top


ucontext.h -- GNU Gnulib

Next: ulimit.h Prev: uchar.h Up: Header File Substitutes Top: Top

8.80. ucontext.h

POSIX specification:* http://www.opengroup.org/susv3xbd/ucontext.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: OpenBSD 3.8, Cygwin, mingw, MSVC 14, BeOS.

Next: ulimit.h Prev: uchar.h Up: Header File Substitutes Top: Top


ulimit.h -- GNU Gnulib

Next: unistd.h Prev: ucontext.h Up: Header File Substitutes Top: Top

8.81. ulimit.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/ulimit.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: unistd.h Prev: ucontext.h Up: Header File Substitutes Top: Top


unistd.h -- GNU Gnulib

Next: utime.h Prev: ulimit.h Up: Header File Substitutes Top: Top

8.82. unistd.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/unistd.h.html

Gnulib module: unistd

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: MSVC 14.
  • The SEEK_* macros are not defined in this file on some platforms: mingw.
  • The *_FILENO macros are not defined in this file on some platforms: OS/2 EMX, mingw.
  • The _exit function is not declared in this file on some platforms: mingw.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:

Next: utime.h Prev: ulimit.h Up: Header File Substitutes Top: Top


utime.h -- GNU Gnulib

Next: utmpx.h Prev: unistd.h Up: Header File Substitutes Top: Top

8.83. utime.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/utime.h.html

Gnulib module: utime-h

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: utmpx.h Prev: unistd.h Up: Header File Substitutes Top: Top


utmpx.h -- GNU Gnulib

Next: wchar.h Prev: utime.h Up: Header File Substitutes Top: Top

8.84. utmpx.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/utmpx.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: wchar.h Prev: utime.h Up: Header File Substitutes Top: Top


wchar.h -- GNU Gnulib

Next: wctype.h Prev: utmpx.h Up: Header File Substitutes Top: Top

8.85. wchar.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/wchar.h.html

Gnulib module: wchar

Portability problems fixed by Gnulib:

  • This header file cannot be included on some platforms: Linux uClibc built without wide character support.
  • This header file is not self-contained on some platforms: OSF/1 with Desktop Toolkit C, BSD/OS 4.0.1.
  • The type wint_t and macro WEOF are missing on some platforms: IRIX 5.3.
  • The type wint_t is incorrect on some platforms: MSVC 14.

  • Some platforms provide a NULL macro that cannot be used in arbitrary expressions: NetBSD 5.0
Portability problems not fixed by Gnulib:
  • This header file leads to link errors and endless recursions or endless loops on some platforms: glibc version 2.5 or older, together with gcc version 4.3 or newer and the option `-std=c99' or `-std=gnu99'.

Next: wctype.h Prev: utmpx.h Up: Header File Substitutes Top: Top


wctype.h -- GNU Gnulib

Next: wordexp.h Prev: wchar.h Up: Header File Substitutes Top: Top

8.86. wctype.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/wctype.h.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: HP-UX 11.00, BeOS.
  • This header file is not self-contained on some platforms: Solaris 2.5, OSF/1 with Desktop Toolkit C, BSD/OS 4.0.1.
  • The type wint_t and macro WEOF are missing on some platforms: IRIX 5.3.
  • The type wint_t is incorrect on some platforms: MSVC 14.
  • The functions isw* are missing on some platforms: FreeBSD 4.11.
  • The function iswblank is declared but not defined on some platforms: IRIX 6.5.30.
  • The functions isw* are actually defined as macros that don't work, on IRIX 5.3.
  • This header file defines some identifiers, such as multibyte, as macros on some platforms: Solaris 2.6.
Portability problems not fixed by Gnulib:

Next: wordexp.h Prev: wchar.h Up: Header File Substitutes Top: Top


wordexp.h -- GNU Gnulib

Prev: wctype.h Up: Header File Substitutes Top: Top

8.87. wordexp.h

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/basedefs/wordexp.h.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: wctype.h Up: Header File Substitutes Top: Top


Function Substitutes -- GNU Gnulib

Next: Legacy Function Substitutes Prev: Header File Substitutes Top: Top

9. ISO C and POSIX Function Substitutes

This chapter describes which functions and function-like macros specified by ISO C or POSIX are substituted by Gnulib, which portability pitfalls are fixed by Gnulib, and which (known) portability problems are not worked around by Gnulib.

Menu

  • FD_CLR
  • FD_ISSET
  • FD_SET
  • FD_ZERO
  • _Exit
  • _exit
  • _longjmp
  • _setjmp
  • _tolower
  • _toupper
  • a64l
  • abort
  • abs
  • accept
  • access
  • acos
  • acosf
  • acosh
  • acoshf
  • acoshl
  • acosl
  • aio_cancel
  • aio_error
  • aio_fsync
  • aio_read
  • aio_return
  • aio_suspend
  • aio_write
  • alarm
  • aligned_alloc
  • alphasort
  • asctime
  • asctime_r
  • asin
  • asinf
  • asinh
  • asinhf
  • asinhl
  • asinl
  • assert
  • atan
  • atan2
  • atan2f
  • atan2l
  • atanf
  • atanh
  • atanhf
  • atanhl
  • atanl
  • atexit
  • atof
  • atoi
  • atol
  • atoll
  • basename
  • bind
  • bsearch
  • btowc
  • c16rtomb
  • c32rtomb
  • cabs
  • cabsf
  • cabsl
  • cacos
  • cacosf
  • cacosh
  • cacoshf
  • cacoshl
  • cacosl
  • calloc
  • carg
  • cargf
  • cargl
  • casin
  • casinf
  • casinh
  • casinhf
  • casinhl
  • casinl
  • catan
  • catanf
  • catanh
  • catanhf
  • catanhl
  • catanl
  • catclose
  • catgets
  • catopen
  • cbrt
  • cbrtf
  • cbrtl
  • ccos
  • ccosf
  • ccosh
  • ccoshf
  • ccoshl
  • ccosl
  • ceil
  • ceilf
  • ceill
  • cexp
  • cexpf
  • cexpl
  • cfgetispeed
  • cfgetospeed
  • cfsetispeed
  • cfsetospeed
  • chdir
  • chmod
  • chown
  • cimag
  • cimagf
  • cimagl
  • clearerr
  • clock
  • clock_getcpuclockid
  • clock_getres
  • clock_gettime
  • clock_nanosleep
  • clock_settime
  • clog
  • clogf
  • clogl
  • close
  • closedir
  • closelog
  • confstr
  • conj
  • conjf
  • conjl
  • connect
  • copysign
  • copysignf
  • copysignl
  • cos
  • cosf
  • cosh
  • coshf
  • coshl
  • cosl
  • cpow
  • cpowf
  • cpowl
  • cproj
  • cprojf
  • cprojl
  • creal
  • crealf
  • creall
  • creat
  • crypt
  • csin
  • csinf
  • csinh
  • csinhf
  • csinhl
  • csinl
  • csqrt
  • csqrtf
  • csqrtl
  • ctan
  • ctanf
  • ctanh
  • ctanhf
  • ctanhl
  • ctanl
  • ctermid
  • ctime
  • ctime_r
  • daylight
  • dbm_clearerr
  • dbm_close
  • dbm_delete
  • dbm_error
  • dbm_fetch
  • dbm_firstkey
  • dbm_nextkey
  • dbm_open
  • dbm_store
  • difftime
  • dirfd
  • dirname
  • div
  • dlclose
  • dlerror
  • dlopen
  • dlsym
  • dprintf
  • drand48
  • dup
  • dup2
  • duplocale
  • encrypt
  • endgrent
  • endhostent
  • endnetent
  • endprotoent
  • endpwent
  • endservent
  • endutxent
  • environ
  • erand48
  • erf
  • erfc
  • erfcf
  • erfcl
  • erff
  • erfl
  • errno
  • execl
  • execle
  • execlp
  • execv
  • execve
  • execvp
  • exit
  • exp
  • exp2
  • exp2f
  • exp2l
  • expf
  • expl
  • expm1
  • expm1f
  • expm1l
  • fabs
  • fabsf
  • fabsl
  • faccessat
  • fattach
  • fchdir
  • fchmod
  • fchmodat
  • fchown
  • fchownat
  • fclose
  • fcntl
  • fdatasync
  • fdetach
  • fdim
  • fdimf
  • fdiml
  • fdopen
  • fdopendir
  • feclearexcept
  • fegetenv
  • fegetexceptflag
  • fegetround
  • feholdexcept
  • feof
  • feraiseexcept
  • ferror
  • fesetenv
  • fesetexceptflag
  • fesetround
  • fetestexcept
  • feupdateenv
  • fexecve
  • fflush
  • ffs
  • fgetc
  • fgetpos
  • fgets
  • fgetwc
  • fgetws
  • fileno
  • flockfile
  • floor
  • floorf
  • floorl
  • fma
  • fmaf
  • fmal
  • fmax
  • fmaxf
  • fmaxl
  • fmemopen
  • fmin
  • fminf
  • fminl
  • fmod
  • fmodf
  • fmodl
  • fmtmsg
  • fnmatch
  • fopen
  • fork
  • fpathconf
  • fpclassify
  • fprintf
  • fputc
  • fputs
  • fputwc
  • fputws
  • fread
  • free
  • freeaddrinfo
  • freelocale
  • freopen
  • frexp
  • frexpf
  • frexpl
  • fscanf
  • fseek
  • fseeko
  • fsetpos
  • fstat
  • fstatat
  • fstatvfs
  • fsync
  • ftell
  • ftello
  • ftok
  • ftruncate
  • ftrylockfile
  • ftw
  • funlockfile
  • futimens
  • fwide
  • fwprintf
  • fwrite
  • fwscanf
  • gai_strerror
  • getaddrinfo
  • getc
  • getc_unlocked
  • getchar
  • getchar_unlocked
  • getcwd
  • getdate
  • getdate_err
  • getdelim
  • getegid
  • getenv
  • geteuid
  • getgid
  • getgrent
  • getgrgid
  • getgrgid_r
  • getgrnam
  • getgrnam_r
  • getgroups
  • gethostent
  • gethostid
  • gethostname
  • getitimer
  • getline
  • getlogin
  • getlogin_r
  • getmsg
  • getnameinfo
  • getnetbyaddr
  • getnetbyname
  • getnetent
  • getopt
  • getpeername
  • getpgid
  • getpgrp
  • getpid
  • getpmsg
  • getppid
  • getpriority
  • getprotobyname
  • getprotobynumber
  • getprotoent
  • getpwent
  • getpwnam
  • getpwnam_r
  • getpwuid
  • getpwuid_r
  • getrlimit
  • getrusage
  • gets
  • getservbyname
  • getservbyport
  • getservent
  • getsid
  • getsockname
  • getsockopt
  • getsubopt
  • gettimeofday
  • getuid
  • getutxent
  • getutxid
  • getutxline
  • getwc
  • getwchar
  • glob
  • globfree
  • gmtime
  • gmtime_r
  • grantpt
  • hcreate
  • hdestroy
  • hsearch
  • htonl
  • htons
  • hypot
  • hypotf
  • hypotl
  • iconv
  • iconv_close
  • iconv_open
  • if_freenameindex
  • if_indextoname
  • if_nameindex
  • if_nametoindex
  • ilogb
  • ilogbf
  • ilogbl
  • imaxabs
  • imaxdiv
  • inet_addr
  • inet_ntoa
  • inet_ntop
  • inet_pton
  • initstate
  • insque
  • ioctl
  • isalnum
  • isalnum_l
  • isalpha
  • isalpha_l
  • isascii
  • isastream
  • isatty
  • isblank
  • isblank_l
  • iscntrl
  • iscntrl_l
  • isdigit
  • isdigit_l
  • isfinite
  • isgraph
  • isgraph_l
  • isgreater
  • isgreaterequal
  • isinf
  • isless
  • islessequal
  • islessgreater
  • islower
  • islower_l
  • isnan
  • isnormal
  • isprint
  • isprint_l
  • ispunct
  • ispunct_l
  • isspace
  • isspace_l
  • isunordered
  • isupper
  • isupper_l
  • iswalnum
  • iswalnum_l
  • iswalpha
  • iswalpha_l
  • iswblank
  • iswblank_l
  • iswcntrl
  • iswcntrl_l
  • iswctype
  • iswctype_l
  • iswdigit
  • iswdigit_l
  • iswgraph
  • iswgraph_l
  • iswlower
  • iswlower_l
  • iswprint
  • iswprint_l
  • iswpunct
  • iswpunct_l
  • iswspace
  • iswspace_l
  • iswupper
  • iswupper_l
  • iswxdigit
  • iswxdigit_l
  • isxdigit
  • isxdigit_l
  • j0
  • j1
  • jn
  • jrand48
  • kill
  • killpg
  • l64a
  • labs
  • lchown
  • lcong48
  • ldexp
  • ldexpf
  • ldexpl
  • ldiv
  • lfind
  • lgamma
  • lgammaf
  • lgammal
  • link
  • linkat
  • lio_listio
  • listen
  • llabs
  • lldiv
  • llrint
  • llrintf
  • llrintl
  • llround
  • llroundf
  • llroundl
  • localeconv
  • localtime
  • localtime_r
  • lockf
  • log
  • log10
  • log10f
  • log10l
  • log1p
  • log1pf
  • log1pl
  • log2
  • log2f
  • log2l
  • logb
  • logbf
  • logbl
  • logf
  • logl
  • longjmp
  • lrand48
  • lrint
  • lrintf
  • lrintl
  • lround
  • lroundf
  • lroundl
  • lsearch
  • lseek
  • lstat
  • malloc
  • mblen
  • mbrlen
  • mbrtoc16
  • mbrtoc32
  • mbrtowc
  • mbsinit
  • mbsnrtowcs
  • mbsrtowcs
  • mbstowcs
  • mbtowc
  • memccpy
  • memchr
  • memcmp
  • memcpy
  • memmove
  • memset
  • mkdir
  • mkdirat
  • mkdtemp
  • mkfifo
  • mkfifoat
  • mknod
  • mknodat
  • mkstemp
  • mktime
  • mlock
  • mlockall
  • mmap
  • modf
  • modff
  • modfl
  • mprotect
  • mq_close
  • mq_getattr
  • mq_notify
  • mq_open
  • mq_receive
  • mq_send
  • mq_setattr
  • mq_timedreceive
  • mq_timedsend
  • mq_unlink
  • mrand48
  • msgctl
  • msgget
  • msgrcv
  • msgsnd
  • msync
  • munlock
  • munlockall
  • munmap
  • nan
  • nanf
  • nanl
  • nanosleep
  • nearbyint
  • nearbyintf
  • nearbyintl
  • newlocale
  • nextafter
  • nextafterf
  • nextafterl
  • nexttoward
  • nexttowardf
  • nexttowardl
  • nftw
  • nice
  • nl_langinfo
  • nl_langinfo_l
  • nrand48
  • ntohl
  • ntohs
  • open
  • openat
  • opendir
  • openlog
  • open_memstream
  • open_wmemstream
  • optarg
  • opterr
  • optind
  • optopt
  • pathconf
  • pause
  • pclose
  • perror
  • pipe
  • poll
  • popen
  • posix_fadvise
  • posix_fallocate
  • posix_madvise
  • posix_mem_offset
  • posix_memalign
  • posix_openpt
  • posix_spawn
  • posix_spawn_file_actions_addclose
  • posix_spawn_file_actions_adddup2
  • posix_spawn_file_actions_addopen
  • posix_spawn_file_actions_destroy
  • posix_spawn_file_actions_init
  • posix_spawnattr_destroy
  • posix_spawnattr_getflags
  • posix_spawnattr_getpgroup
  • posix_spawnattr_getschedparam
  • posix_spawnattr_getschedpolicy
  • posix_spawnattr_getsigdefault
  • posix_spawnattr_getsigmask
  • posix_spawnattr_init
  • posix_spawnattr_setflags
  • posix_spawnattr_setpgroup
  • posix_spawnattr_setschedparam
  • posix_spawnattr_setschedpolicy
  • posix_spawnattr_setsigdefault
  • posix_spawnattr_setsigmask
  • posix_spawnp
  • posix_trace_attr_destroy
  • posix_trace_attr_getclockres
  • posix_trace_attr_getcreatetime
  • posix_trace_attr_getgenversion
  • posix_trace_attr_getinherited
  • posix_trace_attr_getlogfullpolicy
  • posix_trace_attr_getlogsize
  • posix_trace_attr_getmaxdatasize
  • posix_trace_attr_getmaxsystemeventsize
  • posix_trace_attr_getmaxusereventsize
  • posix_trace_attr_getname
  • posix_trace_attr_getstreamfullpolicy
  • posix_trace_attr_getstreamsize
  • posix_trace_attr_init
  • posix_trace_attr_setinherited
  • posix_trace_attr_setlogfullpolicy
  • posix_trace_attr_setlogsize
  • posix_trace_attr_setmaxdatasize
  • posix_trace_attr_setname
  • posix_trace_attr_setstreamfullpolicy
  • posix_trace_attr_setstreamsize
  • posix_trace_clear
  • posix_trace_close
  • posix_trace_create
  • posix_trace_create_withlog
  • posix_trace_event
  • posix_trace_eventid_equal
  • posix_trace_eventid_get_name
  • posix_trace_eventid_open
  • posix_trace_eventset_add
  • posix_trace_eventset_del
  • posix_trace_eventset_empty
  • posix_trace_eventset_fill
  • posix_trace_eventset_ismember
  • posix_trace_eventtypelist_getnext_id
  • posix_trace_eventtypelist_rewind
  • posix_trace_flush
  • posix_trace_get_attr
  • posix_trace_get_filter
  • posix_trace_get_status
  • posix_trace_getnext_event
  • posix_trace_open
  • posix_trace_rewind
  • posix_trace_set_filter
  • posix_trace_shutdown
  • posix_trace_start
  • posix_trace_stop
  • posix_trace_timedgetnext_event
  • posix_trace_trid_eventid_open
  • posix_trace_trygetnext_event
  • posix_typed_mem_get_info
  • posix_typed_mem_open
  • pow
  • powf
  • powl
  • pread
  • printf
  • pselect
  • psiginfo
  • psignal
  • pthread_atfork
  • pthread_attr_destroy
  • pthread_attr_getdetachstate
  • pthread_attr_getguardsize
  • pthread_attr_getinheritsched
  • pthread_attr_getschedparam
  • pthread_attr_getschedpolicy
  • pthread_attr_getscope
  • pthread_attr_getstack
  • pthread_attr_getstacksize
  • pthread_attr_init
  • pthread_attr_setdetachstate
  • pthread_attr_setguardsize
  • pthread_attr_setinheritsched
  • pthread_attr_setschedparam
  • pthread_attr_setschedpolicy
  • pthread_attr_setscope
  • pthread_attr_setstack
  • pthread_attr_setstacksize
  • pthread_barrier_destroy
  • pthread_barrier_init
  • pthread_barrier_wait
  • pthread_barrierattr_destroy
  • pthread_barrierattr_getpshared
  • pthread_barrierattr_init
  • pthread_barrierattr_setpshared
  • pthread_cancel
  • pthread_cleanup_pop
  • pthread_cleanup_push
  • pthread_cond_broadcast
  • pthread_cond_destroy
  • pthread_cond_init
  • pthread_cond_signal
  • pthread_cond_timedwait
  • pthread_cond_wait
  • pthread_condattr_destroy
  • pthread_condattr_getclock
  • pthread_condattr_getpshared
  • pthread_condattr_init
  • pthread_condattr_setclock
  • pthread_condattr_setpshared
  • pthread_create
  • pthread_detach
  • pthread_equal
  • pthread_exit
  • pthread_getconcurrency
  • pthread_getcpuclockid
  • pthread_getschedparam
  • pthread_getspecific
  • pthread_join
  • pthread_key_create
  • pthread_key_delete
  • pthread_kill
  • pthread_mutex_consistent
  • pthread_mutex_destroy
  • pthread_mutex_getprioceiling
  • pthread_mutex_init
  • pthread_mutex_lock
  • pthread_mutex_setprioceiling
  • pthread_mutex_timedlock
  • pthread_mutex_trylock
  • pthread_mutex_unlock
  • pthread_mutexattr_destroy
  • pthread_mutexattr_getprioceiling
  • pthread_mutexattr_getprotocol
  • pthread_mutexattr_getpshared
  • pthread_mutexattr_getrobust
  • pthread_mutexattr_gettype
  • pthread_mutexattr_init
  • pthread_mutexattr_setprioceiling
  • pthread_mutexattr_setprotocol
  • pthread_mutexattr_setpshared
  • pthread_mutexattr_setrobust
  • pthread_mutexattr_settype
  • pthread_once
  • pthread_rwlock_destroy
  • pthread_rwlock_init
  • pthread_rwlock_rdlock
  • pthread_rwlock_timedrdlock
  • pthread_rwlock_timedwrlock
  • pthread_rwlock_tryrdlock
  • pthread_rwlock_trywrlock
  • pthread_rwlock_unlock
  • pthread_rwlock_wrlock
  • pthread_rwlockattr_destroy
  • pthread_rwlockattr_getpshared
  • pthread_rwlockattr_init
  • pthread_rwlockattr_setpshared
  • pthread_self
  • pthread_setcancelstate
  • pthread_setcanceltype
  • pthread_setconcurrency
  • pthread_setschedparam
  • pthread_setschedprio
  • pthread_setspecific
  • pthread_sigmask
  • pthread_spin_destroy
  • pthread_spin_init
  • pthread_spin_lock
  • pthread_spin_trylock
  • pthread_spin_unlock
  • pthread_testcancel
  • ptsname
  • putc
  • putc_unlocked
  • putchar
  • putchar_unlocked
  • putenv
  • putmsg
  • putpmsg
  • puts
  • pututxline
  • putwc
  • putwchar
  • pwrite
  • qsort
  • quick_exit
  • raise
  • rand
  • rand_r
  • random
  • read
  • readdir
  • readdir_r
  • readlink
  • readlinkat
  • readv
  • realloc
  • realpath
  • recv
  • recvfrom
  • recvmsg
  • regcomp
  • regerror
  • regexec
  • regfree
  • remainder
  • remainderf
  • remainderl
  • remove
  • remque
  • remquo
  • remquof
  • remquol
  • rename
  • renameat
  • rewind
  • rewinddir
  • rint
  • rintf
  • rintl
  • rmdir
  • round
  • roundf
  • roundl
  • scalbln
  • scalblnf
  • scalblnl
  • scalbn
  • scalbnf
  • scalbnl
  • scandir
  • scanf
  • sched_get_priority_max
  • sched_get_priority_min
  • sched_getparam
  • sched_getscheduler
  • sched_rr_get_interval
  • sched_setparam
  • sched_setscheduler
  • sched_yield
  • seed48
  • seekdir
  • select
  • sem_close
  • sem_destroy
  • sem_getvalue
  • sem_init
  • sem_open
  • sem_post
  • sem_timedwait
  • sem_trywait
  • sem_unlink
  • sem_wait
  • semctl
  • semget
  • semop
  • send
  • sendmsg
  • sendto
  • setbuf
  • setegid
  • setenv
  • seteuid
  • setgid
  • setgrent
  • sethostent
  • setitimer
  • setjmp
  • setkey
  • setlocale
  • setlogmask
  • setnetent
  • setpgid
  • setpgrp
  • setpriority
  • setprotoent
  • setpwent
  • setregid
  • setreuid
  • setrlimit
  • setservent
  • setsid
  • setsockopt
  • setstate
  • setuid
  • setutxent
  • setvbuf
  • shm_open
  • shm_unlink
  • shmat
  • shmctl
  • shmdt
  • shmget
  • shutdown
  • sigaction
  • sigaddset
  • sigaltstack
  • sigdelset
  • sigemptyset
  • sigfillset
  • sighold
  • sigignore
  • siginterrupt
  • sigismember
  • siglongjmp
  • signal
  • signbit
  • signgam
  • sigpause
  • sigpending
  • sigprocmask
  • sigqueue
  • sigrelse
  • sigset
  • sigsetjmp
  • sigsuspend
  • sigtimedwait
  • sigwait
  • sigwaitinfo
  • sin
  • sinf
  • sinh
  • sinhf
  • sinhl
  • sinl
  • sleep
  • snprintf
  • sockatmark
  • socket
  • socketpair
  • sprintf
  • sqrt
  • sqrtf
  • sqrtl
  • srand
  • srand48
  • srandom
  • sscanf
  • stat
  • statvfs
  • stderr
  • stdin
  • stdout
  • stpcpy
  • stpncpy
  • strcasecmp
  • strcasecmp_l
  • strcat
  • strchr
  • strcmp
  • strcoll
  • strcoll_l
  • strcpy
  • strcspn
  • strdup
  • strerror
  • strerror_l
  • strerror_r
  • strfmon
  • strfmon_l
  • strftime
  • strftime_l
  • strlen
  • strncasecmp
  • strncasecmp_l
  • strncat
  • strncmp
  • strncpy
  • strndup
  • strnlen
  • strpbrk
  • strptime
  • strrchr
  • strsignal
  • strspn
  • strstr
  • strtod
  • strtof
  • strtoimax
  • strtok
  • strtok_r
  • strtol
  • strtold
  • strtoll
  • strtoul
  • strtoull
  • strtoumax
  • strxfrm
  • strxfrm_l
  • swab
  • swprintf
  • swscanf
  • symlink
  • symlinkat
  • sync
  • sysconf
  • syslog
  • system
  • tan
  • tanf
  • tanh
  • tanhf
  • tanhl
  • tanl
  • tcdrain
  • tcflow
  • tcflush
  • tcgetattr
  • tcgetpgrp
  • tcgetsid
  • tcsendbreak
  • tcsetattr
  • tcsetpgrp
  • tdelete
  • telldir
  • tempnam
  • tfind
  • tgamma
  • tgammaf
  • tgammal
  • time
  • timer_create
  • timer_delete
  • timer_getoverrun
  • timer_gettime
  • timer_settime
  • times
  • timezone
  • tmpfile
  • tmpnam
  • toascii
  • tolower
  • tolower_l
  • toupper
  • toupper_l
  • towctrans
  • towctrans_l
  • towlower
  • towlower_l
  • towupper
  • towupper_l
  • trunc
  • truncate
  • truncf
  • truncl
  • tsearch
  • ttyname
  • ttyname_r
  • twalk
  • tzname
  • tzset
  • ulimit
  • umask
  • uname
  • ungetc
  • ungetwc
  • unlink
  • unlinkat
  • unlockpt
  • unsetenv
  • uselocale
  • utime
  • utimensat
  • utimes
  • va_arg
  • va_copy
  • va_end
  • va_start
  • vdprintf
  • vfprintf
  • vfscanf
  • vfwprintf
  • vfwscanf
  • vprintf
  • vscanf
  • vsnprintf
  • vsprintf
  • vsscanf
  • vswprintf
  • vswscanf
  • vwprintf
  • vwscanf
  • wait
  • waitid
  • waitpid
  • wcpcpy
  • wcpncpy
  • wcrtomb
  • wcscasecmp
  • wcscasecmp_l
  • wcscat
  • wcschr
  • wcscmp
  • wcscoll
  • wcscoll_l
  • wcscpy
  • wcscspn
  • wcsdup
  • wcsftime
  • wcslen
  • wcsncasecmp
  • wcsncasecmp_l
  • wcsncat
  • wcsncmp
  • wcsncpy
  • wcsnlen
  • wcsnrtombs
  • wcspbrk
  • wcsrchr
  • wcsrtombs
  • wcsspn
  • wcsstr
  • wcstod
  • wcstof
  • wcstoimax
  • wcstok
  • wcstol
  • wcstold
  • wcstoll
  • wcstombs
  • wcstoul
  • wcstoull
  • wcstoumax
  • wcswidth
  • wcsxfrm
  • wcsxfrm_l
  • wctob
  • wctomb
  • wctrans
  • wctrans_l
  • wctype
  • wctype_l
  • wcwidth
  • wmemchr
  • wmemcmp
  • wmemcpy
  • wmemmove
  • wmemset
  • wordexp
  • wordfree
  • wprintf
  • write
  • writev
  • wscanf
  • y0
  • y1
  • yn

    • Next: Legacy Function Substitutes Prev: Header File Substitutes Top: Top


FD_CLR -- GNU Gnulib

Next: FD_ISSET Up: Function Substitutes Top: Top

9.1. FD_CLR

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/FD_CLR.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: FD_ISSET Up: Function Substitutes Top: Top


FD_ISSET -- GNU Gnulib

Next: FD_SET Prev: FD_CLR Up: Function Substitutes Top: Top

9.2. FD_ISSET

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/FD_ISSET.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: FD_SET Prev: FD_CLR Up: Function Substitutes Top: Top


FD_SET -- GNU Gnulib

Next: FD_ZERO Prev: FD_ISSET Up: Function Substitutes Top: Top

9.3. FD_SET

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/FD_SET.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: FD_ZERO Prev: FD_ISSET Up: Function Substitutes Top: Top


FD_ZERO -- GNU Gnulib

Next: _Exit Prev: FD_SET Up: Function Substitutes Top: Top

9.4. FD_ZERO

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/FD_ZERO.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: _Exit Prev: FD_SET Up: Function Substitutes Top: Top


_exit -- GNU Gnulib

Next: _longjmp Prev: _Exit Up: Function Substitutes Top: Top

9.6. _exit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/_exit.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: _longjmp Prev: _Exit Up: Function Substitutes Top: Top


_longjmp -- GNU Gnulib

Next: _setjmp Prev: _exit Up: Function Substitutes Top: Top

9.7. _longjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/_longjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.5.1, mingw, MSVC 14.
Note: A future revision of POSIX later than the 2008/2009 one may drop the functions _setjmp and _longjmp. Still, in 2008, on all systems which have _setjmp, it is the fastest way to save the registers but not the signal mask (up to 30 times faster than setjmp on some systems).

Next: _setjmp Prev: _exit Up: Function Substitutes Top: Top


_setjmp -- GNU Gnulib

Next: _tolower Prev: _longjmp Up: Function Substitutes Top: Top

9.8. _setjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/_setjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.5.1.
Note: A future revision of POSIX later than the 2008/2009 one may drop the functions _setjmp and _longjmp. Still, in 2008, on all systems which have _setjmp, it is the fastest way to save the registers but not the signal mask (up to 30 times faster than setjmp on some systems).

Next: _tolower Prev: _longjmp Up: Function Substitutes Top: Top


_tolower -- GNU Gnulib

Next: _toupper Prev: _setjmp Up: Function Substitutes Top: Top

9.9. _tolower

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/_tolower.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8.

Next: _toupper Prev: _setjmp Up: Function Substitutes Top: Top


_toupper -- GNU Gnulib

Next: a64l Prev: _tolower Up: Function Substitutes Top: Top

9.10. _toupper

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/_toupper.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8.

Next: a64l Prev: _tolower Up: Function Substitutes Top: Top


a64l -- GNU Gnulib

Next: abort Prev: _toupper Up: Function Substitutes Top: Top

9.11. a64l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/a64l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function was not correctly implemented in glibc versions before 2.2.5.

Next: abort Prev: _toupper Up: Function Substitutes Top: Top


abort -- GNU Gnulib

Next: abs Prev: a64l Up: Function Substitutes Top: Top

9.12. abort

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/abort.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • Some platforms mistakenly close all stdio streams prior to raising SIGABRT: Cygwin 1.5.x.

  • Some platforms always print a message to stderr, even if a SIGABRT handler uses longjmp to resume execution at a safe point: mingw, MSVC 14.

Next: abs Prev: a64l Up: Function Substitutes Top: Top


abs -- GNU Gnulib

Next: accept Prev: abort Up: Function Substitutes Top: Top

9.13. abs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/abs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: accept Prev: abort Up: Function Substitutes Top: Top


accept -- GNU Gnulib

Next: access Prev: abs Up: Function Substitutes Top: Top

9.14. accept

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/accept.html

Gnulib module: accept

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), the descriptors returned by the accept function cannot be used in calls to read, write, and close; you have to use recv, send, closesocket in these cases instead.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • On BeOS, the descriptors returned by the accept function cannot be used in calls to read, write, and close; you have to use recv, send, closesocket in these cases instead.
  • Some platforms don't have a socklen_t type; in this case this function's third argument type is `int *'.
  • On some platforms, this function's third argument type is `void *', not `socklen_t *': Solaris 10.

Next: access Prev: abs Up: Function Substitutes Top: Top


access -- GNU Gnulib

Next: acos Prev: accept Up: Function Substitutes Top: Top

9.15. access

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/access.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function uses the effective id instead of the real id on some platforms: Cygwin 1.5.x.
Other problems of this function:
  • There is an inherent race between calling this function and performing some action based on the results; you should think twice before trusting this function, especially in a set-uid or set-gid program.
  • This function does not have an option for not following symbolic links (like stat versus lstat). If you need this option, use the Gnulib module faccessat with the AT_EACCESS flag.

Next: acos Prev: accept Up: Function Substitutes Top: Top


acos -- GNU Gnulib

Next: acosf Prev: access Up: Function Substitutes Top: Top

9.16. acos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acos.html

Gnulib module: acos

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: acosf Prev: access Up: Function Substitutes Top: Top


acosf -- GNU Gnulib

Next: acosh Prev: acos Up: Function Substitutes Top: Top

9.17. acosf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acosf.html

Gnulib module: acosf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: acosh Prev: acos Up: Function Substitutes Top: Top


acosh -- GNU Gnulib

Next: acoshf Prev: acosf Up: Function Substitutes Top: Top

9.18. acosh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acosh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 9.

Next: acoshf Prev: acosf Up: Function Substitutes Top: Top


acoshf -- GNU Gnulib

Next: acoshl Prev: acosh Up: Function Substitutes Top: Top

9.19. acoshf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acoshf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, mingw, MSVC 9.

Next: acoshl Prev: acosh Up: Function Substitutes Top: Top


acoshl -- GNU Gnulib

Next: acosl Prev: acoshf Up: Function Substitutes Top: Top

9.20. acoshl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acoshl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: acosl Prev: acoshf Up: Function Substitutes Top: Top


acosl -- GNU Gnulib

Next: aio_cancel Prev: acoshl Up: Function Substitutes Top: Top

9.21. acosl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/acosl.html

Gnulib module: acosl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: aio_cancel Prev: acoshl Up: Function Substitutes Top: Top


aio_cancel -- GNU Gnulib

Next: aio_error Prev: acosl Up: Function Substitutes Top: Top

9.22. aio_cancel

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_cancel.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_error Prev: acosl Up: Function Substitutes Top: Top


aio_error -- GNU Gnulib

Next: aio_fsync Prev: aio_cancel Up: Function Substitutes Top: Top

9.23. aio_error

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_error.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_fsync Prev: aio_cancel Up: Function Substitutes Top: Top


aio_fsync -- GNU Gnulib

Next: aio_read Prev: aio_error Up: Function Substitutes Top: Top

9.24. aio_fsync

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_fsync.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_read Prev: aio_error Up: Function Substitutes Top: Top


aio_read -- GNU Gnulib

Next: aio_return Prev: aio_fsync Up: Function Substitutes Top: Top

9.25. aio_read

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_read.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_return Prev: aio_fsync Up: Function Substitutes Top: Top


aio_return -- GNU Gnulib

Next: aio_suspend Prev: aio_read Up: Function Substitutes Top: Top

9.26. aio_return

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_return.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_suspend Prev: aio_read Up: Function Substitutes Top: Top


aio_suspend -- GNU Gnulib

Next: aio_write Prev: aio_return Up: Function Substitutes Top: Top

9.27. aio_suspend

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_suspend.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: aio_write Prev: aio_return Up: Function Substitutes Top: Top


aio_write -- GNU Gnulib

Next: alarm Prev: aio_suspend Up: Function Substitutes Top: Top

9.28. aio_write

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/aio_write.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: alarm Prev: aio_suspend Up: Function Substitutes Top: Top


alarm -- GNU Gnulib

Next: aligned_alloc Prev: aio_write Up: Function Substitutes Top: Top

9.29. alarm

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/alarm.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function has no impact if <code>SIGALRM</code> is inherited as ignored; programs should use <code>signal (SIGALRM, SIG_DFL)</code> if it is important to ensure the alarm will fire.
  • Use of this function in multi-threaded applications is not advised.
  • This function is missing on some platforms: mingw (2011), MSVC 14.
  • This function is conditionally declared in the non-standard <io.h> header on some platforms: mingw (2012 or newer).

Next: aligned_alloc Prev: aio_write Up: Function Substitutes Top: Top


aligned_alloc -- GNU Gnulib

Next: alphasort Prev: alarm Up: Function Substitutes Top: Top

9.30. aligned_alloc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: alphasort Prev: alarm Up: Function Substitutes Top: Top


alphasort -- GNU Gnulib

Next: asctime Prev: aligned_alloc Up: Function Substitutes Top: Top

9.31. alphasort

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/alphasort.html

Gnulib module: alphasort

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, Solaris 9, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • The parameters of this function are declared as const void * on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Interix 3.5.
  • The parameters of this function are declared as void * on some platforms: AIX 5.1.

Next: asctime Prev: aligned_alloc Up: Function Substitutes Top: Top


asctime -- GNU Gnulib

Next: asctime_r Prev: alphasort Up: Function Substitutes Top: Top

9.32. asctime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asctime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function may overflow its internal buffer if an invalid year is passed.

Next: asctime_r Prev: alphasort Up: Function Substitutes Top: Top


asctime_r -- GNU Gnulib

Next: asin Prev: asctime Up: Function Substitutes Top: Top

9.33. asctime_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asctime_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • This function may put more than 26 bytes into the argument buffer if an invalid year is passed.

Next: asin Prev: asctime Up: Function Substitutes Top: Top


asin -- GNU Gnulib

Next: asinf Prev: asctime_r Up: Function Substitutes Top: Top

9.34. asin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asin.html

Gnulib module: asin

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: asinf Prev: asctime_r Up: Function Substitutes Top: Top


asinf -- GNU Gnulib

Next: asinh Prev: asin Up: Function Substitutes Top: Top

9.35. asinf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asinf.html

Gnulib module: asinf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: asinh Prev: asin Up: Function Substitutes Top: Top


asinh -- GNU Gnulib

Next: asinhf Prev: asinf Up: Function Substitutes Top: Top

9.36. asinh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asinh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 9.

Next: asinhf Prev: asinf Up: Function Substitutes Top: Top


asinhf -- GNU Gnulib

Next: asinhl Prev: asinh Up: Function Substitutes Top: Top

9.37. asinhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asinhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, mingw, MSVC 9.

Next: asinhl Prev: asinh Up: Function Substitutes Top: Top


asinhl -- GNU Gnulib

Next: asinl Prev: asinhf Up: Function Substitutes Top: Top

9.38. asinhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asinhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: asinl Prev: asinhf Up: Function Substitutes Top: Top


asinl -- GNU Gnulib

Next: assert Prev: asinhl Up: Function Substitutes Top: Top

9.39. asinl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/asinl.html

Gnulib module: asinl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: assert Prev: asinhl Up: Function Substitutes Top: Top


assert -- GNU Gnulib

Next: atan Prev: asinl Up: Function Substitutes Top: Top

9.40. assert

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/assert.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
Extension: Gnulib offers a module `assert' that allows the installer to disable assertions through a `configure' option: `--disable-assert'.

Next: atan Prev: asinl Up: Function Substitutes Top: Top


atan -- GNU Gnulib

Next: atan2 Prev: assert Up: Function Substitutes Top: Top

9.41. atan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atan.html

Gnulib module: atan

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: atan2 Prev: assert Up: Function Substitutes Top: Top


atan2 -- GNU Gnulib

Next: atan2f Prev: atan Up: Function Substitutes Top: Top

9.42. atan2

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atan2.html

Gnulib module: atan2

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: atan2f Prev: atan Up: Function Substitutes Top: Top


atan2f -- GNU Gnulib

Next: atan2l Prev: atan2 Up: Function Substitutes Top: Top

9.43. atan2f

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atan2f.html

Gnulib module: atan2f

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: atan2l Prev: atan2 Up: Function Substitutes Top: Top


atan2l -- GNU Gnulib

Next: atanf Prev: atan2f Up: Function Substitutes Top: Top

9.44. atan2l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atan2l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.

Next: atanf Prev: atan2f Up: Function Substitutes Top: Top


atanf -- GNU Gnulib

Next: atanh Prev: atan2l Up: Function Substitutes Top: Top

9.45. atanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atanf.html

Gnulib module: atanf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: atanh Prev: atan2l Up: Function Substitutes Top: Top


atanh -- GNU Gnulib

Next: atanhf Prev: atanf Up: Function Substitutes Top: Top

9.46. atanh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atanh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 9.

Next: atanhf Prev: atanf Up: Function Substitutes Top: Top


atanhf -- GNU Gnulib

Next: atanhl Prev: atanh Up: Function Substitutes Top: Top

9.47. atanhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atanhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, mingw, MSVC 9.

Next: atanhl Prev: atanh Up: Function Substitutes Top: Top


atanhl -- GNU Gnulib

Next: atanl Prev: atanhf Up: Function Substitutes Top: Top

9.48. atanhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atanhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: atanl Prev: atanhf Up: Function Substitutes Top: Top


atanl -- GNU Gnulib

Next: atexit Prev: atanhl Up: Function Substitutes Top: Top

9.49. atanl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atanl.html

Gnulib module: atanl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: atexit Prev: atanhl Up: Function Substitutes Top: Top


atexit -- GNU Gnulib

Next: atof Prev: atanl Up: Function Substitutes Top: Top

9.50. atexit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atexit.html

Gnulib module: atexit

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:

Next: atof Prev: atanl Up: Function Substitutes Top: Top


atof -- GNU Gnulib

Next: atoi Prev: atexit Up: Function Substitutes Top: Top

9.51. atof

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atof.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function mis-parses strings with leading `+' on some old platforms: Old versions of Linux.

  • This function returns a positive value for negative underflow on some platforms: glibc 2.4, Mingw, Cygwin.

  • This function fails to do a valid parse of `-0x' on some platforms: glibc 2.4, Cygwin < 1.5.25-11.

  • This function fails to parse Infinities and plain NaNs on some platforms: Solaris 8, Mingw, OpenBSD 4.0.

  • This function fails to parse NaN() on some platforms: Solaris 8, Mingw, OpenBSD 4.0, Cygwin < 1.5.25-11.

  • This function fails to parse NaN(n-char-sequence) on some platforms: Solaris 8, Mingw, OpenBSD 4.0.

  • This function fails to parse C99 hexadecimal floating point on some platforms: Solaris 8, Mingw, OpenBSD 4.0.

  • This function fails to correctly parse very long strings on some platforms: Mingw, Cygwin.

Next: atoi Prev: atexit Up: Function Substitutes Top: Top


atoi -- GNU Gnulib

Next: atol Prev: atof Up: Function Substitutes Top: Top

9.52. atoi

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atoi.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: atol Prev: atof Up: Function Substitutes Top: Top


atol -- GNU Gnulib

Next: atoll Prev: atoi Up: Function Substitutes Top: Top

9.53. atol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atol.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: atoll Prev: atoi Up: Function Substitutes Top: Top


atoll -- GNU Gnulib

Next: basename Prev: atol Up: Function Substitutes Top: Top

9.54. atoll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/atoll.html

Gnulib module: atoll

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.23, OSF/1 5.1, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: basename Prev: atol Up: Function Substitutes Top: Top


basename -- GNU Gnulib

Next: bind Prev: atoll Up: Function Substitutes Top: Top

9.55. basename

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/basename.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: IRIX 6.5, Solaris 2.5.1, mingw, MSVC 14, BeOS.
  • glibc has two different functions basename: the POSIX version and the GNU version.
  • basename assumes file names in POSIX syntax; it does not work with file names in Windows syntax.
The Gnulib module dirname provides similar API, with function base_name, that also works with Windows file names.

Next: bind Prev: atoll Up: Function Substitutes Top: Top


bind -- GNU Gnulib

Next: bsearch Prev: basename Up: Function Substitutes Top: Top

9.56. bind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/bind.html

Gnulib module: bind

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: bsearch Prev: basename Up: Function Substitutes Top: Top


bsearch -- GNU Gnulib

Next: btowc Prev: bind Up: Function Substitutes Top: Top

9.57. bsearch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/bsearch.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: btowc Prev: bind Up: Function Substitutes Top: Top


btowc -- GNU Gnulib

Next: c16rtomb Prev: bsearch Up: Function Substitutes Top: Top

9.58. btowc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/btowc.html

Gnulib module: btowc

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 5.3, Solaris 2.6, mingw, Interix 3.5.
  • This function returns WEOF for a NUL argument on some platforms: Cygwin 1.7.2.
  • This function does not return WEOF for an EOF argument on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • In the C or POSIX locales, this function is not consistent with Gnulib's mbrtowc and can return WEOF: glibc 2.23, MirOS BSD #10.

Next: c16rtomb Prev: bsearch Up: Function Substitutes Top: Top


c16rtomb -- GNU Gnulib

Next: c32rtomb Prev: btowc Up: Function Substitutes Top: Top

9.59. c16rtomb

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on most non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: c32rtomb Prev: btowc Up: Function Substitutes Top: Top


c32rtomb -- GNU Gnulib

Next: cabs Prev: c16rtomb Up: Function Substitutes Top: Top

9.60. c32rtomb

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on most non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cabs Prev: c16rtomb Up: Function Substitutes Top: Top


cabs -- GNU Gnulib

Next: cabsf Prev: c32rtomb Up: Function Substitutes Top: Top

9.61. cabs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cabs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 9.

Next: cabsf Prev: c32rtomb Up: Function Substitutes Top: Top


cabsf -- GNU Gnulib

Next: cabsl Prev: cabs Up: Function Substitutes Top: Top

9.62. cabsf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cabsf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, mingw, MSVC 9.

Next: cabsl Prev: cabs Up: Function Substitutes Top: Top


cabsl -- GNU Gnulib

Next: cacos Prev: cabsf Up: Function Substitutes Top: Top

9.63. cabsl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cabsl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cacos Prev: cabsf Up: Function Substitutes Top: Top


cacos -- GNU Gnulib

Next: cacosf Prev: cabsl Up: Function Substitutes Top: Top

9.64. cacos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacos.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cacosf Prev: cabsl Up: Function Substitutes Top: Top


cacosf -- GNU Gnulib

Next: cacosh Prev: cacos Up: Function Substitutes Top: Top

9.65. cacosf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacosf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cacosh Prev: cacos Up: Function Substitutes Top: Top


cacosh -- GNU Gnulib

Next: cacoshf Prev: cacosf Up: Function Substitutes Top: Top

9.66. cacosh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacosh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cacoshf Prev: cacosf Up: Function Substitutes Top: Top


cacoshf -- GNU Gnulib

Next: cacoshl Prev: cacosh Up: Function Substitutes Top: Top

9.67. cacoshf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacoshf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cacoshl Prev: cacosh Up: Function Substitutes Top: Top


cacoshl -- GNU Gnulib

Next: cacosl Prev: cacoshf Up: Function Substitutes Top: Top

9.68. cacoshl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacoshl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cacosl Prev: cacoshf Up: Function Substitutes Top: Top


cacosl -- GNU Gnulib

Next: calloc Prev: cacoshl Up: Function Substitutes Top: Top

9.69. cacosl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cacosl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: calloc Prev: cacoshl Up: Function Substitutes Top: Top


calloc -- GNU Gnulib

Next: carg Prev: cacosl Up: Function Substitutes Top: Top

9.70. calloc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/calloc.html

Gnulib module: calloc-posix

Portability problems fixed by Gnulib:

  • Upon failure, the function does not set errno to ENOMEM on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
Extension: Gnulib provides a module `calloc-gnu' that substitutes a calloc implementation that behaves more like the glibc implementation.

Next: carg Prev: cacosl Up: Function Substitutes Top: Top


carg -- GNU Gnulib

Next: cargf Prev: calloc Up: Function Substitutes Top: Top

9.71. carg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/carg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cargf Prev: calloc Up: Function Substitutes Top: Top


cargf -- GNU Gnulib

Next: cargl Prev: carg Up: Function Substitutes Top: Top

9.72. cargf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cargf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cargl Prev: carg Up: Function Substitutes Top: Top


cargl -- GNU Gnulib

Next: casin Prev: cargf Up: Function Substitutes Top: Top

9.73. cargl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cargl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: casin Prev: cargf Up: Function Substitutes Top: Top


casin -- GNU Gnulib

Next: casinf Prev: cargl Up: Function Substitutes Top: Top

9.74. casin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casin.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: casinf Prev: cargl Up: Function Substitutes Top: Top


casinf -- GNU Gnulib

Next: casinh Prev: casin Up: Function Substitutes Top: Top

9.75. casinf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casinf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: casinh Prev: casin Up: Function Substitutes Top: Top


casinh -- GNU Gnulib

Next: casinhf Prev: casinf Up: Function Substitutes Top: Top

9.76. casinh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casinh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: casinhf Prev: casinf Up: Function Substitutes Top: Top


casinhf -- GNU Gnulib

Next: casinhl Prev: casinh Up: Function Substitutes Top: Top

9.77. casinhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casinhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: casinhl Prev: casinh Up: Function Substitutes Top: Top


casinhl -- GNU Gnulib

Next: casinl Prev: casinhf Up: Function Substitutes Top: Top

9.78. casinhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casinhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: casinl Prev: casinhf Up: Function Substitutes Top: Top


casinl -- GNU Gnulib

Next: catan Prev: casinhl Up: Function Substitutes Top: Top

9.79. casinl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/casinl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: catan Prev: casinhl Up: Function Substitutes Top: Top


catan -- GNU Gnulib

Next: catanf Prev: casinl Up: Function Substitutes Top: Top

9.80. catan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catan.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: catanf Prev: casinl Up: Function Substitutes Top: Top


catanf -- GNU Gnulib

Next: catanh Prev: catan Up: Function Substitutes Top: Top

9.81. catanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: catanh Prev: catan Up: Function Substitutes Top: Top


catanh -- GNU Gnulib

Next: catanhf Prev: catanf Up: Function Substitutes Top: Top

9.82. catanh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catanh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: catanhf Prev: catanf Up: Function Substitutes Top: Top


catanhf -- GNU Gnulib

Next: catanhl Prev: catanh Up: Function Substitutes Top: Top

9.83. catanhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catanhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: catanhl Prev: catanh Up: Function Substitutes Top: Top


catanhl -- GNU Gnulib

Next: catanl Prev: catanhf Up: Function Substitutes Top: Top

9.84. catanhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catanhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: catanl Prev: catanhf Up: Function Substitutes Top: Top


catanl -- GNU Gnulib

Next: catclose Prev: catanhl Up: Function Substitutes Top: Top

9.85. catanl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catanl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: catclose Prev: catanhl Up: Function Substitutes Top: Top


catclose -- GNU Gnulib

Next: catgets Prev: catanl Up: Function Substitutes Top: Top

9.86. catclose

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catclose.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: catgets Prev: catanl Up: Function Substitutes Top: Top


catgets -- GNU Gnulib

Next: catopen Prev: catclose Up: Function Substitutes Top: Top

9.87. catgets

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catgets.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: catopen Prev: catclose Up: Function Substitutes Top: Top


catopen -- GNU Gnulib

Next: cbrt Prev: catgets Up: Function Substitutes Top: Top

9.88. catopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/catopen.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: cbrt Prev: catgets Up: Function Substitutes Top: Top


cbrt -- GNU Gnulib

Next: cbrtf Prev: catopen Up: Function Substitutes Top: Top

9.89. cbrt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cbrt.html

Gnulib module: cbrt

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
Portability problems not fixed by Gnulib:

Next: cbrtf Prev: catopen Up: Function Substitutes Top: Top


cbrtf -- GNU Gnulib

Next: cbrtl Prev: cbrt Up: Function Substitutes Top: Top

9.90. cbrtf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cbrtf.html

Gnulib module: cbrtf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9, MSVC 9.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function returns a wrong value for a minus zero on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: cbrtl Prev: cbrt Up: Function Substitutes Top: Top


cbrtl -- GNU Gnulib

Next: ccos Prev: cbrtf Up: Function Substitutes Top: Top

9.91. cbrtl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cbrtl.html

Gnulib module: cbrtl or cbrtl-ieee

Portability problems fixed by either Gnulib module cbrtl or cbrtl-ieee

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function produces grossly wrong results on some platforms: OpenBSD 5.1/SPARC.
Portability problems fixed by Gnulib module cbrtl-ieee:
  • This function returns a positive zero for a minus zero argument on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: ccos Prev: cbrtf Up: Function Substitutes Top: Top


ccos -- GNU Gnulib

Next: ccosf Prev: cbrtl Up: Function Substitutes Top: Top

9.92. ccos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccos.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ccosf Prev: cbrtl Up: Function Substitutes Top: Top


ccosf -- GNU Gnulib

Next: ccosh Prev: ccos Up: Function Substitutes Top: Top

9.93. ccosf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccosf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ccosh Prev: ccos Up: Function Substitutes Top: Top


ccosh -- GNU Gnulib

Next: ccoshf Prev: ccosf Up: Function Substitutes Top: Top

9.94. ccosh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccosh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ccoshf Prev: ccosf Up: Function Substitutes Top: Top


ccoshf -- GNU Gnulib

Next: ccoshl Prev: ccosh Up: Function Substitutes Top: Top

9.95. ccoshf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccoshf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ccoshl Prev: ccosh Up: Function Substitutes Top: Top


ccoshl -- GNU Gnulib

Next: ccosl Prev: ccoshf Up: Function Substitutes Top: Top

9.96. ccoshl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccoshl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ccosl Prev: ccoshf Up: Function Substitutes Top: Top


ccosl -- GNU Gnulib

Next: ceil Prev: ccoshl Up: Function Substitutes Top: Top

9.97. ccosl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ccosl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ceil Prev: ccoshl Up: Function Substitutes Top: Top


ceil -- GNU Gnulib

Next: ceilf Prev: ccosl Up: Function Substitutes Top: Top

9.98. ceil

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ceil.html

Gnulib module: ceil or ceil-ieee

Portability problems fixed by either Gnulib module ceil or ceil-ieee:

Portability problems fixed by Gnulib module ceil-ieee:
  • This function returns a positive zero for an argument between -1 and 0 on some platforms: AIX 7.1, OSF/1 5.1.
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: ceilf Prev: ccosl Up: Function Substitutes Top: Top


ceilf -- GNU Gnulib

Next: ceill Prev: ceil Up: Function Substitutes Top: Top

9.99. ceilf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ceilf.html

Gnulib module: ceilf or ceilf-ieee

Portability problems fixed by either Gnulib module ceilf or ceilf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module ceilf-ieee:
  • This function returns a positive zero for an argument between -1 and 0 on some platforms: Mac OS X 10.5, AIX 7.1, OSF/1 5.1.
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: ceill Prev: ceil Up: Function Substitutes Top: Top


ceill -- GNU Gnulib

Next: cexp Prev: ceilf Up: Function Substitutes Top: Top

9.100. ceill

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ceill.html

Gnulib module: ceill or ceill-ieee

Portability problems fixed by either Gnulib module ceill or ceill-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module ceill-ieee:
  • This function returns a positive zero for an argument between -1 and 0 on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: cexp Prev: ceilf Up: Function Substitutes Top: Top


cexp -- GNU Gnulib

Next: cexpf Prev: ceill Up: Function Substitutes Top: Top

9.101. cexp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cexp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cexpf Prev: ceill Up: Function Substitutes Top: Top


cexpf -- GNU Gnulib

Next: cexpl Prev: cexp Up: Function Substitutes Top: Top

9.102. cexpf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cexpf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cexpl Prev: cexp Up: Function Substitutes Top: Top


cexpl -- GNU Gnulib

Next: cfgetispeed Prev: cexpf Up: Function Substitutes Top: Top

9.103. cexpl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cexpl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cfgetispeed Prev: cexpf Up: Function Substitutes Top: Top


cfgetispeed -- GNU Gnulib

Next: cfgetospeed Prev: cexpl Up: Function Substitutes Top: Top

9.104. cfgetispeed

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cfgetispeed.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: cfgetospeed Prev: cexpl Up: Function Substitutes Top: Top


cfgetospeed -- GNU Gnulib

Next: cfsetispeed Prev: cfgetispeed Up: Function Substitutes Top: Top

9.105. cfgetospeed

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cfgetospeed.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: cfsetispeed Prev: cfgetispeed Up: Function Substitutes Top: Top


cfsetispeed -- GNU Gnulib

Next: cfsetospeed Prev: cfgetospeed Up: Function Substitutes Top: Top

9.106. cfsetispeed

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cfsetispeed.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: cfsetospeed Prev: cfgetospeed Up: Function Substitutes Top: Top


cfsetospeed -- GNU Gnulib

Next: chdir Prev: cfsetispeed Up: Function Substitutes Top: Top

9.107. cfsetospeed

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cfsetospeed.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: chdir Prev: cfsetispeed Up: Function Substitutes Top: Top


chdir -- GNU Gnulib

Next: chmod Prev: cfsetospeed Up: Function Substitutes Top: Top

9.108. chdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/chdir.html

Gnulib module: ---

Portability problems fixed by Gnulib:

  • This function is declared in different header files (namely, <io.h> or <direct.h>) on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: chmod Prev: cfsetospeed Up: Function Substitutes Top: Top


chmod -- GNU Gnulib

Next: chown Prev: chdir Up: Function Substitutes Top: Top

9.109. chmod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/chmod.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: chown Prev: chdir Up: Function Substitutes Top: Top


chown -- GNU Gnulib

Next: cimag Prev: chmod Up: Function Substitutes Top: Top

9.110. chown

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/chown.html

Gnulib module: chown

Portability problems fixed by Gnulib:

  • Some platforms fail to detect trailing slash on non-directories, as in chown("link-to-file/",uid,gid): FreeBSD 7.2, AIX 7.1, Solaris 9.
  • Some platforms fail to update the change time when at least one argument was not -1, but no ownership changes resulted: OpenBSD 4.0.
  • When passed an argument of -1, some implementations really set the owner user/group id of the file to this value, rather than leaving that id of the file alone.
  • When applied to a symbolic link, some implementations don't dereference the symlink, i.e. they behave like lchown.
  • This function is missing on some platforms; however, the replacement always fails with ENOSYS: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: cimag Prev: chmod Up: Function Substitutes Top: Top


cimag -- GNU Gnulib

Next: cimagf Prev: chown Up: Function Substitutes Top: Top

9.111. cimag

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cimag.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cimagf Prev: chown Up: Function Substitutes Top: Top


cimagf -- GNU Gnulib

Next: cimagl Prev: cimag Up: Function Substitutes Top: Top

9.112. cimagf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cimagf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cimagl Prev: cimag Up: Function Substitutes Top: Top


cimagl -- GNU Gnulib

Next: clearerr Prev: cimagf Up: Function Substitutes Top: Top

9.113. cimagl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cimagl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: clearerr Prev: cimagf Up: Function Substitutes Top: Top


clearerr -- GNU Gnulib

Next: clock Prev: cimagl Up: Function Substitutes Top: Top

9.114. clearerr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clearerr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: clock Prev: cimagl Up: Function Substitutes Top: Top


clock -- GNU Gnulib

Next: clock_getcpuclockid Prev: clearerr Up: Function Substitutes Top: Top

9.115. clock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: clock_getcpuclockid Prev: clearerr Up: Function Substitutes Top: Top


clock_getcpuclockid -- GNU Gnulib

Next: clock_getres Prev: clock Up: Function Substitutes Top: Top

9.116. clock_getcpuclockid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock_getcpuclockid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: clock_getres Prev: clock Up: Function Substitutes Top: Top


clock_getres -- GNU Gnulib

Next: clock_gettime Prev: clock_getcpuclockid Up: Function Substitutes Top: Top

9.117. clock_getres

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock_getres.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: clock_gettime Prev: clock_getcpuclockid Up: Function Substitutes Top: Top


clock_gettime -- GNU Gnulib

Next: clock_nanosleep Prev: clock_getres Up: Function Substitutes Top: Top

9.118. clock_gettime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock_gettime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: clock_nanosleep Prev: clock_getres Up: Function Substitutes Top: Top


clock_nanosleep -- GNU Gnulib

Next: clock_settime Prev: clock_gettime Up: Function Substitutes Top: Top

9.119. clock_nanosleep

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock_nanosleep.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: clock_settime Prev: clock_gettime Up: Function Substitutes Top: Top


clock_settime -- GNU Gnulib

Next: clog Prev: clock_nanosleep Up: Function Substitutes Top: Top

9.120. clock_settime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clock_settime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: clog Prev: clock_nanosleep Up: Function Substitutes Top: Top


clog -- GNU Gnulib

Next: clogf Prev: clock_settime Up: Function Substitutes Top: Top

9.121. clog

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clog.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: clogf Prev: clock_settime Up: Function Substitutes Top: Top


clogf -- GNU Gnulib

Next: clogl Prev: clog Up: Function Substitutes Top: Top

9.122. clogf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clogf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: clogl Prev: clog Up: Function Substitutes Top: Top


clogl -- GNU Gnulib

Next: close Prev: clogf Up: Function Substitutes Top: Top

9.123. clogl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/clogl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: close Prev: clogf Up: Function Substitutes Top: Top


close -- GNU Gnulib

Next: closedir Prev: clogl Up: Function Substitutes Top: Top

9.124. close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/close.html

Gnulib module: close

Portability problems fixed by Gnulib:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • On Windows platforms (excluding Cygwin), socket and accept do not return file descriptors that can be closed by close. Instead, closesocket must be used.
Portability problems not fixed by Gnulib:
  • On BeOS, socket and accept do not return file descriptors that can be closed by close. Instead, closesocket must be used.

Next: closedir Prev: clogl Up: Function Substitutes Top: Top


closedir -- GNU Gnulib

Next: closelog Prev: close Up: Function Substitutes Top: Top

9.125. closedir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/closedir.html

Gnulib module: closedir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: closelog Prev: close Up: Function Substitutes Top: Top


closelog -- GNU Gnulib

Next: confstr Prev: closedir Up: Function Substitutes Top: Top

9.126. closelog

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/closelog.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: confstr Prev: closedir Up: Function Substitutes Top: Top


confstr -- GNU Gnulib

Next: conj Prev: closelog Up: Function Substitutes Top: Top

9.127. confstr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/confstr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Cygwin 1.5.x, mingw, MSVC 14.

Next: conj Prev: closelog Up: Function Substitutes Top: Top


conj -- GNU Gnulib

Next: conjf Prev: confstr Up: Function Substitutes Top: Top

9.128. conj

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/conj.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: conjf Prev: confstr Up: Function Substitutes Top: Top


conjf -- GNU Gnulib

Next: conjl Prev: conj Up: Function Substitutes Top: Top

9.129. conjf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/conjf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: conjl Prev: conj Up: Function Substitutes Top: Top


conjl -- GNU Gnulib

Next: connect Prev: conjf Up: Function Substitutes Top: Top

9.130. conjl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/conjl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: connect Prev: conjf Up: Function Substitutes Top: Top


connect -- GNU Gnulib

Next: copysign Prev: conjl Up: Function Substitutes Top: Top

9.131. connect

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/connect.html

Gnulib module: connect

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: copysign Prev: conjl Up: Function Substitutes Top: Top


copysign -- GNU Gnulib

Next: copysignf Prev: connect Up: Function Substitutes Top: Top

9.132. copysign

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/copysign.html

Gnulib module: copysign

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
Portability problems not fixed by Gnulib:

Next: copysignf Prev: connect Up: Function Substitutes Top: Top


copysignf -- GNU Gnulib

Next: copysignl Prev: copysign Up: Function Substitutes Top: Top

9.133. copysignf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/copysignf.html

Gnulib module: copysignf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, older IRIX 6.5, Solaris 9, MSVC 9.
  • This function is not declared on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: copysignl Prev: copysign Up: Function Substitutes Top: Top


copysignl -- GNU Gnulib

Next: cos Prev: copysignf Up: Function Substitutes Top: Top

9.134. copysignl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/copysignl.html

Gnulib module: copysignl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: cos Prev: copysignf Up: Function Substitutes Top: Top


cos -- GNU Gnulib

Next: cosf Prev: copysignl Up: Function Substitutes Top: Top

9.135. cos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cos.html

Gnulib module: cos

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: cosf Prev: copysignl Up: Function Substitutes Top: Top


cosf -- GNU Gnulib

Next: cosh Prev: cos Up: Function Substitutes Top: Top

9.136. cosf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cosf.html

Gnulib module: cosf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: cosh Prev: cos Up: Function Substitutes Top: Top


cosh -- GNU Gnulib

Next: coshf Prev: cosf Up: Function Substitutes Top: Top

9.137. cosh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cosh.html

Gnulib module: cosh

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: coshf Prev: cosf Up: Function Substitutes Top: Top


coshf -- GNU Gnulib

Next: coshl Prev: cosh Up: Function Substitutes Top: Top

9.138. coshf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/coshf.html

Gnulib module: coshf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: coshl Prev: cosh Up: Function Substitutes Top: Top


coshl -- GNU Gnulib

Next: cosl Prev: coshf Up: Function Substitutes Top: Top

9.139. coshl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/coshl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.

Next: cosl Prev: coshf Up: Function Substitutes Top: Top


cosl -- GNU Gnulib

Next: cpow Prev: coshl Up: Function Substitutes Top: Top

9.140. cosl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cosl.html

Gnulib module: cosl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: cpow Prev: coshl Up: Function Substitutes Top: Top


cpow -- GNU Gnulib

Next: cpowf Prev: cosl Up: Function Substitutes Top: Top

9.141. cpow

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cpow.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cpowf Prev: cosl Up: Function Substitutes Top: Top


cpowf -- GNU Gnulib

Next: cpowl Prev: cpow Up: Function Substitutes Top: Top

9.142. cpowf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cpowf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: cpowl Prev: cpow Up: Function Substitutes Top: Top


cpowl -- GNU Gnulib

Next: cproj Prev: cpowf Up: Function Substitutes Top: Top

9.143. cpowl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cpowl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: cproj Prev: cpowf Up: Function Substitutes Top: Top


cproj -- GNU Gnulib

Next: cprojf Prev: cpowl Up: Function Substitutes Top: Top

9.144. cproj

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cproj.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.
  • The glibc implementation is or was broken.

Next: cprojf Prev: cpowl Up: Function Substitutes Top: Top


cprojf -- GNU Gnulib

Next: cprojl Prev: cproj Up: Function Substitutes Top: Top

9.145. cprojf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cprojf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.
  • The glibc implementation is or was broken.

Next: cprojl Prev: cproj Up: Function Substitutes Top: Top


cprojl -- GNU Gnulib

Next: creal Prev: cprojf Up: Function Substitutes Top: Top

9.146. cprojl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/cprojl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.
  • The glibc implementation is or was broken.

Next: creal Prev: cprojf Up: Function Substitutes Top: Top


creal -- GNU Gnulib

Next: crealf Prev: cprojl Up: Function Substitutes Top: Top

9.147. creal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/creal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: crealf Prev: cprojl Up: Function Substitutes Top: Top


crealf -- GNU Gnulib

Next: creall Prev: creal Up: Function Substitutes Top: Top

9.148. crealf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/crealf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: creall Prev: creal Up: Function Substitutes Top: Top


creall -- GNU Gnulib

Next: creat Prev: crealf Up: Function Substitutes Top: Top

9.149. creall

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/creall.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: creat Prev: crealf Up: Function Substitutes Top: Top


creat -- GNU Gnulib

Next: crypt Prev: creall Up: Function Substitutes Top: Top

9.150. creat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/creat.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows, this function returns a file handle in O_TEXT mode. If you need a file handle in O_BINARY mode, you need to use the function open instead.
  • On platforms where off_t is a 32-bit type, creat may not work correctly to create files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: crypt Prev: creall Up: Function Substitutes Top: Top


crypt -- GNU Gnulib

Next: csin Prev: creat Up: Function Substitutes Top: Top

9.151. crypt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/crypt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, Cygwin, mingw, MSVC 14.
  • This function is not declared in <unistd.h> (without -D_GNU_SOURCE) on some platforms: glibc (at least 2.11--2.13).

Next: csin Prev: creat Up: Function Substitutes Top: Top


csin -- GNU Gnulib

Next: csinf Prev: crypt Up: Function Substitutes Top: Top

9.152. csin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csin.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csinf Prev: crypt Up: Function Substitutes Top: Top


csinf -- GNU Gnulib

Next: csinh Prev: csin Up: Function Substitutes Top: Top

9.153. csinf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csinf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csinh Prev: csin Up: Function Substitutes Top: Top


csinh -- GNU Gnulib

Next: csinhf Prev: csinf Up: Function Substitutes Top: Top

9.154. csinh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csinh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csinhf Prev: csinf Up: Function Substitutes Top: Top


csinhf -- GNU Gnulib

Next: csinhl Prev: csinh Up: Function Substitutes Top: Top

9.155. csinhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csinhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csinhl Prev: csinh Up: Function Substitutes Top: Top


csinhl -- GNU Gnulib

Next: csinl Prev: csinhf Up: Function Substitutes Top: Top

9.156. csinhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csinhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: csinl Prev: csinhf Up: Function Substitutes Top: Top


csinl -- GNU Gnulib

Next: csqrt Prev: csinhl Up: Function Substitutes Top: Top

9.157. csinl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csinl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: csqrt Prev: csinhl Up: Function Substitutes Top: Top


csqrt -- GNU Gnulib

Next: csqrtf Prev: csinl Up: Function Substitutes Top: Top

9.158. csqrt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csqrt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csqrtf Prev: csinl Up: Function Substitutes Top: Top


csqrtf -- GNU Gnulib

Next: csqrtl Prev: csqrt Up: Function Substitutes Top: Top

9.159. csqrtf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csqrtf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: csqrtl Prev: csqrt Up: Function Substitutes Top: Top


csqrtl -- GNU Gnulib

Next: ctan Prev: csqrtf Up: Function Substitutes Top: Top

9.160. csqrtl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/csqrtl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ctan Prev: csqrtf Up: Function Substitutes Top: Top


ctan -- GNU Gnulib

Next: ctanf Prev: csqrtl Up: Function Substitutes Top: Top

9.161. ctan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctan.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ctanf Prev: csqrtl Up: Function Substitutes Top: Top


ctanf -- GNU Gnulib

Next: ctanh Prev: ctan Up: Function Substitutes Top: Top

9.162. ctanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ctanh Prev: ctan Up: Function Substitutes Top: Top


ctanh -- GNU Gnulib

Next: ctanhf Prev: ctanf Up: Function Substitutes Top: Top

9.163. ctanh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctanh.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ctanhf Prev: ctanf Up: Function Substitutes Top: Top


ctanhf -- GNU Gnulib

Next: ctanhl Prev: ctanh Up: Function Substitutes Top: Top

9.164. ctanhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctanhf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, mingw, MSVC 9, Interix 3.5.

Next: ctanhl Prev: ctanh Up: Function Substitutes Top: Top


ctanhl -- GNU Gnulib

Next: ctanl Prev: ctanhf Up: Function Substitutes Top: Top

9.165. ctanhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctanhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ctanl Prev: ctanhf Up: Function Substitutes Top: Top


ctanl -- GNU Gnulib

Next: ctermid Prev: ctanhl Up: Function Substitutes Top: Top

9.166. ctanl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctanl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: ctermid Prev: ctanhl Up: Function Substitutes Top: Top


ctermid -- GNU Gnulib

Next: ctime Prev: ctanl Up: Function Substitutes Top: Top

9.167. ctermid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctermid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: ctime Prev: ctanl Up: Function Substitutes Top: Top


ctime -- GNU Gnulib

Next: ctime_r Prev: ctermid Up: Function Substitutes Top: Top

9.168. ctime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctime.html

Gnulib module: ctime

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
Portability problems not fixed by Gnulib:
  • This function may overflow its internal buffer if an invalid year is passed.
  • The ctime function need not be reentrant, and consequently is not required to be thread safe. Implementations of ctime typically write the timestamp into static buffer. If two threads call ctime at roughly the same time, you might end up with the wrong date in one of the threads, or some undefined string. There is a re-entrant interface ctime_r.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.
A more flexible function is strftime. However, note that it is locale dependent.

Next: ctime_r Prev: ctermid Up: Function Substitutes Top: Top


ctime_r -- GNU Gnulib

Next: daylight Prev: ctime Up: Function Substitutes Top: Top

9.169. ctime_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ctime_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • This function may put more than 26 bytes into the argument buffer if an invalid year is passed.
ctime_r takes a pre-allocated buffer and length of the buffer, and returns NULL on errors. The input buffer should be at least 26 bytes in size. The output string is locale-independent. However, years can have more than 4 digits if time_t is sufficiently wide, so the length of the required output buffer is not easy to determine. Increasing the buffer size when ctime_r returns NULL is not necessarily sufficient. The NULL return value could mean some other error condition, which will not go away by increasing the buffer size.

A more flexible function is strftime. However, note that it is locale dependent.

Next: daylight Prev: ctime Up: Function Substitutes Top: Top


daylight -- GNU Gnulib

Next: dbm_clearerr Prev: ctime_r Up: Function Substitutes Top: Top

9.170. daylight

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/daylight.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, IRIX 6.5, OSF/1 5.1.
  • The address of this variable is not a compile-time constant on some platforms: Cygwin, mingw.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.
A more portable way of getting the UTC offset is to use strftime with the %z format. See strftime.

Next: dbm_clearerr Prev: ctime_r Up: Function Substitutes Top: Top


dbm_clearerr -- GNU Gnulib

Next: dbm_close Prev: daylight Up: Function Substitutes Top: Top

9.171. dbm_clearerr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_clearerr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, HP-UX 11.11, IRIX 5.3, OSF/1 5.1, Solaris 2.5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_close Prev: daylight Up: Function Substitutes Top: Top


dbm_close -- GNU Gnulib

Next: dbm_delete Prev: dbm_clearerr Up: Function Substitutes Top: Top

9.172. dbm_close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_close.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_delete Prev: dbm_clearerr Up: Function Substitutes Top: Top


dbm_delete -- GNU Gnulib

Next: dbm_error Prev: dbm_close Up: Function Substitutes Top: Top

9.173. dbm_delete

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_delete.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_error Prev: dbm_close Up: Function Substitutes Top: Top


dbm_error -- GNU Gnulib

Next: dbm_fetch Prev: dbm_delete Up: Function Substitutes Top: Top

9.174. dbm_error

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_error.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, HP-UX 11.11, IRIX 5.3, OSF/1 4.0, Solaris 2.5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_fetch Prev: dbm_delete Up: Function Substitutes Top: Top


dbm_fetch -- GNU Gnulib

Next: dbm_firstkey Prev: dbm_error Up: Function Substitutes Top: Top

9.175. dbm_fetch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_fetch.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_firstkey Prev: dbm_error Up: Function Substitutes Top: Top


dbm_firstkey -- GNU Gnulib

Next: dbm_nextkey Prev: dbm_fetch Up: Function Substitutes Top: Top

9.176. dbm_firstkey

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_firstkey.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_nextkey Prev: dbm_fetch Up: Function Substitutes Top: Top


dbm_nextkey -- GNU Gnulib

Next: dbm_open Prev: dbm_firstkey Up: Function Substitutes Top: Top

9.177. dbm_nextkey

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_nextkey.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_open Prev: dbm_firstkey Up: Function Substitutes Top: Top


dbm_open -- GNU Gnulib

Next: dbm_store Prev: dbm_nextkey Up: Function Substitutes Top: Top

9.178. dbm_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: dbm_store Prev: dbm_nextkey Up: Function Substitutes Top: Top


dbm_store -- GNU Gnulib

Next: difftime Prev: dbm_open Up: Function Substitutes Top: Top

9.179. dbm_store

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dbm_store.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Cygwin, mingw, MSVC 14, BeOS.

Next: difftime Prev: dbm_open Up: Function Substitutes Top: Top


difftime -- GNU Gnulib

Next: dirfd Prev: dbm_store Up: Function Substitutes Top: Top

9.180. difftime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/difftime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: dirfd Prev: dbm_store Up: Function Substitutes Top: Top


dirfd -- GNU Gnulib

Next: dirname Prev: difftime Up: Function Substitutes Top: Top

9.181. dirfd

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dirfd.html

Gnulib module: dirfd

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 7.1, HP-UX 11, OSF/1 5.1, Solaris 10, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function always fails on some platforms: mingw.
With the dirfd module, this functions always sets errno when it fails. (POSIX does not require that dirfd sets errno when it fails.)

Next: dirname Prev: difftime Up: Function Substitutes Top: Top


dirname -- GNU Gnulib

Next: div Prev: dirfd Up: Function Substitutes Top: Top

9.182. dirname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dirname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: IRIX 6.5, Solaris 2.5.1, mingw, MSVC 14, BeOS.
  • dirname assumes file names in POSIX syntax; it does not work with file names in Windows syntax.
The Gnulib module dirname provides similar API, with functions dir_name and mdir_name, that also works with Windows file names.

Next: div Prev: dirfd Up: Function Substitutes Top: Top


div -- GNU Gnulib

Next: dlclose Prev: dirname Up: Function Substitutes Top: Top

9.183. div

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/div.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: dlclose Prev: dirname Up: Function Substitutes Top: Top


dlclose -- GNU Gnulib

Next: dlerror Prev: div Up: Function Substitutes Top: Top

9.184. dlclose

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dlclose.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dlerror Prev: div Up: Function Substitutes Top: Top


dlerror -- GNU Gnulib

Next: dlopen Prev: dlclose Up: Function Substitutes Top: Top

9.185. dlerror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dlerror.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dlopen Prev: dlclose Up: Function Substitutes Top: Top


dlopen -- GNU Gnulib

Next: dlsym Prev: dlerror Up: Function Substitutes Top: Top

9.186. dlopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dlopen.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • If the file name argument is not absolute, the file is searched for. The search algorithm is system specific.

Next: dlsym Prev: dlerror Up: Function Substitutes Top: Top


dlsym -- GNU Gnulib

Next: dprintf Prev: dlopen Up: Function Substitutes Top: Top

9.187. dlsym

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dlsym.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • The visibility of symbols loaded in dependent shared libraries or present in the main executable is system dependent.

Next: dprintf Prev: dlopen Up: Function Substitutes Top: Top


dprintf -- GNU Gnulib

Next: drand48 Prev: dlsym Up: Function Substitutes Top: Top

9.188. dprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dprintf.html

Gnulib module: dprintf or dprintf-posix

Portability problems fixed by either Gnulib module dprintf or dprintf-posix:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems fixed by Gnulib module dprintf-posix:
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: drand48 Prev: dlsym Up: Function Substitutes Top: Top


drand48 -- GNU Gnulib

Next: dup Prev: dprintf Up: Function Substitutes Top: Top

9.189. drand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/drand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: dup Prev: dprintf Up: Function Substitutes Top: Top


dup -- GNU Gnulib

Next: dup2 Prev: drand48 Up: Function Substitutes Top: Top

9.190. dup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dup.html

Gnulib module: dup

Portability problems fixed by Gnulib:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: dup2 Prev: drand48 Up: Function Substitutes Top: Top


dup2 -- GNU Gnulib

Next: duplocale Prev: dup Up: Function Substitutes Top: Top

9.191. dup2

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/dup2.html

Gnulib module: dup2 or dup2-obsolete

Portability problems fixed by either Gnulib module dup2 or dup2-obsolete:

  • This function always returns 0 for success on some platforms: mingw, MSVC 14.

  • This function can hang when duplicating an fd to itself on some platforms: mingw, MSVC 14.

  • This function crashes when invoked with invalid arguments on some platforms: Cygwin 1.7.17, MSVC 14.

  • This function crashes when invoked with valid arguments on some platforms: Cygwin 1.7.25.

  • This function fails with EINVAL when duplicating an fd to itself: Android.

  • This function resets the FD_CLOEXEC flag when duplicating an fd to itself on some platforms: Haiku.

  • This function returns 0 for dup2 (1, 1) on some platforms: Cygwin 1.5.x.

  • This function may return -EBADF instead of -1 on some platforms: Linux releases between July 2008 and May 2009 (versions 2.6.27 to 2.6.29).

  • This function returns EMFILE instead of EBADF for large targets, which interferes with using dup2(fd,fd)==fd) as the minimal EBADF filter: AIX 7.1, FreeBSD 6.1, Cygwin 1.5.
Portability problems fixed by Gnulib module dup2-obsolete:
  • This function is missing on some older platforms.
Portability problems not fixed by Gnulib:

Next: duplocale Prev: dup Up: Function Substitutes Top: Top


duplocale -- GNU Gnulib

Next: encrypt Prev: dup2 Up: Function Substitutes Top: Top

9.192. duplocale

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/duplocale.html

Gnulib module: duplocale

Portability problems fixed by Gnulib:

  • The argument LC_GLOBAL_LOCALE is not supported on some platforms: glibc 2.11, AIX 7.1.
  • With the argument LC_GLOBAL_LOCALE, this function returns a wrong result on some platforms: NetBSD 7.0.
Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: encrypt Prev: dup2 Up: Function Substitutes Top: Top


encrypt -- GNU Gnulib

Next: endgrent Prev: duplocale Up: Function Substitutes Top: Top

9.193. encrypt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/encrypt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.
  • This function is not declared in <unistd.h> (without -D_GNU_SOURCE) on some platforms: glibc (at least 2.11--2.13).

Next: endgrent Prev: duplocale Up: Function Substitutes Top: Top


endgrent -- GNU Gnulib

Next: endhostent Prev: encrypt Up: Function Substitutes Top: Top

9.194. endgrent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endgrent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: endhostent Prev: encrypt Up: Function Substitutes Top: Top


endhostent -- GNU Gnulib

Next: endnetent Prev: endgrent Up: Function Substitutes Top: Top

9.195. endhostent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endhostent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: endnetent Prev: endgrent Up: Function Substitutes Top: Top


endnetent -- GNU Gnulib

Next: endprotoent Prev: endhostent Up: Function Substitutes Top: Top

9.196. endnetent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endnetent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: endprotoent Prev: endhostent Up: Function Substitutes Top: Top


endprotoent -- GNU Gnulib

Next: endpwent Prev: endnetent Up: Function Substitutes Top: Top

9.197. endprotoent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endprotoent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: endpwent Prev: endnetent Up: Function Substitutes Top: Top


endpwent -- GNU Gnulib

Next: endservent Prev: endprotoent Up: Function Substitutes Top: Top

9.198. endpwent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endpwent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: endservent Prev: endprotoent Up: Function Substitutes Top: Top


endservent -- GNU Gnulib

Next: endutxent Prev: endpwent Up: Function Substitutes Top: Top

9.199. endservent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endservent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: endutxent Prev: endpwent Up: Function Substitutes Top: Top


endutxent -- GNU Gnulib

Next: environ Prev: endservent Up: Function Substitutes Top: Top

9.200. endutxent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/endutxent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: environ Prev: endservent Up: Function Substitutes Top: Top


environ -- GNU Gnulib

Next: erand48 Prev: endutxent Up: Function Substitutes Top: Top

9.201. environ

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/environ.html

Gnulib module: environ

Portability problems fixed by Gnulib:

  • POSIX does not require this variable to be declared, and it is indeed not declared on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, IRIX 6.5, Solaris 11.3.
  • On Mac OS X 10, this variable is not declared. Up to Mac OS X 10.4, one can use
    extern char **environ;
    to get the variable declared. This does not work any more, however, in shared libraries on Mac OS X 10.5. Here is a workaround: Instead, one can use
    #include <crt_externs.h>
#define environ (*_NSGetEnviron())
    This works at all versions of Mac OS X.
Portability problems not fixed by Gnulib:
  • The address of this variable is not a compile-time constant on some platforms: mingw.

Next: erand48 Prev: endutxent Up: Function Substitutes Top: Top


erand48 -- GNU Gnulib

Next: erf Prev: environ Up: Function Substitutes Top: Top

9.202. erand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: erf Prev: environ Up: Function Substitutes Top: Top


erf -- GNU Gnulib

Next: erfc Prev: erand48 Up: Function Substitutes Top: Top

9.203. erf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erf.html

Gnulib module: erf

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.

Next: erfc Prev: erand48 Up: Function Substitutes Top: Top


erfc -- GNU Gnulib

Next: erfcf Prev: erf Up: Function Substitutes Top: Top

9.204. erfc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erfc.html

Gnulib module: erfc

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.

Next: erfcf Prev: erf Up: Function Substitutes Top: Top


erfcf -- GNU Gnulib

Next: erfcl Prev: erfc Up: Function Substitutes Top: Top

9.205. erfcf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erfcf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, MSVC 9.

Next: erfcl Prev: erfc Up: Function Substitutes Top: Top


erfcl -- GNU Gnulib

Next: erff Prev: erfcf Up: Function Substitutes Top: Top

9.206. erfcl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erfcl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: erff Prev: erfcf Up: Function Substitutes Top: Top


erff -- GNU Gnulib

Next: erfl Prev: erfcl Up: Function Substitutes Top: Top

9.207. erff

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erff.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, MSVC 9.

Next: erfl Prev: erfcl Up: Function Substitutes Top: Top


erfl -- GNU Gnulib

Next: errno Prev: erff Up: Function Substitutes Top: Top

9.208. erfl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/erfl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: errno Prev: erff Up: Function Substitutes Top: Top


errno -- GNU Gnulib

Next: execl Prev: erfl Up: Function Substitutes Top: Top

9.209. errno

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/errno.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows, the socket functions don't set errno; their error code is available through WSAGetLastError() instead.

Next: execl Prev: erfl Up: Function Substitutes Top: Top


execl -- GNU Gnulib

Next: execle Prev: errno Up: Function Substitutes Top: Top

9.210. execl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: execle Prev: errno Up: Function Substitutes Top: Top


execle -- GNU Gnulib

Next: execlp Prev: execl Up: Function Substitutes Top: Top

9.211. execle

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execle.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: execlp Prev: execl Up: Function Substitutes Top: Top


execlp -- GNU Gnulib

Next: execv Prev: execle Up: Function Substitutes Top: Top

9.212. execlp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execlp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: execv Prev: execle Up: Function Substitutes Top: Top


execv -- GNU Gnulib

Next: execve Prev: execlp Up: Function Substitutes Top: Top

9.213. execv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: execve Prev: execlp Up: Function Substitutes Top: Top


execve -- GNU Gnulib

Next: execvp Prev: execv Up: Function Substitutes Top: Top

9.214. execve

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execve.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: execvp Prev: execv Up: Function Substitutes Top: Top


execvp -- GNU Gnulib

Next: exit Prev: execve Up: Function Substitutes Top: Top

9.215. execvp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/execvp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On some platforms, a script without executable permission is still run: Cygwin 1.5.x.
  • On Windows platforms (excluding Cygwin), this function operates by spawning and then by exiting the current process, which means the current process's parent may incorrectly proceed as if its child had exited.

Next: exit Prev: execve Up: Function Substitutes Top: Top


exit -- GNU Gnulib

Next: exp Prev: execvp Up: Function Substitutes Top: Top

9.216. exit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/exit.html

Gnulib module: stdlib

Portability problems fixed by Gnulib:

  • Some problems with the macros EXIT_SUCCESS and EXIT_FAILURE, see stdlib.h.
Portability problems not fixed by Gnulib:

Next: exp Prev: execvp Up: Function Substitutes Top: Top


exp -- GNU Gnulib

Next: exp2 Prev: exit Up: Function Substitutes Top: Top

9.217. exp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/exp.html

Gnulib module: exp

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: exp2 Prev: exit Up: Function Substitutes Top: Top


exp2 -- GNU Gnulib

Next: exp2f Prev: exp Up: Function Substitutes Top: Top

9.218. exp2

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/exp2.html

Gnulib module: exp2

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, older IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function returns grossly wrong results on some platforms: OpenBSD 4.9.
Portability problems not fixed by Gnulib:

Next: exp2f Prev: exp Up: Function Substitutes Top: Top


exp2f -- GNU Gnulib

Next: exp2l Prev: exp2 Up: Function Substitutes Top: Top

9.219. exp2f

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/exp2f.html

Gnulib module: exp2f

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: exp2l Prev: exp2 Up: Function Substitutes Top: Top


exp2l -- GNU Gnulib

Next: expf Prev: exp2f Up: Function Substitutes Top: Top

9.220. exp2l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/exp2l.html

Gnulib module: exp2l or exp2l-ieee

Portability problems fixed by either Gnulib module exp2l or exp2l-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: IRIX 6.5.
Portability problems fixed by Gnulib module exp2l-ieee:
  • This function returns a wrong value for a NaN argument on some platforms: OpenBSD 4.9.
  • This function returns a wrong value for a negative infinity argument on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: expf Prev: exp2f Up: Function Substitutes Top: Top


expf -- GNU Gnulib

Next: expl Prev: exp2l Up: Function Substitutes Top: Top

9.221. expf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/expf.html

Gnulib module: expf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: expl Prev: exp2l Up: Function Substitutes Top: Top


expl -- GNU Gnulib

Next: expm1 Prev: expf Up: Function Substitutes Top: Top

9.222. expl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/expl.html

Gnulib module: expl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function returns NaN for small operands: OpenBSD 5.4.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: expm1 Prev: expf Up: Function Substitutes Top: Top


expm1 -- GNU Gnulib

Next: expm1f Prev: expl Up: Function Substitutes Top: Top

9.223. expm1

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/expm1.html

Gnulib module: expm1 or expm1-ieee

Portability problems fixed by either Gnulib module expm1 or expm1-ieee:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 9.
Portability problems fixed by Gnulib module expm1-ieee:
  • This function has problems when the argument is minus zero on some platforms: AIX 7.1.
Portability problems not fixed by Gnulib:

Next: expm1f Prev: expl Up: Function Substitutes Top: Top


expm1f -- GNU Gnulib

Next: expm1l Prev: expm1 Up: Function Substitutes Top: Top

9.224. expm1f

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/expm1f.html

Gnulib module: expm1f

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, mingw, MSVC 9.
  • This function produces wrong results for arguments <= -17.32868 on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: expm1l Prev: expm1 Up: Function Substitutes Top: Top


expm1l -- GNU Gnulib

Next: fabs Prev: expm1f Up: Function Substitutes Top: Top

9.225. expm1l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/expm1l.html

Gnulib module: expm1l

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: fabs Prev: expm1f Up: Function Substitutes Top: Top


fabs -- GNU Gnulib

Next: fabsf Prev: expm1l Up: Function Substitutes Top: Top

9.226. fabs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fabs.html

Gnulib module: fabs

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: fabsf Prev: expm1l Up: Function Substitutes Top: Top


fabsf -- GNU Gnulib

Next: fabsl Prev: fabs Up: Function Substitutes Top: Top

9.227. fabsf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fabsf.html

Gnulib module: fabsf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: fabsl Prev: fabs Up: Function Substitutes Top: Top


fabsl -- GNU Gnulib

Next: faccessat Prev: fabsf Up: Function Substitutes Top: Top

9.228. fabsl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fabsl.html

Gnulib module: fabsl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function returns a minus zero for a minus zero argument on some platforms: IRIX 6.5 with gcc 4.2.4.
Portability problems not fixed by Gnulib:

Next: faccessat Prev: fabsf Up: Function Substitutes Top: Top


faccessat -- GNU Gnulib

Next: fattach Prev: fabsl Up: Function Substitutes Top: Top

9.229. faccessat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/faccessat.html

Gnulib module: faccessat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, macOS 10.12, FreeBSD 7.4, NetBSD 6.1.5, OpenBSD 4.9, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • The replacement does not always take ACLs into account.
  • The replacement is not safe to be used in libraries.
  • The replacement is not multithread-safe.
  • The replacement does not support the AT_SYMLINK_NOFOLLOW flag, which is supported by GNU faccessat.
Other problems of this function:
  • There is an inherent race between calling this function and performing some action based on the results; you should think twice before trusting this function, especially in a set-uid or set-gid program.

Next: fattach Prev: fabsl Up: Function Substitutes Top: Top


fattach -- GNU Gnulib

Next: fchdir Prev: faccessat Up: Function Substitutes Top: Top

9.230. fattach

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fattach.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fchdir Prev: faccessat Up: Function Substitutes Top: Top


fchdir -- GNU Gnulib

Next: fchmod Prev: fattach Up: Function Substitutes Top: Top

9.231. fchdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fchdir.html

Gnulib module: fchdir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Tandem/NSK, mingw, MSVC 14, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • This function is not declared on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: fchmod Prev: fattach Up: Function Substitutes Top: Top


fchmod -- GNU Gnulib

Next: fchmodat Prev: fchdir Up: Function Substitutes Top: Top

9.232. fchmod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fchmod.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: fchmodat Prev: fchdir Up: Function Substitutes Top: Top


fchmodat -- GNU Gnulib

Next: fchown Prev: fchmod Up: Function Substitutes Top: Top

9.233. fchmodat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fchmodat.html

Gnulib module: fchmodat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
Portability problems not fixed by Gnulib:
  • Some platforms do not allow changing the access bits on symbolic links. POSIX states that fchmodat(...,AT_SYMLINK_NOFOLLOW) may fail with EOPNOTSUPP when called on a symlink, but some platforms, as well as the gnulib replacement, fail for any use of AT_SYMLINK_NOFOLLOW even if the target was not a symlink: glibc, Cygwin.

Next: fchown Prev: fchmod Up: Function Substitutes Top: Top


fchown -- GNU Gnulib

Next: fchownat Prev: fchmodat Up: Function Substitutes Top: Top

9.234. fchown

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fchown.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: fchownat Prev: fchmodat Up: Function Substitutes Top: Top


fchownat -- GNU Gnulib

Next: fclose Prev: fchown Up: Function Substitutes Top: Top

9.235. fchownat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fchownat.html

Gnulib module: fchownat

Portability problems fixed by Gnulib:

  • Some platforms fail to detect trailing slash on non-directories, as in fchown(dir,"link-to-file/",uid,gid,flag): Solaris 9.
  • Some platforms mistakenly dereference symlinks when using AT_SYMLINK_NOFOLLOW: Linux kernel 2.6.17.
  • This function does not fail for an empty filename on some platforms: Linux with glibc < 2.11.
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe. Also, the replacement may fail to change symlinks if lchown is unsupported, or fail altogether if chown is unsupported.
Portability problems not fixed by Gnulib:

Next: fclose Prev: fchown Up: Function Substitutes Top: Top


fclose -- GNU Gnulib

Next: fcntl Prev: fchownat Up: Function Substitutes Top: Top

9.236. fclose

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fclose.html

Gnulib module: fclose

Portability problems fixed by Gnulib:

  • On some platforms, this function fails to set the file position of a seekable input stream to the byte after the last one actually read: glibc 2.13, FreeBSD.
  • This function crashes if the stream's file descriptor has already been closed on some platforms: MSVC 14.
  • On Windows platforms (excluding Cygwin), socket and accept followed by fdopen do not return streams that can be closed by fclose.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: fcntl Prev: fchownat Up: Function Substitutes Top: Top


fcntl -- GNU Gnulib

Next: fdatasync Prev: fclose Up: Function Substitutes Top: Top

9.237. fcntl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fcntl.html

Gnulib module: fcntl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.

  • This function does not support F_DUPFD_CLOEXEC on some platforms: glibc with Linux kernels before 2.6.24, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 7.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11, Cygwin 1.7.1, Interix 3.5, BeOS. Note that the gnulib replacement code is functional but not atomic.

  • The F_DUPFD action of this function does not reject out-of-range targets properly on some platforms: AIX 7.1, Cygwin 1.5.x, Haiku.

  • The F_DUPFD action of this function mistakenly clears FD_CLOEXEC on the source descriptor on some platforms: Haiku.
Portability problems not fixed by Gnulib:
  • The replacement function does not support F_SETFD, F_GETFL, F_SETFL, F_GETOWN, F_SETOWN, F_GETLK, F_SETLK, and F_SETLKW on some platforms: mingw, MSVC 14.

Next: fdatasync Prev: fclose Up: Function Substitutes Top: Top


fdatasync -- GNU Gnulib

Next: fdetach Prev: fcntl Up: Function Substitutes Top: Top

9.238. fdatasync

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdatasync.html

Gnulib module: fdatasync

Portability problems fixed by Gnulib:

  • This function is present but not declared on some platforms: Mac OS X 10.7.
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: fdetach Prev: fcntl Up: Function Substitutes Top: Top


fdetach -- GNU Gnulib

Next: fdim Prev: fdatasync Up: Function Substitutes Top: Top

9.239. fdetach

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdetach.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fdim Prev: fdatasync Up: Function Substitutes Top: Top


fdim -- GNU Gnulib

Next: fdimf Prev: fdetach Up: Function Substitutes Top: Top

9.240. fdim

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdim.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fdimf Prev: fdetach Up: Function Substitutes Top: Top


fdimf -- GNU Gnulib

Next: fdiml Prev: fdim Up: Function Substitutes Top: Top

9.241. fdimf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdimf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fdiml Prev: fdim Up: Function Substitutes Top: Top


fdiml -- GNU Gnulib

Next: fdopen Prev: fdimf Up: Function Substitutes Top: Top

9.242. fdiml

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdiml.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: fdopen Prev: fdimf Up: Function Substitutes Top: Top


fdopen -- GNU Gnulib

Next: fdopendir Prev: fdiml Up: Function Substitutes Top: Top

9.243. fdopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdopen.html

Gnulib module: fdopen

Portability problems fixed by Gnulib:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
Portability problems not fixed by Gnulib:

Next: fdopendir Prev: fdiml Up: Function Substitutes Top: Top


fdopendir -- GNU Gnulib

Next: feclearexcept Prev: fdopen Up: Function Substitutes Top: Top

9.244. fdopendir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fdopendir.html

Gnulib module: fdopendir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe. Also, the replacement does not guarantee that `dirfd(fdopendir(n))==n' (dirfd might fail, or return a different file descriptor than n).
  • This function exists but is not declared on some platforms: FreeBSD 7.3.
  • This function does not reject non-directory file descriptors on some platforms: GNU/Hurd.
  • This function mistakenly closes non-directory file descriptors on some platforms: FreeBSD 8.1.
Portability problems not fixed by Gnulib:

Next: feclearexcept Prev: fdopen Up: Function Substitutes Top: Top


feclearexcept -- GNU Gnulib

Next: fegetenv Prev: fdopendir Up: Function Substitutes Top: Top

9.245. feclearexcept

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/feclearexcept.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fegetenv Prev: fdopendir Up: Function Substitutes Top: Top


fegetenv -- GNU Gnulib

Next: fegetexceptflag Prev: feclearexcept Up: Function Substitutes Top: Top

9.246. fegetenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fegetenv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fegetexceptflag Prev: feclearexcept Up: Function Substitutes Top: Top


fegetexceptflag -- GNU Gnulib

Next: fegetround Prev: fegetenv Up: Function Substitutes Top: Top

9.247. fegetexceptflag

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fegetexceptflag.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fegetround Prev: fegetenv Up: Function Substitutes Top: Top


fegetround -- GNU Gnulib

Next: feholdexcept Prev: fegetexceptflag Up: Function Substitutes Top: Top

9.248. fegetround

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fegetround.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: feholdexcept Prev: fegetexceptflag Up: Function Substitutes Top: Top


feholdexcept -- GNU Gnulib

Next: feof Prev: fegetround Up: Function Substitutes Top: Top

9.249. feholdexcept

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/feholdexcept.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: feof Prev: fegetround Up: Function Substitutes Top: Top


feof -- GNU Gnulib

Next: feraiseexcept Prev: feholdexcept Up: Function Substitutes Top: Top

9.250. feof

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/feof.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: feraiseexcept Prev: feholdexcept Up: Function Substitutes Top: Top


feraiseexcept -- GNU Gnulib

Next: ferror Prev: feof Up: Function Substitutes Top: Top

9.251. feraiseexcept

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/feraiseexcept.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 14, Interix 3.5.

Next: ferror Prev: feof Up: Function Substitutes Top: Top


ferror -- GNU Gnulib

Next: fesetenv Prev: feraiseexcept Up: Function Substitutes Top: Top

9.252. ferror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ferror.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: fesetenv Prev: feraiseexcept Up: Function Substitutes Top: Top


fesetenv -- GNU Gnulib

Next: fesetexceptflag Prev: ferror Up: Function Substitutes Top: Top

9.253. fesetenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fesetenv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fesetexceptflag Prev: ferror Up: Function Substitutes Top: Top


fesetexceptflag -- GNU Gnulib

Next: fesetround Prev: fesetenv Up: Function Substitutes Top: Top

9.254. fesetexceptflag

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fesetexceptflag.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fesetround Prev: fesetenv Up: Function Substitutes Top: Top


fesetround -- GNU Gnulib

Next: fetestexcept Prev: fesetexceptflag Up: Function Substitutes Top: Top

9.255. fesetround

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fesetround.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: fetestexcept Prev: fesetexceptflag Up: Function Substitutes Top: Top


fetestexcept -- GNU Gnulib

Next: feupdateenv Prev: fesetround Up: Function Substitutes Top: Top

9.256. fetestexcept

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fetestexcept.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: feupdateenv Prev: fesetround Up: Function Substitutes Top: Top


feupdateenv -- GNU Gnulib

Next: fexecve Prev: fetestexcept Up: Function Substitutes Top: Top

9.257. feupdateenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/feupdateenv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.7, MSVC 14, Interix 3.5.

Next: fexecve Prev: fetestexcept Up: Function Substitutes Top: Top


fexecve -- GNU Gnulib

Next: fflush Prev: feupdateenv Up: Function Substitutes Top: Top

9.258. fexecve

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fexecve.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fflush Prev: feupdateenv Up: Function Substitutes Top: Top


fflush -- GNU Gnulib

Next: ffs Prev: fexecve Up: Function Substitutes Top: Top

9.259. fflush

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fflush.html

Gnulib module: fflush

Portability problems fixed by Gnulib:

  • fflush followed by fseek or fseeko, applied to an input stream, should have the effect of positioning the underlying file descriptor. It doesn't do this on some platforms.
  • fflush on an input stream changes the position of the stream to the end of the previous buffer, on some platforms: mingw, MSVC 14.
  • fflush on an input stream right after ungetc does not discard the ungetc buffer, on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Cygwin 1.5.25-10.
Portability problems not fixed by Gnulib:
  • fflush, ftell, ftello, fgetpos behave incorrectly on input streams that are opened in O_TEXT mode and whose contents contains Unix line terminators (LF), on some platforms: mingw, MSVC 14.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • This function crashes if the stream's file descriptor has already been closed, if MSVC_INVALID_PARAMETER_HANDLING is HAIRY_LIBRARY_HANDLING or SANE_LIBRARY_HANDLING, on some platforms: MSVC 14.
  • fflush on an input stream right after ungetc does not discard the ungetc buffer, on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11, mingw, MSVC 14.

Next: ffs Prev: fexecve Up: Function Substitutes Top: Top


ffs -- GNU Gnulib

Next: fgetc Prev: fflush Up: Function Substitutes Top: Top

9.260. ffs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ffs.html

Gnulib module: ffs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: fgetc Prev: fflush Up: Function Substitutes Top: Top


fgetc -- GNU Gnulib

Next: fgetpos Prev: ffs Up: Function Substitutes Top: Top

9.261. fgetc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fgetc.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • This function crashes if the stream's file descriptor has already been closed, if MSVC_INVALID_PARAMETER_HANDLING is HAIRY_LIBRARY_HANDLING or SANE_LIBRARY_HANDLING, on some platforms: MSVC 14.

Next: fgetpos Prev: ffs Up: Function Substitutes Top: Top


fgetpos -- GNU Gnulib

Next: fgets Prev: fgetc Up: Function Substitutes Top: Top

9.262. fgetpos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fgetpos.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • fflush, ftell, ftello, fgetpos behave incorrectly on input streams that are opened in O_TEXT mode and whose contents contains Unix line terminators (LF), on some platforms: mingw, MSVC 14.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.
  • On platforms where off_t is a 64-bit type, but fseeko is not present, stream operations on files larger than 2 GB silently do the wrong thing. This affects BSD/OS, which is mostly obsolete.

Next: fgets Prev: fgetc Up: Function Substitutes Top: Top


fgets -- GNU Gnulib

Next: fgetwc Prev: fgetpos Up: Function Substitutes Top: Top

9.263. fgets

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fgets.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: fgetwc Prev: fgetpos Up: Function Substitutes Top: Top


fgetwc -- GNU Gnulib

Next: fgetws Prev: fgets Up: Function Substitutes Top: Top

9.264. fgetwc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fgetwc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fgetws Prev: fgets Up: Function Substitutes Top: Top


fgetws -- GNU Gnulib

Next: fileno Prev: fgetwc Up: Function Substitutes Top: Top

9.265. fgetws

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fgetws.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fileno Prev: fgetwc Up: Function Substitutes Top: Top


fileno -- GNU Gnulib

Next: flockfile Prev: fgetws Up: Function Substitutes Top: Top

9.266. fileno

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fileno.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: flockfile Prev: fgetws Up: Function Substitutes Top: Top


flockfile -- GNU Gnulib

Next: floor Prev: fileno Up: Function Substitutes Top: Top

9.267. flockfile

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/flockfile.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: floor Prev: fileno Up: Function Substitutes Top: Top


floor -- GNU Gnulib

Next: floorf Prev: flockfile Up: Function Substitutes Top: Top

9.268. floor

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/floor.html

Gnulib module: floor or floor-ieee

Portability problems fixed by either Gnulib module floor or floor-ieee:

Portability problems fixed by Gnulib module floor-ieee:
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: floorf Prev: flockfile Up: Function Substitutes Top: Top


floorf -- GNU Gnulib

Next: floorl Prev: floor Up: Function Substitutes Top: Top

9.269. floorf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/floorf.html

Gnulib module: floorf or floorf-ieee

Portability problems fixed by either Gnulib module floorf or floorf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module floorf-ieee:
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: floorl Prev: floor Up: Function Substitutes Top: Top


floorl -- GNU Gnulib

Next: fma Prev: floorf Up: Function Substitutes Top: Top

9.270. floorl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/floorl.html

Gnulib module: floorl or floorl-ieee

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: fma Prev: floorf Up: Function Substitutes Top: Top


fma -- GNU Gnulib

Next: fmaf Prev: floorl Up: Function Substitutes Top: Top

9.271. fma

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fma.html

Gnulib module: fma

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function produces wrong results on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4/x86, OSF/1 5.1, Cygwin 1.5, mingw.
Portability problems not fixed by Gnulib:

Next: fmaf Prev: floorl Up: Function Substitutes Top: Top


fmaf -- GNU Gnulib

Next: fmal Prev: fma Up: Function Substitutes Top: Top

9.272. fmaf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmaf.html

Gnulib module: fmaf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function produces wrong results on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4/x86, OSF/1 5.1, Cygwin 1.5, mingw.
Portability problems not fixed by Gnulib:

Next: fmal Prev: fma Up: Function Substitutes Top: Top


fmal -- GNU Gnulib

Next: fmax Prev: fmaf Up: Function Substitutes Top: Top

9.273. fmal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmal.html

Gnulib module: fmal

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function produces wrong results on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4/x86, OSF/1 5.1, mingw.
Portability problems not fixed by Gnulib:

Next: fmax Prev: fmaf Up: Function Substitutes Top: Top


fmax -- GNU Gnulib

Next: fmaxf Prev: fmal Up: Function Substitutes Top: Top

9.274. fmax

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmax.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fmaxf Prev: fmal Up: Function Substitutes Top: Top


fmaxf -- GNU Gnulib

Next: fmaxl Prev: fmax Up: Function Substitutes Top: Top

9.275. fmaxf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmaxf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fmaxl Prev: fmax Up: Function Substitutes Top: Top


fmaxl -- GNU Gnulib

Next: fmemopen Prev: fmaxf Up: Function Substitutes Top: Top

9.276. fmaxl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmaxl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: fmemopen Prev: fmaxf Up: Function Substitutes Top: Top


fmemopen -- GNU Gnulib

Next: fmin Prev: fmaxl Up: Function Substitutes Top: Top

9.277. fmemopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmemopen.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fmin Prev: fmaxl Up: Function Substitutes Top: Top


fmin -- GNU Gnulib

Next: fminf Prev: fmemopen Up: Function Substitutes Top: Top

9.278. fmin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmin.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fminf Prev: fmemopen Up: Function Substitutes Top: Top


fminf -- GNU Gnulib

Next: fminl Prev: fmin Up: Function Substitutes Top: Top

9.279. fminf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fminf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: fminl Prev: fmin Up: Function Substitutes Top: Top


fminl -- GNU Gnulib

Next: fmod Prev: fminf Up: Function Substitutes Top: Top

9.280. fminl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fminl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: fmod Prev: fminf Up: Function Substitutes Top: Top


fmod -- GNU Gnulib

Next: fmodf Prev: fminl Up: Function Substitutes Top: Top

9.281. fmod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmod.html

Gnulib module: fmod or fmod-ieee

Portability problems fixed by either Gnulib module fmod or fmod-ieee:

Portability problems fixed by Gnulib module fmod-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
  • This function has problems when the first argument is minus zero on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: fmodf Prev: fminl Up: Function Substitutes Top: Top


fmodf -- GNU Gnulib

Next: fmodl Prev: fmod Up: Function Substitutes Top: Top

9.282. fmodf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmodf.html

Gnulib module: fmodf or fmodf-ieee

Portability problems fixed by either Gnulib module fmodf or fmodf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module fmodf-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
  • This function has problems when the first argument is minus zero on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: fmodl Prev: fmod Up: Function Substitutes Top: Top


fmodl -- GNU Gnulib

Next: fmtmsg Prev: fmodf Up: Function Substitutes Top: Top

9.283. fmodl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmodl.html

Gnulib module: fmodl or fmodl-ieee

Portability problems fixed by either Gnulib module fmodl or fmodl-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared and does not work on some platforms: AIX 5.1.
Portability problems fixed by Gnulib module fmodl-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
  • This function has problems when the first argument is minus zero on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: fmtmsg Prev: fmodf Up: Function Substitutes Top: Top


fmtmsg -- GNU Gnulib

Next: fnmatch Prev: fmodl Up: Function Substitutes Top: Top

9.284. fmtmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fmtmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fnmatch Prev: fmodl Up: Function Substitutes Top: Top


fnmatch -- GNU Gnulib

Next: fopen Prev: fmtmsg Up: Function Substitutes Top: Top

9.285. fnmatch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fnmatch.html

Gnulib module: fnmatch or fnmatch-gnu

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, mingw, MSVC 14.
  • This function is broken in some versions of Solaris and glibc.
Portability problems not fixed by Gnulib:

Next: fopen Prev: fmtmsg Up: Function Substitutes Top: Top


fopen -- GNU Gnulib

Next: fork Prev: fnmatch Up: Function Substitutes Top: Top

9.286. fopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fopen.html

Gnulib module: fopen

Portability problems fixed by Gnulib:

  • This function does not fail when the file name argument ends in a slash and (without the slash) names a nonexistent file or a file that is not a directory, on some platforms: HP-UX 11.00, AIX 7.1, Solaris 9, Irix 5.3.
  • On platforms where off_t is a 32-bit type, fopen may not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • On Windows platforms (excluding Cygwin), this function does usually not recognize the /dev/null filename.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, this function returns a file stream in ``text'' mode by default; this means that it translates '\n' to CR/LF by default. Use the "b" flag if you need reliable binary I/O.
  • On Windows platforms (excluding Cygwin), this function fails to open directories for reading. Such streams have implementation-defined semantics on other platforms. To avoid directory streams with a consistent error message, use fstat after open and fdopen, rather than fopen and fileno.

Next: fork Prev: fnmatch Up: Function Substitutes Top: Top


fork -- GNU Gnulib

Next: fpathconf Prev: fopen Up: Function Substitutes Top: Top

9.287. fork

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fork.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • On some platforms, fork followed by a call of the exec family (execl, execlp, execle, execv, execvp, or execve) is less efficient than vfork followed by the same call. vfork is a variant of fork that has been introduced to optimize the fork/exec pattern.
  • On Windows platforms (excluding Cygwin), this function is not implemented; use spawnvp instead.

Next: fpathconf Prev: fopen Up: Function Substitutes Top: Top


fpathconf -- GNU Gnulib

Next: fpclassify Prev: fork Up: Function Substitutes Top: Top

9.288. fpathconf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fpathconf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: fpclassify Prev: fork Up: Function Substitutes Top: Top


fpclassify -- GNU Gnulib

Next: fprintf Prev: fpathconf Up: Function Substitutes Top: Top

9.289. fpclassify

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fpclassify.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5.

Next: fprintf Prev: fpathconf Up: Function Substitutes Top: Top


fprintf -- GNU Gnulib

Next: fputc Prev: fpclassify Up: Function Substitutes Top: Top

9.290. fprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fprintf.html

Gnulib module: fprintf-posix or stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module fprintf-posix:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems fixed by Gnulib module stdio or fprintf-posix, together with module nonblocking:
  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio or fprintf-posix, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • Attempting to write to a read-only stream fails with EOF but does not set the error flag for ferror on some platforms: glibc 2.13, cygwin 1.7.9.

Next: fputc Prev: fpclassify Up: Function Substitutes Top: Top


fputc -- GNU Gnulib

Next: fputs Prev: fprintf Up: Function Substitutes Top: Top

9.291. fputc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fputc.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.
  • This function crashes if the stream's file descriptor has already been closed, if MSVC_INVALID_PARAMETER_HANDLING is HAIRY_LIBRARY_HANDLING or SANE_LIBRARY_HANDLING, on some platforms: MSVC 14.

Next: fputs Prev: fprintf Up: Function Substitutes Top: Top


fputs -- GNU Gnulib

Next: fputwc Prev: fputc Up: Function Substitutes Top: Top

9.292. fputs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fputs.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: fputwc Prev: fputc Up: Function Substitutes Top: Top


fputwc -- GNU Gnulib

Next: fputws Prev: fputs Up: Function Substitutes Top: Top

9.293. fputwc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fputwc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fputws Prev: fputs Up: Function Substitutes Top: Top


fputws -- GNU Gnulib

Next: fread Prev: fputwc Up: Function Substitutes Top: Top

9.294. fputws

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fputws.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: fread Prev: fputwc Up: Function Substitutes Top: Top


fread -- GNU Gnulib

Next: free Prev: fputws Up: Function Substitutes Top: Top

9.295. fread

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fread.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • This function crashes if the stream's file descriptor has already been closed, if MSVC_INVALID_PARAMETER_HANDLING is HAIRY_LIBRARY_HANDLING or SANE_LIBRARY_HANDLING, on some platforms: MSVC 14.

Next: free Prev: fputws Up: Function Substitutes Top: Top


free -- GNU Gnulib

Next: freeaddrinfo Prev: fread Up: Function Substitutes Top: Top

9.296. free

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/free.html

Gnulib module: free

Portability problems fixed by Gnulib:

  • On old platforms such as SunOS4, free (NULL) fails. However, since all such systems are so old as to no longer be considered ``reasonable portability targets,'' this module is no longer useful.
Portability problems not fixed by Gnulib:

Next: freeaddrinfo Prev: fread Up: Function Substitutes Top: Top


freeaddrinfo -- GNU Gnulib

Next: freelocale Prev: free Up: Function Substitutes Top: Top

9.297. freeaddrinfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/freeaddrinfo.html

Gnulib module: getaddrinfo

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: freelocale Prev: free Up: Function Substitutes Top: Top


freelocale -- GNU Gnulib

Next: freopen Prev: freeaddrinfo Up: Function Substitutes Top: Top

9.298. freelocale

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/freelocale.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: freopen Prev: freeaddrinfo Up: Function Substitutes Top: Top


freopen -- GNU Gnulib

Next: frexp Prev: freelocale Up: Function Substitutes Top: Top

9.299. freopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/freopen.html

Gnulib module: freopen

Portability problems fixed by Gnulib:

  • On some platforms, if stream does not already have an open file descriptor, freopen returns the stream without opening the file: glibc 2.24.
  • On platforms where off_t is a 32-bit type, freopen may not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • On Windows platforms (excluding Cygwin), this function does usually not recognize the /dev/null filename.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • This function does not support a NULL file name argument on some platforms: OpenBSD 4.9, AIX 7.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14.
  • This function does not fail when the file name argument ends in a slash and (without the slash) names a nonexistent file or a file that is not a directory, on some platforms: HP-UX 11.00, Solaris 9, Irix 5.3.
  • Applications should not assume that fileno(f) will be the same before and after a call to freopen(name,mode,f). However, the module freopen-safer can at least protect stdin, stdout, and stderr.

Next: frexp Prev: freelocale Up: Function Substitutes Top: Top


frexp -- GNU Gnulib

Next: frexpf Prev: freopen Up: Function Substitutes Top: Top

9.300. frexp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/frexp.html

Gnulib module: frexp

Portability problems fixed by Gnulib:

  • This function does not work on denormalized numbers on some platforms: NetBSD 3.0.
  • This function does not work on negative zero on some platforms: NetBSD 4.99, MSVC 14.
  • This function does not work on infinite numbers on some platforms: IRIX 6.5, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: frexpf Prev: freopen Up: Function Substitutes Top: Top


frexpf -- GNU Gnulib

Next: frexpl Prev: frexp Up: Function Substitutes Top: Top

9.301. frexpf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/frexpf.html

Gnulib module: frexpf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function does not work on negative zero on some platforms: mingw.
  • This function does not work on infinite numbers on some platforms: IRIX 6.5, mingw.
Portability problems not fixed by Gnulib:

Next: frexpl Prev: frexp Up: Function Substitutes Top: Top


frexpl -- GNU Gnulib

Next: fscanf Prev: frexpf Up: Function Substitutes Top: Top

9.302. frexpl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/frexpl.html

Gnulib module: frexpl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
  • This function does not work on finite numbers on some platforms: Mac OS X 10.4/PowerPC, AIX 5.1, MSVC 14, BeOS.
  • This function does not work on denormalized numbers on some platforms: Mac OS X 10.5/i386.
  • This function does not work on infinite numbers on some platforms: IRIX 6.5, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: fscanf Prev: frexpf Up: Function Substitutes Top: Top


fscanf -- GNU Gnulib

Next: fseek Prev: frexpl Up: Function Substitutes Top: Top

9.303. fscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fscanf.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, this function doesn't support the hh, ll, j, t, z size specifiers.

Next: fseek Prev: frexpl Up: Function Substitutes Top: Top


fseek -- GNU Gnulib

Next: fseeko Prev: fscanf Up: Function Substitutes Top: Top

9.304. fseek

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fseek.html

Gnulib module: fseek

Portability problems fixed by Gnulib:

  • This function mistakenly succeeds on pipes on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On platforms where long is a 32-bit type, fseek does not work correctly with files larger than 2 GB, even when the AC_SYS_LARGEFILE macro is used. The fix is to use fseeko instead.

Next: fseeko Prev: fscanf Up: Function Substitutes Top: Top


fseeko -- GNU Gnulib

Next: fsetpos Prev: fseek Up: Function Substitutes Top: Top

9.305. fseeko

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fseeko.html

Gnulib module: fseeko

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, OSF/1 4.0, Solaris 2.5.1, mingw, MSVC 14.
  • The declaration of fseeko in <stdio.h> is not enabled by default on some platforms: glibc 2.3.6, OSF/1 5.1.
  • This function fails on seekable stdin, stdout, and stderr: cygwin <= 1.5.24.
  • On platforms where off_t is a 32-bit type, fseeko does not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
  • On platforms where off_t is a 64-bit type, but fseeko is not present, stream operations on files larger than 2 GB silently do the wrong thing. This affects BSD/OS, which is mostly obsolete.

Next: fsetpos Prev: fseek Up: Function Substitutes Top: Top


fsetpos -- GNU Gnulib

Next: fstat Prev: fseeko Up: Function Substitutes Top: Top

9.306. fsetpos

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fsetpos.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: fstat Prev: fseeko Up: Function Substitutes Top: Top


fstat -- GNU Gnulib

Next: fstatat Prev: fsetpos Up: Function Substitutes Top: Top

9.307. fstat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fstat.html

Gnulib module: fstat

Portability problems fixed by Gnulib:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • On platforms where off_t is a 32-bit type, fstat may not correctly report the size of files or block devices larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • The st_atime, st_ctime, st_mtime fields are affected by the current time zone and by the DST flag of the current time zone on some platforms: mingw, MSVC 14 (when the environment variable TZ is set).
Portability problems not fixed by Gnulib:
  • See sys/stat.h, for general portability problems with struct stat.
  • On Cygwin, fstat applied to the file descriptors 0 and 1, returns different st_ino values, even if standard input and standard output are not redirected and refer to the same terminal.

Next: fstatat Prev: fsetpos Up: Function Substitutes Top: Top


fstatat -- GNU Gnulib

Next: fstatvfs Prev: fstat Up: Function Substitutes Top: Top

9.308. fstatat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fstatat.html

Gnulib module: fstatat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • On platforms where off_t is a 32-bit type, fstatat may not correctly report the size of files or block devices larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • On some platforms, fstatat(fd,"file/",buf,flag) succeeds instead of failing with ENOTDIR. Solaris 9.
  • For symlinks, when the argument ends in a slash, some platforms don't dereference the argument: Solaris 9.
Portability problems not fixed by Gnulib:
  • See sys/stat.h, for general portability problems with struct stat.

Next: fstatvfs Prev: fstat Up: Function Substitutes Top: Top


fstatvfs -- GNU Gnulib

Next: fsync Prev: fstatat Up: Function Substitutes Top: Top

9.309. fstatvfs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fstatvfs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, mingw, MSVC 14.
  • On platforms where f_blocks in `struct statvfs' is a 32-bit value, this function may not work correctly on files systems larger than 4 TiB. The fix is to use the AC_SYS_LARGEFILE macro. This affects glibc/Hurd, HP-UX 11, Solaris.

Next: fsync Prev: fstatat Up: Function Substitutes Top: Top


fsync -- GNU Gnulib

Next: ftell Prev: fstatvfs Up: Function Substitutes Top: Top

9.310. fsync

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fsync.html

Gnulib module: fsync

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • If the argument is a read-only file descriptor, this function fails with EBADF on some platforms: AIX 7.1.

Next: ftell Prev: fstatvfs Up: Function Substitutes Top: Top


ftell -- GNU Gnulib

Next: ftello Prev: fsync Up: Function Substitutes Top: Top

9.311. ftell

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftell.html

Gnulib module: ftell

Portability problems fixed by Gnulib:

  • This function mistakenly succeeds on pipes on some platforms: mingw, MSVC 14.
  • This function produces incorrect results after putc that followed a getc call that reached EOF on some platforms: Solaris 11 2010-11.
Portability problems not fixed by Gnulib:
  • This function produces incorrect results immediately after fseek on some platforms: HP-UX 11.
  • fflush, ftell, ftello, fgetpos behave incorrectly on input streams that are opened in O_TEXT mode and whose contents contains Unix line terminators (LF), on some platforms: mingw, MSVC 14.
  • On platforms where long is a 32-bit type, ftell does not work correctly with files larger than 2 GB, even when the AC_SYS_LARGEFILE macro is used. The fix is to use ftello instead.

Next: ftello Prev: fsync Up: Function Substitutes Top: Top


ftello -- GNU Gnulib

Next: ftok Prev: ftell Up: Function Substitutes Top: Top

9.312. ftello

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftello.html

Gnulib module: ftello

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, OSF/1 4.0, Solaris 2.5.1, mingw, MSVC 14.
  • The declaration of ftello in <stdio.h> is not enabled by default on some platforms: glibc 2.3.6, OSF/1 5.1.
  • This function produces incorrect results after putc that followed a getc call that reached EOF on some platforms: Solaris 11 2010-11.
  • This function fails on seekable stdin, stdout, and stderr: cygwin <= 1.5.24.
  • On platforms where off_t is a 32-bit type, ftello does not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
  • This function produces incorrect results immediately after fseek on some platforms: HP-UX 11.
  • fflush, ftell, ftello, fgetpos behave incorrectly on input streams that are opened in O_TEXT mode and whose contents contains Unix line terminators (LF), on some platforms: mingw, MSVC 14.
  • On platforms where off_t is a 64-bit type, but fseeko is not present, stream operations on files larger than 2 GB silently do the wrong thing. This affects BSD/OS, which is mostly obsolete.

Next: ftok Prev: ftell Up: Function Substitutes Top: Top


ftok -- GNU Gnulib

Next: ftruncate Prev: ftello Up: Function Substitutes Top: Top

9.313. ftok

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftok.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: ftruncate Prev: ftello Up: Function Substitutes Top: Top


ftruncate -- GNU Gnulib

Next: ftrylockfile Prev: ftok Up: Function Substitutes Top: Top

9.314. ftruncate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftruncate.html

Gnulib module: ftruncate

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • On platforms where off_t is a 32-bit type, this function is not applicable to arbitrary lengths for files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.
Portability problems not fixed by Gnulib:

Next: ftrylockfile Prev: ftok Up: Function Substitutes Top: Top


ftrylockfile -- GNU Gnulib

Next: ftw Prev: ftruncate Up: Function Substitutes Top: Top

9.315. ftrylockfile

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftrylockfile.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14.

Next: ftw Prev: ftruncate Up: Function Substitutes Top: Top


ftw -- GNU Gnulib

Next: funlockfile Prev: ftrylockfile Up: Function Substitutes Top: Top

9.316. ftw

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ftw.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 3.0, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not correctly report the size of files or block devices larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: funlockfile Prev: ftrylockfile Up: Function Substitutes Top: Top


funlockfile -- GNU Gnulib

Next: futimens Prev: ftw Up: Function Substitutes Top: Top

9.317. funlockfile

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/funlockfile.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: futimens Prev: ftw Up: Function Substitutes Top: Top


futimens -- GNU Gnulib

Next: fwide Prev: funlockfile Up: Function Substitutes Top: Top

9.318. futimens

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/futimens.html

Gnulib module: futimens

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. However, the replacement function may end up truncating timestamps to less resolution than supported by the file system.
  • This function returns a bogus value instead of failing with ENOSYS on some platforms: Linux kernel 2.6.21.
  • When using UTIME_OMIT or UTIME_NOW, some systems require the tv_sec argument to be 0, and don't necessarily handle all file permissions in the manner required by POSIX: Linux kernel 2.6.25.
  • When using UTIME_OMIT for the modification time, but specifying an access time, some systems fail to update the change time: Linux kernel 2.6.32, Solaris 11.1.
  • Passing AT_FDCWD as the fd argument does not properly fail with EBADF on some systems: glibc 2.11, Solaris 11.
Portability problems not fixed by Gnulib:
  • Some platforms lack the ability to change the timestamps of a file descriptor, so the replacement can fail with ENOSYS; the gnulib module `utimens' provides a more reliable interface fdutimens.
  • The mere act of using stat modifies the access time of directories on some platforms, so utimensat can only effectively change directory modification time: Cygwin 1.5.x.

Next: fwide Prev: funlockfile Up: Function Substitutes Top: Top


fwide -- GNU Gnulib

Next: fwprintf Prev: futimens Up: Function Substitutes Top: Top

9.319. fwide

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fwide.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • fwide is not guaranteed to be able to change a file stream's mode to a different mode than the current one.

Next: fwprintf Prev: futimens Up: Function Substitutes Top: Top


fwprintf -- GNU Gnulib

Next: fwrite Prev: fwide Up: Function Substitutes Top: Top

9.320. fwprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fwprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: fwrite Prev: fwide Up: Function Substitutes Top: Top


fwrite -- GNU Gnulib

Next: fwscanf Prev: fwprintf Up: Function Substitutes Top: Top

9.321. fwrite

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fwrite.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.
  • This function crashes if the stream's file descriptor has already been closed, if MSVC_INVALID_PARAMETER_HANDLING is HAIRY_LIBRARY_HANDLING or SANE_LIBRARY_HANDLING, on some platforms: MSVC 14.

Next: fwscanf Prev: fwprintf Up: Function Substitutes Top: Top


fwscanf -- GNU Gnulib

Next: gai_strerror Prev: fwrite Up: Function Substitutes Top: Top

9.322. fwscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/fwscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: gai_strerror Prev: fwrite Up: Function Substitutes Top: Top


gai_strerror -- GNU Gnulib

Next: getaddrinfo Prev: fwscanf Up: Function Substitutes Top: Top

9.323. gai_strerror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gai_strerror.html

Gnulib module: getaddrinfo

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, Interix 3.5, BeOS.
  • This function is only available in <ws2tcpip.h> on some platforms: mingw, MSVC 14.
  • This function's return type is char * instead of const char * on some platforms: AIX 7.1, HP-UX 11, OSF/1 5.1, Solaris 9, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: getaddrinfo Prev: fwscanf Up: Function Substitutes Top: Top


getaddrinfo -- GNU Gnulib

Next: getc Prev: gai_strerror Up: Function Substitutes Top: Top

9.324. getaddrinfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getaddrinfo.html

Gnulib module: getaddrinfo

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • On Windows, this function is declared in <ws2tcpip.h> rather than in <netdb.h>.
Portability problems not fixed by Gnulib:

Next: getc Prev: gai_strerror Up: Function Substitutes Top: Top


getc -- GNU Gnulib

Next: getc_unlocked Prev: getaddrinfo Up: Function Substitutes Top: Top

9.325. getc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getc.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: getc_unlocked Prev: getaddrinfo Up: Function Substitutes Top: Top


getc_unlocked -- GNU Gnulib

Next: getchar Prev: getc Up: Function Substitutes Top: Top

9.326. getc_unlocked

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getc_unlocked.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: getchar Prev: getc Up: Function Substitutes Top: Top


getchar -- GNU Gnulib

Next: getchar_unlocked Prev: getc_unlocked Up: Function Substitutes Top: Top

9.327. getchar

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getchar.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: getchar_unlocked Prev: getc_unlocked Up: Function Substitutes Top: Top


getchar_unlocked -- GNU Gnulib

Next: getcwd Prev: getchar Up: Function Substitutes Top: Top

9.328. getchar_unlocked

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getchar_unlocked.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: getcwd Prev: getchar Up: Function Substitutes Top: Top


getcwd -- GNU Gnulib

Next: getdate Prev: getchar_unlocked Up: Function Substitutes Top: Top

9.329. getcwd

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getcwd.html

Gnulib module: getcwd or getcwd-lgpl

Portability problems fixed by either Gnulib module getcwd or getcwd-lgpl:

  • This function is declared in different header files (namely, <io.h> or <direct.h>) on some platforms: mingw, MSVC 14.
  • On glibc and Solaris 11.3 platforms, getcwd (NULL, n) allocates memory for the result. On some other platforms, this call is not allowed.
  • On some platforms, the prototype for getcwd uses int instead of size_t for the size argument when using non-standard headers, and the declaration is missing from <unistd.h>: mingw, MSVC 14.
  • On some platforms, getcwd (buf, 0) fails with ERANGE instead of the required EINVAL: mingw, MSVC 14.
Portability problems fixed by Gnulib module getcwd:
  • This function is missing on some older platforms.
  • This function does not handle long file names (greater than PATH_MAX) correctly on some platforms: glibc on Linux 2.4.20, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.1, OpenBSD 4.9, AIX 7.1.
Portability problems not fixed by Gnulib:
  • When using getcwd(NULL, nonzero), some platforms, such as glibc or cygwin, allocate exactly nonzero bytes and fail with ERANGE if it was not big enough, while other platforms, such as FreeBSD, mingw, or MSVC 14, ignore the size argument and allocate whatever size is necessary. If this call succeeds, an application cannot portably access beyond the string length of the result.

Next: getdate Prev: getchar_unlocked Up: Function Substitutes Top: Top


getdate -- GNU Gnulib

Next: getdate_err Prev: getcwd Up: Function Substitutes Top: Top

9.330. getdate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getdate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.
Gnulib provides a module parse-datetime that contains a function parse_datetime that has similar functionality as the getdate function.

Next: getdate_err Prev: getcwd Up: Function Substitutes Top: Top


getdate_err -- GNU Gnulib

Next: getdelim Prev: getdate Up: Function Substitutes Top: Top

9.331. getdate_err

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getdate_err.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: getdelim Prev: getdate Up: Function Substitutes Top: Top


getdelim -- GNU Gnulib

Next: getegid Prev: getdate_err Up: Function Substitutes Top: Top

9.332. getdelim

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getdelim.html

Gnulib module: getdelim

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5.
  • This function is missing a declaration on some platforms: BeOS.
  • This function crashes when passed a pointer to a NULL buffer together with a pointer to a non-zero buffer size on some platforms: FreeBSD 8.0.
Portability problems not fixed by Gnulib:
  • This function has quadratic running time for long lines on some platforms: uClibc 0.9.31.

Next: getegid Prev: getdate_err Up: Function Substitutes Top: Top


getegid -- GNU Gnulib

Next: getenv Prev: getdelim Up: Function Substitutes Top: Top

9.333. getegid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getegid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getenv Prev: getdelim Up: Function Substitutes Top: Top


getenv -- GNU Gnulib

Next: geteuid Prev: getegid Up: Function Substitutes Top: Top

9.334. getenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getenv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: geteuid Prev: getegid Up: Function Substitutes Top: Top


geteuid -- GNU Gnulib

Next: getgid Prev: getenv Up: Function Substitutes Top: Top

9.335. geteuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/geteuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getgid Prev: getenv Up: Function Substitutes Top: Top


getgid -- GNU Gnulib

Next: getgrent Prev: geteuid Up: Function Substitutes Top: Top

9.336. getgid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getgrent Prev: geteuid Up: Function Substitutes Top: Top


getgrent -- GNU Gnulib

Next: getgrgid Prev: getgid Up: Function Substitutes Top: Top

9.337. getgrent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgrent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getgrgid Prev: getgid Up: Function Substitutes Top: Top


getgrgid -- GNU Gnulib

Next: getgrgid_r Prev: getgrent Up: Function Substitutes Top: Top

9.338. getgrgid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgrgid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getgrgid_r Prev: getgrent Up: Function Substitutes Top: Top


getgrgid_r -- GNU Gnulib

Next: getgrnam Prev: getgrgid Up: Function Substitutes Top: Top

9.339. getgrgid_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgrgid_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getgrnam Prev: getgrgid Up: Function Substitutes Top: Top


getgrnam -- GNU Gnulib

Next: getgrnam_r Prev: getgrgid_r Up: Function Substitutes Top: Top

9.340. getgrnam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgrnam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getgrnam_r Prev: getgrgid_r Up: Function Substitutes Top: Top


getgrnam_r -- GNU Gnulib

Next: getgroups Prev: getgrnam Up: Function Substitutes Top: Top

9.341. getgrnam_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgrnam_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getgroups Prev: getgrnam Up: Function Substitutes Top: Top


getgroups -- GNU Gnulib

Next: gethostent Prev: getgrnam_r Up: Function Substitutes Top: Top

9.342. getgroups

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getgroups.html

Gnulib module: getgroups

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • On some platforms, this function fails to reject a negative count, even though that is less than the size that would be returned: FreeBSD 7.2.
  • On Ultrix 4.3, getgroups (0, NULL) always fails. See macro `AC_FUNC_GETGROUPS'.
  • On very old systems, this function operated on an array of `int', even though that was a different size than an array of `gid_t'.
Portability problems not fixed by Gnulib:
  • This function is unsafe to call between fork and exec if the parent process is multi-threaded.
  • It is unspecified whether the effective group id will be included in the returned list, nor whether the list will be sorted in any particular order. For that matter, some platforms include the effective group id twice, if it is also a member of the current supplemental group ids.
The Gnulib module mgetgroups provides a similar API.

Next: gethostent Prev: getgrnam_r Up: Function Substitutes Top: Top


gethostent -- GNU Gnulib

Next: gethostid Prev: getgroups Up: Function Substitutes Top: Top

9.343. gethostent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gethostent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: gethostid Prev: getgroups Up: Function Substitutes Top: Top


gethostid -- GNU Gnulib

Next: gethostname Prev: gethostent Up: Function Substitutes Top: Top

9.344. gethostid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gethostid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostname Prev: gethostent Up: Function Substitutes Top: Top


gethostname -- GNU Gnulib

Next: getitimer Prev: gethostid Up: Function Substitutes Top: Top

9.345. gethostname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gethostname.html

Gnulib module: gethostname

Portability problems fixed by Gnulib:

  • On mingw and MSVC 14, this function has a prototype that differs from that specified by POSIX, and it is defined only in the ws2_32 library.
Portability problems not fixed by Gnulib:
  • This function's second argument type is int instead of size_t on some platforms: OSF/1 5.1, Solaris 10.
  • If the given buffer is too small for the host name, some implementations fail with EINVAL, instead of returning a truncated host name.

Next: getitimer Prev: gethostid Up: Function Substitutes Top: Top


getitimer -- GNU Gnulib

Next: getline Prev: gethostname Up: Function Substitutes Top: Top

9.346. getitimer

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getitimer.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getline Prev: gethostname Up: Function Substitutes Top: Top


getline -- GNU Gnulib

Next: getlogin Prev: getitimer Up: Function Substitutes Top: Top

9.347. getline

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getline.html

Gnulib module: getline

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5.
  • This function is missing a declaration on some platforms: AIX 7.1, BeOS.
  • Some platforms provide a function by this name but with the wrong signature, for example in -linet.
  • This function crashes when passed a pointer to a NULL buffer together with a pointer to a non-zero buffer size on some platforms: FreeBSD 8.0.
Portability problems not fixed by Gnulib:
  • This function has quadratic running time for long lines on some platforms: uClibc 0.9.31.

Next: getlogin Prev: getitimer Up: Function Substitutes Top: Top


getlogin -- GNU Gnulib

Next: getlogin_r Prev: getline Up: Function Substitutes Top: Top

9.348. getlogin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getlogin.html

Gnulib module: getlogin

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: older mingw, MSVC 14.
  • This function is not declared unless _POSIX is defined on some platforms: mingw.
Portability problems not fixed by Gnulib:
  • This function returns an empty string even when standard input is a tty on some platforms: HP-UX 11.11.

Next: getlogin_r Prev: getline Up: Function Substitutes Top: Top


getlogin_r -- GNU Gnulib

Next: getmsg Prev: getlogin Up: Function Substitutes Top: Top

9.349. getlogin_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getlogin_r.html

Gnulib module: getlogin_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 3.0, Minix 3.1.8, mingw, MSVC 14.
  • This function is not declared unless _REENTRANT is defined, on some platforms: HP-UX 11.
  • This function returns a truncated result, instead of failing with error code ERANGE, when the buffer is not large enough, on some platforms: Mac OS X 10.12, OSF/1 5.1.
Portability problems not fixed by Gnulib:
  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
  • This function fails even when standard input is a tty on some platforms: HP-UX 11.11.
  • This function fails with error code EINVAL instead of ERANGE when the second argument is zero on some platforms: HP-UX 11.31.

Next: getmsg Prev: getlogin Up: Function Substitutes Top: Top


getmsg -- GNU Gnulib

Next: getnameinfo Prev: getlogin_r Up: Function Substitutes Top: Top

9.350. getmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnameinfo Prev: getlogin_r Up: Function Substitutes Top: Top


getnameinfo -- GNU Gnulib

Next: getnetbyaddr Prev: getmsg Up: Function Substitutes Top: Top

9.351. getnameinfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getnameinfo.html

Gnulib module: getaddrinfo

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: getnetbyaddr Prev: getmsg Up: Function Substitutes Top: Top


getnetbyaddr -- GNU Gnulib

Next: getnetbyname Prev: getnameinfo Up: Function Substitutes Top: Top

9.352. getnetbyaddr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getnetbyaddr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: getnetbyname Prev: getnameinfo Up: Function Substitutes Top: Top


getnetbyname -- GNU Gnulib

Next: getnetent Prev: getnetbyaddr Up: Function Substitutes Top: Top

9.353. getnetbyname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getnetbyname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: getnetent Prev: getnetbyaddr Up: Function Substitutes Top: Top


getnetent -- GNU Gnulib

Next: getopt Prev: getnetbyname Up: Function Substitutes Top: Top

9.354. getnetent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getnetent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: getopt Prev: getnetbyname Up: Function Substitutes Top: Top


getopt -- GNU Gnulib

Next: getpeername Prev: getnetent Up: Function Substitutes Top: Top

9.355. getopt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getopt.html

Gnulib module: getopt-posix or getopt-gnu

The module getopt-gnu has support for ``long options'' and for ``options that take optional arguments''. Compared to the API defined by POSIX, it adds a header file <getopt.h> and a function getopt_long.

Portability problems fixed by either Gnulib module getopt-posix or getopt-gnu:

  • This function is missing on some platforms: MSVC 14.
  • The value of optind after a missing required argument is wrong on some platforms: Mac OS X 10.5, AIX 7.1, mingw.
Portability problems fixed by Gnulib module getopt-gnu:
  • The function getopt does not support the `+' flag in the options string on some platforms: Mac OS X 10.5, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11.
  • The function getopt does not obey the combination of `+' and `:' flags in the options string on some platforms: glibc 2.11.
  • The function getopt does not obey the `-' flag in the options string when @env{POSIXLY_CORRECT} is set on some platforms: Cygwin 1.7.0.
  • The function getopt does not support options with optional arguments on some platforms: Mac OS X 10.5, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11, Cygwin 1.5.x.
  • The function getopt_long is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, MSVC 14, Interix 3.5.
  • The function getopt_long does not support abbreviated long options where all disambiguations are equivalent on some platforms: OpenBSD 5.0.
  • The function getopt_long_only is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 5.0, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 14, Interix 3.5.
  • This function crashes if the option string includes W; on some platforms: glibc 2.14.
Portability problems not fixed by Gnulib:
  • The default behavior of the glibc implementation of getopt allows mixing option and non-option arguments on the command line in any order. Other implementations, such as the one in Cygwin, enforce strict POSIX compliance: they require that the option arguments precede the non-option arguments. This is something to watch out in your program's testsuite.
  • The glibc implementation allows a complete reset of the environment, including re-checking for @env{POSIXLY_CORRECT}, by setting optind to 0. Several BSD implementations provide optreset, causing a reset by setting it non-zero, although it does not necessarily re-read @env{POSIXLY_CORRECT}. Solaris getopt does not support either reset method, but does not maintain state that needs the extra level of reset.
  • On some platforms, this function does not set the stream error indicator on attempts to write to a read-only stream: glibc 2.13, Cygwin 1.7.9.

Next: getpeername Prev: getnetent Up: Function Substitutes Top: Top


getpeername -- GNU Gnulib

Next: getpgid Prev: getopt Up: Function Substitutes Top: Top

9.356. getpeername

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpeername.html

Gnulib module: getpeername

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • Some platforms don't have a socklen_t type; in this case this function's third argument type is `int *'.

Next: getpgid Prev: getopt Up: Function Substitutes Top: Top


getpgid -- GNU Gnulib

Next: getpgrp Prev: getpeername Up: Function Substitutes Top: Top

9.357. getpgid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpgid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getpgrp Prev: getpeername Up: Function Substitutes Top: Top


getpgrp -- GNU Gnulib

Next: getpid Prev: getpgid Up: Function Substitutes Top: Top

9.358. getpgrp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpgrp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getpid Prev: getpgid Up: Function Substitutes Top: Top


getpid -- GNU Gnulib

Next: getpmsg Prev: getpgrp Up: Function Substitutes Top: Top

9.359. getpid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: getpmsg Prev: getpgrp Up: Function Substitutes Top: Top


getpmsg -- GNU Gnulib

Next: getppid Prev: getpid Up: Function Substitutes Top: Top

9.360. getpmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getppid Prev: getpid Up: Function Substitutes Top: Top


getppid -- GNU Gnulib

Next: getpriority Prev: getpmsg Up: Function Substitutes Top: Top

9.361. getppid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getppid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getpriority Prev: getpmsg Up: Function Substitutes Top: Top


getpriority -- GNU Gnulib

Next: getprotobyname Prev: getppid Up: Function Substitutes Top: Top

9.362. getpriority

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpriority.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, BeOS.

Next: getprotobyname Prev: getppid Up: Function Substitutes Top: Top


getprotobyname -- GNU Gnulib

Next: getprotobynumber Prev: getpriority Up: Function Substitutes Top: Top

9.363. getprotobyname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getprotobyname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getprotobynumber Prev: getpriority Up: Function Substitutes Top: Top


getprotobynumber -- GNU Gnulib

Next: getprotoent Prev: getprotobyname Up: Function Substitutes Top: Top

9.364. getprotobynumber

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getprotobynumber.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getprotoent Prev: getprotobyname Up: Function Substitutes Top: Top


getprotoent -- GNU Gnulib

Next: getpwent Prev: getprotobynumber Up: Function Substitutes Top: Top

9.365. getprotoent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getprotoent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getpwent Prev: getprotobynumber Up: Function Substitutes Top: Top


getpwent -- GNU Gnulib

Next: getpwnam Prev: getprotoent Up: Function Substitutes Top: Top

9.366. getpwent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpwent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getpwnam Prev: getprotoent Up: Function Substitutes Top: Top


getpwnam -- GNU Gnulib

Next: getpwnam_r Prev: getpwent Up: Function Substitutes Top: Top

9.367. getpwnam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpwnam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getpwnam_r Prev: getpwent Up: Function Substitutes Top: Top


getpwnam_r -- GNU Gnulib

Next: getpwuid Prev: getpwnam Up: Function Substitutes Top: Top

9.368. getpwnam_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpwnam_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function has an incompatible declaration, with fewer than five arguments, on some platforms: IRIX 5.3.

Next: getpwuid Prev: getpwnam Up: Function Substitutes Top: Top


getpwuid -- GNU Gnulib

Next: getpwuid_r Prev: getpwnam_r Up: Function Substitutes Top: Top

9.369. getpwuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpwuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is unsafe to call between fork and exec if the parent process is multi-threaded. Instead, use getpwuid_r prior to forking.
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getpwuid_r Prev: getpwnam_r Up: Function Substitutes Top: Top


getpwuid_r -- GNU Gnulib

Next: getrlimit Prev: getpwuid Up: Function Substitutes Top: Top

9.370. getpwuid_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getpwuid_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is unsafe to call between fork and exec if the parent process is multi-threaded. Use it prior to forking.
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getrlimit Prev: getpwuid Up: Function Substitutes Top: Top


getrlimit -- GNU Gnulib

Next: getrusage Prev: getpwuid_r Up: Function Substitutes Top: Top

9.371. getrlimit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getrlimit.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • On platforms where rlim_t is a 32-bit type, this function does not allow to retrieve limits larger than 4 GB, such as for RLIMIT_FSIZE. The fix is to use the AC_SYS_LARGEFILE macro.

Next: getrusage Prev: getpwuid_r Up: Function Substitutes Top: Top


getrusage -- GNU Gnulib

Next: gets Prev: getrlimit Up: Function Substitutes Top: Top

9.372. getrusage

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getrusage.html

Gnulib module: getrusage

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Many platforms don't fill in all the fields of struct rusage with meaningful values.

Next: gets Prev: getrlimit Up: Function Substitutes Top: Top


gets -- GNU Gnulib

Next: getservbyname Prev: getrusage Up: Function Substitutes Top: Top

9.373. gets

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gets.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function should never be used, because it can overflow any given buffer.
  • This function is missing on some platforms: Solaris 11.3.
  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: getservbyname Prev: getrusage Up: Function Substitutes Top: Top


getservbyname -- GNU Gnulib

Next: getservbyport Prev: gets Up: Function Substitutes Top: Top

9.374. getservbyname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getservbyname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getservbyport Prev: gets Up: Function Substitutes Top: Top


getservbyport -- GNU Gnulib

Next: getservent Prev: getservbyname Up: Function Substitutes Top: Top

9.375. getservbyport

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getservbyport.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getservent Prev: getservbyname Up: Function Substitutes Top: Top


getservent -- GNU Gnulib

Next: getsid Prev: getservbyport Up: Function Substitutes Top: Top

9.376. getservent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getservent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: getsid Prev: getservbyport Up: Function Substitutes Top: Top


getsid -- GNU Gnulib

Next: getsockname Prev: getservent Up: Function Substitutes Top: Top

9.377. getsid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getsid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsockname Prev: getservent Up: Function Substitutes Top: Top


getsockname -- GNU Gnulib

Next: getsockopt Prev: getsid Up: Function Substitutes Top: Top

9.378. getsockname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getsockname.html

Gnulib module: getsockname

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • Some platforms don't have a socklen_t type; in this case this function's third argument type is `int *'.

Next: getsockopt Prev: getsid Up: Function Substitutes Top: Top


getsockopt -- GNU Gnulib

Next: getsubopt Prev: getsockname Up: Function Substitutes Top: Top

9.379. getsockopt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getsockopt.html

Gnulib module: getsockopt

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.
  • Some platforms don't have a socklen_t type; in this case this function's fifth argument type is `int *'.
  • Many socket options are not available on all platforms.
  • BeOS has the setsockopt function, but not the getsockopt function.

Next: getsubopt Prev: getsockname Up: Function Substitutes Top: Top


getsubopt -- GNU Gnulib

Next: gettimeofday Prev: getsockopt Up: Function Substitutes Top: Top

9.380. getsubopt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getsubopt.html

Gnulib module: getsubopt

Portability problems fixed by Gnulib:

  • This function is declared in unistd.h instead of stdlib.h on some platforms: Cygwin 1.7.1.
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: gettimeofday Prev: getsockopt Up: Function Substitutes Top: Top


gettimeofday -- GNU Gnulib

Next: getuid Prev: getsubopt Up: Function Substitutes Top: Top

9.381. gettimeofday

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gettimeofday.html

Gnulib module: gettimeofday

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • This function is declared with a nonstandard function prototype (only one argument, or ``...'' after the first argument) on some platforms.
  • On some platforms, the second argument has type struct timezone* rather than void *, making it an error to redeclare the function with the POSIX signature: glibc. However, rather than penalize these systems with a replacement function, gnulib defines GETTIMEOFDAY_TIMEZONE to the appropriate type for use in avoiding a compiler warning if assigning gettimeofday to a function pointer.
  • On some platforms, gettimeofday clobbers the buffer in which localtime returns its result: Mac OS X 10.0.
  • This function has only a precision of 15.6 milliseconds on some platforms: mingw.
Portability problems not fixed by Gnulib:
  • Behavior is non-portable if the second argument to gettimeofday is not NULL.

Next: getuid Prev: getsubopt Up: Function Substitutes Top: Top


getuid -- GNU Gnulib

Next: getutxent Prev: gettimeofday Up: Function Substitutes Top: Top

9.382. getuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getutxent Prev: gettimeofday Up: Function Substitutes Top: Top


getutxent -- GNU Gnulib

Next: getutxid Prev: getuid Up: Function Substitutes Top: Top

9.383. getutxent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getutxent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getutxid Prev: getuid Up: Function Substitutes Top: Top


getutxid -- GNU Gnulib

Next: getutxline Prev: getutxent Up: Function Substitutes Top: Top

9.384. getutxid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getutxid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getutxline Prev: getutxent Up: Function Substitutes Top: Top


getutxline -- GNU Gnulib

Next: getwc Prev: getutxid Up: Function Substitutes Top: Top

9.385. getutxline

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getutxline.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: getwc Prev: getutxid Up: Function Substitutes Top: Top


getwc -- GNU Gnulib

Next: getwchar Prev: getutxline Up: Function Substitutes Top: Top

9.386. getwc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getwc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: getwchar Prev: getutxline Up: Function Substitutes Top: Top


getwchar -- GNU Gnulib

Next: glob Prev: getwc Up: Function Substitutes Top: Top

9.387. getwchar

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/getwchar.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: glob Prev: getwc Up: Function Substitutes Top: Top


glob -- GNU Gnulib

Next: globfree Prev: getwchar Up: Function Substitutes Top: Top

9.388. glob

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/glob.html

Gnulib module: glob

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, mingw, MSVC 14, BeOS.
  • This function does not list symbolic links to nonexistent files among the results, on some platforms: glibc 2.26, AIX 7.2, HP-UX 11, Solaris 11.3.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
  • Some platforms may store additional flags in the gl_flags field.

Next: globfree Prev: getwchar Up: Function Substitutes Top: Top


globfree -- GNU Gnulib

Next: gmtime Prev: glob Up: Function Substitutes Top: Top

9.389. globfree

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/globfree.html

Gnulib module: glob

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: gmtime Prev: glob Up: Function Substitutes Top: Top


gmtime -- GNU Gnulib

Next: gmtime_r Prev: globfree Up: Function Substitutes Top: Top

9.390. gmtime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gmtime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: gmtime_r Prev: globfree Up: Function Substitutes Top: Top


gmtime_r -- GNU Gnulib

Next: grantpt Prev: gmtime Up: Function Substitutes Top: Top

9.391. gmtime_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/gmtime_r.html

Gnulib module: time_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function is not declared unless _REENTRANT is defined, on some platforms: HP-UX 11.
  • Some platforms define a function of this name that is incompatible to POSIX: HP-UX 10.
Portability problems not fixed by Gnulib:

Next: grantpt Prev: gmtime Up: Function Substitutes Top: Top


grantpt -- GNU Gnulib

Next: hcreate Prev: gmtime_r Up: Function Substitutes Top: Top

9.392. grantpt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/grantpt.html

Gnulib module: grantpt

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • This function is not declared on some platforms: IRIX 5.3.
  • This function reports success for invalid file descriptors on some platforms: OpenBSD, Cygwin 1.7.9, musl libc.

Next: hcreate Prev: gmtime_r Up: Function Substitutes Top: Top


hcreate -- GNU Gnulib

Next: hdestroy Prev: grantpt Up: Function Substitutes Top: Top

9.393. hcreate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hcreate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: hdestroy Prev: grantpt Up: Function Substitutes Top: Top


hdestroy -- GNU Gnulib

Next: hsearch Prev: hcreate Up: Function Substitutes Top: Top

9.394. hdestroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hdestroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: hsearch Prev: hcreate Up: Function Substitutes Top: Top


hsearch -- GNU Gnulib

Next: htonl Prev: hdestroy Up: Function Substitutes Top: Top

9.395. hsearch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hsearch.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: htonl Prev: hdestroy Up: Function Substitutes Top: Top


htonl -- GNU Gnulib

Next: htons Prev: hsearch Up: Function Substitutes Top: Top

9.396. htonl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/htonl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, mingw, MSVC 14, BeOS.

Next: htons Prev: hsearch Up: Function Substitutes Top: Top


htons -- GNU Gnulib

Next: hypot Prev: htonl Up: Function Substitutes Top: Top

9.397. htons

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/htons.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, mingw, MSVC 14, BeOS.

Next: hypot Prev: htonl Up: Function Substitutes Top: Top


hypot -- GNU Gnulib

Next: hypotf Prev: htons Up: Function Substitutes Top: Top

9.398. hypot

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hypot.html

Gnulib module: hypot or hypot-ieee

Portability problems fixed by either Gnulib module hypot or hypot-ieee:

Portability problems fixed by Gnulib module hypot-ieee:
  • When the arguments are mixed NaN and Infinity, this function returns a wrong value on some platforms: OSF/1 5.1, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: hypotf Prev: htons Up: Function Substitutes Top: Top


hypotf -- GNU Gnulib

Next: hypotl Prev: hypot Up: Function Substitutes Top: Top

9.399. hypotf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hypotf.html

Gnulib module: hypotf or hypotf-ieee

Portability problems fixed by either Gnulib module hypotf or hypotf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, MSVC 14.
  • This function produces wrong values on some platforms: NetBSD 5.1, OpenBSD 4.9.
Portability problems fixed by Gnulib module hypot-ieee:
  • When the arguments are mixed NaN and Infinity, this function returns a wrong value on some platforms: OSF/1 5.1, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: hypotl Prev: hypot Up: Function Substitutes Top: Top


hypotl -- GNU Gnulib

Next: iconv Prev: hypotf Up: Function Substitutes Top: Top

9.400. hypotl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/hypotl.html

Gnulib module: hypotl or hypotl-ieee

Portability problems fixed by either Gnulib module hypotl or hypotl-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, MSVC 14, Interix 3.5, BeOS.
  • This function produces very imprecise results on some platforms: OpenBSD 5.1/SPARC.
Portability problems fixed by Gnulib module hypotl-ieee:
  • When the arguments are mixed NaN and Infinity, this function returns a wrong value on some platforms: OSF/1 5.1, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: iconv Prev: hypotf Up: Function Substitutes Top: Top


iconv -- GNU Gnulib

Next: iconv_close Prev: hypotl Up: Function Substitutes Top: Top

9.401. iconv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iconv.html

Gnulib module: iconv

Portability problems fixed by Gnulib:

  • GNU libiconv is not found if installed in $PREFIX/lib.
  • Failures are not distinguishable from successful returns on some platforms: AIX 5.1, Solaris 10.
  • A buffer overrun can occur on some platforms: AIX 6.1..7.1.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin, mingw, MSVC 14, BeOS, when GNU libiconv is not installed.
  • This function was not correctly implemented in glibc versions before 2.2.
  • When iconv encounters an input character that is valid but that cannot be converted to the output character set, glibc's and GNU libiconv's iconv stop the conversion. Some other implementations put an implementation-defined character into the output buffer. Gnulib provides higher-level facilities striconv and striconveh (wrappers around iconv) that deal with conversion errors in a platform independent way.
  • This function returns a positive return value, instead of zero, when converting from ISO-8859-1 to UTF-8 on HP-UX 11.

Next: iconv_close Prev: hypotl Up: Function Substitutes Top: Top


iconv_close -- GNU Gnulib

Next: iconv_open Prev: iconv Up: Function Substitutes Top: Top

9.402. iconv_close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iconv_close.html

Gnulib module: iconv

Portability problems fixed by Gnulib:

  • GNU libiconv is not found if installed in $PREFIX/lib.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin, mingw, MSVC 14, BeOS, when GNU libiconv is not installed.

Next: iconv_open Prev: iconv Up: Function Substitutes Top: Top


iconv_open -- GNU Gnulib

Next: if_freenameindex Prev: iconv_close Up: Function Substitutes Top: Top

9.403. iconv_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iconv_open.html

Gnulib module: iconv, iconv_open, iconv_open-utf

Portability problems fixed by either Gnulib module iconv or iconv_open:

  • GNU libiconv is not found if installed in $PREFIX/lib.
  • No converter from EUC-JP to UTF-8 is provided on some platforms: HP-UX 11.
Portability problems fixed by Gnulib module iconv_open:
  • This function recognizes only non-standard aliases for many encodings (not the IANA registered encoding names) on many platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11 2010-11.
Portability problems fixed by Gnulib module iconv_open-utf:
  • This function does not support the encodings UTF-16BE, UTF-16LE, UTF-32BE, UTF-32LE on many platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 8.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin, mingw, MSVC 14, BeOS, when GNU libiconv is not installed.
  • For some encodings A and B, this function cannot convert directly from A to B, although an indirect conversion from A through UTF-8 to B is possible. This occurs on some platforms: Solaris 11 2010-11. Gnulib provides a higher-level facility striconveh (a wrapper around iconv) that deals with this problem.
  • The set of supported encodings and conversions is system dependent.

Next: if_freenameindex Prev: iconv_close Up: Function Substitutes Top: Top


if_freenameindex -- GNU Gnulib

Next: if_indextoname Prev: iconv_open Up: Function Substitutes Top: Top

9.404. if_freenameindex

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/if_freenameindex.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11.23, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

  • This is available only as a macro, rather than a function, on some platforms: OpenBSD 4.6, MirBSD 10.

Next: if_indextoname Prev: iconv_open Up: Function Substitutes Top: Top


if_indextoname -- GNU Gnulib

Next: if_nameindex Prev: if_freenameindex Up: Function Substitutes Top: Top

9.405. if_indextoname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/if_indextoname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.23, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: if_nameindex Prev: if_freenameindex Up: Function Substitutes Top: Top


if_nameindex -- GNU Gnulib

Next: if_nametoindex Prev: if_indextoname Up: Function Substitutes Top: Top

9.406. if_nameindex

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/if_nameindex.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.23, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: if_nametoindex Prev: if_indextoname Up: Function Substitutes Top: Top


if_nametoindex -- GNU Gnulib

Next: ilogb Prev: if_nameindex Up: Function Substitutes Top: Top

9.407. if_nametoindex

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/if_nametoindex.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.23, IRIX 6.5, OSF/1 4.0, Solaris 7, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ilogb Prev: if_nameindex Up: Function Substitutes Top: Top


ilogb -- GNU Gnulib

Next: ilogbf Prev: if_nametoindex Up: Function Substitutes Top: Top

9.408. ilogb

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ilogb.html

Gnulib module: ilogb

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, MSVC 9.
  • This function returns a wrong result for a zero argument on some platforms: OpenBSD 4.9, AIX 5.1.
  • This function returns a wrong result for an infinite argument on some platforms: NetBSD 5.1, OpenBSD 4.9.
  • This function returns a wrong result for a NaN argument on some platforms: OpenBSD 4.9.
Portability problems not fixed by Gnulib:

Next: ilogbf Prev: if_nametoindex Up: Function Substitutes Top: Top


ilogbf -- GNU Gnulib

Next: ilogbl Prev: ilogb Up: Function Substitutes Top: Top

9.409. ilogbf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ilogbf.html

Gnulib module: ilogbf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, MSVC 9.
  • This function returns a wrong result for a zero argument on some platforms: OpenBSD 4.9.
  • This function returns a wrong result for an infinite argument on some platforms: NetBSD 5.1, OpenBSD 4.9.
Portability problems not fixed by Gnulib:

Next: ilogbl Prev: ilogb Up: Function Substitutes Top: Top


ilogbl -- GNU Gnulib

Next: imaxabs Prev: ilogbf Up: Function Substitutes Top: Top

9.410. ilogbl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ilogbl.html

Gnulib module: ilogbl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: imaxabs Prev: ilogbf Up: Function Substitutes Top: Top


imaxabs -- GNU Gnulib

Next: imaxdiv Prev: ilogbl Up: Function Substitutes Top: Top

9.411. imaxabs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/imaxabs.html

Gnulib module: imaxabs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, MSVC 9, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: imaxdiv Prev: ilogbl Up: Function Substitutes Top: Top


imaxdiv -- GNU Gnulib

Next: inet_addr Prev: imaxabs Up: Function Substitutes Top: Top

9.412. imaxdiv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/imaxdiv.html

Gnulib module: imaxdiv

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, MSVC 9, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: inet_addr Prev: imaxabs Up: Function Substitutes Top: Top


inet_addr -- GNU Gnulib

Next: inet_ntoa Prev: imaxdiv Up: Function Substitutes Top: Top

9.413. inet_addr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/inet_addr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • On some old platforms, this function returns a `struct in_addr' rather than a scalar type such as `unsigned int' or `unsigned long'.

Next: inet_ntoa Prev: imaxdiv Up: Function Substitutes Top: Top


inet_ntoa -- GNU Gnulib

Next: inet_ntop Prev: inet_addr Up: Function Substitutes Top: Top

9.414. inet_ntoa

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/inet_ntoa.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • The inet_ntoa function need not be reentrant, and consequently is not required to be thread safe. Implementations of inet_ntoa typically write the timestamp into static buffer. If two threads call inet_ntoa at roughly the same time, you might end up with the wrong date in one of the threads, or some undefined string.
Note: inet_ntoa is specific for IPv4 addresses. A protocol independent function is inet_ntop.

Next: inet_ntop Prev: inet_addr Up: Function Substitutes Top: Top


inet_ntop -- GNU Gnulib

Next: inet_pton Prev: inet_ntoa Up: Function Substitutes Top: Top

9.415. inet_ntop

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/inet_ntop.html

Gnulib module: inet_ntop

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, OSF/1 4.0, Solaris 2.5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is declared in <netdb.h> instead of <arpa/inet.h> on some platforms: NonStop Kernel.
  • This function is declared in <ws2tcpip.h>, with a POSIX incompatible declaration, on some platforms: MSVC 14 on Windows >= Vista.
Portability problems not fixed by Gnulib:
  • This function's fourth argument type is size_t instead of socklen_t on some platforms: OSF/1 5.1, Solaris 10.

Next: inet_pton Prev: inet_ntoa Up: Function Substitutes Top: Top


inet_pton -- GNU Gnulib

Next: initstate Prev: inet_ntop Up: Function Substitutes Top: Top

9.416. inet_pton

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/inet_pton.html

Gnulib module: inet_pton

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, OSF/1 4.0, Solaris 2.5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is declared in <netdb.h> instead of <arpa/inet.h> on some platforms: NonStop Kernel.
  • This function is declared in <ws2tcpip.h>, with a POSIX incompatible declaration, on some platforms: MSVC 14 on Windows >= Vista.
Portability problems not fixed by Gnulib:

Next: initstate Prev: inet_ntop Up: Function Substitutes Top: Top


initstate -- GNU Gnulib

Next: insque Prev: inet_pton Up: Function Substitutes Top: Top

9.417. initstate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/initstate.html

Gnulib module: random

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
  • This function is not declared on some platforms: Cygwin 1.5.25.
Portability problems not fixed by Gnulib:

Next: insque Prev: inet_pton Up: Function Substitutes Top: Top


insque -- GNU Gnulib

Next: ioctl Prev: initstate Up: Function Substitutes Top: Top

9.418. insque

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/insque.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ioctl Prev: initstate Up: Function Substitutes Top: Top


ioctl -- GNU Gnulib

Next: isalnum Prev: insque Up: Function Substitutes Top: Top

9.419. ioctl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ioctl.html

Gnulib module: ioctl

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), ioctl is called ioctlsocket, and error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
  • The second parameter is of type unsigned long rather than int on some platforms: glibc 2.26, Mac OS X 10.5, FreeBSD 11.0, NetBSD 7.0, OpenBSD 6.0, BeOS.
Portability problems not fixed by Gnulib:
  • Most ioctl requests are platform and hardware specific.

Next: isalnum Prev: insque Up: Function Substitutes Top: Top


isalnum -- GNU Gnulib

Next: isalnum_l Prev: ioctl Up: Function Substitutes Top: Top

9.420. isalnum

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isalnum.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isalnum
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswalnum
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isalnum
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_alnum
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-alnum'.

Next: isalnum_l Prev: ioctl Up: Function Substitutes Top: Top


isalnum_l -- GNU Gnulib

Next: isalpha Prev: isalnum Up: Function Substitutes Top: Top

9.421. isalnum_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isalnum_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isalpha Prev: isalnum Up: Function Substitutes Top: Top


isalpha -- GNU Gnulib

Next: isalpha_l Prev: isalnum_l Up: Function Substitutes Top: Top

9.422. isalpha

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isalpha.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isalpha
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswalpha
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isalpha
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_alpha
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-alpha'.

Next: isalpha_l Prev: isalnum_l Up: Function Substitutes Top: Top


isalpha_l -- GNU Gnulib

Next: isascii Prev: isalpha Up: Function Substitutes Top: Top

9.423. isalpha_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isalpha_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isascii Prev: isalpha Up: Function Substitutes Top: Top


isascii -- GNU Gnulib

Next: isastream Prev: isalpha_l Up: Function Substitutes Top: Top

9.424. isascii

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isascii.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but requires special handling for the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are two alternative APIs:

c_isascii
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

mb_isascii
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

Next: isastream Prev: isalpha_l Up: Function Substitutes Top: Top


isastream -- GNU Gnulib

Next: isatty Prev: isascii Up: Function Substitutes Top: Top

9.425. isastream

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isastream.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isatty Prev: isascii Up: Function Substitutes Top: Top


isatty -- GNU Gnulib

Next: isblank Prev: isastream Up: Function Substitutes Top: Top

9.426. isatty

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isatty.html

Gnulib module: isatty

Portability problems fixed by Gnulib:

  • On native Windows, this function also returns true for character devices such as NUL.
  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: isblank Prev: isastream Up: Function Substitutes Top: Top


isblank -- GNU Gnulib

Next: isblank_l Prev: isatty Up: Function Substitutes Top: Top

9.427. isblank

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isblank.html

Gnulib module: isblank

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 4.3.2, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 9.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isblank
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswblank
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isblank
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_blank
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-blank'.

Next: isblank_l Prev: isatty Up: Function Substitutes Top: Top


isblank_l -- GNU Gnulib

Next: iscntrl Prev: isblank Up: Function Substitutes Top: Top

9.428. isblank_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isblank_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: iscntrl Prev: isblank Up: Function Substitutes Top: Top


iscntrl -- GNU Gnulib

Next: iscntrl_l Prev: isblank_l Up: Function Substitutes Top: Top

9.429. iscntrl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iscntrl.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_iscntrl
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswcntrl
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_iscntrl
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_cntrl
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-cntrl'.

Next: iscntrl_l Prev: isblank_l Up: Function Substitutes Top: Top


iscntrl_l -- GNU Gnulib

Next: isdigit Prev: iscntrl Up: Function Substitutes Top: Top

9.430. iscntrl_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iscntrl_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isdigit Prev: iscntrl Up: Function Substitutes Top: Top


isdigit -- GNU Gnulib

Next: isdigit_l Prev: iscntrl_l Up: Function Substitutes Top: Top

9.431. isdigit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isdigit.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isdigit
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswdigit
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isdigit
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_digit
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-digit'.

Next: isdigit_l Prev: iscntrl_l Up: Function Substitutes Top: Top


isdigit_l -- GNU Gnulib

Next: isfinite Prev: isdigit Up: Function Substitutes Top: Top

9.432. isdigit_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isdigit_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isfinite Prev: isdigit Up: Function Substitutes Top: Top


isfinite -- GNU Gnulib

Next: isgraph Prev: isdigit_l Up: Function Substitutes Top: Top

9.433. isfinite

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isfinite.html

Gnulib module: isfinite

Portability problems fixed by Gnulib:

  • This macro is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5.
  • This macro incorrectly yields true for some `double' arguments, on some platforms: Linux/ia64 (signalling NaNs).
Portability problems not fixed by Gnulib:
  • It is implementation-dependent whether isfinite raises an exception given a signaling NaN operand.
  • This macro returns an unspecified result when given noncanonical values such as unnormalized numbers, pseudo-denormals, pseudo-NaNs, pseudo-Infinities, and pseudo-zeroes.

Next: isgraph Prev: isdigit_l Up: Function Substitutes Top: Top


isgraph -- GNU Gnulib

Next: isgraph_l Prev: isfinite Up: Function Substitutes Top: Top

9.434. isgraph

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isgraph.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isgraph
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswgraph
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isgraph
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_graph
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-graph'.

Next: isgraph_l Prev: isfinite Up: Function Substitutes Top: Top


isgraph_l -- GNU Gnulib

Next: isgreater Prev: isgraph Up: Function Substitutes Top: Top

9.435. isgraph_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isgraph_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isgreater Prev: isgraph Up: Function Substitutes Top: Top


isgreater -- GNU Gnulib

Next: isgreaterequal Prev: isgraph_l Up: Function Substitutes Top: Top

9.436. isgreater

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isgreater.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: isgreaterequal Prev: isgraph_l Up: Function Substitutes Top: Top


isgreaterequal -- GNU Gnulib

Next: isinf Prev: isgreater Up: Function Substitutes Top: Top

9.437. isgreaterequal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isgreaterequal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: isinf Prev: isgreater Up: Function Substitutes Top: Top


isinf -- GNU Gnulib

Next: isless Prev: isgreaterequal Up: Function Substitutes Top: Top

9.438. isinf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isinf.html

Gnulib module: isinf

Portability problems fixed by Gnulib:

  • This macro is missing on some platforms: AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3.
Portability problems not fixed by Gnulib:
  • This macro returns an unspecified result when given noncanonical values such as unnormalized numbers, pseudo-denormals, pseudo-NaNs, pseudo-Infinities, and pseudo-zeroes.

Next: isless Prev: isgreaterequal Up: Function Substitutes Top: Top


isless -- GNU Gnulib

Next: islessequal Prev: isinf Up: Function Substitutes Top: Top

9.439. isless

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isless.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: islessequal Prev: isinf Up: Function Substitutes Top: Top


islessequal -- GNU Gnulib

Next: islessgreater Prev: isless Up: Function Substitutes Top: Top

9.440. islessequal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/islessequal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: islessgreater Prev: isless Up: Function Substitutes Top: Top


islessgreater -- GNU Gnulib

Next: islower Prev: islessequal Up: Function Substitutes Top: Top

9.441. islessgreater

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/islessgreater.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: islower Prev: islessequal Up: Function Substitutes Top: Top


islower -- GNU Gnulib

Next: islower_l Prev: islessgreater Up: Function Substitutes Top: Top

9.442. islower

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/islower.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_islower
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswlower
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_islower
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_lower
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-lower'.

Next: islower_l Prev: islessgreater Up: Function Substitutes Top: Top


islower_l -- GNU Gnulib

Next: isnan Prev: islower Up: Function Substitutes Top: Top

9.443. islower_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/islower_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isnan Prev: islower Up: Function Substitutes Top: Top


isnan -- GNU Gnulib

Next: isnormal Prev: islower_l Up: Function Substitutes Top: Top

9.444. isnan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isnan.html

Gnulib module: isnan

Portability problems fixed by Gnulib:

  • This macro is missing on some platforms: MSVC 9.
  • isnan was introduced with C99 and is thus commonly not present on pre-C99 systems.
  • isnan is not a macro on some platforms: IRIX 6.5, OSF/1 5.1 with gcc, Solaris 11.3.
  • This macro does not work on some platforms: MSVC 14.
  • On IRIX 6.5 with cc, isnan does not recognize some NaNs.
Portability problems not fixed by Gnulib:
  • This macro returns an unspecified result when given noncanonical values such as unnormalized numbers, pseudo-denormals, pseudo-NaNs, pseudo-Infinities, and pseudo-zeroes.

Next: isnormal Prev: islower_l Up: Function Substitutes Top: Top


isnormal -- GNU Gnulib

Next: isprint Prev: isnan Up: Function Substitutes Top: Top

9.445. isnormal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isnormal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5.

Next: isprint Prev: isnan Up: Function Substitutes Top: Top


isprint -- GNU Gnulib

Next: isprint_l Prev: isnormal Up: Function Substitutes Top: Top

9.446. isprint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isprint.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isprint
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswprint
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isprint
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_print
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-print'.

Next: isprint_l Prev: isnormal Up: Function Substitutes Top: Top


isprint_l -- GNU Gnulib

Next: ispunct Prev: isprint Up: Function Substitutes Top: Top

9.447. isprint_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isprint_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ispunct Prev: isprint Up: Function Substitutes Top: Top


ispunct -- GNU Gnulib

Next: ispunct_l Prev: isprint_l Up: Function Substitutes Top: Top

9.448. ispunct

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ispunct.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_ispunct
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswpunct
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_ispunct
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_punct
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-punct'.

Next: ispunct_l Prev: isprint_l Up: Function Substitutes Top: Top


ispunct_l -- GNU Gnulib

Next: isspace Prev: ispunct Up: Function Substitutes Top: Top

9.449. ispunct_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ispunct_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isspace Prev: ispunct Up: Function Substitutes Top: Top


isspace -- GNU Gnulib

Next: isspace_l Prev: ispunct_l Up: Function Substitutes Top: Top

9.450. isspace

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isspace.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isspace
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswspace
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isspace
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_space
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-space'.

Next: isspace_l Prev: ispunct_l Up: Function Substitutes Top: Top


isspace_l -- GNU Gnulib

Next: isunordered Prev: isspace Up: Function Substitutes Top: Top

9.451. isspace_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isspace_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isunordered Prev: isspace Up: Function Substitutes Top: Top


isunordered -- GNU Gnulib

Next: isupper Prev: isspace_l Up: Function Substitutes Top: Top

9.452. isunordered

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isunordered.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Interix 3.5, BeOS.

Next: isupper Prev: isspace_l Up: Function Substitutes Top: Top


isupper -- GNU Gnulib

Next: isupper_l Prev: isunordered Up: Function Substitutes Top: Top

9.453. isupper

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isupper.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isupper
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswupper
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isupper
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_upper
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-upper'.

Next: isupper_l Prev: isunordered Up: Function Substitutes Top: Top


isupper_l -- GNU Gnulib

Next: iswalnum Prev: isupper Up: Function Substitutes Top: Top

9.454. isupper_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isupper_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: iswalnum Prev: isupper Up: Function Substitutes Top: Top


iswalnum -- GNU Gnulib

Next: iswalnum_l Prev: isupper_l Up: Function Substitutes Top: Top

9.455. iswalnum

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswalnum.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswalnum_l Prev: isupper_l Up: Function Substitutes Top: Top


iswalnum_l -- GNU Gnulib

Next: iswalpha Prev: iswalnum Up: Function Substitutes Top: Top

9.456. iswalnum_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswalnum_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswalpha Prev: iswalnum Up: Function Substitutes Top: Top


iswalpha -- GNU Gnulib

Next: iswalpha_l Prev: iswalnum_l Up: Function Substitutes Top: Top

9.457. iswalpha

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswalpha.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswalpha_l Prev: iswalnum_l Up: Function Substitutes Top: Top


iswalpha_l -- GNU Gnulib

Next: iswblank Prev: iswalpha Up: Function Substitutes Top: Top

9.458. iswalpha_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswalpha_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswblank Prev: iswalpha Up: Function Substitutes Top: Top


iswblank -- GNU Gnulib

Next: iswblank_l Prev: iswalpha_l Up: Function Substitutes Top: Top

9.459. iswblank

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswblank.html

Gnulib module: iswblank

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 9.
  • This function is declared but not defined on some platforms: IRIX 6.5.30.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.8.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswblank_l Prev: iswalpha_l Up: Function Substitutes Top: Top


iswblank_l -- GNU Gnulib

Next: iswcntrl Prev: iswblank Up: Function Substitutes Top: Top

9.460. iswblank_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswblank_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswcntrl Prev: iswblank Up: Function Substitutes Top: Top


iswcntrl -- GNU Gnulib

Next: iswcntrl_l Prev: iswblank_l Up: Function Substitutes Top: Top

9.461. iswcntrl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswcntrl.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswcntrl_l Prev: iswblank_l Up: Function Substitutes Top: Top


iswcntrl_l -- GNU Gnulib

Next: iswctype Prev: iswcntrl Up: Function Substitutes Top: Top

9.462. iswcntrl_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswcntrl_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswctype Prev: iswcntrl Up: Function Substitutes Top: Top


iswctype -- GNU Gnulib

Next: iswctype_l Prev: iswcntrl_l Up: Function Substitutes Top: Top

9.463. iswctype

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswctype.html

Gnulib module: iswctype

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function is declared in <wchar.h>, not in <wctype.h>, on some platforms: HP-UX 11.00.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswctype_l Prev: iswcntrl_l Up: Function Substitutes Top: Top


iswctype_l -- GNU Gnulib

Next: iswdigit Prev: iswctype Up: Function Substitutes Top: Top

9.464. iswctype_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswctype_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswdigit Prev: iswctype Up: Function Substitutes Top: Top


iswdigit -- GNU Gnulib

Next: iswdigit_l Prev: iswctype_l Up: Function Substitutes Top: Top

9.465. iswdigit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswdigit.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswdigit_l Prev: iswctype_l Up: Function Substitutes Top: Top


iswdigit_l -- GNU Gnulib

Next: iswgraph Prev: iswdigit Up: Function Substitutes Top: Top

9.466. iswdigit_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswdigit_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswgraph Prev: iswdigit Up: Function Substitutes Top: Top


iswgraph -- GNU Gnulib

Next: iswgraph_l Prev: iswdigit_l Up: Function Substitutes Top: Top

9.467. iswgraph

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswgraph.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswgraph_l Prev: iswdigit_l Up: Function Substitutes Top: Top


iswgraph_l -- GNU Gnulib

Next: iswlower Prev: iswgraph Up: Function Substitutes Top: Top

9.468. iswgraph_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswgraph_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswlower Prev: iswgraph Up: Function Substitutes Top: Top


iswlower -- GNU Gnulib

Next: iswlower_l Prev: iswgraph_l Up: Function Substitutes Top: Top

9.469. iswlower

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswlower.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswlower_l Prev: iswgraph_l Up: Function Substitutes Top: Top


iswlower_l -- GNU Gnulib

Next: iswprint Prev: iswlower Up: Function Substitutes Top: Top

9.470. iswlower_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswlower_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswprint Prev: iswlower Up: Function Substitutes Top: Top


iswprint -- GNU Gnulib

Next: iswprint_l Prev: iswlower_l Up: Function Substitutes Top: Top

9.471. iswprint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswprint.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswprint_l Prev: iswlower_l Up: Function Substitutes Top: Top


iswprint_l -- GNU Gnulib

Next: iswpunct Prev: iswprint Up: Function Substitutes Top: Top

9.472. iswprint_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswprint_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswpunct Prev: iswprint Up: Function Substitutes Top: Top


iswpunct -- GNU Gnulib

Next: iswpunct_l Prev: iswprint_l Up: Function Substitutes Top: Top

9.473. iswpunct

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswpunct.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswpunct_l Prev: iswprint_l Up: Function Substitutes Top: Top


iswpunct_l -- GNU Gnulib

Next: iswspace Prev: iswpunct Up: Function Substitutes Top: Top

9.474. iswpunct_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswpunct_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswspace Prev: iswpunct Up: Function Substitutes Top: Top


iswspace -- GNU Gnulib

Next: iswspace_l Prev: iswpunct_l Up: Function Substitutes Top: Top

9.475. iswspace

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswspace.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswspace_l Prev: iswpunct_l Up: Function Substitutes Top: Top


iswspace_l -- GNU Gnulib

Next: iswupper Prev: iswspace Up: Function Substitutes Top: Top

9.476. iswspace_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswspace_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswupper Prev: iswspace Up: Function Substitutes Top: Top


iswupper -- GNU Gnulib

Next: iswupper_l Prev: iswspace_l Up: Function Substitutes Top: Top

9.477. iswupper

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswupper.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswupper_l Prev: iswspace_l Up: Function Substitutes Top: Top


iswupper_l -- GNU Gnulib

Next: iswxdigit Prev: iswupper Up: Function Substitutes Top: Top

9.478. iswupper_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswupper_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswxdigit Prev: iswupper Up: Function Substitutes Top: Top


iswxdigit -- GNU Gnulib

Next: iswxdigit_l Prev: iswupper_l Up: Function Substitutes Top: Top

9.479. iswxdigit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswxdigit.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
  • This function returns 0 for all possible arguments on some platforms: Linux libc5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: iswxdigit_l Prev: iswupper_l Up: Function Substitutes Top: Top


iswxdigit_l -- GNU Gnulib

Next: isxdigit Prev: iswxdigit Up: Function Substitutes Top: Top

9.480. iswxdigit_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/iswxdigit_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: isxdigit Prev: iswxdigit Up: Function Substitutes Top: Top


isxdigit -- GNU Gnulib

Next: isxdigit_l Prev: iswxdigit_l Up: Function Substitutes Top: Top

9.481. isxdigit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isxdigit.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function's behaviour depends on the locale, but does not support the multibyte characters that occur in strings in locales with MB_CUR_MAX > 1 (this includes all the common UTF-8 locales). There are four alternative APIs:

c_isxdigit
This function operates in a locale independent way and returns true only for ASCII characters. It is provided by the Gnulib module `c-ctype'.

iswxdigit
This function operates in a locale dependent way, on wide characters. In order to use it, you first have to convert from multibyte to wide characters, using the mbrtowc function. It is provided by the Gnulib module `wctype'.

mb_isxdigit
This function operates in a locale dependent way, on multibyte characters. It is provided by the Gnulib module `mbchar'.

uc_is_xdigit
This function operates in a locale independent way, on Unicode characters. It is provided by the Gnulib module `unictype/ctype-xdigit'.

Next: isxdigit_l Prev: iswxdigit_l Up: Function Substitutes Top: Top


isxdigit_l -- GNU Gnulib

Next: j0 Prev: isxdigit Up: Function Substitutes Top: Top

9.482. isxdigit_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/isxdigit_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: j0 Prev: isxdigit Up: Function Substitutes Top: Top


j0 -- GNU Gnulib

Next: j1 Prev: isxdigit_l Up: Function Substitutes Top: Top

9.483. j0

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/j0.html

Gnulib module: j0

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Next: j1 Prev: isxdigit_l Up: Function Substitutes Top: Top


j1 -- GNU Gnulib

Next: jn Prev: j0 Up: Function Substitutes Top: Top

9.484. j1

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/j1.html

Gnulib module: j1

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Next: jn Prev: j0 Up: Function Substitutes Top: Top


jn -- GNU Gnulib

Next: jrand48 Prev: j1 Up: Function Substitutes Top: Top

9.485. jn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/jn.html

Gnulib module: jn

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Next: jrand48 Prev: j1 Up: Function Substitutes Top: Top


jrand48 -- GNU Gnulib

Next: kill Prev: jn Up: Function Substitutes Top: Top

9.486. jrand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/jrand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: kill Prev: jn Up: Function Substitutes Top: Top


kill -- GNU Gnulib

Next: killpg Prev: jrand48 Up: Function Substitutes Top: Top

9.487. kill

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/kill.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: killpg Prev: jrand48 Up: Function Substitutes Top: Top


killpg -- GNU Gnulib

Next: l64a Prev: kill Up: Function Substitutes Top: Top

9.488. killpg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/killpg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, BeOS.

Next: l64a Prev: kill Up: Function Substitutes Top: Top


l64a -- GNU Gnulib

Next: labs Prev: killpg Up: Function Substitutes Top: Top

9.489. l64a

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/l64a.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function was not correctly implemented in glibc versions before 2.2.5.

Next: labs Prev: killpg Up: Function Substitutes Top: Top


labs -- GNU Gnulib

Next: lchown Prev: l64a Up: Function Substitutes Top: Top

9.490. labs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/labs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: lchown Prev: l64a Up: Function Substitutes Top: Top


lchown -- GNU Gnulib

Next: lcong48 Prev: labs Up: Function Substitutes Top: Top

9.491. lchown

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lchown.html

Gnulib module: lchown

Portability problems fixed by Gnulib:

  • Some platforms fail to detect trailing slash on non-directories, as in lchown("link-to-file/",uid,gid): FreeBSD 7.2, Solaris 9.
  • Some platforms fail to update the change time when at least one argument was not -1, but no ownership changes resulted. However, without lchmod, the replacement only fixes this for non-symlinks: OpenBSD 4.0.
  • This function is missing on some platforms; however, the replacement fails on symlinks if chown is supported, and fails altogether with ENOSYS otherwise: Mac OS X 10.3, Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: lcong48 Prev: labs Up: Function Substitutes Top: Top


lcong48 -- GNU Gnulib

Next: ldexp Prev: lchown Up: Function Substitutes Top: Top

9.492. lcong48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lcong48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: ldexp Prev: lchown Up: Function Substitutes Top: Top


ldexp -- GNU Gnulib

Next: ldexpf Prev: lcong48 Up: Function Substitutes Top: Top

9.493. ldexp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ldexp.html

Gnulib module: ldexp

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: ldexpf Prev: lcong48 Up: Function Substitutes Top: Top


ldexpf -- GNU Gnulib

Next: ldexpl Prev: ldexp Up: Function Substitutes Top: Top

9.494. ldexpf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ldexpf.html

Gnulib module: ldexpf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: ldexpl Prev: ldexp Up: Function Substitutes Top: Top


ldexpl -- GNU Gnulib

Next: ldiv Prev: ldexpf Up: Function Substitutes Top: Top

9.495. ldexpl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ldexpl.html

Gnulib module: ldexpl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function has no prototype in <math.h> on some platforms: Mac OS X.
  • This function does not work on finite numbers on some platforms: AIX 5.1.
Portability problems not fixed by Gnulib:

Next: ldiv Prev: ldexpf Up: Function Substitutes Top: Top


ldiv -- GNU Gnulib

Next: lfind Prev: ldexpl Up: Function Substitutes Top: Top

9.496. ldiv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ldiv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: lfind Prev: ldexpl Up: Function Substitutes Top: Top


lfind -- GNU Gnulib

Next: lgamma Prev: ldiv Up: Function Substitutes Top: Top

9.497. lfind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lfind.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: lgamma Prev: ldiv Up: Function Substitutes Top: Top


lgamma -- GNU Gnulib

Next: lgammaf Prev: lfind Up: Function Substitutes Top: Top

9.498. lgamma

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lgamma.html

Gnulib module: lgamma

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
  • This function is not declared on some platforms: IRIX 5.3.

Next: lgammaf Prev: lfind Up: Function Substitutes Top: Top


lgammaf -- GNU Gnulib

Next: lgammal Prev: lgamma Up: Function Substitutes Top: Top

9.499. lgammaf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lgammaf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, MSVC 9.

Next: lgammal Prev: lgamma Up: Function Substitutes Top: Top


lgammal -- GNU Gnulib

Next: link Prev: lgammaf Up: Function Substitutes Top: Top

9.500. lgammal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lgammal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: link Prev: lgammaf Up: Function Substitutes Top: Top


link -- GNU Gnulib

Next: linkat Prev: lgammal Up: Function Substitutes Top: Top

9.501. link

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/link.html

Gnulib module: link

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function fails to reject trailing slashes on non-directories on some platforms: FreeBSD 7.2, Solaris 11.3, Cygwin 1.5.x.
  • When the second argument is a dangling symlink, some platforms follow that link and create the destination rather than failing: IRIX 6.5.
Portability problems not fixed by Gnulib:
  • When the first argument is a symlink, some platforms create a hard-link to what the symlink referenced, rather than to the symlink itself. Use `linkat' to force a particular behavior.

Next: linkat Prev: lgammal Up: Function Substitutes Top: Top


linkat -- GNU Gnulib

Next: lio_listio Prev: link Up: Function Substitutes Top: Top

9.502. linkat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/linkat.html

Gnulib module: linkat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X < 10.10, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • This function fails to directly hardlink symlinks on some platforms: Mac OS X 10.10.
  • This function fails to reject trailing slashes on non-directories on some platforms: AIX 7.1, Solaris 11.3, Mac OS X 10.10.
  • This functions does not support AT_SYMLINK_FOLLOW on some platforms: Linux kernel 2.6.17.
Portability problems not fixed by Gnulib:

Next: lio_listio Prev: link Up: Function Substitutes Top: Top


lio_listio -- GNU Gnulib

Next: listen Prev: linkat Up: Function Substitutes Top: Top

9.503. lio_listio

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lio_listio.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: listen Prev: linkat Up: Function Substitutes Top: Top


listen -- GNU Gnulib

Next: llabs Prev: lio_listio Up: Function Substitutes Top: Top

9.504. listen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/listen.html

Gnulib module: listen

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: llabs Prev: lio_listio Up: Function Substitutes Top: Top


llabs -- GNU Gnulib

Next: lldiv Prev: listen Up: Function Substitutes Top: Top

9.505. llabs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llabs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.23, OSF/1 5.1, MSVC 9, Interix 3.5.

Next: lldiv Prev: listen Up: Function Substitutes Top: Top


lldiv -- GNU Gnulib

Next: llrint Prev: llabs Up: Function Substitutes Top: Top

9.506. lldiv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lldiv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11.23, OSF/1 5.1, MSVC 9, Interix 3.5.

Next: llrint Prev: llabs Up: Function Substitutes Top: Top


llrint -- GNU Gnulib

Next: llrintf Prev: lldiv Up: Function Substitutes Top: Top

9.507. llrint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llrint.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.

Next: llrintf Prev: lldiv Up: Function Substitutes Top: Top


llrintf -- GNU Gnulib

Next: llrintl Prev: llrint Up: Function Substitutes Top: Top

9.508. llrintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llrintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.

Next: llrintl Prev: llrint Up: Function Substitutes Top: Top


llrintl -- GNU Gnulib

Next: llround Prev: llrintf Up: Function Substitutes Top: Top

9.509. llrintl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llrintl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5, BeOS.

Next: llround Prev: llrintf Up: Function Substitutes Top: Top


llround -- GNU Gnulib

Next: llroundf Prev: llrintl Up: Function Substitutes Top: Top

9.510. llround

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llround.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: llroundf Prev: llrintl Up: Function Substitutes Top: Top


llroundf -- GNU Gnulib

Next: llroundl Prev: llround Up: Function Substitutes Top: Top

9.511. llroundf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llroundf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.7.7, MSVC 9, Interix 3.5.

Next: llroundl Prev: llround Up: Function Substitutes Top: Top


llroundl -- GNU Gnulib

Next: localeconv Prev: llroundf Up: Function Substitutes Top: Top

9.512. llroundl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/llroundl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: localeconv Prev: llroundf Up: Function Substitutes Top: Top


localeconv -- GNU Gnulib

Next: localtime Prev: llroundl Up: Function Substitutes Top: Top

9.513. localeconv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/localeconv.html

Gnulib module: localeconv

Portability problems fixed by Gnulib:

  • The struct lconv type does not contain any members on some platforms: Android.
  • The struct lconv type does not contain the members int_p_cs_precedes, int_p_sign_posn, int_p_sep_by_space, int_n_cs_precedes, int_n_sign_posn, int_n_sep_by_space on some platforms: glibc, OpenBSD 4.9, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: localtime Prev: llroundl Up: Function Substitutes Top: Top


localtime -- GNU Gnulib

Next: localtime_r Prev: localeconv Up: Function Substitutes Top: Top

9.514. localtime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/localtime.html

Gnulib module: localtime

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
Portability problems not fixed by Gnulib:
  • On some platforms, this function returns nonsense values for unsupported arguments (like @math{2^56}), rather than failing: FreeBSD 10.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.

Next: localtime_r Prev: localeconv Up: Function Substitutes Top: Top


localtime_r -- GNU Gnulib

Next: lockf Prev: localtime Up: Function Substitutes Top: Top

9.515. localtime_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/localtime_r.html

Gnulib module: time_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function is not declared unless _REENTRANT is defined, on some platforms: HP-UX 11.
  • Some platforms define a function of this name that is incompatible to POSIX: HP-UX 10.
Portability problems not fixed by Gnulib:
  • On some platforms, this function returns nonsense values for unsupported arguments (like @math{2^56}), rather than failing: FreeBSD 10.

Next: lockf Prev: localtime Up: Function Substitutes Top: Top


lockf -- GNU Gnulib

Next: log Prev: localtime_r Up: Function Substitutes Top: Top

9.516. lockf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lockf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly across the entire data range of files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: log Prev: localtime_r Up: Function Substitutes Top: Top


log -- GNU Gnulib

Next: log10 Prev: lockf Up: Function Substitutes Top: Top

9.517. log

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log.html

Gnulib module: log or log-ieee

Portability problems fixed by either Gnulib module log or log-ieee:

  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems fixed by Gnulib module log-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1, Solaris 11.0.
Portability problems not fixed by Gnulib:

Next: log10 Prev: lockf Up: Function Substitutes Top: Top


log10 -- GNU Gnulib

Next: log10f Prev: log Up: Function Substitutes Top: Top

9.518. log10

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log10.html

Gnulib module: log10 or log10-ieee

Portability problems fixed by either Gnulib module log10 or log10-ieee:

  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems fixed by Gnulib module log10-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1, Solaris 11.0.
Portability problems not fixed by Gnulib:

Next: log10f Prev: log Up: Function Substitutes Top: Top


log10f -- GNU Gnulib

Next: log10l Prev: log10 Up: Function Substitutes Top: Top

9.519. log10f

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log10f.html

Gnulib module: log10f or log10f-ieee

Portability problems fixed by either Gnulib module log10f or log10f-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems fixed by Gnulib module log10f-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1.
Portability problems not fixed by Gnulib:

Next: log10l Prev: log10 Up: Function Substitutes Top: Top


log10l -- GNU Gnulib

Next: log1p Prev: log10f Up: Function Substitutes Top: Top

9.520. log10l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log10l.html

Gnulib module: log10l

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, older IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared and does not work on some platforms: AIX 5.1.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
  • This function returns an unnormalized negative infinity for a minus zero argument on some platforms: IRIX 6.5.
  • This function returns an unnormalized positive infinity for a positive infinite argument on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: log1p Prev: log10f Up: Function Substitutes Top: Top


log1p -- GNU Gnulib

Next: log1pf Prev: log10l Up: Function Substitutes Top: Top

9.521. log1p

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log1p.html

Gnulib module: log1p or log1p-ieee

Portability problems fixed by either Gnulib module log1p or log1p-ieee:

  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
Portability problems fixed by Gnulib module log1p-ieee:
  • This function has problems when the argument is minus zero on some platforms: AIX 7.1, HP-UX 11.
Portability problems not fixed by Gnulib:

Next: log1pf Prev: log10l Up: Function Substitutes Top: Top


log1pf -- GNU Gnulib

Next: log1pl Prev: log1p Up: Function Substitutes Top: Top

9.522. log1pf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log1pf.html

Gnulib module: log1pf or log1pf-ieee

Portability problems fixed by either Gnulib module log1pf or log1pf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, MSVC 9.
  • This function returns a wrong value for the argument -1.0f on some platforms: IRIX 6.5.
Portability problems fixed by Gnulib module log1pf-ieee:
  • This function has problems when the argument is minus zero on some platforms: OpenBSD 4.9, AIX 7.1.
Portability problems not fixed by Gnulib:

Next: log1pl Prev: log1p Up: Function Substitutes Top: Top


log1pl -- GNU Gnulib

Next: log2 Prev: log1pf Up: Function Substitutes Top: Top

9.523. log1pl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log1pl.html

Gnulib module: log1pl or log1pl-ieee

Portability problems fixed by either Gnulib module log1pl or log1pl-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
Portability problems fixed by Gnulib module log1pl-ieee:
  • This function has problems when the argument is minus zero on some platforms: AIX 7.1, IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: log2 Prev: log1pf Up: Function Substitutes Top: Top


log2 -- GNU Gnulib

Next: log2f Prev: log1pl Up: Function Substitutes Top: Top

9.524. log2

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log2.html

Gnulib module: log2 or log2-ieee

Portability problems fixed by either Gnulib module log2 or log2-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, older IRIX 6.5, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function is only provided as a macro on some platforms: Cygwin 1.5.x.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
  • This function returns slightly wrong values for exact powers of 2 on some platforms: Cygwin 1.7.9.
Portability problems fixed by Gnulib module log2-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1, Solaris 10/x86_64.
Portability problems not fixed by Gnulib:

Next: log2f Prev: log1pl Up: Function Substitutes Top: Top


log2f -- GNU Gnulib

Next: log2l Prev: log2 Up: Function Substitutes Top: Top

9.525. log2f

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log2f.html

Gnulib module: log2f or log2f-ieee

Portability problems fixed by either Gnulib module log2f or log2f-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, older IRIX 6.5, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function is only provided as a macro on some platforms: Cygwin 1.5.x.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
  • This function returns slightly wrong values for exact powers of 2 on some platforms: Cygwin 1.7.9.
Portability problems fixed by Gnulib module log2f-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1, Solaris 10/x86_64.
Portability problems not fixed by Gnulib:

Next: log2l Prev: log2 Up: Function Substitutes Top: Top


log2l -- GNU Gnulib

Next: logb Prev: log2f Up: Function Substitutes Top: Top

9.526. log2l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/log2l.html

Gnulib module: log2l

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: logb Prev: log2f Up: Function Substitutes Top: Top


logb -- GNU Gnulib

Next: logbf Prev: log2l Up: Function Substitutes Top: Top

9.527. logb

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/logb.html

Gnulib module: logb

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
  • This function is missing a declaration on some platforms: Cygwin 1.5.x.
  • This function produces wrong results for subnormal numbers on some platforms: glibc 2.11/ppc, glibc 2.7/sparc, glibc 2.7/hppa, Solaris 11.0, Cygwin 1.5.x.
Portability problems not fixed by Gnulib:

Next: logbf Prev: log2l Up: Function Substitutes Top: Top


logbf -- GNU Gnulib

Next: logbl Prev: logb Up: Function Substitutes Top: Top

9.528. logbf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/logbf.html

Gnulib module: logbf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, MSVC 9.
  • This function produces wrong results for subnormal numbers on some platforms: glibc 2.11/ppc, glibc 2.7/sparc, glibc 2.7/hppa, Solaris 11.0.
Portability problems not fixed by Gnulib:

Next: logbl Prev: logb Up: Function Substitutes Top: Top


logbl -- GNU Gnulib

Next: logf Prev: logbf Up: Function Substitutes Top: Top

9.529. logbl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/logbl.html

Gnulib module: logbl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function produces wrong results for subnormal numbers on some platforms: glibc 2.11/powerpc, glibc 2.7/sparc, glibc 2.7/hppa, Solaris 11.0, glibc 2.23/powerpc64le.
Portability problems not fixed by Gnulib:

Next: logf Prev: logbf Up: Function Substitutes Top: Top


logf -- GNU Gnulib

Next: logl Prev: logbl Up: Function Substitutes Top: Top

9.530. logf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/logf.html

Gnulib module: logf or logf-ieee

Portability problems fixed by either Gnulib module logf or logf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems fixed by Gnulib module logf-ieee:
  • This function returns a wrong value for a negative argument on some platforms: NetBSD 5.1.
Portability problems not fixed by Gnulib:

Next: logl Prev: logbl Up: Function Substitutes Top: Top


logl -- GNU Gnulib

Next: longjmp Prev: logf Up: Function Substitutes Top: Top

9.531. logl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/logl.html

Gnulib module: logl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
  • This function returns wrong results on some platforms: glibc 2.7 on Linux/SPARC64.
  • This function returns a wrong value for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: longjmp Prev: logf Up: Function Substitutes Top: Top


longjmp -- GNU Gnulib

Next: lrand48 Prev: logl Up: Function Substitutes Top: Top

9.532. longjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/longjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • The effects of this call are system and compiler optimization dependent, since it restores the contents of register-allocated variables but not the contents of stack-allocated variables.
  • When longjumping out of a signal handler that was being executed on an alternate stack (installed through sigaltstack), on FreeBSD, NetBSD, OpenBSD, you need to clear the SS_ONSTACK flag in the stack_t structure managed by the kernel.

Next: lrand48 Prev: logl Up: Function Substitutes Top: Top


lrand48 -- GNU Gnulib

Next: lrint Prev: longjmp Up: Function Substitutes Top: Top

9.533. lrand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lrand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: lrint Prev: longjmp Up: Function Substitutes Top: Top


lrint -- GNU Gnulib

Next: lrintf Prev: lrand48 Up: Function Substitutes Top: Top

9.534. lrint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lrint.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: lrintf Prev: lrand48 Up: Function Substitutes Top: Top


lrintf -- GNU Gnulib

Next: lrintl Prev: lrint Up: Function Substitutes Top: Top

9.535. lrintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lrintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: lrintl Prev: lrint Up: Function Substitutes Top: Top


lrintl -- GNU Gnulib

Next: lround Prev: lrintf Up: Function Substitutes Top: Top

9.536. lrintl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lrintl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5, BeOS.

Next: lround Prev: lrintf Up: Function Substitutes Top: Top


lround -- GNU Gnulib

Next: lroundf Prev: lrintl Up: Function Substitutes Top: Top

9.537. lround

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lround.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: lroundf Prev: lrintl Up: Function Substitutes Top: Top


lroundf -- GNU Gnulib

Next: lroundl Prev: lround Up: Function Substitutes Top: Top

9.538. lroundf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lroundf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: lroundl Prev: lround Up: Function Substitutes Top: Top


lroundl -- GNU Gnulib

Next: lsearch Prev: lroundf Up: Function Substitutes Top: Top

9.539. lroundl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lroundl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: lsearch Prev: lroundf Up: Function Substitutes Top: Top


lsearch -- GNU Gnulib

Next: lseek Prev: lroundl Up: Function Substitutes Top: Top

9.540. lsearch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lsearch.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: lseek Prev: lroundl Up: Function Substitutes Top: Top


lseek -- GNU Gnulib

Next: lstat Prev: lsearch Up: Function Substitutes Top: Top

9.541. lseek

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lseek.html

Gnulib module: lseek

Portability problems fixed by Gnulib:

  • On platforms where off_t is a 32-bit type, lseek does not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • This function mistakenly succeeds on pipes on some platforms: mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • POSIX does not specify which file descriptors support seeking and which don't. In practice, regular files and block devices support seeking, and ttys, pipes, and most character devices don't support it.
  • When the third argument is invalid, POSIX says that lseek should set errno to EINVAL and return -1, but in this situation a SIGSYS signal is raised on some platforms: IRIX 6.5.
  • When the lseek function fails, POSIX says that the file offset remains unchanged. But on some platforms, attempting to set a negative file offset fails and sets the file offset to 0: BeOS.

Next: lstat Prev: lsearch Up: Function Substitutes Top: Top


lstat -- GNU Gnulib

Next: malloc Prev: lseek Up: Function Substitutes Top: Top

9.542. lstat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/lstat.html

Gnulib module: lstat

Portability problems fixed by Gnulib:

  • On platforms where off_t is a 32-bit type, lstat may not correctly report the size of files or block devices larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • For symlinks, when the argument ends in a slash, some platforms don't dereference the argument: Solaris 9.
  • On some platforms, lstat("file/",buf) succeeds instead of failing with ENOTDIR. Solaris 9.
  • On Windows platforms (excluding Cygwin), symlinks are not supported, so lstat does not exist.
Portability problems not fixed by Gnulib:
  • See sys/stat.h, for general portability problems with struct stat.

Next: malloc Prev: lseek Up: Function Substitutes Top: Top


malloc -- GNU Gnulib

Next: mblen Prev: lstat Up: Function Substitutes Top: Top

9.543. malloc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/malloc.html

Gnulib module: malloc-posix

Portability problems fixed by Gnulib:

  • Upon failure, the function does not set errno to ENOMEM on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • malloc (0) always returns a NULL pointer on some platforms: AIX 5.1, OSF/1 5.1.
Extension: Gnulib provides a module `malloc-gnu' that substitutes a malloc implementation that behaves more like the glibc implementation, regarding the result of malloc (0).

Next: mblen Prev: lstat Up: Function Substitutes Top: Top


mblen -- GNU Gnulib

Next: mbrlen Prev: malloc Up: Function Substitutes Top: Top

9.544. mblen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mblen.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: mbrlen Prev: malloc Up: Function Substitutes Top: Top


mbrlen -- GNU Gnulib

Next: mbrtoc16 Prev: mblen Up: Function Substitutes Top: Top

9.545. mbrlen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbrlen.html

Gnulib module: mbrlen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, mingw, Interix 3.5.
  • In the C or POSIX locales, this function can return (size_t) -1 and set errno to EILSEQ: glibc 2.23.
  • This function returns 0 instead of (size_t) -2 when the input is empty: glibc 2.19.
  • This function returns (size_t) -1 instead of (size_t) -2 when the input is empty: AIX 5.1.
  • This function does not put the state into non-initial state when parsing an incomplete multibyte character on some platforms: AIX 5.1, OSF/1 5.1.
  • This function returns the total number of bytes that make up the multibyte character, not the number of bytes that were needed to complete the multibyte character, on some platforms: HP-UX 11.11, Solaris 11 2010-11.
  • This function may not return 0 when parsing the NUL character on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:

Next: mbrtoc16 Prev: mblen Up: Function Substitutes Top: Top


mbrtoc16 -- GNU Gnulib

Next: mbrtoc32 Prev: mbrlen Up: Function Substitutes Top: Top

9.546. mbrtoc16

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on most non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: mbrtoc32 Prev: mbrlen Up: Function Substitutes Top: Top


mbrtoc32 -- GNU Gnulib

Next: mbrtowc Prev: mbrtoc16 Up: Function Substitutes Top: Top

9.547. mbrtoc32

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on most non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: mbrtowc Prev: mbrtoc16 Up: Function Substitutes Top: Top


mbrtowc -- GNU Gnulib

Next: mbsinit Prev: mbrtoc32 Up: Function Substitutes Top: Top

9.548. mbrtowc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbrtowc.html

Gnulib module: mbrtowc

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, mingw, Interix 3.5.
  • In the C or POSIX locales, this function can return (size_t) -1 and set errno to EILSEQ: glibc 2.23.
  • This function returns 0 instead of (size_t) -2 when the input is empty: glibc 2.19.
  • This function returns (size_t) -1 instead of (size_t) -2 when the input is empty: AIX 5.1.
  • This function does not put the state into non-initial state when parsing an incomplete multibyte character on some platforms: AIX 5.1, OSF/1 5.1.
  • This function does not produce correct results in the zh_CN.GB18030 locale on some platforms: Solaris 8.
  • This function fails if the pwc argument is NULL on some platforms: Solaris 7.
  • This function does not ignore the pwc argument if the string argument is NULL on some platforms: OSF/1 5.1.
  • This function returns the total number of bytes that make up the multibyte character, not the number of bytes that were needed to complete the multibyte character, on some platforms: HP-UX 11.11, Solaris 11 2010-11, mingw, possibly MSVC 14.
  • This function may not return 0 when parsing the NUL character on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: mbsinit Prev: mbrtoc32 Up: Function Substitutes Top: Top


mbsinit -- GNU Gnulib

Next: mbsnrtowcs Prev: mbrtowc Up: Function Substitutes Top: Top

9.549. mbsinit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbsinit.html

Gnulib module: mbsinit

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 14, Interix 3.5.
  • This function always returns 1, even in multibyte locales, on some platforms: mingw.
Portability problems not fixed by Gnulib:

Next: mbsnrtowcs Prev: mbrtowc Up: Function Substitutes Top: Top


mbsnrtowcs -- GNU Gnulib

Next: mbsrtowcs Prev: mbsinit Up: Function Substitutes Top: Top

9.550. mbsnrtowcs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbsnrtowcs.html

Gnulib module: mbsnrtowcs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • The specification is not clear about whether this function should update the conversion state when the first argument (the destination pointer) is NULL. The glibc, Mac OS X, FreeBSD implementations do update the state in this case. For portability, when passing a NULL destination argument, it is best to pass a pointer to a temporary copy of the conversion state.

Next: mbsrtowcs Prev: mbsinit Up: Function Substitutes Top: Top


mbsrtowcs -- GNU Gnulib

Next: mbstowcs Prev: mbsnrtowcs Up: Function Substitutes Top: Top

9.551. mbsrtowcs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbsrtowcs.html

Gnulib module: mbsrtowcs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, mingw, Interix 3.5.
  • This function does not work on some platforms: HP-UX 11, Solaris 11 2010-11.
  • This function does not work when the first argument is NULL on some platforms: mingw.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • The specification is not clear about whether this function should update the conversion state when the first argument (the destination pointer) is NULL. The glibc implementation does not update the state in this case; the Mac OS X and FreeBSD implementations do. For portability, when passing a NULL destination argument, it is best to pass a pointer to a temporary copy of the conversion state.

Next: mbstowcs Prev: mbsnrtowcs Up: Function Substitutes Top: Top


mbstowcs -- GNU Gnulib

Next: mbtowc Prev: mbsrtowcs Up: Function Substitutes Top: Top

9.552. mbstowcs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbstowcs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: mbtowc Prev: mbsrtowcs Up: Function Substitutes Top: Top


mbtowc -- GNU Gnulib

Next: memccpy Prev: mbstowcs Up: Function Substitutes Top: Top

9.553. mbtowc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mbtowc.html

Gnulib module: mbtowc

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function accumulates hidden state on some platforms: glibc 2.8 (see https://sourceware.org/bugzilla/show_bug.cgi?id=9674).
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: memccpy Prev: mbstowcs Up: Function Substitutes Top: Top


memccpy -- GNU Gnulib

Next: memchr Prev: mbtowc Up: Function Substitutes Top: Top

9.554. memccpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memccpy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: memchr Prev: mbtowc Up: Function Substitutes Top: Top


memchr -- GNU Gnulib

Next: memcmp Prev: memccpy Up: Function Substitutes Top: Top

9.555. memchr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memchr.html

Gnulib module: memchr or memchr-obsolete

Portability problems fixed by either Gnulib module memchr or memchr-obsolete:

  • This function dereferences too much memory on some platforms: glibc 2.10 on x86_64, IA-64; glibc 2.11 on Alpha.
Portability problems fixed by Gnulib module memchr-obsolete:
  • This function is missing on some older platforms.
Portability problems not fixed by Gnulib:

Next: memcmp Prev: memccpy Up: Function Substitutes Top: Top


memcmp -- GNU Gnulib

Next: memcpy Prev: memchr Up: Function Substitutes Top: Top

9.556. memcmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memcmp.html

Gnulib module: memcmp

Portability problems fixed by Gnulib:

  • This function is missing on some older platforms.
  • This function does not work on 8-bit data on some older platforms: SunOS 4.1.3.
  • This function fails when comparing 16 bytes or more and with at least one buffer not starting on a 4-byte boundary on some older platforms: NeXTstep/x86.
Portability problems not fixed by Gnulib:

Next: memcpy Prev: memchr Up: Function Substitutes Top: Top


memcpy -- GNU Gnulib

Next: memmove Prev: memcmp Up: Function Substitutes Top: Top

9.557. memcpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memcpy.html

Gnulib module: memcpy

Portability problems fixed by Gnulib:

  • This function is missing on some older platforms.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: memmove Prev: memcmp Up: Function Substitutes Top: Top


memmove -- GNU Gnulib

Next: memset Prev: memcpy Up: Function Substitutes Top: Top

9.558. memmove

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memmove.html

Gnulib module: memmove

Portability problems fixed by Gnulib:

  • This function is missing on some older platforms.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: memset Prev: memcpy Up: Function Substitutes Top: Top


memset -- GNU Gnulib

Next: mkdir Prev: memmove Up: Function Substitutes Top: Top

9.559. memset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/memset.html

Gnulib module: memset

Portability problems fixed by Gnulib:

  • This function is missing on some older platforms.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: mkdir Prev: memmove Up: Function Substitutes Top: Top


mkdir -- GNU Gnulib

Next: mkdirat Prev: memset Up: Function Substitutes Top: Top

9.560. mkdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkdir.html

Gnulib module: mkdir

Portability problems fixed by Gnulib:

  • This function is declared in different header files (namely, <io.h> or <direct.h>) on some platforms: mingw, MSVC 14.
  • When the argument ends in a slash, the function call fails on some platforms.
  • This function mistakenly succeeds on `mkdir("d/./",mode)' on some platforms: Cygwin 1.5.x, mingw, MSVC 14.
  • On Windows platforms (excluding Cygwin), this function is called _mkdir and takes only one argument. The fix (without Gnulib) is to define a macro like this:
    #define mkdir ((int (*)()) _mkdir)
    or
    #define mkdir(path,mode) _mkdir (path)
Portability problems not fixed by Gnulib:

Next: mkdirat Prev: memset Up: Function Substitutes Top: Top


mkdirat -- GNU Gnulib

Next: mkdtemp Prev: mkdir Up: Function Substitutes Top: Top

9.561. mkdirat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkdirat.html

Gnulib module: mkdirat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
Portability problems not fixed by Gnulib:

Next: mkdtemp Prev: mkdir Up: Function Substitutes Top: Top


mkdtemp -- GNU Gnulib

Next: mkfifo Prev: mkdirat Up: Function Substitutes Top: Top

9.562. mkdtemp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkdtemp.html

Gnulib module: mkdtemp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: mkfifo Prev: mkdirat Up: Function Substitutes Top: Top


mkfifo -- GNU Gnulib

Next: mkfifoat Prev: mkdtemp Up: Function Substitutes Top: Top

9.563. mkfifo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkfifo.html

Gnulib module: mkfifo

Portability problems fixed by Gnulib:

  • This function mishandles trailing slash on some platforms: FreeBSD 7.2, Solaris 9.
  • This function is missing on some platforms; however, the replacement always fails with ENOSYS: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • If the argument exists and is a directory, this function fails with EISDIR instead of the correct EEXIST: HP-UX 11.11.

Next: mkfifoat Prev: mkdtemp Up: Function Substitutes Top: Top


mkfifoat -- GNU Gnulib

Next: mknod Prev: mkfifo Up: Function Substitutes Top: Top

9.564. mkfifoat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkfifoat.html

Gnulib module: mkfifoat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
Portability problems not fixed by Gnulib:
  • The gnulib replacement function always fails with `ENOSYS' on some platforms: mingw, MSVC 14.
  • If the argument exists and is a directory, the gnulib replacement function fails with EISDIR instead of the correct EEXIST: HP-UX 11.11.

Next: mknod Prev: mkfifo Up: Function Substitutes Top: Top


mknod -- GNU Gnulib

Next: mknodat Prev: mkfifoat Up: Function Substitutes Top: Top

9.565. mknod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mknod.html

Gnulib module: mknod

Portability problems fixed by Gnulib:

  • This function requires super-user privileges to create a fifo: FreeBSD 7.2, OpenBSD 3.8.
  • This function mishandles trailing slash on some platforms: FreeBSD 7.2, Solaris 9.
  • This function is missing on some platforms; however, the replacement always fails with ENOSYS: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Use of this function for anything except fifos is not portable, generally requiring super-user privileges and knowledge of supported device numbers.
  • If the argument exists and is a directory, this function fails with EISDIR instead of the correct EEXIST: HP-UX 11.11.

Next: mknodat Prev: mkfifoat Up: Function Substitutes Top: Top


mknodat -- GNU Gnulib

Next: mkstemp Prev: mknod Up: Function Substitutes Top: Top

9.566. mknodat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mknodat.html

Gnulib module: mkfifoat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
Portability problems not fixed by Gnulib:
  • The gnulib replacement function always fails with `ENOSYS' on some platforms: mingw, MSVC 14.
  • If the argument exists and is a directory, the gnulib replacement function fails with EISDIR instead of the correct EEXIST: HP-UX 11.11.

Next: mkstemp Prev: mknod Up: Function Substitutes Top: Top


mkstemp -- GNU Gnulib

Next: mktime Prev: mknodat Up: Function Substitutes Top: Top

9.567. mkstemp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mkstemp.html

Gnulib module: mkstemp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function is declared in <unistd.h> instead of <stdlib.h> on some platforms: Mac OS X 10.3.
  • On some platforms (HP-UX 10.20, SunOS 4.1.4, Solaris 2.5.1), mkstemp has a silly limit that it can create no more than 26 files from a given template. On OSF/1 4.0f, it can create only 32 files per process.
  • On platforms where off_t is a 32-bit type, mkstemp may not work correctly to create files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • On some older platforms, mkstemp can create a world or group writable or readable file, if you haven't set the process umask to 077. This is a security risk.
Portability problems not fixed by Gnulib:
The gnulib module clean-temp can create temporary files that will not be left behind after signals such as SIGINT.

Next: mktime Prev: mknodat Up: Function Substitutes Top: Top


mktime -- GNU Gnulib

Next: mlock Prev: mkstemp Up: Function Substitutes Top: Top

9.568. mktime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mktime.html

Gnulib module: mktime

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
  • mktime may go into an endless loop on some platforms.
  • mktime may occasionally return wrong results on some platforms.
Portability problems not fixed by Gnulib:
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.

Next: mlock Prev: mkstemp Up: Function Substitutes Top: Top


mlock -- GNU Gnulib

Next: mlockall Prev: mktime Up: Function Substitutes Top: Top

9.569. mlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, OSF/1 4.0, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mlockall Prev: mktime Up: Function Substitutes Top: Top


mlockall -- GNU Gnulib

Next: mmap Prev: mlock Up: Function Substitutes Top: Top

9.570. mlockall

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mlockall.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, OSF/1 4.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mmap Prev: mlock Up: Function Substitutes Top: Top


mmap -- GNU Gnulib

Next: modf Prev: mlockall Up: Function Substitutes Top: Top

9.571. mmap

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mmap.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly across the entire data range of files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.
  • To get anonymous memory, on some platforms, you can use the flags MAP_ANONYMOUS | MAP_PRIVATE and -1 instead of a file descriptor; on others you have to use a read-only file descriptor of /dev/zero.
  • On HP-UX, passing a non-NULL first argument, as a hint for the address (even without MAP_FIXED, often causes mmap to fail. Better pass NULL in this case.
  • On HP-UX, MAP_FIXED basically never works. On other platforms, it depends on the circumstances whether memory can be returned at a given address.

Next: modf Prev: mlockall Up: Function Substitutes Top: Top


modf -- GNU Gnulib

Next: modff Prev: mmap Up: Function Substitutes Top: Top

9.572. modf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/modf.html

Gnulib module: modf or modf-ieee

Portability problems fixed by either Gnulib module modf or modf-ieee:

Portability problems fixed by Gnulib module modf-ieee:
  • This function has problems with a NaN argument on some platforms: NetBSD 5.1, Cygwin.
  • This function has problems with infinite arguments on some platforms: FreeBSD 6.4, OpenBSD 4.9, IRIX 6.5, OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: modff Prev: mmap Up: Function Substitutes Top: Top


modff -- GNU Gnulib

Next: modfl Prev: modf Up: Function Substitutes Top: Top

9.573. modff

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/modff.html

Gnulib module: modff or modff-ieee

Portability problems fixed by either Gnulib module modff or modff-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.
  • This function is only defined as a buggy macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module modff-ieee:
  • This function has problems with a NaN argument on some platforms: NetBSD 5.1, OpenBSD 4.9, Solaris 9, Cygwin.
  • This function has problems with infinite arguments on some platforms: IRIX 6.5, OSF/1 5.1, mingw.
Portability problems not fixed by Gnulib:

Next: modfl Prev: modf Up: Function Substitutes Top: Top


modfl -- GNU Gnulib

Next: mprotect Prev: modff Up: Function Substitutes Top: Top

9.574. modfl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/modfl.html

Gnulib module: modfl or modfl-ieee

Portability problems fixed by either Gnulib module modfl or modfl-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems fixed by Gnulib module modfl-ieee:
  • This function has problems with infinite arguments on some platforms: IRIX 6.5, OSF/1 5.1, mingw.
Portability problems not fixed by Gnulib:

Next: mprotect Prev: modff Up: Function Substitutes Top: Top


mprotect -- GNU Gnulib

Next: mq_close Prev: modfl Up: Function Substitutes Top: Top

9.575. mprotect

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mprotect.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function does not set errno on some platforms: mingw.
  • On AIX, it is not possible to use mprotect on memory regions allocated with malloc.

Next: mq_close Prev: modfl Up: Function Substitutes Top: Top


mq_close -- GNU Gnulib

Next: mq_getattr Prev: mprotect Up: Function Substitutes Top: Top

9.576. mq_close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_close.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_getattr Prev: mprotect Up: Function Substitutes Top: Top


mq_getattr -- GNU Gnulib

Next: mq_notify Prev: mq_close Up: Function Substitutes Top: Top

9.577. mq_getattr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_getattr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_notify Prev: mq_close Up: Function Substitutes Top: Top


mq_notify -- GNU Gnulib

Next: mq_open Prev: mq_getattr Up: Function Substitutes Top: Top

9.578. mq_notify

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_notify.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_open Prev: mq_getattr Up: Function Substitutes Top: Top


mq_open -- GNU Gnulib

Next: mq_receive Prev: mq_notify Up: Function Substitutes Top: Top

9.579. mq_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_receive Prev: mq_notify Up: Function Substitutes Top: Top


mq_receive -- GNU Gnulib

Next: mq_send Prev: mq_open Up: Function Substitutes Top: Top

9.580. mq_receive

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_receive.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_send Prev: mq_open Up: Function Substitutes Top: Top


mq_send -- GNU Gnulib

Next: mq_setattr Prev: mq_receive Up: Function Substitutes Top: Top

9.581. mq_send

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_send.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_setattr Prev: mq_receive Up: Function Substitutes Top: Top


mq_setattr -- GNU Gnulib

Next: mq_timedreceive Prev: mq_send Up: Function Substitutes Top: Top

9.582. mq_setattr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_setattr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_timedreceive Prev: mq_send Up: Function Substitutes Top: Top


mq_timedreceive -- GNU Gnulib

Next: mq_timedsend Prev: mq_setattr Up: Function Substitutes Top: Top

9.583. mq_timedreceive

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_timedreceive.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_timedsend Prev: mq_setattr Up: Function Substitutes Top: Top


mq_timedsend -- GNU Gnulib

Next: mq_unlink Prev: mq_timedreceive Up: Function Substitutes Top: Top

9.584. mq_timedsend

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_timedsend.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mq_unlink Prev: mq_timedreceive Up: Function Substitutes Top: Top


mq_unlink -- GNU Gnulib

Next: mrand48 Prev: mq_timedsend Up: Function Substitutes Top: Top

9.585. mq_unlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mq_unlink.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mrand48 Prev: mq_timedsend Up: Function Substitutes Top: Top


mrand48 -- GNU Gnulib

Next: msgctl Prev: mq_unlink Up: Function Substitutes Top: Top

9.586. mrand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/mrand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: msgctl Prev: mq_unlink Up: Function Substitutes Top: Top


msgctl -- GNU Gnulib

Next: msgget Prev: mrand48 Up: Function Substitutes Top: Top

9.587. msgctl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/msgctl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: msgget Prev: mrand48 Up: Function Substitutes Top: Top


msgget -- GNU Gnulib

Next: msgrcv Prev: msgctl Up: Function Substitutes Top: Top

9.588. msgget

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/msgget.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: msgrcv Prev: msgctl Up: Function Substitutes Top: Top


msgrcv -- GNU Gnulib

Next: msgsnd Prev: msgget Up: Function Substitutes Top: Top

9.589. msgrcv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/msgrcv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: msgsnd Prev: msgget Up: Function Substitutes Top: Top


msgsnd -- GNU Gnulib

Next: msync Prev: msgrcv Up: Function Substitutes Top: Top

9.590. msgsnd

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/msgsnd.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: msync Prev: msgrcv Up: Function Substitutes Top: Top


msync -- GNU Gnulib

Next: munlock Prev: msgsnd Up: Function Substitutes Top: Top

9.591. msync

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/msync.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On NetBSD, msync takes only two arguments.

Next: munlock Prev: msgsnd Up: Function Substitutes Top: Top


munlock -- GNU Gnulib

Next: munlockall Prev: msync Up: Function Substitutes Top: Top

9.592. munlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/munlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, OSF/1 4.0, mingw, MSVC 14, Interix 3.5, BeOS.

Next: munlockall Prev: msync Up: Function Substitutes Top: Top


munlockall -- GNU Gnulib

Next: munmap Prev: munlock Up: Function Substitutes Top: Top

9.593. munlockall

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/munlockall.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, OSF/1 4.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: munmap Prev: munlock Up: Function Substitutes Top: Top


munmap -- GNU Gnulib

Next: nan Prev: munlockall Up: Function Substitutes Top: Top

9.594. munmap

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/munmap.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: nan Prev: munlockall Up: Function Substitutes Top: Top


nan -- GNU Gnulib

Next: nanf Prev: munmap Up: Function Substitutes Top: Top

9.595. nan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nan.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: nanf Prev: munmap Up: Function Substitutes Top: Top


nanf -- GNU Gnulib

Next: nanl Prev: nan Up: Function Substitutes Top: Top

9.596. nanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: nanl Prev: nan Up: Function Substitutes Top: Top


nanl -- GNU Gnulib

Next: nanosleep Prev: nanf Up: Function Substitutes Top: Top

9.597. nanl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nanl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: nanosleep Prev: nanf Up: Function Substitutes Top: Top


nanosleep -- GNU Gnulib

Next: nearbyint Prev: nanl Up: Function Substitutes Top: Top

9.598. nanosleep

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nanosleep.html

Gnulib module: nanosleep

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function reports failure when called with small arguments such as 1 ns on some platforms: AIX 4.3.2.
  • This function mishandles large arguments when interrupted by a signal on some platforms: Linux 64-bit, Solaris 64-bit.
  • This function cannot sleep longer than 49.7 days on some platforms: Cygwin 1.5.x.
Portability problems not fixed by Gnulib:

Next: nearbyint Prev: nanl Up: Function Substitutes Top: Top


nearbyint -- GNU Gnulib

Next: nearbyintf Prev: nanosleep Up: Function Substitutes Top: Top

9.599. nearbyint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nearbyint.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: nearbyintf Prev: nanosleep Up: Function Substitutes Top: Top


nearbyintf -- GNU Gnulib

Next: nearbyintl Prev: nearbyint Up: Function Substitutes Top: Top

9.600. nearbyintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nearbyintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: nearbyintl Prev: nearbyint Up: Function Substitutes Top: Top


nearbyintl -- GNU Gnulib

Next: newlocale Prev: nearbyintf Up: Function Substitutes Top: Top

9.601. nearbyintl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nearbyintl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: newlocale Prev: nearbyintf Up: Function Substitutes Top: Top


newlocale -- GNU Gnulib

Next: nextafter Prev: nearbyintl Up: Function Substitutes Top: Top

9.602. newlocale

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/newlocale.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nextafter Prev: nearbyintl Up: Function Substitutes Top: Top


nextafter -- GNU Gnulib

Next: nextafterf Prev: newlocale Up: Function Substitutes Top: Top

9.603. nextafter

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nextafter.html

Gnulib module: nextafter

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, MSVC 9.
  • This function is not declared on some platforms: IRIX 5.3.

Next: nextafterf Prev: newlocale Up: Function Substitutes Top: Top


nextafterf -- GNU Gnulib

Next: nextafterl Prev: nextafter Up: Function Substitutes Top: Top

9.604. nextafterf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nextafterf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, IRIX 6.5, Solaris 9, MSVC 9.

Next: nextafterl Prev: nextafter Up: Function Substitutes Top: Top


nextafterl -- GNU Gnulib

Next: nexttoward Prev: nextafterf Up: Function Substitutes Top: Top

9.605. nextafterl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nextafterl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: nexttoward Prev: nextafterf Up: Function Substitutes Top: Top


nexttoward -- GNU Gnulib

Next: nexttowardf Prev: nextafterl Up: Function Substitutes Top: Top

9.606. nexttoward

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nexttoward.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: nexttowardf Prev: nextafterl Up: Function Substitutes Top: Top


nexttowardf -- GNU Gnulib

Next: nexttowardl Prev: nexttoward Up: Function Substitutes Top: Top

9.607. nexttowardf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nexttowardf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: nexttowardl Prev: nexttoward Up: Function Substitutes Top: Top


nexttowardl -- GNU Gnulib

Next: nftw Prev: nexttowardf Up: Function Substitutes Top: Top

9.608. nexttowardl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nexttowardl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: nftw Prev: nexttowardf Up: Function Substitutes Top: Top


nftw -- GNU Gnulib

Next: nice Prev: nexttowardl Up: Function Substitutes Top: Top

9.609. nftw

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nftw.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 3.0, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not correctly report the size of files or block devices larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: nice Prev: nexttowardl Up: Function Substitutes Top: Top


nice -- GNU Gnulib

Next: nl_langinfo Prev: nftw Up: Function Substitutes Top: Top

9.610. nice

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nice.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • In glibc before glibc 2.2.4, nice returned 0 upon success.

Next: nl_langinfo Prev: nftw Up: Function Substitutes Top: Top


nl_langinfo -- GNU Gnulib

Next: nl_langinfo_l Prev: nice Up: Function Substitutes Top: Top

9.611. nl_langinfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nl_langinfo.html

Gnulib module: nl_langinfo

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • The constant CODESET is not supported on some platforms: glibc 2.0.6, OpenBSD 3.8.
  • The constants ERA, ERA_D_FMT, ERA_D_T_FMT, ERA_T_FMT, ALT_DIGITS are not supported on some platforms: OpenBSD 3.8.
  • The constants T_FMT_AMPM, YESEXPR, NOEXPR are not supported on some platforms: IRIX 5.3.
  • The constants YESEXPR and NOEXPR do not return a valid string on some platforms: Irix 6.5.
Portability problems not fixed by Gnulib:
  • On Cygwin 1.5.x, which doesn't have locales, nl_langinfo(CODESET) always returns "US-ASCII".

  • On Cygwin 1.7.0, only the charset portion of a locale designation is honored.

  • On NetBSD 5.0, in some locales, nl_langinfo(CRNCYSTR) returns the empty string, although the local currency symbol, as returned by localeconv()->currency_symbol, is non-empty.

  • On NetBSD 5.1, in the "C" locale, the results of nl_langinfo(ABMON_1) ... nl_langinfo(ABMON_12) are full month names, not abbreviated month names.

Next: nl_langinfo_l Prev: nice Up: Function Substitutes Top: Top


nl_langinfo_l -- GNU Gnulib

Next: nrand48 Prev: nl_langinfo Up: Function Substitutes Top: Top

9.612. nl_langinfo_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nl_langinfo_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nrand48 Prev: nl_langinfo Up: Function Substitutes Top: Top


nrand48 -- GNU Gnulib

Next: ntohl Prev: nl_langinfo_l Up: Function Substitutes Top: Top

9.613. nrand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/nrand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: ntohl Prev: nl_langinfo_l Up: Function Substitutes Top: Top


ntohl -- GNU Gnulib

Next: ntohs Prev: nrand48 Up: Function Substitutes Top: Top

9.614. ntohl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ntohl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, mingw, MSVC 14, BeOS.

Next: ntohs Prev: nrand48 Up: Function Substitutes Top: Top


ntohs -- GNU Gnulib

Next: open Prev: ntohl Up: Function Substitutes Top: Top

9.615. ntohs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ntohs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, mingw, MSVC 14, BeOS.

Next: open Prev: ntohl Up: Function Substitutes Top: Top


open -- GNU Gnulib

Next: openat Prev: ntohs Up: Function Substitutes Top: Top

9.616. open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/open.html

Gnulib module: open, fchdir

Portability problems fixed by the Gnulib module open:

  • Some platforms do not support O_CLOEXEC: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5.
  • On platforms where off_t is a 32-bit type, open may not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • This function does not fail when the file name argument ends in a slash and (without the slash) names a nonexistent file or a file that is not a directory, on some platforms: FreeBSD 7.2, AIX 7.1, HP-UX 11.00, Solaris 9, Irix 5.3.
  • This function does not support the O_NONBLOCK flag when it is defined by the gnulib module nonblocking on some platforms: mingw, MSVC 14.
  • On Windows platforms (excluding Cygwin), this function does usually not recognize the /dev/null filename.
Portability problems fixed by the Gnulib module fchdir:
  • On Windows platforms (excluding Cygwin), this function fails to open a read-only descriptor for directories.
Portability problems not fixed by Gnulib:
  • The Gnulib replacement for O_CLOEXEC is not atomic, and so is not safe in the presence of multiple threads or signal handlers.
  • open ("symlink", O_NOFOLLOW ...) fails with errno set to EMLINK instead of the POSIX-required ELOOP on some platforms: FreeBSD 10.1.
  • open ("symlink", O_NOFOLLOW ...) fails with errno set to EFTYPE instead of the POSIX-required ELOOP on some platforms: NetBSD 6.1.
  • On Windows, this function returns a file handle in O_TEXT mode by default; this means that it translates '\n' to CR/LF by default. Use the O_BINARY flag if you need reliable binary I/O.

Next: openat Prev: ntohs Up: Function Substitutes Top: Top


openat -- GNU Gnulib

Next: opendir Prev: open Up: Function Substitutes Top: Top

9.617. openat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/openat.html

Gnulib module: openat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • Some platforms do not support O_CLOEXEC: AIX 7.1, Solaris 10.
  • On platforms where off_t is a 32-bit type, open may not work correctly with files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • This function does not fail when the file name argument ends in a slash and (without the slash) names a nonexistent file or a file that is not a directory, on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:
  • The Gnulib replacement for O_CLOEXEC is not atomic, and so is not safe in the presence of multiple threads or signal handlers.
  • openat (fd, "symlink", O_NOFOLLOW ...) fails with errno set to EMLINK instead of the POSIX-required ELOOP on some platforms: FreeBSD 10.1.
  • openat (fd, "symlink", O_NOFOLLOW ...) fails with errno set to EFTYPE instead of the POSIX-required ELOOP on some platforms: NetBSD 6.1.

Next: opendir Prev: open Up: Function Substitutes Top: Top


opendir -- GNU Gnulib

Next: openlog Prev: openat Up: Function Substitutes Top: Top

9.618. opendir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/opendir.html

Gnulib module: opendir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:

Next: openlog Prev: openat Up: Function Substitutes Top: Top


openlog -- GNU Gnulib

Next: open_memstream Prev: opendir Up: Function Substitutes Top: Top

9.619. openlog

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/openlog.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: open_memstream Prev: opendir Up: Function Substitutes Top: Top


open_memstream -- GNU Gnulib

Next: open_wmemstream Prev: openlog Up: Function Substitutes Top: Top

9.620. open_memstream

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/open_memstream.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: open_wmemstream Prev: openlog Up: Function Substitutes Top: Top


open_wmemstream -- GNU Gnulib

Next: optarg Prev: open_memstream Up: Function Substitutes Top: Top

9.621. open_wmemstream

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/open_wmemstream.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: optarg Prev: open_memstream Up: Function Substitutes Top: Top


optarg -- GNU Gnulib

Next: opterr Prev: open_wmemstream Up: Function Substitutes Top: Top

9.622. optarg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/optarg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, IRIX 6.5, OSF/1 5.1, MSVC 14.

Next: opterr Prev: open_wmemstream Up: Function Substitutes Top: Top


opterr -- GNU Gnulib

Next: optind Prev: optarg Up: Function Substitutes Top: Top

9.623. opterr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/opterr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: IRIX 6.5, OSF/1 5.1, MSVC 14.

Next: optind Prev: optarg Up: Function Substitutes Top: Top


optind -- GNU Gnulib

Next: optopt Prev: opterr Up: Function Substitutes Top: Top

9.624. optind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/optind.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: IRIX 6.5, OSF/1 5.1, MSVC 14.

Next: optopt Prev: opterr Up: Function Substitutes Top: Top


optopt -- GNU Gnulib

Next: pathconf Prev: optind Up: Function Substitutes Top: Top

9.625. optopt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/optopt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, IRIX 6.5, OSF/1 5.1, MSVC 14.

Next: pathconf Prev: optind Up: Function Substitutes Top: Top


pathconf -- GNU Gnulib

Next: pause Prev: optopt Up: Function Substitutes Top: Top

9.626. pathconf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pathconf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: pause Prev: optopt Up: Function Substitutes Top: Top


pause -- GNU Gnulib

Next: pclose Prev: pathconf Up: Function Substitutes Top: Top

9.627. pause

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pause.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: pclose Prev: pathconf Up: Function Substitutes Top: Top


pclose -- GNU Gnulib

Next: perror Prev: pause Up: Function Substitutes Top: Top

9.628. pclose

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pclose.html

Gnulib module: pclose

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: perror Prev: pause Up: Function Substitutes Top: Top


perror -- GNU Gnulib

Next: pipe Prev: pclose Up: Function Substitutes Top: Top

9.629. perror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/perror.html

Gnulib module: perror

Portability problems fixed by Gnulib:

  • This function does not support the error values that are specified by POSIX but not defined by the system, on some platforms: OpenBSD 4.0, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14.
  • This function treats errno of 0 like failure, although POSIX requires that the message declare it as a success, on some platforms: FreeBSD 8.2, OpenBSD 4.7, Mac OS X 10.5.
  • This function clobbers the strerror buffer on some platforms: Cygwin 1.7.9.
  • This function fails to print a useful a string for out-of-range integers on some platforms: HP-UX 11, IRIX 6.5, Solaris 8.
Portability problems not fixed by Gnulib:
  • POSIX requires that this function set the stream error bit (detected by ferror) on write failure, but not all platforms do this: glibc 2.13, cygwin 1.7.9.
  • POSIX requires that this function not alter stream orientation, but the gnulib replacement locks in byte orientation and fails on wide character streams.

Next: pipe Prev: pclose Up: Function Substitutes Top: Top


pipe -- GNU Gnulib

Next: poll Prev: perror Up: Function Substitutes Top: Top

9.630. pipe

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pipe.html

Gnulib module: pipe-posix

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function crashes rather than failing with EMFILE if no resources are left on some platforms: Cygwin 1.7.9.

Next: poll Prev: perror Up: Function Substitutes Top: Top


poll -- GNU Gnulib

Next: popen Prev: pipe Up: Function Substitutes Top: Top

9.631. poll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/poll.html

Gnulib module: poll

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14, BeOS, HP NonStop.
  • This function doesn't work on special files like /dev/null and ttys like /dev/tty on some platforms: Mac OS X 10.4.0, AIX 5.3.
Portability problems not fixed by Gnulib:
  • Under BeOS, Gnulib's poll replacement can only be called on descriptors created by the socket function, not on regular file descriptors.

  • Under Windows, when passing a pipe, Gnulib's poll replacement might return 0 even before the timeout has passed. Programs using it with pipes can thus busy wait.

  • Under HP NonStop, file descriptors other than sockets do not support POLLHUP; they will return a "readable" status instead.

Next: popen Prev: pipe Up: Function Substitutes Top: Top


popen -- GNU Gnulib

Next: posix_fadvise Prev: poll Up: Function Substitutes Top: Top

9.632. popen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/popen.html

Gnulib module: popen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • Some platforms start the child with closed stdin or stdout if the standard descriptors were closed in the parent: Cygwin 1.5.x.
Portability problems not fixed by Gnulib:
  • On native Windows platforms, this functions terminates the current process with exit code 127 if the environment variable COMSPEC is not set.
  • Some platforms mistakenly set the close-on-exec bit, then if it is cleared by the application, the platform then leaks file descriptors from earlier popen calls into subsequent popen children: Cygwin 1.5.x.

Next: posix_fadvise Prev: poll Up: Function Substitutes Top: Top


posix_fadvise -- GNU Gnulib

Next: posix_fallocate Prev: popen Up: Function Substitutes Top: Top

9.633. posix_fadvise

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_fadvise.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly across the entire data range of files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: posix_fallocate Prev: popen Up: Function Substitutes Top: Top


posix_fallocate -- GNU Gnulib

Next: posix_madvise Prev: posix_fadvise Up: Function Substitutes Top: Top

9.634. posix_fallocate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_fallocate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • POSIX specifies that EINVAL should be returned when the file system doesn't support the allocation operation directly. glibc however emulates the file system allocation with writes where unsupported, and apps have depended on that long term implementation. This is both inefficient, and as of glibc 2.21 at least, buggy on certain NFS setups.
  • On platforms where off_t is a 32-bit type, this function may not work correctly across the entire data range of files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: posix_madvise Prev: posix_fadvise Up: Function Substitutes Top: Top


posix_madvise -- GNU Gnulib

Next: posix_mem_offset Prev: posix_fallocate Up: Function Substitutes Top: Top

9.635. posix_madvise

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_madvise.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_mem_offset Prev: posix_fallocate Up: Function Substitutes Top: Top


posix_mem_offset -- GNU Gnulib

Next: posix_memalign Prev: posix_madvise Up: Function Substitutes Top: Top

9.636. posix_mem_offset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_mem_offset.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_memalign Prev: posix_madvise Up: Function Substitutes Top: Top


posix_memalign -- GNU Gnulib

Next: posix_openpt Prev: posix_mem_offset Up: Function Substitutes Top: Top

9.637. posix_memalign

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_memalign.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
The Gnulib module pagealign_alloc provides a similar API that returns memory aligned on a system page boundary.

Next: posix_openpt Prev: posix_mem_offset Up: Function Substitutes Top: Top


posix_openpt -- GNU Gnulib

Next: posix_spawn Prev: posix_memalign Up: Function Substitutes Top: Top

9.638. posix_openpt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_openpt.html

Gnulib module: posix_openpt

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. However, the replacement may fail with ENOSYS or ENOENT on some platforms.
Portability problems not fixed by Gnulib:
Note that when using this function to open the master side of a pseudo-terminal, you still need platform dependent code to open the corresponding slave side. The Gnulib module openpty provides an easy-to-use API that does both at once.

Next: posix_spawn Prev: posix_memalign Up: Function Substitutes Top: Top


posix_spawn -- GNU Gnulib

Next: posix_spawn_file_actions_addclose Prev: posix_openpt Up: Function Substitutes Top: Top

9.639. posix_spawn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn.html

Gnulib module: posix_spawn

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • When this function fails, it causes the stdio buffer contents to be output twice on some platforms: AIX 6.1.
Portability problems not fixed by Gnulib:
  • This function does not work on some platforms: AIX 6.1 (under particular circumstances), mingw.

Next: posix_spawn_file_actions_addclose Prev: posix_openpt Up: Function Substitutes Top: Top


posix_spawn_file_actions_addclose -- GNU Gnulib

Next: posix_spawn_file_actions_adddup2 Prev: posix_spawn Up: Function Substitutes Top: Top

9.640. posix_spawn_file_actions_addclose

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn_file_actions_addclose.html

Gnulib module: posix_spawn_file_actions_addclose

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function does not reject a too large file descriptor on some platforms: Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: posix_spawn_file_actions_adddup2 Prev: posix_spawn Up: Function Substitutes Top: Top


posix_spawn_file_actions_adddup2 -- GNU Gnulib

Next: posix_spawn_file_actions_addopen Prev: posix_spawn_file_actions_addclose Up: Function Substitutes Top: Top

9.641. posix_spawn_file_actions_adddup2

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn_file_actions_adddup2.html

Gnulib module: posix_spawn_file_actions_adddup2

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function does not reject a too large file descriptor on some platforms: Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: posix_spawn_file_actions_addopen Prev: posix_spawn_file_actions_addclose Up: Function Substitutes Top: Top


posix_spawn_file_actions_addopen -- GNU Gnulib

Next: posix_spawn_file_actions_destroy Prev: posix_spawn_file_actions_adddup2 Up: Function Substitutes Top: Top

9.642. posix_spawn_file_actions_addopen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn_file_actions_addopen.html

Gnulib module: posix_spawn_file_actions_addopen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function does not reject a too large file descriptor on some platforms: Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: posix_spawn_file_actions_destroy Prev: posix_spawn_file_actions_adddup2 Up: Function Substitutes Top: Top


posix_spawn_file_actions_destroy -- GNU Gnulib

Next: posix_spawn_file_actions_init Prev: posix_spawn_file_actions_addopen Up: Function Substitutes Top: Top

9.643. posix_spawn_file_actions_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn_file_actions_destroy.html

Gnulib module: posix_spawn_file_actions_destroy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawn_file_actions_init Prev: posix_spawn_file_actions_addopen Up: Function Substitutes Top: Top


posix_spawn_file_actions_init -- GNU Gnulib

Next: posix_spawnattr_destroy Prev: posix_spawn_file_actions_destroy Up: Function Substitutes Top: Top

9.644. posix_spawn_file_actions_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawn_file_actions_init.html

Gnulib module: posix_spawn_file_actions_init

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_destroy Prev: posix_spawn_file_actions_destroy Up: Function Substitutes Top: Top


posix_spawnattr_destroy -- GNU Gnulib

Next: posix_spawnattr_getflags Prev: posix_spawn_file_actions_init Up: Function Substitutes Top: Top

9.645. posix_spawnattr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_destroy.html

Gnulib module: posix_spawnattr_destroy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getflags Prev: posix_spawn_file_actions_init Up: Function Substitutes Top: Top


posix_spawnattr_getflags -- GNU Gnulib

Next: posix_spawnattr_getpgroup Prev: posix_spawnattr_destroy Up: Function Substitutes Top: Top

9.646. posix_spawnattr_getflags

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getflags.html

Gnulib module: posix_spawnattr_getflags

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getpgroup Prev: posix_spawnattr_destroy Up: Function Substitutes Top: Top


posix_spawnattr_getpgroup -- GNU Gnulib

Next: posix_spawnattr_getschedparam Prev: posix_spawnattr_getflags Up: Function Substitutes Top: Top

9.647. posix_spawnattr_getpgroup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getpgroup.html

Gnulib module: posix_spawnattr_getpgroup

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getschedparam Prev: posix_spawnattr_getflags Up: Function Substitutes Top: Top


posix_spawnattr_getschedparam -- GNU Gnulib

Next: posix_spawnattr_getschedpolicy Prev: posix_spawnattr_getpgroup Up: Function Substitutes Top: Top

9.648. posix_spawnattr_getschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getschedparam.html

Gnulib module: posix_spawnattr_getschedparam

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getschedpolicy Prev: posix_spawnattr_getpgroup Up: Function Substitutes Top: Top


posix_spawnattr_getschedpolicy -- GNU Gnulib

Next: posix_spawnattr_getsigdefault Prev: posix_spawnattr_getschedparam Up: Function Substitutes Top: Top

9.649. posix_spawnattr_getschedpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getschedpolicy.html

Gnulib module: posix_spawnattr_getschedpolicy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getsigdefault Prev: posix_spawnattr_getschedparam Up: Function Substitutes Top: Top


posix_spawnattr_getsigdefault -- GNU Gnulib

Next: posix_spawnattr_getsigmask Prev: posix_spawnattr_getschedpolicy Up: Function Substitutes Top: Top

9.650. posix_spawnattr_getsigdefault

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getsigdefault.html

Gnulib module: posix_spawnattr_getsigdefault

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_getsigmask Prev: posix_spawnattr_getschedpolicy Up: Function Substitutes Top: Top


posix_spawnattr_getsigmask -- GNU Gnulib

Next: posix_spawnattr_init Prev: posix_spawnattr_getsigdefault Up: Function Substitutes Top: Top

9.651. posix_spawnattr_getsigmask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_getsigmask.html

Gnulib module: posix_spawnattr_getsigmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_init Prev: posix_spawnattr_getsigdefault Up: Function Substitutes Top: Top


posix_spawnattr_init -- GNU Gnulib

Next: posix_spawnattr_setflags Prev: posix_spawnattr_getsigmask Up: Function Substitutes Top: Top

9.652. posix_spawnattr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_init.html

Gnulib module: posix_spawnattr_init

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setflags Prev: posix_spawnattr_getsigmask Up: Function Substitutes Top: Top


posix_spawnattr_setflags -- GNU Gnulib

Next: posix_spawnattr_setpgroup Prev: posix_spawnattr_init Up: Function Substitutes Top: Top

9.653. posix_spawnattr_setflags

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setflags.html

Gnulib module: posix_spawnattr_setflags

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setpgroup Prev: posix_spawnattr_init Up: Function Substitutes Top: Top


posix_spawnattr_setpgroup -- GNU Gnulib

Next: posix_spawnattr_setschedparam Prev: posix_spawnattr_setflags Up: Function Substitutes Top: Top

9.654. posix_spawnattr_setpgroup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setpgroup.html

Gnulib module: posix_spawnattr_setpgroup

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setschedparam Prev: posix_spawnattr_setflags Up: Function Substitutes Top: Top


posix_spawnattr_setschedparam -- GNU Gnulib

Next: posix_spawnattr_setschedpolicy Prev: posix_spawnattr_setpgroup Up: Function Substitutes Top: Top

9.655. posix_spawnattr_setschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setschedparam.html

Gnulib module: posix_spawnattr_setschedparam

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setschedpolicy Prev: posix_spawnattr_setpgroup Up: Function Substitutes Top: Top


posix_spawnattr_setschedpolicy -- GNU Gnulib

Next: posix_spawnattr_setsigdefault Prev: posix_spawnattr_setschedparam Up: Function Substitutes Top: Top

9.656. posix_spawnattr_setschedpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setschedpolicy.html

Gnulib module: posix_spawnattr_setschedpolicy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setsigdefault Prev: posix_spawnattr_setschedparam Up: Function Substitutes Top: Top


posix_spawnattr_setsigdefault -- GNU Gnulib

Next: posix_spawnattr_setsigmask Prev: posix_spawnattr_setschedpolicy Up: Function Substitutes Top: Top

9.657. posix_spawnattr_setsigdefault

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setsigdefault.html

Gnulib module: posix_spawnattr_setsigdefault

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnattr_setsigmask Prev: posix_spawnattr_setschedpolicy Up: Function Substitutes Top: Top


posix_spawnattr_setsigmask -- GNU Gnulib

Next: posix_spawnp Prev: posix_spawnattr_setsigdefault Up: Function Substitutes Top: Top

9.658. posix_spawnattr_setsigmask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnattr_setsigmask.html

Gnulib module: posix_spawnattr_setsigmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: posix_spawnp Prev: posix_spawnattr_setsigdefault Up: Function Substitutes Top: Top


posix_spawnp -- GNU Gnulib

Next: posix_trace_attr_destroy Prev: posix_spawnattr_setsigmask Up: Function Substitutes Top: Top

9.659. posix_spawnp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_spawnp.html

Gnulib module: posix_spawnp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • When this function fails, it causes the stdio buffer contents to be output twice on some platforms: AIX 6.1.
Portability problems not fixed by Gnulib:
  • This function does not work on some platforms: AIX 6.1 (under particular circumstances), mingw.

Next: posix_trace_attr_destroy Prev: posix_spawnattr_setsigmask Up: Function Substitutes Top: Top


posix_trace_attr_destroy -- GNU Gnulib

Next: posix_trace_attr_getclockres Prev: posix_spawnp Up: Function Substitutes Top: Top

9.660. posix_trace_attr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getclockres Prev: posix_spawnp Up: Function Substitutes Top: Top


posix_trace_attr_getclockres -- GNU Gnulib

Next: posix_trace_attr_getcreatetime Prev: posix_trace_attr_destroy Up: Function Substitutes Top: Top

9.661. posix_trace_attr_getclockres

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getclockres.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getcreatetime Prev: posix_trace_attr_destroy Up: Function Substitutes Top: Top


posix_trace_attr_getcreatetime -- GNU Gnulib

Next: posix_trace_attr_getgenversion Prev: posix_trace_attr_getclockres Up: Function Substitutes Top: Top

9.662. posix_trace_attr_getcreatetime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getcreatetime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getgenversion Prev: posix_trace_attr_getclockres Up: Function Substitutes Top: Top


posix_trace_attr_getgenversion -- GNU Gnulib

Next: posix_trace_attr_getinherited Prev: posix_trace_attr_getcreatetime Up: Function Substitutes Top: Top

9.663. posix_trace_attr_getgenversion

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getgenversion.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getinherited Prev: posix_trace_attr_getcreatetime Up: Function Substitutes Top: Top


posix_trace_attr_getinherited -- GNU Gnulib

Next: posix_trace_attr_getlogfullpolicy Prev: posix_trace_attr_getgenversion Up: Function Substitutes Top: Top

9.664. posix_trace_attr_getinherited

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getinherited.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getlogfullpolicy Prev: posix_trace_attr_getgenversion Up: Function Substitutes Top: Top


posix_trace_attr_getlogfullpolicy -- GNU Gnulib

Next: posix_trace_attr_getlogsize Prev: posix_trace_attr_getinherited Up: Function Substitutes Top: Top

9.665. posix_trace_attr_getlogfullpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getlogfullpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getlogsize Prev: posix_trace_attr_getinherited Up: Function Substitutes Top: Top


posix_trace_attr_getlogsize -- GNU Gnulib

Next: posix_trace_attr_getmaxdatasize Prev: posix_trace_attr_getlogfullpolicy Up: Function Substitutes Top: Top

9.666. posix_trace_attr_getlogsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getlogsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getmaxdatasize Prev: posix_trace_attr_getlogfullpolicy Up: Function Substitutes Top: Top


posix_trace_attr_getmaxdatasize -- GNU Gnulib

Next: posix_trace_attr_getmaxsystemeventsize Prev: posix_trace_attr_getlogsize Up: Function Substitutes Top: Top

9.667. posix_trace_attr_getmaxdatasize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getmaxdatasize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getmaxsystemeventsize Prev: posix_trace_attr_getlogsize Up: Function Substitutes Top: Top


posix_trace_attr_getmaxsystemeventsize -- GNU Gnulib

Next: posix_trace_attr_getmaxusereventsize Prev: posix_trace_attr_getmaxdatasize Up: Function Substitutes Top: Top

9.668. posix_trace_attr_getmaxsystemeventsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getmaxsystemeventsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getmaxusereventsize Prev: posix_trace_attr_getmaxdatasize Up: Function Substitutes Top: Top


posix_trace_attr_getmaxusereventsize -- GNU Gnulib

Next: posix_trace_attr_getname Prev: posix_trace_attr_getmaxsystemeventsize Up: Function Substitutes Top: Top

9.669. posix_trace_attr_getmaxusereventsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getmaxusereventsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getname Prev: posix_trace_attr_getmaxsystemeventsize Up: Function Substitutes Top: Top


posix_trace_attr_getname -- GNU Gnulib

Next: posix_trace_attr_getstreamfullpolicy Prev: posix_trace_attr_getmaxusereventsize Up: Function Substitutes Top: Top

9.670. posix_trace_attr_getname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getstreamfullpolicy Prev: posix_trace_attr_getmaxusereventsize Up: Function Substitutes Top: Top


posix_trace_attr_getstreamfullpolicy -- GNU Gnulib

Next: posix_trace_attr_getstreamsize Prev: posix_trace_attr_getname Up: Function Substitutes Top: Top

9.671. posix_trace_attr_getstreamfullpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getstreamfullpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_getstreamsize Prev: posix_trace_attr_getname Up: Function Substitutes Top: Top


posix_trace_attr_getstreamsize -- GNU Gnulib

Next: posix_trace_attr_init Prev: posix_trace_attr_getstreamfullpolicy Up: Function Substitutes Top: Top

9.672. posix_trace_attr_getstreamsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_getstreamsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_init Prev: posix_trace_attr_getstreamfullpolicy Up: Function Substitutes Top: Top


posix_trace_attr_init -- GNU Gnulib

Next: posix_trace_attr_setinherited Prev: posix_trace_attr_getstreamsize Up: Function Substitutes Top: Top

9.673. posix_trace_attr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setinherited Prev: posix_trace_attr_getstreamsize Up: Function Substitutes Top: Top


posix_trace_attr_setinherited -- GNU Gnulib

Next: posix_trace_attr_setlogfullpolicy Prev: posix_trace_attr_init Up: Function Substitutes Top: Top

9.674. posix_trace_attr_setinherited

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setinherited.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setlogfullpolicy Prev: posix_trace_attr_init Up: Function Substitutes Top: Top


posix_trace_attr_setlogfullpolicy -- GNU Gnulib

Next: posix_trace_attr_setlogsize Prev: posix_trace_attr_setinherited Up: Function Substitutes Top: Top

9.675. posix_trace_attr_setlogfullpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setlogfullpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setlogsize Prev: posix_trace_attr_setinherited Up: Function Substitutes Top: Top


posix_trace_attr_setlogsize -- GNU Gnulib

Next: posix_trace_attr_setmaxdatasize Prev: posix_trace_attr_setlogfullpolicy Up: Function Substitutes Top: Top

9.676. posix_trace_attr_setlogsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setlogsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setmaxdatasize Prev: posix_trace_attr_setlogfullpolicy Up: Function Substitutes Top: Top


posix_trace_attr_setmaxdatasize -- GNU Gnulib

Next: posix_trace_attr_setname Prev: posix_trace_attr_setlogsize Up: Function Substitutes Top: Top

9.677. posix_trace_attr_setmaxdatasize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setmaxdatasize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setname Prev: posix_trace_attr_setlogsize Up: Function Substitutes Top: Top


posix_trace_attr_setname -- GNU Gnulib

Next: posix_trace_attr_setstreamfullpolicy Prev: posix_trace_attr_setmaxdatasize Up: Function Substitutes Top: Top

9.678. posix_trace_attr_setname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setstreamfullpolicy Prev: posix_trace_attr_setmaxdatasize Up: Function Substitutes Top: Top


posix_trace_attr_setstreamfullpolicy -- GNU Gnulib

Next: posix_trace_attr_setstreamsize Prev: posix_trace_attr_setname Up: Function Substitutes Top: Top

9.679. posix_trace_attr_setstreamfullpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setstreamfullpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_attr_setstreamsize Prev: posix_trace_attr_setname Up: Function Substitutes Top: Top


posix_trace_attr_setstreamsize -- GNU Gnulib

Next: posix_trace_clear Prev: posix_trace_attr_setstreamfullpolicy Up: Function Substitutes Top: Top

9.680. posix_trace_attr_setstreamsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_attr_setstreamsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_clear Prev: posix_trace_attr_setstreamfullpolicy Up: Function Substitutes Top: Top


posix_trace_clear -- GNU Gnulib

Next: posix_trace_close Prev: posix_trace_attr_setstreamsize Up: Function Substitutes Top: Top

9.681. posix_trace_clear

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_clear.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_close Prev: posix_trace_attr_setstreamsize Up: Function Substitutes Top: Top


posix_trace_close -- GNU Gnulib

Next: posix_trace_create Prev: posix_trace_clear Up: Function Substitutes Top: Top

9.682. posix_trace_close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_close.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_create Prev: posix_trace_clear Up: Function Substitutes Top: Top


posix_trace_create -- GNU Gnulib

Next: posix_trace_create_withlog Prev: posix_trace_close Up: Function Substitutes Top: Top

9.683. posix_trace_create

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_create.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_create_withlog Prev: posix_trace_close Up: Function Substitutes Top: Top


posix_trace_create_withlog -- GNU Gnulib

Next: posix_trace_event Prev: posix_trace_create Up: Function Substitutes Top: Top

9.684. posix_trace_create_withlog

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_create_withlog.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_event Prev: posix_trace_create Up: Function Substitutes Top: Top


posix_trace_event -- GNU Gnulib

Next: posix_trace_eventid_equal Prev: posix_trace_create_withlog Up: Function Substitutes Top: Top

9.685. posix_trace_event

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_event.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventid_equal Prev: posix_trace_create_withlog Up: Function Substitutes Top: Top


posix_trace_eventid_equal -- GNU Gnulib

Next: posix_trace_eventid_get_name Prev: posix_trace_event Up: Function Substitutes Top: Top

9.686. posix_trace_eventid_equal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventid_equal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventid_get_name Prev: posix_trace_event Up: Function Substitutes Top: Top


posix_trace_eventid_get_name -- GNU Gnulib

Next: posix_trace_eventid_open Prev: posix_trace_eventid_equal Up: Function Substitutes Top: Top

9.687. posix_trace_eventid_get_name

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventid_get_name.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventid_open Prev: posix_trace_eventid_equal Up: Function Substitutes Top: Top


posix_trace_eventid_open -- GNU Gnulib

Next: posix_trace_eventset_add Prev: posix_trace_eventid_get_name Up: Function Substitutes Top: Top

9.688. posix_trace_eventid_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventid_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventset_add Prev: posix_trace_eventid_get_name Up: Function Substitutes Top: Top


posix_trace_eventset_add -- GNU Gnulib

Next: posix_trace_eventset_del Prev: posix_trace_eventid_open Up: Function Substitutes Top: Top

9.689. posix_trace_eventset_add

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventset_add.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventset_del Prev: posix_trace_eventid_open Up: Function Substitutes Top: Top


posix_trace_eventset_del -- GNU Gnulib

Next: posix_trace_eventset_empty Prev: posix_trace_eventset_add Up: Function Substitutes Top: Top

9.690. posix_trace_eventset_del

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventset_del.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventset_empty Prev: posix_trace_eventset_add Up: Function Substitutes Top: Top


posix_trace_eventset_empty -- GNU Gnulib

Next: posix_trace_eventset_fill Prev: posix_trace_eventset_del Up: Function Substitutes Top: Top

9.691. posix_trace_eventset_empty

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventset_empty.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventset_fill Prev: posix_trace_eventset_del Up: Function Substitutes Top: Top


posix_trace_eventset_fill -- GNU Gnulib

Next: posix_trace_eventset_ismember Prev: posix_trace_eventset_empty Up: Function Substitutes Top: Top

9.692. posix_trace_eventset_fill

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventset_fill.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventset_ismember Prev: posix_trace_eventset_empty Up: Function Substitutes Top: Top


posix_trace_eventset_ismember -- GNU Gnulib

Next: posix_trace_eventtypelist_getnext_id Prev: posix_trace_eventset_fill Up: Function Substitutes Top: Top

9.693. posix_trace_eventset_ismember

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventset_ismember.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventtypelist_getnext_id Prev: posix_trace_eventset_fill Up: Function Substitutes Top: Top


posix_trace_eventtypelist_getnext_id -- GNU Gnulib

Next: posix_trace_eventtypelist_rewind Prev: posix_trace_eventset_ismember Up: Function Substitutes Top: Top

9.694. posix_trace_eventtypelist_getnext_id

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventtypelist_getnext_id.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_eventtypelist_rewind Prev: posix_trace_eventset_ismember Up: Function Substitutes Top: Top


posix_trace_eventtypelist_rewind -- GNU Gnulib

Next: posix_trace_flush Prev: posix_trace_eventtypelist_getnext_id Up: Function Substitutes Top: Top

9.695. posix_trace_eventtypelist_rewind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_eventtypelist_rewind.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_flush Prev: posix_trace_eventtypelist_getnext_id Up: Function Substitutes Top: Top


posix_trace_flush -- GNU Gnulib

Next: posix_trace_get_attr Prev: posix_trace_eventtypelist_rewind Up: Function Substitutes Top: Top

9.696. posix_trace_flush

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_flush.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_get_attr Prev: posix_trace_eventtypelist_rewind Up: Function Substitutes Top: Top


posix_trace_get_attr -- GNU Gnulib

Next: posix_trace_get_filter Prev: posix_trace_flush Up: Function Substitutes Top: Top

9.697. posix_trace_get_attr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_get_attr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_get_filter Prev: posix_trace_flush Up: Function Substitutes Top: Top


posix_trace_get_filter -- GNU Gnulib

Next: posix_trace_get_status Prev: posix_trace_get_attr Up: Function Substitutes Top: Top

9.698. posix_trace_get_filter

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_get_filter.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_get_status Prev: posix_trace_get_attr Up: Function Substitutes Top: Top


posix_trace_get_status -- GNU Gnulib

Next: posix_trace_getnext_event Prev: posix_trace_get_filter Up: Function Substitutes Top: Top

9.699. posix_trace_get_status

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_get_status.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_getnext_event Prev: posix_trace_get_filter Up: Function Substitutes Top: Top


posix_trace_getnext_event -- GNU Gnulib

Next: posix_trace_open Prev: posix_trace_get_status Up: Function Substitutes Top: Top

9.700. posix_trace_getnext_event

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_getnext_event.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_open Prev: posix_trace_get_status Up: Function Substitutes Top: Top


posix_trace_open -- GNU Gnulib

Next: posix_trace_rewind Prev: posix_trace_getnext_event Up: Function Substitutes Top: Top

9.701. posix_trace_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_rewind Prev: posix_trace_getnext_event Up: Function Substitutes Top: Top


posix_trace_rewind -- GNU Gnulib

Next: posix_trace_set_filter Prev: posix_trace_open Up: Function Substitutes Top: Top

9.702. posix_trace_rewind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_rewind.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_set_filter Prev: posix_trace_open Up: Function Substitutes Top: Top


posix_trace_set_filter -- GNU Gnulib

Next: posix_trace_shutdown Prev: posix_trace_rewind Up: Function Substitutes Top: Top

9.703. posix_trace_set_filter

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_set_filter.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_shutdown Prev: posix_trace_rewind Up: Function Substitutes Top: Top


posix_trace_shutdown -- GNU Gnulib

Next: posix_trace_start Prev: posix_trace_set_filter Up: Function Substitutes Top: Top

9.704. posix_trace_shutdown

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_shutdown.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_start Prev: posix_trace_set_filter Up: Function Substitutes Top: Top


posix_trace_start -- GNU Gnulib

Next: posix_trace_stop Prev: posix_trace_shutdown Up: Function Substitutes Top: Top

9.705. posix_trace_start

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_start.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_stop Prev: posix_trace_shutdown Up: Function Substitutes Top: Top


posix_trace_stop -- GNU Gnulib

Next: posix_trace_timedgetnext_event Prev: posix_trace_start Up: Function Substitutes Top: Top

9.706. posix_trace_stop

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_stop.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_timedgetnext_event Prev: posix_trace_start Up: Function Substitutes Top: Top


posix_trace_timedgetnext_event -- GNU Gnulib

Next: posix_trace_trid_eventid_open Prev: posix_trace_stop Up: Function Substitutes Top: Top

9.707. posix_trace_timedgetnext_event

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_timedgetnext_event.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_trid_eventid_open Prev: posix_trace_stop Up: Function Substitutes Top: Top


posix_trace_trid_eventid_open -- GNU Gnulib

Next: posix_trace_trygetnext_event Prev: posix_trace_timedgetnext_event Up: Function Substitutes Top: Top

9.708. posix_trace_trid_eventid_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_trid_eventid_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_trace_trygetnext_event Prev: posix_trace_timedgetnext_event Up: Function Substitutes Top: Top


posix_trace_trygetnext_event -- GNU Gnulib

Next: posix_typed_mem_get_info Prev: posix_trace_trid_eventid_open Up: Function Substitutes Top: Top

9.709. posix_trace_trygetnext_event

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_trace_trygetnext_event.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_typed_mem_get_info Prev: posix_trace_trid_eventid_open Up: Function Substitutes Top: Top


posix_typed_mem_get_info -- GNU Gnulib

Next: posix_typed_mem_open Prev: posix_trace_trygetnext_event Up: Function Substitutes Top: Top

9.710. posix_typed_mem_get_info

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_typed_mem_get_info.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: posix_typed_mem_open Prev: posix_trace_trygetnext_event Up: Function Substitutes Top: Top


posix_typed_mem_open -- GNU Gnulib

Next: pow Prev: posix_typed_mem_get_info Up: Function Substitutes Top: Top

9.711. posix_typed_mem_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/posix_typed_mem_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pow Prev: posix_typed_mem_get_info Up: Function Substitutes Top: Top


pow -- GNU Gnulib

Next: powf Prev: posix_typed_mem_open Up: Function Substitutes Top: Top

9.712. pow

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pow.html

Gnulib module: pow

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: powf Prev: posix_typed_mem_open Up: Function Substitutes Top: Top


powf -- GNU Gnulib

Next: powl Prev: pow Up: Function Substitutes Top: Top

9.713. powf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/powf.html

Gnulib module: powf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 9.
Portability problems not fixed by Gnulib:

Next: powl Prev: pow Up: Function Substitutes Top: Top


powl -- GNU Gnulib

Next: pread Prev: powf Up: Function Substitutes Top: Top

9.714. powl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/powl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.

Next: pread Prev: powf Up: Function Substitutes Top: Top


pread -- GNU Gnulib

Next: printf Prev: powl Up: Function Substitutes Top: Top

9.715. pread

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pread.html

Gnulib module: pread

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 10, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • This function returns zero instead of positive values when large file support is enabled on some platforms: HP-UX 11.11.
  • This function does not fail on pipes on some platforms: HP-UX 11.31.
Portability problems not fixed by Gnulib:

Next: printf Prev: powl Up: Function Substitutes Top: Top


printf -- GNU Gnulib

Next: pselect Prev: pread Up: Function Substitutes Top: Top

9.716. printf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/printf.html

Gnulib module: printf-posix or stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module printf-posix:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems fixed by Gnulib module stdio or printf-posix, together with module nonblocking:
  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio or printf-posix, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • Attempting to write to a read-only stream fails with EOF but does not set the error flag for ferror on some platforms: glibc 2.13, cygwin 1.7.9.

Next: pselect Prev: pread Up: Function Substitutes Top: Top


pselect -- GNU Gnulib

Next: psiginfo Prev: printf Up: Function Substitutes Top: Top

9.717. pselect

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pselect.html

Gnulib module: ---

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 14, Interix 3.5, BeOS.
  • On some platforms, this function fails to detect invalid fds with EBADF, but only if they lie beyond the current maximum open fd: FreeBSD 8.2.
Portability problems not fixed by Gnulib:
  • When the sigmask argument is nonnull on platforms that do not natively support this function, race conditions are possible when its gnulib implementation temporarily modifies the signal mask, and the behavior is unspecified in a multi-threaded process.

Next: psiginfo Prev: printf Up: Function Substitutes Top: Top


psiginfo -- GNU Gnulib

Next: psignal Prev: pselect Up: Function Substitutes Top: Top

9.718. psiginfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/psiginfo.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: psignal Prev: pselect Up: Function Substitutes Top: Top


psignal -- GNU Gnulib

Next: pthread_atfork Prev: psiginfo Up: Function Substitutes Top: Top

9.719. psignal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/psignal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_atfork Prev: psiginfo Up: Function Substitutes Top: Top


pthread_atfork -- GNU Gnulib

Next: pthread_attr_destroy Prev: psignal Up: Function Substitutes Top: Top

9.720. pthread_atfork

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_atfork.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_destroy Prev: psignal Up: Function Substitutes Top: Top


pthread_attr_destroy -- GNU Gnulib

Next: pthread_attr_getdetachstate Prev: pthread_atfork Up: Function Substitutes Top: Top

9.721. pthread_attr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getdetachstate Prev: pthread_atfork Up: Function Substitutes Top: Top


pthread_attr_getdetachstate -- GNU Gnulib

Next: pthread_attr_getguardsize Prev: pthread_attr_destroy Up: Function Substitutes Top: Top

9.722. pthread_attr_getdetachstate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getdetachstate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getguardsize Prev: pthread_attr_destroy Up: Function Substitutes Top: Top


pthread_attr_getguardsize -- GNU Gnulib

Next: pthread_attr_getinheritsched Prev: pthread_attr_getdetachstate Up: Function Substitutes Top: Top

9.723. pthread_attr_getguardsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getguardsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_attr_getinheritsched Prev: pthread_attr_getdetachstate Up: Function Substitutes Top: Top


pthread_attr_getinheritsched -- GNU Gnulib

Next: pthread_attr_getschedparam Prev: pthread_attr_getguardsize Up: Function Substitutes Top: Top

9.724. pthread_attr_getinheritsched

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getinheritsched.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getschedparam Prev: pthread_attr_getguardsize Up: Function Substitutes Top: Top


pthread_attr_getschedparam -- GNU Gnulib

Next: pthread_attr_getschedpolicy Prev: pthread_attr_getinheritsched Up: Function Substitutes Top: Top

9.725. pthread_attr_getschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getschedparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getschedpolicy Prev: pthread_attr_getinheritsched Up: Function Substitutes Top: Top


pthread_attr_getschedpolicy -- GNU Gnulib

Next: pthread_attr_getscope Prev: pthread_attr_getschedparam Up: Function Substitutes Top: Top

9.726. pthread_attr_getschedpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getschedpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getscope Prev: pthread_attr_getschedparam Up: Function Substitutes Top: Top


pthread_attr_getscope -- GNU Gnulib

Next: pthread_attr_getstack Prev: pthread_attr_getschedpolicy Up: Function Substitutes Top: Top

9.727. pthread_attr_getscope

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getscope.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_getstack Prev: pthread_attr_getschedpolicy Up: Function Substitutes Top: Top


pthread_attr_getstack -- GNU Gnulib

Next: pthread_attr_getstacksize Prev: pthread_attr_getscope Up: Function Substitutes Top: Top

9.728. pthread_attr_getstack

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getstack.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_attr_getstacksize Prev: pthread_attr_getscope Up: Function Substitutes Top: Top


pthread_attr_getstacksize -- GNU Gnulib

Next: pthread_attr_init Prev: pthread_attr_getstack Up: Function Substitutes Top: Top

9.729. pthread_attr_getstacksize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_getstacksize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_init Prev: pthread_attr_getstack Up: Function Substitutes Top: Top


pthread_attr_init -- GNU Gnulib

Next: pthread_attr_setdetachstate Prev: pthread_attr_getstacksize Up: Function Substitutes Top: Top

9.730. pthread_attr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setdetachstate Prev: pthread_attr_getstacksize Up: Function Substitutes Top: Top


pthread_attr_setdetachstate -- GNU Gnulib

Next: pthread_attr_setguardsize Prev: pthread_attr_init Up: Function Substitutes Top: Top

9.731. pthread_attr_setdetachstate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setdetachstate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setguardsize Prev: pthread_attr_init Up: Function Substitutes Top: Top


pthread_attr_setguardsize -- GNU Gnulib

Next: pthread_attr_setinheritsched Prev: pthread_attr_setdetachstate Up: Function Substitutes Top: Top

9.732. pthread_attr_setguardsize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setguardsize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_attr_setinheritsched Prev: pthread_attr_setdetachstate Up: Function Substitutes Top: Top


pthread_attr_setinheritsched -- GNU Gnulib

Next: pthread_attr_setschedparam Prev: pthread_attr_setguardsize Up: Function Substitutes Top: Top

9.733. pthread_attr_setinheritsched

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setinheritsched.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setschedparam Prev: pthread_attr_setguardsize Up: Function Substitutes Top: Top


pthread_attr_setschedparam -- GNU Gnulib

Next: pthread_attr_setschedpolicy Prev: pthread_attr_setinheritsched Up: Function Substitutes Top: Top

9.734. pthread_attr_setschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setschedparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setschedpolicy Prev: pthread_attr_setinheritsched Up: Function Substitutes Top: Top


pthread_attr_setschedpolicy -- GNU Gnulib

Next: pthread_attr_setscope Prev: pthread_attr_setschedparam Up: Function Substitutes Top: Top

9.735. pthread_attr_setschedpolicy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setschedpolicy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setscope Prev: pthread_attr_setschedparam Up: Function Substitutes Top: Top


pthread_attr_setscope -- GNU Gnulib

Next: pthread_attr_setstack Prev: pthread_attr_setschedpolicy Up: Function Substitutes Top: Top

9.736. pthread_attr_setscope

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setscope.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_attr_setstack Prev: pthread_attr_setschedpolicy Up: Function Substitutes Top: Top


pthread_attr_setstack -- GNU Gnulib

Next: pthread_attr_setstacksize Prev: pthread_attr_setscope Up: Function Substitutes Top: Top

9.737. pthread_attr_setstack

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setstack.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_attr_setstacksize Prev: pthread_attr_setscope Up: Function Substitutes Top: Top


pthread_attr_setstacksize -- GNU Gnulib

Next: pthread_barrier_destroy Prev: pthread_attr_setstack Up: Function Substitutes Top: Top

9.738. pthread_attr_setstacksize

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_attr_setstacksize.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_barrier_destroy Prev: pthread_attr_setstack Up: Function Substitutes Top: Top


pthread_barrier_destroy -- GNU Gnulib

Next: pthread_barrier_init Prev: pthread_attr_setstacksize Up: Function Substitutes Top: Top

9.739. pthread_barrier_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrier_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrier_init Prev: pthread_attr_setstacksize Up: Function Substitutes Top: Top


pthread_barrier_init -- GNU Gnulib

Next: pthread_barrier_wait Prev: pthread_barrier_destroy Up: Function Substitutes Top: Top

9.740. pthread_barrier_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrier_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrier_wait Prev: pthread_barrier_destroy Up: Function Substitutes Top: Top


pthread_barrier_wait -- GNU Gnulib

Next: pthread_barrierattr_destroy Prev: pthread_barrier_init Up: Function Substitutes Top: Top

9.741. pthread_barrier_wait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrier_wait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrierattr_destroy Prev: pthread_barrier_init Up: Function Substitutes Top: Top


pthread_barrierattr_destroy -- GNU Gnulib

Next: pthread_barrierattr_getpshared Prev: pthread_barrier_wait Up: Function Substitutes Top: Top

9.742. pthread_barrierattr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrierattr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrierattr_getpshared Prev: pthread_barrier_wait Up: Function Substitutes Top: Top


pthread_barrierattr_getpshared -- GNU Gnulib

Next: pthread_barrierattr_init Prev: pthread_barrierattr_destroy Up: Function Substitutes Top: Top

9.743. pthread_barrierattr_getpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrierattr_getpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrierattr_init Prev: pthread_barrierattr_destroy Up: Function Substitutes Top: Top


pthread_barrierattr_init -- GNU Gnulib

Next: pthread_barrierattr_setpshared Prev: pthread_barrierattr_getpshared Up: Function Substitutes Top: Top

9.744. pthread_barrierattr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrierattr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_barrierattr_setpshared Prev: pthread_barrierattr_getpshared Up: Function Substitutes Top: Top


pthread_barrierattr_setpshared -- GNU Gnulib

Next: pthread_cancel Prev: pthread_barrierattr_init Up: Function Substitutes Top: Top

9.745. pthread_barrierattr_setpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_barrierattr_setpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_cancel Prev: pthread_barrierattr_init Up: Function Substitutes Top: Top


pthread_cancel -- GNU Gnulib

Next: pthread_cleanup_pop Prev: pthread_barrierattr_setpshared Up: Function Substitutes Top: Top

9.746. pthread_cancel

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cancel.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cleanup_pop Prev: pthread_barrierattr_setpshared Up: Function Substitutes Top: Top


pthread_cleanup_pop -- GNU Gnulib

Next: pthread_cleanup_push Prev: pthread_cancel Up: Function Substitutes Top: Top

9.747. pthread_cleanup_pop

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cleanup_pop.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_cleanup_push Prev: pthread_cancel Up: Function Substitutes Top: Top


pthread_cleanup_push -- GNU Gnulib

Next: pthread_cond_broadcast Prev: pthread_cleanup_pop Up: Function Substitutes Top: Top

9.748. pthread_cleanup_push

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cleanup_push.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_cond_broadcast Prev: pthread_cleanup_pop Up: Function Substitutes Top: Top


pthread_cond_broadcast -- GNU Gnulib

Next: pthread_cond_destroy Prev: pthread_cleanup_push Up: Function Substitutes Top: Top

9.749. pthread_cond_broadcast

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_broadcast.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cond_destroy Prev: pthread_cleanup_push Up: Function Substitutes Top: Top


pthread_cond_destroy -- GNU Gnulib

Next: pthread_cond_init Prev: pthread_cond_broadcast Up: Function Substitutes Top: Top

9.750. pthread_cond_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cond_init Prev: pthread_cond_broadcast Up: Function Substitutes Top: Top


pthread_cond_init -- GNU Gnulib

Next: pthread_cond_signal Prev: pthread_cond_destroy Up: Function Substitutes Top: Top

9.751. pthread_cond_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cond_signal Prev: pthread_cond_destroy Up: Function Substitutes Top: Top


pthread_cond_signal -- GNU Gnulib

Next: pthread_cond_timedwait Prev: pthread_cond_init Up: Function Substitutes Top: Top

9.752. pthread_cond_signal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_signal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cond_timedwait Prev: pthread_cond_init Up: Function Substitutes Top: Top


pthread_cond_timedwait -- GNU Gnulib

Next: pthread_cond_wait Prev: pthread_cond_signal Up: Function Substitutes Top: Top

9.753. pthread_cond_timedwait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_timedwait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_cond_wait Prev: pthread_cond_signal Up: Function Substitutes Top: Top


pthread_cond_wait -- GNU Gnulib

Next: pthread_condattr_destroy Prev: pthread_cond_timedwait Up: Function Substitutes Top: Top

9.754. pthread_cond_wait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_cond_wait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_condattr_destroy Prev: pthread_cond_timedwait Up: Function Substitutes Top: Top


pthread_condattr_destroy -- GNU Gnulib

Next: pthread_condattr_getclock Prev: pthread_cond_wait Up: Function Substitutes Top: Top

9.755. pthread_condattr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_condattr_getclock Prev: pthread_cond_wait Up: Function Substitutes Top: Top


pthread_condattr_getclock -- GNU Gnulib

Next: pthread_condattr_getpshared Prev: pthread_condattr_destroy Up: Function Substitutes Top: Top

9.756. pthread_condattr_getclock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_getclock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_condattr_getpshared Prev: pthread_condattr_destroy Up: Function Substitutes Top: Top


pthread_condattr_getpshared -- GNU Gnulib

Next: pthread_condattr_init Prev: pthread_condattr_getclock Up: Function Substitutes Top: Top

9.757. pthread_condattr_getpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_getpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_condattr_init Prev: pthread_condattr_getclock Up: Function Substitutes Top: Top


pthread_condattr_init -- GNU Gnulib

Next: pthread_condattr_setclock Prev: pthread_condattr_getpshared Up: Function Substitutes Top: Top

9.758. pthread_condattr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_condattr_setclock Prev: pthread_condattr_getpshared Up: Function Substitutes Top: Top


pthread_condattr_setclock -- GNU Gnulib

Next: pthread_condattr_setpshared Prev: pthread_condattr_init Up: Function Substitutes Top: Top

9.759. pthread_condattr_setclock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_setclock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_condattr_setpshared Prev: pthread_condattr_init Up: Function Substitutes Top: Top


pthread_condattr_setpshared -- GNU Gnulib

Next: pthread_create Prev: pthread_condattr_setclock Up: Function Substitutes Top: Top

9.760. pthread_condattr_setpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_condattr_setpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_create Prev: pthread_condattr_setclock Up: Function Substitutes Top: Top


pthread_create -- GNU Gnulib

Next: pthread_detach Prev: pthread_condattr_setpshared Up: Function Substitutes Top: Top

9.761. pthread_create

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_create.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.
  • On Linux/glibc platforms before the advent of NPTL, signals could only be sent to one particular thread. In POSIX, signals are sent to the entire process and executed by any thread of the process that happens to have the particular signal currently unblocked.

Next: pthread_detach Prev: pthread_condattr_setpshared Up: Function Substitutes Top: Top


pthread_detach -- GNU Gnulib

Next: pthread_equal Prev: pthread_create Up: Function Substitutes Top: Top

9.762. pthread_detach

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_detach.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_equal Prev: pthread_create Up: Function Substitutes Top: Top


pthread_equal -- GNU Gnulib

Next: pthread_exit Prev: pthread_detach Up: Function Substitutes Top: Top

9.763. pthread_equal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_equal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_exit Prev: pthread_detach Up: Function Substitutes Top: Top


pthread_exit -- GNU Gnulib

Next: pthread_getconcurrency Prev: pthread_equal Up: Function Substitutes Top: Top

9.764. pthread_exit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_exit.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_getconcurrency Prev: pthread_equal Up: Function Substitutes Top: Top


pthread_getconcurrency -- GNU Gnulib

Next: pthread_getcpuclockid Prev: pthread_exit Up: Function Substitutes Top: Top

9.765. pthread_getconcurrency

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_getconcurrency.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, HP-UX 11, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_getcpuclockid Prev: pthread_exit Up: Function Substitutes Top: Top


pthread_getcpuclockid -- GNU Gnulib

Next: pthread_getschedparam Prev: pthread_getconcurrency Up: Function Substitutes Top: Top

9.766. pthread_getcpuclockid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_getcpuclockid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_getschedparam Prev: pthread_getconcurrency Up: Function Substitutes Top: Top


pthread_getschedparam -- GNU Gnulib

Next: pthread_getspecific Prev: pthread_getcpuclockid Up: Function Substitutes Top: Top

9.767. pthread_getschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_getschedparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_getspecific Prev: pthread_getcpuclockid Up: Function Substitutes Top: Top


pthread_getspecific -- GNU Gnulib

Next: pthread_join Prev: pthread_getschedparam Up: Function Substitutes Top: Top

9.768. pthread_getspecific

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_getspecific.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_join Prev: pthread_getschedparam Up: Function Substitutes Top: Top


pthread_join -- GNU Gnulib

Next: pthread_key_create Prev: pthread_getspecific Up: Function Substitutes Top: Top

9.769. pthread_join

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_join.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_key_create Prev: pthread_getspecific Up: Function Substitutes Top: Top


pthread_key_create -- GNU Gnulib

Next: pthread_key_delete Prev: pthread_join Up: Function Substitutes Top: Top

9.770. pthread_key_create

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_key_create.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_key_delete Prev: pthread_join Up: Function Substitutes Top: Top


pthread_key_delete -- GNU Gnulib

Next: pthread_kill Prev: pthread_key_create Up: Function Substitutes Top: Top

9.771. pthread_key_delete

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_key_delete.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_kill Prev: pthread_key_create Up: Function Substitutes Top: Top


pthread_kill -- GNU Gnulib

Next: pthread_mutex_consistent Prev: pthread_key_delete Up: Function Substitutes Top: Top

9.772. pthread_kill

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_kill.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutex_consistent Prev: pthread_key_delete Up: Function Substitutes Top: Top


pthread_mutex_consistent -- GNU Gnulib

Next: pthread_mutex_destroy Prev: pthread_kill Up: Function Substitutes Top: Top

9.773. pthread_mutex_consistent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_consistent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutex_destroy Prev: pthread_kill Up: Function Substitutes Top: Top


pthread_mutex_destroy -- GNU Gnulib

Next: pthread_mutex_getprioceiling Prev: pthread_mutex_consistent Up: Function Substitutes Top: Top

9.774. pthread_mutex_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutex_getprioceiling Prev: pthread_mutex_consistent Up: Function Substitutes Top: Top


pthread_mutex_getprioceiling -- GNU Gnulib

Next: pthread_mutex_init Prev: pthread_mutex_destroy Up: Function Substitutes Top: Top

9.775. pthread_mutex_getprioceiling

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_getprioceiling.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutex_init Prev: pthread_mutex_destroy Up: Function Substitutes Top: Top


pthread_mutex_init -- GNU Gnulib

Next: pthread_mutex_lock Prev: pthread_mutex_getprioceiling Up: Function Substitutes Top: Top

9.776. pthread_mutex_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutex_lock Prev: pthread_mutex_getprioceiling Up: Function Substitutes Top: Top


pthread_mutex_lock -- GNU Gnulib

Next: pthread_mutex_setprioceiling Prev: pthread_mutex_init Up: Function Substitutes Top: Top

9.777. pthread_mutex_lock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_lock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutex_setprioceiling Prev: pthread_mutex_init Up: Function Substitutes Top: Top


pthread_mutex_setprioceiling -- GNU Gnulib

Next: pthread_mutex_timedlock Prev: pthread_mutex_lock Up: Function Substitutes Top: Top

9.778. pthread_mutex_setprioceiling

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_setprioceiling.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutex_timedlock Prev: pthread_mutex_lock Up: Function Substitutes Top: Top


pthread_mutex_timedlock -- GNU Gnulib

Next: pthread_mutex_trylock Prev: pthread_mutex_setprioceiling Up: Function Substitutes Top: Top

9.779. pthread_mutex_timedlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_timedlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, BeOS.

Next: pthread_mutex_trylock Prev: pthread_mutex_setprioceiling Up: Function Substitutes Top: Top


pthread_mutex_trylock -- GNU Gnulib

Next: pthread_mutex_unlock Prev: pthread_mutex_timedlock Up: Function Substitutes Top: Top

9.780. pthread_mutex_trylock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_trylock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutex_unlock Prev: pthread_mutex_timedlock Up: Function Substitutes Top: Top


pthread_mutex_unlock -- GNU Gnulib

Next: pthread_mutexattr_destroy Prev: pthread_mutex_trylock Up: Function Substitutes Top: Top

9.781. pthread_mutex_unlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutex_unlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_destroy Prev: pthread_mutex_trylock Up: Function Substitutes Top: Top


pthread_mutexattr_destroy -- GNU Gnulib

Next: pthread_mutexattr_getprioceiling Prev: pthread_mutex_unlock Up: Function Substitutes Top: Top

9.782. pthread_mutexattr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_getprioceiling Prev: pthread_mutex_unlock Up: Function Substitutes Top: Top


pthread_mutexattr_getprioceiling -- GNU Gnulib

Next: pthread_mutexattr_getprotocol Prev: pthread_mutexattr_destroy Up: Function Substitutes Top: Top

9.783. pthread_mutexattr_getprioceiling

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_getprioceiling.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_getprotocol Prev: pthread_mutexattr_destroy Up: Function Substitutes Top: Top


pthread_mutexattr_getprotocol -- GNU Gnulib

Next: pthread_mutexattr_getpshared Prev: pthread_mutexattr_getprioceiling Up: Function Substitutes Top: Top

9.784. pthread_mutexattr_getprotocol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_getprotocol.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_getpshared Prev: pthread_mutexattr_getprioceiling Up: Function Substitutes Top: Top


pthread_mutexattr_getpshared -- GNU Gnulib

Next: pthread_mutexattr_getrobust Prev: pthread_mutexattr_getprotocol Up: Function Substitutes Top: Top

9.785. pthread_mutexattr_getpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_getpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_getrobust Prev: pthread_mutexattr_getprotocol Up: Function Substitutes Top: Top


pthread_mutexattr_getrobust -- GNU Gnulib

Next: pthread_mutexattr_gettype Prev: pthread_mutexattr_getpshared Up: Function Substitutes Top: Top

9.786. pthread_mutexattr_getrobust

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_getrobust.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_gettype Prev: pthread_mutexattr_getpshared Up: Function Substitutes Top: Top


pthread_mutexattr_gettype -- GNU Gnulib

Next: pthread_mutexattr_init Prev: pthread_mutexattr_getrobust Up: Function Substitutes Top: Top

9.787. pthread_mutexattr_gettype

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_gettype.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_init Prev: pthread_mutexattr_getrobust Up: Function Substitutes Top: Top


pthread_mutexattr_init -- GNU Gnulib

Next: pthread_mutexattr_setprioceiling Prev: pthread_mutexattr_gettype Up: Function Substitutes Top: Top

9.788. pthread_mutexattr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_setprioceiling Prev: pthread_mutexattr_gettype Up: Function Substitutes Top: Top


pthread_mutexattr_setprioceiling -- GNU Gnulib

Next: pthread_mutexattr_setprotocol Prev: pthread_mutexattr_init Up: Function Substitutes Top: Top

9.789. pthread_mutexattr_setprioceiling

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_setprioceiling.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_setprotocol Prev: pthread_mutexattr_init Up: Function Substitutes Top: Top


pthread_mutexattr_setprotocol -- GNU Gnulib

Next: pthread_mutexattr_setpshared Prev: pthread_mutexattr_setprioceiling Up: Function Substitutes Top: Top

9.790. pthread_mutexattr_setprotocol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_setprotocol.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_setpshared Prev: pthread_mutexattr_setprioceiling Up: Function Substitutes Top: Top


pthread_mutexattr_setpshared -- GNU Gnulib

Next: pthread_mutexattr_setrobust Prev: pthread_mutexattr_setprotocol Up: Function Substitutes Top: Top

9.791. pthread_mutexattr_setpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_setpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_mutexattr_setrobust Prev: pthread_mutexattr_setprotocol Up: Function Substitutes Top: Top


pthread_mutexattr_setrobust -- GNU Gnulib

Next: pthread_mutexattr_settype Prev: pthread_mutexattr_setpshared Up: Function Substitutes Top: Top

9.792. pthread_mutexattr_setrobust

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_setrobust.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_settype Prev: pthread_mutexattr_setpshared Up: Function Substitutes Top: Top


pthread_mutexattr_settype -- GNU Gnulib

Next: pthread_once Prev: pthread_mutexattr_setrobust Up: Function Substitutes Top: Top

9.793. pthread_mutexattr_settype

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_mutexattr_settype.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_once Prev: pthread_mutexattr_setrobust Up: Function Substitutes Top: Top


pthread_once -- GNU Gnulib

Next: pthread_rwlock_destroy Prev: pthread_mutexattr_settype Up: Function Substitutes Top: Top

9.794. pthread_once

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_once.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_destroy Prev: pthread_mutexattr_settype Up: Function Substitutes Top: Top


pthread_rwlock_destroy -- GNU Gnulib

Next: pthread_rwlock_init Prev: pthread_once Up: Function Substitutes Top: Top

9.795. pthread_rwlock_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_init Prev: pthread_once Up: Function Substitutes Top: Top


pthread_rwlock_init -- GNU Gnulib

Next: pthread_rwlock_rdlock Prev: pthread_rwlock_destroy Up: Function Substitutes Top: Top

9.796. pthread_rwlock_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_rdlock Prev: pthread_rwlock_destroy Up: Function Substitutes Top: Top


pthread_rwlock_rdlock -- GNU Gnulib

Next: pthread_rwlock_timedrdlock Prev: pthread_rwlock_init Up: Function Substitutes Top: Top

9.797. pthread_rwlock_rdlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_rdlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_timedrdlock Prev: pthread_rwlock_init Up: Function Substitutes Top: Top


pthread_rwlock_timedrdlock -- GNU Gnulib

Next: pthread_rwlock_timedwrlock Prev: pthread_rwlock_rdlock Up: Function Substitutes Top: Top

9.798. pthread_rwlock_timedrdlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_timedrdlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_timedwrlock Prev: pthread_rwlock_rdlock Up: Function Substitutes Top: Top


pthread_rwlock_timedwrlock -- GNU Gnulib

Next: pthread_rwlock_tryrdlock Prev: pthread_rwlock_timedrdlock Up: Function Substitutes Top: Top

9.799. pthread_rwlock_timedwrlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_timedwrlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_tryrdlock Prev: pthread_rwlock_timedrdlock Up: Function Substitutes Top: Top


pthread_rwlock_tryrdlock -- GNU Gnulib

Next: pthread_rwlock_trywrlock Prev: pthread_rwlock_timedwrlock Up: Function Substitutes Top: Top

9.800. pthread_rwlock_tryrdlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_tryrdlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_trywrlock Prev: pthread_rwlock_timedwrlock Up: Function Substitutes Top: Top


pthread_rwlock_trywrlock -- GNU Gnulib

Next: pthread_rwlock_unlock Prev: pthread_rwlock_tryrdlock Up: Function Substitutes Top: Top

9.801. pthread_rwlock_trywrlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_trywrlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_unlock Prev: pthread_rwlock_tryrdlock Up: Function Substitutes Top: Top


pthread_rwlock_unlock -- GNU Gnulib

Next: pthread_rwlock_wrlock Prev: pthread_rwlock_trywrlock Up: Function Substitutes Top: Top

9.802. pthread_rwlock_unlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_unlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlock_wrlock Prev: pthread_rwlock_trywrlock Up: Function Substitutes Top: Top


pthread_rwlock_wrlock -- GNU Gnulib

Next: pthread_rwlockattr_destroy Prev: pthread_rwlock_unlock Up: Function Substitutes Top: Top

9.803. pthread_rwlock_wrlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlock_wrlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlockattr_destroy Prev: pthread_rwlock_unlock Up: Function Substitutes Top: Top


pthread_rwlockattr_destroy -- GNU Gnulib

Next: pthread_rwlockattr_getpshared Prev: pthread_rwlock_wrlock Up: Function Substitutes Top: Top

9.804. pthread_rwlockattr_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlockattr_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlockattr_getpshared Prev: pthread_rwlock_wrlock Up: Function Substitutes Top: Top


pthread_rwlockattr_getpshared -- GNU Gnulib

Next: pthread_rwlockattr_init Prev: pthread_rwlockattr_destroy Up: Function Substitutes Top: Top

9.805. pthread_rwlockattr_getpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlockattr_getpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlockattr_init Prev: pthread_rwlockattr_destroy Up: Function Substitutes Top: Top


pthread_rwlockattr_init -- GNU Gnulib

Next: pthread_rwlockattr_setpshared Prev: pthread_rwlockattr_getpshared Up: Function Substitutes Top: Top

9.806. pthread_rwlockattr_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlockattr_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_rwlockattr_setpshared Prev: pthread_rwlockattr_getpshared Up: Function Substitutes Top: Top


pthread_rwlockattr_setpshared -- GNU Gnulib

Next: pthread_self Prev: pthread_rwlockattr_init Up: Function Substitutes Top: Top

9.807. pthread_rwlockattr_setpshared

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_rwlockattr_setpshared.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, HP-UX 11, OSF/1 4.0, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_self Prev: pthread_rwlockattr_init Up: Function Substitutes Top: Top


pthread_self -- GNU Gnulib

Next: pthread_setcancelstate Prev: pthread_rwlockattr_setpshared Up: Function Substitutes Top: Top

9.808. pthread_self

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_self.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_setcancelstate Prev: pthread_rwlockattr_setpshared Up: Function Substitutes Top: Top


pthread_setcancelstate -- GNU Gnulib

Next: pthread_setcanceltype Prev: pthread_self Up: Function Substitutes Top: Top

9.809. pthread_setcancelstate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setcancelstate.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_setcanceltype Prev: pthread_self Up: Function Substitutes Top: Top


pthread_setcanceltype -- GNU Gnulib

Next: pthread_setconcurrency Prev: pthread_setcancelstate Up: Function Substitutes Top: Top

9.810. pthread_setcanceltype

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setcanceltype.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_setconcurrency Prev: pthread_setcancelstate Up: Function Substitutes Top: Top


pthread_setconcurrency -- GNU Gnulib

Next: pthread_setschedparam Prev: pthread_setcanceltype Up: Function Substitutes Top: Top

9.811. pthread_setconcurrency

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setconcurrency.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, HP-UX 11, Solaris 2.6, mingw, MSVC 14, BeOS.

Next: pthread_setschedparam Prev: pthread_setcanceltype Up: Function Substitutes Top: Top


pthread_setschedparam -- GNU Gnulib

Next: pthread_setschedprio Prev: pthread_setconcurrency Up: Function Substitutes Top: Top

9.812. pthread_setschedparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setschedparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_setschedprio Prev: pthread_setconcurrency Up: Function Substitutes Top: Top


pthread_setschedprio -- GNU Gnulib

Next: pthread_setspecific Prev: pthread_setschedparam Up: Function Substitutes Top: Top

9.813. pthread_setschedprio

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setschedprio.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_setspecific Prev: pthread_setschedparam Up: Function Substitutes Top: Top


pthread_setspecific -- GNU Gnulib

Next: pthread_sigmask Prev: pthread_setschedprio Up: Function Substitutes Top: Top

9.814. pthread_setspecific

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_setspecific.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: pthread_sigmask Prev: pthread_setschedprio Up: Function Substitutes Top: Top


pthread_sigmask -- GNU Gnulib

Next: pthread_spin_destroy Prev: pthread_setspecific Up: Function Substitutes Top: Top

9.815. pthread_sigmask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_sigmask.html

Gnulib module: pthread_sigmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.
  • This function is declared in <pthread.h> instead of <signal.h> on some platforms: Mac OS X 10.3, FreeBSD 6.4, OpenBSD 3.8, OSF/1 4.0, Solaris 2.6.
  • This function does nothing and always returns 0 in programs that are not linked with -lpthread on some platforms: FreeBSD 6.4, HP-UX 11.31, Solaris 9.
  • When it fails, this functions returns -1 instead of the error number on some platforms: Cygwin 1.7.5.
  • This function does not immediately raise signals that were pending before the call and unblocked by the call on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:
  • On platforms that do not natively support this function, it has unspecified behavior in a multi-threaded process.

Next: pthread_spin_destroy Prev: pthread_setspecific Up: Function Substitutes Top: Top


pthread_spin_destroy -- GNU Gnulib

Next: pthread_spin_init Prev: pthread_sigmask Up: Function Substitutes Top: Top

9.816. pthread_spin_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_spin_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_spin_init Prev: pthread_sigmask Up: Function Substitutes Top: Top


pthread_spin_init -- GNU Gnulib

Next: pthread_spin_lock Prev: pthread_spin_destroy Up: Function Substitutes Top: Top

9.817. pthread_spin_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_spin_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_spin_lock Prev: pthread_spin_destroy Up: Function Substitutes Top: Top


pthread_spin_lock -- GNU Gnulib

Next: pthread_spin_trylock Prev: pthread_spin_init Up: Function Substitutes Top: Top

9.818. pthread_spin_lock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_spin_lock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_spin_trylock Prev: pthread_spin_init Up: Function Substitutes Top: Top


pthread_spin_trylock -- GNU Gnulib

Next: pthread_spin_unlock Prev: pthread_spin_lock Up: Function Substitutes Top: Top

9.819. pthread_spin_trylock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_spin_trylock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_spin_unlock Prev: pthread_spin_lock Up: Function Substitutes Top: Top


pthread_spin_unlock -- GNU Gnulib

Next: pthread_testcancel Prev: pthread_spin_trylock Up: Function Substitutes Top: Top

9.820. pthread_spin_unlock

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_spin_unlock.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_testcancel Prev: pthread_spin_trylock Up: Function Substitutes Top: Top


pthread_testcancel -- GNU Gnulib

Next: ptsname Prev: pthread_spin_unlock Up: Function Substitutes Top: Top

9.821. pthread_testcancel

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pthread_testcancel.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: ptsname Prev: pthread_spin_unlock Up: Function Substitutes Top: Top


ptsname -- GNU Gnulib

Next: putc Prev: pthread_testcancel Up: Function Substitutes Top: Top

9.822. ptsname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ptsname.html

Gnulib module: ptsname

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function fails to set errno on failure on some platforms: FreeBSD 8.2.
Portability problems not fixed by Gnulib:
  • This function is not declared on some platforms: IRIX 5.3.
  • On Solaris 11 2010-11, this function fails on all BSD-style /dev/pty* device files.
  • This function is not thread-safe on some platforms: Cygwin 1.7.9. Likewise, the gnulib replacement is not thread-safe.
Note that the Gnulib module ptsname_r is a version of this function that is more likely to be thread-safe.

Next: putc Prev: pthread_testcancel Up: Function Substitutes Top: Top


putc -- GNU Gnulib

Next: putc_unlocked Prev: ptsname Up: Function Substitutes Top: Top

9.823. putc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putc.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: putc_unlocked Prev: ptsname Up: Function Substitutes Top: Top


putc_unlocked -- GNU Gnulib

Next: putchar Prev: putc Up: Function Substitutes Top: Top

9.824. putc_unlocked

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putc_unlocked.html

Gnulib module: ---

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: putchar Prev: putc Up: Function Substitutes Top: Top


putchar -- GNU Gnulib

Next: putchar_unlocked Prev: putc_unlocked Up: Function Substitutes Top: Top

9.825. putchar

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putchar.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: putchar_unlocked Prev: putc_unlocked Up: Function Substitutes Top: Top


putchar_unlocked -- GNU Gnulib

Next: putenv Prev: putchar Up: Function Substitutes Top: Top

9.826. putchar_unlocked

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putchar_unlocked.html

Gnulib module: ---

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: putenv Prev: putchar Up: Function Substitutes Top: Top


putenv -- GNU Gnulib

Next: putmsg Prev: putchar_unlocked Up: Function Substitutes Top: Top

9.827. putenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putenv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
Extension: Gnulib provides a module `putenv' that substitutes a putenv implementation that can also be used to remove environment variables.

Next: putmsg Prev: putchar_unlocked Up: Function Substitutes Top: Top


putmsg -- GNU Gnulib

Next: putpmsg Prev: putenv Up: Function Substitutes Top: Top

9.828. putmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: putpmsg Prev: putenv Up: Function Substitutes Top: Top


putpmsg -- GNU Gnulib

Next: puts Prev: putmsg Up: Function Substitutes Top: Top

9.829. putpmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putpmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: puts Prev: putmsg Up: Function Substitutes Top: Top


puts -- GNU Gnulib

Next: pututxline Prev: putpmsg Up: Function Substitutes Top: Top

9.830. puts

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/puts.html

Gnulib module: stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: pututxline Prev: putpmsg Up: Function Substitutes Top: Top


pututxline -- GNU Gnulib

Next: putwc Prev: puts Up: Function Substitutes Top: Top

9.831. pututxline

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pututxline.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: putwc Prev: puts Up: Function Substitutes Top: Top


putwc -- GNU Gnulib

Next: putwchar Prev: pututxline Up: Function Substitutes Top: Top

9.832. putwc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putwc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: putwchar Prev: pututxline Up: Function Substitutes Top: Top


putwchar -- GNU Gnulib

Next: pwrite Prev: putwc Up: Function Substitutes Top: Top

9.833. putwchar

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/putwchar.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: pwrite Prev: putwc Up: Function Substitutes Top: Top


pwrite -- GNU Gnulib

Next: qsort Prev: putwchar Up: Function Substitutes Top: Top

9.834. pwrite

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/pwrite.html

Gnulib module: pwrite

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 10, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • This function does not fail when an invalid (negative) offset is passed when large file support is enabled on some platforms: HP-UX 11.11.
  • This function uses an arbitrary offset instead of the off_t argument when large file support is enabled on some platforms: HP-UX 11.11.
Portability problems not fixed by Gnulib:

Next: qsort Prev: putwchar Up: Function Substitutes Top: Top


qsort -- GNU Gnulib

Next: quick_exit Prev: pwrite Up: Function Substitutes Top: Top

9.835. qsort

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/qsort.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: quick_exit Prev: pwrite Up: Function Substitutes Top: Top


quick_exit -- GNU Gnulib

Next: raise Prev: qsort Up: Function Substitutes Top: Top

9.836. quick_exit

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Next: raise Prev: qsort Up: Function Substitutes Top: Top


raise -- GNU Gnulib

Next: rand Prev: quick_exit Up: Function Substitutes Top: Top

9.837. raise

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/raise.html

Gnulib module: raise

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: rand Prev: quick_exit Up: Function Substitutes Top: Top


rand -- GNU Gnulib

Next: rand_r Prev: raise Up: Function Substitutes Top: Top

9.838. rand

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rand.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: rand_r Prev: raise Up: Function Substitutes Top: Top


rand_r -- GNU Gnulib

Next: random Prev: rand Up: Function Substitutes Top: Top

9.839. rand_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rand_r.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: random Prev: rand Up: Function Substitutes Top: Top


random -- GNU Gnulib

Next: read Prev: rand_r Up: Function Substitutes Top: Top

9.840. random

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/random.html

Gnulib module: random

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function has a slightly incompatible declaration (the return type being `int' instead of `long') on some platforms: Cygwin 1.5.25.

Next: read Prev: rand_r Up: Function Substitutes Top: Top


read -- GNU Gnulib

Next: readdir Prev: random Up: Function Substitutes Top: Top

9.841. read

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/read.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function may fail with error EINTR, even in programs that don't install any signal handlers, on some platforms: Mac OS X 10.5.
For handling EINTR, Gnulib provides a module `safe-read' with a function safe_read.

Next: readdir Prev: random Up: Function Substitutes Top: Top


readdir -- GNU Gnulib

Next: readdir_r Prev: read Up: Function Substitutes Top: Top

9.842. readdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/readdir.html

Gnulib module: readdir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
  • Although POSIX places no restrictions on d_ino values, some older systems are rumored to return d_ino values equal to zero for directory entries that do not really exist. Although Gnulib formerly attempted to cater to these older systems, this caused misbehavior on standard systems and so Gnulib does not attempt to cater to them any more. If you know of any problems caused by this, please send a bug report.

Next: readdir_r Prev: read Up: Function Substitutes Top: Top


readdir_r -- GNU Gnulib

Next: readlink Prev: readdir Up: Function Substitutes Top: Top

9.843. readdir_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/readdir_r.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function is planned to be removed from POSIX and to be deprecated in glibc. Portable applications should use readdir.
  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. The fix is to use the AC_SYS_LARGEFILE macro.

Next: readlink Prev: readdir Up: Function Substitutes Top: Top


readlink -- GNU Gnulib

Next: readlinkat Prev: readdir_r Up: Function Substitutes Top: Top

9.844. readlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/readlink.html

Gnulib module: readlink

Portability problems fixed by Gnulib:

  • Some platforms mistakenly succeed on readlink("link/",buf,len): FreeBSD 7.2, Solaris 9, Mac OS X 10.10.
  • On some platforms, readlink returns int instead of ssize_t: glibc 2.4, FreeBSD 6.0, OpenBSD 3.8, Cygwin 1.5.x, AIX 7.1.
  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • When readlink is called on a directory: In the case of NFS mounted directories, Cygwin sets errno to ENOENT or EIO instead of EINVAL. To avoid this problem, check for a directory before calling readlink.
  • When readlink is called on a file that is not a symbolic link: Irix may set errno to ENXIO instead of EINVAL. Cygwin may set errno to EACCES instead of EINVAL.
  • Symlink contents do not always have a trailing null byte, and there is no indication if symlink contents were truncated if the return value matches the length. Furthermore, AIX 5.1 and HP-UX 11 set errno to ERANGE rather than returning truncated contents, and Linux sets errno to EINVAL if the requested length is zero. Use the gnulib module areadlink for improved ability to read symlink contents.

Next: readlinkat Prev: readdir_r Up: Function Substitutes Top: Top


readlinkat -- GNU Gnulib

Next: readv Prev: readlink Up: Function Substitutes Top: Top

9.845. readlinkat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/readlinkat.html

Gnulib module: readlinkat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X < 10.10, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • Some platforms mistakenly succeed on readlink("link/",buf,len): Mac OS X 10.10.
  • On some platforms, readlinkat returns int instead of ssize_t: AIX 7.1.
Portability problems not fixed by Gnulib:
  • This function always fails on platforms that don't support symlinks: mingw, MSVC 14.
  • When readlink is called on a directory: In the case of NFS mounted directories, Cygwin sets errno to ENOENT or EIO instead of EINVAL. To avoid this problem, check for a directory before calling readlink.
  • When readlink is called on a file that is not a symbolic link: Irix may set errno to ENXIO instead of EINVAL. Cygwin may set errno to EACCES instead of EINVAL.
  • Symlink contents do not always have a trailing null byte, and there is no indication if symlink contents were truncated if the return value matches the length. Furthermore, AIX 5.1 and HP-UX 11 set errno to ERANGE rather than returning truncated contents, and Linux sets errno to EINVAL if the requested length is zero. Use the gnulib module areadlink for improved ability to read symlink contents.

Next: readv Prev: readlink Up: Function Substitutes Top: Top


readv -- GNU Gnulib

Next: realloc Prev: readlinkat Up: Function Substitutes Top: Top

9.846. readv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/readv.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: realloc Prev: readlinkat Up: Function Substitutes Top: Top


realloc -- GNU Gnulib

Next: realpath Prev: readv Up: Function Substitutes Top: Top

9.847. realloc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/realloc.html

Gnulib module: realloc-posix

Portability problems fixed by Gnulib:

  • Upon failure, the function does not set errno to ENOMEM on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • It is not portable to call realloc with a size of 0. With a NULL pointer argument, this is the same ambiguity as malloc (0) on whether a unique zero-size object is created. With a non-NULL pointer argument, C99 requires that if realloc (p, 0) returns NULL then p is still valid. Among implementations that obey C99, behavior varies on whether realloc (p, 0) always fails and leaves p valid, or usually succeeds and returns a unique zero-size object; either way, a program not suspecting these semantics will leak memory (either the still-valid p, or the non-NULL return value). Meanwhile, several implementations violate C99, by always calling free (p) but returning NULL: glibc, Cygwin
Extension: Gnulib provides a module `realloc-gnu' that substitutes a realloc implementation that behaves more like the glibc implementation.

Next: realpath Prev: readv Up: Function Substitutes Top: Top


realpath -- GNU Gnulib

Next: recv Prev: realloc Up: Function Substitutes Top: Top

9.848. realpath

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/realpath.html

Gnulib module: canonicalize-lgpl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • This function does not allow for a NULL `resolved' parameter on some platforms: Mac OS X 10.5, FreeBSD 6.4, OpenBSD 4.4, Solaris 10.
  • This function does not always return an absolute path on some platforms: Solaris 10.
  • This function fails to detect trailing slashes on non-directories on some platforms: glibc 2.3.5.
  • This function fails to recognize non-directories followed `..' on some platforms: cygwin.
  • This function misbehaves on consecutive slashes on some platforms: AIX 7.
Portability problems not fixed by Gnulib:
  • This function does not allow to determine the required size of output buffer; the use of a non-NULL `resolved' buffer is non-portable, since PATH_MAX, if it is defined, is nothing more than a guess.

Next: recv Prev: realloc Up: Function Substitutes Top: Top


recv -- GNU Gnulib

Next: recvfrom Prev: realpath Up: Function Substitutes Top: Top

9.849. recv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/recv.html

Gnulib module: recv

Portability problems fixed by Gnulib:

  • This function has the return type int instead of ssize_t on some platforms: OSF/1 5.1.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: recvfrom Prev: realpath Up: Function Substitutes Top: Top


recvfrom -- GNU Gnulib

Next: recvmsg Prev: recv Up: Function Substitutes Top: Top

9.850. recvfrom

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/recvfrom.html

Gnulib module: recvfrom

Portability problems fixed by Gnulib:

  • This function has the return type int instead of ssize_t on some platforms: OSF/1 5.1.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • Some platforms don't have a socklen_t type; in this case this function's sixth argument type is `int *'.

Next: recvmsg Prev: recv Up: Function Substitutes Top: Top


recvmsg -- GNU Gnulib

Next: regcomp Prev: recvfrom Up: Function Substitutes Top: Top

9.851. recvmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/recvmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, Interix 3.5, BeOS.

Next: regcomp Prev: recvfrom Up: Function Substitutes Top: Top


regcomp -- GNU Gnulib

Next: regerror Prev: recvmsg Up: Function Substitutes Top: Top

9.852. regcomp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/regcomp.html

Gnulib module: regex

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • Many regular expression implementations have bugs.
Portability problems not fixed by Gnulib:

Next: regerror Prev: recvmsg Up: Function Substitutes Top: Top


regerror -- GNU Gnulib

Next: regexec Prev: regcomp Up: Function Substitutes Top: Top

9.853. regerror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/regerror.html

Gnulib module: regex

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: regexec Prev: regcomp Up: Function Substitutes Top: Top


regexec -- GNU Gnulib

Next: regfree Prev: regerror Up: Function Substitutes Top: Top

9.854. regexec

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/regexec.html

Gnulib module: regex

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • Many regular expression implementations have bugs.
Portability problems not fixed by Gnulib:

Next: regfree Prev: regerror Up: Function Substitutes Top: Top


regfree -- GNU Gnulib

Next: remainder Prev: regexec Up: Function Substitutes Top: Top

9.855. regfree

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/regfree.html

Gnulib module: regex

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: remainder Prev: regexec Up: Function Substitutes Top: Top


remainder -- GNU Gnulib

Next: remainderf Prev: regfree Up: Function Substitutes Top: Top

9.856. remainder

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remainder.html

Gnulib module: remainder or remainder-ieee

Portability problems fixed by either Gnulib module remainder or remainder-ieee:

  • This function is missing on some platforms: MSVC 9.
  • This function is not declared on some platforms: IRIX 5.3.
Portability problems fixed by Gnulib module remainder-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: remainderf Prev: regfree Up: Function Substitutes Top: Top


remainderf -- GNU Gnulib

Next: remainderl Prev: remainder Up: Function Substitutes Top: Top

9.857. remainderf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remainderf.html

Gnulib module: remainderf or remainderf-ieee

Portability problems fixed by either Gnulib module remainderf or remainderf-ieee:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, MSVC 9.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function may go into an endless loop on some platforms: IRIX 6.5.
Portability problems fixed by Gnulib module remainderf-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: remainderl Prev: remainder Up: Function Substitutes Top: Top


remainderl -- GNU Gnulib

Next: remove Prev: remainderf Up: Function Substitutes Top: Top

9.858. remainderl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remainderl.html

Gnulib module: remainderl or remainderl-ieee

Portability problems fixed by either Gnulib module remainderl or remainderl-ieee:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: IRIX 6.5.
  • This function returns completely wrong values on some platforms: OpenBSD 5.1/SPARC.
Portability problems fixed by Gnulib module remainderl-ieee:
  • This function has problems when the second argument is zero on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: remove Prev: remainderf Up: Function Substitutes Top: Top


remove -- GNU Gnulib

Next: remque Prev: remainderl Up: Function Substitutes Top: Top

9.859. remove

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remove.html

Gnulib module: remove

Portability problems fixed by Gnulib:

  • This function fails to reject trailing slashes on non-directories on some platforms: FreeBSD 7.2, Solaris 9.
  • This function mistakenly removes a directory with remove("dir/./") on some platforms: Cygwin 1.5.x.
  • This function does not remove empty directories on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: remque Prev: remainderl Up: Function Substitutes Top: Top


remque -- GNU Gnulib

Next: remquo Prev: remove Up: Function Substitutes Top: Top

9.860. remque

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remque.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: remquo Prev: remove Up: Function Substitutes Top: Top


remquo -- GNU Gnulib

Next: remquof Prev: remque Up: Function Substitutes Top: Top

9.861. remquo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remquo.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: remquof Prev: remque Up: Function Substitutes Top: Top


remquof -- GNU Gnulib

Next: remquol Prev: remquo Up: Function Substitutes Top: Top

9.862. remquof

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remquof.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: remquol Prev: remquo Up: Function Substitutes Top: Top


remquol -- GNU Gnulib

Next: rename Prev: remquof Up: Function Substitutes Top: Top

9.863. remquol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/remquol.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: rename Prev: remquof Up: Function Substitutes Top: Top


rename -- GNU Gnulib

Next: renameat Prev: remquol Up: Function Substitutes Top: Top

9.864. rename

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rename.html

Gnulib module: rename

Portability problems fixed by Gnulib:

  • This function does not allow trailing slashes when creating a destination directory, as in rename("dir","new/"): NetBSD 1.6.
  • This function does not reject trailing slashes on the destination for non-directories on some platforms, as in rename("file","new/"): AIX 7.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not reject trailing slashes on symlinks to non-directories on some platforms, as in rename("link-to-file/","f"): FreeBSD 7.2.
  • This function ignores trailing slashes on symlinks on some platforms, such that rename("link/","new") corrupts link: Solaris 9.
  • This function incorrectly reduces the link count when comparing two spellings of a hard link on some platforms: NetBSD 1.6, Cygwin 1.5.x.
  • This function will not always replace an existing destination on some platforms: Cygwin 1.5.x, mingw, MSVC 14. However, the replacement is not atomic for directories, and may end up losing the empty destination if the source could not be renamed.
  • This function mistakenly allows names ending in `.' or `..' on some platforms: Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not reject attempts to rename existing directories and non-directories onto one another on some platforms: Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not allow trailing slashes on source directories on older platforms, as in `rename("dir/","new")': SunOS 4.1.
Portability problems not fixed by Gnulib:
  • POSIX requires that rename("symlink-to-dir/","dir2") rename dir and leave symlink-to-dir dangling; likewise, it requires that rename("dir","dangling/") rename dir so that dangling is no longer a dangling symlink. This behavior is counter-intuitive, so on some systems, rename fails with ENOTDIR if either argument is a symlink with a trailing slash: glibc, OpenBSD, Cygwin 1.7.
  • POSIX requires that rename do nothing and return 0 if the source and destination are hard links to the same file. This behavior is counterintuitive, and on some systems renameat is a no-op in this way only if the source and destination identify the same directory entry. On these systems, for example, although renaming ./f to f is a no-op, renaming f to g deletes f when f and g are hard links to the same file: NetBSD 7.0.
  • After renaming a non-empty directory over an existing empty directory, the old directory name is still visible through the stat function for 30 seconds after the rename, on NFS file systems, on some platforms: Linux 2.6.18.
  • This function will not rename a source that is currently opened by any process: mingw, MSVC 14.

Next: renameat Prev: remquol Up: Function Substitutes Top: Top


renameat -- GNU Gnulib

Next: rewind Prev: rename Up: Function Substitutes Top: Top

9.865. renameat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/renameat.html

Gnulib module: renameat

Portability problems fixed by Gnulib:

  • This function does not reject trailing slashes on non-directories on some platforms, as in renameat(fd,"file",fd,"new/"): Solaris 11.3.
  • This function ignores trailing slashes on symlinks on some platforms, such that renameat(fd,"link/",fd,"new") corrupts link: Solaris 9.
  • This function is declared in <unistd.h> instead of <stdio.h> on some platforms: NetBSD 7.0, Solaris 11.3.
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
Portability problems not fixed by Gnulib:
  • POSIX requires that renameat(fd,"symlink-to-dir/",fd,"dir2") rename dir and leave symlink-to-dir dangling; likewise, it requires that renameat(fd,"dir",fd,"dangling/") rename dir so that dangling is no longer a dangling symlink. This behavior is counter-intuitive, so on some systems, renameat fails with ENOTDIR if either argument is a symlink with a trailing slash: glibc, OpenBSD, Cygwin 1.7.
  • POSIX requires that renameat do nothing and return 0 if the source and destination are hard links to the same file. This behavior is counterintuitive, and on some systems renameat is a no-op in this way only if the source and destination identify the same directory entry. On these systems, for example, although renaming ./f to f is a no-op, renaming f to g deletes f when f and g are hard links to the same file: NetBSD 7.0.
  • After renaming a non-empty directory over an existing empty directory, the old directory name is still visible through the stat function for 30 seconds after the rename, on NFS file systems, on some platforms: Linux 2.6.18.
  • This function will not rename a source that is currently opened by any process: mingw, MSVC 14.

Next: rewind Prev: rename Up: Function Substitutes Top: Top


rewind -- GNU Gnulib

Next: rewinddir Prev: renameat Up: Function Substitutes Top: Top

9.866. rewind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rewind.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: rewinddir Prev: renameat Up: Function Substitutes Top: Top


rewinddir -- GNU Gnulib

Next: rint Prev: rewind Up: Function Substitutes Top: Top

9.867. rewinddir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rewinddir.html

Gnulib module: rewinddir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
  • On Mac OS X platforms where long int is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:

Next: rint Prev: rewind Up: Function Substitutes Top: Top


rint -- GNU Gnulib

Next: rintf Prev: rewinddir Up: Function Substitutes Top: Top

9.868. rint

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rint.html

Gnulib module: rint

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 9.
Portability problems not fixed by Gnulib:

Next: rintf Prev: rewinddir Up: Function Substitutes Top: Top


rintf -- GNU Gnulib

Next: rintl Prev: rint Up: Function Substitutes Top: Top

9.869. rintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rintf.html

Gnulib module: rintf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, Solaris 9, MSVC 9.
  • This function is not declared on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: rintl Prev: rint Up: Function Substitutes Top: Top


rintl -- GNU Gnulib

Next: rmdir Prev: rintf Up: Function Substitutes Top: Top

9.870. rintl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rintl.html

Gnulib module: rintl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: rmdir Prev: rintf Up: Function Substitutes Top: Top


rmdir -- GNU Gnulib

Next: round Prev: rintl Up: Function Substitutes Top: Top

9.871. rmdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/rmdir.html

Gnulib module: rmdir

Portability problems fixed by Gnulib:

  • This function is declared in different header files (namely, <io.h> or <direct.h>) on some platforms: mingw, MSVC 14.
  • This function mistakenly removes a directory with rmdir("dir/./") on some platforms: Cygwin 1.5.x.
  • This function fails with EINVAL instead of the expected ENOTDIR for rmdir("file/") on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • When rmdir fails because the specified directory is not empty, the errno value is system dependent.
  • POSIX requires that rmdir("link-to-empty/") remove empty and leave link-to-empty as a dangling symlink. This is counter-intuitive, so some systems fail with ENOTDIR instead: glibc

Next: round Prev: rintl Up: Function Substitutes Top: Top


round -- GNU Gnulib

Next: roundf Prev: rmdir Up: Function Substitutes Top: Top

9.872. round

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/round.html

Gnulib module: round or round-ieee

Portability problems fixed by either Gnulib module round or round-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, older IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: glibc 2.8, IRIX 6.5, OSF/1 5.1.
  • This functions returns a wrong result for @math{x = 1/2 - 2^-54} on some platforms: NetBSD 3.0, AIX 7.1.
Portability problems fixed by Gnulib module round-ieee:
  • This function returns a positive zero for an argument between -0.5 and 0 on some platforms: AIX 7.1, OSF/1 5.1.
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: roundf Prev: rmdir Up: Function Substitutes Top: Top


roundf -- GNU Gnulib

Next: roundl Prev: round Up: Function Substitutes Top: Top

9.873. roundf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/roundf.html

Gnulib module: roundf or roundf-ieee

Portability problems fixed by either Gnulib module roundf or roundf-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared on some platforms: glibc 2.8, IRIX 6.5, OSF/1 5.1.
  • This functions returns a wrong result for @math{x = 1/2 - 2^-25} on some platforms: mingw.
Portability problems fixed by Gnulib module roundf-ieee:
  • This function returns a positive zero for an argument between -0.5 and 0 on some platforms: AIX 7.1, OSF/1 5.1.
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: roundl Prev: round Up: Function Substitutes Top: Top


roundl -- GNU Gnulib

Next: scalbln Prev: roundf Up: Function Substitutes Top: Top

9.874. roundl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/roundl.html

Gnulib module: roundl or roundl-ieee

Portability problems fixed by either Gnulib module roundl or roundl-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, older IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared on some platforms: glibc 2.8, IRIX 6.5, OSF/1 5.1.
Portability problems fixed by Gnulib module roundl-ieee:
  • This function returns a positive zero for an argument between -0.5 and 0 on some platforms: AIX 7.1.
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: scalbln Prev: roundf Up: Function Substitutes Top: Top


scalbln -- GNU Gnulib

Next: scalblnf Prev: roundl Up: Function Substitutes Top: Top

9.875. scalbln

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalbln.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: scalblnf Prev: roundl Up: Function Substitutes Top: Top


scalblnf -- GNU Gnulib

Next: scalblnl Prev: scalbln Up: Function Substitutes Top: Top

9.876. scalblnf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalblnf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5.

Next: scalblnl Prev: scalbln Up: Function Substitutes Top: Top


scalblnl -- GNU Gnulib

Next: scalbn Prev: scalblnf Up: Function Substitutes Top: Top

9.877. scalblnl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalblnl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5.

Next: scalbn Prev: scalblnf Up: Function Substitutes Top: Top


scalbn -- GNU Gnulib

Next: scalbnf Prev: scalblnl Up: Function Substitutes Top: Top

9.878. scalbn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalbn.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, IRIX 6.5, OSF/1 4.0, MSVC 9.

Next: scalbnf Prev: scalblnl Up: Function Substitutes Top: Top


scalbnf -- GNU Gnulib

Next: scalbnl Prev: scalbn Up: Function Substitutes Top: Top

9.879. scalbnf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalbnf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9.

Next: scalbnl Prev: scalbn Up: Function Substitutes Top: Top


scalbnl -- GNU Gnulib

Next: scandir Prev: scalbnf Up: Function Substitutes Top: Top

9.880. scalbnl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scalbnl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5.

Next: scandir Prev: scalbnf Up: Function Substitutes Top: Top


scandir -- GNU Gnulib

Next: scanf Prev: scalbnl Up: Function Substitutes Top: Top

9.881. scandir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scandir.html

Gnulib module: scandir

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, Solaris 9, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
  • The fourth parameter of this function is declared as int (*) (const void *, const void *) on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Interix 3.5.
  • The fourth parameter of this function is declared as int (*) (void *, void *) on some platforms: AIX 5.1.

Next: scanf Prev: scalbnl Up: Function Substitutes Top: Top


scanf -- GNU Gnulib

Next: sched_get_priority_max Prev: scandir Up: Function Substitutes Top: Top

9.882. scanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/scanf.html

Gnulib module: stdio, nonblocking

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • C99 and POSIX.1-2001 and later require end-of-file to be sticky, that is, they require this function to act as if it reads end-of-file if feof would return nonzero. However, on some systems this function attempts to read from the underlying file descriptor even if the stream's end-of-file indicator is set. These systems include glibc and default Solaris.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, this function doesn't support the hh, ll, j, t, z size specifiers.

Next: sched_get_priority_max Prev: scandir Up: Function Substitutes Top: Top


sched_get_priority_max -- GNU Gnulib

Next: sched_get_priority_min Prev: scanf Up: Function Substitutes Top: Top

9.883. sched_get_priority_max

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_get_priority_max.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: sched_get_priority_min Prev: scanf Up: Function Substitutes Top: Top


sched_get_priority_min -- GNU Gnulib

Next: sched_getparam Prev: sched_get_priority_max Up: Function Substitutes Top: Top

9.884. sched_get_priority_min

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_get_priority_min.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, mingw, MSVC 14, BeOS.

Next: sched_getparam Prev: sched_get_priority_max Up: Function Substitutes Top: Top


sched_getparam -- GNU Gnulib

Next: sched_getscheduler Prev: sched_get_priority_min Up: Function Substitutes Top: Top

9.885. sched_getparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_getparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_getscheduler Prev: sched_get_priority_min Up: Function Substitutes Top: Top


sched_getscheduler -- GNU Gnulib

Next: sched_rr_get_interval Prev: sched_getparam Up: Function Substitutes Top: Top

9.886. sched_getscheduler

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_getscheduler.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_rr_get_interval Prev: sched_getparam Up: Function Substitutes Top: Top


sched_rr_get_interval -- GNU Gnulib

Next: sched_setparam Prev: sched_getscheduler Up: Function Substitutes Top: Top

9.887. sched_rr_get_interval

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_rr_get_interval.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_setparam Prev: sched_getscheduler Up: Function Substitutes Top: Top


sched_setparam -- GNU Gnulib

Next: sched_setscheduler Prev: sched_rr_get_interval Up: Function Substitutes Top: Top

9.888. sched_setparam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_setparam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_setscheduler Prev: sched_rr_get_interval Up: Function Substitutes Top: Top


sched_setscheduler -- GNU Gnulib

Next: sched_yield Prev: sched_setparam Up: Function Substitutes Top: Top

9.889. sched_setscheduler

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_setscheduler.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_yield Prev: sched_setparam Up: Function Substitutes Top: Top


sched_yield -- GNU Gnulib

Next: seed48 Prev: sched_setscheduler Up: Function Substitutes Top: Top

9.890. sched_yield

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sched_yield.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: seed48 Prev: sched_setscheduler Up: Function Substitutes Top: Top


seed48 -- GNU Gnulib

Next: seekdir Prev: sched_yield Up: Function Substitutes Top: Top

9.891. seed48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/seed48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: seekdir Prev: sched_yield Up: Function Substitutes Top: Top


seekdir -- GNU Gnulib

Next: select Prev: seed48 Up: Function Substitutes Top: Top

9.892. seekdir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/seekdir.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: MSVC 14, BeOS.
  • On platforms where long int is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro (only on Mac OS X systems).

Next: select Prev: seed48 Up: Function Substitutes Top: Top


select -- GNU Gnulib

Next: sem_close Prev: seekdir Up: Function Substitutes Top: Top

9.893. select

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/select.html

Gnulib module: select

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), select can only be called on descriptors created by the socket function, not on regular file descriptors.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
  • This function fails when the nfds argument is 0 on some platforms: Interix 3.5.
  • On some platforms, this function fails to detect invalid fds with EBADF, but only if they lie beyond the current maximum open fd: FreeBSD 8.2.
Portability problems not fixed by Gnulib:
  • When you call select with a timeout, some implementations modify the timeout parameter so that upon return from the function, it contains the amount of time not slept. Other implementations leave the timeout parameter unmodified.
  • On BeOS, select can only be called on descriptors created by the socket function, not on regular file descriptors.
  • Under Windows, when passing a pipe, Gnulib's select replacement might return 0 even before the timeout has passed. Programs using it with pipes can thus busy wait.
  • On Solaris 2.6 and older, select applied to a file descriptor opened for reading and associated with /dev/null hangs, waiting for input, when instead it should return immediately.
  • On Linux, when some file descriptor refers to a regular file, select may fail, setting errno to EBADF.
  • This function is declared in <unistd.h>, not <sys/select.h>, on some platforms: IRIX 5.3.

Next: sem_close Prev: seekdir Up: Function Substitutes Top: Top


sem_close -- GNU Gnulib

Next: sem_destroy Prev: select Up: Function Substitutes Top: Top

9.894. sem_close

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_close.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: sem_destroy Prev: select Up: Function Substitutes Top: Top


sem_destroy -- GNU Gnulib

Next: sem_getvalue Prev: sem_close Up: Function Substitutes Top: Top

9.895. sem_destroy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_destroy.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.
  • This function is not implemented on some platforms: Mac OS X 10.11.

Next: sem_getvalue Prev: sem_close Up: Function Substitutes Top: Top


sem_getvalue -- GNU Gnulib

Next: sem_init Prev: sem_destroy Up: Function Substitutes Top: Top

9.896. sem_getvalue

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_getvalue.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.
  • This function is not implemented on some platforms: Mac OS X 10.11.

Next: sem_init Prev: sem_destroy Up: Function Substitutes Top: Top


sem_init -- GNU Gnulib

Next: sem_open Prev: sem_getvalue Up: Function Substitutes Top: Top

9.897. sem_init

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_init.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.
  • This function is not implemented on some platforms: Mac OS X 10.11.

Next: sem_open Prev: sem_getvalue Up: Function Substitutes Top: Top


sem_open -- GNU Gnulib

Next: sem_post Prev: sem_init Up: Function Substitutes Top: Top

9.898. sem_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: sem_post Prev: sem_init Up: Function Substitutes Top: Top


sem_post -- GNU Gnulib

Next: sem_timedwait Prev: sem_open Up: Function Substitutes Top: Top

9.899. sem_post

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_post.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: sem_timedwait Prev: sem_open Up: Function Substitutes Top: Top


sem_timedwait -- GNU Gnulib

Next: sem_trywait Prev: sem_post Up: Function Substitutes Top: Top

9.900. sem_timedwait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_timedwait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 14, BeOS.

Next: sem_trywait Prev: sem_post Up: Function Substitutes Top: Top


sem_trywait -- GNU Gnulib

Next: sem_unlink Prev: sem_timedwait Up: Function Substitutes Top: Top

9.901. sem_trywait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_trywait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: sem_unlink Prev: sem_timedwait Up: Function Substitutes Top: Top


sem_unlink -- GNU Gnulib

Next: sem_wait Prev: sem_trywait Up: Function Substitutes Top: Top

9.902. sem_unlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_unlink.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, BeOS.

Next: sem_wait Prev: sem_trywait Up: Function Substitutes Top: Top


sem_wait -- GNU Gnulib

Next: semctl Prev: sem_unlink Up: Function Substitutes Top: Top

9.903. sem_wait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sem_wait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: semctl Prev: sem_unlink Up: Function Substitutes Top: Top


semctl -- GNU Gnulib

Next: semget Prev: sem_wait Up: Function Substitutes Top: Top

9.904. semctl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/semctl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: semget Prev: sem_wait Up: Function Substitutes Top: Top


semget -- GNU Gnulib

Next: semop Prev: semctl Up: Function Substitutes Top: Top

9.905. semget

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/semget.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: semop Prev: semctl Up: Function Substitutes Top: Top


semop -- GNU Gnulib

Next: send Prev: semget Up: Function Substitutes Top: Top

9.906. semop

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/semop.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: send Prev: semget Up: Function Substitutes Top: Top


send -- GNU Gnulib

Next: sendmsg Prev: semop Up: Function Substitutes Top: Top

9.907. send

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/send.html

Gnulib module: send

Portability problems fixed by Gnulib:

  • This function has the return type int instead of ssize_t on some platforms: OSF/1 5.1.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: sendmsg Prev: semop Up: Function Substitutes Top: Top


sendmsg -- GNU Gnulib

Next: sendto Prev: send Up: Function Substitutes Top: Top

9.908. sendmsg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sendmsg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, Interix 3.5, BeOS.

Next: sendto Prev: send Up: Function Substitutes Top: Top


sendto -- GNU Gnulib

Next: setbuf Prev: sendmsg Up: Function Substitutes Top: Top

9.909. sendto

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sendto.html

Gnulib module: sendto

Portability problems fixed by Gnulib:

  • This function has the return type int instead of ssize_t on some platforms: OSF/1 5.1.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: setbuf Prev: sendmsg Up: Function Substitutes Top: Top


setbuf -- GNU Gnulib

Next: setegid Prev: sendto Up: Function Substitutes Top: Top

9.910. setbuf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setbuf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: setegid Prev: sendto Up: Function Substitutes Top: Top


setegid -- GNU Gnulib

Next: setenv Prev: setbuf Up: Function Substitutes Top: Top

9.911. setegid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setegid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11.23, mingw, MSVC 14, BeOS.

Next: setenv Prev: setbuf Up: Function Substitutes Top: Top


setenv -- GNU Gnulib

Next: seteuid Prev: setegid Up: Function Substitutes Top: Top

9.912. setenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setenv.html

Gnulib module: setenv

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 4.3.2, HP-UX 11.23, IRIX 6.5, Solaris 9, mingw, MSVC 14, BeOS.
  • This function is not declared on some platforms: OSF/1 5.1.
  • On some platforms, this function does not fail with `EINVAL' when passed an empty string or a string containing `=': Mac OS X 10.5, FreeBSD 6.0, NetBSD 1.6, OpenBSD 3.8, Cygwin 1.5.x.
  • On some platforms, this function removes a leading `=' from the value argument: Cygwin 1.5.x.
Portability problems not fixed by Gnulib:
  • Older versions of POSIX required that setenv(NULL,"",0) gracefully fail with EINVAL, but not all implementations guarantee this, and the requirement was removed.

Next: seteuid Prev: setegid Up: Function Substitutes Top: Top


seteuid -- GNU Gnulib

Next: setgid Prev: setenv Up: Function Substitutes Top: Top

9.913. seteuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/seteuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11.23, mingw, MSVC 14, BeOS.

Next: setgid Prev: setenv Up: Function Substitutes Top: Top


setgid -- GNU Gnulib

Next: setgrent Prev: seteuid Up: Function Substitutes Top: Top

9.914. setgid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setgid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: setgrent Prev: seteuid Up: Function Substitutes Top: Top


setgrent -- GNU Gnulib

Next: sethostent Prev: setgid Up: Function Substitutes Top: Top

9.915. setgrent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setgrent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: sethostent Prev: setgid Up: Function Substitutes Top: Top


sethostent -- GNU Gnulib

Next: setitimer Prev: setgrent Up: Function Substitutes Top: Top

9.916. sethostent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sethostent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: setitimer Prev: setgrent Up: Function Substitutes Top: Top


setitimer -- GNU Gnulib

Next: setjmp Prev: sethostent Up: Function Substitutes Top: Top

9.917. setitimer

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setitimer.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: setjmp Prev: sethostent Up: Function Substitutes Top: Top


setjmp -- GNU Gnulib

Next: setkey Prev: setitimer Up: Function Substitutes Top: Top

9.918. setjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • POSIX does not specify whether setjmp saves the signal mask in the jmp_buf. It does on BSD platforms, and on glibc platforms when _BSD_SOURCE (and/or _DEFAULT_SOURCE on glibc >= 2.19) is defined; in this case setjmp behaves like sigsetjmp(.,1), and functions _setjmp and _longjmp are available that don't save or restore the signal mask. On System V platforms (excluding HP-UX), and on glibc platforms by default, setjmp doesn't save the signal mask.

Next: setkey Prev: setitimer Up: Function Substitutes Top: Top


setkey -- GNU Gnulib

Next: setlocale Prev: setjmp Up: Function Substitutes Top: Top

9.919. setkey

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setkey.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.
  • This function is not declared in <stdlib.h> (without -D_GNU_SOURCE) on some platforms: glibc (at least 2.11--2.13).

Next: setlocale Prev: setjmp Up: Function Substitutes Top: Top


setlocale -- GNU Gnulib

Next: setlogmask Prev: setkey Up: Function Substitutes Top: Top

9.920. setlocale

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setlocale.html

Gnulib module: setlocale

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), setlocale(category,NULL) ignores the environment variables LC_ALL, category, and LANG.
  • On Windows platforms (excluding Cygwin) and Cygwin 1.5.x, setlocale(LC_ALL,name) succeeds and sets the LC_CTYPE category to `C' when it does not support the encoding, instead of failing.
  • On Windows platforms (excluding Cygwin), setlocale understands different locale names, that are not based on ISO 639 language names and ISO 3166 country names.
Portability problems not fixed by Gnulib:
  • On Cygwin 1.5.x, which doesn't have locales, setlocale(LC_ALL,NULL) always returns "C".
  • On Cygwin 1.7.0, only the charset portion of a locale designation is honored.
  • On OpenBSD, setlocale(LC_ALL,"") will only update categories that are deemed appropriate for the LC_ALL environment value, even if there are other categories set to different values in the environment. In addition any value is accepted for LC_CTYPE, and so NULL is never returned to indicate a failure to set locale. To verify category values, each category must be set individually with setlocale(LC_COLLATE,"") etc.

Next: setlogmask Prev: setkey Up: Function Substitutes Top: Top


setlogmask -- GNU Gnulib

Next: setnetent Prev: setlocale Up: Function Substitutes Top: Top

9.921. setlogmask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setlogmask.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: setnetent Prev: setlocale Up: Function Substitutes Top: Top


setnetent -- GNU Gnulib

Next: setpgid Prev: setlogmask Up: Function Substitutes Top: Top

9.922. setnetent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setnetent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin, mingw, MSVC 14, BeOS.

Next: setpgid Prev: setlogmask Up: Function Substitutes Top: Top


setpgid -- GNU Gnulib

Next: setpgrp Prev: setnetent Up: Function Substitutes Top: Top

9.923. setpgid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setpgid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: setpgrp Prev: setnetent Up: Function Substitutes Top: Top


setpgrp -- GNU Gnulib

Next: setpriority Prev: setpgid Up: Function Substitutes Top: Top

9.924. setpgrp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setpgrp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5.

Next: setpriority Prev: setpgid Up: Function Substitutes Top: Top


setpriority -- GNU Gnulib

Next: setprotoent Prev: setpgrp Up: Function Substitutes Top: Top

9.925. setpriority

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setpriority.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, BeOS.

Next: setprotoent Prev: setpgrp Up: Function Substitutes Top: Top


setprotoent -- GNU Gnulib

Next: setpwent Prev: setpriority Up: Function Substitutes Top: Top

9.926. setprotoent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setprotoent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: setpwent Prev: setpriority Up: Function Substitutes Top: Top


setpwent -- GNU Gnulib

Next: setregid Prev: setprotoent Up: Function Substitutes Top: Top

9.927. setpwent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setpwent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: setregid Prev: setprotoent Up: Function Substitutes Top: Top


setregid -- GNU Gnulib

Next: setreuid Prev: setpwent Up: Function Substitutes Top: Top

9.928. setregid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setregid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: setreuid Prev: setpwent Up: Function Substitutes Top: Top


setreuid -- GNU Gnulib

Next: setrlimit Prev: setregid Up: Function Substitutes Top: Top

9.929. setreuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setreuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, BeOS.

Next: setrlimit Prev: setregid Up: Function Substitutes Top: Top


setrlimit -- GNU Gnulib

Next: setservent Prev: setreuid Up: Function Substitutes Top: Top

9.930. setrlimit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setrlimit.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On platforms where rlim_t is a 32-bit type, this function does not allow to set limits larger than 4 GB, such as for RLIMIT_FSIZE. The fix is to use the AC_SYS_LARGEFILE macro.

Next: setservent Prev: setreuid Up: Function Substitutes Top: Top


setservent -- GNU Gnulib

Next: setsid Prev: setrlimit Up: Function Substitutes Top: Top

9.931. setservent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setservent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: setsid Prev: setrlimit Up: Function Substitutes Top: Top


setsid -- GNU Gnulib

Next: setsockopt Prev: setservent Up: Function Substitutes Top: Top

9.932. setsid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setsid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: setsockopt Prev: setservent Up: Function Substitutes Top: Top


setsockopt -- GNU Gnulib

Next: setstate Prev: setsid Up: Function Substitutes Top: Top

9.933. setsockopt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setsockopt.html

Gnulib module: setsockopt

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • Many socket options are not available on all platforms.

Next: setstate Prev: setsid Up: Function Substitutes Top: Top


setstate -- GNU Gnulib

Next: setuid Prev: setsockopt Up: Function Substitutes Top: Top

9.934. setstate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setstate.html

Gnulib module: random

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
  • This function is not declared on some platforms: Cygwin 1.5.25.
Portability problems not fixed by Gnulib:
  • This function has a slightly incompatible declaration (the argument type being `const char *' instead of `char *') on some platforms.

Next: setuid Prev: setsockopt Up: Function Substitutes Top: Top


setuid -- GNU Gnulib

Next: setutxent Prev: setstate Up: Function Substitutes Top: Top

9.935. setuid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setuid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: setutxent Prev: setstate Up: Function Substitutes Top: Top


setutxent -- GNU Gnulib

Next: setvbuf Prev: setuid Up: Function Substitutes Top: Top

9.936. setutxent

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setutxent.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: setvbuf Prev: setuid Up: Function Substitutes Top: Top


setvbuf -- GNU Gnulib

Next: shm_open Prev: setutxent Up: Function Substitutes Top: Top

9.937. setvbuf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/setvbuf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: shm_open Prev: setutxent Up: Function Substitutes Top: Top


shm_open -- GNU Gnulib

Next: shm_unlink Prev: setvbuf Up: Function Substitutes Top: Top

9.938. shm_open

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shm_open.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: shm_unlink Prev: setvbuf Up: Function Substitutes Top: Top


shm_unlink -- GNU Gnulib

Next: shmat Prev: shm_open Up: Function Substitutes Top: Top

9.939. shm_unlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shm_unlink.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: shmat Prev: shm_open Up: Function Substitutes Top: Top


shmat -- GNU Gnulib

Next: shmctl Prev: shm_unlink Up: Function Substitutes Top: Top

9.940. shmat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shmat.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • Attempts to shmat into a previously malloc-ed region fail on SunOS 4, with errno set to EINVAL, even if there is an munmap call in between.
  • On Linux, the flag SHM_REMAP is needed in order to force shmat to replace existing memory mappings in the specify address range. On other platforms, it is not needed.

Next: shmctl Prev: shm_unlink Up: Function Substitutes Top: Top


shmctl -- GNU Gnulib

Next: shmdt Prev: shmat Up: Function Substitutes Top: Top

9.941. shmctl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shmctl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: shmdt Prev: shmat Up: Function Substitutes Top: Top


shmdt -- GNU Gnulib

Next: shmget Prev: shmctl Up: Function Substitutes Top: Top

9.942. shmdt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shmdt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: shmget Prev: shmctl Up: Function Substitutes Top: Top


shmget -- GNU Gnulib

Next: shutdown Prev: shmdt Up: Function Substitutes Top: Top

9.943. shmget

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shmget.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
  • On many platforms (not Linux), SHMMAX is so small that it is unusable for reasonable applications, and/or shmget requires superuser privileges.

Next: shutdown Prev: shmdt Up: Function Substitutes Top: Top


shutdown -- GNU Gnulib

Next: sigaction Prev: shmget Up: Function Substitutes Top: Top

9.944. shutdown

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/shutdown.html

Gnulib module: shutdown

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:

Next: sigaction Prev: shmget Up: Function Substitutes Top: Top


sigaction -- GNU Gnulib

Next: sigaddset Prev: shutdown Up: Function Substitutes Top: Top

9.945. sigaction

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigaction.html

Gnulib module: sigaction

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • POSIX recommends that when specifying SA_RESETHAND, SA_NODEFER must also be specified.

  • Support for SA_ONSTACK is missing on some platforms: mingw, MSVC 14, cygwin.

  • Support for SA_SIGINFO is missing on some platforms: mingw, MSVC 14, Interix 3.5.

  • Support for SIGCHLD, and thus for SA_NOCLDSTOP and SA_NOCLDWAIT, is missing on some platforms: mingw, MSVC 14.

  • Support for SA_RESETHAND is missing on some platforms: NonStop.

  • Support for SA_RESTART is missing on some platforms: mingw, MSVC 14, NonStop.

  • In spite of having SA_SIGACTION, struct sigaction lacks the sa_sigaction member on some platforms: Irix 5.3.

  • The symbolic value SIG_IGN for the SIGCHLD signal is equivalent to a signal handler
    void handle_child (int sigchld)
{
  while (waitpid (-1, NULL, WNOHANG) > 0)
    ;
}
    except that SIG_IGN for SIGCHLD has the effect that the children execution times are not accounted in the times function. On some platforms (BSD? SystemV? Linux?), you need to use the sigaction flag SA_NOCLDWAIT in order to obtain this behavior.

Next: sigaddset Prev: shutdown Up: Function Substitutes Top: Top


sigaddset -- GNU Gnulib

Next: sigaltstack Prev: sigaction Up: Function Substitutes Top: Top

9.946. sigaddset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigaddset.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: sigaltstack Prev: sigaction Up: Function Substitutes Top: Top


sigaltstack -- GNU Gnulib

Next: sigdelset Prev: sigaddset Up: Function Substitutes Top: Top

9.947. sigaltstack

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigaltstack.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • sigaltstack doesn't work on HP-UX 11/IA-64 and OpenBSD 3.6/Sparc64.
  • This function interprets the ss_sp member of stack_t as the upper bound instead of the lower bound of the alternate stack on some platforms: Irix 6.5

Next: sigdelset Prev: sigaddset Up: Function Substitutes Top: Top


sigdelset -- GNU Gnulib

Next: sigemptyset Prev: sigaltstack Up: Function Substitutes Top: Top

9.948. sigdelset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigdelset.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: sigemptyset Prev: sigaltstack Up: Function Substitutes Top: Top


sigemptyset -- GNU Gnulib

Next: sigfillset Prev: sigdelset Up: Function Substitutes Top: Top

9.949. sigemptyset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigemptyset.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: sigfillset Prev: sigdelset Up: Function Substitutes Top: Top


sigfillset -- GNU Gnulib

Next: sighold Prev: sigemptyset Up: Function Substitutes Top: Top

9.950. sigfillset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigfillset.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: sighold Prev: sigemptyset Up: Function Substitutes Top: Top


sighold -- GNU Gnulib

Next: sigignore Prev: sigfillset Up: Function Substitutes Top: Top

9.951. sighold

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sighold.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: sigignore Prev: sigfillset Up: Function Substitutes Top: Top


sigignore -- GNU Gnulib

Next: siginterrupt Prev: sighold Up: Function Substitutes Top: Top

9.952. sigignore

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigignore.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, BeOS.

Next: siginterrupt Prev: sighold Up: Function Substitutes Top: Top


siginterrupt -- GNU Gnulib

Next: sigismember Prev: sigignore Up: Function Substitutes Top: Top

9.953. siginterrupt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/siginterrupt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, mingw, MSVC 14, Interix 3.5, BeOS.
Note: POSIX recommends using sigaction with SA_RESTART instead of siginterrupt (sig, 0).

Next: sigismember Prev: sigignore Up: Function Substitutes Top: Top


sigismember -- GNU Gnulib

Next: siglongjmp Prev: siginterrupt Up: Function Substitutes Top: Top

9.954. sigismember

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigismember.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: siglongjmp Prev: siginterrupt Up: Function Substitutes Top: Top


siglongjmp -- GNU Gnulib

Next: signal Prev: sigismember Up: Function Substitutes Top: Top

9.955. siglongjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/siglongjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

  • This is only provided as a macro on some platforms: Cygwin.

Next: signal Prev: sigismember Up: Function Substitutes Top: Top


signal -- GNU Gnulib

Next: signbit Prev: siglongjmp Up: Function Substitutes Top: Top

9.956. signal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/signal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • On System V platforms, when the signal is triggered, the kernel uninstalls the handler (i.e. resets the signal's action to SIG_DFL) before invoking the handler. This opens the door to race conditions: undesired things happen if the signal is triggered twice and the signal handler was not quick enough reinstalling itself as a handler. On BSD platforms and glibc platforms, on the other hand, when the signal is triggered, the kernel blocks the signal before invoking the handler. This is saner, but POSIX still allows either behavior. To avoid this problem, use sigaction instead of signal.

Next: signbit Prev: siglongjmp Up: Function Substitutes Top: Top


signbit -- GNU Gnulib

Next: signgam Prev: signal Up: Function Substitutes Top: Top

9.957. signbit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/signbit.html

Gnulib module: signbit

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.0, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: signgam Prev: signal Up: Function Substitutes Top: Top


signgam -- GNU Gnulib

Next: sigpause Prev: signbit Up: Function Substitutes Top: Top

9.958. signgam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/signgam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

Next: sigpause Prev: signbit Up: Function Substitutes Top: Top


sigpause -- GNU Gnulib

Next: sigpending Prev: signgam Up: Function Substitutes Top: Top

9.959. sigpause

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigpause.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: sigpending Prev: signgam Up: Function Substitutes Top: Top


sigpending -- GNU Gnulib

Next: sigprocmask Prev: sigpause Up: Function Substitutes Top: Top

9.960. sigpending

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigpending.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: sigprocmask Prev: sigpause Up: Function Substitutes Top: Top


sigprocmask -- GNU Gnulib

Next: sigqueue Prev: sigpending Up: Function Substitutes Top: Top

9.961. sigprocmask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigprocmask.html

Gnulib module: sigprocmask

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: sigqueue Prev: sigpending Up: Function Substitutes Top: Top


sigqueue -- GNU Gnulib

Next: sigrelse Prev: sigprocmask Up: Function Substitutes Top: Top

9.962. sigqueue

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigqueue.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigrelse Prev: sigprocmask Up: Function Substitutes Top: Top


sigrelse -- GNU Gnulib

Next: sigset Prev: sigqueue Up: Function Substitutes Top: Top

9.963. sigrelse

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigrelse.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: sigset Prev: sigqueue Up: Function Substitutes Top: Top


sigset -- GNU Gnulib

Next: sigsetjmp Prev: sigrelse Up: Function Substitutes Top: Top

9.964. sigset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigset.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.5.x, mingw, MSVC 14, BeOS.

Next: sigsetjmp Prev: sigrelse Up: Function Substitutes Top: Top


sigsetjmp -- GNU Gnulib

Next: sigsuspend Prev: sigset Up: Function Substitutes Top: Top

9.965. sigsetjmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigsetjmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: sigsuspend Prev: sigset Up: Function Substitutes Top: Top


sigsuspend -- GNU Gnulib

Next: sigtimedwait Prev: sigsetjmp Up: Function Substitutes Top: Top

9.966. sigsuspend

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigsuspend.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: sigtimedwait Prev: sigsetjmp Up: Function Substitutes Top: Top


sigtimedwait -- GNU Gnulib

Next: sigwait Prev: sigsuspend Up: Function Substitutes Top: Top

9.967. sigtimedwait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigtimedwait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • Linux implements the meaning of NULL timeout by doing what sigwaitinfo does; other platforms may not do the same.

Next: sigwait Prev: sigsuspend Up: Function Substitutes Top: Top


sigwait -- GNU Gnulib

Next: sigwaitinfo Prev: sigtimedwait Up: Function Substitutes Top: Top

9.968. sigwait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigwait.html

Gnulib module: extensions

Portability problems fixed by Gnulib:

  • This function has an incompatible declaration on some platforms: Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • On Linux/glibc platforms before the advent of NPTL, signals could only be sent to one particular thread. In POSIX, signals are sent to the entire process and executed by any thread of the process that happens to have the particular signal currently unblocked.

Next: sigwaitinfo Prev: sigtimedwait Up: Function Substitutes Top: Top


sigwaitinfo -- GNU Gnulib

Next: sin Prev: sigwait Up: Function Substitutes Top: Top

9.969. sigwaitinfo

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sigwaitinfo.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sin Prev: sigwait Up: Function Substitutes Top: Top


sin -- GNU Gnulib

Next: sinf Prev: sigwaitinfo Up: Function Substitutes Top: Top

9.970. sin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sin.html

Gnulib module: sin

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: sinf Prev: sigwaitinfo Up: Function Substitutes Top: Top


sinf -- GNU Gnulib

Next: sinh Prev: sin Up: Function Substitutes Top: Top

9.971. sinf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sinf.html

Gnulib module: sinf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: sinh Prev: sin Up: Function Substitutes Top: Top


sinh -- GNU Gnulib

Next: sinhf Prev: sinf Up: Function Substitutes Top: Top

9.972. sinh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sinh.html

Gnulib module: sinh

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: sinhf Prev: sinf Up: Function Substitutes Top: Top


sinhf -- GNU Gnulib

Next: sinhl Prev: sinh Up: Function Substitutes Top: Top

9.973. sinhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sinhf.html

Gnulib module: sinhf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: sinhl Prev: sinh Up: Function Substitutes Top: Top


sinhl -- GNU Gnulib

Next: sinl Prev: sinhf Up: Function Substitutes Top: Top

9.974. sinhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sinhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.

Next: sinl Prev: sinhf Up: Function Substitutes Top: Top


sinl -- GNU Gnulib

Next: sleep Prev: sinhl Up: Function Substitutes Top: Top

9.975. sinl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sinl.html

Gnulib module: sinl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: sleep Prev: sinhl Up: Function Substitutes Top: Top


sleep -- GNU Gnulib

Next: snprintf Prev: sinl Up: Function Substitutes Top: Top

9.976. sleep

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sleep.html

Gnulib module: sleep

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw (2005 or newer), MSVC 14.
  • This function takes milliseconds as argument and returns void on some platforms: mingw (2005 and older).
  • This function cannot sleep longer than 49.7 days on some platforms: Cygwin 1.5.x.
Portability problems not fixed by Gnulib:
  • According to POSIX, the sleep function may interfere with the program's use of the SIGALRM signal. On Linux, it doesn't; on other platforms, it may.

Next: snprintf Prev: sinl Up: Function Substitutes Top: Top


snprintf -- GNU Gnulib

Next: sockatmark Prev: sleep Up: Function Substitutes Top: Top

9.977. snprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/snprintf.html

Gnulib module: snprintf or snprintf-posix

Portability problems fixed by either Gnulib module snprintf or snprintf-posix:

  • This function is missing on some platforms: IRIX 5.3, OSF/1 4.0, Solaris 2.5.1, MSVC 14.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, BeOS.
  • This function does not return a byte count as specified in C99 on some platforms: HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw.
  • This function overwrites memory even when a size argument of 1 is passed on some platforms: Linux libc5, BeOS.
Portability problems fixed by Gnulib module snprintf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
  • This function does not truncate the result as specified in C99 on some platforms: mingw, MSVC 14.
  • This function does not fully support the `n' directive on some platforms: HP-UX 11, mingw, MSVC 14.
  • This function overwrites memory even when a zero size argument is passed on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: sockatmark Prev: sleep Up: Function Substitutes Top: Top


sockatmark -- GNU Gnulib

Next: socket Prev: snprintf Up: Function Substitutes Top: Top

9.978. sockatmark

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sockatmark.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: socket Prev: snprintf Up: Function Substitutes Top: Top


socket -- GNU Gnulib

Next: socketpair Prev: sockatmark Up: Function Substitutes Top: Top

9.979. socket

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/socket.html

Gnulib module: socket

Portability problems fixed by Gnulib:

  • On Windows platforms (excluding Cygwin), the descriptors returned by the socket function cannot be used in calls to read, write, and close; you have to use recv, send, closesocket in these cases instead.
  • On Windows platforms (excluding Cygwin), error codes from this function are not placed in errno, and WSAGetLastError must be used instead.
Portability problems not fixed by Gnulib:
  • On BeOS, the descriptors returned by the socket function cannot be used in calls to read, write, and close; you have to use recv, send, closesocket in these cases instead.

Next: socketpair Prev: sockatmark Up: Function Substitutes Top: Top


socketpair -- GNU Gnulib

Next: sprintf Prev: socket Up: Function Substitutes Top: Top

9.980. socketpair

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/socketpair.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: sprintf Prev: socket Up: Function Substitutes Top: Top


sprintf -- GNU Gnulib

Next: sqrt Prev: socketpair Up: Function Substitutes Top: Top

9.981. sprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sprintf.html

Gnulib module: sprintf-posix

Portability problems fixed by Gnulib:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: sqrt Prev: socketpair Up: Function Substitutes Top: Top


sqrt -- GNU Gnulib

Next: sqrtf Prev: sprintf Up: Function Substitutes Top: Top

9.982. sqrt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sqrt.html

Gnulib module: sqrt

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3.

Next: sqrtf Prev: sprintf Up: Function Substitutes Top: Top


sqrtf -- GNU Gnulib

Next: sqrtl Prev: sqrt Up: Function Substitutes Top: Top

9.983. sqrtf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sqrtf.html

Gnulib module: sqrtf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: sqrtl Prev: sqrt Up: Function Substitutes Top: Top


sqrtl -- GNU Gnulib

Next: srand Prev: sqrtf Up: Function Substitutes Top: Top

9.984. sqrtl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sqrtl.html

Gnulib module: sqrtl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
  • This function produces very imprecise results on some platforms: OpenBSD 5.1/SPARC.
Portability problems not fixed by Gnulib:

Next: srand Prev: sqrtf Up: Function Substitutes Top: Top


srand -- GNU Gnulib

Next: srand48 Prev: sqrtl Up: Function Substitutes Top: Top

9.985. srand

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/srand.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: srand48 Prev: sqrtl Up: Function Substitutes Top: Top


srand48 -- GNU Gnulib

Next: srandom Prev: srand Up: Function Substitutes Top: Top

9.986. srand48

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/srand48.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: srandom Prev: srand Up: Function Substitutes Top: Top


srandom -- GNU Gnulib

Next: sscanf Prev: srand48 Up: Function Substitutes Top: Top

9.987. srandom

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/srandom.html

Gnulib module: random

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function has a slightly incompatible declaration (the return type being `long' instead of `void') on some platforms: Cygwin 1.5.25.

Next: sscanf Prev: srand48 Up: Function Substitutes Top: Top


sscanf -- GNU Gnulib

Next: stat Prev: srandom Up: Function Substitutes Top: Top

9.988. sscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, this function doesn't support the hh, ll, j, t, z size specifiers.

Next: stat Prev: srandom Up: Function Substitutes Top: Top


stat -- GNU Gnulib

Next: statvfs Prev: sscanf Up: Function Substitutes Top: Top

9.989. stat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stat.html

Gnulib module: stat

Portability problems fixed by Gnulib:

  • On platforms where off_t is a 32-bit type, stat may not correctly report the size of files or block devices larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
  • The st_atime, st_ctime, st_mtime fields are affected by the current time zone and by the DST flag of the current time zone on some platforms: mingw, MSVC 14 (when the environment variable TZ is set).
  • On MSVC 14, this function fails with error ENOENT on files such as `C:\pagefile.sys' and on directories such as `C:\System Volume Information'.
  • On some platforms, stat("link-to-file/",buf) succeeds instead of failing with ENOTDIR. FreeBSD 7.2, AIX 7.1, Solaris 9, mingw64.
  • On some platforms, stat(".",buf) and stat("./",buf) give different results: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • See sys/stat.h, for general portability problems with struct stat.
  • Cygwin's stat function sometimes sets errno to EACCES when ENOENT would be more appropriate.
  • Because of the definition of struct stat, it is not possible to portably replace stat via an object-like macro. Therefore, expressions such as (islnk ? lstat : stat) (name, buf) are not portable, and should instead be written islnk ? lstat (name, buf) : stat (name, buf).

Next: statvfs Prev: sscanf Up: Function Substitutes Top: Top


statvfs -- GNU Gnulib

Next: stderr Prev: stat Up: Function Substitutes Top: Top

9.990. statvfs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/statvfs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, mingw, MSVC 14.
  • This function can hang if it stats all preceding entries in /proc/mounts, and any of those file systems are hard-mounted and not available. This affects Linux < 2.6.36.
  • On platforms where f_blocks in `struct statvfs' is a 32-bit value, this function may not work correctly on files systems larger than 4 TiB. The fix is to use the AC_SYS_LARGEFILE macro. This affects glibc/Hurd, HP-UX 11, Solaris.
Gnulib provides a module fsusage that provides similar information as statvfs.

Next: stderr Prev: stat Up: Function Substitutes Top: Top


stderr -- GNU Gnulib

Next: stdin Prev: statvfs Up: Function Substitutes Top: Top

9.991. stderr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stderr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • stderr is created in 32-bit mode instead of 64-bit mode: Cygwin 1.5.x. One workaround is to use freopen(NULL, ``r+'', stderr) on Cygwin 1.5.21 or newer. Another is to use the gnulib ftello module and do ftello(stderr).
  • POSIX states that a setuid application can guarantee that fd 2 is open, but some systems guarantee this even for non-setuid programs. If an application is executed with fd 2 closed, use of stderr can affect an unrelated file that happened to be assigned to fd 2. The gnulib *-safer modules may be used to guarantee that fd 2 stays reserved for stderr.

Next: stdin Prev: statvfs Up: Function Substitutes Top: Top


stdin -- GNU Gnulib

Next: stdout Prev: stderr Up: Function Substitutes Top: Top

9.992. stdin

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stdin.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • stdin is created in 32-bit mode instead of 64-bit mode: Cygwin 1.5.x. One workaround is to use freopen(NULL, ``r'', stdin) on Cygwin 1.5.21 or newer. Another is to use the gnulib ftello module and do ftello(stdin).
  • POSIX states that a setuid application can guarantee that fd 0 is open, but some systems guarantee this even for non-setuid programs. If an application is executed with fd 0 closed, use of stdin can affect an unrelated file that happened to be assigned to fd 0. The gnulib *-safer modules may be used to guarantee that fd 0 stays reserved for stdin.

Next: stdout Prev: stderr Up: Function Substitutes Top: Top


stdout -- GNU Gnulib

Next: stpcpy Prev: stdin Up: Function Substitutes Top: Top

9.993. stdout

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stdout.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • stdout is created in 32-bit mode instead of 64-bit mode: Cygwin 1.5.x. One workaround is to use freopen(NULL, ``w'', stdout) on Cygwin 1.5.21 or newer. Another is to use the gnulib ftello module and do ftello(stdout).
  • POSIX states that a setuid application can guarantee that fd 1 is open, but some systems guarantee this even for non-setuid programs. If an application is executed with fd 1 closed, use of stdout can affect an unrelated file that happened to be assigned to fd 1. The gnulib *-safer modules may be used to guarantee that fd 1 stays reserved for stdout.

Next: stpcpy Prev: stdin Up: Function Substitutes Top: Top


stpcpy -- GNU Gnulib

Next: stpncpy Prev: stdout Up: Function Substitutes Top: Top

9.994. stpcpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stpcpy.html

Gnulib module: stpcpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: stpncpy Prev: stdout Up: Function Substitutes Top: Top


stpncpy -- GNU Gnulib

Next: strcasecmp Prev: stpcpy Up: Function Substitutes Top: Top

9.995. stpncpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/stpncpy.html

Gnulib module: stpncpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has an incompatible return value on some platforms: AIX 5.1.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: strcasecmp Prev: stpcpy Up: Function Substitutes Top: Top


strcasecmp -- GNU Gnulib

Next: strcasecmp_l Prev: stpncpy Up: Function Substitutes Top: Top

9.996. strcasecmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcasecmp.html

Gnulib module: strcase

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides an alternative function mbscasecmp that does a case insensitive comparison of character strings and that works in all locales.

Next: strcasecmp_l Prev: stpncpy Up: Function Substitutes Top: Top


strcasecmp_l -- GNU Gnulib

Next: strcat Prev: strcasecmp Up: Function Substitutes Top: Top

9.997. strcasecmp_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcasecmp_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strcat Prev: strcasecmp Up: Function Substitutes Top: Top


strcat -- GNU Gnulib

Next: strchr Prev: strcasecmp_l Up: Function Substitutes Top: Top

9.998. strcat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcat.html

Gnulib module: string

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: strchr Prev: strcasecmp_l Up: Function Substitutes Top: Top


strchr -- GNU Gnulib

Next: strcmp Prev: strcat Up: Function Substitutes Top: Top

9.999. strchr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strchr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in some multibyte locales. Gnulib provides an alternative function mbschr that works on character strings in all locales.

Next: strcmp Prev: strcat Up: Function Substitutes Top: Top


strcmp -- GNU Gnulib

Next: strcoll Prev: strchr Up: Function Substitutes Top: Top

9.1000. strcmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: strcoll Prev: strchr Up: Function Substitutes Top: Top


strcoll -- GNU Gnulib

Next: strcoll_l Prev: strcmp Up: Function Substitutes Top: Top

9.1001. strcoll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcoll.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function fails, setting errno to EILSEQ, on Solaris 10, in UTF-8 locales, when at least one of the strings contains a Unicode character in a block that was not assigned in Unicode 4.0.

Next: strcoll_l Prev: strcmp Up: Function Substitutes Top: Top


strcoll_l -- GNU Gnulib

Next: strcpy Prev: strcoll Up: Function Substitutes Top: Top

9.1002. strcoll_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcoll_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strcpy Prev: strcoll Up: Function Substitutes Top: Top


strcpy -- GNU Gnulib

Next: strcspn Prev: strcoll_l Up: Function Substitutes Top: Top

9.1003. strcpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcpy.html

Gnulib module: string

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: strcpy (dst, src) is only safe to use when you can guarantee that there are at least strlen (src) + 1 bytes allocated at dst.

Next: strcspn Prev: strcoll_l Up: Function Substitutes Top: Top


strcspn -- GNU Gnulib

Next: strdup Prev: strcpy Up: Function Substitutes Top: Top

9.1004. strcspn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strcspn.html

Gnulib module: strcspn

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides an alternative function mbscspn that works on character strings in all locales.

Next: strdup Prev: strcpy Up: Function Substitutes Top: Top


strdup -- GNU Gnulib

Next: strerror Prev: strcspn Up: Function Substitutes Top: Top

9.1005. strdup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strdup.html

Gnulib module: strdup or strdup-posix

Portability problems fixed by either Gnulib module strdup or strdup-posix:

  • This function is missing on some old platforms.
  • This function has no prototype in <string.h> on some old platforms.
Portability problems fixed by Gnulib module strdup-posix:
  • Upon failure, the function does not set errno to ENOMEM on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: strerror Prev: strcspn Up: Function Substitutes Top: Top


strerror -- GNU Gnulib

Next: strerror_l Prev: strdup Up: Function Substitutes Top: Top

9.1006. strerror

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strerror.html

Gnulib module: strerror

Portability problems fixed by Gnulib:

  • This function does not support the error values that are specified by POSIX but not defined by the system, on some platforms: OpenBSD 4.0, OSF/1 5.1, NonStop Kernel, Cygwin 1.5.x, mingw, MSVC 14.
  • This function reports failure for strerror(0) (by setting errno or using a string similar to out-of-range values), although POSIX requires this to leave errno unchanged and report success, on some platforms: FreeBSD 8.2, OpenBSD 4.7, Mac OS X 10.5.
  • This function fails to return a string for out-of-range integers on some platforms: HP-UX 11, IRIX 6.5, Solaris 8. (Some return NULL which is a POSIX violation, others return the empty string which is valid but not as useful); this can still cause bugs because most programs call strerror without setting and testing errno.)
Portability problems not fixed by Gnulib:

Next: strerror_l Prev: strdup Up: Function Substitutes Top: Top


strerror_l -- GNU Gnulib

Next: strerror_r Prev: strerror Up: Function Substitutes Top: Top

9.1007. strerror_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strerror_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strerror_r Prev: strerror Up: Function Substitutes Top: Top


strerror_r -- GNU Gnulib

Next: strfmon Prev: strerror_l Up: Function Substitutes Top: Top

9.1008. strerror_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strerror_r.html

Gnulib module: strerror_r-posix

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 3.0, Minix 3.1.8, HP-UX 11.23, IRIX 6.5, Solaris 9, mingw, MSVC 14.
  • glibc and Cygwin have an incompatible version of this function. The POSIX compliant code
    char *s = (strerror_r (err, buf, buflen) == 0 ? buf : NULL);
    is essentially equivalent to this code using the glibc function:
    char *s = strerror_r (err, buf, buflen);
  • This function clobbers the strerror buffer on some platforms: Cygwin 1.7.9.
  • This function is sometimes not declared in <string.h> on some platforms: glibc 2.8, OSF/1 5.1.
  • The third argument is of type int instead of size_t on some platforms: AIX 5.1, OSF/1 5.1.
  • When this function fails, it returns -1 and sets errno, instead of returning the error number, on some platforms: glibc 2.12 with -D_POSIX_C_SOURCE=200112L, AIX 6.1, OSF/1 5.1.
  • When this function fails, it corrupts errno, on some platforms: Solaris 10.
  • This function does not support many error values defined in <errno.h> on some platforms: MSVC 14.
  • This function does not support the error values that are specified by POSIX but not defined by the system, on some platforms: OpenBSD 4.0, OSF/1 5.1, NonStop Kernel, Cygwin 1.5.x.
  • This function reports failure for strerror_r(0, buf, len), although POSIX requires this to succeed, on some platforms: FreeBSD 8.2.
  • This function produces a different string for 0 than strerror on some platforms: Mac OS X 10.5.
  • This function always fails when the third argument is less than 80 on some platforms: HP-UX 11.31.
  • When the buffer is too small and the value is in range, this function does not fail, but instead truncates the result and returns 0 on some platforms: AIX 6.1, OSF/1 5.1.
  • When the value is not in range or the buffer is too small, this function fails to leave a NUL-terminated string in the buffer on some platforms: glibc 2.13, FreeBSD 8.2, Solaris 10.
  • When the value is out of range but the buffer is too small, this function does not always return the longest possible string on some platforms: OpenBSD 4.7.
Portability problems not fixed by Gnulib:

Next: strfmon Prev: strerror_l Up: Function Substitutes Top: Top


strfmon -- GNU Gnulib

Next: strfmon_l Prev: strerror_r Up: Function Substitutes Top: Top

9.1009. strfmon

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strfmon.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin 1.7.1, mingw, MSVC 14, BeOS.

Next: strfmon_l Prev: strerror_r Up: Function Substitutes Top: Top


strfmon_l -- GNU Gnulib

Next: strftime Prev: strfmon Up: Function Substitutes Top: Top

9.1010. strfmon_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strfmon_l.html

Gnulib module: strfmon_l

Portability problems fixed by Gnulib:

  • This function uses a wrong locale for the numbers on some platforms: glibc 2.23.
Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strftime Prev: strfmon Up: Function Substitutes Top: Top


strftime -- GNU Gnulib

Next: strftime_l Prev: strfmon_l Up: Function Substitutes Top: Top

9.1011. strftime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strftime.html

Gnulib module: strftime-fixes

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
Portability problems not fixed by Gnulib:
  • The Windows C runtime library (which is used by MinGW) does not support the %e specifier (and possibly the other more recent SUS specifiers too, i.e., %C, %D, %h, %n, %r, %R, %t, and %T).
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.
Extension: Gnulib offers a module `nstrftime' that provides an nstrftime function with various GNU extensions.

Next: strftime_l Prev: strfmon_l Up: Function Substitutes Top: Top


strftime_l -- GNU Gnulib

Next: strlen Prev: strftime Up: Function Substitutes Top: Top

9.1012. strftime_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strftime_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strlen Prev: strftime Up: Function Substitutes Top: Top


strlen -- GNU Gnulib

Next: strncasecmp Prev: strftime_l Up: Function Substitutes Top: Top

9.1013. strlen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strlen.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: strncasecmp Prev: strftime_l Up: Function Substitutes Top: Top


strncasecmp -- GNU Gnulib

Next: strncasecmp_l Prev: strlen Up: Function Substitutes Top: Top

9.1014. strncasecmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strncasecmp.html

Gnulib module: strcase

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides alternative functions mbsncasecmp and mbspcasecmp that do a case insensitive comparison of character strings and that work in all locales.

Next: strncasecmp_l Prev: strlen Up: Function Substitutes Top: Top


strncasecmp_l -- GNU Gnulib

Next: strncat Prev: strncasecmp Up: Function Substitutes Top: Top

9.1015. strncasecmp_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strncasecmp_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strncat Prev: strncasecmp Up: Function Substitutes Top: Top


strncat -- GNU Gnulib

Next: strncmp Prev: strncasecmp_l Up: Function Substitutes Top: Top

9.1016. strncat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strncat.html

Gnulib module: strncat

Portability problems fixed by Gnulib:

  • This function dereferences too much memory on some platforms: Solaris 10 on SPARC, Solaris 11.0 on x86.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: strncmp Prev: strncasecmp_l Up: Function Substitutes Top: Top


strncmp -- GNU Gnulib

Next: strncpy Prev: strncat Up: Function Substitutes Top: Top

9.1017. strncmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strncmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: strncpy Prev: strncat Up: Function Substitutes Top: Top


strncpy -- GNU Gnulib

Next: strndup Prev: strncmp Up: Function Substitutes Top: Top

9.1018. strncpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strncpy.html

Gnulib module: string

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
Note: This function was designed for the use-case of filling a fixed-size record with a string, before writing it to a file. This function is not appropriate for copying a string into a bounded memory area, because you have no guarantee that the result will be NUL-terminated. Even if you add the NUL byte at the end yourself, this function is inefficient (as it spends time clearing unused memory) and will allow silent truncation to occur, which is not a good behavior for GNU programs. For more details, see https://meyering.net/crusade-to-eliminate-strncpy/.

Next: strndup Prev: strncmp Up: Function Substitutes Top: Top


strndup -- GNU Gnulib

Next: strnlen Prev: strncpy Up: Function Substitutes Top: Top

9.1019. strndup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strndup.html

Gnulib module: strndup

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function does not NUL-terminate the result on some platforms: AIX 5.1.
Portability problems not fixed by Gnulib:

Next: strnlen Prev: strncpy Up: Function Substitutes Top: Top


strnlen -- GNU Gnulib

Next: strpbrk Prev: strndup Up: Function Substitutes Top: Top

9.1020. strnlen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strnlen.html

Gnulib module: strnlen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, Interix 3.5.
  • This function is buggy on some platforms: AIX 4.3.
Portability problems not fixed by Gnulib:

Next: strpbrk Prev: strndup Up: Function Substitutes Top: Top


strpbrk -- GNU Gnulib

Next: strptime Prev: strnlen Up: Function Substitutes Top: Top

9.1021. strpbrk

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strpbrk.html

Gnulib module: strpbrk

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides an alternative function mbspbrk that works on character strings in all locales.

Next: strptime Prev: strnlen Up: Function Substitutes Top: Top


strptime -- GNU Gnulib

Next: strrchr Prev: strpbrk Up: Function Substitutes Top: Top

9.1022. strptime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strptime.html

Gnulib module: strptime

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: strrchr Prev: strpbrk Up: Function Substitutes Top: Top


strrchr -- GNU Gnulib

Next: strsignal Prev: strptime Up: Function Substitutes Top: Top

9.1023. strrchr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strrchr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in some multibyte locales. Gnulib provides an alternative function mbsrchr that works on character strings in all locales.

Next: strsignal Prev: strptime Up: Function Substitutes Top: Top


strsignal -- GNU Gnulib

Next: strspn Prev: strrchr Up: Function Substitutes Top: Top

9.1024. strsignal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strsignal.html

Gnulib module: strsignal

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

  • This function does not return a string for out-of-range numbers on some platforms: Solaris, AIX 5.1.

  • This function is declared in unistd.h instead of string.h on some platforms: NetBSD 5.0.
Portability problems not fixed by Gnulib:
  • This function returns const char * instead of char * on some platforms: cygwin 1.5.25.

Next: strspn Prev: strrchr Up: Function Substitutes Top: Top


strspn -- GNU Gnulib

Next: strstr Prev: strsignal Up: Function Substitutes Top: Top

9.1025. strspn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strspn.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides an alternative function mbsspn that works on character strings in all locales.

Next: strstr Prev: strsignal Up: Function Substitutes Top: Top


strstr -- GNU Gnulib

Next: strtod Prev: strspn Up: Function Substitutes Top: Top

9.1026. strstr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strstr.html

Gnulib module: strstr or strstr-simple

Portability problems fixed by either Gnulib module strstr-simple or strstr:

  • This function can trigger memchr bugs on some platforms: glibc 2.10.
  • This function can trigger false positives for long periodic needles on some platforms: glibc 2.12, Cygwin 1.7.7.
Portability problems fixed by Gnulib strstr:
  • This function has quadratic instead of linear worst-case complexity on some platforms: glibc 2.8, Mac OS X 10.5, FreeBSD 6.2, NetBSD 5.0, OpenBSD 4.0, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in most multibyte locales. Gnulib provides an alternative function mbsstr that works on character strings in all locales.

Next: strtod Prev: strspn Up: Function Substitutes Top: Top


strtod -- GNU Gnulib

Next: strtof Prev: strstr Up: Function Substitutes Top: Top

9.1027. strtod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtod.html

Gnulib module: strtod or strtod-obsolete

Portability problems fixed by either Gnulib module strtod or strtod-obsolete:

  • This function mis-parses strings with leading `+' on some old platforms: Old versions of Linux.

  • This function returns a wrong end pointer on some old platforms.

  • This function consumes whitespace even when there is nothing that should be parsed on some platforms: IRIX 6.5, OSF/1 5.1.

  • This function allows whitespace between `e' and the exponent on some platforms: HP-UX 11.11, IRIX 6.5, OSF/1 4.0.

  • This function returns the wrong end pointer for `-0x' on some platforms: glibc 2.4, Mac OS X 10.5, FreeBSD 6.2, AIX 7.1, Cygwin < 1.5.25-11.

  • This function returns +0.0 (not -0.0) for `-0' on some platforms: IRIX 6.5, OSF/1 4.0.

  • This function fails to parse Infinities and plain NaNs on some platforms: OpenBSD 4.0, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 14.

  • This function fails to parse `NaN()' on some platforms: glibc-2.3.6, Mac OS X 10.5, FreeBSD 6.2, OpenBSD 4.0, AIX 7.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Cygwin < 1.5.25-11, mingw, MSVC 14.

  • This function fails to parse `NaN(n-char-sequence)' on some platforms: OpenBSD 4.0, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

  • This function parses `NaN(n-char-sequence)', but returns the wrong end pointer on some platforms: glibc-2.4, AIX 7.1.

  • This function fails to parse C99 hexadecimal floating point on some platforms: NetBSD 5.0, OpenBSD 4.0, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.

  • This function returns the wrong end pointer for `0x1p' on some platforms: AIX 7.1.
Portability problems fixed by Gnulib module strtod-obsolete:
  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:
  • This function returns +0.0 (not -0.0) for negative underflow on some platforms: glibc 2.7, Cygwin 1.5.x, mingw, MSVC 14.

  • This function cannot distinguish between ``nan'' and ``-nan'' on some platforms: glibc 2.7, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

  • This function fails to correctly parse very long strings on some platforms: Mac OS X 10.5, FreeBSD 6.2, NetBSD 5.0, OpenBSD 4.0, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14.

  • The replacement function does not always return correctly rounded results.

Next: strtof Prev: strstr Up: Function Substitutes Top: Top


strtof -- GNU Gnulib

Next: strtoimax Prev: strtod Up: Function Substitutes Top: Top

9.1028. strtof

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtof.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5, BeOS.

Next: strtoimax Prev: strtod Up: Function Substitutes Top: Top


strtoimax -- GNU Gnulib

Next: strtok Prev: strtof Up: Function Substitutes Top: Top

9.1029. strtoimax

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtoimax.html

Gnulib module: strtoimax

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, IRIX 6.5, OSF/1 5.1, Solaris 9, MSVC 9, Interix 3.5.
  • This function fails on valid input strings on some platforms: AIX 5.1.
Portability problems not fixed by Gnulib:
  • This function is only defined as a macro on some platforms: HP-UX 11.11.

Next: strtok Prev: strtof Up: Function Substitutes Top: Top


strtok -- GNU Gnulib

Next: strtok_r Prev: strtoimax Up: Function Substitutes Top: Top

9.1030. strtok

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtok.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: strtok_r Prev: strtoimax Up: Function Substitutes Top: Top


strtok_r -- GNU Gnulib

Next: strtol Prev: strtok Up: Function Substitutes Top: Top

9.1031. strtok_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtok_r.html

Gnulib module: strtok_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • This function crashes when invoked from code compiled with optimization enabled on some platforms: glibc 2.7.
Portability problems not fixed by Gnulib:
  • This function cannot work correctly on character strings in multibyte locales. Gnulib provides an alternative function mbstok_r that works on character strings in all locales.

Next: strtol Prev: strtok Up: Function Substitutes Top: Top


strtol -- GNU Gnulib

Next: strtold Prev: strtok_r Up: Function Substitutes Top: Top

9.1032. strtol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtol.html

Gnulib module: strtol

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:

Next: strtold Prev: strtok_r Up: Function Substitutes Top: Top


strtold -- GNU Gnulib

Next: strtoll Prev: strtol Up: Function Substitutes Top: Top

9.1033. strtold

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtold.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: strtoll Prev: strtol Up: Function Substitutes Top: Top


strtoll -- GNU Gnulib

Next: strtoul Prev: strtold Up: Function Substitutes Top: Top

9.1034. strtoll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtoll.html

Gnulib module: strtoll

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, OSF/1 5.1, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: strtoul Prev: strtold Up: Function Substitutes Top: Top


strtoul -- GNU Gnulib

Next: strtoull Prev: strtoll Up: Function Substitutes Top: Top

9.1035. strtoul

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtoul.html

Gnulib module: strtoul

Portability problems fixed by Gnulib:

  • This function is missing on some old platforms.
Portability problems not fixed by Gnulib:

Next: strtoull Prev: strtoll Up: Function Substitutes Top: Top


strtoull -- GNU Gnulib

Next: strtoumax Prev: strtoul Up: Function Substitutes Top: Top

9.1036. strtoull

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtoull.html

Gnulib module: strtoull

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.11, OSF/1 5.1, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: strtoumax Prev: strtoul Up: Function Substitutes Top: Top


strtoumax -- GNU Gnulib

Next: strxfrm Prev: strtoull Up: Function Substitutes Top: Top

9.1037. strtoumax

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strtoumax.html

Gnulib module: strtoumax

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 9, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • This function is only defined as a macro on some platforms: HP-UX 11.11.

Next: strxfrm Prev: strtoull Up: Function Substitutes Top: Top


strxfrm -- GNU Gnulib

Next: strxfrm_l Prev: strtoumax Up: Function Substitutes Top: Top

9.1038. strxfrm

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strxfrm.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: strxfrm_l Prev: strtoumax Up: Function Substitutes Top: Top


strxfrm_l -- GNU Gnulib

Next: swab Prev: strxfrm Up: Function Substitutes Top: Top

9.1039. strxfrm_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/strxfrm_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: swab Prev: strxfrm Up: Function Substitutes Top: Top


swab -- GNU Gnulib

Next: swprintf Prev: strxfrm_l Up: Function Substitutes Top: Top

9.1040. swab

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/swab.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: swprintf Prev: strxfrm_l Up: Function Substitutes Top: Top


swprintf -- GNU Gnulib

Next: swscanf Prev: swab Up: Function Substitutes Top: Top

9.1041. swprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/swprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: MSVC 9.
  • This function is only defined as a macro on some platforms: MSVC 14.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • On Windows, this function does not take a buffer size as second argument.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: swscanf Prev: swab Up: Function Substitutes Top: Top


swscanf -- GNU Gnulib

Next: symlink Prev: swprintf Up: Function Substitutes Top: Top

9.1042. swscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/swscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: symlink Prev: swprintf Up: Function Substitutes Top: Top


symlink -- GNU Gnulib

Next: symlinkat Prev: swscanf Up: Function Substitutes Top: Top

9.1043. symlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/symlink.html

Gnulib module: symlink

Portability problems fixed by Gnulib:

  • On some systems, symlink(value,"name/") mistakenly creates a symlink: FreeBSD 7.2, AIX 7.1, Solaris 9.
  • This function is missing on some platforms; however, the replacement always fails with EPERM: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Some file systems do not support symbolic links.

Next: symlinkat Prev: swscanf Up: Function Substitutes Top: Top


symlinkat -- GNU Gnulib

Next: sync Prev: symlink Up: Function Substitutes Top: Top

9.1044. symlinkat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/symlinkat.html

Gnulib module: symlinkat

Portability problems fixed by Gnulib:

  • On some systems, symlinkat(value, fd, "name/") mistakenly creates a symlink: AIX 7.1.
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • Some platforms declare this function in stdio.h instead of unistd.h: Cygwin 1.7.1.
Portability problems not fixed by Gnulib:
  • This function always fails with `ENOSYS' on platforms that don't support symlinks: mingw, MSVC 14.

Next: sync Prev: symlink Up: Function Substitutes Top: Top


sync -- GNU Gnulib

Next: sysconf Prev: symlinkat Up: Function Substitutes Top: Top

9.1045. sync

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sync.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, Interix 3.5.

Next: sysconf Prev: symlinkat Up: Function Substitutes Top: Top


sysconf -- GNU Gnulib

Next: syslog Prev: sync Up: Function Substitutes Top: Top

9.1046. sysconf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/sysconf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: syslog Prev: sync Up: Function Substitutes Top: Top


syslog -- GNU Gnulib

Next: system Prev: sysconf Up: Function Substitutes Top: Top

9.1047. syslog

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/syslog.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: system Prev: sysconf Up: Function Substitutes Top: Top


system -- GNU Gnulib

Next: tan Prev: syslog Up: Function Substitutes Top: Top

9.1048. system

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/system.html

Gnulib module: system-posix

Portability problems fixed by Gnulib:

  • The macros WIFSIGNALED, WIFEXITED, WIFSTOPPED, WTERMSIG, WEXITSTATUS, WNOHANG, WUNTRACED, WSTOPSIG are not defined in <stdlib.h> (only in <sys/wait.h>) on some platforms: MirBSD 10.
Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), the command processor used by the system function is cmd.exe, not /bin/sh. Accordingly, the rules for quoting shell arguments containing spaces, quote or other special characters are different.

Next: tan Prev: syslog Up: Function Substitutes Top: Top


tan -- GNU Gnulib

Next: tanf Prev: system Up: Function Substitutes Top: Top

9.1049. tan

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tan.html

Gnulib module: tan

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: tanf Prev: system Up: Function Substitutes Top: Top


tanf -- GNU Gnulib

Next: tanh Prev: tan Up: Function Substitutes Top: Top

9.1050. tanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tanf.html

Gnulib module: tanf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: tanh Prev: tan Up: Function Substitutes Top: Top


tanh -- GNU Gnulib

Next: tanhf Prev: tanf Up: Function Substitutes Top: Top

9.1051. tanh

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tanh.html

Gnulib module: tanh

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: tanhf Prev: tanf Up: Function Substitutes Top: Top


tanhf -- GNU Gnulib

Next: tanhl Prev: tanh Up: Function Substitutes Top: Top

9.1052. tanhf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tanhf.html

Gnulib module: tanhf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 9.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
Portability problems not fixed by Gnulib:

Next: tanhl Prev: tanh Up: Function Substitutes Top: Top


tanhl -- GNU Gnulib

Next: tanl Prev: tanhf Up: Function Substitutes Top: Top

9.1053. tanhl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tanhl.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.

Next: tanl Prev: tanhf Up: Function Substitutes Top: Top


tanl -- GNU Gnulib

Next: tcdrain Prev: tanhl Up: Function Substitutes Top: Top

9.1054. tanl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tanl.html

Gnulib module: tanl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, Interix 3.5, BeOS.
  • This function is only defined as a macro with arguments on some platforms: MSVC 14.
  • This function is not declared on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:

Next: tcdrain Prev: tanhl Up: Function Substitutes Top: Top


tcdrain -- GNU Gnulib

Next: tcflow Prev: tanl Up: Function Substitutes Top: Top

9.1055. tcdrain

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcdrain.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • On some platforms, tcdrain on a non-tty fails with errno set to EINVAL or, on Mac OS X, also EOPNOTSUPP or ENODEV, rather than ENOTTY.

Next: tcflow Prev: tanl Up: Function Substitutes Top: Top


tcflow -- GNU Gnulib

Next: tcflush Prev: tcdrain Up: Function Substitutes Top: Top

9.1056. tcflow

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcflow.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: tcflush Prev: tcdrain Up: Function Substitutes Top: Top


tcflush -- GNU Gnulib

Next: tcgetattr Prev: tcflow Up: Function Substitutes Top: Top

9.1057. tcflush

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcflush.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • On some platforms, tcflush of TCIFLUSH on a non-tty fails with errno set to EINVAL rather than ENOTTY.
  • On some platforms, tcflush of TCOFLUSH on a non-tty fails with errno set to EINVAL or, on IRIX, also ENOSYS, or, on Mac OS X, also EOPNOTSUPP or ENODEV, rather than ENOTTY.

Next: tcgetattr Prev: tcflow Up: Function Substitutes Top: Top


tcgetattr -- GNU Gnulib

Next: tcgetpgrp Prev: tcflush Up: Function Substitutes Top: Top

9.1058. tcgetattr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcgetattr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: tcgetpgrp Prev: tcflush Up: Function Substitutes Top: Top


tcgetpgrp -- GNU Gnulib

Next: tcgetsid Prev: tcgetattr Up: Function Substitutes Top: Top

9.1059. tcgetpgrp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcgetpgrp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: tcgetsid Prev: tcgetattr Up: Function Substitutes Top: Top


tcgetsid -- GNU Gnulib

Next: tcsendbreak Prev: tcgetpgrp Up: Function Substitutes Top: Top

9.1060. tcgetsid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcgetsid.html

Gnulib module: tcgetsid

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, OpenBSD 4.5, Minix 3.1.8, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared on some platforms: OSF/1 5.1.
  • The declaration of this function in C++ compilation units has C++ linkage, not C linkage, on some platforms: HP-UX 11.00.
Portability problems not fixed by Gnulib:
  • This function always fails on some platforms: FreeBSD 6.0, Cygwin 1.7.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function returns int instead of pid_t on some platforms: Cygwin 1.7.11.

Next: tcsendbreak Prev: tcgetpgrp Up: Function Substitutes Top: Top


tcsendbreak -- GNU Gnulib

Next: tcsetattr Prev: tcgetsid Up: Function Substitutes Top: Top

9.1061. tcsendbreak

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcsendbreak.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: tcsetattr Prev: tcgetsid Up: Function Substitutes Top: Top


tcsetattr -- GNU Gnulib

Next: tcsetpgrp Prev: tcsendbreak Up: Function Substitutes Top: Top

9.1062. tcsetattr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcsetattr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: tcsetpgrp Prev: tcsendbreak Up: Function Substitutes Top: Top


tcsetpgrp -- GNU Gnulib

Next: tdelete Prev: tcsetattr Up: Function Substitutes Top: Top

9.1063. tcsetpgrp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tcsetpgrp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: tdelete Prev: tcsetattr Up: Function Substitutes Top: Top


tdelete -- GNU Gnulib

Next: telldir Prev: tcsetpgrp Up: Function Substitutes Top: Top

9.1064. tdelete

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tdelete.html

Gnulib module: tsearch

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
  • tdelete returns NULL when removing the last element of a tree on some platforms: OpenBSD 4.0.
Portability problems not fixed by Gnulib:

Next: telldir Prev: tcsetpgrp Up: Function Substitutes Top: Top


telldir -- GNU Gnulib

Next: tempnam Prev: tdelete Up: Function Substitutes Top: Top

9.1065. telldir

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/telldir.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: MSVC 14, BeOS.
  • On platforms where long int is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro (only on Mac OS X systems).

Next: tempnam Prev: tdelete Up: Function Substitutes Top: Top


tempnam -- GNU Gnulib

Next: tfind Prev: telldir Up: Function Substitutes Top: Top

9.1066. tempnam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tempnam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.
  • This function is not appropriate for creating temporary files. (It has security risks.) Better use mkstemp instead.

Next: tfind Prev: telldir Up: Function Substitutes Top: Top


tfind -- GNU Gnulib

Next: tgamma Prev: tempnam Up: Function Substitutes Top: Top

9.1067. tfind

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tfind.html

Gnulib module: tsearch

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: tgamma Prev: tempnam Up: Function Substitutes Top: Top


tgamma -- GNU Gnulib

Next: tgammaf Prev: tfind Up: Function Substitutes Top: Top

9.1068. tgamma

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tgamma.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5, BeOS.

Next: tgammaf Prev: tfind Up: Function Substitutes Top: Top


tgammaf -- GNU Gnulib

Next: tgammal Prev: tgamma Up: Function Substitutes Top: Top

9.1069. tgammaf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tgammaf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, MSVC 9, Interix 3.5, BeOS.

Next: tgammal Prev: tgamma Up: Function Substitutes Top: Top


tgammal -- GNU Gnulib

Next: time Prev: tgammaf Up: Function Substitutes Top: Top

9.1070. tgammal

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tgammal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.

Next: time Prev: tgammaf Up: Function Substitutes Top: Top


time -- GNU Gnulib

Next: timer_create Prev: tgammal Up: Function Substitutes Top: Top

9.1071. time

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/time.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: timer_create Prev: tgammal Up: Function Substitutes Top: Top


timer_create -- GNU Gnulib

Next: timer_delete Prev: time Up: Function Substitutes Top: Top

9.1072. timer_create

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timer_create.html

Gnulib module: timer-time

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.4, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS, Tandem/NSK.
  • This function fails with ENOSYS on some platforms: OpenBSD 4.9.

Next: timer_delete Prev: time Up: Function Substitutes Top: Top


timer_delete -- GNU Gnulib

Next: timer_getoverrun Prev: timer_create Up: Function Substitutes Top: Top

9.1073. timer_delete

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timer_delete.html

Gnulib module: timer-time

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.4, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS, Tandem/NSK.
  • This function fails with ENOSYS on some platforms: OpenBSD 4.9.

Next: timer_getoverrun Prev: timer_create Up: Function Substitutes Top: Top


timer_getoverrun -- GNU Gnulib

Next: timer_gettime Prev: timer_delete Up: Function Substitutes Top: Top

9.1074. timer_getoverrun

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timer_getoverrun.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, IRIX 5.3, Solaris 2.4, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: timer_gettime Prev: timer_delete Up: Function Substitutes Top: Top


timer_gettime -- GNU Gnulib

Next: timer_settime Prev: timer_getoverrun Up: Function Substitutes Top: Top

9.1075. timer_gettime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timer_gettime.html

Gnulib module: timer-time

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.4, Minix 3.1.8, IRIX 5.3, mingw, MSVC 14, Interix 3.5, BeOS, Tandem/NSK.
  • This function fails with ENOSYS on some platforms: OpenBSD 4.9.

Next: timer_settime Prev: timer_getoverrun Up: Function Substitutes Top: Top


timer_settime -- GNU Gnulib

Next: times Prev: timer_gettime Up: Function Substitutes Top: Top

9.1076. timer_settime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timer_settime.html

Gnulib module: timer-time

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.4, Minix 3.1.8, IRIX 5.3, Solaris 2.4, mingw, MSVC 14, Interix 3.5, BeOS, Tandem/NSK.
  • This function fails with ENOSYS on some platforms: OpenBSD 4.9.

Next: times Prev: timer_gettime Up: Function Substitutes Top: Top


times -- GNU Gnulib

Next: timezone Prev: timer_settime Up: Function Substitutes Top: Top

9.1077. times

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/times.html

Gnulib module: times

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • There is no function on Windows to measure consumed process child times, thus the tms_cutime and tms_cstime will always be 0 when the module is used.

Next: timezone Prev: timer_settime Up: Function Substitutes Top: Top


timezone -- GNU Gnulib

Next: tmpfile Prev: times Up: Function Substitutes Top: Top

9.1078. timezone

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/timezone.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: IRIX 6.5, OSF/1 5.1, mingw.
  • The address of this variable is not a compile-time constant on some platforms: mingw.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.
A more portable way of getting the UTC offset is to use strftime with the %z format. See strftime.

Next: tmpfile Prev: times Up: Function Substitutes Top: Top


tmpfile -- GNU Gnulib

Next: tmpnam Prev: timezone Up: Function Substitutes Top: Top

9.1079. tmpfile

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tmpfile.html

Gnulib module: tmpfile

Portability problems fixed by Gnulib:

  • This function often fails for trivial reasons on some platforms: mingw, MSVC 14.
  • On platforms where off_t is a 32-bit type, tmpfile may not work correctly to create files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:

Next: tmpnam Prev: timezone Up: Function Substitutes Top: Top


tmpnam -- GNU Gnulib

Next: toascii Prev: tmpfile Up: Function Substitutes Top: Top

9.1080. tmpnam

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tmpnam.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is not appropriate for creating temporary files. (It has security risks.) Better use mkstemp instead.

Next: toascii Prev: tmpfile Up: Function Substitutes Top: Top


toascii -- GNU Gnulib

Next: tolower Prev: tmpnam Up: Function Substitutes Top: Top

9.1081. toascii

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/toascii.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:

Next: tolower Prev: tmpnam Up: Function Substitutes Top: Top


tolower -- GNU Gnulib

Next: tolower_l Prev: toascii Up: Function Substitutes Top: Top

9.1082. tolower

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tolower.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: tolower_l Prev: toascii Up: Function Substitutes Top: Top


tolower_l -- GNU Gnulib

Next: toupper Prev: tolower Up: Function Substitutes Top: Top

9.1083. tolower_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tolower_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: toupper Prev: tolower Up: Function Substitutes Top: Top


toupper -- GNU Gnulib

Next: toupper_l Prev: tolower_l Up: Function Substitutes Top: Top

9.1084. toupper

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/toupper.html

Gnulib module: ctype

Portability problems fixed by Gnulib:

  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: toupper_l Prev: tolower_l Up: Function Substitutes Top: Top


toupper_l -- GNU Gnulib

Next: towctrans Prev: toupper Up: Function Substitutes Top: Top

9.1085. toupper_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/toupper_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: towctrans Prev: toupper Up: Function Substitutes Top: Top


towctrans -- GNU Gnulib

Next: towctrans_l Prev: toupper_l Up: Function Substitutes Top: Top

9.1086. towctrans

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towctrans.html

Gnulib module: towctrans

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.5.1, mingw, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: towctrans_l Prev: toupper_l Up: Function Substitutes Top: Top


towctrans_l -- GNU Gnulib

Next: towlower Prev: towctrans Up: Function Substitutes Top: Top

9.1087. towctrans_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towctrans_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: towlower Prev: towctrans Up: Function Substitutes Top: Top


towlower -- GNU Gnulib

Next: towlower_l Prev: towctrans_l Up: Function Substitutes Top: Top

9.1088. towlower

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towlower.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
  • This function returns values of which the upper 16 bits are incorrect on some platforms: mingw.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: towlower_l Prev: towctrans_l Up: Function Substitutes Top: Top


towlower_l -- GNU Gnulib

Next: towupper Prev: towlower Up: Function Substitutes Top: Top

9.1089. towlower_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towlower_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: towupper Prev: towlower Up: Function Substitutes Top: Top


towupper -- GNU Gnulib

Next: towupper_l Prev: towlower_l Up: Function Substitutes Top: Top

9.1090. towupper

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towupper.html

Gnulib module: wctype-h

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
  • This function returns values of which the upper 16 bits are incorrect on some platforms: mingw.
  • This function cannot be called from plain inline or extern inline functions on some platforms: OS X 10.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: towupper_l Prev: towlower_l Up: Function Substitutes Top: Top


towupper_l -- GNU Gnulib

Next: trunc Prev: towupper Up: Function Substitutes Top: Top

9.1091. towupper_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/towupper_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: trunc Prev: towupper Up: Function Substitutes Top: Top


trunc -- GNU Gnulib

Next: truncate Prev: towupper_l Up: Function Substitutes Top: Top

9.1092. trunc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/trunc.html

Gnulib module: trunc or trunc-ieee

Portability problems fixed by either Gnulib module trunc or trunc-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.8.
Portability problems fixed by Gnulib module trunc-ieee:
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: truncate Prev: towupper_l Up: Function Substitutes Top: Top


truncate -- GNU Gnulib

Next: truncf Prev: trunc Up: Function Substitutes Top: Top

9.1093. truncate

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/truncate.html

Gnulib module: truncate

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
  • On platforms where off_t is a 32-bit type, this function is not applicable to arbitrary lengths for files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.
Portability problems not fixed by Gnulib:

Next: truncf Prev: trunc Up: Function Substitutes Top: Top


truncf -- GNU Gnulib

Next: truncl Prev: truncate Up: Function Substitutes Top: Top

9.1094. truncf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/truncf.html

Gnulib module: truncf or truncf-ieee

Portability problems fixed by either Gnulib module truncf or truncf-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 9, MSVC 9, Interix 3.5.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.8.
Portability problems fixed by Gnulib module truncf-ieee:
  • This function returns a positive zero for a minus zero argument on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: truncl Prev: truncate Up: Function Substitutes Top: Top


truncl -- GNU Gnulib

Next: tsearch Prev: truncf Up: Function Substitutes Top: Top

9.1095. truncl

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/truncl.html

Gnulib module: truncl or truncl-ieee

Portability problems fixed by either Gnulib module truncl or truncl-ieee:

  • This function is missing on some platforms: FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.8.
  • This function crashes on some platforms: OSF/1 4.0.
Portability problems fixed by Gnulib module truncl-ieee:
  • This function returns a positive zero for an argument between -1 and 0 on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: tsearch Prev: truncf Up: Function Substitutes Top: Top


tsearch -- GNU Gnulib

Next: ttyname Prev: truncl Up: Function Substitutes Top: Top

9.1096. tsearch

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tsearch.html

Gnulib module: tsearch

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: ttyname Prev: truncl Up: Function Substitutes Top: Top


ttyname -- GNU Gnulib

Next: ttyname_r Prev: tsearch Up: Function Substitutes Top: Top

9.1097. ttyname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ttyname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: ttyname_r Prev: tsearch Up: Function Substitutes Top: Top


ttyname_r -- GNU Gnulib

Next: twalk Prev: ttyname Up: Function Substitutes Top: Top

9.1098. ttyname_r

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ttyname_r.html

Gnulib module: ttyname_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: NetBSD 3.0, Minix 3.1.8, mingw, MSVC 14, BeOS.
  • This function is not declared unless _REENTRANT is defined, on some platforms: HP-UX 11.
  • This function has an incompatible declaration on some platforms: Mac OS X 10.4, Solaris 11.3 (when _POSIX_PTHREAD_SEMANTICS is not defined).
  • This function ignores the size argument, thus overwriting memory after the buffer, on some platforms: OSF/1 5.1.
  • This function refuses to do anything when the output buffer is less than 128 bytes large, on some platforms: Solaris 11 2010-11.
Portability problems not fixed by Gnulib:

Next: twalk Prev: ttyname Up: Function Substitutes Top: Top


twalk -- GNU Gnulib

Next: tzname Prev: ttyname_r Up: Function Substitutes Top: Top

9.1099. twalk

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/twalk.html

Gnulib module: tsearch

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: tzname Prev: ttyname_r Up: Function Substitutes Top: Top


tzname -- GNU Gnulib

Next: tzset Prev: twalk Up: Function Substitutes Top: Top

9.1100. tzname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tzname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: IRIX 6.5, OSF/1 5.1, mingw.
  • The address of this variable is not a compile-time constant on some platforms: Cygwin, mingw.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones supported by GNU or specified by POSIX. See tzset.
A more portable way of getting the time zone abbreviation is to use strftime with the %Z format. See strftime.

Next: tzset Prev: twalk Up: Function Substitutes Top: Top


tzset -- GNU Gnulib

Next: ulimit Prev: tzname Up: Function Substitutes Top: Top

9.1101. tzset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/tzset.html

Gnulib module: tzset

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
  • This function clobbers the buffer used by the localtime function on some platforms: Solaris 2.6.
Portability problems not fixed by Gnulib:
  • Native Windows platforms (mingw, MSVC) support only a subset of POSIX-specified values for the @env{TZ} environment variable, consisting of a time zone abbreviation containing exactly three ASCII letters with no daylight saving time or angle brackets, and with no support for tz database settings like TZ='America/New_York'. Even this subset does not work on applications built via the Universal Windows Platform, as it does not make environment variables like @env{TZ} available to applications.

Next: ulimit Prev: tzname Up: Function Substitutes Top: Top


ulimit -- GNU Gnulib

Next: umask Prev: tzset Up: Function Substitutes Top: Top

9.1102. ulimit

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ulimit.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: umask Prev: tzset Up: Function Substitutes Top: Top


umask -- GNU Gnulib

Next: uname Prev: ulimit Up: Function Substitutes Top: Top

9.1103. umask

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/umask.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: uname Prev: ulimit Up: Function Substitutes Top: Top


uname -- GNU Gnulib

Next: ungetc Prev: umask Up: Function Substitutes Top: Top

9.1104. uname

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/uname.html

Gnulib module: uname

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: ungetc Prev: umask Up: Function Substitutes Top: Top


ungetc -- GNU Gnulib

Next: ungetwc Prev: uname Up: Function Substitutes Top: Top

9.1105. ungetc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ungetc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.

Next: ungetwc Prev: uname Up: Function Substitutes Top: Top


ungetwc -- GNU Gnulib

Next: unlink Prev: ungetc Up: Function Substitutes Top: Top

9.1106. ungetwc

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/ungetwc.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: unlink Prev: ungetc Up: Function Substitutes Top: Top


unlink -- GNU Gnulib

Next: unlinkat Prev: ungetwc Up: Function Substitutes Top: Top

9.1107. unlink

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/unlink.html

Gnulib module: unlink

Portability problems fixed by Gnulib:

  • Some systems mistakenly succeed on unlink("link-to-file/"): GNU/Hurd, FreeBSD 7.2, AIX 7.1, Solaris 9.
  • On Mac OS X 10.10, in a writable HFS mount, unlink("..") succeeds without doing anything.
Portability problems not fixed by Gnulib:
  • Some systems allow a superuser to unlink directories, even though this can cause file system corruption. The error given if a process is not permitted to unlink directories varies across implementations; it is not always the POSIX value of EPERM. Meanwhile, if a process has the ability to unlink directories, POSIX requires that unlink("symlink-to-dir/") remove dir and leave symlink-to-dir dangling; this behavior is counter-intuitive. The gnulib module unlinkdir can help determine whether code must be cautious of unlinking directories.
  • Removing an open file is non-portable: On Unix this allows the programs that have the file already open to continue working with it; the file's storage is only freed when the no process has the file open any more. On Windows, the attempt to remove an open file fails.

Next: unlinkat Prev: ungetwc Up: Function Substitutes Top: Top


unlinkat -- GNU Gnulib

Next: unlockpt Prev: unlink Up: Function Substitutes Top: Top

9.1108. unlinkat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/unlinkat.html

Gnulib module: unlinkat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not safe to be used in libraries and is not multithread-safe.
  • On Mac OS X 10.10, in a writable HFS mount, unlinkat(fd, "..", 0) succeeds without doing anything.
  • Some systems mistakenly succeed on unlinkat(fd,"file/",flag): GNU/Hurd, Solaris 9.
  • Some platforms declare this function in fcntl.h instead of unistd.h: Cygwin 1.7.1.
Portability problems not fixed by Gnulib:
  • When unlinkat(fd,name,AT_REMOVEDIR) fails because the specified directory is not empty, the errno value is system dependent.
  • POSIX requires that unlinkdir(fd,"link-to-empty/",AT_REMOVEDIR) remove empty and leave link-to-empty as a dangling symlink. This is counter-intuitive, so some systems fail with ENOTDIR instead: glibc
  • Some systems allow a superuser to unlink directories, even though this can cause file system corruption. The error given if a process is not permitted to unlink directories varies across implementations; it is not always the POSIX value of EPERM. Meanwhile, if a process has the ability to unlink directories, POSIX requires that unlinkat(fd,"symlink-to-dir/",0) remove dir and leave symlink-to-dir dangling; this behavior is counter-intuitive. The gnulib module unlinkdir can help determine whether code must be cautious of unlinking directories.
  • Removing an open file is non-portable: On Unix this allows the programs that have the file already open to continue working with it; the file's storage is only freed when the no process has the file open any more. On Windows, the attempt to remove an open file fails.

Next: unlockpt Prev: unlink Up: Function Substitutes Top: Top


unlockpt -- GNU Gnulib

Next: unsetenv Prev: unlinkat Up: Function Substitutes Top: Top

9.1109. unlockpt

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/unlockpt.html

Gnulib module: unlockpt

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • This function is not declared on some platforms: IRIX 5.3.
  • This function reports success for invalid file descriptors on some platforms: NetBSD 5.1, Cygwin 1.7.9.

Next: unsetenv Prev: unlinkat Up: Function Substitutes Top: Top


unsetenv -- GNU Gnulib

Next: uselocale Prev: unlockpt Up: Function Substitutes Top: Top

9.1110. unsetenv

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/unsetenv.html

Gnulib module: unsetenv

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, Solaris 9, mingw, MSVC 14, BeOS.
  • This function is not declared on some platforms: OSF/1 5.1.
  • This function has the return type `void' instead of `int' on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 1.6, OpenBSD 3.8, OSF/1 5.1.
  • On some platforms, this function does not fail with `EINVAL' when passed an empty string or a string containing `=': FreeBSD 6.0, NetBSD 1.6, OpenBSD 4.7.
  • This function removes only the first value association for the given environment variable, not all of them, on some platforms: Solaris 11.3, Haiku.
Portability problems not fixed by Gnulib:
  • Older versions of POSIX required that unsetenv(NULL) gracefully fail with EINVAL, but not all implementations guarantee this, and the requirement was removed.

Next: uselocale Prev: unlockpt Up: Function Substitutes Top: Top


uselocale -- GNU Gnulib

Next: utime Prev: unsetenv Up: Function Substitutes Top: Top

9.1111. uselocale

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/uselocale.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: utime Prev: unsetenv Up: Function Substitutes Top: Top


utime -- GNU Gnulib

Next: utimensat Prev: uselocale Up: Function Substitutes Top: Top

9.1112. utime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/utime.html

Gnulib module: utime

Portability problems fixed by Gnulib:

  • The times that are set on the file are affected by the current time zone and by the DST flag of the current time zone on some platforms: mingw, MSVC 14 (when the environment variable TZ is set).
  • On some platforms, the prototype for utime omits const for the second argument: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On some old platforms (Sequent), utime (file, NULL) fails to set the file's timestamp to the current time.
  • On some platforms, this function mis-handles trailing slash: Solaris 9.
  • This function cannot set full timestamp resolution. Use utimensat(AT_FDCWD,file,times,0), or the gnulib module utimens, instead.

Next: utimensat Prev: uselocale Up: Function Substitutes Top: Top


utimensat -- GNU Gnulib

Next: utimes Prev: utime Up: Function Substitutes Top: Top

9.1113. utimensat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/utimensat.html

Gnulib module: utimensat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS. However, the replacement function may end up truncating timestamps to less resolution than supported by the file system. Furthermore, the replacement function is not safe to be used in libraries and is not multithread-safe.
  • This function returns a bogus value instead of failing with ENOSYS on some platforms: Linux kernel 2.6.21.
  • This function fails with ENOSYS if passed the flag AT_SYMLINK_NOFOLLOW on a regular file: Linux kernel 2.6.22.
  • When using UTIME_OMIT or UTIME_NOW, some systems require the tv_sec argument to be 0, and don't necessarily handle all file permissions in the manner required by POSIX: Linux kernel 2.6.25.
  • When using UTIME_OMIT for the modification time, but specifying an access time, some systems fail to update the change time: Linux kernel 2.6.32, Solaris 11.1.
  • Out-of-range values of tv_nsec do not lead to a failure on some platforms: Linux kernel 2.6.22.19 on hppa.
Portability problems not fixed by Gnulib:
  • On some platforms, timestamps of symbolic links cannot be modified, so the replacement fails with ENOSYS if passed the flag AT_SYMLINK_NOFOLLOW on a symlink.
  • The mere act of using lstat modifies the access time of symlinks on some platforms, so utimensat with AT_SYMLINK_NOFOLLOW can only effectively change modification time: Cygwin.
  • The mere act of using stat modifies the access time of directories on some platforms, so utimensat can only effectively change directory modification time: Cygwin 1.5.x.
The gnulib module fdutimensat provides a similar interface.

Next: utimes Prev: utime Up: Function Substitutes Top: Top


utimes -- GNU Gnulib

Next: va_arg Prev: utimensat Up: Function Substitutes Top: Top

9.1114. utimes

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/utimes.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • The declaration of this function lacks const in the second argument on some platforms: OSF/1 5.1.
  • On some platforms, this function mis-handles trailing slash: FreeBSD 7.2, Solaris 9.
  • This function cannot set full timestamp resolution. In particular, some platforms incorrectly round rather than truncate. Use utimensat(AT_FDCWD,file,times,0), or the gnulib module utimens, instead.
  • On some platforms, utimes (file, NULL) fails to set the file's timestamp to the current time: glibc 2.3.3.
  • On some platforms, utimes failed on read-only files when utime worked fine. glibc 2.2.5.
  • On OS/2, this function cannot set the timestamp to earlier than the year 1980 in local time.
  • On OS/2, this function cannot set the timestamp to an odd number of seconds.
  • On OS/2, this function does not work on an opened file.
Extension: Gnulib provides a module `utimens' that works around these problems and allows to set the time with nanosecond resolution (as far as supported by the file system).

Next: va_arg Prev: utimensat Up: Function Substitutes Top: Top


va_arg -- GNU Gnulib

Next: va_copy Prev: utimes Up: Function Substitutes Top: Top

9.1115. va_arg

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/va_arg.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • The second argument of va_arg must be a type that is invariant under the ``default argument promotions'' (ISO C 99 6.5.2.2 paragraph 6). This means that the following are not valid here:
    `float'
    Use `double' instead.
    `bool'
    Use `int' instead.
    Integer types smaller than `int'.
    Use `int' or `unsigned int' instead.
    This is a portability problem because you don't know the width of some abstract types like uid_t, gid_t, mode_t. So, instead of
    mode = va_arg (ap, mode_t);
    you have to write
    mode = (sizeof (mode_t) < sizeof (int)
        ? va_arg (ap, int)
        : va_arg (ap, mode_t));

Next: va_copy Prev: utimes Up: Function Substitutes Top: Top


va_copy -- GNU Gnulib

Next: va_end Prev: va_arg Up: Function Substitutes Top: Top

9.1116. va_copy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/va_copy.html

Gnulib module: stdarg

Portability problems fixed by Gnulib:

  • This macro is missing on some platforms: AIX 5.1 with cc or xlc, HP-UX 11 with cc, IRIX 6.5 with cc, OSF/1 5.1 with cc.
Portability problems not fixed by Gnulib:

Next: va_end Prev: va_arg Up: Function Substitutes Top: Top


va_end -- GNU Gnulib

Next: va_start Prev: va_copy Up: Function Substitutes Top: Top

9.1117. va_end

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/va_end.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: va_start Prev: va_copy Up: Function Substitutes Top: Top


va_start -- GNU Gnulib

Next: vdprintf Prev: va_end Up: Function Substitutes Top: Top

9.1118. va_start

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/va_start.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: vdprintf Prev: va_end Up: Function Substitutes Top: Top


vdprintf -- GNU Gnulib

Next: vfprintf Prev: va_start Up: Function Substitutes Top: Top

9.1119. vdprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vdprintf.html

Gnulib module: vdprintf or vdprintf-posix

Portability problems fixed by either Gnulib module vdprintf or vdprintf-posix:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.
Portability problems fixed by Gnulib module vdprintf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: BeOS.
  • printf of `long double' numbers is unsupported on some platforms: BeOS.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, BeOS.
  • This function does not support the `F' directive on some platforms: BeOS.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: BeOS.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, BeOS.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: vfprintf Prev: va_start Up: Function Substitutes Top: Top


vfprintf -- GNU Gnulib

Next: vfscanf Prev: vdprintf Up: Function Substitutes Top: Top

9.1120. vfprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vfprintf.html

Gnulib module: vfprintf-posix or stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module vfprintf-posix:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems fixed by Gnulib module stdio or vfprintf-posix, together with module nonblocking:
  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio or vfprintf-posix, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • Attempting to write to a read-only stream fails with EOF but does not set the error flag for ferror on some platforms: glibc 2.13, cygwin 1.7.9.

Next: vfscanf Prev: vdprintf Up: Function Substitutes Top: Top


vfscanf -- GNU Gnulib

Next: vfwprintf Prev: vfprintf Up: Function Substitutes Top: Top

9.1121. vfscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vfscanf.html

Gnulib module: vfscanf, nonblocking

Portability problems fixed by Gnulib module vfscanf, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, OSF/1 5.1, Solaris 8, Interix 3.5.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, this function doesn't support the hh, ll, j, t, z size specifiers.

Next: vfwprintf Prev: vfprintf Up: Function Substitutes Top: Top


vfwprintf -- GNU Gnulib

Next: vfwscanf Prev: vfscanf Up: Function Substitutes Top: Top

9.1122. vfwprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vfwprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: vfwscanf Prev: vfscanf Up: Function Substitutes Top: Top


vfwscanf -- GNU Gnulib

Next: vprintf Prev: vfwprintf Up: Function Substitutes Top: Top

9.1123. vfwscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vfwscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: vprintf Prev: vfwprintf Up: Function Substitutes Top: Top


vprintf -- GNU Gnulib

Next: vscanf Prev: vfwscanf Up: Function Substitutes Top: Top

9.1124. vprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vprintf.html

Gnulib module: vprintf-posix or stdio, nonblocking, sigpipe

Portability problems fixed by Gnulib module vprintf-posix:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems fixed by Gnulib module stdio or vprintf-posix, together with module nonblocking:
  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio or vprintf-posix, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • Attempting to write to a read-only stream fails with EOF but does not set the error flag for ferror on some platforms: glibc 2.13, cygwin 1.7.9.

Next: vscanf Prev: vfwscanf Up: Function Substitutes Top: Top


vscanf -- GNU Gnulib

Next: vsnprintf Prev: vprintf Up: Function Substitutes Top: Top

9.1125. vscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vscanf.html

Gnulib module: vscanf, nonblocking

Portability problems fixed by Gnulib module vscanf, together with module nonblocking:

  • When reading from a non-blocking pipe whose buffer is empty, this function fails with errno being set to EINVAL instead of EAGAIN on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 4.3.2, IRIX 6.5, OSF/1 5.1, Solaris 8.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, these functions don't support the hh, ll, j, t, z size specifiers.

Next: vsnprintf Prev: vprintf Up: Function Substitutes Top: Top


vsnprintf -- GNU Gnulib

Next: vsprintf Prev: vscanf Up: Function Substitutes Top: Top

9.1126. vsnprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vsnprintf.html

Gnulib module: vsnprintf or vsnprintf-posix

Portability problems fixed by either Gnulib module vsnprintf or vsnprintf-posix:

  • This function is missing on some platforms: IRIX 5.3, OSF/1 4.0, Solaris 2.5.1.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function overwrites memory even when a size argument of 1 is passed on some platforms: Linux libc5, BeOS.
  • This function does not return a byte count as specified in C99 on some platforms: HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw, MSVC 14.
Portability problems fixed by Gnulib module vsnprintf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
  • This function does not truncate the result as specified in C99 on some platforms: mingw, MSVC 14.
  • This function does not fully support the `n' directive on some platforms: HP-UX 11, mingw, MSVC 14.
  • This function overwrites memory even when a zero size argument is passed on some platforms: HP-UX 11, OSF/1 5.1.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: vsprintf Prev: vscanf Up: Function Substitutes Top: Top


vsprintf -- GNU Gnulib

Next: vsscanf Prev: vsnprintf Up: Function Substitutes Top: Top

9.1127. vsprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vsprintf.html

Gnulib module: vsprintf-posix

Portability problems fixed by Gnulib:

  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: AIX 7.1, Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function mishandles large floating point precisions (for example, formatting 1.0 with `"%.511f"') on some platforms: Solaris 10.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems not fixed by Gnulib:
  • Formatting noncanonical `long double' numbers produces nonmeaningful results on some platforms: glibc and others, on x86, x86_64, IA-64 CPUs.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: vsscanf Prev: vsnprintf Up: Function Substitutes Top: Top


vsscanf -- GNU Gnulib

Next: vswprintf Prev: vsprintf Up: Function Substitutes Top: Top

9.1128. vsscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vsscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 8, MSVC 14.
  • On Windows platforms (excluding Cygwin), this function does not set errno upon failure.
  • On Windows, these functions don't support the hh, ll, j, t, z size specifiers.

Next: vswprintf Prev: vsprintf Up: Function Substitutes Top: Top


vswprintf -- GNU Gnulib

Next: vswscanf Prev: vsscanf Up: Function Substitutes Top: Top

9.1129. vswprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vswprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • On Windows, this function does not take a buffer size as second argument.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.

Next: vswscanf Prev: vsscanf Up: Function Substitutes Top: Top


vswscanf -- GNU Gnulib

Next: vwprintf Prev: vswprintf Up: Function Substitutes Top: Top

9.1130. vswscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vswscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: vwprintf Prev: vswprintf Up: Function Substitutes Top: Top


vwprintf -- GNU Gnulib

Next: vwscanf Prev: vswscanf Up: Function Substitutes Top: Top

9.1131. vwprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vwprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS, Cygwin 1.7.
  • This function exists, but does not support wide arguments on some platforms: Cygwin 1.5.x.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: vwscanf Prev: vswscanf Up: Function Substitutes Top: Top


vwscanf -- GNU Gnulib

Next: wait Prev: vwprintf Up: Function Substitutes Top: Top

9.1132. vwscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/vwscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wait Prev: vwprintf Up: Function Substitutes Top: Top


wait -- GNU Gnulib

Next: waitid Prev: vwscanf Up: Function Substitutes Top: Top

9.1133. wait

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wait.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: waitid Prev: vwscanf Up: Function Substitutes Top: Top


waitid -- GNU Gnulib

Next: waitpid Prev: wait Up: Function Substitutes Top: Top

9.1134. waitid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/waitid.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • As of 2005, no system is known on which waitid with flag WNOWAIT works correctly.

Next: waitpid Prev: wait Up: Function Substitutes Top: Top


waitpid -- GNU Gnulib

Next: wcpcpy Prev: waitid Up: Function Substitutes Top: Top

9.1135. waitpid

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/waitpid.html

Gnulib module: waitpid

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: wcpcpy Prev: waitid Up: Function Substitutes Top: Top


wcpcpy -- GNU Gnulib

Next: wcpncpy Prev: waitpid Up: Function Substitutes Top: Top

9.1136. wcpcpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcpcpy.html

Gnulib module: wcpcpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.13.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcpncpy Prev: waitpid Up: Function Substitutes Top: Top


wcpncpy -- GNU Gnulib

Next: wcrtomb Prev: wcpcpy Up: Function Substitutes Top: Top

9.1137. wcpncpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcpncpy.html

Gnulib module: wcpncpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.13.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcrtomb Prev: wcpcpy Up: Function Substitutes Top: Top


wcrtomb -- GNU Gnulib

Next: wcscasecmp Prev: wcpncpy Up: Function Substitutes Top: Top

9.1138. wcrtomb

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcrtomb.html

Gnulib module: wcrtomb

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, mingw, Interix 3.5.
  • This function returns 0 when the first argument is NULL in some locales on some platforms: AIX 4.3, OSF/1 5.1, Solaris 11.3.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscasecmp Prev: wcpncpy Up: Function Substitutes Top: Top


wcscasecmp -- GNU Gnulib

Next: wcscasecmp_l Prev: wcrtomb Up: Function Substitutes Top: Top

9.1139. wcscasecmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscasecmp.html

Gnulib module: wcscasecmp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscasecmp_l Prev: wcrtomb Up: Function Substitutes Top: Top


wcscasecmp_l -- GNU Gnulib

Next: wcscat Prev: wcscasecmp Up: Function Substitutes Top: Top

9.1140. wcscasecmp_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscasecmp_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscat Prev: wcscasecmp Up: Function Substitutes Top: Top


wcscat -- GNU Gnulib

Next: wcschr Prev: wcscasecmp_l Up: Function Substitutes Top: Top

9.1141. wcscat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscat.html

Gnulib module: wcscat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcschr Prev: wcscasecmp_l Up: Function Substitutes Top: Top


wcschr -- GNU Gnulib

Next: wcscmp Prev: wcscat Up: Function Substitutes Top: Top

9.1142. wcschr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcschr.html

Gnulib module: wcschr

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscmp Prev: wcscat Up: Function Substitutes Top: Top


wcscmp -- GNU Gnulib

Next: wcscoll Prev: wcschr Up: Function Substitutes Top: Top

9.1143. wcscmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscmp.html

Gnulib module: wcscmp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscoll Prev: wcschr Up: Function Substitutes Top: Top


wcscoll -- GNU Gnulib

Next: wcscoll_l Prev: wcscmp Up: Function Substitutes Top: Top

9.1144. wcscoll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscoll.html

Gnulib module: wcscoll

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscoll_l Prev: wcscmp Up: Function Substitutes Top: Top


wcscoll_l -- GNU Gnulib

Next: wcscpy Prev: wcscoll Up: Function Substitutes Top: Top

9.1145. wcscoll_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscoll_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcscpy Prev: wcscoll Up: Function Substitutes Top: Top


wcscpy -- GNU Gnulib

Next: wcscspn Prev: wcscoll_l Up: Function Substitutes Top: Top

9.1146. wcscpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscpy.html

Gnulib module: wcscpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
Note: wcscpy (dst, src) is only safe to use when you can guarantee that there are at least wcslen (src) + 1 wide characters allocated at dst.

Next: wcscspn Prev: wcscoll_l Up: Function Substitutes Top: Top


wcscspn -- GNU Gnulib

Next: wcsdup Prev: wcscpy Up: Function Substitutes Top: Top

9.1147. wcscspn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcscspn.html

Gnulib module: wcscspn

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsdup Prev: wcscpy Up: Function Substitutes Top: Top


wcsdup -- GNU Gnulib

Next: wcsftime Prev: wcscspn Up: Function Substitutes Top: Top

9.1148. wcsdup

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsdup.html

Gnulib module: wcsdup

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, BeOS.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsftime Prev: wcscspn Up: Function Substitutes Top: Top


wcsftime -- GNU Gnulib

Next: wcslen Prev: wcsdup Up: Function Substitutes Top: Top

9.1149. wcsftime

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsftime.html

Gnulib module: wcsftime

Portability problems fixed by Gnulib:

  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • Native Windows platforms (mingw, MSVC) support only a subset of time zones specified by POSIX. See tzset.

Next: wcslen Prev: wcsdup Up: Function Substitutes Top: Top


wcslen -- GNU Gnulib

Next: wcsncasecmp Prev: wcsftime Up: Function Substitutes Top: Top

9.1150. wcslen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcslen.html

Gnulib module: wcslen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsncasecmp Prev: wcsftime Up: Function Substitutes Top: Top


wcsncasecmp -- GNU Gnulib

Next: wcsncasecmp_l Prev: wcslen Up: Function Substitutes Top: Top

9.1151. wcsncasecmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsncasecmp.html

Gnulib module: wcsncasecmp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsncasecmp_l Prev: wcslen Up: Function Substitutes Top: Top


wcsncasecmp_l -- GNU Gnulib

Next: wcsncat Prev: wcsncasecmp Up: Function Substitutes Top: Top

9.1152. wcsncasecmp_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsncasecmp_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsncat Prev: wcsncasecmp Up: Function Substitutes Top: Top


wcsncat -- GNU Gnulib

Next: wcsncmp Prev: wcsncasecmp_l Up: Function Substitutes Top: Top

9.1153. wcsncat

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsncat.html

Gnulib module: wcsncat

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsncmp Prev: wcsncasecmp_l Up: Function Substitutes Top: Top


wcsncmp -- GNU Gnulib

Next: wcsncpy Prev: wcsncat Up: Function Substitutes Top: Top

9.1154. wcsncmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsncmp.html

Gnulib module: wcsncmp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsncpy Prev: wcsncat Up: Function Substitutes Top: Top


wcsncpy -- GNU Gnulib

Next: wcsnlen Prev: wcsncmp Up: Function Substitutes Top: Top

9.1155. wcsncpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsncpy.html

Gnulib module: wcsncpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
Note: This function has no real use: It cannot be used for filling a fixed-size record with a wide string, before writing it to a file, because the wide string encoding is platform dependent and, on some platforms, also locale dependent. And this function is not appropriate for copying a wide string into a bounded memory area, because you have no guarantee that the result will be null-terminated. Even if you add the null character at the end yourself, this function is inefficient (as it spends time clearing unused memory) and will allow silent truncation to occur, which is not a good behavior for GNU programs.

Next: wcsnlen Prev: wcsncmp Up: Function Substitutes Top: Top


wcsnlen -- GNU Gnulib

Next: wcsnrtombs Prev: wcsncpy Up: Function Substitutes Top: Top

9.1156. wcsnlen

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsnlen.html

Gnulib module: wcsnlen

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsnrtombs Prev: wcsncpy Up: Function Substitutes Top: Top


wcsnrtombs -- GNU Gnulib

Next: wcspbrk Prev: wcsnlen Up: Function Substitutes Top: Top

9.1157. wcsnrtombs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsnrtombs.html

Gnulib module: wcsnrtombs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcspbrk Prev: wcsnlen Up: Function Substitutes Top: Top


wcspbrk -- GNU Gnulib

Next: wcsrchr Prev: wcsnrtombs Up: Function Substitutes Top: Top

9.1158. wcspbrk

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcspbrk.html

Gnulib module: wcspbrk

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsrchr Prev: wcsnrtombs Up: Function Substitutes Top: Top


wcsrchr -- GNU Gnulib

Next: wcsrtombs Prev: wcspbrk Up: Function Substitutes Top: Top

9.1159. wcsrchr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsrchr.html

Gnulib module: wcsrchr

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsrtombs Prev: wcspbrk Up: Function Substitutes Top: Top


wcsrtombs -- GNU Gnulib

Next: wcsspn Prev: wcsrchr Up: Function Substitutes Top: Top

9.1160. wcsrtombs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsrtombs.html

Gnulib module: wcsrtombs

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, mingw, Interix 3.5.
  • This function may set the source pointer to NULL before NUL terminating the destination string on some platforms: OSF/1 5.1.
  • This function does not ignore the length argument if the destination argument is NULL on some platforms: mingw.
  • This function updates the source pointer also if the destination argument is NULL on some platforms: HP-UX 11, OSF/1 5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsspn Prev: wcsrchr Up: Function Substitutes Top: Top


wcsspn -- GNU Gnulib

Next: wcsstr Prev: wcsrtombs Up: Function Substitutes Top: Top

9.1161. wcsspn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsspn.html

Gnulib module: wcsspn

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsstr Prev: wcsrtombs Up: Function Substitutes Top: Top


wcsstr -- GNU Gnulib

Next: wcstod Prev: wcsspn Up: Function Substitutes Top: Top

9.1162. wcsstr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsstr.html

Gnulib module: wcsstr

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 5.3, Solaris 2.6.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstod Prev: wcsspn Up: Function Substitutes Top: Top


wcstod -- GNU Gnulib

Next: wcstof Prev: wcsstr Up: Function Substitutes Top: Top

9.1163. wcstod

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstod.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstof Prev: wcsstr Up: Function Substitutes Top: Top


wcstof -- GNU Gnulib

Next: wcstoimax Prev: wcstod Up: Function Substitutes Top: Top

9.1164. wcstof

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstof.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoimax Prev: wcstod Up: Function Substitutes Top: Top


wcstoimax -- GNU Gnulib

Next: wcstok Prev: wcstof Up: Function Substitutes Top: Top

9.1165. wcstoimax

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstoimax.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstok Prev: wcstof Up: Function Substitutes Top: Top


wcstok -- GNU Gnulib

Next: wcstol Prev: wcstoimax Up: Function Substitutes Top: Top

9.1166. wcstok

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstok.html

Gnulib module: wcstok

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstol Prev: wcstoimax Up: Function Substitutes Top: Top


wcstol -- GNU Gnulib

Next: wcstold Prev: wcstok Up: Function Substitutes Top: Top

9.1167. wcstol

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstol.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstold Prev: wcstok Up: Function Substitutes Top: Top


wcstold -- GNU Gnulib

Next: wcstoll Prev: wcstol Up: Function Substitutes Top: Top

9.1168. wcstold

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstold.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 9, Cygwin, MSVC 9, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoll Prev: wcstol Up: Function Substitutes Top: Top


wcstoll -- GNU Gnulib

Next: wcstombs Prev: wcstold Up: Function Substitutes Top: Top

9.1169. wcstoll

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstoll.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.11, IRIX 5.3, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstombs Prev: wcstold Up: Function Substitutes Top: Top


wcstombs -- GNU Gnulib

Next: wcstoul Prev: wcstoll Up: Function Substitutes Top: Top

9.1170. wcstombs

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstombs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoul Prev: wcstoll Up: Function Substitutes Top: Top


wcstoul -- GNU Gnulib

Next: wcstoull Prev: wcstombs Up: Function Substitutes Top: Top

9.1171. wcstoul

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstoul.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoull Prev: wcstombs Up: Function Substitutes Top: Top


wcstoull -- GNU Gnulib

Next: wcstoumax Prev: wcstoul Up: Function Substitutes Top: Top

9.1172. wcstoull

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstoull.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.11, IRIX 5.3, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoumax Prev: wcstoul Up: Function Substitutes Top: Top


wcstoumax -- GNU Gnulib

Next: wcswidth Prev: wcstoull Up: Function Substitutes Top: Top

9.1173. wcstoumax

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcstoumax.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, MSVC 9, Interix 3.5.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcswidth Prev: wcstoull Up: Function Substitutes Top: Top


wcswidth -- GNU Gnulib

Next: wcsxfrm Prev: wcstoumax Up: Function Substitutes Top: Top

9.1174. wcswidth

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcswidth.html

Gnulib module: wcswidth

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, mingw, MSVC 14, BeOS.
  • This function handles combining characters in UTF-8 locales incorrectly on some platforms: Mac OS X 10.3.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsxfrm Prev: wcstoumax Up: Function Substitutes Top: Top


wcsxfrm -- GNU Gnulib

Next: wcsxfrm_l Prev: wcswidth Up: Function Substitutes Top: Top

9.1175. wcsxfrm

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsxfrm.html

Gnulib module: wcsxfrm

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, Cygwin 1.5.x.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsxfrm_l Prev: wcswidth Up: Function Substitutes Top: Top


wcsxfrm_l -- GNU Gnulib

Next: wctob Prev: wcsxfrm Up: Function Substitutes Top: Top

9.1176. wcsxfrm_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcsxfrm_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctob Prev: wcsxfrm Up: Function Substitutes Top: Top


wctob -- GNU Gnulib

Next: wctomb Prev: wcsxfrm_l Up: Function Substitutes Top: Top

9.1177. wctob

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctob.html

Gnulib module: wctob

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 5.3, Solaris 2.6, mingw, Interix 3.5.
  • This function clobbers caller-owned registers on some platforms: Cygwin 1.7.5.
  • This function does not work on some platforms: Solaris 9.
  • This function is missing a declaration on some platforms: IRIX 6.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctomb Prev: wcsxfrm_l Up: Function Substitutes Top: Top


wctomb -- GNU Gnulib

Next: wctrans Prev: wctob Up: Function Substitutes Top: Top

9.1178. wctomb

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctomb.html

Gnulib module: wctomb

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctrans Prev: wctob Up: Function Substitutes Top: Top


wctrans -- GNU Gnulib

Next: wctrans_l Prev: wctomb Up: Function Substitutes Top: Top

9.1179. wctrans

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctrans.html

Gnulib module: wctrans

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.5.1, mingw, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctrans_l Prev: wctomb Up: Function Substitutes Top: Top


wctrans_l -- GNU Gnulib

Next: wctype Prev: wctrans Up: Function Substitutes Top: Top

9.1180. wctrans_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctrans_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctype Prev: wctrans Up: Function Substitutes Top: Top


wctype -- GNU Gnulib

Next: wctype_l Prev: wctrans_l Up: Function Substitutes Top: Top

9.1181. wctype

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctype.html

Gnulib module: wctype

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, MSVC 9.
  • This function is declared in <wchar.h>, not in <wctype.h>, on some platforms: HP-UX 11.00.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wctype_l Prev: wctrans_l Up: Function Substitutes Top: Top


wctype_l -- GNU Gnulib

Next: wcwidth Prev: wctype Up: Function Substitutes Top: Top

9.1182. wctype_l

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wctype_l.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcwidth Prev: wctype Up: Function Substitutes Top: Top


wcwidth -- GNU Gnulib

Next: wmemchr Prev: wctype_l Up: Function Substitutes Top: Top

9.1183. wcwidth

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wcwidth.html

Gnulib module: wcwidth

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, IRIX 5.3, Solaris 2.5.1, mingw, MSVC 14, BeOS.
  • This function is not declared (without -D_GNU_SOURCE) on some platforms: glibc 2.8.
  • This function handles combining characters in UTF-8 locales incorrectly on some platforms: Mac OS X 10.3, OpenBSD 5.8.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmemchr Prev: wctype_l Up: Function Substitutes Top: Top


wmemchr -- GNU Gnulib

Next: wmemcmp Prev: wcwidth Up: Function Substitutes Top: Top

9.1184. wmemchr

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wmemchr.html

Gnulib module: wmemchr

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 14, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmemcmp Prev: wcwidth Up: Function Substitutes Top: Top


wmemcmp -- GNU Gnulib

Next: wmemcpy Prev: wmemchr Up: Function Substitutes Top: Top

9.1185. wmemcmp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wmemcmp.html

Gnulib module: wmemcmp

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 14, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmemcpy Prev: wmemchr Up: Function Substitutes Top: Top


wmemcpy -- GNU Gnulib

Next: wmemmove Prev: wmemcmp Up: Function Substitutes Top: Top

9.1186. wmemcpy

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wmemcpy.html

Gnulib module: wmemcpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmemmove Prev: wmemcmp Up: Function Substitutes Top: Top


wmemmove -- GNU Gnulib

Next: wmemset Prev: wmemcpy Up: Function Substitutes Top: Top

9.1187. wmemmove

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wmemmove.html

Gnulib module: wmemmove

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmemset Prev: wmemcpy Up: Function Substitutes Top: Top


wmemset -- GNU Gnulib

Next: wordexp Prev: wmemmove Up: Function Substitutes Top: Top

9.1188. wmemset

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wmemset.html

Gnulib module: wmemset

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: HP-UX 11.00, IRIX 6.5, Solaris 2.6, MSVC 9, Interix 3.5.
Portability problems not fixed by Gnulib:
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wordexp Prev: wmemmove Up: Function Substitutes Top: Top


wordexp -- GNU Gnulib

Next: wordfree Prev: wmemset Up: Function Substitutes Top: Top

9.1189. wordexp

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wordexp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: wordfree Prev: wmemset Up: Function Substitutes Top: Top


wordfree -- GNU Gnulib

Next: wprintf Prev: wordexp Up: Function Substitutes Top: Top

9.1190. wordfree

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wordfree.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: wprintf Prev: wordexp Up: Function Substitutes Top: Top


wprintf -- GNU Gnulib

Next: write Prev: wordfree Up: Function Substitutes Top: Top

9.1191. wprintf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wprintf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Interix 3.5, BeOS.
  • This function exists, but does not support wide arguments on some platforms: Cygwin 1.5.x.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • When formatting an integer with grouping flag, this function inserts thousands separators even in the "C" locale on some platforms: NetBSD 5.1.
  • On some platforms, this function does not set errno or the stream error indicator on attempts to write to a read-only stream: Cygwin 1.7.9.

Next: write Prev: wordfree Up: Function Substitutes Top: Top


write -- GNU Gnulib

Next: writev Prev: wprintf Up: Function Substitutes Top: Top

9.1192. write

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/write.html

Gnulib module: write, nonblocking, sigpipe

Portability problems fixed by Gnulib module stdio, together with module nonblocking:

  • This function crashes when invoked with invalid arguments on some platforms: MSVC 14.
  • When writing to a non-blocking pipe whose buffer is full, this function fails with errno being set to ENOSPC instead of EAGAIN on some platforms: mingw, MSVC 14.
  • When writing to a non-blocking pipe on which no reader is currently waiting an amount of bytes that exceeds the pipe buffer's size, then---even if the pipe's buffer is empty---this function fails, instead of performing a partial write into the pipe buffer, on some platforms: mingw, MSVC 14.
Portability problems fixed by Gnulib module stdio, together with module sigpipe:
  • When writing to a pipe with no readers, this function fails with error EINVAL, instead of obeying the current SIGPIPE handler, on some platforms: mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function may fail with error EINTR, even in programs that don't install any signal handlers, on some platforms: Mac OS X 10.5.
For handling EINTR, Gnulib provides a module `safe-write' with a function safe_write.

Next: writev Prev: wprintf Up: Function Substitutes Top: Top


writev -- GNU Gnulib

Next: wscanf Prev: write Up: Function Substitutes Top: Top

9.1193. writev

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/writev.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: wscanf Prev: write Up: Function Substitutes Top: Top


wscanf -- GNU Gnulib

Next: y0 Prev: writev Up: Function Substitutes Top: Top

9.1194. wscanf

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/wscanf.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: y0 Prev: writev Up: Function Substitutes Top: Top


y0 -- GNU Gnulib

Next: y1 Prev: wscanf Up: Function Substitutes Top: Top

9.1195. y0

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/y0.html

Gnulib module: y0

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Next: y1 Prev: wscanf Up: Function Substitutes Top: Top


y1 -- GNU Gnulib

Next: yn Prev: y0 Up: Function Substitutes Top: Top

9.1196. y1

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/y1.html

Gnulib module: y1

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Next: yn Prev: y0 Up: Function Substitutes Top: Top


yn -- GNU Gnulib

Prev: y1 Up: Function Substitutes Top: Top

9.1197. yn

POSIX specification:* http://www.opengroup.org/onlinepubs/9699919799/functions/yn.html

Gnulib module: yn

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8.

Prev: y1 Up: Function Substitutes Top: Top


Legacy Function Substitutes -- GNU Gnulib

Next: Glibc Header File Substitutes Prev: Function Substitutes Top: Top

10. Past POSIX Function Substitutes

This chapter describes which functions and function-like macros specified by older versions of POSIX are substituted by Gnulib, which portability pitfalls are fixed by Gnulib, and which (known) portability problems are not worked around by Gnulib.

Menu

  • bcmp
  • bcopy
  • bsd_signal
  • bzero
  • ecvt
  • fcvt
  • ftime
  • gcvt
  • getcontext
  • gethostbyaddr
  • gethostbyname
  • getwd
  • h_errno
  • index
  • makecontext
  • mktemp
  • pthread_attr_getstackaddr
  • pthread_attr_setstackaddr
  • rindex
  • scalb
  • setcontext
  • swapcontext
  • ualarm
  • usleep
  • vfork
  • wcswcs

    • Next: Glibc Header File Substitutes Prev: Function Substitutes Top: Top


bcmp -- GNU Gnulib

Next: bcopy Up: Legacy Function Substitutes Top: Top

10.1. bcmp

POSIX specification: http://www.opengroup.org/susv3xsh/bcmp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
  • This function is marked as ``legacy'' in POSIX. Better use memcmp instead.

Next: bcopy Up: Legacy Function Substitutes Top: Top


bcopy -- GNU Gnulib

Next: bsd_signal Prev: bcmp Up: Legacy Function Substitutes Top: Top

10.2. bcopy

POSIX specification: http://www.opengroup.org/susv3xsh/bcopy.html

Gnulib module: bcopy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
Portability problems not fixed by Gnulib:
  • This function is marked as ``legacy'' in POSIX. Better use memcpy or memmove instead.

Next: bsd_signal Prev: bcmp Up: Legacy Function Substitutes Top: Top


bsd_signal -- GNU Gnulib

Next: bzero Prev: bcopy Up: Legacy Function Substitutes Top: Top

10.3. bsd_signal

POSIX specification: http://www.opengroup.org/susv3xsh/bsd_signal.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, IRIX 5.3, Solaris 2.5.1, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: bzero Prev: bcopy Up: Legacy Function Substitutes Top: Top


bzero -- GNU Gnulib

Next: ecvt Prev: bsd_signal Up: Legacy Function Substitutes Top: Top

10.4. bzero

POSIX specification: http://www.opengroup.org/susv3xsh/bzero.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
  • This function is marked as ``legacy'' in POSIX. Better use memset instead.

Next: ecvt Prev: bsd_signal Up: Legacy Function Substitutes Top: Top


ecvt -- GNU Gnulib

Next: fcvt Prev: bzero Up: Legacy Function Substitutes Top: Top

10.5. ecvt

POSIX specification: http://www.opengroup.org/susv3xsh/ecvt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0.
  • This function is marked as ``legacy'' in POSIX. Better use sprintf instead.

Next: fcvt Prev: bzero Up: Legacy Function Substitutes Top: Top


fcvt -- GNU Gnulib

Next: ftime Prev: ecvt Up: Legacy Function Substitutes Top: Top

10.6. fcvt

POSIX specification: http://www.opengroup.org/susv3xsh/fcvt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, NetBSD 5.0.
  • This function is marked as ``legacy'' in POSIX. Better use sprintf instead.

Next: ftime Prev: ecvt Up: Legacy Function Substitutes Top: Top


ftime -- GNU Gnulib

Next: gcvt Prev: fcvt Up: Legacy Function Substitutes Top: Top

10.7. ftime

POSIX specification: http://www.opengroup.org/susv3xsh/ftime.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, IRIX 5.3, Solaris 2.4.
  • On native Windows platforms (mingw, MSVC), this function works incorrectly when the environment variable TZ has been set by Cygwin.
  • This function is marked as ``legacy'' in POSIX. Better use gettimeofday or clock_gettime instead, and use ftime only as a fallback for portability to Windows platforms.

Next: gcvt Prev: fcvt Up: Legacy Function Substitutes Top: Top


gcvt -- GNU Gnulib

Next: getcontext Prev: ftime Up: Legacy Function Substitutes Top: Top

10.8. gcvt

POSIX specification: http://www.opengroup.org/susv3xsh/gcvt.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0.
  • This function is marked as ``legacy'' in POSIX. Better use sprintf instead.

Next: getcontext Prev: ftime Up: Legacy Function Substitutes Top: Top


getcontext -- GNU Gnulib

Next: gethostbyaddr Prev: gcvt Up: Legacy Function Substitutes Top: Top

10.9. getcontext

POSIX specification: http://www.opengroup.org/susv3xsh/getcontext.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostbyaddr Prev: gcvt Up: Legacy Function Substitutes Top: Top


gethostbyaddr -- GNU Gnulib

Next: gethostbyname Prev: getcontext Up: Legacy Function Substitutes Top: Top

10.10. gethostbyaddr

POSIX specification: http://www.opengroup.org/susv3xsh/gethostbyaddr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: gethostbyname Prev: getcontext Up: Legacy Function Substitutes Top: Top


gethostbyname -- GNU Gnulib

Next: getwd Prev: gethostbyaddr Up: Legacy Function Substitutes Top: Top

10.11. gethostbyname

POSIX specification: http://www.opengroup.org/susv3xsh/gethostbyname.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: getwd Prev: gethostbyaddr Up: Legacy Function Substitutes Top: Top


getwd -- GNU Gnulib

Next: h_errno Prev: gethostbyname Up: Legacy Function Substitutes Top: Top

10.12. getwd

POSIX specification: http://www.opengroup.org/susv3xsh/getwd.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, BeOS.
  • The size of the buffer required for this function is not a compile-time constant. Also, the function truncates a result that would be larger than the minimum buffer size. For these reasons, this function is marked as ``legacy'' in POSIX. Better use the getcwd function instead.

Next: h_errno Prev: gethostbyname Up: Legacy Function Substitutes Top: Top


h_errno -- GNU Gnulib

Next: index Prev: getwd Up: Legacy Function Substitutes Top: Top

10.13. h_errno

POSIX specification: http://www.opengroup.org/susv3xsh/h_errno.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: index Prev: getwd Up: Legacy Function Substitutes Top: Top


Index -- GNU Gnulib

Prev: GNU Free Documentation License Top: Top

Index

$
Match-end-of-line Operator
(
Grouping Operators
)
Grouping Operators
`*'
Match-zero-or-more Operator
`+'
Match-one-or-more Operator
`-'
List Operators
`.'
Match-any-character Operator
`=]' in regex
Equivalence Class Operators
`?'
Match-zero-or-one Operator
`{'
Interval Operators
`}'
Interval Operators
`[=' in regex
Equivalence Class Operators
`[^'
List Operators
`[colon' in regex
Character Class Operators
`['
List Operators
\
The Backslash Character
`\''
Match-end-of-buffer Operator
\(
Grouping Operators
\)
Grouping Operators
`\<'
Match-beginning-of-word Operator
`\>'
Match-end-of-word Operator
`\{'
Interval Operators
`\}'
Interval Operators
`\`'
Match-beginning-of-buffer Operator
`\B'
Match-within-word Operator
`\b'
Match-word-boundary Operator
`\S'
Match-not-syntactic-class Operator
`\s'
Match-syntactic-class Operator
`\W'
Match-non-word-constituent Operator
`\w'
Match-word-constituent Operator
\|
Alternation Operator
`\'
List Operators
`]'
List Operators
^
Match-beginning-of-line Operator
`^'
List Operators
_Exit
_Exit
_exit
_exit
_GL_EXTERN_INLINE
extern inline
_GL_INLINE
extern inline
_GL_INLINE_HEADER_BEGIN
extern inline
_GL_INLINE_HEADER_END
extern inline
_longjmp
_longjmp
_setjmp
_setjmp
_tolower
_tolower
_toupper
_toupper
a64l
a64l
abort
abort
Aborting execution
Out of memory handling
abs
abs
AC_LIB_HAVE_LINKFLAGS(name, [dependencies], [includes], [testcode], [missing-message])
Searching for Libraries
AC_LIB_LINKFLAGS(name, [dependencies])
Searching for Libraries
accept
accept
accept4
accept4
access
access
acct
acct
acos
acos
acosf
acosf
acosh
acosh
acoshf
acoshf
acoshl
acoshl
acosl
acosl
addmntent
addmntent
addseverity
addseverity
adjtime
adjtime
adjtimex
adjtimex
advance
advance
aio_cancel
aio_cancel
aio_error
aio_error
aio_fsync
aio_fsync
aio_init
aio_init
aio_read
aio_read
aio_return
aio_return
aio_suspend
aio_suspend
aio_write
aio_write
alarm
alarm
aligned_alloc
aligned_alloc
ALLOC
Safe Allocation Macros
ALLOC_N
Safe Allocation Macros
ALLOC_N_UNINITIALIZED
Safe Allocation Macros
alloca
alloca
alloca-opt
allocated initialization
GNU Regular Expression Compiling
alphasort
alphasort
alternation operator
Alternation Operator
alternation operator and `^'
Match-beginning-of-line Operator
anchoring
Anchoring Operators
anchors
Match-beginning-of-line Operator
Match-end-of-line Operator
argp_err_exit_status
argp_err_exit_status
argp_error
argp_error
argp_failure
argp_failure
argp_help
argp_help
argp_parse
argp_parse
argp_program_bug_address
argp_program_bug_address
argp_program_version
argp_program_version
argp_program_version_hook
argp_program_version_hook
argp_state_help
argp_state_help
argp_usage
argp_usage
argz_add
argz_add
argz_add_sep
argz_add_sep
argz_append
argz_append
argz_count
argz_count
argz_create
argz_create
argz_create_sep
argz_create_sep
argz_delete
argz_delete
argz_extract
argz_extract
argz_insert
argz_insert
argz_next
argz_next
argz_replace
argz_replace
argz_stringify
argz_stringify
asctime
asctime
asctime_r
asctime_r
asin
asin
asinf
asinf
asinh
asinh
asinhf
asinhf
asinhl
asinhl
asinl
asinl
asprintf
asprintf
assert
assert
assertion
Compile-time Assertions
atan
atan
atan2
atan2
atan2f
atan2f
atan2l
atan2l
atanf
atanf
atanh
atanh
atanhf
atanhf
atanhl
atanhl
atanl
atanl
atexit
atexit
atof
atof
atoi
atoi
atol
atol
atoll
atoll
authdes_create
authdes_create
authdes_getucred
authdes_getucred
authdes_pk_create
authdes_pk_create
authnone_create
authnone_create
authunix_create
authunix_create
authunix_create_default
authunix_create_default
autopoint, caveat
gettextize and autopoint
Awk
Predefined Syntaxes
back references
Back-reference Operator
backtrace
backtrace
backtrace_symbols
backtrace_symbols
backtrace_symbols_fd
backtrace_symbols_fd
backtracking
Alternation Operator
Match-zero-or-more Operator
basename
basename
bcmp
bcmp
bcopy
bcopy
bdflush
bdflush
beginning-of-line operator
Match-beginning-of-line Operator
bind
bind
bind_textdomain_codeset
bind_textdomain_codeset
bindresvport
bindresvport
bindtextdomain
bindtextdomain
block size
stat-size
bracket expression
List Operators
brk
brk
bsd_signal
bsd_signal
bsearch
bsearch
bswap_16
bswap_16
bswap_32
bswap_32
bswap_64
bswap_64
btowc
btowc
buffer field, set by re_compile_pattern
GNU Regular Expression Compiling
buffer initialization
GNU Regular Expression Compiling
bzero
bzero
C++ header files
Header files
C++ tests modules
Extra tests modules
c16rtomb
c16rtomb
c32rtomb
c32rtomb
cabs
cabs
cabsf
cabsf
cabsl
cabsl
cacos
cacos
cacosf
cacosf
cacosh
cacosh
cacoshf
cacoshf
cacoshl
cacoshl
cacosl
cacosl
calloc
calloc
callrpc
callrpc
canonicalize_file_name
canonicalize_file_name
capget
capget
capset
capset
carg
carg
cargf
cargf
cargl
cargl
casin
casin
casinf
casinf
casinh
casinh
casinhf
casinhf
casinhl
casinhl
casinl
casinl
catan
catan
catanf
catanf
catanh
catanh
catanhf
catanhf
catanhl
catanhl
catanl
catanl
catclose
catclose
catgets
catgets
catopen
catopen
cbc_crypt
cbc_crypt
cbrt
cbrt
cbrtf
cbrtf
cbrtl
cbrtl
ccos
ccos
ccosf
ccosf
ccosh
ccosh
ccoshf
ccoshf
ccoshl
ccoshl
ccosl
ccosl
ceil
ceil
ceilf
ceilf
ceill
ceill
cexp
cexp
cexpf
cexpf
cexpl
cexpl
cfgetispeed
cfgetispeed
cfgetospeed
cfgetospeed
cfmakeraw
cfmakeraw
cfree
cfree
cfsetispeed
cfsetispeed
cfsetospeed
cfsetospeed
cfsetspeed
cfsetspeed
character classes
Character Class Operators
chdir
chdir
chmod
chmod
chown
chown
chroot
chroot
cimag
cimag
cimagf
cimagf
cimagl
cimagl
clearenv
clearenv
clearerr
clearerr
clearerr_unlocked
clearerr_unlocked
clnt_broadcast
clnt_broadcast
clnt_create
clnt_create
clnt_pcreateerror
clnt_pcreateerror
clnt_perrno
clnt_perrno
clnt_perror
clnt_perror
clnt_spcreateerror
clnt_spcreateerror
clnt_sperrno
clnt_sperrno
clnt_sperror
clnt_sperror
clntraw_create
clntraw_create
clnttcp_create
clnttcp_create
clntudp_bufcreate
clntudp_bufcreate
clntudp_create
clntudp_create
clntunix_create
clntunix_create
clock
clock
clock_adjtime
clock_adjtime
clock_getcpuclockid
clock_getcpuclockid
clock_getres
clock_getres
clock_gettime
clock_gettime
clock_nanosleep
clock_nanosleep
clock_settime
clock_settime
clog
clog
clog10
clog10
clog10f
clog10f
clog10l
clog10l
clogf
clogf
clogl
clogl
clone
clone
close
close
closedir
closedir
closelog
closelog
`colon]' in regex
Character Class Operators
comments describing functions
Specification
conditional dependencies
Conditional dependencies
configmake module
configmake
configmake.h, module for updating
configmake
confstr
confstr
conj
conj
conjf
conjf
conjl
conjl
connect
connect
copysign
copysign
copysignf
copysignf
copysignl
copysignl
cos
cos
cosf
cosf
cosh
cosh
coshf
coshf
coshl
coshl
cosl
cosl
cpow
cpow
cpowf
cpowf
cpowl
cpowl
cproj
cproj
cprojf
cprojf
cprojl
cprojl
creal
creal
crealf
crealf
creall
creall
creat
creat
crypt
crypt
crypt_r
crypt_r
csin
csin
csinf
csinf
csinh
csinh
csinhf
csinhf
csinhl
csinhl
csinl
csinl
csqrt
csqrt
csqrtf
csqrtf
csqrtl
csqrtl
ctan
ctan
ctanf
ctanf
ctanh
ctanh
ctanhf
ctanhf
ctanhl
ctanhl
ctanl
ctanl
ctermid
ctermid
ctime
ctime
ctime_r
ctime_r
cuserid
cuserid
daemon
daemon
daylight
daylight
dbm_clearerr
dbm_clearerr
dbm_close
dbm_close
dbm_delete
dbm_delete
dbm_error
dbm_error
dbm_fetch
dbm_fetch
dbm_firstkey
dbm_firstkey
dbm_nextkey
dbm_nextkey
dbm_open
dbm_open
dbm_store
dbm_store
dcgettext
dcgettext
dcngettext
dcngettext
DEF files
Visual Studio Compatibility
des_setparity
des_setparity
describing functions, locating
Specification
dgettext
dgettext
difftime
difftime
dirfd
dirfd
dirname
dirname
div
div
dl_iterate_phdr
dl_iterate_phdr
dladdr
dladdr
dladdr1
dladdr1
dlclose
dlclose
dlerror
dlerror
dlinfo
dlinfo
dlmopen
dlmopen
dlopen
dlopen
dlsym
dlsym
dlvsym
dlvsym
dn_expand
dn_expand
dngettext
dngettext
double inclusion of header files
Header files
dprintf
dprintf
drand48
drand48
drand48_r
drand48_r
drem
drem
dremf
dremf
dreml
dreml
dup
dup
dup2
dup2
dup3
dup3
duplocale
duplocale
dysize
dysize
ecb_crypt
ecb_crypt
ecvt
ecvt
ecvt_r
ecvt_r
Egrep
Predefined Syntaxes
Emacs
Predefined Syntaxes
encrypt
encrypt
encrypt_r
encrypt_r
end in struct re_registers
Using Registers
end-of-line operator
Match-end-of-line Operator
endaliasent
endaliasent
endfsent
endfsent
endgrent
endgrent
endhostent
endhostent
endmntent
endmntent
endnetent
endnetent
endnetgrent
endnetgrent
endprotoent
endprotoent
endpwent
endpwent
endrpcent
endrpcent
endservent
endservent
endsgent
endsgent
endspent
endspent
endttyent
endttyent
endusershell
endusershell
endutent
endutent
endutxent
endutxent
environ
environ
envz_add
envz_add
envz_entry
envz_entry
envz_get
envz_get
envz_merge
envz_merge
envz_remove
envz_remove
envz_strip
envz_strip
epoll_create
epoll_create
epoll_ctl
epoll_ctl
epoll_wait
epoll_wait
equivalence class expression in regex
Equivalence Class Operators
erand48
erand48
erand48_r
erand48_r
erf
erf
erfc
erfc
erfcf
erfcf
erfcl
erfcl
erff
erff
erfl
erfl
err
err
errno
errno
error
error
error and progname
error_at_line
error_at_line
error_message_count
error_message_count
error_one_per_line
error_one_per_line
error_print_progname
error_print_progname
errx
errx
ether_aton
ether_aton
ether_aton_r
ether_aton_r
ether_hostton
ether_hostton
ether_line
ether_line
ether_ntoa
ether_ntoa
ether_ntoa_r
ether_ntoa_r
ether_ntohost
ether_ntohost
euidaccess
euidaccess
execl
execl
execle
execle
execlp
execlp
execv
execv
execve
execve
execvp
execvp
execvpe
execvpe
exit
exit
exp
exp
exp10
exp10
exp10f
exp10f
exp10l
exp10l
exp2
exp2
exp2f
exp2f
exp2l
exp2l
expf
expf
expl
expl
explicit_bzero
explicit_bzero
expm1
expm1
expm1f
expm1f
expm1l
expm1l
EXPR_SIGNED
Arithmetic Type Properties
extern inline
extern inline
Extra tests modules
Extra tests modules
fabs
fabs
fabsf
fabsf
fabsl
fabsl
faccessat
faccessat
fallocate
fallocate
fanotify_init
fanotify_init
fanotify_mark
fanotify_mark
fastmap initialization
GNU Regular Expression Compiling
fastmaps
Searching with Fastmaps
fattach
fattach
fchdir
fchdir
fchmod
fchmod
fchmodat
fchmodat
fchown
fchown
fchownat
fchownat
fclose
fclose
fcloseall
fcloseall
fcntl
fcntl
fcvt
fcvt
fcvt_r
fcvt_r
FD_CLR
FD_CLR
FD_ISSET
FD_ISSET
FD_SET
FD_SET
FD_ZERO
FD_ZERO
fdatasync
fdatasync
fdetach
fdetach
fdim
fdim
fdimf
fdimf
fdiml
fdiml
fdopen
fdopen
fdopendir
fdopendir
feclearexcept
feclearexcept
fedisableexcept
fedisableexcept
feenableexcept
feenableexcept
fegetenv
fegetenv
fegetexcept
fegetexcept
fegetexceptflag
fegetexceptflag
fegetround
fegetround
feholdexcept
feholdexcept
feof
feof
feof_unlocked
feof_unlocked
feraiseexcept
feraiseexcept
ferror
ferror
ferror_unlocked
ferror_unlocked
fesetenv
fesetenv
fesetexceptflag
fesetexceptflag
fesetround
fesetround
fetestexcept
fetestexcept
feupdateenv
feupdateenv
fexecve
fexecve
fflush
fflush
fflush_unlocked
fflush_unlocked
ffs
ffs
ffsl
ffsl
ffsll
ffsll
fgetc
fgetc
fgetc_unlocked
fgetc_unlocked
fgetfilecon
fgetfilecon
fgetgrent
fgetgrent
fgetgrent_r
fgetgrent_r
fgetpos
fgetpos
fgetpwent
fgetpwent
fgetpwent_r
fgetpwent_r
fgets
fgets
fgets_unlocked
fgets_unlocked
fgetsgent
fgetsgent
fgetsgent_r
fgetsgent_r
fgetspent
fgetspent
fgetspent_r
fgetspent_r
fgetwc
fgetwc
fgetwc_unlocked
fgetwc_unlocked
fgetws
fgetws
fgetws_unlocked
fgetws_unlocked
fgetxattr
fgetxattr
fileno
fileno
fileno_unlocked
fileno_unlocked
Finding modules
Which modules?
finite
finite
finitef
finitef
finitel
finitel
flistxattr
flistxattr
flock
flock
flockfile
flockfile
floor
floor
floorf
floorf
floorl
floorl
fma
fma
fmaf
fmaf
fmal
fmal
fmax
fmax
fmaxf
fmaxf
fmaxl
fmaxl
fmemopen
fmemopen
fmin
fmin
fminf
fminf
fminl
fminl
fmod
fmod
fmodf
fmodf
fmodl
fmodl
fmtmsg
fmtmsg
fnmatch
fnmatch
fopen
fopen
fopencookie
fopencookie
fork
fork
forkpty
forkpty
fpathconf
fpathconf
fpclassify
fpclassify
fprintf
fprintf
fputc
fputc
fputc_unlocked
fputc_unlocked
fputs
fputs
fputs_unlocked
fputs_unlocked
fputwc
fputwc
fputwc_unlocked
fputwc_unlocked
fputws
fputws
fputws_unlocked
fputws_unlocked
fread
fread
fread_unlocked
fread_unlocked
FREE
Safe Allocation Macros
free
free
freeaddrinfo
freeaddrinfo
freeifaddrs
freeifaddrs
freelocale
freelocale
fremovexattr
fremovexattr
freopen
freopen
frexp
frexp
frexpf
frexpf
frexpl
frexpl
fscanf
fscanf
fseek
fseek
fseeko
fseeko
fsetpos
fsetpos
fsetxattr
fsetxattr
fstat
fstat
fstatat
fstatat
fstatfs
fstatfs
fstatvfs
fstatvfs
fsync
fsync
ftell
ftell
ftello
ftello
ftime
ftime
ftok
ftok
ftruncate
ftruncate
ftrylockfile
ftrylockfile
fts_children
fts_children
fts_close
fts_close
fts_open
fts_open
fts_read
fts_read
fts_set
fts_set
ftw
ftw
funlockfile
funlockfile
futimens
futimens
futimes
futimes
futimesat
futimesat
fwide
fwide
fwprintf
fwprintf
fwrite
fwrite
fwrite_unlocked
fwrite_unlocked
fwscanf
fwscanf
gai_strerror
gai_strerror
gamma
gamma
gammaf
gammaf
gammal
gammal
gcd
gcd
gcvt
gcvt
get_avphys_pages
get_avphys_pages
get_current_dir_name
get_current_dir_name
get_myaddress
get_myaddress
get_nprocs
get_nprocs
get_nprocs_conf
get_nprocs_conf
get_phys_pages
get_phys_pages
getaddrinfo
getaddrinfo
getaliasbyname
getaliasbyname
getaliasbyname_r
getaliasbyname_r
getaliasent
getaliasent
getaliasent_r
getaliasent_r
getc
getc
getc_unlocked
getc_unlocked
getchar
getchar
getchar_unlocked
getchar_unlocked
getcontext
getcontext
getcwd
getcwd
getdate
getdate
getdate_err
getdate_err
getdate_r
getdate_r
getdelim
getdelim
getdirentries
getdirentries
getdomainname
getdomainname
getdtablesize
getdtablesize
getegid
getegid
getenv
getenv
geteuid
geteuid
getfilecon
getfilecon
getfsent
getfsent
getfsfile
getfsfile
getfsspec
getfsspec
getgid
getgid
getgrent
getgrent
getgrent_r
getgrent_r
getgrgid
getgrgid
getgrgid_r
getgrgid_r
getgrnam
getgrnam
getgrnam_r
getgrnam_r
getgrouplist
getgrouplist
getgroups
getgroups
gethostbyaddr
gethostbyaddr
gethostbyaddr_r
gethostbyaddr_r
gethostbyname
gethostbyname
gethostbyname2
gethostbyname2
gethostbyname2_r
gethostbyname2_r
gethostbyname_r
gethostbyname_r
gethostent
gethostent
gethostent_r
gethostent_r
gethostid
gethostid
gethostname
gethostname
getifaddrs
getifaddrs
getipv4sourcefilter
getipv4sourcefilter
getitimer
getitimer
getline
getline
getloadavg
getloadavg
getlogin
getlogin
getlogin_r
getlogin_r
getmntent
getmntent
getmntent_r
getmntent_r
getmsg
getmsg
getnameinfo
getnameinfo
getnetbyaddr
getnetbyaddr
getnetbyaddr_r
getnetbyaddr_r
getnetbyname
getnetbyname
getnetbyname_r
getnetbyname_r
getnetent
getnetent
getnetent_r
getnetent_r
getnetgrent
getnetgrent
getnetgrent_r
getnetgrent_r
getnetname
getnetname
getopt
getopt
getopt_long
getopt_long
getopt_long_only
getopt_long_only
getpagesize
getpagesize
getpass
getpass
getpeername
getpeername
getpgid
getpgid
getpgrp
getpgrp
getpid
getpid
getpmsg
getpmsg
getppid
getppid
getpriority
getpriority
getprotobyname
getprotobyname
getprotobyname_r
getprotobyname_r
getprotobynumber
getprotobynumber
getprotobynumber_r
getprotobynumber_r
getprotoent
getprotoent
getprotoent_r
getprotoent_r
getpt
getpt
getpublickey
getpublickey
getpw
getpw
getpwent
getpwent
getpwent_r
getpwent_r
getpwnam
getpwnam
getpwnam_r
getpwnam_r
getpwuid
getpwuid
getpwuid_r
getpwuid_r
getresgid
getresgid
getresuid
getresuid
getrlimit
getrlimit
getrpcbyname
getrpcbyname
getrpcbyname_r
getrpcbyname_r
getrpcbynumber
getrpcbynumber
getrpcbynumber_r
getrpcbynumber_r
getrpcent
getrpcent
getrpcent_r
getrpcent_r
getrpcport
getrpcport
getrusage
getrusage
gets
gets
getsecretkey
getsecretkey
getservbyname
getservbyname
getservbyname_r
getservbyname_r
getservbyport
getservbyport
getservbyport_r
getservbyport_r
getservent
getservent
getservent_r
getservent_r
getsgent
getsgent
getsgent_r
getsgent_r
getsgnam
getsgnam
getsgnam_r
getsgnam_r
getsid
getsid
getsockname
getsockname
getsockopt
getsockopt
getsourcefilter
getsourcefilter
getspent
getspent
getspent_r
getspent_r
getspnam
getspnam
getspnam_r
getspnam_r
getsubopt
getsubopt
gettext
gettext
gettextize, caveat
gettextize and autopoint
gettimeofday
gettimeofday
getttyent
getttyent
getttynam
getttynam
getuid
getuid
getusershell
getusershell
getutent
getutent
getutent_r
getutent_r
getutid
getutid
getutid_r
getutid_r
getutline
getutline
getutline_r
getutline_r
getutmp
getutmp
getutmpx
getutmpx
getutxent
getutxent
getutxid
getutxid
getutxline
getutxline
getw
getw
getwc
getwc
getwc_unlocked
getwc_unlocked
getwchar
getwchar
getwchar_unlocked
getwchar_unlocked
getwd
getwd
getxattr
getxattr
glob
glob
glob_pattern_p
glob_pattern_p
globfree
globfree
gmtime
gmtime
gmtime_r
gmtime_r
gnu_dev_major
gnu_dev_major
gnu_dev_makedev
gnu_dev_makedev
gnu_dev_minor
gnu_dev_minor
gnu_get_libc_release
gnu_get_libc_release
gnu_get_libc_version
gnu_get_libc_version
gnulib-tool
Invoking gnulib-tool
grantpt
grantpt
Grep
Predefined Syntaxes
group_member
group_member
grouping
Grouping Operators
gsignal
gsignal
h_errno
h_errno
hasmntopt
hasmntopt
hcreate
hcreate
hcreate_r
hcreate_r
hdestroy
hdestroy
hdestroy_r
hdestroy_r
header file include protection
Header files
Header files and C++
Header files
herror
herror
host2netname
host2netname
hsearch
hsearch
hsearch_r
hsearch_r
hstrerror
hstrerror
htonl
htonl
htons
htons
hypot
hypot
hypotf
hypotf
hypotl
hypotl
iconv
iconv
iconv_close
iconv_close
iconv_open
iconv_open
if_freenameindex
if_freenameindex
if_indextoname
if_indextoname
if_nameindex
if_nameindex
if_nametoindex
if_nametoindex
ilogb
ilogb
ilogbf
ilogbf
ilogbl
ilogbl
imaxabs
imaxabs
imaxdiv
imaxdiv
in6addr_any
in6addr_any
in6addr_loopback
in6addr_loopback
index
index
inet6_opt_append
inet6_opt_append
inet6_opt_find
inet6_opt_find
inet6_opt_finish
inet6_opt_finish
inet6_opt_get_val
inet6_opt_get_val
inet6_opt_init
inet6_opt_init
inet6_opt_next
inet6_opt_next
inet6_opt_set_val
inet6_opt_set_val
inet6_option_alloc
inet6_option_alloc
inet6_option_append
inet6_option_append
inet6_option_find
inet6_option_find
inet6_option_init
inet6_option_init
inet6_option_next
inet6_option_next
inet6_option_space
inet6_option_space
inet6_rth_add
inet6_rth_add
inet6_rth_getaddr
inet6_rth_getaddr
inet6_rth_init
inet6_rth_init
inet6_rth_reverse
inet6_rth_reverse
inet6_rth_segments
inet6_rth_segments
inet6_rth_space
inet6_rth_space
inet_addr
inet_addr
inet_aton
inet_aton
inet_lnaof
inet_lnaof
inet_makeaddr
inet_makeaddr
inet_net_ntop
inet_net_ntop
inet_net_pton
inet_net_pton
inet_neta
inet_neta
inet_netof
inet_netof
inet_network
inet_network
inet_nsap_addr
inet_nsap_addr
inet_nsap_ntoa
inet_nsap_ntoa
inet_ntoa
inet_ntoa
inet_ntop
inet_ntop
inet_pton
inet_pton
initgroups
initgroups
initial import
Initial import
initstate
initstate
initstate_r
initstate_r
inline
extern inline
innetgr
innetgr
insque
insque
INT_ADD_OVERFLOW
Integer Type Overflow
INT_ADD_RANGE_OVERFLOW
Integer Range Overflow
INT_ADD_WRAPV
Wraparound Arithmetic
INT_BUFSIZE_BOUND
Integer Bounds
INT_DIVIDE_OVERFLOW
Integer Type Overflow
INT_DIVIDE_RANGE_OVERFLOW
Integer Range Overflow
INT_LEFT_SHIFT_OVERFLOW
Integer Type Overflow
INT_LEFT_SHIFT_RANGE_OVERFLOW
Integer Range Overflow
INT_MULTIPLY_OVERFLOW
Integer Type Overflow
INT_MULTIPLY_RANGE_OVERFLOW
Integer Range Overflow
INT_MULTIPLY_WRAPV
Wraparound Arithmetic
INT_NEGATE_OVERFLOW
Integer Type Overflow
INT_NEGATE_RANGE_OVERFLOW
Integer Range Overflow
INT_REMAINDER_OVERFLOW
Integer Type Overflow
INT_REMAINDER_RANGE_OVERFLOW
Integer Range Overflow
INT_STRLEN_BOUND
Integer Bounds
INT_SUBTRACT_OVERFLOW
Integer Type Overflow
INT_SUBTRACT_RANGE_OVERFLOW
Integer Range Overflow
INT_SUBTRACT_WRAPV
Wraparound Arithmetic
integer bounds
Integer Bounds
integer overflow
Integer Properties
integer properties
Integer Properties
integer range overflow
Integer Range Overflow
integer type overflow
Integer Type Overflow
interval expression
Interval Operators
int
Safe Allocation Macros
invoking @command{gnulib-tool}
Invoking gnulib-tool
ioctl
ioctl
ioperm
ioperm
iopl
iopl
isalnum
isalnum
isalnum_l
isalnum_l
isalpha
isalpha
isalpha_l
isalpha_l
isascii
isascii
isastream
isastream
isatty
isatty
isblank
isblank
isblank_l
isblank_l
iscntrl
iscntrl
iscntrl_l
iscntrl_l
isctype
isctype
isdigit
isdigit
isdigit_l
isdigit_l
isfdtype
isfdtype
isfinite
isfinite
isgraph
isgraph
isgraph_l
isgraph_l
isgreater
isgreater
isgreaterequal
isgreaterequal
isinf
isinf
isinff
isinff
isinfl
isinfl
isless
isless
islessequal
islessequal
islessgreater
islessgreater
islower
islower
islower_l
islower_l
isnan
isnan
isnanf
isnanf
isnanl
isnanl
isnormal
isnormal
isprint
isprint
isprint_l
isprint_l
ispunct
ispunct
ispunct_l
ispunct_l
isspace
isspace
isspace_l
isspace_l
isunordered
isunordered
isupper
isupper
isupper_l
isupper_l
iswalnum
iswalnum
iswalnum_l
iswalnum_l
iswalpha
iswalpha
iswalpha_l
iswalpha_l
iswblank
iswblank
iswblank_l
iswblank_l
iswcntrl
iswcntrl
iswcntrl_l
iswcntrl_l
iswctype
iswctype
iswctype_l
iswctype_l
iswdigit
iswdigit
iswdigit_l
iswdigit_l
iswgraph
iswgraph
iswgraph_l
iswgraph_l
iswlower
iswlower
iswlower_l
iswlower_l
iswprint
iswprint
iswprint_l
iswprint_l
iswpunct
iswpunct
iswpunct_l
iswpunct_l
iswspace
iswspace
iswspace_l
iswspace_l
iswupper
iswupper
iswupper_l
iswupper_l
iswxdigit
iswxdigit
iswxdigit_l
iswxdigit_l
isxdigit
isxdigit
isxdigit_l
isxdigit_l
j0
j0
j0f
j0f
j0l
j0l
j1
j1
j1f
j1f
j1l
j1l
jn
jn
jnf
jnf
jnl
jnl
jrand48
jrand48
jrand48_r
jrand48_r
key_decryptsession
key_decryptsession
key_decryptsession_pk
key_decryptsession_pk
key_encryptsession
key_encryptsession
key_encryptsession_pk
key_encryptsession_pk
key_gendes
key_gendes
key_get_conv
key_get_conv
key_secretkey_is_set
key_secretkey_is_set
key_setsecret
key_setsecret
kill
kill
killpg
killpg
klogctl
klogctl
l64a
l64a
labs
labs
lchmod
lchmod
lchown
lchown
lckpwdf
lckpwdf
lcong48
lcong48
lcong48_r
lcong48_r
LD DEF files
Visual Studio Compatibility
ldexp
ldexp
ldexpf
ldexpf
ldexpl
ldexpl
ldiv
ldiv
lfind
lfind
lgamma
lgamma
lgamma_r
lgamma_r
lgammaf
lgammaf
lgammaf_r
lgammaf_r
lgammal
lgammal
lgammal_r
lgammal_r
lgetfilecon
lgetfilecon
lgetxattr
lgetxattr
link
link
linkat
linkat
lio_listio
lio_listio
listen
listen
listxattr
listxattr
llabs
llabs
lldiv
lldiv
llistxattr
llistxattr
llrint
llrint
llrintf
llrintf
llrintl
llrintl
llround
llround
llroundf
llroundf
llroundl
llroundl
loc1
loc1
loc2
loc2
localeconv
localeconv
localtime
localtime
localtime_r
localtime_r
lockf
lockf
locs
locs
log
log
log10
log10
log10f
log10f
log10l
log10l
log1p
log1p
log1pf
log1pf
log1pl
log1pl
log2
log2
log2f
log2f
log2l
log2l
logb
logb
logbf
logbf
logbl
logbl
logf
logf
login
login
login_tty
login_tty
logl
logl
long-running tests modules
Extra tests modules
longjmp
longjmp
lrand48
lrand48
lrand48_r
lrand48_r
lremovexattr
lremovexattr
lrint
lrint
lrintf
lrintf
lrintl
lrintl
lround
lround
lroundf
lroundf
lroundl
lroundl
lsearch
lsearch
lseek
lseek
lsetxattr
lsetxattr
lstat
lstat
lutimes
lutimes
madvise
madvise
makecontext
makecontext
mallinfo
mallinfo
malloc
GNU Regular Expression Compiling
malloc
malloc_get_state
malloc_get_state
malloc_info
malloc_info
malloc_set_state
malloc_set_state
malloc_stats
malloc_stats
malloc_trim
malloc_trim
malloc_usable_size
malloc_usable_size
mallopt
mallopt
matching list
List Operators
matching newline
List Operators
matching with GNU functions
GNU Matching
matherr
matherr
mblen
mblen
mbrlen
mbrlen
mbrtoc16
mbrtoc16
mbrtoc32
mbrtoc32
mbrtowc
mbrtowc
mbsinit
mbsinit
mbsnrtowcs
mbsnrtowcs
mbsrtowcs
mbsrtowcs
mbstowcs
mbstowcs
mbtowc
mbtowc
mcheck
mcheck
mcheck_check_all
mcheck_check_all
mcheck_pedantic
mcheck_pedantic
memalign
memalign
memccpy
memccpy
memchr
memchr
memcmp
memcmp
memcpy
memcpy
memfrob
memfrob
memmem
memmem
memmove
memmove
Memory allocation failure
Out of memory handling
mempcpy
mempcpy
memrchr
memrchr
memset
memset
mincore
mincore
mkdir
mkdir
mkdirat
mkdirat
mkdtemp
mkdtemp
mkfifo
mkfifo
mkfifoat
mkfifoat
mknod
mknod
mknodat
mknodat
mkostemp
mkostemp
mkostemps
mkostemps
mkstemp
mkstemp
mkstemps
mkstemps
mktemp
mktemp
mktime
mktime
mlock
mlock
mlockall
mlockall
mmap
mmap
modf
modf
modff
modff
modfl
modfl
monstartup
monstartup
mount
mount
mprobe
mprobe
mprotect
mprotect
mq_close
mq_close
mq_getattr
mq_getattr
mq_notify
mq_notify
mq_open
mq_open
mq_receive
mq_receive
mq_send
mq_send
mq_setattr
mq_setattr
mq_timedreceive
mq_timedreceive
mq_timedsend
mq_timedsend
mq_unlink
mq_unlink
mrand48
mrand48
mrand48_r
mrand48_r
mremap
mremap
msgctl
msgctl
msgget
msgget
msgrcv
msgrcv
msgsnd
msgsnd
msync
msync
mtrace
mtrace
munlock
munlock
munlockall
munlockall
munmap
munmap
muntrace
muntrace
name_to_handle_at
name_to_handle_at
nan
nan
nanf
nanf
nanl
nanl
nanosleep
nanosleep
nearbyint
nearbyint
nearbyintf
nearbyintf
nearbyintl
nearbyintl
netname2host
netname2host
netname2user
netname2user
newlocale
newlocale
nextafter
nextafter
nextafterf
nextafterf
nextafterl
nextafterl
nexttoward
nexttoward
nexttowardf
nexttowardf
nexttowardl
nexttowardl
nftw
nftw
ngettext
ngettext
nice
nice
nis_add
nis_add
nis_add_entry
nis_add_entry
nis_addmember
nis_addmember
nis_checkpoint
nis_checkpoint
nis_clone_object
nis_clone_object
nis_creategroup
nis_creategroup
nis_destroy_object
nis_destroy_object
nis_destroygroup
nis_destroygroup
nis_dir_cmp
nis_dir_cmp
nis_domain_of
nis_domain_of
nis_domain_of_r
nis_domain_of_r
nis_first_entry
nis_first_entry
nis_freenames
nis_freenames
nis_freeresult
nis_freeresult
nis_freeservlist
nis_freeservlist
nis_freetags
nis_freetags
nis_getnames
nis_getnames
nis_getservlist
nis_getservlist
nis_ismember
nis_ismember
nis_leaf_of
nis_leaf_of
nis_leaf_of_r
nis_leaf_of_r
nis_lerror
nis_lerror
nis_list
nis_list
nis_local_directory
nis_local_directory
nis_local_group
nis_local_group
nis_local_host
nis_local_host
nis_local_principal
nis_local_principal
nis_lookup
nis_lookup
nis_mkdir
nis_mkdir
nis_modify
nis_modify
nis_modify_entry
nis_modify_entry
nis_name_of
nis_name_of
nis_name_of_r
nis_name_of_r
nis_next_entry
nis_next_entry
nis_perror
nis_perror
nis_ping
nis_ping
nis_print_directory
nis_print_directory
nis_print_entry
nis_print_entry
nis_print_group
nis_print_group
nis_print_group_entry
nis_print_group_entry
nis_print_link
nis_print_link
nis_print_object
nis_print_object
nis_print_result
nis_print_result
nis_print_rights
nis_print_rights
nis_print_table
nis_print_table
nis_remove
nis_remove
nis_remove_entry
nis_remove_entry
nis_removemember
nis_removemember
nis_rmdir
nis_rmdir
nis_servstate
nis_servstate
nis_sperrno
nis_sperrno
nis_sperror
nis_sperror
nis_sperror_r
nis_sperror_r
nis_stats
nis_stats
nis_verifygroup
nis_verifygroup
nl_langinfo
nl_langinfo
nl_langinfo_l
nl_langinfo_l
nonmatching list
List Operators
not_bol field in pattern buffer
Match-beginning-of-line Operator
nrand48
nrand48
nrand48_r
nrand48_r
ntohl
ntohl
ntohs
ntohs
ntp_adjtime
ntp_adjtime
ntp_gettime
ntp_gettime
ntp_gettimex
ntp_gettimex
num_regs in struct re_registers
Using Registers
Obsolete modules
Obsolete modules
obstack_alloc_failed_handler
obstack_alloc_failed_handler
obstack_exit_failure
obstack_exit_failure
obstack_free
obstack_free
obstack_printf
obstack_printf
obstack_vprintf
obstack_vprintf
on_exit
on_exit
open
open
open-group operator and `^'
Match-beginning-of-line Operator
open_by_handle_at
open_by_handle_at
open_memstream
open_memstream
open_wmemstream
open_wmemstream
openat
openat
opendir
opendir
openlog
openlog
openpty
openpty
optarg
optarg
opterr
opterr
optind
optind
optopt
optopt
or operator
Alternation Operator
Out of Memory handling
Out of memory handling
overflow, integer
Integer Properties
overflow, integer range
Integer Range Overflow
overflow, integer type
Integer Type Overflow
parenthesizing
Grouping Operators
parse_printf_format
parse_printf_format
pathconf
pathconf
pattern buffer initialization
GNU Regular Expression Compiling
pattern buffer, definition of
GNU Pattern Buffers
pause
pause
pclose
pclose
perror
perror
personality
personality
pipe
pipe
pipe2
pipe2
pmap_getmaps
pmap_getmaps
pmap_getport
pmap_getport
pmap_rmtcall
pmap_rmtcall
pmap_set
pmap_set
pmap_unset
pmap_unset
poll
poll
popen
popen
POSIX Awk
Predefined Syntaxes
posix_fadvise
posix_fadvise
posix_fallocate
posix_fallocate
posix_madvise
posix_madvise
posix_mem_offset
posix_mem_offset
posix_memalign
posix_memalign
posix_openpt
posix_openpt
posix_spawn
posix_spawn
posix_spawn_file_actions_addclose
posix_spawn_file_actions_addclose
posix_spawn_file_actions_adddup2
posix_spawn_file_actions_adddup2
posix_spawn_file_actions_addopen
posix_spawn_file_actions_addopen
posix_spawn_file_actions_destroy
posix_spawn_file_actions_destroy
posix_spawn_file_actions_init
posix_spawn_file_actions_init
posix_spawnattr_destroy
posix_spawnattr_destroy
posix_spawnattr_getflags
posix_spawnattr_getflags
posix_spawnattr_getpgroup
posix_spawnattr_getpgroup
posix_spawnattr_getschedparam
posix_spawnattr_getschedparam
posix_spawnattr_getschedpolicy
posix_spawnattr_getschedpolicy
posix_spawnattr_getsigdefault
posix_spawnattr_getsigdefault
posix_spawnattr_getsigmask
posix_spawnattr_getsigmask
posix_spawnattr_init
posix_spawnattr_init
posix_spawnattr_setflags
posix_spawnattr_setflags
posix_spawnattr_setpgroup
posix_spawnattr_setpgroup
posix_spawnattr_setschedparam
posix_spawnattr_setschedparam
posix_spawnattr_setschedpolicy
posix_spawnattr_setschedpolicy
posix_spawnattr_setsigdefault
posix_spawnattr_setsigdefault
posix_spawnattr_setsigmask
posix_spawnattr_setsigmask
posix_spawnp
posix_spawnp
posix_trace_attr_destroy
posix_trace_attr_destroy
posix_trace_attr_getclockres
posix_trace_attr_getclockres
posix_trace_attr_getcreatetime
posix_trace_attr_getcreatetime
posix_trace_attr_getgenversion
posix_trace_attr_getgenversion
posix_trace_attr_getinherited
posix_trace_attr_getinherited
posix_trace_attr_getlogfullpolicy
posix_trace_attr_getlogfullpolicy
posix_trace_attr_getlogsize
posix_trace_attr_getlogsize
posix_trace_attr_getmaxdatasize
posix_trace_attr_getmaxdatasize
posix_trace_attr_getmaxsystemeventsize
posix_trace_attr_getmaxsystemeventsize
posix_trace_attr_getmaxusereventsize
posix_trace_attr_getmaxusereventsize
posix_trace_attr_getname
posix_trace_attr_getname
posix_trace_attr_getstreamfullpolicy
posix_trace_attr_getstreamfullpolicy
posix_trace_attr_getstreamsize
posix_trace_attr_getstreamsize
posix_trace_attr_init
posix_trace_attr_init
posix_trace_attr_setinherited
posix_trace_attr_setinherited
posix_trace_attr_setlogfullpolicy
posix_trace_attr_setlogfullpolicy
posix_trace_attr_setlogsize
posix_trace_attr_setlogsize
posix_trace_attr_setmaxdatasize
posix_trace_attr_setmaxdatasize
posix_trace_attr_setname
posix_trace_attr_setname
posix_trace_attr_setstreamfullpolicy
posix_trace_attr_setstreamfullpolicy
posix_trace_attr_setstreamsize
posix_trace_attr_setstreamsize
posix_trace_clear
posix_trace_clear
posix_trace_close
posix_trace_close
posix_trace_create
posix_trace_create
posix_trace_create_withlog
posix_trace_create_withlog
posix_trace_event
posix_trace_event
posix_trace_eventid_equal
posix_trace_eventid_equal
posix_trace_eventid_get_name
posix_trace_eventid_get_name
posix_trace_eventid_open
posix_trace_eventid_open
posix_trace_eventset_add
posix_trace_eventset_add
posix_trace_eventset_del
posix_trace_eventset_del
posix_trace_eventset_empty
posix_trace_eventset_empty
posix_trace_eventset_fill
posix_trace_eventset_fill
posix_trace_eventset_ismember
posix_trace_eventset_ismember
posix_trace_eventtypelist_getnext_id
posix_trace_eventtypelist_getnext_id
posix_trace_eventtypelist_rewind
posix_trace_eventtypelist_rewind
posix_trace_flush
posix_trace_flush
posix_trace_get_attr
posix_trace_get_attr
posix_trace_get_filter
posix_trace_get_filter
posix_trace_get_status
posix_trace_get_status
posix_trace_getnext_event
posix_trace_getnext_event
posix_trace_open
posix_trace_open
posix_trace_rewind
posix_trace_rewind
posix_trace_set_filter
posix_trace_set_filter
posix_trace_shutdown
posix_trace_shutdown
posix_trace_start
posix_trace_start
posix_trace_stop
posix_trace_stop
posix_trace_timedgetnext_event
posix_trace_timedgetnext_event
posix_trace_trid_eventid_open
posix_trace_trid_eventid_open
posix_trace_trygetnext_event
posix_trace_trygetnext_event
posix_typed_mem_get_info
posix_typed_mem_get_info
posix_typed_mem_open
posix_typed_mem_open
pow
pow
pow10
pow10
pow10f
pow10f
pow10l
pow10l
powf
powf
powl
powl
prctl
prctl
pread
pread
preadv
preadv
printf
printf
printf_size
printf_size
printf_size_info
printf_size_info
privileged tests modules
Extra tests modules
prlimit
prlimit
process_vm_readv
process_vm_readv
process_vm_writev
process_vm_writev
profil
profil
progname
error and progname
program_invocation_name
program_invocation_name
program_invocation_short_name
program_invocation_short_name
program_name
error and progname
pselect
pselect
psiginfo
psiginfo
psignal
psignal
pthread_atfork
pthread_atfork
pthread_attr_destroy
pthread_attr_destroy
pthread_attr_getaffinity_np
pthread_attr_getaffinity_np
pthread_attr_getdetachstate
pthread_attr_getdetachstate
pthread_attr_getguardsize
pthread_attr_getguardsize
pthread_attr_getinheritsched
pthread_attr_getinheritsched
pthread_attr_getschedparam
pthread_attr_getschedparam
pthread_attr_getschedpolicy
pthread_attr_getschedpolicy
pthread_attr_getscope
pthread_attr_getscope
pthread_attr_getstack
pthread_attr_getstack
pthread_attr_getstackaddr
pthread_attr_getstackaddr
pthread_attr_getstacksize
pthread_attr_getstacksize
pthread_attr_init
pthread_attr_init
pthread_attr_setaffinity_np
pthread_attr_setaffinity_np
pthread_attr_setdetachstate
pthread_attr_setdetachstate
pthread_attr_setguardsize
pthread_attr_setguardsize
pthread_attr_setinheritsched
pthread_attr_setinheritsched
pthread_attr_setschedparam
pthread_attr_setschedparam
pthread_attr_setschedpolicy
pthread_attr_setschedpolicy
pthread_attr_setscope
pthread_attr_setscope
pthread_attr_setstack
pthread_attr_setstack
pthread_attr_setstackaddr
pthread_attr_setstackaddr
pthread_attr_setstacksize
pthread_attr_setstacksize
pthread_barrier_destroy
pthread_barrier_destroy
pthread_barrier_init
pthread_barrier_init
pthread_barrier_wait
pthread_barrier_wait
pthread_barrierattr_destroy
pthread_barrierattr_destroy
pthread_barrierattr_getpshared
pthread_barrierattr_getpshared
pthread_barrierattr_init
pthread_barrierattr_init
pthread_barrierattr_setpshared
pthread_barrierattr_setpshared
pthread_cancel
pthread_cancel
pthread_cleanup_pop
pthread_cleanup_pop
pthread_cleanup_push
pthread_cleanup_push
pthread_cond_broadcast
pthread_cond_broadcast
pthread_cond_destroy
pthread_cond_destroy
pthread_cond_init
pthread_cond_init
pthread_cond_signal
pthread_cond_signal
pthread_cond_timedwait
pthread_cond_timedwait
pthread_cond_wait
pthread_cond_wait
pthread_condattr_destroy
pthread_condattr_destroy
pthread_condattr_getclock
pthread_condattr_getclock
pthread_condattr_getpshared
pthread_condattr_getpshared
pthread_condattr_init
pthread_condattr_init
pthread_condattr_setclock
pthread_condattr_setclock
pthread_condattr_setpshared
pthread_condattr_setpshared
pthread_create
pthread_create
pthread_detach
pthread_detach
pthread_equal
pthread_equal
pthread_exit
pthread_exit
pthread_getaffinity_np
pthread_getaffinity_np
pthread_getattr_np
pthread_getattr_np
pthread_getconcurrency
pthread_getconcurrency
pthread_getcpuclockid
pthread_getcpuclockid
pthread_getname_np
pthread_getname_np
pthread_getschedparam
pthread_getschedparam
pthread_getspecific
pthread_getspecific
pthread_join
pthread_join
pthread_key_create
pthread_key_create
pthread_key_delete
pthread_key_delete
pthread_kill
pthread_kill
pthread_kill_other_threads_np
pthread_kill_other_threads_np
pthread_mutex_consistent
pthread_mutex_consistent
pthread_mutex_consistent_np
pthread_mutex_consistent_np
pthread_mutex_destroy
pthread_mutex_destroy
pthread_mutex_getprioceiling
pthread_mutex_getprioceiling
pthread_mutex_init
pthread_mutex_init
pthread_mutex_lock
pthread_mutex_lock
pthread_mutex_setprioceiling
pthread_mutex_setprioceiling
pthread_mutex_timedlock
pthread_mutex_timedlock
pthread_mutex_trylock
pthread_mutex_trylock
pthread_mutex_unlock
pthread_mutex_unlock
pthread_mutexattr_destroy
pthread_mutexattr_destroy
pthread_mutexattr_getprioceiling
pthread_mutexattr_getprioceiling
pthread_mutexattr_getprotocol
pthread_mutexattr_getprotocol
pthread_mutexattr_getpshared
pthread_mutexattr_getpshared
pthread_mutexattr_getrobust
pthread_mutexattr_getrobust
pthread_mutexattr_getrobust_np
pthread_mutexattr_getrobust_np
pthread_mutexattr_gettype
pthread_mutexattr_gettype
pthread_mutexattr_init
pthread_mutexattr_init
pthread_mutexattr_setprioceiling
pthread_mutexattr_setprioceiling
pthread_mutexattr_setprotocol
pthread_mutexattr_setprotocol
pthread_mutexattr_setpshared
pthread_mutexattr_setpshared
pthread_mutexattr_setrobust
pthread_mutexattr_setrobust
pthread_mutexattr_setrobust_np
pthread_mutexattr_setrobust_np
pthread_mutexattr_settype
pthread_mutexattr_settype
pthread_once
pthread_once
pthread_rwlock_destroy
pthread_rwlock_destroy
pthread_rwlock_init
pthread_rwlock_init
pthread_rwlock_rdlock
pthread_rwlock_rdlock
pthread_rwlock_timedrdlock
pthread_rwlock_timedrdlock
pthread_rwlock_timedwrlock
pthread_rwlock_timedwrlock
pthread_rwlock_tryrdlock
pthread_rwlock_tryrdlock
pthread_rwlock_trywrlock
pthread_rwlock_trywrlock
pthread_rwlock_unlock
pthread_rwlock_unlock
pthread_rwlock_wrlock
pthread_rwlock_wrlock
pthread_rwlockattr_destroy
pthread_rwlockattr_destroy
pthread_rwlockattr_getkind_np
pthread_rwlockattr_getkind_np
pthread_rwlockattr_getpshared
pthread_rwlockattr_getpshared
pthread_rwlockattr_init
pthread_rwlockattr_init
pthread_rwlockattr_setkind_np
pthread_rwlockattr_setkind_np
pthread_rwlockattr_setpshared
pthread_rwlockattr_setpshared
pthread_self
pthread_self
pthread_setaffinity_np
pthread_setaffinity_np
pthread_setcancelstate
pthread_setcancelstate
pthread_setcanceltype
pthread_setcanceltype
pthread_setconcurrency
pthread_setconcurrency
pthread_setname_np
pthread_setname_np
pthread_setschedparam
pthread_setschedparam
pthread_setschedprio
pthread_setschedprio
pthread_setspecific
pthread_setspecific
pthread_sigmask
pthread_sigmask
pthread_sigqueue
pthread_sigqueue
pthread_spin_destroy
pthread_spin_destroy
pthread_spin_init
pthread_spin_init
pthread_spin_lock
pthread_spin_lock
pthread_spin_trylock
pthread_spin_trylock
pthread_spin_unlock
pthread_spin_unlock
pthread_testcancel
pthread_testcancel
pthread_timedjoin_np
pthread_timedjoin_np
pthread_tryjoin_np
pthread_tryjoin_np
pthread_yield
pthread_yield
ptrace
ptrace
ptsname
ptsname
ptsname_r
ptsname_r
putc
putc
putc_unlocked
putc_unlocked
putchar
putchar
putchar_unlocked
putchar_unlocked
putenv
putenv
putgrent
putgrent
putmsg
putmsg
putpmsg
putpmsg
putpwent
putpwent
puts
puts
putsgent
putsgent
putspent
putspent
pututline
pututline
pututxline
pututxline
putw
putw
putwc
putwc
putwc_unlocked
putwc_unlocked
putwchar
putwchar
putwchar_unlocked
putwchar_unlocked
pvalloc
pvalloc
pwrite
pwrite
pwritev
pwritev
qecvt
qecvt
qecvt_r
qecvt_r
qfcvt
qfcvt
qfcvt_r
qfcvt_r
qgcvt
qgcvt
qsort
qsort
qsort_r
qsort_r
quick_exit
quick_exit
quotactl
quotactl
quote
Quoting
quote_n
Quoting
quotearg
Quoting
quotearg_alloc
Quoting
Quoting
Quoting
raise
raise
rand
rand
rand_r
rand_r
random
random
random_r
random_r
range argument to re_search
GNU Searching
rawmemchr
rawmemchr
rcmd
rcmd
rcmd_af
rcmd_af
re_comp
BSD Regular Expression Compiling
re_comp
re_compile_fastmap
Searching with Fastmaps
re_compile_fastmap
re_compile_pattern
GNU Regular Expression Compiling
re_compile_pattern
re_exec
BSD Searching
re_exec
re_match
GNU Matching
re_match
re_match_2
Matching/Searching with Split Data
re_match_2
re_nsub field, set by re_compile_pattern
GNU Regular Expression Compiling
re_pattern_buffer definition
GNU Pattern Buffers
re_registers
Using Registers
re_search
GNU Searching
re_search
re_search_2
Matching/Searching with Split Data
re_search_2
re_set_registers
Using Registers
re_set_registers
re_set_syntax
re_set_syntax
re_syntax_options
re_syntax_options
re_syntax_options initialization
GNU Regular Expression Compiling
read
read
readahead
readahead
readdir
readdir
readdir_r
readdir_r
readlink
readlink
readlinkat
readlinkat
readv
readv
realloc
realloc
REALLOC_N
Safe Allocation Macros
realpath
realpath
reboot
reboot
recv
recv
recvfrom
recvfrom
recvmmsg
recvmmsg
recvmsg
recvmsg
regcomp
regcomp
regerror
regerror
regex.h
Overview
regexec
regexec
regexp anchoring
Anchoring Operators
regfree
Freeing GNU Pattern Buffers
regfree
register_printf_function
register_printf_function
register_printf_modifier
register_printf_modifier
register_printf_specifier
register_printf_specifier
register_printf_type
register_printf_type
regular expressions, syntax of
Regular Expression Syntax
remainder
remainder
remainderf
remainderf
remainderl
remainderl
remap_file_pages
remap_file_pages
remove
remove
removexattr
removexattr
remque
remque
remquo
remquo
remquof
remquof
remquol
remquol
rename
rename
renameat
renameat
res_init
res_init
res_mkquery
res_mkquery
res_query
res_query
res_querydomain
res_querydomain
res_search
res_search
revoke
revoke
rewind
rewind
rewinddir
rewinddir
rexec
rexec
rexec_af
rexec_af
rindex
rindex
rint
rint
rintf
rintf
rintl
rintl
rmdir
rmdir
round
round
roundf
roundf
roundl
roundl
rpc_createerr
rpc_createerr
rpmatch
rpmatch
rresvport
rresvport
rresvport_af
rresvport_af
rtime
rtime
ruserok
ruserok
ruserok_af
ruserok_af
sbrk
sbrk
scalb
scalb
scalbf
scalbf
scalbl
scalbl
scalbln
scalbln
scalblnf
scalblnf
scalblnl
scalblnl
scalbn
scalbn
scalbnf
scalbnf
scalbnl
scalbnl
scandir
scandir
scandirat
scandirat
scanf
scanf
sched_get_priority_max
sched_get_priority_max
sched_get_priority_min
sched_get_priority_min
sched_getaffinity
sched_getaffinity
sched_getparam
sched_getparam
sched_getscheduler
sched_getscheduler
sched_rr_get_interval
sched_rr_get_interval
sched_setaffinity
sched_setaffinity
sched_setparam
sched_setparam
sched_setscheduler
sched_setscheduler
sched_yield
sched_yield
searching with GNU functions
GNU Searching
secure_getenv
secure_getenv
seed48
seed48
seed48_r
seed48_r
seekdir
seekdir
select
select
sem_close
sem_close
sem_destroy
sem_destroy
sem_getvalue
sem_getvalue
sem_init
sem_init
sem_open
sem_open
sem_post
sem_post
sem_timedwait
sem_timedwait
sem_trywait
sem_trywait
sem_unlink
sem_unlink
sem_wait
sem_wait
semctl
semctl
semget
semget
semop
semop
semtimedop
semtimedop
send
send
sendfile
sendfile
sendmmsg
sendmmsg
sendmsg
sendmsg
sendto
sendto
setaliasent
setaliasent
setbuf
setbuf
setbuffer
setbuffer
setcontext
setcontext
setdomainname
setdomainname
setegid
setegid
setenv
setenv
seteuid
seteuid
setfsent
setfsent
setfsgid
setfsgid
setfsuid
setfsuid
setgid
setgid
setgrent
setgrent
setgroups
setgroups
sethostent
sethostent
sethostid
sethostid
sethostname
sethostname
setipv4sourcefilter
setipv4sourcefilter
setitimer
setitimer
setjmp
setjmp
setkey
setkey
setkey_r
setkey_r
setlinebuf
setlinebuf
setlocale
setlocale
setlogin
setlogin
setlogmask
setlogmask
setmntent
setmntent
setnetent
setnetent
setnetgrent
setnetgrent
setns
setns
setpgid
setpgid
setpgrp
setpgrp
setpriority
setpriority
setprotoent
setprotoent
setpwent
setpwent
setregid
setregid
setresgid
setresgid
setresuid
setresuid
setreuid
setreuid
setrlimit
setrlimit
setrpcent
setrpcent
setservent
setservent
setsgent
setsgent
setsid
setsid
setsockopt
setsockopt
setsourcefilter
setsourcefilter
setspent
setspent
setstate
setstate
setstate_r
setstate_r
settimeofday
settimeofday
setttyent
setttyent
setuid
setuid
setusershell
setusershell
setutent
setutent
setutxent
setutxent
setvbuf
setvbuf
setxattr
setxattr
sgetsgent
sgetsgent
sgetsgent_r
sgetsgent_r
sgetspent
sgetspent
sgetspent_r
sgetspent_r
shm_open
shm_open
shm_unlink
shm_unlink
shmat
shmat
shmctl
shmctl
shmdt
shmdt
shmget
shmget
shutdown
shutdown
sigaction
sigaction
sigaddset
sigaddset
sigaltstack
sigaltstack
sigandset
sigandset
sigblock
sigblock
sigdelset
sigdelset
sigemptyset
sigemptyset
sigfillset
sigfillset
siggetmask
siggetmask
sighold
sighold
sigignore
sigignore
siginterrupt
siginterrupt
sigisemptyset
sigisemptyset
sigismember
sigismember
siglongjmp
siglongjmp
signal
signal
signbit
signbit
signgam
signgam
significand
significand
significandf
significandf
significandl
significandl
sigorset
sigorset
sigpause
sigpause
sigpending
sigpending
sigprocmask
sigprocmask
sigqueue
sigqueue
sigrelse
sigrelse
sigreturn
sigreturn
sigset
sigset
sigsetjmp
sigsetjmp
sigsetmask
sigsetmask
sigstack
sigstack
sigsuspend
sigsuspend
sigtimedwait
sigtimedwait
sigvec
sigvec
sigwait
sigwait
sigwaitinfo
sigwaitinfo
sin
sin
sincos
sincos
sincosf
sincosf
sincosl
sincosl
sinf
sinf
sinh
sinh
sinhf
sinhf
sinhl
sinhl
sinl
sinl
sleep
sleep
snprintf
snprintf
sockatmark
sockatmark
socket
socket
socketpair
socketpair
specification
Specification
sprintf
sprintf
sprofil
sprofil
sqrt
sqrt
sqrtf
sqrtf
sqrtl
sqrtl
srand
srand
srand48
srand48
srand48_r
srand48_r
srandom
srandom
srandom_r
srandom_r
sscanf
sscanf
ssignal
ssignal
ST_BLKSIZE
stat-size
ST_NBLOCKS
stat-size
ST_NBLOCKSIZE
stat-size
start argument to re_search
GNU Searching
start in struct re_registers
Using Registers
stat
stat
statfs
statfs
statvfs
statvfs
stderr
stderr
stdin
stdin
stdout
stdout
step
step
stime
stime
stpcpy
stpcpy
stpncpy
stpncpy
strcasecmp
strcasecmp
strcasecmp_l
strcasecmp_l
strcasestr
strcasestr
strcat
strcat
strchr
strchr
strchrnul
strchrnul
strcmp
strcmp
strcoll
strcoll
strcoll_l
strcoll_l
strcpy
strcpy
strcspn
strcspn
strdup
strdup
strerror
strerror
strerror_l
strerror_l
strerror_r
strerror_r
strfmon
strfmon
strfmon_l
strfmon_l
strfry
strfry
strftime
strftime
strftime_l
strftime_l
strlen
strlen
strncasecmp
strncasecmp
strncasecmp_l
strncasecmp_l
strncat
strncat
strncmp
strncmp
strncpy
strncpy
strndup
strndup
strnlen
strnlen
strpbrk
strpbrk
strptime
strptime
strptime_l
strptime_l
strrchr
strrchr
strsep
strsep
strsignal
strsignal
strspn
strspn
strstr
strstr
strtod
strtod
strtod_l
strtod_l
strtof
strtof
strtof_l
strtof_l
strtoimax
strtoimax
strtok
strtok
strtok_r
strtok_r
strtol
strtol
strtol_l
strtol_l
strtold
strtold
strtold_l
strtold_l
strtoll
strtoll
strtoll_l
strtoll_l
strtoq
strtoq
strtoul
strtoul
strtoul_l
strtoul_l
strtoull
strtoull
strtoull_l
strtoull_l
strtoumax
strtoumax
strtouq
strtouq
struct re_pattern_buffer definition
GNU Pattern Buffers
strverscmp
strverscmp
strxfrm
strxfrm
strxfrm_l
strxfrm_l
subexpressions
Grouping Operators
svc_exit
svc_exit
svc_fdset
svc_fdset
svc_getreq
svc_getreq
svc_getreq_common
svc_getreq_common
svc_getreq_poll
svc_getreq_poll
svc_getreqset
svc_getreqset
svc_max_pollfd
svc_max_pollfd
svc_pollfd
svc_pollfd
svc_register
svc_register
svc_run
svc_run
svc_sendreply
svc_sendreply
svc_unregister
svc_unregister
svcerr_auth
svcerr_auth
svcerr_decode
svcerr_decode
svcerr_noproc
svcerr_noproc
svcerr_noprog
svcerr_noprog
svcerr_progvers
svcerr_progvers
svcerr_systemerr
svcerr_systemerr
svcerr_weakauth
svcerr_weakauth
svcraw_create
svcraw_create
svctcp_create
svctcp_create
svcudp_bufcreate
svcudp_bufcreate
svcudp_create
svcudp_create
svcunix_create
svcunix_create
swab
swab
swapcontext
swapcontext
swapoff
swapoff
swapon
swapon
swprintf
swprintf
swscanf
swscanf
symlink
symlink
symlinkat
symlinkat
sync
sync
syncfs
syncfs
syntax field, set by re_compile_pattern
GNU Regular Expression Compiling
syntax bits
Syntax Bits
syntax initialization
GNU Regular Expression Compiling
syntax of regular expressions
Regular Expression Syntax
sys_errlist
sys_errlist
sys_nerr
sys_nerr
sys_siglist
sys_siglist
syscall
syscall
sysconf
sysconf
sysctl
sysctl
sysinfo
sysinfo
syslog
syslog
system
system
sysv_signal
sysv_signal
tan
tan
tanf
tanf
tanh
tanh
tanhf
tanhf
tanhl
tanhl
tanl
tanl
tcdrain
tcdrain
tcflow
tcflow
tcflush
tcflush
tcgetattr
tcgetattr
tcgetpgrp
tcgetpgrp
tcgetsid
tcgetsid
tcsendbreak
tcsendbreak
tcsetattr
tcsetattr
tcsetpgrp
tcsetpgrp
tdelete
tdelete
tdestroy
tdestroy
telldir
telldir
tempnam
tempnam
tests modules, C++
Extra tests modules
tests modules, long-running
Extra tests modules
tests modules, privileged
Extra tests modules
tests modules, unportable
Extra tests modules
textdomain
textdomain
tfind
tfind
tgamma
tgamma
tgammaf
tgammaf
tgammal
tgammal
time
time
timegm
timegm
timelocal
timelocal
timer_create
timer_create
timer_delete
timer_delete
timer_getoverrun
timer_getoverrun
timer_gettime
timer_gettime
timer_settime
timer_settime
times
times
timespec_get
timespec_get
timezone
timezone
tmpfile
tmpfile
tmpnam
tmpnam
tmpnam_r
tmpnam_r
toascii
toascii
tolower
tolower
tolower_l
tolower_l
toupper
toupper
toupper_l
toupper_l
towctrans
towctrans
towctrans_l
towctrans_l
towlower
towlower
towlower_l
towlower_l
towupper
towupper
towupper_l
towupper_l
translate initialization
GNU Regular Expression Compiling
trunc
trunc
truncate
truncate
truncf
truncf
truncl
truncl
tsearch
tsearch
ttyname
ttyname
ttyname_r
ttyname_r
ttyslot
ttyslot
twalk
twalk
TYPE_IS_INTEGER
Arithmetic Type Properties
TYPE_MAXIMUM
Integer Bounds
TYPE_MINIMUM
Integer Bounds
TYPE_SIGNED
Arithmetic Type Properties
tzname
tzname
tzset
tzset
ualarm
ualarm
ulckpwdf
ulckpwdf
ulimit
ulimit
umask
umask
umount
umount
umount2
umount2
uname
uname
ungetc
ungetc
ungetwc
ungetwc
unlink
unlink
unlinkat
unlinkat
unlockpt
unlockpt
unportable tests modules
Extra tests modules
unsetenv
unsetenv
updwtmp
updwtmp
updwtmpx
updwtmpx
uselocale
uselocale
user2netname
user2netname
usleep
usleep
ustat
ustat
utime
utime
utimensat
utimensat
utimes
utimes
utmpname
utmpname
utmpxname
utmpxname
va_arg
va_arg
va_copy
va_copy
va_end
va_end
va_start
va_start
valloc
valloc
vasprintf
vasprintf
vdprintf
vdprintf
verify
Compile-time Assertions
verify_expr
Compile-time Assertions
verr
verr
verrx
verrx
versionsort
versionsort
vfork
vfork
vfprintf
vfprintf
vfscanf
vfscanf
vfwprintf
vfwprintf
vfwscanf
vfwscanf
vhangup
vhangup
vlimit
vlimit
vm86
vm86
void
Safe Allocation Macros
vprintf
vprintf
vscanf
vscanf
vsnprintf
vsnprintf
vsprintf
vsprintf
vsscanf
vsscanf
vswprintf
vswprintf
vswscanf
vswscanf
vsyslog
vsyslog
vtimes
vtimes
vwarn
vwarn
vwarnx
vwarnx
vwprintf
vwprintf
vwscanf
vwscanf
wait
wait
wait3
wait3
wait4
wait4
waitid
waitid
waitpid
waitpid
warn
warn
warnx
warnx
wcpcpy
wcpcpy
wcpncpy
wcpncpy
wcrtomb
wcrtomb
wcscasecmp
wcscasecmp
wcscasecmp_l
wcscasecmp_l
wcscat
wcscat
wcschr
wcschr
wcschrnul
wcschrnul
wcscmp
wcscmp
wcscoll
wcscoll
wcscoll_l
wcscoll_l
wcscpy
wcscpy
wcscspn
wcscspn
wcsdup
wcsdup
wcsftime
wcsftime
wcsftime_l
wcsftime_l
wcslen
wcslen
wcsncasecmp
wcsncasecmp
wcsncasecmp_l
wcsncasecmp_l
wcsncat
wcsncat
wcsncmp
wcsncmp
wcsncpy
wcsncpy
wcsnlen
wcsnlen
wcsnrtombs
wcsnrtombs
wcspbrk
wcspbrk
wcsrchr
wcsrchr
wcsrtombs
wcsrtombs
wcsspn
wcsspn
wcsstr
wcsstr
wcstod
wcstod
wcstod_l
wcstod_l
wcstof
wcstof
wcstof_l
wcstof_l
wcstoimax
wcstoimax
wcstok
wcstok
wcstol
wcstol
wcstol_l
wcstol_l
wcstold
wcstold
wcstold_l
wcstold_l
wcstoll
wcstoll
wcstoll_l
wcstoll_l
wcstombs
wcstombs
wcstoq
wcstoq
wcstoul
wcstoul
wcstoul_l
wcstoul_l
wcstoull
wcstoull
wcstoull_l
wcstoull_l
wcstoumax
wcstoumax
wcstouq
wcstouq
wcswcs
wcswcs
wcswidth
wcswidth
wcsxfrm
wcsxfrm
wcsxfrm_l
wcsxfrm_l
wctob
wctob
wctomb
wctomb
wctrans
wctrans
wctrans_l
wctrans_l
wctype
wctype
wctype_l
wctype_l
wcwidth
wcwidth
wmemchr
wmemchr
wmemcmp
wmemcmp
wmemcpy
wmemcpy
wmemmove
wmemmove
wmempcpy
wmempcpy
wmemset
wmemset
word boundaries, matching
Match-word-boundary Operator
wordexp
wordexp
wordfree
wordfree
wprintf
wprintf
wraparound integer arithmetic
Wraparound Arithmetic
write
write
writev
writev
wscanf
wscanf
xalloc_die
Out of memory handling
xdr_array
xdr_array
xdr_authunix_parms
xdr_authunix_parms
xdr_bool
xdr_bool
xdr_bytes
xdr_bytes
xdr_callhdr
xdr_callhdr
xdr_callmsg
xdr_callmsg
xdr_cback_data
xdr_cback_data
xdr_char
xdr_char
xdr_cryptkeyarg
xdr_cryptkeyarg
xdr_cryptkeyarg2
xdr_cryptkeyarg2
xdr_cryptkeyres
xdr_cryptkeyres
xdr_des_block
xdr_des_block
xdr_domainname
xdr_domainname
xdr_double
xdr_double
xdr_enum
xdr_enum
xdr_float
xdr_float
xdr_free
xdr_free
xdr_getcredres
xdr_getcredres
xdr_hyper
xdr_hyper
xdr_int
xdr_int
xdr_int16_t
xdr_int16_t
xdr_int32_t
xdr_int32_t
xdr_int64_t
xdr_int64_t
xdr_int8_t
xdr_int8_t
xdr_key_netstarg
xdr_key_netstarg
xdr_key_netstres
xdr_key_netstres
xdr_keybuf
xdr_keybuf
xdr_keydat
xdr_keydat
xdr_keystatus
xdr_keystatus
xdr_long
xdr_long
xdr_longlong_t
xdr_longlong_t
xdr_mapname
xdr_mapname
xdr_netnamestr
xdr_netnamestr
xdr_netobj
xdr_netobj
xdr_obj_p
xdr_obj_p
xdr_opaque
xdr_opaque
xdr_opaque_auth
xdr_opaque_auth
xdr_peername
xdr_peername
xdr_pmap
xdr_pmap
xdr_pmaplist
xdr_pmaplist
xdr_pointer
xdr_pointer
xdr_quad_t
xdr_quad_t
xdr_reference
xdr_reference
xdr_replymsg
xdr_replymsg
xdr_rmtcall_args
xdr_rmtcall_args
xdr_rmtcallres
xdr_rmtcallres
xdr_short
xdr_short
xdr_sizeof
xdr_sizeof
xdr_string
xdr_string
xdr_u_char
xdr_u_char
xdr_u_hyper
xdr_u_hyper
xdr_u_int
xdr_u_int
xdr_u_long
xdr_u_long
xdr_u_longlong_t
xdr_u_longlong_t
xdr_u_quad_t
xdr_u_quad_t
xdr_u_short
xdr_u_short
xdr_uint16_t
xdr_uint16_t
xdr_uint32_t
xdr_uint32_t
xdr_uint64_t
xdr_uint64_t
xdr_uint8_t
xdr_uint8_t
xdr_union
xdr_union
xdr_unixcred
xdr_unixcred
xdr_valdat
xdr_valdat
xdr_vector
xdr_vector
xdr_void
xdr_void
xdr_wrapstring
xdr_wrapstring
xdr_yp_buf
xdr_yp_buf
xdr_ypall
xdr_ypall
xdr_ypbind_binding
xdr_ypbind_binding
xdr_ypbind_resp
xdr_ypbind_resp
xdr_ypbind_resptype
xdr_ypbind_resptype
xdr_ypbind_setdom
xdr_ypbind_setdom
xdr_ypdelete_args
xdr_ypdelete_args
xdr_ypmap_parms
xdr_ypmap_parms
xdr_ypmaplist
xdr_ypmaplist
xdr_yppush_status
xdr_yppush_status
xdr_yppushresp_xfr
xdr_yppushresp_xfr
xdr_ypreq_key
xdr_ypreq_key
xdr_ypreq_nokey
xdr_ypreq_nokey
xdr_ypreq_xfr
xdr_ypreq_xfr
xdr_ypresp_all
xdr_ypresp_all
xdr_ypresp_key_val
xdr_ypresp_key_val
xdr_ypresp_maplist
xdr_ypresp_maplist
xdr_ypresp_master
xdr_ypresp_master
xdr_ypresp_order
xdr_ypresp_order
xdr_ypresp_val
xdr_ypresp_val
xdr_ypresp_xfr
xdr_ypresp_xfr
xdr_ypstat
xdr_ypstat
xdr_ypupdate_args
xdr_ypupdate_args
xdr_ypxfrstat
xdr_ypxfrstat
xdrmem_create
xdrmem_create
xdrrec_create
xdrrec_create
xdrrec_endofrecord
xdrrec_endofrecord
xdrrec_eof
xdrrec_eof
xdrrec_skiprecord
xdrrec_skiprecord
xdrstdio_create
xdrstdio_create
xprt_register
xprt_register
xprt_unregister
xprt_unregister
y0
y0
y0f
y0f
y0l
y0l
y1
y1
y1f
y1f
y1l
y1l
yn
yn
ynf
ynf
ynl
ynl
yp_all
yp_all
yp_bind
yp_bind
yp_first
yp_first
yp_get_default_domain
yp_get_default_domain
yp_master
yp_master
yp_match
yp_match
yp_next
yp_next
yp_order
yp_order
yp_unbind
yp_unbind
yp_update
yp_update
ypbinderr_string
ypbinderr_string
yperr_string
yperr_string
ypprot_err
ypprot_err
|
Alternation Operator

Prev: GNU Free Documentation License Top: Top


makecontext -- GNU Gnulib

Next: mktemp Prev: index Up: Legacy Function Substitutes Top: Top

10.15. makecontext

POSIX specification: http://www.opengroup.org/susv3xsh/makecontext.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mktemp Prev: index Up: Legacy Function Substitutes Top: Top


mktemp -- GNU Gnulib

Next: pthread_attr_getstackaddr Prev: makecontext Up: Legacy Function Substitutes Top: Top

10.16. mktemp

POSIX specification: http://www.opengroup.org/susv3xsh/mktemp.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is not appropriate for creating temporary files. (It has security risks.) Therefore it is marked as ``legacy'' in POSIX. Better use mkstemp instead.

Next: pthread_attr_getstackaddr Prev: makecontext Up: Legacy Function Substitutes Top: Top


pthread_attr_getstackaddr -- GNU Gnulib

Next: pthread_attr_setstackaddr Prev: mktemp Up: Legacy Function Substitutes Top: Top

10.17. pthread_attr_getstackaddr

POSIX specification: http://www.opengroup.org/susv3xsh/pthread_attr_getstackaddr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Solaris 2.4, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: pthread_attr_setstackaddr Prev: mktemp Up: Legacy Function Substitutes Top: Top


pthread_attr_setstackaddr -- GNU Gnulib

Next: rindex Prev: pthread_attr_getstackaddr Up: Legacy Function Substitutes Top: Top

10.18. pthread_attr_setstackaddr

POSIX specification: http://www.opengroup.org/susv3xsh/pthread_attr_setstackaddr.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, IRIX 5.3, Solaris 2.4, Cygwin 1.7.9, mingw, MSVC 14, BeOS.

Next: rindex Prev: pthread_attr_getstackaddr Up: Legacy Function Substitutes Top: Top


rindex -- GNU Gnulib

Next: scalb Prev: pthread_attr_setstackaddr Up: Legacy Function Substitutes Top: Top

10.19. rindex

POSIX specification: http://www.opengroup.org/susv3xsh/rindex.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14.
  • This function is marked as ``legacy'' in POSIX. Better use strrchr instead.

Next: scalb Prev: pthread_attr_setstackaddr Up: Legacy Function Substitutes Top: Top


scalb -- GNU Gnulib

Next: setcontext Prev: rindex Up: Legacy Function Substitutes Top: Top

10.20. scalb

POSIX specification: http://www.opengroup.org/susv3xsh/scalb.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:

Next: setcontext Prev: rindex Up: Legacy Function Substitutes Top: Top


setcontext -- GNU Gnulib

Next: swapcontext Prev: scalb Up: Legacy Function Substitutes Top: Top

10.21. setcontext

POSIX specification: http://www.opengroup.org/susv3xsh/setcontext.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • The effects of this call are system and compiler optimization dependent, since it restores the contents of register-allocated variables but not the contents of stack-allocated variables.

Next: swapcontext Prev: scalb Up: Legacy Function Substitutes Top: Top


swapcontext -- GNU Gnulib

Next: ualarm Prev: setcontext Up: Legacy Function Substitutes Top: Top

10.22. swapcontext

POSIX specification: http://www.opengroup.org/susv3xsh/swapcontext.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ualarm Prev: setcontext Up: Legacy Function Substitutes Top: Top


ualarm -- GNU Gnulib

Next: usleep Prev: swapcontext Up: Legacy Function Substitutes Top: Top

10.23. ualarm

POSIX specification: http://www.opengroup.org/susv3xsh/ualarm.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Solaris 2.4, mingw, MSVC 14, BeOS.

Next: usleep Prev: swapcontext Up: Legacy Function Substitutes Top: Top


usleep -- GNU Gnulib

Next: vfork Prev: ualarm Up: Legacy Function Substitutes Top: Top

10.24. usleep

POSIX specification: http://www.opengroup.org/susv3xsh/usleep.html

Gnulib module: usleep

Portability problems fixed by Gnulib:

  • On some systems, usleep rejects attempts to sleep longer than 1 second, as allowed by POSIX: mingw.
  • This function is missing on some platforms. However, the replacement is designed to be lightweight, and may round to the nearest second; use select or nanosleep if better resolution is needed: IRIX 5.3, Solaris 2.4, older mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:
  • According to POSIX, the usleep function may interfere with the program's use of the SIGALRM signal. On Linux, it doesn't; on other platforms, it may.

Next: vfork Prev: ualarm Up: Legacy Function Substitutes Top: Top


vfork -- GNU Gnulib

Next: wcswcs Prev: usleep Up: Legacy Function Substitutes Top: Top

10.25. vfork

POSIX specification: http://www.opengroup.org/susv3xsh/vfork.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: IRIX 6.5, mingw, MSVC 14, BeOS.

Next: wcswcs Prev: usleep Up: Legacy Function Substitutes Top: Top


wcswcs -- GNU Gnulib

Prev: vfork Up: Legacy Function Substitutes Top: Top

10.26. wcswcs

POSIX specification: http://www.opengroup.org/susv3xsh/wcswcs.html

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, IRIX 5.3, Solaris 2.5.1, Cygwin, mingw, MSVC 14, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.
  • This function is marked as ``legacy'' in POSIX. Better use wcsstr instead.

Prev: vfork Up: Legacy Function Substitutes Top: Top


Glibc Header File Substitutes -- GNU Gnulib

Next: Glibc Function Substitutes Prev: Legacy Function Substitutes Top: Top

11. Glibc Header File Substitutes

This chapter describes which header files contained in GNU libc but not specified by ISO C or POSIX are substituted by Gnulib, which portability pitfalls are fixed by Gnulib, and which (known) portability problems are not worked around by Gnulib.

Menu

  • a.out.h
  • aliases.h
  • alloca.h
  • ar.h
  • argp.h
  • argz.h
  • byteswap.h
  • crypt.h
  • endian.h
  • envz.h
  • err.h
  • error.h
  • execinfo.h
  • fpu_control.h
  • fstab.h
  • fts.h
  • getopt.h
  • gshadow.h
  • ieee754.h
  • ifaddrs.h
  • libintl.h
  • mcheck.h
  • mntent.h
  • obstack.h
  • paths.h
  • printf.h
  • pty.h
  • resolv.h
  • shadow.h
  • sys/ioctl.h
  • sysexits.h
  • ttyent.h

    • Next: Glibc Function Substitutes Prev: Legacy Function Substitutes Top: Top


a.out.h -- GNU Gnulib

Next: aliases.h Up: Glibc Header File Substitutes Top: Top

11.1. a.out.h

Describes the structure of executables (and object files?) in the old a.out format.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • This header file is useless because most executables and object files are in ELF format on some platforms: glibc 2.3.6, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8.

Next: aliases.h Up: Glibc Header File Substitutes Top: Top


aliases.h -- GNU Gnulib

Next: alloca.h Prev: a.out.h Up: Glibc Header File Substitutes Top: Top

11.2. aliases.h

Defines the type struct aliasent and declares the functions setaliasent, endaliasent, getaliasent, getaliasent_r, getaliasbyname, getaliasbyname_r.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/setaliasent.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: alloca.h Prev: a.out.h Up: Glibc Header File Substitutes Top: Top


alloca.h -- GNU Gnulib

Next: ar.h Prev: aliases.h Up: Glibc Header File Substitutes Top: Top

11.3. alloca.h

Declares the alloca function of function-like macro.

Documentation:

  • Automatic Storage with Variable Size, https://www.gnu.org/software/libc/manual/html_node/Variable-Size-Automatic.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/alloca.3.html.
Gnulib module: alloca

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 4.3.2, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: ar.h Prev: aliases.h Up: Glibc Header File Substitutes Top: Top


ar.h -- GNU Gnulib

Next: argp.h Prev: alloca.h Up: Glibc Header File Substitutes Top: Top

11.4. ar.h

Describes the structure of files produced by the `ar' program. Defines the type struct ar_hdr and the macros ARMAG, SARMAG, ARFMAG.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14, BeOS.

Next: argp.h Prev: alloca.h Up: Glibc Header File Substitutes Top: Top


argp.h -- GNU Gnulib

Next: argz.h Prev: ar.h Up: Glibc Header File Substitutes Top: Top

11.5. argp.h

Documentation:
  • Parsing Program Options with Argp, https://www.gnu.org/software/libc/manual/html_node/Argp.html.
Gnulib module: argp

Portability problems fixed by Gnulib:

  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: argz.h Prev: ar.h Up: Glibc Header File Substitutes Top: Top


argz.h -- GNU Gnulib

Next: byteswap.h Prev: argp.h Up: Glibc Header File Substitutes Top: Top

11.6. argz.h

Documentation:
  • Argz Functions, https://www.gnu.org/software/libc/manual/html_node/Argz-Functions.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/argz.3.html.
Gnulib module: argz

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • The argz functions do not work on some platforms: Cygwin.
Portability problems not fixed by Gnulib:

Next: byteswap.h Prev: argp.h Up: Glibc Header File Substitutes Top: Top


byteswap.h -- GNU Gnulib

Next: crypt.h Prev: argz.h Up: Glibc Header File Substitutes Top: Top

11.7. byteswap.h

Defines the functions or function-like macros bswap_16, bswap_32, bswap_64.

Gnulib module: byteswap

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: crypt.h Prev: argz.h Up: Glibc Header File Substitutes Top: Top


crypt.h -- GNU Gnulib

Next: endian.h Prev: byteswap.h Up: Glibc Header File Substitutes Top: Top

11.8. crypt.h

Defines the type struct crypt_data and declares the functions crypt, crypt_r, setkey, setkey_r, encrypt, encrypt_r.

Documentation:

  • Encrypting Passwords, DES Encryption, https://www.gnu.org/software/libc/manual/html_node/crypt.html, https://www.gnu.org/software/libc/manual/html_node/DES-Encryption.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/crypt.3.html, https://www.kernel.org/doc/man-pages/online/pages/man3/encrypt.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • The functions crypt, setkey, encrypt are missing on some platforms: HP-UX 11, OSF/1 5.1.
  • The type struct crypt_data and the functions crypt_r, setkey_r, encrypt_r are missing on some platforms: IRIX 6.5, Solaris 11.3, Cygwin.

Next: endian.h Prev: byteswap.h Up: Glibc Header File Substitutes Top: Top


endian.h -- GNU Gnulib

Next: envz.h Prev: crypt.h Up: Glibc Header File Substitutes Top: Top

11.9. endian.h

Describe's the platform's endianness (byte ordering of words stored in memory). Defines the macros BYTE_ORDER, LITTLE_ENDIAN, BIG_ENDIAN, PDP_ENDIAN.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5.

Next: envz.h Prev: crypt.h Up: Glibc Header File Substitutes Top: Top


envz.h -- GNU Gnulib

Next: err.h Prev: endian.h Up: Glibc Header File Substitutes Top: Top

11.10. envz.h

Documentation:
  • Envz Functions, https://www.gnu.org/software/libc/manual/html_node/Envz-Functions.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/envz.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: err.h Prev: endian.h Up: Glibc Header File Substitutes Top: Top


err.h -- GNU Gnulib

Next: error.h Prev: envz.h Up: Glibc Header File Substitutes Top: Top

11.11. err.h

Declares the functions warn, vwarn, warnx, vwarnx, err, verr, errx, verrx.

Documentation:

  • Error Messages, https://www.gnu.org/software/libc/manual/html_node/Error-Messages.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/err.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: error.h Prev: envz.h Up: Glibc Header File Substitutes Top: Top


error.h -- GNU Gnulib

Next: execinfo.h Prev: err.h Up: Glibc Header File Substitutes Top: Top

11.12. error.h

Declares the functions error, error_at_line and the variables error_print_progname, error_message_count, error_one_per_line.

Documentation:

  • Error Messages, https://www.gnu.org/software/libc/manual/html_node/Error-Messages.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/error.3.html.
Gnulib module: error

Portability problems fixed by Gnulib:

  • This header file is missing on many platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: execinfo.h Prev: err.h Up: Glibc Header File Substitutes Top: Top


execinfo.h -- GNU Gnulib

Next: fpu_control.h Prev: error.h Up: Glibc Header File Substitutes Top: Top

11.13. execinfo.h

Declares the functions backtrace, backtrace_symbols, backtrace_symbols_fd.

Documentation:

  • Backtraces, https://www.gnu.org/software/libc/manual/html_node/Backtraces.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/backtrace.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
  • On platforms where the header file is missing, the Gnulib substitute implementation is just a stub, and does nothing.

Next: fpu_control.h Prev: error.h Up: Glibc Header File Substitutes Top: Top


fpu_control.h -- GNU Gnulib

Next: fstab.h Prev: execinfo.h Up: Glibc Header File Substitutes Top: Top

11.14. fpu_control.h

Handling of the FPU control word. Defines the fpu_control_t type, declares the __fpu_control variable, and defines the _FPU_GETCW, _FPU_SETCW macros.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fstab.h Prev: execinfo.h Up: Glibc Header File Substitutes Top: Top


fstab.h -- GNU Gnulib

Next: fts.h Prev: fpu_control.h Up: Glibc Header File Substitutes Top: Top

11.15. fstab.h

Defines the type struct fstab, the macros FSTAB_*, _PATH_FSTAB, and declares the functions setfsent, endfsent, getfsent, getfsspec, getfsfile.

Documentation:

  • The `fstab' file, https://www.gnu.org/software/libc/manual/html_node/fstab.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/setfsent.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • The macro _PATH_FSTAB is missing on some platforms: AIX 5.1, HP-UX 11.

Next: fts.h Prev: fpu_control.h Up: Glibc Header File Substitutes Top: Top


fts.h -- GNU Gnulib

Next: getopt.h Prev: fstab.h Up: Glibc Header File Substitutes Top: Top

11.16. fts.h

Defines the types FTS, FTSENT and the macros FTS_*, and declares the functions fts_open, fts_read, fts_children, fts_set, fts_close.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/fts.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: getopt.h Prev: fstab.h Up: Glibc Header File Substitutes Top: Top


getopt.h -- GNU Gnulib

Next: gshadow.h Prev: fts.h Up: Glibc Header File Substitutes Top: Top

11.17. getopt.h

Defines the type struct option and declares the variables optarg, optind, opterr, optopt and the functions getopt, getopt_long, getopt_long_only.

Documentation:

  • Parsing program options using `getopt', https://www.gnu.org/software/libc/manual/html_node/Getopt.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/getopt.3.html.
Gnulib module: getopt-gnu

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: AIX 5.1, HP-UX 11, MSVC 14, Interix 3.5.
  • The function getopt_long is missing on some platforms: IRIX 6.5, OSF/1 5.1, Solaris 9.
  • The function getopt_long_only is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 5.0, IRIX 6.5, OSF/1 5.1, Solaris 9, mingw.
  • The method to reset options is incompatible on some platforms: FreeBSD 6.0, NetBSD 5.0(?), OpenBSD 3.8, Cygwin 1.5.x, mingw.
  • The function getopt does not handle a leading `+' character in the options string on some platforms: Solaris 11 2010-11.
Portability problems not fixed by Gnulib:

Next: gshadow.h Prev: fts.h Up: Glibc Header File Substitutes Top: Top


gshadow.h -- GNU Gnulib

Next: ieee754.h Prev: getopt.h Up: Glibc Header File Substitutes Top: Top

11.18. gshadow.h

Defines the type struct sgrp and declares the functions setsgent, endsgent, getsgent, getsgnam, sgetsgent, fgetsgent, putsgent, getsgent_r, getsgnam_r, sgetsgent_r, fgetsgent_r.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ieee754.h Prev: getopt.h Up: Glibc Header File Substitutes Top: Top


ieee754.h -- GNU Gnulib

Next: ifaddrs.h Prev: gshadow.h Up: Glibc Header File Substitutes Top: Top

11.19. ieee754.h

Defines the types union ieee754_float, union ieee754_double, union ieee854_long_double.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ifaddrs.h Prev: gshadow.h Up: Glibc Header File Substitutes Top: Top


ifaddrs.h -- GNU Gnulib

Next: libintl.h Prev: ieee754.h Up: Glibc Header File Substitutes Top: Top

11.20. ifaddrs.h

Defines the type struct ifaddrs and declares the functions getifaddrs, freeifaddrs.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/getifaddrs.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: libintl.h Prev: ieee754.h Up: Glibc Header File Substitutes Top: Top


libintl.h -- GNU Gnulib

Next: mcheck.h Prev: ifaddrs.h Up: Glibc Header File Substitutes Top: Top

11.21. libintl.h

Defines the macros __USE_GNU_GETTEXT, __GNU_GETTEXT_SUPPORTED_REVISION, and declares the functions gettext, dgettext, dcgettext, ngettext, dngettext, dcngettext, textdomain, bindtextdomain, bind_textdomain_codeset.

Documentation:

  • The `gettext' family of functions, https://www.gnu.org/software/libc/manual/html_node/Message-catalogs-with-gettext.html,
  • gettext, https://www.gnu.org/software/gettext/manual/html_node/gettext.html.
Gnulib module: gettext

Portability problems fixed by Gnulib, if GNU gettext is installed:

  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • The functions cannot deal with GNU .mo files with system-dependent strings (of major version 1 or of minor version 1) on some non-glibc platforms: NetBSD 3.0, Solaris 10.
Portability problems not fixed by Gnulib:

Next: mcheck.h Prev: ifaddrs.h Up: Glibc Header File Substitutes Top: Top


mcheck.h -- GNU Gnulib

Next: mntent.h Prev: libintl.h Up: Glibc Header File Substitutes Top: Top

11.22. mcheck.h

Defines the type enum mcheck_status and declares the functions mcheck, mcheck_pedantic, mcheck_check_all, mprobe, mtrace, muntrace.

Documentation:

  • Heap Consistency Checking, https://www.gnu.org/software/libc/manual/html_node/Heap-Consistency-Checking.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mntent.h Prev: libintl.h Up: Glibc Header File Substitutes Top: Top


mntent.h -- GNU Gnulib

Next: obstack.h Prev: mcheck.h Up: Glibc Header File Substitutes Top: Top

11.23. mntent.h

Defines the type struct mntent and the macros MNTTAB, MOUNTED, MNTTYPE_*, MNTOPT_*, and declares the functions setmntent, getmntent, getmntent_r, addmntent, endmntent, hasmntopt.

Documentation:

  • The `mtab' file, https://www.gnu.org/software/libc/manual/html_node/mtab.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/setmntent.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • The function getmntent_r is missing on all non-glibc platforms: AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin.
Gnulib module mountlist provides a higher-level abstraction.

Next: obstack.h Prev: mcheck.h Up: Glibc Header File Substitutes Top: Top


obstack.h -- GNU Gnulib

Next: paths.h Prev: mntent.h Up: Glibc Header File Substitutes Top: Top

11.24. obstack.h

Documentation:
  • Obstacks, https://www.gnu.org/software/libc/manual/html_node/Obstacks.html.
Gnulib module: obstack

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: paths.h Prev: mntent.h Up: Glibc Header File Substitutes Top: Top


paths.h -- GNU Gnulib

Next: printf.h Prev: obstack.h Up: Glibc Header File Substitutes Top: Top

11.25. paths.h

Defines the macros _PATH_*.

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11 2010-11, mingw, MSVC 14, BeOS.
  • The set of _PATH_* macros is platform dependent.

Next: printf.h Prev: obstack.h Up: Glibc Header File Substitutes Top: Top


printf.h -- GNU Gnulib

Next: pty.h Prev: paths.h Up: Glibc Header File Substitutes Top: Top

11.26. printf.h

Defines the type struct printf_info and the macros and enum values PA_*, and declares the functions printf_function, printf_arginfo_function, register_printf_function, parse_printf_format, printf_size, printf_size_info.

Documentation:

  • Parsing a Template String, https://www.gnu.org/software/libc/manual/html_node/Parsing-a-Template-String.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: pty.h Prev: paths.h Up: Glibc Header File Substitutes Top: Top


pty.h -- GNU Gnulib

Next: resolv.h Prev: printf.h Up: Glibc Header File Substitutes Top: Top

11.27. pty.h

Declares the functions openpty and forkpty.

Documentation:

  • Opening a Pseudo-Terminal Pair, https://www.gnu.org/software/libc/manual/html_node/Pseudo_002dTerminal-Pairs.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man3/openpty.3.html.
Gnulib module: pty

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms that declare the forkpty and openpty functions in util.h or libutil.h instead: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8.
  • This header file is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, BeOS.
Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: mingw, MSVC 14.

Next: resolv.h Prev: printf.h Up: Glibc Header File Substitutes Top: Top


resolv.h -- GNU Gnulib

Next: shadow.h Prev: pty.h Up: Glibc Header File Substitutes Top: Top

11.28. resolv.h

Defines the types res_sendhookact, res_send_qhook, res_send_rhook, res_state, struct res_sym and the macros _PATH_RESCONF, RES_*, and declares the functions fp_nquery, fp_query, hostalias, p_query, res_close, res_init, res_isourserver, res_mkquery, res_query, res_querydomain, res_search, res_send.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/res_init.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • The functions are missing on some platforms: HP-UX 11.

Next: shadow.h Prev: pty.h Up: Glibc Header File Substitutes Top: Top


shadow.h -- GNU Gnulib

Next: sys/ioctl.h Prev: resolv.h Up: Glibc Header File Substitutes Top: Top

11.29. shadow.h

Defines the type struct spwd and declares the functions setspent, endspent, getspent, getspent_r, getspnam, getspnam_r, sgetspent, sgetspent_r, fgetspent, fgetspent_r, putspent, lckpwdf, ulckpwdf.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/setspent.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • The functions getspent_r, getspnam_r, sgetspent_r, fgetspent, fgetspent_r, putspent are missing on some platforms: HP-UX 11.
  • The functions sgetspent, sgetspent_r are missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3.

Next: sys/ioctl.h Prev: resolv.h Up: Glibc Header File Substitutes Top: Top


sys/ioctl.h -- GNU Gnulib

Next: sysexits.h Prev: shadow.h Up: Glibc Header File Substitutes Top: Top

11.30. sys/ioctl.h

Declares the function ioctl.

Documentation:

  • IOCTLs, https://www.gnu.org/software/libc/manual/html_node/IOCTLs.html,
  • https://www.kernel.org/doc/man-pages/online/pages/man2/ioctl.2.html.
Gnulib module: sys_ioctl

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14.
  • This header file does not declare the ioctl function on some platforms: AIX 5.1, Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: sysexits.h Prev: shadow.h Up: Glibc Header File Substitutes Top: Top


sysexits.h -- GNU Gnulib

Next: ttyent.h Prev: sys/ioctl.h Up: Glibc Header File Substitutes Top: Top

11.31. sysexits.h

Defines the EX_* macros, including EX_OK.

Gnulib module: sysexits

Portability problems fixed by Gnulib:

  • This header file is missing on some platforms: mingw, MSVC 14, Interix 3.5, BeOS.
  • The macro EX_CONFIG is missing on some platforms: HP-UX 11.
Portability problems not fixed by Gnulib:

Next: ttyent.h Prev: sys/ioctl.h Up: Glibc Header File Substitutes Top: Top


ttyent.h -- GNU Gnulib

Prev: sysexits.h Up: Glibc Header File Substitutes Top: Top

11.32. ttyent.h

Defines the type struct ttyent and declares the functions setttyent, endttyent, getttyent, getttynam.

Documentation:

  • https://www.kernel.org/doc/man-pages/online/pages/man3/setttyent.3.html.
Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This header file is missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: sysexits.h Up: Glibc Header File Substitutes Top: Top


Glibc Function Substitutes -- GNU Gnulib

Next: Native Windows Support Prev: Glibc Header File Substitutes Top: Top

12. Glibc Function Substitutes

This chapter describes which functions and function-like macros provided as extensions by at least GNU libc are also supported by Gnulib, which portability pitfalls are fixed by Gnulib, and which (known) portability problems are not worked around by Gnulib.

This list of functions is sorted according to the header that declares them.

Menu

  • Glibc aio.h
  • Glibc aliases.h
  • Glibc argp.h
  • Glibc argz.h
  • Glibc arpa/inet.h
  • Glibc byteswap.h
  • Glibc complex.h
  • Glibc crypt.h
  • Glibc ctype.h
  • Glibc dirent.h
  • Glibc dlfcn.h
  • Glibc envz.h
  • Glibc err.h
  • Glibc errno.h
  • Glibc error.h
  • Glibc execinfo.h
  • Glibc fcntl.h
  • Glibc fenv.h
  • Glibc fmtmsg.h
  • Glibc fstab.h
  • Glibc fts.h
  • Glibc getopt.h
  • Glibc glob.h
  • Glibc gnu/libc-version.h
  • Glibc grp.h
  • Glibc gshadow.h
  • Glibc ifaddrs.h
  • Glibc libintl.h
  • Glibc link.h
  • Glibc malloc.h
  • Glibc math.h
  • Glibc mcheck.h
  • Glibc mntent.h
  • Glibc netdb.h
  • Glibc netinet/ether.h
  • Glibc netinet/in.h
  • Glibc obstack.h
  • Glibc printf.h
  • Glibc pthread.h
  • Glibc pty.h
  • Glibc pwd.h
  • Glibc regex.h
  • Glibc regexp.h
  • Glibc resolv.h
  • Glibc rpc/auth.h
  • Glibc rpc/auth_des.h
  • Glibc rpc/auth_unix.h
  • Glibc rpc/clnt.h
  • Glibc rpc/des_crypt.h
  • Glibc rpc/key_prot.h
  • Glibc rpc/netdb.h
  • Glibc rpc/pmap_clnt.h
  • Glibc rpc/pmap_prot.h
  • Glibc rpc/pmap_rmt.h
  • Glibc rpc/rpc_msg.h
  • Glibc rpc/svc.h
  • Glibc rpc/xdr.h
  • Glibc rpcsvc/nislib.h
  • Glibc rpcsvc/nis_callback.h
  • Glibc rpcsvc/yp.h
  • Glibc rpcsvc/yp_prot.h
  • Glibc rpcsvc/ypclnt.h
  • Glibc rpcsvc/ypupd.h
  • Glibc sched.h
  • Glibc search.h
  • Glibc selinux/selinux.h
  • Glibc shadow.h
  • Glibc signal.h
  • Glibc stdio.h
  • Glibc stdlib.h
  • Glibc string.h
  • Glibc sys/capability.h
  • Glibc sys/epoll.h
  • Glibc sys/fanotify.h
  • Glibc sys/file.h
  • Glibc sys/fsuid.h
  • Glibc sys/gmon.h
  • Glibc sys/io.h and sys/perm.h
  • Glibc sys/kdaemon.h
  • Glibc sys/klog.h
  • Glibc sys/mman.h
  • Glibc sys/mount.h
  • Glibc sys/personality.h
  • Glibc sys/prctl.h
  • Glibc sys/profil.h
  • Glibc sys/ptrace.h
  • Glibc sys/quota.h
  • Glibc sys/reboot.h
  • Glibc sys/resource.h
  • Glibc sys/sem.h
  • Glibc sys/sendfile.h
  • Glibc sys/socket.h
  • Glibc sys/stat.h
  • Glibc sys/statfs.h
  • Glibc sys/swap.h
  • Glibc sys/sysctl.h
  • Glibc sys/sysinfo.h
  • Glibc sys/syslog.h
  • Glibc sys/sysmacros.h
  • Glibc sys/time.h
  • Glibc sys/timex.h
  • Glibc sys/uio.h
  • Glibc sys/ustat.h
  • Glibc sys/vlimit.h
  • Glibc sys/vm86.h
  • Glibc sys/vtimes.h
  • Glibc sys/wait.h
  • Glibc sys/xattr.h
  • Glibc termios.h
  • Glibc time.h
  • Glibc ttyent.h
  • Glibc unistd.h
  • Glibc utmp.h
  • Glibc utmpx.h
  • Glibc wchar.h

    • Next: Native Windows Support Prev: Glibc Header File Substitutes Top: Top


Glibc aio.h -- GNU Gnulib

Next: Glibc aliases.h Up: Glibc Function Substitutes Top: Top

12.1. Glibc Extensions to <aio.h>

Menu

  • aio_init


aio_init -- GNU Gnulib

Up: Glibc aio.h Top: Top

12.1.1. aio_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc aio.h Top: Top


Glibc aliases.h -- GNU Gnulib

Next: Glibc argp.h Prev: Glibc aio.h Up: Glibc Function Substitutes Top: Top

12.2. Glibc <aliases.h>

Menu

  • endaliasent
  • getaliasbyname
  • getaliasbyname_r
  • getaliasent
  • getaliasent_r
  • setaliasent


endaliasent -- GNU Gnulib

Next: getaliasbyname Up: Glibc aliases.h Top: Top

12.2.1. endaliasent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getaliasbyname Up: Glibc aliases.h Top: Top


getaliasbyname -- GNU Gnulib

Next: getaliasbyname_r Prev: endaliasent Up: Glibc aliases.h Top: Top

12.2.2. getaliasbyname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getaliasbyname_r Prev: endaliasent Up: Glibc aliases.h Top: Top


getaliasbyname_r -- GNU Gnulib

Next: getaliasent Prev: getaliasbyname Up: Glibc aliases.h Top: Top

12.2.3. getaliasbyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getaliasent Prev: getaliasbyname Up: Glibc aliases.h Top: Top


getaliasent -- GNU Gnulib

Next: getaliasent_r Prev: getaliasbyname_r Up: Glibc aliases.h Top: Top

12.2.4. getaliasent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getaliasent_r Prev: getaliasbyname_r Up: Glibc aliases.h Top: Top


getaliasent_r -- GNU Gnulib

Next: setaliasent Prev: getaliasent Up: Glibc aliases.h Top: Top

12.2.5. getaliasent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setaliasent Prev: getaliasent Up: Glibc aliases.h Top: Top


setaliasent -- GNU Gnulib

Prev: getaliasent_r Up: Glibc aliases.h Top: Top

12.2.6. setaliasent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getaliasent_r Up: Glibc aliases.h Top: Top


Glibc argp.h -- GNU Gnulib

Next: Glibc argz.h Prev: Glibc aliases.h Up: Glibc Function Substitutes Top: Top

12.3. Glibc <argp.h>

Menu

  • argp_err_exit_status
  • argp_error
  • argp_failure
  • argp_help
  • argp_parse
  • argp_program_bug_address
  • argp_program_version
  • argp_program_version_hook
  • argp_state_help
  • argp_usage

    • Next: Glibc argz.h Prev: Glibc aliases.h Up: Glibc Function Substitutes Top: Top


argp_err_exit_status -- GNU Gnulib

Next: argp_error Up: Glibc argp.h Top: Top

12.3.1. argp_err_exit_status

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_error Up: Glibc argp.h Top: Top


argp_error -- GNU Gnulib

Next: argp_failure Prev: argp_err_exit_status Up: Glibc argp.h Top: Top

12.3.2. argp_error

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_failure Prev: argp_err_exit_status Up: Glibc argp.h Top: Top


argp_failure -- GNU Gnulib

Next: argp_help Prev: argp_error Up: Glibc argp.h Top: Top

12.3.3. argp_failure

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_help Prev: argp_error Up: Glibc argp.h Top: Top


argp_help -- GNU Gnulib

Next: argp_parse Prev: argp_failure Up: Glibc argp.h Top: Top

12.3.4. argp_help

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_parse Prev: argp_failure Up: Glibc argp.h Top: Top


argp_parse -- GNU Gnulib

Next: argp_program_bug_address Prev: argp_help Up: Glibc argp.h Top: Top

12.3.5. argp_parse

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_program_bug_address Prev: argp_help Up: Glibc argp.h Top: Top


argp_program_bug_address -- GNU Gnulib

Next: argp_program_version Prev: argp_parse Up: Glibc argp.h Top: Top

12.3.6. argp_program_bug_address

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_program_version Prev: argp_parse Up: Glibc argp.h Top: Top


argp_program_version -- GNU Gnulib

Next: argp_program_version_hook Prev: argp_program_bug_address Up: Glibc argp.h Top: Top

12.3.7. argp_program_version

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_program_version_hook Prev: argp_program_bug_address Up: Glibc argp.h Top: Top


argp_program_version_hook -- GNU Gnulib

Next: argp_state_help Prev: argp_program_version Up: Glibc argp.h Top: Top

12.3.8. argp_program_version_hook

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_state_help Prev: argp_program_version Up: Glibc argp.h Top: Top


argp_state_help -- GNU Gnulib

Next: argp_usage Prev: argp_program_version_hook Up: Glibc argp.h Top: Top

12.3.9. argp_state_help

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: argp_usage Prev: argp_program_version_hook Up: Glibc argp.h Top: Top


argp_usage -- GNU Gnulib

Prev: argp_state_help Up: Glibc argp.h Top: Top

12.3.10. argp_usage

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: argp_state_help Up: Glibc argp.h Top: Top


Glibc argz.h -- GNU Gnulib

Next: Glibc arpa/inet.h Prev: Glibc argp.h Up: Glibc Function Substitutes Top: Top

12.4. Glibc <argz.h>

Menu

  • argz_add
  • argz_add_sep
  • argz_append
  • argz_count
  • argz_create
  • argz_create_sep
  • argz_delete
  • argz_extract
  • argz_insert
  • argz_next
  • argz_replace
  • argz_stringify

    • Next: Glibc arpa/inet.h Prev: Glibc argp.h Up: Glibc Function Substitutes Top: Top


argz_add -- GNU Gnulib

Next: argz_add_sep Up: Glibc argz.h Top: Top

12.4.1. argz_add

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_add_sep Up: Glibc argz.h Top: Top


argz_add_sep -- GNU Gnulib

Next: argz_append Prev: argz_add Up: Glibc argz.h Top: Top

12.4.2. argz_add_sep

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_append Prev: argz_add Up: Glibc argz.h Top: Top


argz_append -- GNU Gnulib

Next: argz_count Prev: argz_add_sep Up: Glibc argz.h Top: Top

12.4.3. argz_append

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_count Prev: argz_add_sep Up: Glibc argz.h Top: Top


argz_count -- GNU Gnulib

Next: argz_create Prev: argz_append Up: Glibc argz.h Top: Top

12.4.4. argz_count

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_create Prev: argz_append Up: Glibc argz.h Top: Top


argz_create -- GNU Gnulib

Next: argz_create_sep Prev: argz_count Up: Glibc argz.h Top: Top

12.4.5. argz_create

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_create_sep Prev: argz_count Up: Glibc argz.h Top: Top


argz_create_sep -- GNU Gnulib

Next: argz_delete Prev: argz_create Up: Glibc argz.h Top: Top

12.4.6. argz_create_sep

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_delete Prev: argz_create Up: Glibc argz.h Top: Top


argz_delete -- GNU Gnulib

Next: argz_extract Prev: argz_create_sep Up: Glibc argz.h Top: Top

12.4.7. argz_delete

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_extract Prev: argz_create_sep Up: Glibc argz.h Top: Top


argz_extract -- GNU Gnulib

Next: argz_insert Prev: argz_delete Up: Glibc argz.h Top: Top

12.4.8. argz_extract

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_insert Prev: argz_delete Up: Glibc argz.h Top: Top


argz_insert -- GNU Gnulib

Next: argz_next Prev: argz_extract Up: Glibc argz.h Top: Top

12.4.9. argz_insert

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_next Prev: argz_extract Up: Glibc argz.h Top: Top


argz_next -- GNU Gnulib

Next: argz_replace Prev: argz_insert Up: Glibc argz.h Top: Top

12.4.10. argz_next

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_replace Prev: argz_insert Up: Glibc argz.h Top: Top


argz_replace -- GNU Gnulib

Next: argz_stringify Prev: argz_next Up: Glibc argz.h Top: Top

12.4.11. argz_replace

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Next: argz_stringify Prev: argz_next Up: Glibc argz.h Top: Top


argz_stringify -- GNU Gnulib

Prev: argz_replace Up: Glibc argz.h Top: Top

12.4.12. argz_stringify

Gnulib module: argz

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function is broken on some platforms: Cygwin 1.5.24.
Portability problems not fixed by Gnulib:

Prev: argz_replace Up: Glibc argz.h Top: Top


Glibc arpa/inet.h -- GNU Gnulib

Next: Glibc byteswap.h Prev: Glibc argz.h Up: Glibc Function Substitutes Top: Top

12.5. Glibc Extensions to <arpa/inet.h>

Menu

  • inet_aton
  • inet_lnaof
  • inet_makeaddr
  • inet_net_ntop
  • inet_net_pton
  • inet_neta
  • inet_netof
  • inet_network
  • inet_nsap_addr
  • inet_nsap_ntoa

    • Next: Glibc byteswap.h Prev: Glibc argz.h Up: Glibc Function Substitutes Top: Top


inet_aton -- GNU Gnulib

Next: inet_lnaof Up: Glibc arpa/inet.h Top: Top

12.5.1. inet_aton

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: inet_lnaof Up: Glibc arpa/inet.h Top: Top


inet_lnaof -- GNU Gnulib

Next: inet_makeaddr Prev: inet_aton Up: Glibc arpa/inet.h Top: Top

12.5.2. inet_lnaof

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: inet_makeaddr Prev: inet_aton Up: Glibc arpa/inet.h Top: Top


inet_makeaddr -- GNU Gnulib

Next: inet_net_ntop Prev: inet_lnaof Up: Glibc arpa/inet.h Top: Top

12.5.3. inet_makeaddr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: inet_net_ntop Prev: inet_lnaof Up: Glibc arpa/inet.h Top: Top


inet_net_ntop -- GNU Gnulib

Next: inet_net_pton Prev: inet_makeaddr Up: Glibc arpa/inet.h Top: Top

12.5.4. inet_net_ntop

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, OSF/1 4.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet_net_pton Prev: inet_makeaddr Up: Glibc arpa/inet.h Top: Top


inet_net_pton -- GNU Gnulib

Next: inet_neta Prev: inet_net_ntop Up: Glibc arpa/inet.h Top: Top

12.5.5. inet_net_pton

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, OSF/1 4.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet_neta Prev: inet_net_ntop Up: Glibc arpa/inet.h Top: Top


inet_neta -- GNU Gnulib

Next: inet_netof Prev: inet_net_pton Up: Glibc arpa/inet.h Top: Top

12.5.6. inet_neta

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 6.5, OSF/1 4.0, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet_netof Prev: inet_net_pton Up: Glibc arpa/inet.h Top: Top


inet_netof -- GNU Gnulib

Next: inet_network Prev: inet_neta Up: Glibc arpa/inet.h Top: Top

12.5.7. inet_netof

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: inet_network Prev: inet_neta Up: Glibc arpa/inet.h Top: Top


inet_network -- GNU Gnulib

Next: inet_nsap_addr Prev: inet_netof Up: Glibc arpa/inet.h Top: Top

12.5.8. inet_network

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: inet_nsap_addr Prev: inet_netof Up: Glibc arpa/inet.h Top: Top


inet_nsap_addr -- GNU Gnulib

Next: inet_nsap_ntoa Prev: inet_network Up: Glibc arpa/inet.h Top: Top

12.5.9. inet_nsap_addr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet_nsap_ntoa Prev: inet_network Up: Glibc arpa/inet.h Top: Top


inet_nsap_ntoa -- GNU Gnulib

Prev: inet_nsap_addr Up: Glibc arpa/inet.h Top: Top

12.5.10. inet_nsap_ntoa

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.00, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: inet_nsap_addr Up: Glibc arpa/inet.h Top: Top


Glibc byteswap.h -- GNU Gnulib

Next: Glibc complex.h Prev: Glibc arpa/inet.h Up: Glibc Function Substitutes Top: Top

12.6. Glibc <byteswap.h>

Menu

  • bswap_16
  • bswap_32
  • bswap_64


bswap_16 -- GNU Gnulib

Next: bswap_32 Up: Glibc byteswap.h Top: Top

12.6.1. bswap_16

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: bswap_32 Up: Glibc byteswap.h Top: Top


bswap_32 -- GNU Gnulib

Next: bswap_64 Prev: bswap_16 Up: Glibc byteswap.h Top: Top

12.6.2. bswap_32

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: bswap_64 Prev: bswap_16 Up: Glibc byteswap.h Top: Top


bswap_64 -- GNU Gnulib

Prev: bswap_32 Up: Glibc byteswap.h Top: Top

12.6.3. bswap_64

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: bswap_32 Up: Glibc byteswap.h Top: Top


Glibc complex.h -- GNU Gnulib

Next: Glibc crypt.h Prev: Glibc byteswap.h Up: Glibc Function Substitutes Top: Top

12.7. Glibc Extensions to <complex.h>

Menu

  • clog10
  • clog10f
  • clog10l


clog10 -- GNU Gnulib

Next: clog10f Up: Glibc complex.h Top: Top

12.7.1. clog10

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5.

Next: clog10f Up: Glibc complex.h Top: Top


clog10f -- GNU Gnulib

Next: clog10l Prev: clog10 Up: Glibc complex.h Top: Top

12.7.2. clog10f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5.

Next: clog10l Prev: clog10 Up: Glibc complex.h Top: Top


clog10l -- GNU Gnulib

Prev: clog10f Up: Glibc complex.h Top: Top

12.7.3. clog10l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 9, Interix 3.5, BeOS.

Prev: clog10f Up: Glibc complex.h Top: Top


Glibc crypt.h -- GNU Gnulib

Next: Glibc ctype.h Prev: Glibc complex.h Up: Glibc Function Substitutes Top: Top

12.8. Glibc <crypt.h>

Menu

  • crypt_r
  • encrypt_r
  • setkey_r


crypt_r -- GNU Gnulib

Next: encrypt_r Up: Glibc crypt.h Top: Top

12.8.1. crypt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: encrypt_r Up: Glibc crypt.h Top: Top


encrypt_r -- GNU Gnulib

Next: setkey_r Prev: crypt_r Up: Glibc crypt.h Top: Top

12.8.2. encrypt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setkey_r Prev: crypt_r Up: Glibc crypt.h Top: Top


setkey_r -- GNU Gnulib

Prev: encrypt_r Up: Glibc crypt.h Top: Top

12.8.3. setkey_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: encrypt_r Up: Glibc crypt.h Top: Top


Glibc ctype.h -- GNU Gnulib

Next: Glibc dirent.h Prev: Glibc crypt.h Up: Glibc Function Substitutes Top: Top

12.9. Glibc Extensions to <ctype.h>

Menu

  • isctype


isctype -- GNU Gnulib

Up: Glibc ctype.h Top: Top

12.9.1. isctype

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc ctype.h Top: Top


Glibc dirent.h -- GNU Gnulib

Next: Glibc dlfcn.h Prev: Glibc ctype.h Up: Glibc Function Substitutes Top: Top

12.10. Glibc Extensions to <dirent.h>

Menu

  • getdirentries
  • scandirat
  • versionsort


getdirentries -- GNU Gnulib

Next: scandirat Up: Glibc dirent.h Top: Top

12.10.1. getdirentries

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on huge directories larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: scandirat Up: Glibc dirent.h Top: Top


scandirat -- GNU Gnulib

Next: versionsort Prev: getdirentries Up: Glibc dirent.h Top: Top

12.10.2. scandirat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.14, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.10, mingw, MSVC 14, Interix 3.5, BeOS.

Next: versionsort Prev: getdirentries Up: Glibc dirent.h Top: Top


versionsort -- GNU Gnulib

Prev: scandirat Up: Glibc dirent.h Top: Top

12.10.3. versionsort

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: scandirat Up: Glibc dirent.h Top: Top


Glibc dlfcn.h -- GNU Gnulib

Next: Glibc envz.h Prev: Glibc dirent.h Up: Glibc Function Substitutes Top: Top

12.11. Glibc Extensions to <dlfcn.h>

Menu

  • dladdr
  • dladdr1
  • dlinfo
  • dlmopen
  • dlvsym


dladdr -- GNU Gnulib

Next: dladdr1 Up: Glibc dlfcn.h Top: Top

12.11.1. dladdr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dladdr1 Up: Glibc dlfcn.h Top: Top


dladdr1 -- GNU Gnulib

Next: dlinfo Prev: dladdr Up: Glibc dlfcn.h Top: Top

12.11.2. dladdr1

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dlinfo Prev: dladdr Up: Glibc dlfcn.h Top: Top


dlinfo -- GNU Gnulib

Next: dlmopen Prev: dladdr1 Up: Glibc dlfcn.h Top: Top

12.11.3. dlinfo

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dlmopen Prev: dladdr1 Up: Glibc dlfcn.h Top: Top


dlmopen -- GNU Gnulib

Next: dlvsym Prev: dlinfo Up: Glibc dlfcn.h Top: Top

12.11.4. dlmopen

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dlvsym Prev: dlinfo Up: Glibc dlfcn.h Top: Top


dlvsym -- GNU Gnulib

Prev: dlmopen Up: Glibc dlfcn.h Top: Top

12.11.5. dlvsym

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: dlmopen Up: Glibc dlfcn.h Top: Top


Glibc envz.h -- GNU Gnulib

Next: Glibc err.h Prev: Glibc dlfcn.h Up: Glibc Function Substitutes Top: Top

12.12. Glibc <envz.h>

Menu

  • envz_add
  • envz_entry
  • envz_get
  • envz_merge
  • envz_remove
  • envz_strip


envz_add -- GNU Gnulib

Next: envz_entry Up: Glibc envz.h Top: Top

12.12.1. envz_add

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: envz_entry Up: Glibc envz.h Top: Top


envz_entry -- GNU Gnulib

Next: envz_get Prev: envz_add Up: Glibc envz.h Top: Top

12.12.2. envz_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: envz_get Prev: envz_add Up: Glibc envz.h Top: Top


envz_get -- GNU Gnulib

Next: envz_merge Prev: envz_entry Up: Glibc envz.h Top: Top

12.12.3. envz_get

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: envz_merge Prev: envz_entry Up: Glibc envz.h Top: Top


envz_merge -- GNU Gnulib

Next: envz_remove Prev: envz_get Up: Glibc envz.h Top: Top

12.12.4. envz_merge

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: envz_remove Prev: envz_get Up: Glibc envz.h Top: Top


envz_remove -- GNU Gnulib

Next: envz_strip Prev: envz_merge Up: Glibc envz.h Top: Top

12.12.5. envz_remove

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: envz_strip Prev: envz_merge Up: Glibc envz.h Top: Top


envz_strip -- GNU Gnulib

Prev: envz_remove Up: Glibc envz.h Top: Top

12.12.6. envz_strip

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: envz_remove Up: Glibc envz.h Top: Top


Glibc err.h -- GNU Gnulib

Next: Glibc errno.h Prev: Glibc envz.h Up: Glibc Function Substitutes Top: Top

12.13. Glibc <err.h>

Menu

  • err
  • errx
  • verr
  • verrx
  • vwarn
  • vwarnx
  • warn
  • warnx

    • Next: Glibc errno.h Prev: Glibc envz.h Up: Glibc Function Substitutes Top: Top


err -- GNU Gnulib

Next: errx Up: Glibc err.h Top: Top

12.13.1. err

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: errx Up: Glibc err.h Top: Top


errx -- GNU Gnulib

Next: verr Prev: err Up: Glibc err.h Top: Top

12.13.2. errx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: verr Prev: err Up: Glibc err.h Top: Top


verr -- GNU Gnulib

Next: verrx Prev: errx Up: Glibc err.h Top: Top

12.13.3. verr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: verrx Prev: errx Up: Glibc err.h Top: Top


verrx -- GNU Gnulib

Next: vwarn Prev: verr Up: Glibc err.h Top: Top

12.13.4. verrx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: vwarn Prev: verr Up: Glibc err.h Top: Top


vwarn -- GNU Gnulib

Next: vwarnx Prev: verrx Up: Glibc err.h Top: Top

12.13.5. vwarn

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: vwarnx Prev: verrx Up: Glibc err.h Top: Top


vwarnx -- GNU Gnulib

Next: warn Prev: vwarn Up: Glibc err.h Top: Top

12.13.6. vwarnx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: warn Prev: vwarn Up: Glibc err.h Top: Top


warn -- GNU Gnulib

Next: warnx Prev: vwarnx Up: Glibc err.h Top: Top

12.13.7. warn

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Next: warnx Prev: vwarnx Up: Glibc err.h Top: Top


warnx -- GNU Gnulib

Prev: warn Up: Glibc err.h Top: Top

12.13.8. warnx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.

Prev: warn Up: Glibc err.h Top: Top


Glibc errno.h -- GNU Gnulib

Next: Glibc error.h Prev: Glibc err.h Up: Glibc Function Substitutes Top: Top

12.14. Glibc Extensions to <errno.h>

Menu

  • program_invocation_name
  • program_invocation_short_name


program_invocation_name -- GNU Gnulib

Next: program_invocation_short_name Up: Glibc errno.h Top: Top

12.14.1. program_invocation_name

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5.

Next: program_invocation_short_name Up: Glibc errno.h Top: Top


program_invocation_short_name -- GNU Gnulib

Prev: program_invocation_name Up: Glibc errno.h Top: Top

12.14.2. program_invocation_short_name

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5.

Prev: program_invocation_name Up: Glibc errno.h Top: Top


Glibc error.h -- GNU Gnulib

Next: Glibc execinfo.h Prev: Glibc errno.h Up: Glibc Function Substitutes Top: Top

12.15. Glibc <error.h>

Menu

  • error
  • error_at_line
  • error_message_count
  • error_one_per_line
  • error_print_progname


error -- GNU Gnulib

Next: error_at_line Up: Glibc error.h Top: Top

12.15.1. error

Gnulib module: error

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: error_at_line Up: Glibc error.h Top: Top


error_at_line -- GNU Gnulib

Next: error_message_count Prev: error Up: Glibc error.h Top: Top

12.15.2. error_at_line

Gnulib module: error

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: error_message_count Prev: error Up: Glibc error.h Top: Top


error_message_count -- GNU Gnulib

Next: error_one_per_line Prev: error_at_line Up: Glibc error.h Top: Top

12.15.3. error_message_count

Gnulib module: error

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: error_one_per_line Prev: error_at_line Up: Glibc error.h Top: Top


error_one_per_line -- GNU Gnulib

Next: error_print_progname Prev: error_message_count Up: Glibc error.h Top: Top

12.15.4. error_one_per_line

Gnulib module: error

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: error_print_progname Prev: error_message_count Up: Glibc error.h Top: Top


error_print_progname -- GNU Gnulib

Prev: error_one_per_line Up: Glibc error.h Top: Top

12.15.5. error_print_progname

Gnulib module: error

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: error_one_per_line Up: Glibc error.h Top: Top


Glibc execinfo.h -- GNU Gnulib

Next: Glibc fcntl.h Prev: Glibc error.h Up: Glibc Function Substitutes Top: Top

12.16. Glibc <execinfo.h>

Menu

  • backtrace
  • backtrace_symbols
  • backtrace_symbols_fd


backtrace -- GNU Gnulib

Next: backtrace_symbols Up: Glibc execinfo.h Top: Top

12.16.1. backtrace

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: backtrace_symbols Up: Glibc execinfo.h Top: Top


backtrace_symbols -- GNU Gnulib

Next: backtrace_symbols_fd Prev: backtrace Up: Glibc execinfo.h Top: Top

12.16.2. backtrace_symbols

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: backtrace_symbols_fd Prev: backtrace Up: Glibc execinfo.h Top: Top


backtrace_symbols_fd -- GNU Gnulib

Prev: backtrace_symbols Up: Glibc execinfo.h Top: Top

12.16.3. backtrace_symbols_fd

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.4, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: backtrace_symbols Up: Glibc execinfo.h Top: Top


Glibc fcntl.h -- GNU Gnulib

Next: Glibc fenv.h Prev: Glibc execinfo.h Up: Glibc Function Substitutes Top: Top

12.17. Glibc Extensions to <fcntl.h>

Menu

  • fallocate
  • name_to_handle_at
  • readahead
  • open_by_handle_at


fallocate -- GNU Gnulib

Next: name_to_handle_at Up: Glibc fcntl.h Top: Top

12.17.1. fallocate

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on older glibc versions and all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly across the entire data range of files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: name_to_handle_at Up: Glibc fcntl.h Top: Top


name_to_handle_at -- GNU Gnulib

Next: readahead Prev: fallocate Up: Glibc fcntl.h Top: Top

12.17.2. name_to_handle_at

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: readahead Prev: fallocate Up: Glibc fcntl.h Top: Top


readahead -- GNU Gnulib

Next: open_by_handle_at Prev: name_to_handle_at Up: Glibc fcntl.h Top: Top

12.17.3. readahead

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: open_by_handle_at Prev: name_to_handle_at Up: Glibc fcntl.h Top: Top


open_by_handle_at -- GNU Gnulib

Prev: readahead Up: Glibc fcntl.h Top: Top

12.17.4. open_by_handle_at

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: readahead Up: Glibc fcntl.h Top: Top


Glibc fenv.h -- GNU Gnulib

Next: Glibc fmtmsg.h Prev: Glibc fcntl.h Up: Glibc Function Substitutes Top: Top

12.18. Glibc Extensions to <fenv.h>

Menu

  • fedisableexcept
  • feenableexcept
  • fegetexcept


fedisableexcept -- GNU Gnulib

Next: feenableexcept Up: Glibc fenv.h Top: Top

12.18.1. fedisableexcept

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5, BeOS.

Next: feenableexcept Up: Glibc fenv.h Top: Top


feenableexcept -- GNU Gnulib

Next: fegetexcept Prev: fedisableexcept Up: Glibc fenv.h Top: Top

12.18.2. feenableexcept

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fegetexcept Prev: fedisableexcept Up: Glibc fenv.h Top: Top


fegetexcept -- GNU Gnulib

Prev: feenableexcept Up: Glibc fenv.h Top: Top

12.18.3. fegetexcept

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: feenableexcept Up: Glibc fenv.h Top: Top


Glibc fmtmsg.h -- GNU Gnulib

Next: Glibc fstab.h Prev: Glibc fenv.h Up: Glibc Function Substitutes Top: Top

12.19. Glibc Extensions to <fmtmsg.h>

Menu

  • addseverity


addseverity -- GNU Gnulib

Up: Glibc fmtmsg.h Top: Top

12.19.1. addseverity

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc fmtmsg.h Top: Top


Glibc fstab.h -- GNU Gnulib

Next: Glibc fts.h Prev: Glibc fmtmsg.h Up: Glibc Function Substitutes Top: Top

12.20. Glibc <fstab.h>

Menu

  • endfsent
  • getfsent
  • getfsfile
  • getfsspec
  • setfsent


endfsent -- GNU Gnulib

Next: getfsent Up: Glibc fstab.h Top: Top

12.20.1. endfsent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getfsent Up: Glibc fstab.h Top: Top


getfsent -- GNU Gnulib

Next: getfsfile Prev: endfsent Up: Glibc fstab.h Top: Top

12.20.2. getfsent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getfsfile Prev: endfsent Up: Glibc fstab.h Top: Top


getfsfile -- GNU Gnulib

Next: getfsspec Prev: getfsent Up: Glibc fstab.h Top: Top

12.20.3. getfsfile

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getfsspec Prev: getfsent Up: Glibc fstab.h Top: Top


getfsspec -- GNU Gnulib

Next: setfsent Prev: getfsfile Up: Glibc fstab.h Top: Top

12.20.4. getfsspec

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setfsent Prev: getfsfile Up: Glibc fstab.h Top: Top


setfsent -- GNU Gnulib

Prev: getfsspec Up: Glibc fstab.h Top: Top

12.20.5. setfsent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getfsspec Up: Glibc fstab.h Top: Top


Glibc fts.h -- GNU Gnulib

Next: Glibc getopt.h Prev: Glibc fstab.h Up: Glibc Function Substitutes Top: Top

12.21. Glibc <fts.h>

Menu

  • fts_children
  • fts_close
  • fts_open
  • fts_read
  • fts_set


fts_children -- GNU Gnulib

Next: fts_close Up: Glibc fts.h Top: Top

12.21.1. fts_children

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not correctly report the size of files or block devices larger than 2 GB and may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. The fix is to use the AC_SYS_LARGEFILE macro (only on Mac OS X systems).

Next: fts_close Up: Glibc fts.h Top: Top


fts_close -- GNU Gnulib

Next: fts_open Prev: fts_children Up: Glibc fts.h Top: Top

12.21.2. fts_close

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: fts_open Prev: fts_children Up: Glibc fts.h Top: Top


fts_open -- GNU Gnulib

Next: fts_read Prev: fts_close Up: Glibc fts.h Top: Top

12.21.3. fts_open

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: fts_read Prev: fts_close Up: Glibc fts.h Top: Top


fts_read -- GNU Gnulib

Next: fts_set Prev: fts_open Up: Glibc fts.h Top: Top

12.21.4. fts_read

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not correctly report the size of files or block devices larger than 2 GB and may not work correctly on huge directories larger than 2 GB. Also, on platforms where ino_t is a 32-bit type, this function may report inode numbers incorrectly. The fix is to use the AC_SYS_LARGEFILE macro (only on Mac OS X systems).

Next: fts_set Prev: fts_open Up: Glibc fts.h Top: Top


fts_set -- GNU Gnulib

Prev: fts_read Up: Glibc fts.h Top: Top

12.21.5. fts_set

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, BeOS.

Prev: fts_read Up: Glibc fts.h Top: Top


Glibc getopt.h -- GNU Gnulib

Next: Glibc glob.h Prev: Glibc fts.h Up: Glibc Function Substitutes Top: Top

12.22. Glibc <getopt.h>

Menu

  • getopt_long
  • getopt_long_only


getopt_long -- GNU Gnulib

Next: getopt_long_only Up: Glibc getopt.h Top: Top

12.22.1. getopt_long

Gnulib module: getopt-gnu

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, MSVC 14, Interix 3.5.
  • The function getopt_long does not obey the combination of `+' and `:' flags in the options string on some platforms: glibc 2.11.
  • The use of `W;' in the optstring argument to does not always allow -W foo to behave synonymously with --foo: glibc 2.11.
  • The function getopt_long does not support the `+' flag in the options string on some platforms: Mac OS X 10.5, AIX 5.2, OSF/1 5.1, Solaris 10.
  • The value of optind after a missing required argument is wrong on some platforms: Mac OS X 10.5.
  • The function getopt_long does not obey the `-' flag in the options string when @env{POSIXLY_CORRECT} is set on some platforms: Cygwin 1.7.0.
  • Some implementations fail to reset state, including re-checking @env{POSIXLY_CORRECT}, when optind is set to `0': NetBSD, Cygwin 1.7.0.
  • The function getopt_long does not support options with optional arguments on some platforms: Mac OS X 10.5, OpenBSD 4.0, AIX 5.2, IRIX 6.5, Solaris 11 2010-11, Cygwin 1.5.x.
  • This function crashes if the option string includes W; but there are no long options, on some platforms: glibc 2.14.
Portability problems not fixed by Gnulib:

Next: getopt_long_only Up: Glibc getopt.h Top: Top


getopt_long_only -- GNU Gnulib

Prev: getopt_long Up: Glibc getopt.h Top: Top

12.22.2. getopt_long_only

Gnulib module: getopt-gnu

Portability problems fixed by Gnulib:

  • The function getopt_long_only does not obey the combination of `+' and `:' flags in the options string on some platforms: glibc 2.11.
  • The use of `W;' in the optstring argument to does not always allow -W foo to behave synonymously with --foo: glibc 2.11.
  • The function getopt_long_only does not support the `+' flag in the options string on some platforms: Mac OS X 10.5, AIX 5.2, OSF/1 5.1, Solaris 10.
  • The value of optind after a missing required argument is wrong on some platforms: Mac OS X 10.5.
  • The function getopt_long_only does not obey the `-' flag in the options string when @env{POSIXLY_CORRECT} is set on some platforms: Cygwin 1.7.0.
  • Some implementations fail to reset state, including re-checking @env{POSIXLY_CORRECT}, when optind is set to `0': NetBSD, Cygwin 1.7.0.
  • The function getopt_long_only does not support options with optional arguments on some platforms: Mac OS X 10.5, OpenBSD 4.0, AIX 5.2, Solaris 11 2010-11, Cygwin 1.5.x.
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 5.2.1, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14, Interix 3.5.
  • This function crashes if the option string includes W; but there are no long options, on some platforms: glibc 2.14.
Portability problems not fixed by Gnulib:
  • Some implementations return success instead of reporting an ambiguity if user's option is a prefix of two long options with the same outcome: FreeBSD.
  • The GNU Coding Standards discourage the use of getopt_long_only in new programs.

Prev: getopt_long Up: Glibc getopt.h Top: Top


Glibc glob.h -- GNU Gnulib

Next: Glibc gnu/libc-version.h Prev: Glibc getopt.h Up: Glibc Function Substitutes Top: Top

12.23. Glibc Extensions to <glob.h>

Menu

  • glob_pattern_p


glob_pattern_p -- GNU Gnulib

Up: Glibc glob.h Top: Top

12.23.1. glob_pattern_p

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on most non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc glob.h Top: Top


Glibc gnu/libc-version.h -- GNU Gnulib

Next: Glibc grp.h Prev: Glibc glob.h Up: Glibc Function Substitutes Top: Top

12.24. Glibc Extensions to <gnu/libc-version.h>

Menu

  • gnu_get_libc_release
  • gnu_get_libc_version


gnu_get_libc_release -- GNU Gnulib

Next: gnu_get_libc_version Up: Glibc gnu/libc-version.h Top: Top

12.24.1. gnu_get_libc_release

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: gnu_get_libc_version Up: Glibc gnu/libc-version.h Top: Top


gnu_get_libc_version -- GNU Gnulib

Prev: gnu_get_libc_release Up: Glibc gnu/libc-version.h Top: Top

12.24.2. gnu_get_libc_version

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Prev: gnu_get_libc_release Up: Glibc gnu/libc-version.h Top: Top


Glibc grp.h -- GNU Gnulib

Next: Glibc gshadow.h Prev: Glibc gnu/libc-version.h Up: Glibc Function Substitutes Top: Top

12.25. Glibc Extensions to <grp.h>

Menu

  • fgetgrent
  • fgetgrent_r
  • getgrent_r
  • getgrouplist
  • initgroups
  • putgrent
  • setgroups


fgetgrent -- GNU Gnulib

Next: fgetgrent_r Up: Glibc grp.h Top: Top

12.25.1. fgetgrent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetgrent_r Up: Glibc grp.h Top: Top


fgetgrent_r -- GNU Gnulib

Next: getgrent_r Prev: fgetgrent Up: Glibc grp.h Top: Top

12.25.2. fgetgrent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getgrent_r Prev: fgetgrent Up: Glibc grp.h Top: Top


getgrent_r -- GNU Gnulib

Next: getgrouplist Prev: fgetgrent_r Up: Glibc grp.h Top: Top

12.25.3. getgrent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getgrouplist Prev: fgetgrent_r Up: Glibc grp.h Top: Top


getgrouplist -- GNU Gnulib

Next: initgroups Prev: getgrent_r Up: Glibc grp.h Top: Top

12.25.4. getgrouplist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function takes int instead of gid_t parameters on some platforms: OS X 10.11.

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.7.9, mingw, MSVC 14, BeOS.
The Gnulib module getugroups provides a similar API.

Next: initgroups Prev: getgrent_r Up: Glibc grp.h Top: Top


initgroups -- GNU Gnulib

Next: putgrent Prev: getgrouplist Up: Glibc grp.h Top: Top

12.25.5. initgroups

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is unsafe to call between fork and exec if the parent process is multi-threaded. Instead, use getgroups or getgrouplist (or use the gnulib module mgetgroups) before forking, and setgroups in the child.
  • This function is missing on some platforms: mingw, MSVC 14, Interix 3.5, BeOS.

Next: putgrent Prev: getgrouplist Up: Glibc grp.h Top: Top


putgrent -- GNU Gnulib

Next: setgroups Prev: initgroups Up: Glibc grp.h Top: Top

12.25.6. putgrent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setgroups Prev: initgroups Up: Glibc grp.h Top: Top


setgroups -- GNU Gnulib

Prev: putgrent Up: Glibc grp.h Top: Top

12.25.7. setgroups

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • On very old systems, this function operated on an array of `int', even though that was a different size than an array of `gid_t'; you can use autoconf's AC_TYPE_GETGROUPS to set GETGROUPS_T to the appropriate size (since getgroups and setgroups share the same bug).

Prev: putgrent Up: Glibc grp.h Top: Top


Glibc gshadow.h -- GNU Gnulib

Next: Glibc ifaddrs.h Prev: Glibc grp.h Up: Glibc Function Substitutes Top: Top

12.26. Glibc <gshadow.h>

Menu

  • endsgent
  • fgetsgent
  • fgetsgent_r
  • getsgent
  • getsgent_r
  • getsgnam
  • getsgnam_r
  • putsgent
  • setsgent
  • sgetsgent
  • sgetsgent_r

    • Next: Glibc ifaddrs.h Prev: Glibc grp.h Up: Glibc Function Substitutes Top: Top


endsgent -- GNU Gnulib

Next: fgetsgent Up: Glibc gshadow.h Top: Top

12.26.1. endsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetsgent Up: Glibc gshadow.h Top: Top


fgetsgent -- GNU Gnulib

Next: fgetsgent_r Prev: endsgent Up: Glibc gshadow.h Top: Top

12.26.2. fgetsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetsgent_r Prev: endsgent Up: Glibc gshadow.h Top: Top


fgetsgent_r -- GNU Gnulib

Next: getsgent Prev: fgetsgent Up: Glibc gshadow.h Top: Top

12.26.3. fgetsgent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsgent Prev: fgetsgent Up: Glibc gshadow.h Top: Top


getsgent -- GNU Gnulib

Next: getsgent_r Prev: fgetsgent_r Up: Glibc gshadow.h Top: Top

12.26.4. getsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsgent_r Prev: fgetsgent_r Up: Glibc gshadow.h Top: Top


getsgent_r -- GNU Gnulib

Next: getsgnam Prev: getsgent Up: Glibc gshadow.h Top: Top

12.26.5. getsgent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsgnam Prev: getsgent Up: Glibc gshadow.h Top: Top


getsgnam -- GNU Gnulib

Next: getsgnam_r Prev: getsgent_r Up: Glibc gshadow.h Top: Top

12.26.6. getsgnam

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsgnam_r Prev: getsgent_r Up: Glibc gshadow.h Top: Top


getsgnam_r -- GNU Gnulib

Next: putsgent Prev: getsgnam Up: Glibc gshadow.h Top: Top

12.26.7. getsgnam_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: putsgent Prev: getsgnam Up: Glibc gshadow.h Top: Top


putsgent -- GNU Gnulib

Next: setsgent Prev: getsgnam_r Up: Glibc gshadow.h Top: Top

12.26.8. putsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setsgent Prev: getsgnam_r Up: Glibc gshadow.h Top: Top


setsgent -- GNU Gnulib

Next: sgetsgent Prev: putsgent Up: Glibc gshadow.h Top: Top

12.26.9. setsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sgetsgent Prev: putsgent Up: Glibc gshadow.h Top: Top


sgetsgent -- GNU Gnulib

Next: sgetsgent_r Prev: setsgent Up: Glibc gshadow.h Top: Top

12.26.10. sgetsgent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sgetsgent_r Prev: setsgent Up: Glibc gshadow.h Top: Top


sgetsgent_r -- GNU Gnulib

Prev: sgetsgent Up: Glibc gshadow.h Top: Top

12.26.11. sgetsgent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: sgetsgent Up: Glibc gshadow.h Top: Top


Glibc ifaddrs.h -- GNU Gnulib

Next: Glibc libintl.h Prev: Glibc gshadow.h Up: Glibc Function Substitutes Top: Top

12.27. Glibc <ifaddrs.h>

Menu

  • getifaddrs
  • freeifaddrs


getifaddrs -- GNU Gnulib

Next: freeifaddrs Up: Glibc ifaddrs.h Top: Top

12.27.1. getifaddrs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: freeifaddrs Up: Glibc ifaddrs.h Top: Top


freeifaddrs -- GNU Gnulib

Prev: getifaddrs Up: Glibc ifaddrs.h Top: Top

12.27.2. freeifaddrs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getifaddrs Up: Glibc ifaddrs.h Top: Top


Glibc libintl.h -- GNU Gnulib

Next: Glibc link.h Prev: Glibc ifaddrs.h Up: Glibc Function Substitutes Top: Top

12.28. Glibc <libintl.h>

Menu

  • bind_textdomain_codeset
  • bindtextdomain
  • dcgettext
  • dcngettext
  • dgettext
  • dngettext
  • gettext
  • ngettext
  • textdomain

    • Next: Glibc link.h Prev: Glibc ifaddrs.h Up: Glibc Function Substitutes Top: Top


bind_textdomain_codeset -- GNU Gnulib

Next: bindtextdomain Up: Glibc libintl.h Top: Top

12.28.1. bind_textdomain_codeset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: bindtextdomain Up: Glibc libintl.h Top: Top


bindtextdomain -- GNU Gnulib

Next: dcgettext Prev: bind_textdomain_codeset Up: Glibc libintl.h Top: Top

12.28.2. bindtextdomain

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dcgettext Prev: bind_textdomain_codeset Up: Glibc libintl.h Top: Top


dcgettext -- GNU Gnulib

Next: dcngettext Prev: bindtextdomain Up: Glibc libintl.h Top: Top

12.28.3. dcgettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dcngettext Prev: bindtextdomain Up: Glibc libintl.h Top: Top


dcngettext -- GNU Gnulib

Next: dgettext Prev: dcgettext Up: Glibc libintl.h Top: Top

12.28.4. dcngettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dgettext Prev: dcgettext Up: Glibc libintl.h Top: Top


dgettext -- GNU Gnulib

Next: dngettext Prev: dcngettext Up: Glibc libintl.h Top: Top

12.28.5. dgettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dngettext Prev: dcngettext Up: Glibc libintl.h Top: Top


dngettext -- GNU Gnulib

Next: gettext Prev: dgettext Up: Glibc libintl.h Top: Top

12.28.6. dngettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gettext Prev: dgettext Up: Glibc libintl.h Top: Top


gettext -- GNU Gnulib

Next: ngettext Prev: dngettext Up: Glibc libintl.h Top: Top

12.28.7. gettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ngettext Prev: dngettext Up: Glibc libintl.h Top: Top


ngettext -- GNU Gnulib

Next: textdomain Prev: gettext Up: Glibc libintl.h Top: Top

12.28.8. ngettext

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: textdomain Prev: gettext Up: Glibc libintl.h Top: Top


textdomain -- GNU Gnulib

Prev: ngettext Up: Glibc libintl.h Top: Top

12.28.9. textdomain

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ngettext Up: Glibc libintl.h Top: Top


Glibc link.h -- GNU Gnulib

Next: Glibc malloc.h Prev: Glibc libintl.h Up: Glibc Function Substitutes Top: Top

12.29. Glibc <link.h>

Menu

  • dl_iterate_phdr


dl_iterate_phdr -- GNU Gnulib

Up: Glibc link.h Top: Top

12.29.1. dl_iterate_phdr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc link.h Top: Top


Glibc malloc.h -- GNU Gnulib

Next: Glibc math.h Prev: Glibc link.h Up: Glibc Function Substitutes Top: Top

12.30. Glibc <malloc.h>

Menu

  • mallinfo
  • malloc_get_state
  • malloc_set_state
  • malloc_info
  • malloc_stats
  • malloc_trim
  • malloc_usable_size
  • mallopt
  • memalign
  • pvalloc

    • Next: Glibc math.h Prev: Glibc link.h Up: Glibc Function Substitutes Top: Top


mallinfo -- GNU Gnulib

Next: malloc_get_state Up: Glibc malloc.h Top: Top

12.30.1. mallinfo

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Solaris 11 2010-11, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_get_state Up: Glibc malloc.h Top: Top


malloc_get_state -- GNU Gnulib

Next: malloc_set_state Prev: mallinfo Up: Glibc malloc.h Top: Top

12.30.2. malloc_get_state

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_set_state Prev: mallinfo Up: Glibc malloc.h Top: Top


malloc_set_state -- GNU Gnulib

Next: malloc_info Prev: malloc_get_state Up: Glibc malloc.h Top: Top

12.30.3. malloc_set_state

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_info Prev: malloc_get_state Up: Glibc malloc.h Top: Top


malloc_info -- GNU Gnulib

Next: malloc_stats Prev: malloc_set_state Up: Glibc malloc.h Top: Top

12.30.4. malloc_info

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_stats Prev: malloc_set_state Up: Glibc malloc.h Top: Top


malloc_stats -- GNU Gnulib

Next: malloc_trim Prev: malloc_info Up: Glibc malloc.h Top: Top

12.30.5. malloc_stats

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_trim Prev: malloc_info Up: Glibc malloc.h Top: Top


malloc_trim -- GNU Gnulib

Next: malloc_usable_size Prev: malloc_stats Up: Glibc malloc.h Top: Top

12.30.6. malloc_trim

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: malloc_usable_size Prev: malloc_stats Up: Glibc malloc.h Top: Top


malloc_usable_size -- GNU Gnulib

Next: mallopt Prev: malloc_trim Up: Glibc malloc.h Top: Top

12.30.7. malloc_usable_size

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.00, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mallopt Prev: malloc_trim Up: Glibc malloc.h Top: Top


mallopt -- GNU Gnulib

Next: memalign Prev: malloc_usable_size Up: Glibc malloc.h Top: Top

12.30.8. mallopt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Solaris 11 2010-11, mingw, MSVC 14, Interix 3.5, BeOS.

Next: memalign Prev: malloc_usable_size Up: Glibc malloc.h Top: Top


memalign -- GNU Gnulib

Next: pvalloc Prev: mallopt Up: Glibc malloc.h Top: Top

12.30.9. memalign

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.00, OSF/1 5.1, mingw, MSVC 14, Interix 3.5.

Next: pvalloc Prev: mallopt Up: Glibc malloc.h Top: Top


pvalloc -- GNU Gnulib

Prev: memalign Up: Glibc malloc.h Top: Top

12.30.10. pvalloc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: memalign Up: Glibc malloc.h Top: Top


Glibc math.h -- GNU Gnulib

Next: Glibc mcheck.h Prev: Glibc malloc.h Up: Glibc Function Substitutes Top: Top

12.31. Glibc Extensions to <math.h>

Menu

  • drem
  • dremf
  • dreml
  • exp10
  • exp10f
  • exp10l
  • finite
  • finitef
  • finitel
  • gamma
  • gammaf
  • gammal
  • isinff
  • isinfl
  • isnanf
  • isnanl
  • j0f
  • j0l
  • j1f
  • j1l
  • jnf
  • jnl
  • lgamma_r
  • lgammaf_r
  • lgammal_r
  • matherr
  • pow10
  • pow10f
  • pow10l
  • scalbf
  • scalbl
  • significand
  • significandf
  • significandl
  • sincos
  • sincosf
  • sincosl
  • y0f
  • y0l
  • y1f
  • y1l
  • ynf
  • ynl

    • Next: Glibc mcheck.h Prev: Glibc malloc.h Up: Glibc Function Substitutes Top: Top


drem -- GNU Gnulib

Next: dremf Up: Glibc math.h Top: Top

12.31.1. drem

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, mingw, MSVC 14.

Next: dremf Up: Glibc math.h Top: Top


dremf -- GNU Gnulib

Next: dreml Prev: drem Up: Glibc math.h Top: Top

12.31.2. dremf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14.

Next: dreml Prev: drem Up: Glibc math.h Top: Top


dreml -- GNU Gnulib

Next: exp10 Prev: dremf Up: Glibc math.h Top: Top

12.31.3. dreml

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: exp10 Prev: dremf Up: Glibc math.h Top: Top


exp10 -- GNU Gnulib

Next: exp10f Prev: dreml Up: Glibc math.h Top: Top

12.31.4. exp10

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: exp10f Prev: dreml Up: Glibc math.h Top: Top


exp10f -- GNU Gnulib

Next: exp10l Prev: exp10 Up: Glibc math.h Top: Top

12.31.5. exp10f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: exp10l Prev: exp10 Up: Glibc math.h Top: Top


exp10l -- GNU Gnulib

Next: finite Prev: exp10f Up: Glibc math.h Top: Top

12.31.6. exp10l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: finite Prev: exp10f Up: Glibc math.h Top: Top


finite -- GNU Gnulib

Next: finitef Prev: exp10l Up: Glibc math.h Top: Top

12.31.7. finite

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, MSVC 14.

Next: finitef Prev: exp10l Up: Glibc math.h Top: Top


finitef -- GNU Gnulib

Next: finitel Prev: finite Up: Glibc math.h Top: Top

12.31.8. finitef

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14.

Next: finitel Prev: finite Up: Glibc math.h Top: Top


finitel -- GNU Gnulib

Next: gamma Prev: finitef Up: Glibc math.h Top: Top

12.31.9. finitel

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: gamma Prev: finitef Up: Glibc math.h Top: Top


gamma -- GNU Gnulib

Next: gammaf Prev: finitel Up: Glibc math.h Top: Top

12.31.10. gamma

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14.

Next: gammaf Prev: finitel Up: Glibc math.h Top: Top


gammaf -- GNU Gnulib

Next: gammal Prev: gamma Up: Glibc math.h Top: Top

12.31.11. gammaf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: gammal Prev: gamma Up: Glibc math.h Top: Top


gammal -- GNU Gnulib

Next: isinff Prev: gammaf Up: Glibc math.h Top: Top

12.31.12. gammal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: isinff Prev: gammaf Up: Glibc math.h Top: Top


isinff -- GNU Gnulib

Next: isinfl Prev: gammal Up: Glibc math.h Top: Top

12.31.13. isinff

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14.

Next: isinfl Prev: gammal Up: Glibc math.h Top: Top


isinfl -- GNU Gnulib

Next: isnanf Prev: isinff Up: Glibc math.h Top: Top

12.31.14. isinfl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: isnanf Prev: isinff Up: Glibc math.h Top: Top


isnanf -- GNU Gnulib

Next: isnanl Prev: isinfl Up: Glibc math.h Top: Top

12.31.15. isnanf

Gnulib module: isnanf

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, MSVC 14.
Portability problems not fixed by Gnulib:

Next: isnanl Prev: isinfl Up: Glibc math.h Top: Top


isnanl -- GNU Gnulib

Next: j0f Prev: isnanf Up: Glibc math.h Top: Top

12.31.16. isnanl

Gnulib module: isnanl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, MSVC 14, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: j0f Prev: isnanf Up: Glibc math.h Top: Top


j0f -- GNU Gnulib

Next: j0l Prev: isnanl Up: Glibc math.h Top: Top

12.31.17. j0f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: j0l Prev: isnanl Up: Glibc math.h Top: Top


j0l -- GNU Gnulib

Next: j1f Prev: j0f Up: Glibc math.h Top: Top

12.31.18. j0l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: j1f Prev: j0f Up: Glibc math.h Top: Top


j1f -- GNU Gnulib

Next: j1l Prev: j0l Up: Glibc math.h Top: Top

12.31.19. j1f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: j1l Prev: j0l Up: Glibc math.h Top: Top


j1l -- GNU Gnulib

Next: jnf Prev: j1f Up: Glibc math.h Top: Top

12.31.20. j1l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: jnf Prev: j1f Up: Glibc math.h Top: Top


jnf -- GNU Gnulib

Next: jnl Prev: j1l Up: Glibc math.h Top: Top

12.31.21. jnf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: jnl Prev: j1l Up: Glibc math.h Top: Top


jnl -- GNU Gnulib

Next: lgamma_r Prev: jnf Up: Glibc math.h Top: Top

12.31.22. jnl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: lgamma_r Prev: jnf Up: Glibc math.h Top: Top


lgamma_r -- GNU Gnulib

Next: lgammaf_r Prev: jnl Up: Glibc math.h Top: Top

12.31.23. lgamma_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5 x86, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

Next: lgammaf_r Prev: jnl Up: Glibc math.h Top: Top


lgammaf_r -- GNU Gnulib

Next: lgammal_r Prev: lgamma_r Up: Glibc math.h Top: Top

12.31.24. lgammaf_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

Next: lgammal_r Prev: lgamma_r Up: Glibc math.h Top: Top


lgammal_r -- GNU Gnulib

Next: matherr Prev: lgammaf_r Up: Glibc math.h Top: Top

12.31.25. lgammal_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: matherr Prev: lgammaf_r Up: Glibc math.h Top: Top


matherr -- GNU Gnulib

Next: pow10 Prev: lgammal_r Up: Glibc math.h Top: Top

12.31.26. matherr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: FreeBSD 6.0, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, mingw, MSVC 14.

Next: pow10 Prev: lgammal_r Up: Glibc math.h Top: Top


pow10 -- GNU Gnulib

Next: pow10f Prev: matherr Up: Glibc math.h Top: Top

12.31.27. pow10

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: pow10f Prev: matherr Up: Glibc math.h Top: Top


pow10f -- GNU Gnulib

Next: pow10l Prev: pow10 Up: Glibc math.h Top: Top

12.31.28. pow10f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: pow10l Prev: pow10 Up: Glibc math.h Top: Top


pow10l -- GNU Gnulib

Next: scalbf Prev: pow10f Up: Glibc math.h Top: Top

12.31.29. pow10l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: scalbf Prev: pow10f Up: Glibc math.h Top: Top


scalbf -- GNU Gnulib

Next: scalbl Prev: pow10l Up: Glibc math.h Top: Top

12.31.30. scalbf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: scalbl Prev: pow10l Up: Glibc math.h Top: Top


scalbl -- GNU Gnulib

Next: significand Prev: scalbf Up: Glibc math.h Top: Top

12.31.31. scalbl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: significand Prev: scalbf Up: Glibc math.h Top: Top


significand -- GNU Gnulib

Next: significandf Prev: scalbl Up: Glibc math.h Top: Top

12.31.32. significand

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

Next: significandf Prev: scalbl Up: Glibc math.h Top: Top


significandf -- GNU Gnulib

Next: significandl Prev: significand Up: Glibc math.h Top: Top

12.31.33. significandf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14.

Next: significandl Prev: significand Up: Glibc math.h Top: Top


significandl -- GNU Gnulib

Next: sincos Prev: significandf Up: Glibc math.h Top: Top

12.31.34. significandl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sincos Prev: significandf Up: Glibc math.h Top: Top


sincos -- GNU Gnulib

Next: sincosf Prev: significandl Up: Glibc math.h Top: Top

12.31.35. sincos

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14, Interix 3.5.

Next: sincosf Prev: significandl Up: Glibc math.h Top: Top


sincosf -- GNU Gnulib

Next: sincosl Prev: sincos Up: Glibc math.h Top: Top

12.31.36. sincosf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14, Interix 3.5.

Next: sincosl Prev: sincos Up: Glibc math.h Top: Top


sincosl -- GNU Gnulib

Next: y0f Prev: sincosf Up: Glibc math.h Top: Top

12.31.37. sincosl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: y0f Prev: sincosf Up: Glibc math.h Top: Top


y0f -- GNU Gnulib

Next: y0l Prev: sincosl Up: Glibc math.h Top: Top

12.31.38. y0f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: y0l Prev: sincosl Up: Glibc math.h Top: Top


y0l -- GNU Gnulib

Next: y1f Prev: y0f Up: Glibc math.h Top: Top

12.31.39. y0l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: y1f Prev: y0f Up: Glibc math.h Top: Top


y1f -- GNU Gnulib

Next: y1l Prev: y0l Up: Glibc math.h Top: Top

12.31.40. y1f

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: y1l Prev: y0l Up: Glibc math.h Top: Top


y1l -- GNU Gnulib

Next: ynf Prev: y1f Up: Glibc math.h Top: Top

12.31.41. y1l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ynf Prev: y1f Up: Glibc math.h Top: Top


ynf -- GNU Gnulib

Next: ynl Prev: y1l Up: Glibc math.h Top: Top

12.31.42. ynf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, mingw, MSVC 14.

Next: ynl Prev: y1l Up: Glibc math.h Top: Top


ynl -- GNU Gnulib

Prev: ynf Up: Glibc math.h Top: Top

12.31.43. ynl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ynf Up: Glibc math.h Top: Top


Glibc mcheck.h -- GNU Gnulib

Next: Glibc mntent.h Prev: Glibc math.h Up: Glibc Function Substitutes Top: Top

12.32. Glibc <mcheck.h>

Menu

  • mcheck
  • mcheck_check_all
  • mcheck_pedantic
  • mprobe
  • mtrace
  • muntrace


mcheck -- GNU Gnulib

Next: mcheck_check_all Up: Glibc mcheck.h Top: Top

12.32.1. mcheck

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: mcheck_check_all Up: Glibc mcheck.h Top: Top


mcheck_check_all -- GNU Gnulib

Next: mcheck_pedantic Prev: mcheck Up: Glibc mcheck.h Top: Top

12.32.2. mcheck_check_all

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mcheck_pedantic Prev: mcheck Up: Glibc mcheck.h Top: Top


mcheck_pedantic -- GNU Gnulib

Next: mprobe Prev: mcheck_check_all Up: Glibc mcheck.h Top: Top

12.32.3. mcheck_pedantic

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mprobe Prev: mcheck_check_all Up: Glibc mcheck.h Top: Top


mprobe -- GNU Gnulib

Next: mtrace Prev: mcheck_pedantic Up: Glibc mcheck.h Top: Top

12.32.4. mprobe

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: mtrace Prev: mcheck_pedantic Up: Glibc mcheck.h Top: Top


mtrace -- GNU Gnulib

Next: muntrace Prev: mprobe Up: Glibc mcheck.h Top: Top

12.32.5. mtrace

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: muntrace Prev: mprobe Up: Glibc mcheck.h Top: Top


muntrace -- GNU Gnulib

Prev: mtrace Up: Glibc mcheck.h Top: Top

12.32.6. muntrace

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: mtrace Up: Glibc mcheck.h Top: Top


Glibc mntent.h -- GNU Gnulib

Next: Glibc netdb.h Prev: Glibc mcheck.h Up: Glibc Function Substitutes Top: Top

12.33. Glibc <mntent.h>

Menu

  • addmntent
  • endmntent
  • getmntent
  • getmntent_r
  • hasmntopt
  • setmntent


addmntent -- GNU Gnulib

Next: endmntent Up: Glibc mntent.h Top: Top

12.33.1. addmntent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: endmntent Up: Glibc mntent.h Top: Top


endmntent -- GNU Gnulib

Next: getmntent Prev: addmntent Up: Glibc mntent.h Top: Top

12.33.2. endmntent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getmntent Prev: addmntent Up: Glibc mntent.h Top: Top


getmntent -- GNU Gnulib

Next: getmntent_r Prev: endmntent Up: Glibc mntent.h Top: Top

12.33.3. getmntent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, mingw, MSVC 14, BeOS.

Next: getmntent_r Prev: endmntent Up: Glibc mntent.h Top: Top


getmntent_r -- GNU Gnulib

Next: hasmntopt Prev: getmntent Up: Glibc mntent.h Top: Top

12.33.4. getmntent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: hasmntopt Prev: getmntent Up: Glibc mntent.h Top: Top


hasmntopt -- GNU Gnulib

Next: setmntent Prev: getmntent_r Up: Glibc mntent.h Top: Top

12.33.5. hasmntopt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: setmntent Prev: getmntent_r Up: Glibc mntent.h Top: Top


setmntent -- GNU Gnulib

Prev: hasmntopt Up: Glibc mntent.h Top: Top

12.33.6. setmntent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: hasmntopt Up: Glibc mntent.h Top: Top


Glibc netdb.h -- GNU Gnulib

Next: Glibc netinet/ether.h Prev: Glibc mntent.h Up: Glibc Function Substitutes Top: Top

12.34. Glibc Extensions to <netdb.h>

Menu

  • endnetgrent
  • gethostbyaddr_r
  • gethostbyname2
  • gethostbyname2_r
  • gethostbyname_r
  • gethostent_r
  • getnetbyaddr_r
  • getnetbyname_r
  • getnetent_r
  • getnetgrent
  • getnetgrent_r
  • getprotobyname_r
  • getprotobynumber_r
  • getprotoent_r
  • getservbyname_r
  • getservbyport_r
  • getservent_r
  • herror
  • hstrerror
  • innetgr
  • rcmd
  • rcmd_af
  • rexec
  • rexec_af
  • rresvport
  • rresvport_af
  • ruserok
  • ruserok_af
  • setnetgrent

    • Next: Glibc netinet/ether.h Prev: Glibc mntent.h Up: Glibc Function Substitutes Top: Top


endnetgrent -- GNU Gnulib

Next: gethostbyaddr_r Up: Glibc netdb.h Top: Top

12.34.1. endnetgrent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostbyaddr_r Up: Glibc netdb.h Top: Top


gethostbyaddr_r -- GNU Gnulib

Next: gethostbyname2 Prev: endnetgrent Up: Glibc netdb.h Top: Top

12.34.2. gethostbyaddr_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostbyname2 Prev: endnetgrent Up: Glibc netdb.h Top: Top


gethostbyname2 -- GNU Gnulib

Next: gethostbyname2_r Prev: gethostbyaddr_r Up: Glibc netdb.h Top: Top

12.34.3. gethostbyname2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostbyname2_r Prev: gethostbyaddr_r Up: Glibc netdb.h Top: Top


gethostbyname2_r -- GNU Gnulib

Next: gethostbyname_r Prev: gethostbyname2 Up: Glibc netdb.h Top: Top

12.34.4. gethostbyname2_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostbyname_r Prev: gethostbyname2 Up: Glibc netdb.h Top: Top


gethostbyname_r -- GNU Gnulib

Next: gethostent_r Prev: gethostbyname2_r Up: Glibc netdb.h Top: Top

12.34.5. gethostbyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gethostent_r Prev: gethostbyname2_r Up: Glibc netdb.h Top: Top


gethostent_r -- GNU Gnulib

Next: getnetbyaddr_r Prev: gethostbyname_r Up: Glibc netdb.h Top: Top

12.34.6. gethostent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnetbyaddr_r Prev: gethostbyname_r Up: Glibc netdb.h Top: Top


getnetbyaddr_r -- GNU Gnulib

Next: getnetbyname_r Prev: gethostent_r Up: Glibc netdb.h Top: Top

12.34.7. getnetbyaddr_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnetbyname_r Prev: gethostent_r Up: Glibc netdb.h Top: Top


getnetbyname_r -- GNU Gnulib

Next: getnetent_r Prev: getnetbyaddr_r Up: Glibc netdb.h Top: Top

12.34.8. getnetbyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnetent_r Prev: getnetbyaddr_r Up: Glibc netdb.h Top: Top


getnetent_r -- GNU Gnulib

Next: getnetgrent Prev: getnetbyname_r Up: Glibc netdb.h Top: Top

12.34.9. getnetent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnetgrent Prev: getnetbyname_r Up: Glibc netdb.h Top: Top


getnetgrent -- GNU Gnulib

Next: getnetgrent_r Prev: getnetent_r Up: Glibc netdb.h Top: Top

12.34.10. getnetgrent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getnetgrent_r Prev: getnetent_r Up: Glibc netdb.h Top: Top


getnetgrent_r -- GNU Gnulib

Next: getprotobyname_r Prev: getnetgrent Up: Glibc netdb.h Top: Top

12.34.11. getnetgrent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getprotobyname_r Prev: getnetgrent Up: Glibc netdb.h Top: Top


getprotobyname_r -- GNU Gnulib

Next: getprotobynumber_r Prev: getnetgrent_r Up: Glibc netdb.h Top: Top

12.34.12. getprotobyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getprotobynumber_r Prev: getnetgrent_r Up: Glibc netdb.h Top: Top


getprotobynumber_r -- GNU Gnulib

Next: getprotoent_r Prev: getprotobyname_r Up: Glibc netdb.h Top: Top

12.34.13. getprotobynumber_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getprotoent_r Prev: getprotobyname_r Up: Glibc netdb.h Top: Top


getprotoent_r -- GNU Gnulib

Next: getservbyname_r Prev: getprotobynumber_r Up: Glibc netdb.h Top: Top

12.34.14. getprotoent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getservbyname_r Prev: getprotobynumber_r Up: Glibc netdb.h Top: Top


getservbyname_r -- GNU Gnulib

Next: getservbyport_r Prev: getprotoent_r Up: Glibc netdb.h Top: Top

12.34.15. getservbyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getservbyport_r Prev: getprotoent_r Up: Glibc netdb.h Top: Top


getservbyport_r -- GNU Gnulib

Next: getservent_r Prev: getservbyname_r Up: Glibc netdb.h Top: Top

12.34.16. getservbyport_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getservent_r Prev: getservbyname_r Up: Glibc netdb.h Top: Top


getservent_r -- GNU Gnulib

Next: herror Prev: getservbyport_r Up: Glibc netdb.h Top: Top

12.34.17. getservent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: herror Prev: getservbyport_r Up: Glibc netdb.h Top: Top


herror -- GNU Gnulib

Next: hstrerror Prev: getservent_r Up: Glibc netdb.h Top: Top

12.34.18. herror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5.

Next: hstrerror Prev: getservent_r Up: Glibc netdb.h Top: Top


hstrerror -- GNU Gnulib

Next: innetgr Prev: herror Up: Glibc netdb.h Top: Top

12.34.19. hstrerror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, mingw, MSVC 14, Interix 3.5, BeOS.

Next: innetgr Prev: herror Up: Glibc netdb.h Top: Top


innetgr -- GNU Gnulib

Next: rcmd Prev: hstrerror Up: Glibc netdb.h Top: Top

12.34.20. innetgr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: rcmd Prev: hstrerror Up: Glibc netdb.h Top: Top


rcmd -- GNU Gnulib

Next: rcmd_af Prev: innetgr Up: Glibc netdb.h Top: Top

12.34.21. rcmd

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: rcmd_af Prev: innetgr Up: Glibc netdb.h Top: Top


rcmd_af -- GNU Gnulib

Next: rexec Prev: rcmd Up: Glibc netdb.h Top: Top

12.34.22. rcmd_af

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: rexec Prev: rcmd Up: Glibc netdb.h Top: Top


rexec -- GNU Gnulib

Next: rexec_af Prev: rcmd_af Up: Glibc netdb.h Top: Top

12.34.23. rexec

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: rexec_af Prev: rcmd_af Up: Glibc netdb.h Top: Top


rexec_af -- GNU Gnulib

Next: rresvport Prev: rexec Up: Glibc netdb.h Top: Top

12.34.24. rexec_af

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: rresvport Prev: rexec Up: Glibc netdb.h Top: Top


rresvport -- GNU Gnulib

Next: rresvport_af Prev: rexec_af Up: Glibc netdb.h Top: Top

12.34.25. rresvport

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: rresvport_af Prev: rexec_af Up: Glibc netdb.h Top: Top


rresvport_af -- GNU Gnulib

Next: ruserok Prev: rresvport Up: Glibc netdb.h Top: Top

12.34.26. rresvport_af

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 4.0, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ruserok Prev: rresvport Up: Glibc netdb.h Top: Top


ruserok -- GNU Gnulib

Next: ruserok_af Prev: rresvport_af Up: Glibc netdb.h Top: Top

12.34.27. ruserok

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, BeOS.

Next: ruserok_af Prev: rresvport_af Up: Glibc netdb.h Top: Top


ruserok_af -- GNU Gnulib

Next: setnetgrent Prev: ruserok Up: Glibc netdb.h Top: Top

12.34.28. ruserok_af

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setnetgrent Prev: ruserok Up: Glibc netdb.h Top: Top


setnetgrent -- GNU Gnulib

Prev: ruserok_af Up: Glibc netdb.h Top: Top

12.34.29. setnetgrent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ruserok_af Up: Glibc netdb.h Top: Top


Glibc netinet/ether.h -- GNU Gnulib

Next: Glibc netinet/in.h Prev: Glibc netdb.h Up: Glibc Function Substitutes Top: Top

12.35. Glibc <netinet/ether.h>

Menu

  • ether_aton
  • ether_aton_r
  • ether_hostton
  • ether_line
  • ether_ntoa
  • ether_ntoa_r
  • ether_ntohost


ether_aton -- GNU Gnulib

Next: ether_aton_r Up: Glibc netinet/ether.h Top: Top

12.35.1. ether_aton

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_aton_r Up: Glibc netinet/ether.h Top: Top


ether_aton_r -- GNU Gnulib

Next: ether_hostton Prev: ether_aton Up: Glibc netinet/ether.h Top: Top

12.35.2. ether_aton_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_hostton Prev: ether_aton Up: Glibc netinet/ether.h Top: Top


ether_hostton -- GNU Gnulib

Next: ether_line Prev: ether_aton_r Up: Glibc netinet/ether.h Top: Top

12.35.3. ether_hostton

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_line Prev: ether_aton_r Up: Glibc netinet/ether.h Top: Top


ether_line -- GNU Gnulib

Next: ether_ntoa Prev: ether_hostton Up: Glibc netinet/ether.h Top: Top

12.35.4. ether_line

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_ntoa Prev: ether_hostton Up: Glibc netinet/ether.h Top: Top


ether_ntoa -- GNU Gnulib

Next: ether_ntoa_r Prev: ether_line Up: Glibc netinet/ether.h Top: Top

12.35.5. ether_ntoa

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_ntoa_r Prev: ether_line Up: Glibc netinet/ether.h Top: Top


ether_ntoa_r -- GNU Gnulib

Next: ether_ntohost Prev: ether_ntoa Up: Glibc netinet/ether.h Top: Top

12.35.6. ether_ntoa_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ether_ntohost Prev: ether_ntoa Up: Glibc netinet/ether.h Top: Top


ether_ntohost -- GNU Gnulib

Prev: ether_ntoa_r Up: Glibc netinet/ether.h Top: Top

12.35.7. ether_ntohost

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ether_ntoa_r Up: Glibc netinet/ether.h Top: Top


Glibc netinet/in.h -- GNU Gnulib

Next: Glibc obstack.h Prev: Glibc netinet/ether.h Up: Glibc Function Substitutes Top: Top

12.36. Glibc Extensions to <netinet/in.h>

Menu

  • bindresvport
  • getipv4sourcefilter
  • getsourcefilter
  • in6addr_any
  • in6addr_loopback
  • inet6_option_alloc
  • inet6_option_append
  • inet6_option_find
  • inet6_option_init
  • inet6_option_next
  • inet6_option_space
  • inet6_opt_append
  • inet6_opt_find
  • inet6_opt_finish
  • inet6_opt_get_val
  • inet6_opt_init
  • inet6_opt_next
  • inet6_opt_set_val
  • inet6_rth_add
  • inet6_rth_getaddr
  • inet6_rth_init
  • inet6_rth_reverse
  • inet6_rth_segments
  • inet6_rth_space
  • setipv4sourcefilter
  • setsourcefilter

    • Next: Glibc obstack.h Prev: Glibc netinet/ether.h Up: Glibc Function Substitutes Top: Top


bindresvport -- GNU Gnulib

Next: getipv4sourcefilter Up: Glibc netinet/in.h Top: Top

12.36.1. bindresvport

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Cygwin 1.5.x, mingw, MSVC 14, BeOS.

Next: getipv4sourcefilter Up: Glibc netinet/in.h Top: Top


getipv4sourcefilter -- GNU Gnulib

Next: getsourcefilter Prev: bindresvport Up: Glibc netinet/in.h Top: Top

12.36.2. getipv4sourcefilter

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsourcefilter Prev: bindresvport Up: Glibc netinet/in.h Top: Top


getsourcefilter -- GNU Gnulib

Next: in6addr_any Prev: getipv4sourcefilter Up: Glibc netinet/in.h Top: Top

12.36.3. getsourcefilter

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: in6addr_any Prev: getipv4sourcefilter Up: Glibc netinet/in.h Top: Top


in6addr_any -- GNU Gnulib

Next: in6addr_loopback Prev: getsourcefilter Up: Glibc netinet/in.h Top: Top

12.36.4. in6addr_any

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This constant is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, HP-UX 11.00, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: in6addr_loopback Prev: getsourcefilter Up: Glibc netinet/in.h Top: Top


in6addr_loopback -- GNU Gnulib

Next: inet6_option_alloc Prev: in6addr_any Up: Glibc netinet/in.h Top: Top

12.36.5. in6addr_loopback

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This constant is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 4.3.2, HP-UX 11.00, IRIX 6.5, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_alloc Prev: in6addr_any Up: Glibc netinet/in.h Top: Top


inet6_option_alloc -- GNU Gnulib

Next: inet6_option_append Prev: in6addr_loopback Up: Glibc netinet/in.h Top: Top

12.36.6. inet6_option_alloc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_append Prev: in6addr_loopback Up: Glibc netinet/in.h Top: Top


inet6_option_append -- GNU Gnulib

Next: inet6_option_find Prev: inet6_option_alloc Up: Glibc netinet/in.h Top: Top

12.36.7. inet6_option_append

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_find Prev: inet6_option_alloc Up: Glibc netinet/in.h Top: Top


inet6_option_find -- GNU Gnulib

Next: inet6_option_init Prev: inet6_option_append Up: Glibc netinet/in.h Top: Top

12.36.8. inet6_option_find

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_init Prev: inet6_option_append Up: Glibc netinet/in.h Top: Top


inet6_option_init -- GNU Gnulib

Next: inet6_option_next Prev: inet6_option_find Up: Glibc netinet/in.h Top: Top

12.36.9. inet6_option_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_next Prev: inet6_option_find Up: Glibc netinet/in.h Top: Top


inet6_option_next -- GNU Gnulib

Next: inet6_option_space Prev: inet6_option_init Up: Glibc netinet/in.h Top: Top

12.36.10. inet6_option_next

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_option_space Prev: inet6_option_init Up: Glibc netinet/in.h Top: Top


inet6_option_space -- GNU Gnulib

Next: inet6_opt_append Prev: inet6_option_next Up: Glibc netinet/in.h Top: Top

12.36.11. inet6_option_space

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_append Prev: inet6_option_next Up: Glibc netinet/in.h Top: Top


inet6_opt_append -- GNU Gnulib

Next: inet6_opt_find Prev: inet6_option_space Up: Glibc netinet/in.h Top: Top

12.36.12. inet6_opt_append

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_find Prev: inet6_option_space Up: Glibc netinet/in.h Top: Top


inet6_opt_find -- GNU Gnulib

Next: inet6_opt_finish Prev: inet6_opt_append Up: Glibc netinet/in.h Top: Top

12.36.13. inet6_opt_find

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_finish Prev: inet6_opt_append Up: Glibc netinet/in.h Top: Top


inet6_opt_finish -- GNU Gnulib

Next: inet6_opt_get_val Prev: inet6_opt_find Up: Glibc netinet/in.h Top: Top

12.36.14. inet6_opt_finish

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_get_val Prev: inet6_opt_find Up: Glibc netinet/in.h Top: Top


inet6_opt_get_val -- GNU Gnulib

Next: inet6_opt_init Prev: inet6_opt_finish Up: Glibc netinet/in.h Top: Top

12.36.15. inet6_opt_get_val

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_init Prev: inet6_opt_finish Up: Glibc netinet/in.h Top: Top


inet6_opt_init -- GNU Gnulib

Next: inet6_opt_next Prev: inet6_opt_get_val Up: Glibc netinet/in.h Top: Top

12.36.16. inet6_opt_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_next Prev: inet6_opt_get_val Up: Glibc netinet/in.h Top: Top


inet6_opt_next -- GNU Gnulib

Next: inet6_opt_set_val Prev: inet6_opt_init Up: Glibc netinet/in.h Top: Top

12.36.17. inet6_opt_next

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_opt_set_val Prev: inet6_opt_init Up: Glibc netinet/in.h Top: Top


inet6_opt_set_val -- GNU Gnulib

Next: inet6_rth_add Prev: inet6_opt_next Up: Glibc netinet/in.h Top: Top

12.36.18. inet6_opt_set_val

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_add Prev: inet6_opt_next Up: Glibc netinet/in.h Top: Top


inet6_rth_add -- GNU Gnulib

Next: inet6_rth_getaddr Prev: inet6_opt_set_val Up: Glibc netinet/in.h Top: Top

12.36.19. inet6_rth_add

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_getaddr Prev: inet6_opt_set_val Up: Glibc netinet/in.h Top: Top


inet6_rth_getaddr -- GNU Gnulib

Next: inet6_rth_init Prev: inet6_rth_add Up: Glibc netinet/in.h Top: Top

12.36.20. inet6_rth_getaddr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_init Prev: inet6_rth_add Up: Glibc netinet/in.h Top: Top


inet6_rth_init -- GNU Gnulib

Next: inet6_rth_reverse Prev: inet6_rth_getaddr Up: Glibc netinet/in.h Top: Top

12.36.21. inet6_rth_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_reverse Prev: inet6_rth_getaddr Up: Glibc netinet/in.h Top: Top


inet6_rth_reverse -- GNU Gnulib

Next: inet6_rth_segments Prev: inet6_rth_init Up: Glibc netinet/in.h Top: Top

12.36.22. inet6_rth_reverse

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_segments Prev: inet6_rth_init Up: Glibc netinet/in.h Top: Top


inet6_rth_segments -- GNU Gnulib

Next: inet6_rth_space Prev: inet6_rth_reverse Up: Glibc netinet/in.h Top: Top

12.36.23. inet6_rth_segments

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: inet6_rth_space Prev: inet6_rth_reverse Up: Glibc netinet/in.h Top: Top


inet6_rth_space -- GNU Gnulib

Next: setipv4sourcefilter Prev: inet6_rth_segments Up: Glibc netinet/in.h Top: Top

12.36.24. inet6_rth_space

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.4, Mac OS X 10.5, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setipv4sourcefilter Prev: inet6_rth_segments Up: Glibc netinet/in.h Top: Top


setipv4sourcefilter -- GNU Gnulib

Next: setsourcefilter Prev: inet6_rth_space Up: Glibc netinet/in.h Top: Top

12.36.25. setipv4sourcefilter

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setsourcefilter Prev: inet6_rth_space Up: Glibc netinet/in.h Top: Top


setsourcefilter -- GNU Gnulib

Prev: setipv4sourcefilter Up: Glibc netinet/in.h Top: Top

12.36.26. setsourcefilter

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: setipv4sourcefilter Up: Glibc netinet/in.h Top: Top


Glibc obstack.h -- GNU Gnulib

Next: Glibc printf.h Prev: Glibc netinet/in.h Up: Glibc Function Substitutes Top: Top

12.37. Glibc <obstack.h>

Menu

  • obstack_alloc_failed_handler
  • obstack_exit_failure
  • obstack_free
  • obstack_printf
  • obstack_vprintf


obstack_alloc_failed_handler -- GNU Gnulib

Next: obstack_exit_failure Up: Glibc obstack.h Top: Top

12.37.1. obstack_alloc_failed_handler

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: obstack_exit_failure Up: Glibc obstack.h Top: Top


obstack_exit_failure -- GNU Gnulib

Next: obstack_free Prev: obstack_alloc_failed_handler Up: Glibc obstack.h Top: Top

12.37.2. obstack_exit_failure

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: obstack_free Prev: obstack_alloc_failed_handler Up: Glibc obstack.h Top: Top


obstack_free -- GNU Gnulib

Next: obstack_printf Prev: obstack_exit_failure Up: Glibc obstack.h Top: Top

12.37.3. obstack_free

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: obstack_printf Prev: obstack_exit_failure Up: Glibc obstack.h Top: Top


obstack_printf -- GNU Gnulib

Next: obstack_vprintf Prev: obstack_free Up: Glibc obstack.h Top: Top

12.37.4. obstack_printf

Gnulib module: obstack-printf or obstack-printf-posix

Portability problems fixed by either Gnulib module obstack-printf or obstack-printf-posix:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems fixed by Gnulib module ostack-printf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
  • This function does not fully support the `n' directive on some platforms: HP-UX 11, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Next: obstack_vprintf Prev: obstack_free Up: Glibc obstack.h Top: Top


obstack_vprintf -- GNU Gnulib

Prev: obstack_printf Up: Glibc obstack.h Top: Top

12.37.5. obstack_vprintf

Gnulib module: obstack-printf or obstack-printf-posix

Portability problems fixed by either Gnulib module obstack-printf or obstack-printf-posix:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems fixed by Gnulib module ostack-printf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.24, mingw, MSVC 14, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: mingw, MSVC 14, BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: AIX 5.2, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, AIX 5.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Solaris 9, Cygwin 1.5.x, mingw, MSVC 14, BeOS.
  • This function does not support the `n' directive on some platforms: MSVC 14.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, IRIX 6.5, Solaris 2.6, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, mingw, MSVC 14, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24, mingw, MSVC 14.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • This function behaves incorrectly when a `-' flag and a negative width are specified together, on some platforms: HP-UX 10.20.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, AIX 5.2, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.5.x, mingw, MSVC 14.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: Solaris 10/x86, mingw, MSVC 14, BeOS.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
  • This function does not fully support the `n' directive on some platforms: HP-UX 11, mingw, MSVC 14.
Portability problems not fixed by Gnulib:

Prev: obstack_printf Up: Glibc obstack.h Top: Top


Glibc printf.h -- GNU Gnulib

Next: Glibc pthread.h Prev: Glibc obstack.h Up: Glibc Function Substitutes Top: Top

12.38. Glibc <printf.h>

Menu

  • parse_printf_format
  • printf_size
  • printf_size_info
  • register_printf_function
  • register_printf_modifier
  • register_printf_specifier
  • register_printf_type


parse_printf_format -- GNU Gnulib

Next: printf_size Up: Glibc printf.h Top: Top

12.38.1. parse_printf_format

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: printf_size Up: Glibc printf.h Top: Top


printf_size -- GNU Gnulib

Next: printf_size_info Prev: parse_printf_format Up: Glibc printf.h Top: Top

12.38.2. printf_size

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: printf_size_info Prev: parse_printf_format Up: Glibc printf.h Top: Top


printf_size_info -- GNU Gnulib

Next: register_printf_function Prev: printf_size Up: Glibc printf.h Top: Top

12.38.3. printf_size_info

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: register_printf_function Prev: printf_size Up: Glibc printf.h Top: Top


register_printf_function -- GNU Gnulib

Next: register_printf_modifier Prev: printf_size_info Up: Glibc printf.h Top: Top

12.38.4. register_printf_function

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: register_printf_modifier Prev: printf_size_info Up: Glibc printf.h Top: Top


register_printf_modifier -- GNU Gnulib

Next: register_printf_specifier Prev: register_printf_function Up: Glibc printf.h Top: Top

12.38.5. register_printf_modifier

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: register_printf_specifier Prev: register_printf_function Up: Glibc printf.h Top: Top


register_printf_specifier -- GNU Gnulib

Next: register_printf_type Prev: register_printf_modifier Up: Glibc printf.h Top: Top

12.38.6. register_printf_specifier

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: register_printf_type Prev: register_printf_modifier Up: Glibc printf.h Top: Top


register_printf_type -- GNU Gnulib

Prev: register_printf_specifier Up: Glibc printf.h Top: Top

12.38.7. register_printf_type

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: register_printf_specifier Up: Glibc printf.h Top: Top


Glibc pthread.h -- GNU Gnulib

Next: Glibc pty.h Prev: Glibc printf.h Up: Glibc Function Substitutes Top: Top

12.39. Glibc Extensions to <pthread.h>

Menu

  • pthread_attr_getaffinity_np
  • pthread_attr_setaffinity_np
  • pthread_getaffinity_np
  • pthread_getattr_np
  • pthread_getname_np
  • pthread_kill_other_threads_np
  • pthread_mutex_consistent_np
  • pthread_mutexattr_getrobust_np
  • pthread_mutexattr_setrobust_np
  • pthread_rwlockattr_getkind_np
  • pthread_rwlockattr_setkind_np
  • pthread_setaffinity_np
  • pthread_setname_np
  • pthread_sigqueue
  • pthread_timedjoin_np
  • pthread_tryjoin_np
  • pthread_yield

    • Next: Glibc pty.h Prev: Glibc printf.h Up: Glibc Function Substitutes Top: Top


pthread_attr_getaffinity_np -- GNU Gnulib

Next: pthread_attr_setaffinity_np Up: Glibc pthread.h Top: Top

12.39.1. pthread_attr_getaffinity_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: glibc 2.3.3.

Next: pthread_attr_setaffinity_np Up: Glibc pthread.h Top: Top


pthread_attr_setaffinity_np -- GNU Gnulib

Next: pthread_getaffinity_np Prev: pthread_attr_getaffinity_np Up: Glibc pthread.h Top: Top

12.39.2. pthread_attr_setaffinity_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: glibc 2.3.3.

Next: pthread_getaffinity_np Prev: pthread_attr_getaffinity_np Up: Glibc pthread.h Top: Top


pthread_getaffinity_np -- GNU Gnulib

Next: pthread_getattr_np Prev: pthread_attr_setaffinity_np Up: Glibc pthread.h Top: Top

12.39.3. pthread_getaffinity_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: glibc 2.3.3.
  • The third parameter has a different type on some platforms: FreeBSD 7.2, NetBSD 5.0.

Next: pthread_getattr_np Prev: pthread_attr_setaffinity_np Up: Glibc pthread.h Top: Top


pthread_getattr_np -- GNU Gnulib

Next: pthread_getname_np Prev: pthread_getaffinity_np Up: Glibc pthread.h Top: Top

12.39.4. pthread_getattr_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_getname_np Prev: pthread_getaffinity_np Up: Glibc pthread.h Top: Top


pthread_getname_np -- GNU Gnulib

Next: pthread_kill_other_threads_np Prev: pthread_getattr_np Up: Glibc pthread.h Top: Top

12.39.5. pthread_getname_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, Solaris 11.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_kill_other_threads_np Prev: pthread_getattr_np Up: Glibc pthread.h Top: Top


pthread_kill_other_threads_np -- GNU Gnulib

Next: pthread_mutex_consistent_np Prev: pthread_getname_np Up: Glibc pthread.h Top: Top

12.39.6. pthread_kill_other_threads_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutex_consistent_np Prev: pthread_getname_np Up: Glibc pthread.h Top: Top


pthread_mutex_consistent_np -- GNU Gnulib

Next: pthread_mutexattr_getrobust_np Prev: pthread_kill_other_threads_np Up: Glibc pthread.h Top: Top

12.39.7. pthread_mutex_consistent_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 7, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_mutexattr_getrobust_np Prev: pthread_kill_other_threads_np Up: Glibc pthread.h Top: Top


pthread_mutexattr_getrobust_np -- GNU Gnulib

Next: pthread_mutexattr_setrobust_np Prev: pthread_mutex_consistent_np Up: Glibc pthread.h Top: Top

12.39.8. pthread_mutexattr_getrobust_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 7, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
This function has now been standardized by POSIX under the name pthread_mutexattr_getrobust.

Next: pthread_mutexattr_setrobust_np Prev: pthread_mutex_consistent_np Up: Glibc pthread.h Top: Top


pthread_mutexattr_setrobust_np -- GNU Gnulib

Next: pthread_rwlockattr_getkind_np Prev: pthread_mutexattr_getrobust_np Up: Glibc pthread.h Top: Top

12.39.9. pthread_mutexattr_setrobust_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 7, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
This function has now been standardized by POSIX under the name pthread_mutexattr_setrobust.

Next: pthread_rwlockattr_getkind_np Prev: pthread_mutexattr_getrobust_np Up: Glibc pthread.h Top: Top


pthread_rwlockattr_getkind_np -- GNU Gnulib

Next: pthread_rwlockattr_setkind_np Prev: pthread_mutexattr_setrobust_np Up: Glibc pthread.h Top: Top

12.39.10. pthread_rwlockattr_getkind_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_rwlockattr_setkind_np Prev: pthread_mutexattr_setrobust_np Up: Glibc pthread.h Top: Top


pthread_rwlockattr_setkind_np -- GNU Gnulib

Next: pthread_setaffinity_np Prev: pthread_rwlockattr_getkind_np Up: Glibc pthread.h Top: Top

12.39.11. pthread_rwlockattr_setkind_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_setaffinity_np Prev: pthread_rwlockattr_getkind_np Up: Glibc pthread.h Top: Top


pthread_setaffinity_np -- GNU Gnulib

Next: pthread_setname_np Prev: pthread_rwlockattr_setkind_np Up: Glibc pthread.h Top: Top

12.39.12. pthread_setaffinity_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: glibc 2.3.3.
  • The third parameter has a different type on some platforms: FreeBSD 7.2, NetBSD 5.0.

Next: pthread_setname_np Prev: pthread_rwlockattr_setkind_np Up: Glibc pthread.h Top: Top


pthread_setname_np -- GNU Gnulib

Next: pthread_sigqueue Prev: pthread_setaffinity_np Up: Glibc pthread.h Top: Top

12.39.13. pthread_setname_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, Solaris 11.0, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has a different signature on some platforms: NetBSD 5.0, OSF/1 5.1. On OSF/1 the third argument must be NULL. On NetBSD the second argument is interpreted as a printf format string, with the third argument as parameter.

Next: pthread_sigqueue Prev: pthread_setaffinity_np Up: Glibc pthread.h Top: Top


pthread_sigqueue -- GNU Gnulib

Next: pthread_timedjoin_np Prev: pthread_setname_np Up: Glibc pthread.h Top: Top

12.39.14. pthread_sigqueue

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.10, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.0, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_timedjoin_np Prev: pthread_setname_np Up: Glibc pthread.h Top: Top


pthread_timedjoin_np -- GNU Gnulib

Next: pthread_tryjoin_np Prev: pthread_sigqueue Up: Glibc pthread.h Top: Top

12.39.15. pthread_timedjoin_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • FreeBSD 6.4 has a function of this name in libthr but not in libpthread, and it also is missing a declaration.

Next: pthread_tryjoin_np Prev: pthread_sigqueue Up: Glibc pthread.h Top: Top


pthread_tryjoin_np -- GNU Gnulib

Next: pthread_yield Prev: pthread_timedjoin_np Up: Glibc pthread.h Top: Top

12.39.16. pthread_tryjoin_np

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.3.2, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pthread_yield Prev: pthread_timedjoin_np Up: Glibc pthread.h Top: Top


pthread_yield -- GNU Gnulib

Prev: pthread_tryjoin_np Up: Glibc pthread.h Top: Top

12.39.17. pthread_yield

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin 1.7.7, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: pthread_tryjoin_np Up: Glibc pthread.h Top: Top


Glibc pty.h -- GNU Gnulib

Next: Glibc pwd.h Prev: Glibc pthread.h Up: Glibc Function Substitutes Top: Top

12.40. Glibc <pty.h>

Menu

  • forkpty
  • openpty


forkpty -- GNU Gnulib

Next: openpty Up: Glibc pty.h Top: Top

12.40.1. forkpty

Gnulib module: forkpty

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3.
  • One some systems (at least including Cygwin, Interix, OSF/1 4 and 5, and Mac OS X) linking with -lutil is not required.
  • On glibc, OpenBSD, NetBSD and FreeBSD linking with -lutil is required.
  • The function is declared in pty.h on Cygwin, Interix, OSF/1 4 and 5, and glibc. It is declared in util.h on Mac OS X, OpenBSD and NetBSD. It is declared in libutil.h on FreeBSD.
  • Some platforms declare the function without marking the last two parameters const. FreeBSD, Cygwin 1.7.1.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.

Next: openpty Up: Glibc pty.h Top: Top


openpty -- GNU Gnulib

Prev: forkpty Up: Glibc pty.h Top: Top

12.40.2. openpty

Gnulib module: openpty

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3.
  • One some systems (at least including Cygwin, Interix, OSF/1 4 and 5, and Mac OS X) linking with -lutil is not required.
  • On glibc, OpenBSD, NetBSD and FreeBSD linking with -lutil is required.
  • The function is declared in pty.h on Cygwin, Interix, OSF/1 4 and 5, and glibc. It is declared in util.h on Mac OS X, OpenBSD and NetBSD. It is declared in libutil.h on FreeBSD.
  • Some platforms declare the function without marking the last two parameters const. FreeBSD, Cygwin 1.7.1.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • After a successful call to openpty, the application needs to close the master's file descriptor before closing the slave's file descriptor, otherwise the process may hang in a state where it cannot be killed, on some platforms: Mac OS X 10.4.11.

Prev: forkpty Up: Glibc pty.h Top: Top


Glibc pwd.h -- GNU Gnulib

Next: Glibc regex.h Prev: Glibc pty.h Up: Glibc Function Substitutes Top: Top

12.41. Glibc Extensions to <pwd.h>

Menu

  • fgetpwent
  • fgetpwent_r
  • getpw
  • getpwent_r
  • putpwent


fgetpwent -- GNU Gnulib

Next: fgetpwent_r Up: Glibc pwd.h Top: Top

12.41.1. fgetpwent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetpwent_r Up: Glibc pwd.h Top: Top


fgetpwent_r -- GNU Gnulib

Next: getpw Prev: fgetpwent Up: Glibc pwd.h Top: Top

12.41.2. fgetpwent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getpw Prev: fgetpwent Up: Glibc pwd.h Top: Top


getpw -- GNU Gnulib

Next: getpwent_r Prev: fgetpwent_r Up: Glibc pwd.h Top: Top

12.41.3. getpw

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getpwent_r Prev: fgetpwent_r Up: Glibc pwd.h Top: Top


getpwent_r -- GNU Gnulib

Next: putpwent Prev: getpw Up: Glibc pwd.h Top: Top

12.41.4. getpwent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: putpwent Prev: getpw Up: Glibc pwd.h Top: Top


putpwent -- GNU Gnulib

Prev: getpwent_r Up: Glibc pwd.h Top: Top

12.41.5. putpwent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getpwent_r Up: Glibc pwd.h Top: Top


Glibc regex.h -- GNU Gnulib

Next: Glibc regexp.h Prev: Glibc pwd.h Up: Glibc Function Substitutes Top: Top

12.42. Glibc Extensions to <regex.h>

Menu

  • re_comp
  • re_compile_fastmap
  • re_compile_pattern
  • re_exec
  • re_match
  • re_match_2
  • re_search
  • re_search_2
  • re_set_registers
  • re_set_syntax
  • re_syntax_options

    • Next: Glibc regexp.h Prev: Glibc pwd.h Up: Glibc Function Substitutes Top: Top


re_comp -- GNU Gnulib

Next: re_compile_fastmap Up: Glibc regex.h Top: Top

12.42.1. re_comp

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_compile_fastmap Up: Glibc regex.h Top: Top


re_compile_fastmap -- GNU Gnulib

Next: re_compile_pattern Prev: re_comp Up: Glibc regex.h Top: Top

12.42.2. re_compile_fastmap

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_compile_pattern Prev: re_comp Up: Glibc regex.h Top: Top


re_compile_pattern -- GNU Gnulib

Next: re_exec Prev: re_compile_fastmap Up: Glibc regex.h Top: Top

12.42.3. re_compile_pattern

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_exec Prev: re_compile_fastmap Up: Glibc regex.h Top: Top


re_exec -- GNU Gnulib

Next: re_match Prev: re_compile_pattern Up: Glibc regex.h Top: Top

12.42.4. re_exec

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_match Prev: re_compile_pattern Up: Glibc regex.h Top: Top


re_match -- GNU Gnulib

Next: re_match_2 Prev: re_exec Up: Glibc regex.h Top: Top

12.42.5. re_match

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_match_2 Prev: re_exec Up: Glibc regex.h Top: Top


re_match_2 -- GNU Gnulib

Next: re_search Prev: re_match Up: Glibc regex.h Top: Top

12.42.6. re_match_2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_search Prev: re_match Up: Glibc regex.h Top: Top


re_search -- GNU Gnulib

Next: re_search_2 Prev: re_match_2 Up: Glibc regex.h Top: Top

12.42.7. re_search

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_search_2 Prev: re_match_2 Up: Glibc regex.h Top: Top


re_search_2 -- GNU Gnulib

Next: re_set_registers Prev: re_search Up: Glibc regex.h Top: Top

12.42.8. re_search_2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_set_registers Prev: re_search Up: Glibc regex.h Top: Top


re_set_registers -- GNU Gnulib

Next: re_set_syntax Prev: re_search_2 Up: Glibc regex.h Top: Top

12.42.9. re_set_registers

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_set_syntax Prev: re_search_2 Up: Glibc regex.h Top: Top


re_set_syntax -- GNU Gnulib

Next: re_syntax_options Prev: re_set_registers Up: Glibc regex.h Top: Top

12.42.10. re_set_syntax

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: re_syntax_options Prev: re_set_registers Up: Glibc regex.h Top: Top


re_syntax_options -- GNU Gnulib

Prev: re_set_syntax Up: Glibc regex.h Top: Top

12.42.11. re_syntax_options

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Prev: re_set_syntax Up: Glibc regex.h Top: Top


Glibc regexp.h -- GNU Gnulib

Next: Glibc resolv.h Prev: Glibc regex.h Up: Glibc Function Substitutes Top: Top

12.43. Glibc <regexp.h>

Menu

  • advance
  • loc1
  • loc2
  • locs
  • step


advance -- GNU Gnulib

Next: loc1 Up: Glibc regexp.h Top: Top

12.43.1. advance

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: loc1 Up: Glibc regexp.h Top: Top


loc1 -- GNU Gnulib

Next: loc2 Prev: advance Up: Glibc regexp.h Top: Top

12.43.2. loc1

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: loc2 Prev: advance Up: Glibc regexp.h Top: Top


loc2 -- GNU Gnulib

Next: locs Prev: loc1 Up: Glibc regexp.h Top: Top

12.43.3. loc2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: locs Prev: loc1 Up: Glibc regexp.h Top: Top


locs -- GNU Gnulib

Next: step Prev: loc2 Up: Glibc regexp.h Top: Top

12.43.4. locs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: step Prev: loc2 Up: Glibc regexp.h Top: Top


step -- GNU Gnulib

Prev: locs Up: Glibc regexp.h Top: Top

12.43.5. step

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: locs Up: Glibc regexp.h Top: Top


Glibc resolv.h -- GNU Gnulib

Next: Glibc rpc/auth.h Prev: Glibc regexp.h Up: Glibc Function Substitutes Top: Top

12.44. Glibc <resolv.h>

Menu

  • dn_expand
  • res_init
  • res_mkquery
  • res_query
  • res_querydomain
  • res_search


dn_expand -- GNU Gnulib

Next: res_init Up: Glibc resolv.h Top: Top

12.44.1. dn_expand

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: res_init Up: Glibc resolv.h Top: Top


res_init -- GNU Gnulib

Next: res_mkquery Prev: dn_expand Up: Glibc resolv.h Top: Top

12.44.2. res_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: res_mkquery Prev: dn_expand Up: Glibc resolv.h Top: Top


res_mkquery -- GNU Gnulib

Next: res_query Prev: res_init Up: Glibc resolv.h Top: Top

12.44.3. res_mkquery

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: res_query Prev: res_init Up: Glibc resolv.h Top: Top


res_query -- GNU Gnulib

Next: res_querydomain Prev: res_mkquery Up: Glibc resolv.h Top: Top

12.44.4. res_query

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: res_querydomain Prev: res_mkquery Up: Glibc resolv.h Top: Top


res_querydomain -- GNU Gnulib

Next: res_search Prev: res_query Up: Glibc resolv.h Top: Top

12.44.5. res_querydomain

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Next: res_search Prev: res_query Up: Glibc resolv.h Top: Top


res_search -- GNU Gnulib

Prev: res_querydomain Up: Glibc resolv.h Top: Top

12.44.6. res_search

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5.

Prev: res_querydomain Up: Glibc resolv.h Top: Top


Glibc rpc/auth.h -- GNU Gnulib

Next: Glibc rpc/auth_des.h Prev: Glibc resolv.h Up: Glibc Function Substitutes Top: Top

12.45. Glibc <rpc/auth.h>

Menu

  • authdes_create
  • authdes_pk_create
  • authnone_create
  • authunix_create
  • authunix_create_default
  • getnetname
  • host2netname
  • key_decryptsession
  • key_decryptsession_pk
  • key_encryptsession
  • key_encryptsession_pk
  • key_gendes
  • key_get_conv
  • key_secretkey_is_set
  • key_setsecret
  • netname2host
  • netname2user
  • user2netname
  • xdr_des_block
  • xdr_opaque_auth

    • Next: Glibc rpc/auth_des.h Prev: Glibc resolv.h Up: Glibc Function Substitutes Top: Top


authdes_create -- GNU Gnulib

Next: authdes_pk_create Up: Glibc rpc/auth.h Top: Top

12.45.1. authdes_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: authdes_pk_create Up: Glibc rpc/auth.h Top: Top


authdes_pk_create -- GNU Gnulib

Next: authnone_create Prev: authdes_create Up: Glibc rpc/auth.h Top: Top

12.45.2. authdes_pk_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: authnone_create Prev: authdes_create Up: Glibc rpc/auth.h Top: Top


authnone_create -- GNU Gnulib

Next: authunix_create Prev: authdes_pk_create Up: Glibc rpc/auth.h Top: Top

12.45.3. authnone_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: authunix_create Prev: authdes_pk_create Up: Glibc rpc/auth.h Top: Top


authunix_create -- GNU Gnulib

Next: authunix_create_default Prev: authnone_create Up: Glibc rpc/auth.h Top: Top

12.45.4. authunix_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: authunix_create_default Prev: authnone_create Up: Glibc rpc/auth.h Top: Top


authunix_create_default -- GNU Gnulib

Next: getnetname Prev: authunix_create Up: Glibc rpc/auth.h Top: Top

12.45.5. authunix_create_default

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: getnetname Prev: authunix_create Up: Glibc rpc/auth.h Top: Top


getnetname -- GNU Gnulib

Next: host2netname Prev: authunix_create_default Up: Glibc rpc/auth.h Top: Top

12.45.6. getnetname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: host2netname Prev: authunix_create_default Up: Glibc rpc/auth.h Top: Top


host2netname -- GNU Gnulib

Next: key_decryptsession Prev: getnetname Up: Glibc rpc/auth.h Top: Top

12.45.7. host2netname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_decryptsession Prev: getnetname Up: Glibc rpc/auth.h Top: Top


key_decryptsession -- GNU Gnulib

Next: key_decryptsession_pk Prev: host2netname Up: Glibc rpc/auth.h Top: Top

12.45.8. key_decryptsession

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_decryptsession_pk Prev: host2netname Up: Glibc rpc/auth.h Top: Top


key_decryptsession_pk -- GNU Gnulib

Next: key_encryptsession Prev: key_decryptsession Up: Glibc rpc/auth.h Top: Top

12.45.9. key_decryptsession_pk

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_encryptsession Prev: key_decryptsession Up: Glibc rpc/auth.h Top: Top


key_encryptsession -- GNU Gnulib

Next: key_encryptsession_pk Prev: key_decryptsession_pk Up: Glibc rpc/auth.h Top: Top

12.45.10. key_encryptsession

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_encryptsession_pk Prev: key_decryptsession_pk Up: Glibc rpc/auth.h Top: Top


key_encryptsession_pk -- GNU Gnulib

Next: key_gendes Prev: key_encryptsession Up: Glibc rpc/auth.h Top: Top

12.45.11. key_encryptsession_pk

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_gendes Prev: key_encryptsession Up: Glibc rpc/auth.h Top: Top


key_gendes -- GNU Gnulib

Next: key_get_conv Prev: key_encryptsession_pk Up: Glibc rpc/auth.h Top: Top

12.45.12. key_gendes

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_get_conv Prev: key_encryptsession_pk Up: Glibc rpc/auth.h Top: Top


key_get_conv -- GNU Gnulib

Next: key_secretkey_is_set Prev: key_gendes Up: Glibc rpc/auth.h Top: Top

12.45.13. key_get_conv

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_secretkey_is_set Prev: key_gendes Up: Glibc rpc/auth.h Top: Top


key_secretkey_is_set -- GNU Gnulib

Next: key_setsecret Prev: key_get_conv Up: Glibc rpc/auth.h Top: Top

12.45.14. key_secretkey_is_set

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: key_setsecret Prev: key_get_conv Up: Glibc rpc/auth.h Top: Top


key_setsecret -- GNU Gnulib

Next: netname2host Prev: key_secretkey_is_set Up: Glibc rpc/auth.h Top: Top

12.45.15. key_setsecret

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: netname2host Prev: key_secretkey_is_set Up: Glibc rpc/auth.h Top: Top


netname2host -- GNU Gnulib

Next: netname2user Prev: key_setsecret Up: Glibc rpc/auth.h Top: Top

12.45.16. netname2host

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: netname2user Prev: key_setsecret Up: Glibc rpc/auth.h Top: Top


netname2user -- GNU Gnulib

Next: user2netname Prev: netname2host Up: Glibc rpc/auth.h Top: Top

12.45.17. netname2user

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: user2netname Prev: netname2host Up: Glibc rpc/auth.h Top: Top


user2netname -- GNU Gnulib

Next: xdr_des_block Prev: netname2user Up: Glibc rpc/auth.h Top: Top

12.45.18. user2netname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_des_block Prev: netname2user Up: Glibc rpc/auth.h Top: Top


xdr_des_block -- GNU Gnulib

Next: xdr_opaque_auth Prev: user2netname Up: Glibc rpc/auth.h Top: Top

12.45.19. xdr_des_block

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: xdr_opaque_auth Prev: user2netname Up: Glibc rpc/auth.h Top: Top


xdr_opaque_auth -- GNU Gnulib

Prev: xdr_des_block Up: Glibc rpc/auth.h Top: Top

12.45.20. xdr_opaque_auth

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: xdr_des_block Up: Glibc rpc/auth.h Top: Top


Glibc rpc/auth_des.h -- GNU Gnulib

Next: Glibc rpc/auth_unix.h Prev: Glibc rpc/auth.h Up: Glibc Function Substitutes Top: Top

12.46. Glibc <rpc/auth_des.h>

Menu

  • authdes_getucred
  • getpublickey
  • getsecretkey
  • rtime


authdes_getucred -- GNU Gnulib

Next: getpublickey Up: Glibc rpc/auth_des.h Top: Top

12.46.1. authdes_getucred

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getpublickey Up: Glibc rpc/auth_des.h Top: Top


getpublickey -- GNU Gnulib

Next: getsecretkey Prev: authdes_getucred Up: Glibc rpc/auth_des.h Top: Top

12.46.2. getpublickey

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getsecretkey Prev: authdes_getucred Up: Glibc rpc/auth_des.h Top: Top


getsecretkey -- GNU Gnulib

Next: rtime Prev: getpublickey Up: Glibc rpc/auth_des.h Top: Top

12.46.3. getsecretkey

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: rtime Prev: getpublickey Up: Glibc rpc/auth_des.h Top: Top


rtime -- GNU Gnulib

Prev: getsecretkey Up: Glibc rpc/auth_des.h Top: Top

12.46.4. rtime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getsecretkey Up: Glibc rpc/auth_des.h Top: Top


Glibc rpc/auth_unix.h -- GNU Gnulib

Next: Glibc rpc/clnt.h Prev: Glibc rpc/auth_des.h Up: Glibc Function Substitutes Top: Top

12.47. Glibc <rpc/auth_unix.h>

Menu

  • xdr_authunix_parms


xdr_authunix_parms -- GNU Gnulib

Up: Glibc rpc/auth_unix.h Top: Top

12.47.1. xdr_authunix_parms

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Up: Glibc rpc/auth_unix.h Top: Top


Glibc rpc/clnt.h -- GNU Gnulib

Next: Glibc rpc/des_crypt.h Prev: Glibc rpc/auth_unix.h Up: Glibc Function Substitutes Top: Top

12.48. Glibc <rpc/clnt.h>

Menu

  • callrpc
  • clnt_create
  • clnt_pcreateerror
  • clnt_perrno
  • clnt_perror
  • clnt_spcreateerror
  • clnt_sperrno
  • clnt_sperror
  • clntraw_create
  • clnttcp_create
  • clntudp_bufcreate
  • clntudp_create
  • clntunix_create
  • get_myaddress
  • getrpcport
  • rpc_createerr

    • Next: Glibc rpc/des_crypt.h Prev: Glibc rpc/auth_unix.h Up: Glibc Function Substitutes Top: Top


callrpc -- GNU Gnulib

Next: clnt_create Up: Glibc rpc/clnt.h Top: Top

12.48.1. callrpc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_create Up: Glibc rpc/clnt.h Top: Top


clnt_create -- GNU Gnulib

Next: clnt_pcreateerror Prev: callrpc Up: Glibc rpc/clnt.h Top: Top

12.48.2. clnt_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_pcreateerror Prev: callrpc Up: Glibc rpc/clnt.h Top: Top


clnt_pcreateerror -- GNU Gnulib

Next: clnt_perrno Prev: clnt_create Up: Glibc rpc/clnt.h Top: Top

12.48.3. clnt_pcreateerror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_perrno Prev: clnt_create Up: Glibc rpc/clnt.h Top: Top


clnt_perrno -- GNU Gnulib

Next: clnt_perror Prev: clnt_pcreateerror Up: Glibc rpc/clnt.h Top: Top

12.48.4. clnt_perrno

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_perror Prev: clnt_pcreateerror Up: Glibc rpc/clnt.h Top: Top


clnt_perror -- GNU Gnulib

Next: clnt_spcreateerror Prev: clnt_perrno Up: Glibc rpc/clnt.h Top: Top

12.48.5. clnt_perror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_spcreateerror Prev: clnt_perrno Up: Glibc rpc/clnt.h Top: Top


clnt_spcreateerror -- GNU Gnulib

Next: clnt_sperrno Prev: clnt_perror Up: Glibc rpc/clnt.h Top: Top

12.48.6. clnt_spcreateerror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_sperrno Prev: clnt_perror Up: Glibc rpc/clnt.h Top: Top


clnt_sperrno -- GNU Gnulib

Next: clnt_sperror Prev: clnt_spcreateerror Up: Glibc rpc/clnt.h Top: Top

12.48.7. clnt_sperrno

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnt_sperror Prev: clnt_spcreateerror Up: Glibc rpc/clnt.h Top: Top


clnt_sperror -- GNU Gnulib

Next: clntraw_create Prev: clnt_sperrno Up: Glibc rpc/clnt.h Top: Top

12.48.8. clnt_sperror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clntraw_create Prev: clnt_sperrno Up: Glibc rpc/clnt.h Top: Top


clntraw_create -- GNU Gnulib

Next: clnttcp_create Prev: clnt_sperror Up: Glibc rpc/clnt.h Top: Top

12.48.9. clntraw_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clnttcp_create Prev: clnt_sperror Up: Glibc rpc/clnt.h Top: Top


clnttcp_create -- GNU Gnulib

Next: clntudp_bufcreate Prev: clntraw_create Up: Glibc rpc/clnt.h Top: Top

12.48.10. clnttcp_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clntudp_bufcreate Prev: clntraw_create Up: Glibc rpc/clnt.h Top: Top


clntudp_bufcreate -- GNU Gnulib

Next: clntudp_create Prev: clnttcp_create Up: Glibc rpc/clnt.h Top: Top

12.48.11. clntudp_bufcreate

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clntudp_create Prev: clnttcp_create Up: Glibc rpc/clnt.h Top: Top


clntudp_create -- GNU Gnulib

Next: clntunix_create Prev: clntudp_bufcreate Up: Glibc rpc/clnt.h Top: Top

12.48.12. clntudp_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: clntunix_create Prev: clntudp_bufcreate Up: Glibc rpc/clnt.h Top: Top


clntunix_create -- GNU Gnulib

Next: get_myaddress Prev: clntudp_create Up: Glibc rpc/clnt.h Top: Top

12.48.13. clntunix_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: get_myaddress Prev: clntudp_create Up: Glibc rpc/clnt.h Top: Top


get_myaddress -- GNU Gnulib

Next: getrpcport Prev: clntunix_create Up: Glibc rpc/clnt.h Top: Top

12.48.14. get_myaddress

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: getrpcport Prev: clntunix_create Up: Glibc rpc/clnt.h Top: Top


getrpcport -- GNU Gnulib

Next: rpc_createerr Prev: get_myaddress Up: Glibc rpc/clnt.h Top: Top

12.48.15. getrpcport

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, Cygwin, mingw, MSVC 14, BeOS.

Next: rpc_createerr Prev: get_myaddress Up: Glibc rpc/clnt.h Top: Top


rpc_createerr -- GNU Gnulib

Prev: getrpcport Up: Glibc rpc/clnt.h Top: Top

12.48.16. rpc_createerr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, BeOS.

Prev: getrpcport Up: Glibc rpc/clnt.h Top: Top


Glibc rpc/des_crypt.h -- GNU Gnulib

Next: Glibc rpc/key_prot.h Prev: Glibc rpc/clnt.h Up: Glibc Function Substitutes Top: Top

12.49. Glibc <rpc/des_crypt.h>

Menu

  • cbc_crypt
  • des_setparity
  • ecb_crypt


cbc_crypt -- GNU Gnulib

Next: des_setparity Up: Glibc rpc/des_crypt.h Top: Top

12.49.1. cbc_crypt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: des_setparity Up: Glibc rpc/des_crypt.h Top: Top


des_setparity -- GNU Gnulib

Next: ecb_crypt Prev: cbc_crypt Up: Glibc rpc/des_crypt.h Top: Top

12.49.2. des_setparity

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ecb_crypt Prev: cbc_crypt Up: Glibc rpc/des_crypt.h Top: Top


ecb_crypt -- GNU Gnulib

Prev: des_setparity Up: Glibc rpc/des_crypt.h Top: Top

12.49.3. ecb_crypt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: des_setparity Up: Glibc rpc/des_crypt.h Top: Top


Glibc rpc/key_prot.h -- GNU Gnulib

Next: Glibc rpc/netdb.h Prev: Glibc rpc/des_crypt.h Up: Glibc Function Substitutes Top: Top

12.50. Glibc <rpc/key_prot.h>

Menu

  • xdr_cryptkeyarg
  • xdr_cryptkeyarg2
  • xdr_cryptkeyres
  • xdr_getcredres
  • xdr_key_netstarg
  • xdr_key_netstres
  • xdr_keybuf
  • xdr_keystatus
  • xdr_netnamestr
  • xdr_unixcred

    • Next: Glibc rpc/netdb.h Prev: Glibc rpc/des_crypt.h Up: Glibc Function Substitutes Top: Top


xdr_cryptkeyarg -- GNU Gnulib

Next: xdr_cryptkeyarg2 Up: Glibc rpc/key_prot.h Top: Top

12.50.1. xdr_cryptkeyarg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_cryptkeyarg2 Up: Glibc rpc/key_prot.h Top: Top


xdr_cryptkeyarg2 -- GNU Gnulib

Next: xdr_cryptkeyres Prev: xdr_cryptkeyarg Up: Glibc rpc/key_prot.h Top: Top

12.50.2. xdr_cryptkeyarg2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_cryptkeyres Prev: xdr_cryptkeyarg Up: Glibc rpc/key_prot.h Top: Top


xdr_cryptkeyres -- GNU Gnulib

Next: xdr_getcredres Prev: xdr_cryptkeyarg2 Up: Glibc rpc/key_prot.h Top: Top

12.50.3. xdr_cryptkeyres

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_getcredres Prev: xdr_cryptkeyarg2 Up: Glibc rpc/key_prot.h Top: Top


xdr_getcredres -- GNU Gnulib

Next: xdr_key_netstarg Prev: xdr_cryptkeyres Up: Glibc rpc/key_prot.h Top: Top

12.50.4. xdr_getcredres

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_key_netstarg Prev: xdr_cryptkeyres Up: Glibc rpc/key_prot.h Top: Top


xdr_key_netstarg -- GNU Gnulib

Next: xdr_key_netstres Prev: xdr_getcredres Up: Glibc rpc/key_prot.h Top: Top

12.50.5. xdr_key_netstarg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_key_netstres Prev: xdr_getcredres Up: Glibc rpc/key_prot.h Top: Top


xdr_key_netstres -- GNU Gnulib

Next: xdr_keybuf Prev: xdr_key_netstarg Up: Glibc rpc/key_prot.h Top: Top

12.50.6. xdr_key_netstres

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_keybuf Prev: xdr_key_netstarg Up: Glibc rpc/key_prot.h Top: Top


xdr_keybuf -- GNU Gnulib

Next: xdr_keystatus Prev: xdr_key_netstres Up: Glibc rpc/key_prot.h Top: Top

12.50.7. xdr_keybuf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_keystatus Prev: xdr_key_netstres Up: Glibc rpc/key_prot.h Top: Top


xdr_keystatus -- GNU Gnulib

Next: xdr_netnamestr Prev: xdr_keybuf Up: Glibc rpc/key_prot.h Top: Top

12.50.8. xdr_keystatus

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_netnamestr Prev: xdr_keybuf Up: Glibc rpc/key_prot.h Top: Top


xdr_netnamestr -- GNU Gnulib

Next: xdr_unixcred Prev: xdr_keystatus Up: Glibc rpc/key_prot.h Top: Top

12.50.9. xdr_netnamestr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_unixcred Prev: xdr_keystatus Up: Glibc rpc/key_prot.h Top: Top


xdr_unixcred -- GNU Gnulib

Prev: xdr_netnamestr Up: Glibc rpc/key_prot.h Top: Top

12.50.10. xdr_unixcred

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: xdr_netnamestr Up: Glibc rpc/key_prot.h Top: Top


Glibc rpc/netdb.h -- GNU Gnulib

Next: Glibc rpc/pmap_clnt.h Prev: Glibc rpc/key_prot.h Up: Glibc Function Substitutes Top: Top

12.51. Glibc <rpc/netdb.h>

Menu

  • endrpcent
  • getrpcbyname
  • getrpcbyname_r
  • getrpcbynumber
  • getrpcbynumber_r
  • getrpcent
  • getrpcent_r
  • setrpcent

    • Next: Glibc rpc/pmap_clnt.h Prev: Glibc rpc/key_prot.h Up: Glibc Function Substitutes Top: Top


endrpcent -- GNU Gnulib

Next: getrpcbyname Up: Glibc rpc/netdb.h Top: Top

12.51.1. endrpcent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: getrpcbyname Up: Glibc rpc/netdb.h Top: Top


getrpcbyname -- GNU Gnulib

Next: getrpcbyname_r Prev: endrpcent Up: Glibc rpc/netdb.h Top: Top

12.51.2. getrpcbyname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: getrpcbyname_r Prev: endrpcent Up: Glibc rpc/netdb.h Top: Top


getrpcbyname_r -- GNU Gnulib

Next: getrpcbynumber Prev: getrpcbyname Up: Glibc rpc/netdb.h Top: Top

12.51.3. getrpcbyname_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getrpcbynumber Prev: getrpcbyname Up: Glibc rpc/netdb.h Top: Top


getrpcbynumber -- GNU Gnulib

Next: getrpcbynumber_r Prev: getrpcbyname_r Up: Glibc rpc/netdb.h Top: Top

12.51.4. getrpcbynumber

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: getrpcbynumber_r Prev: getrpcbyname_r Up: Glibc rpc/netdb.h Top: Top


getrpcbynumber_r -- GNU Gnulib

Next: getrpcent Prev: getrpcbynumber Up: Glibc rpc/netdb.h Top: Top

12.51.5. getrpcbynumber_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getrpcent Prev: getrpcbynumber Up: Glibc rpc/netdb.h Top: Top


getrpcent -- GNU Gnulib

Next: getrpcent_r Prev: getrpcbynumber_r Up: Glibc rpc/netdb.h Top: Top

12.51.6. getrpcent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: getrpcent_r Prev: getrpcbynumber_r Up: Glibc rpc/netdb.h Top: Top


getrpcent_r -- GNU Gnulib

Next: setrpcent Prev: getrpcent Up: Glibc rpc/netdb.h Top: Top

12.51.7. getrpcent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setrpcent Prev: getrpcent Up: Glibc rpc/netdb.h Top: Top


setrpcent -- GNU Gnulib

Prev: getrpcent_r Up: Glibc rpc/netdb.h Top: Top

12.51.8. setrpcent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: getrpcent_r Up: Glibc rpc/netdb.h Top: Top


Glibc rpc/pmap_clnt.h -- GNU Gnulib

Next: Glibc rpc/pmap_prot.h Prev: Glibc rpc/netdb.h Up: Glibc Function Substitutes Top: Top

12.52. Glibc <rpc/pmap_clnt.h>

Menu

  • clnt_broadcast
  • pmap_getmaps
  • pmap_getport
  • pmap_rmtcall
  • pmap_set
  • pmap_unset


clnt_broadcast -- GNU Gnulib

Next: pmap_getmaps Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.1. clnt_broadcast

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: pmap_getmaps Up: Glibc rpc/pmap_clnt.h Top: Top


pmap_getmaps -- GNU Gnulib

Next: pmap_getport Prev: clnt_broadcast Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.2. pmap_getmaps

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: pmap_getport Prev: clnt_broadcast Up: Glibc rpc/pmap_clnt.h Top: Top


pmap_getport -- GNU Gnulib

Next: pmap_rmtcall Prev: pmap_getmaps Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.3. pmap_getport

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: pmap_rmtcall Prev: pmap_getmaps Up: Glibc rpc/pmap_clnt.h Top: Top


pmap_rmtcall -- GNU Gnulib

Next: pmap_set Prev: pmap_getport Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.4. pmap_rmtcall

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: pmap_set Prev: pmap_getport Up: Glibc rpc/pmap_clnt.h Top: Top


pmap_set -- GNU Gnulib

Next: pmap_unset Prev: pmap_rmtcall Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.5. pmap_set

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: pmap_unset Prev: pmap_rmtcall Up: Glibc rpc/pmap_clnt.h Top: Top


pmap_unset -- GNU Gnulib

Prev: pmap_set Up: Glibc rpc/pmap_clnt.h Top: Top

12.52.6. pmap_unset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: pmap_set Up: Glibc rpc/pmap_clnt.h Top: Top


Glibc rpc/pmap_prot.h -- GNU Gnulib

Next: Glibc rpc/pmap_rmt.h Prev: Glibc rpc/pmap_clnt.h Up: Glibc Function Substitutes Top: Top

12.53. Glibc <rpc/pmap_prot.h>

Menu

  • xdr_pmap
  • xdr_pmaplist


xdr_pmap -- GNU Gnulib

Next: xdr_pmaplist Up: Glibc rpc/pmap_prot.h Top: Top

12.53.1. xdr_pmap

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: xdr_pmaplist Up: Glibc rpc/pmap_prot.h Top: Top


xdr_pmaplist -- GNU Gnulib

Prev: xdr_pmap Up: Glibc rpc/pmap_prot.h Top: Top

12.53.2. xdr_pmaplist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: xdr_pmap Up: Glibc rpc/pmap_prot.h Top: Top


Glibc rpc/pmap_rmt.h -- GNU Gnulib

Next: Glibc rpc/rpc_msg.h Prev: Glibc rpc/pmap_prot.h Up: Glibc Function Substitutes Top: Top

12.54. Glibc <rpc/pmap_rmt.h>

Menu

  • xdr_rmtcall_args
  • xdr_rmtcallres


xdr_rmtcall_args -- GNU Gnulib

Next: xdr_rmtcallres Up: Glibc rpc/pmap_rmt.h Top: Top

12.54.1. xdr_rmtcall_args

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: xdr_rmtcallres Up: Glibc rpc/pmap_rmt.h Top: Top


xdr_rmtcallres -- GNU Gnulib

Prev: xdr_rmtcall_args Up: Glibc rpc/pmap_rmt.h Top: Top

12.54.2. xdr_rmtcallres

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: xdr_rmtcall_args Up: Glibc rpc/pmap_rmt.h Top: Top


Glibc rpc/rpc_msg.h -- GNU Gnulib

Next: Glibc rpc/svc.h Prev: Glibc rpc/pmap_rmt.h Up: Glibc Function Substitutes Top: Top

12.55. Glibc <rpc/rpc_msg.h>

Menu

  • xdr_callhdr
  • xdr_callmsg
  • xdr_replymsg


xdr_callhdr -- GNU Gnulib

Next: xdr_callmsg Up: Glibc rpc/rpc_msg.h Top: Top

12.55.1. xdr_callhdr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: xdr_callmsg Up: Glibc rpc/rpc_msg.h Top: Top


xdr_callmsg -- GNU Gnulib

Next: xdr_replymsg Prev: xdr_callhdr Up: Glibc rpc/rpc_msg.h Top: Top

12.55.2. xdr_callmsg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: xdr_replymsg Prev: xdr_callhdr Up: Glibc rpc/rpc_msg.h Top: Top


xdr_replymsg -- GNU Gnulib

Prev: xdr_callmsg Up: Glibc rpc/rpc_msg.h Top: Top

12.55.3. xdr_replymsg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: xdr_callmsg Up: Glibc rpc/rpc_msg.h Top: Top


Glibc rpc/svc.h -- GNU Gnulib

Next: Glibc rpc/xdr.h Prev: Glibc rpc/rpc_msg.h Up: Glibc Function Substitutes Top: Top

12.56. Glibc <rpc/svc.h>

Menu

  • svc_exit
  • svc_fdset
  • svc_getreq
  • svc_getreq_common
  • svc_getreq_poll
  • svc_getreqset
  • svc_max_pollfd
  • svc_pollfd
  • svc_register
  • svc_run
  • svc_sendreply
  • svc_unregister
  • svcerr_auth
  • svcerr_decode
  • svcerr_noproc
  • svcerr_noprog
  • svcerr_progvers
  • svcerr_systemerr
  • svcerr_weakauth
  • svcraw_create
  • svctcp_create
  • svcudp_bufcreate
  • svcudp_create
  • svcunix_create
  • xprt_register
  • xprt_unregister

    • Next: Glibc rpc/xdr.h Prev: Glibc rpc/rpc_msg.h Up: Glibc Function Substitutes Top: Top


svc_exit -- GNU Gnulib

Next: svc_fdset Up: Glibc rpc/svc.h Top: Top

12.56.1. svc_exit

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: svc_fdset Up: Glibc rpc/svc.h Top: Top


svc_fdset -- GNU Gnulib

Next: svc_getreq Prev: svc_exit Up: Glibc rpc/svc.h Top: Top

12.56.2. svc_fdset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_getreq Prev: svc_exit Up: Glibc rpc/svc.h Top: Top


svc_getreq -- GNU Gnulib

Next: svc_getreq_common Prev: svc_fdset Up: Glibc rpc/svc.h Top: Top

12.56.3. svc_getreq

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_getreq_common Prev: svc_fdset Up: Glibc rpc/svc.h Top: Top


svc_getreq_common -- GNU Gnulib

Next: svc_getreq_poll Prev: svc_getreq Up: Glibc rpc/svc.h Top: Top

12.56.4. svc_getreq_common

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: svc_getreq_poll Prev: svc_getreq Up: Glibc rpc/svc.h Top: Top


svc_getreq_poll -- GNU Gnulib

Next: svc_getreqset Prev: svc_getreq_common Up: Glibc rpc/svc.h Top: Top

12.56.5. svc_getreq_poll

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: svc_getreqset Prev: svc_getreq_common Up: Glibc rpc/svc.h Top: Top


svc_getreqset -- GNU Gnulib

Next: svc_max_pollfd Prev: svc_getreq_poll Up: Glibc rpc/svc.h Top: Top

12.56.6. svc_getreqset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_max_pollfd Prev: svc_getreq_poll Up: Glibc rpc/svc.h Top: Top


svc_max_pollfd -- GNU Gnulib

Next: svc_pollfd Prev: svc_getreqset Up: Glibc rpc/svc.h Top: Top

12.56.7. svc_max_pollfd

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: svc_pollfd Prev: svc_getreqset Up: Glibc rpc/svc.h Top: Top


svc_pollfd -- GNU Gnulib

Next: svc_register Prev: svc_max_pollfd Up: Glibc rpc/svc.h Top: Top

12.56.8. svc_pollfd

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: svc_register Prev: svc_max_pollfd Up: Glibc rpc/svc.h Top: Top


svc_register -- GNU Gnulib

Next: svc_run Prev: svc_pollfd Up: Glibc rpc/svc.h Top: Top

12.56.9. svc_register

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_run Prev: svc_pollfd Up: Glibc rpc/svc.h Top: Top


svc_run -- GNU Gnulib

Next: svc_sendreply Prev: svc_register Up: Glibc rpc/svc.h Top: Top

12.56.10. svc_run

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_sendreply Prev: svc_register Up: Glibc rpc/svc.h Top: Top


svc_sendreply -- GNU Gnulib

Next: svc_unregister Prev: svc_run Up: Glibc rpc/svc.h Top: Top

12.56.11. svc_sendreply

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svc_unregister Prev: svc_run Up: Glibc rpc/svc.h Top: Top


svc_unregister -- GNU Gnulib

Next: svcerr_auth Prev: svc_sendreply Up: Glibc rpc/svc.h Top: Top

12.56.12. svc_unregister

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_auth Prev: svc_sendreply Up: Glibc rpc/svc.h Top: Top


svcerr_auth -- GNU Gnulib

Next: svcerr_decode Prev: svc_unregister Up: Glibc rpc/svc.h Top: Top

12.56.13. svcerr_auth

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_decode Prev: svc_unregister Up: Glibc rpc/svc.h Top: Top


svcerr_decode -- GNU Gnulib

Next: svcerr_noproc Prev: svcerr_auth Up: Glibc rpc/svc.h Top: Top

12.56.14. svcerr_decode

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_noproc Prev: svcerr_auth Up: Glibc rpc/svc.h Top: Top


svcerr_noproc -- GNU Gnulib

Next: svcerr_noprog Prev: svcerr_decode Up: Glibc rpc/svc.h Top: Top

12.56.15. svcerr_noproc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_noprog Prev: svcerr_decode Up: Glibc rpc/svc.h Top: Top


svcerr_noprog -- GNU Gnulib

Next: svcerr_progvers Prev: svcerr_noproc Up: Glibc rpc/svc.h Top: Top

12.56.16. svcerr_noprog

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_progvers Prev: svcerr_noproc Up: Glibc rpc/svc.h Top: Top


svcerr_progvers -- GNU Gnulib

Next: svcerr_systemerr Prev: svcerr_noprog Up: Glibc rpc/svc.h Top: Top

12.56.17. svcerr_progvers

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_systemerr Prev: svcerr_noprog Up: Glibc rpc/svc.h Top: Top


svcerr_systemerr -- GNU Gnulib

Next: svcerr_weakauth Prev: svcerr_progvers Up: Glibc rpc/svc.h Top: Top

12.56.18. svcerr_systemerr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcerr_weakauth Prev: svcerr_progvers Up: Glibc rpc/svc.h Top: Top


svcerr_weakauth -- GNU Gnulib

Next: svcraw_create Prev: svcerr_systemerr Up: Glibc rpc/svc.h Top: Top

12.56.19. svcerr_weakauth

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcraw_create Prev: svcerr_systemerr Up: Glibc rpc/svc.h Top: Top


svcraw_create -- GNU Gnulib

Next: svctcp_create Prev: svcerr_weakauth Up: Glibc rpc/svc.h Top: Top

12.56.20. svcraw_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svctcp_create Prev: svcerr_weakauth Up: Glibc rpc/svc.h Top: Top


svctcp_create -- GNU Gnulib

Next: svcudp_bufcreate Prev: svcraw_create Up: Glibc rpc/svc.h Top: Top

12.56.21. svctcp_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcudp_bufcreate Prev: svcraw_create Up: Glibc rpc/svc.h Top: Top


svcudp_bufcreate -- GNU Gnulib

Next: svcudp_create Prev: svctcp_create Up: Glibc rpc/svc.h Top: Top

12.56.22. svcudp_bufcreate

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcudp_create Prev: svctcp_create Up: Glibc rpc/svc.h Top: Top


svcudp_create -- GNU Gnulib

Next: svcunix_create Prev: svcudp_bufcreate Up: Glibc rpc/svc.h Top: Top

12.56.23. svcudp_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: svcunix_create Prev: svcudp_bufcreate Up: Glibc rpc/svc.h Top: Top


svcunix_create -- GNU Gnulib

Next: xprt_register Prev: svcudp_create Up: Glibc rpc/svc.h Top: Top

12.56.24. svcunix_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xprt_register Prev: svcudp_create Up: Glibc rpc/svc.h Top: Top


xprt_register -- GNU Gnulib

Next: xprt_unregister Prev: svcunix_create Up: Glibc rpc/svc.h Top: Top

12.56.25. xprt_register

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Next: xprt_unregister Prev: svcunix_create Up: Glibc rpc/svc.h Top: Top


xprt_unregister -- GNU Gnulib

Prev: xprt_register Up: Glibc rpc/svc.h Top: Top

12.56.26. xprt_unregister

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, BeOS.

Prev: xprt_register Up: Glibc rpc/svc.h Top: Top


Glibc rpc/xdr.h -- GNU Gnulib

Next: Glibc rpcsvc/nislib.h Prev: Glibc rpc/svc.h Up: Glibc Function Substitutes Top: Top

12.57. Glibc <rpc/xdr.h>

Menu

  • xdr_array
  • xdr_bool
  • xdr_bytes
  • xdr_char
  • xdr_double
  • xdr_enum
  • xdr_float
  • xdr_free
  • xdr_hyper
  • xdr_int
  • xdr_int16_t
  • xdr_int32_t
  • xdr_int64_t
  • xdr_int8_t
  • xdr_long
  • xdr_longlong_t
  • xdr_netobj
  • xdr_opaque
  • xdr_pointer
  • xdr_quad_t
  • xdr_reference
  • xdr_short
  • xdr_sizeof
  • xdr_string
  • xdr_u_char
  • xdr_u_hyper
  • xdr_u_int
  • xdr_u_long
  • xdr_u_longlong_t
  • xdr_u_quad_t
  • xdr_u_short
  • xdr_uint16_t
  • xdr_uint32_t
  • xdr_uint64_t
  • xdr_uint8_t
  • xdr_union
  • xdr_vector
  • xdr_void
  • xdr_wrapstring
  • xdrmem_create
  • xdrrec_create
  • xdrrec_endofrecord
  • xdrrec_eof
  • xdrrec_skiprecord
  • xdrstdio_create

    • Next: Glibc rpcsvc/nislib.h Prev: Glibc rpc/svc.h Up: Glibc Function Substitutes Top: Top


xdr_array -- GNU Gnulib

Next: xdr_bool Up: Glibc rpc/xdr.h Top: Top

12.57.1. xdr_array

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_bool Up: Glibc rpc/xdr.h Top: Top


xdr_bool -- GNU Gnulib

Next: xdr_bytes Prev: xdr_array Up: Glibc rpc/xdr.h Top: Top

12.57.2. xdr_bool

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_bytes Prev: xdr_array Up: Glibc rpc/xdr.h Top: Top


xdr_bytes -- GNU Gnulib

Next: xdr_char Prev: xdr_bool Up: Glibc rpc/xdr.h Top: Top

12.57.3. xdr_bytes

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_char Prev: xdr_bool Up: Glibc rpc/xdr.h Top: Top


xdr_char -- GNU Gnulib

Next: xdr_double Prev: xdr_bytes Up: Glibc rpc/xdr.h Top: Top

12.57.4. xdr_char

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_double Prev: xdr_bytes Up: Glibc rpc/xdr.h Top: Top


xdr_double -- GNU Gnulib

Next: xdr_enum Prev: xdr_char Up: Glibc rpc/xdr.h Top: Top

12.57.5. xdr_double

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_enum Prev: xdr_char Up: Glibc rpc/xdr.h Top: Top


xdr_enum -- GNU Gnulib

Next: xdr_float Prev: xdr_double Up: Glibc rpc/xdr.h Top: Top

12.57.6. xdr_enum

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_float Prev: xdr_double Up: Glibc rpc/xdr.h Top: Top


xdr_float -- GNU Gnulib

Next: xdr_free Prev: xdr_enum Up: Glibc rpc/xdr.h Top: Top

12.57.7. xdr_float

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_free Prev: xdr_enum Up: Glibc rpc/xdr.h Top: Top


xdr_free -- GNU Gnulib

Next: xdr_hyper Prev: xdr_float Up: Glibc rpc/xdr.h Top: Top

12.57.8. xdr_free

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_hyper Prev: xdr_float Up: Glibc rpc/xdr.h Top: Top


xdr_hyper -- GNU Gnulib

Next: xdr_int Prev: xdr_free Up: Glibc rpc/xdr.h Top: Top

12.57.9. xdr_hyper

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_int Prev: xdr_free Up: Glibc rpc/xdr.h Top: Top


xdr_int -- GNU Gnulib

Next: xdr_int16_t Prev: xdr_hyper Up: Glibc rpc/xdr.h Top: Top

12.57.10. xdr_int

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_int16_t Prev: xdr_hyper Up: Glibc rpc/xdr.h Top: Top


xdr_int16_t -- GNU Gnulib

Next: xdr_int32_t Prev: xdr_int Up: Glibc rpc/xdr.h Top: Top

12.57.11. xdr_int16_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_int32_t Prev: xdr_int Up: Glibc rpc/xdr.h Top: Top


xdr_int32_t -- GNU Gnulib

Next: xdr_int64_t Prev: xdr_int16_t Up: Glibc rpc/xdr.h Top: Top

12.57.12. xdr_int32_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_int64_t Prev: xdr_int16_t Up: Glibc rpc/xdr.h Top: Top


xdr_int64_t -- GNU Gnulib

Next: xdr_int8_t Prev: xdr_int32_t Up: Glibc rpc/xdr.h Top: Top

12.57.13. xdr_int64_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_int8_t Prev: xdr_int32_t Up: Glibc rpc/xdr.h Top: Top


xdr_int8_t -- GNU Gnulib

Next: xdr_long Prev: xdr_int64_t Up: Glibc rpc/xdr.h Top: Top

12.57.14. xdr_int8_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_long Prev: xdr_int64_t Up: Glibc rpc/xdr.h Top: Top


xdr_long -- GNU Gnulib

Next: xdr_longlong_t Prev: xdr_int8_t Up: Glibc rpc/xdr.h Top: Top

12.57.15. xdr_long

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_longlong_t Prev: xdr_int8_t Up: Glibc rpc/xdr.h Top: Top


xdr_longlong_t -- GNU Gnulib

Next: xdr_netobj Prev: xdr_long Up: Glibc rpc/xdr.h Top: Top

12.57.16. xdr_longlong_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_netobj Prev: xdr_long Up: Glibc rpc/xdr.h Top: Top


xdr_netobj -- GNU Gnulib

Next: xdr_opaque Prev: xdr_longlong_t Up: Glibc rpc/xdr.h Top: Top

12.57.17. xdr_netobj

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_opaque Prev: xdr_longlong_t Up: Glibc rpc/xdr.h Top: Top


xdr_opaque -- GNU Gnulib

Next: xdr_pointer Prev: xdr_netobj Up: Glibc rpc/xdr.h Top: Top

12.57.18. xdr_opaque

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_pointer Prev: xdr_netobj Up: Glibc rpc/xdr.h Top: Top


xdr_pointer -- GNU Gnulib

Next: xdr_quad_t Prev: xdr_opaque Up: Glibc rpc/xdr.h Top: Top

12.57.19. xdr_pointer

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_quad_t Prev: xdr_opaque Up: Glibc rpc/xdr.h Top: Top


xdr_quad_t -- GNU Gnulib

Next: xdr_reference Prev: xdr_pointer Up: Glibc rpc/xdr.h Top: Top

12.57.20. xdr_quad_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_reference Prev: xdr_pointer Up: Glibc rpc/xdr.h Top: Top


xdr_reference -- GNU Gnulib

Next: xdr_short Prev: xdr_quad_t Up: Glibc rpc/xdr.h Top: Top

12.57.21. xdr_reference

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_short Prev: xdr_quad_t Up: Glibc rpc/xdr.h Top: Top


xdr_short -- GNU Gnulib

Next: xdr_sizeof Prev: xdr_reference Up: Glibc rpc/xdr.h Top: Top

12.57.22. xdr_short

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_sizeof Prev: xdr_reference Up: Glibc rpc/xdr.h Top: Top


xdr_sizeof -- GNU Gnulib

Next: xdr_string Prev: xdr_short Up: Glibc rpc/xdr.h Top: Top

12.57.23. xdr_sizeof

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_string Prev: xdr_short Up: Glibc rpc/xdr.h Top: Top


xdr_string -- GNU Gnulib

Next: xdr_u_char Prev: xdr_sizeof Up: Glibc rpc/xdr.h Top: Top

12.57.24. xdr_string

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_u_char Prev: xdr_sizeof Up: Glibc rpc/xdr.h Top: Top


xdr_u_char -- GNU Gnulib

Next: xdr_u_hyper Prev: xdr_string Up: Glibc rpc/xdr.h Top: Top

12.57.25. xdr_u_char

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_u_hyper Prev: xdr_string Up: Glibc rpc/xdr.h Top: Top


xdr_u_hyper -- GNU Gnulib

Next: xdr_u_int Prev: xdr_u_char Up: Glibc rpc/xdr.h Top: Top

12.57.26. xdr_u_hyper

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, IRIX 5.3, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_u_int Prev: xdr_u_char Up: Glibc rpc/xdr.h Top: Top


xdr_u_int -- GNU Gnulib

Next: xdr_u_long Prev: xdr_u_hyper Up: Glibc rpc/xdr.h Top: Top

12.57.27. xdr_u_int

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_u_long Prev: xdr_u_hyper Up: Glibc rpc/xdr.h Top: Top


xdr_u_long -- GNU Gnulib

Next: xdr_u_longlong_t Prev: xdr_u_int Up: Glibc rpc/xdr.h Top: Top

12.57.28. xdr_u_long

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_u_longlong_t Prev: xdr_u_int Up: Glibc rpc/xdr.h Top: Top


xdr_u_longlong_t -- GNU Gnulib

Next: xdr_u_quad_t Prev: xdr_u_long Up: Glibc rpc/xdr.h Top: Top

12.57.29. xdr_u_longlong_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.3, OpenBSD 3.8, Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_u_quad_t Prev: xdr_u_long Up: Glibc rpc/xdr.h Top: Top


xdr_u_quad_t -- GNU Gnulib

Next: xdr_u_short Prev: xdr_u_longlong_t Up: Glibc rpc/xdr.h Top: Top

12.57.30. xdr_u_quad_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_u_short Prev: xdr_u_longlong_t Up: Glibc rpc/xdr.h Top: Top


xdr_u_short -- GNU Gnulib

Next: xdr_uint16_t Prev: xdr_u_quad_t Up: Glibc rpc/xdr.h Top: Top

12.57.31. xdr_u_short

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_uint16_t Prev: xdr_u_quad_t Up: Glibc rpc/xdr.h Top: Top


xdr_uint16_t -- GNU Gnulib

Next: xdr_uint32_t Prev: xdr_u_short Up: Glibc rpc/xdr.h Top: Top

12.57.32. xdr_uint16_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin 1.7.4, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared in the header on some platforms: Cygwin 1.7.5.

Next: xdr_uint32_t Prev: xdr_u_short Up: Glibc rpc/xdr.h Top: Top


xdr_uint32_t -- GNU Gnulib

Next: xdr_uint64_t Prev: xdr_uint16_t Up: Glibc rpc/xdr.h Top: Top

12.57.33. xdr_uint32_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared in the header on some platforms: Cygwin 1.7.5.

Next: xdr_uint64_t Prev: xdr_uint16_t Up: Glibc rpc/xdr.h Top: Top


xdr_uint64_t -- GNU Gnulib

Next: xdr_uint8_t Prev: xdr_uint32_t Up: Glibc rpc/xdr.h Top: Top

12.57.34. xdr_uint64_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared in the header on some platforms: Cygwin 1.7.5.

Next: xdr_uint8_t Prev: xdr_uint32_t Up: Glibc rpc/xdr.h Top: Top


xdr_uint8_t -- GNU Gnulib

Next: xdr_union Prev: xdr_uint64_t Up: Glibc rpc/xdr.h Top: Top

12.57.35. xdr_uint8_t

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is not declared in the header on some platforms: Cygwin 1.7.5.

Next: xdr_union Prev: xdr_uint64_t Up: Glibc rpc/xdr.h Top: Top


xdr_union -- GNU Gnulib

Next: xdr_vector Prev: xdr_uint8_t Up: Glibc rpc/xdr.h Top: Top

12.57.36. xdr_union

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_vector Prev: xdr_uint8_t Up: Glibc rpc/xdr.h Top: Top


xdr_vector -- GNU Gnulib

Next: xdr_void Prev: xdr_union Up: Glibc rpc/xdr.h Top: Top

12.57.37. xdr_vector

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_void Prev: xdr_union Up: Glibc rpc/xdr.h Top: Top


xdr_void -- GNU Gnulib

Next: xdr_wrapstring Prev: xdr_vector Up: Glibc rpc/xdr.h Top: Top

12.57.38. xdr_void

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdr_wrapstring Prev: xdr_vector Up: Glibc rpc/xdr.h Top: Top


xdr_wrapstring -- GNU Gnulib

Next: xdrmem_create Prev: xdr_void Up: Glibc rpc/xdr.h Top: Top

12.57.39. xdr_wrapstring

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrmem_create Prev: xdr_void Up: Glibc rpc/xdr.h Top: Top


xdrmem_create -- GNU Gnulib

Next: xdrrec_create Prev: xdr_wrapstring Up: Glibc rpc/xdr.h Top: Top

12.57.40. xdrmem_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrrec_create Prev: xdr_wrapstring Up: Glibc rpc/xdr.h Top: Top


xdrrec_create -- GNU Gnulib

Next: xdrrec_endofrecord Prev: xdrmem_create Up: Glibc rpc/xdr.h Top: Top

12.57.41. xdrrec_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrrec_endofrecord Prev: xdrmem_create Up: Glibc rpc/xdr.h Top: Top


xdrrec_endofrecord -- GNU Gnulib

Next: xdrrec_eof Prev: xdrrec_create Up: Glibc rpc/xdr.h Top: Top

12.57.42. xdrrec_endofrecord

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrrec_eof Prev: xdrrec_create Up: Glibc rpc/xdr.h Top: Top


xdrrec_eof -- GNU Gnulib

Next: xdrrec_skiprecord Prev: xdrrec_endofrecord Up: Glibc rpc/xdr.h Top: Top

12.57.43. xdrrec_eof

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrrec_skiprecord Prev: xdrrec_endofrecord Up: Glibc rpc/xdr.h Top: Top


xdrrec_skiprecord -- GNU Gnulib

Next: xdrstdio_create Prev: xdrrec_eof Up: Glibc rpc/xdr.h Top: Top

12.57.44. xdrrec_skiprecord

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Next: xdrstdio_create Prev: xdrrec_eof Up: Glibc rpc/xdr.h Top: Top


xdrstdio_create -- GNU Gnulib

Prev: xdrrec_skiprecord Up: Glibc rpc/xdr.h Top: Top

12.57.45. xdrstdio_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin 1.7.4, mingw, MSVC 14, BeOS.

Prev: xdrrec_skiprecord Up: Glibc rpc/xdr.h Top: Top


Glibc rpcsvc/nislib.h -- GNU Gnulib

Next: Glibc rpcsvc/nis_callback.h Prev: Glibc rpc/xdr.h Up: Glibc Function Substitutes Top: Top

12.58. Glibc <rpcsvc/nislib.h>

Menu

  • nis_add
  • nis_add_entry
  • nis_addmember
  • nis_checkpoint
  • nis_clone_object
  • nis_creategroup
  • nis_destroy_object
  • nis_destroygroup
  • nis_dir_cmp
  • nis_domain_of
  • nis_domain_of_r
  • nis_first_entry
  • nis_freenames
  • nis_freeresult
  • nis_freeservlist
  • nis_freetags
  • nis_getnames
  • nis_getservlist
  • nis_ismember
  • nis_leaf_of
  • nis_leaf_of_r
  • nis_lerror
  • nis_list
  • nis_local_directory
  • nis_local_group
  • nis_local_host
  • nis_local_principal
  • nis_lookup
  • nis_mkdir
  • nis_modify
  • nis_modify_entry
  • nis_name_of
  • nis_name_of_r
  • nis_next_entry
  • nis_perror
  • nis_ping
  • nis_print_directory
  • nis_print_entry
  • nis_print_group
  • nis_print_group_entry
  • nis_print_link
  • nis_print_object
  • nis_print_result
  • nis_print_rights
  • nis_print_table
  • nis_remove
  • nis_remove_entry
  • nis_removemember
  • nis_rmdir
  • nis_servstate
  • nis_sperrno
  • nis_sperror
  • nis_sperror_r
  • nis_stats
  • nis_verifygroup

    • Next: Glibc rpcsvc/nis_callback.h Prev: Glibc rpc/xdr.h Up: Glibc Function Substitutes Top: Top


nis_add -- GNU Gnulib

Next: nis_add_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.1. nis_add

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_add_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_add_entry -- GNU Gnulib

Next: nis_addmember Prev: nis_add Up: Glibc rpcsvc/nislib.h Top: Top

12.58.2. nis_add_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_addmember Prev: nis_add Up: Glibc rpcsvc/nislib.h Top: Top


nis_addmember -- GNU Gnulib

Next: nis_checkpoint Prev: nis_add_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.3. nis_addmember

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_checkpoint Prev: nis_add_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_checkpoint -- GNU Gnulib

Next: nis_clone_object Prev: nis_addmember Up: Glibc rpcsvc/nislib.h Top: Top

12.58.4. nis_checkpoint

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_clone_object Prev: nis_addmember Up: Glibc rpcsvc/nislib.h Top: Top


nis_clone_object -- GNU Gnulib

Next: nis_creategroup Prev: nis_checkpoint Up: Glibc rpcsvc/nislib.h Top: Top

12.58.5. nis_clone_object

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_creategroup Prev: nis_checkpoint Up: Glibc rpcsvc/nislib.h Top: Top


nis_creategroup -- GNU Gnulib

Next: nis_destroy_object Prev: nis_clone_object Up: Glibc rpcsvc/nislib.h Top: Top

12.58.6. nis_creategroup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_destroy_object Prev: nis_clone_object Up: Glibc rpcsvc/nislib.h Top: Top


nis_destroy_object -- GNU Gnulib

Next: nis_destroygroup Prev: nis_creategroup Up: Glibc rpcsvc/nislib.h Top: Top

12.58.7. nis_destroy_object

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_destroygroup Prev: nis_creategroup Up: Glibc rpcsvc/nislib.h Top: Top


nis_destroygroup -- GNU Gnulib

Next: nis_dir_cmp Prev: nis_destroy_object Up: Glibc rpcsvc/nislib.h Top: Top

12.58.8. nis_destroygroup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_dir_cmp Prev: nis_destroy_object Up: Glibc rpcsvc/nislib.h Top: Top


nis_dir_cmp -- GNU Gnulib

Next: nis_domain_of Prev: nis_destroygroup Up: Glibc rpcsvc/nislib.h Top: Top

12.58.9. nis_dir_cmp

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_domain_of Prev: nis_destroygroup Up: Glibc rpcsvc/nislib.h Top: Top


nis_domain_of -- GNU Gnulib

Next: nis_domain_of_r Prev: nis_dir_cmp Up: Glibc rpcsvc/nislib.h Top: Top

12.58.10. nis_domain_of

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_domain_of_r Prev: nis_dir_cmp Up: Glibc rpcsvc/nislib.h Top: Top


nis_domain_of_r -- GNU Gnulib

Next: nis_first_entry Prev: nis_domain_of Up: Glibc rpcsvc/nislib.h Top: Top

12.58.11. nis_domain_of_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_first_entry Prev: nis_domain_of Up: Glibc rpcsvc/nislib.h Top: Top


nis_first_entry -- GNU Gnulib

Next: nis_freenames Prev: nis_domain_of_r Up: Glibc rpcsvc/nislib.h Top: Top

12.58.12. nis_first_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_freenames Prev: nis_domain_of_r Up: Glibc rpcsvc/nislib.h Top: Top


nis_freenames -- GNU Gnulib

Next: nis_freeresult Prev: nis_first_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.13. nis_freenames

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_freeresult Prev: nis_first_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_freeresult -- GNU Gnulib

Next: nis_freeservlist Prev: nis_freenames Up: Glibc rpcsvc/nislib.h Top: Top

12.58.14. nis_freeresult

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_freeservlist Prev: nis_freenames Up: Glibc rpcsvc/nislib.h Top: Top


nis_freeservlist -- GNU Gnulib

Next: nis_freetags Prev: nis_freeresult Up: Glibc rpcsvc/nislib.h Top: Top

12.58.15. nis_freeservlist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_freetags Prev: nis_freeresult Up: Glibc rpcsvc/nislib.h Top: Top


nis_freetags -- GNU Gnulib

Next: nis_getnames Prev: nis_freeservlist Up: Glibc rpcsvc/nislib.h Top: Top

12.58.16. nis_freetags

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_getnames Prev: nis_freeservlist Up: Glibc rpcsvc/nislib.h Top: Top


nis_getnames -- GNU Gnulib

Next: nis_getservlist Prev: nis_freetags Up: Glibc rpcsvc/nislib.h Top: Top

12.58.17. nis_getnames

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_getservlist Prev: nis_freetags Up: Glibc rpcsvc/nislib.h Top: Top


nis_getservlist -- GNU Gnulib

Next: nis_ismember Prev: nis_getnames Up: Glibc rpcsvc/nislib.h Top: Top

12.58.18. nis_getservlist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_ismember Prev: nis_getnames Up: Glibc rpcsvc/nislib.h Top: Top


nis_ismember -- GNU Gnulib

Next: nis_leaf_of Prev: nis_getservlist Up: Glibc rpcsvc/nislib.h Top: Top

12.58.19. nis_ismember

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_leaf_of Prev: nis_getservlist Up: Glibc rpcsvc/nislib.h Top: Top


nis_leaf_of -- GNU Gnulib

Next: nis_leaf_of_r Prev: nis_ismember Up: Glibc rpcsvc/nislib.h Top: Top

12.58.20. nis_leaf_of

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_leaf_of_r Prev: nis_ismember Up: Glibc rpcsvc/nislib.h Top: Top


nis_leaf_of_r -- GNU Gnulib

Next: nis_lerror Prev: nis_leaf_of Up: Glibc rpcsvc/nislib.h Top: Top

12.58.21. nis_leaf_of_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_lerror Prev: nis_leaf_of Up: Glibc rpcsvc/nislib.h Top: Top


nis_lerror -- GNU Gnulib

Next: nis_list Prev: nis_leaf_of_r Up: Glibc rpcsvc/nislib.h Top: Top

12.58.22. nis_lerror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_list Prev: nis_leaf_of_r Up: Glibc rpcsvc/nislib.h Top: Top


nis_list -- GNU Gnulib

Next: nis_local_directory Prev: nis_lerror Up: Glibc rpcsvc/nislib.h Top: Top

12.58.23. nis_list

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_local_directory Prev: nis_lerror Up: Glibc rpcsvc/nislib.h Top: Top


nis_local_directory -- GNU Gnulib

Next: nis_local_group Prev: nis_list Up: Glibc rpcsvc/nislib.h Top: Top

12.58.24. nis_local_directory

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_local_group Prev: nis_list Up: Glibc rpcsvc/nislib.h Top: Top


nis_local_group -- GNU Gnulib

Next: nis_local_host Prev: nis_local_directory Up: Glibc rpcsvc/nislib.h Top: Top

12.58.25. nis_local_group

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_local_host Prev: nis_local_directory Up: Glibc rpcsvc/nislib.h Top: Top


nis_local_host -- GNU Gnulib

Next: nis_local_principal Prev: nis_local_group Up: Glibc rpcsvc/nislib.h Top: Top

12.58.26. nis_local_host

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_local_principal Prev: nis_local_group Up: Glibc rpcsvc/nislib.h Top: Top


nis_local_principal -- GNU Gnulib

Next: nis_lookup Prev: nis_local_host Up: Glibc rpcsvc/nislib.h Top: Top

12.58.27. nis_local_principal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_lookup Prev: nis_local_host Up: Glibc rpcsvc/nislib.h Top: Top


nis_lookup -- GNU Gnulib

Next: nis_mkdir Prev: nis_local_principal Up: Glibc rpcsvc/nislib.h Top: Top

12.58.28. nis_lookup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_mkdir Prev: nis_local_principal Up: Glibc rpcsvc/nislib.h Top: Top


nis_mkdir -- GNU Gnulib

Next: nis_modify Prev: nis_lookup Up: Glibc rpcsvc/nislib.h Top: Top

12.58.29. nis_mkdir

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_modify Prev: nis_lookup Up: Glibc rpcsvc/nislib.h Top: Top


nis_modify -- GNU Gnulib

Next: nis_modify_entry Prev: nis_mkdir Up: Glibc rpcsvc/nislib.h Top: Top

12.58.30. nis_modify

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_modify_entry Prev: nis_mkdir Up: Glibc rpcsvc/nislib.h Top: Top


nis_modify_entry -- GNU Gnulib

Next: nis_name_of Prev: nis_modify Up: Glibc rpcsvc/nislib.h Top: Top

12.58.31. nis_modify_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_name_of Prev: nis_modify Up: Glibc rpcsvc/nislib.h Top: Top


nis_name_of -- GNU Gnulib

Next: nis_name_of_r Prev: nis_modify_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.32. nis_name_of

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_name_of_r Prev: nis_modify_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_name_of_r -- GNU Gnulib

Next: nis_next_entry Prev: nis_name_of Up: Glibc rpcsvc/nislib.h Top: Top

12.58.33. nis_name_of_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_next_entry Prev: nis_name_of Up: Glibc rpcsvc/nislib.h Top: Top


nis_next_entry -- GNU Gnulib

Next: nis_perror Prev: nis_name_of_r Up: Glibc rpcsvc/nislib.h Top: Top

12.58.34. nis_next_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_perror Prev: nis_name_of_r Up: Glibc rpcsvc/nislib.h Top: Top


nis_perror -- GNU Gnulib

Next: nis_ping Prev: nis_next_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.35. nis_perror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_ping Prev: nis_next_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_ping -- GNU Gnulib

Next: nis_print_directory Prev: nis_perror Up: Glibc rpcsvc/nislib.h Top: Top

12.58.36. nis_ping

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_directory Prev: nis_perror Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_directory -- GNU Gnulib

Next: nis_print_entry Prev: nis_ping Up: Glibc rpcsvc/nislib.h Top: Top

12.58.37. nis_print_directory

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_entry Prev: nis_ping Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_entry -- GNU Gnulib

Next: nis_print_group Prev: nis_print_directory Up: Glibc rpcsvc/nislib.h Top: Top

12.58.38. nis_print_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_group Prev: nis_print_directory Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_group -- GNU Gnulib

Next: nis_print_group_entry Prev: nis_print_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.39. nis_print_group

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_group_entry Prev: nis_print_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_group_entry -- GNU Gnulib

Next: nis_print_link Prev: nis_print_group Up: Glibc rpcsvc/nislib.h Top: Top

12.58.40. nis_print_group_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_link Prev: nis_print_group Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_link -- GNU Gnulib

Next: nis_print_object Prev: nis_print_group_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.41. nis_print_link

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_object Prev: nis_print_group_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_object -- GNU Gnulib

Next: nis_print_result Prev: nis_print_link Up: Glibc rpcsvc/nislib.h Top: Top

12.58.42. nis_print_object

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_result Prev: nis_print_link Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_result -- GNU Gnulib

Next: nis_print_rights Prev: nis_print_object Up: Glibc rpcsvc/nislib.h Top: Top

12.58.43. nis_print_result

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_rights Prev: nis_print_object Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_rights -- GNU Gnulib

Next: nis_print_table Prev: nis_print_result Up: Glibc rpcsvc/nislib.h Top: Top

12.58.44. nis_print_rights

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_print_table Prev: nis_print_result Up: Glibc rpcsvc/nislib.h Top: Top


nis_print_table -- GNU Gnulib

Next: nis_remove Prev: nis_print_rights Up: Glibc rpcsvc/nislib.h Top: Top

12.58.45. nis_print_table

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_remove Prev: nis_print_rights Up: Glibc rpcsvc/nislib.h Top: Top


nis_remove -- GNU Gnulib

Next: nis_remove_entry Prev: nis_print_table Up: Glibc rpcsvc/nislib.h Top: Top

12.58.46. nis_remove

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_remove_entry Prev: nis_print_table Up: Glibc rpcsvc/nislib.h Top: Top


nis_remove_entry -- GNU Gnulib

Next: nis_removemember Prev: nis_remove Up: Glibc rpcsvc/nislib.h Top: Top

12.58.47. nis_remove_entry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_removemember Prev: nis_remove Up: Glibc rpcsvc/nislib.h Top: Top


nis_removemember -- GNU Gnulib

Next: nis_rmdir Prev: nis_remove_entry Up: Glibc rpcsvc/nislib.h Top: Top

12.58.48. nis_removemember

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_rmdir Prev: nis_remove_entry Up: Glibc rpcsvc/nislib.h Top: Top


nis_rmdir -- GNU Gnulib

Next: nis_servstate Prev: nis_removemember Up: Glibc rpcsvc/nislib.h Top: Top

12.58.49. nis_rmdir

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_servstate Prev: nis_removemember Up: Glibc rpcsvc/nislib.h Top: Top


nis_servstate -- GNU Gnulib

Next: nis_sperrno Prev: nis_rmdir Up: Glibc rpcsvc/nislib.h Top: Top

12.58.50. nis_servstate

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_sperrno Prev: nis_rmdir Up: Glibc rpcsvc/nislib.h Top: Top


nis_sperrno -- GNU Gnulib

Next: nis_sperror Prev: nis_servstate Up: Glibc rpcsvc/nislib.h Top: Top

12.58.51. nis_sperrno

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_sperror Prev: nis_servstate Up: Glibc rpcsvc/nislib.h Top: Top


nis_sperror -- GNU Gnulib

Next: nis_sperror_r Prev: nis_sperrno Up: Glibc rpcsvc/nislib.h Top: Top

12.58.52. nis_sperror

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_sperror_r Prev: nis_sperrno Up: Glibc rpcsvc/nislib.h Top: Top


nis_sperror_r -- GNU Gnulib

Next: nis_stats Prev: nis_sperror Up: Glibc rpcsvc/nislib.h Top: Top

12.58.53. nis_sperror_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_stats Prev: nis_sperror Up: Glibc rpcsvc/nislib.h Top: Top


nis_stats -- GNU Gnulib

Next: nis_verifygroup Prev: nis_sperror_r Up: Glibc rpcsvc/nislib.h Top: Top

12.58.54. nis_stats

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: nis_verifygroup Prev: nis_sperror_r Up: Glibc rpcsvc/nislib.h Top: Top


nis_verifygroup -- GNU Gnulib

Prev: nis_stats Up: Glibc rpcsvc/nislib.h Top: Top

12.58.55. nis_verifygroup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: nis_stats Up: Glibc rpcsvc/nislib.h Top: Top


Glibc rpcsvc/nis_callback.h -- GNU Gnulib

Next: Glibc rpcsvc/yp.h Prev: Glibc rpcsvc/nislib.h Up: Glibc Function Substitutes Top: Top

12.59. Glibc <rpcsvc/nis_callback.h>

Menu

  • xdr_cback_data
  • xdr_obj_p


xdr_cback_data -- GNU Gnulib

Next: xdr_obj_p Up: Glibc rpcsvc/nis_callback.h Top: Top

12.59.1. xdr_cback_data

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_obj_p Up: Glibc rpcsvc/nis_callback.h Top: Top


xdr_obj_p -- GNU Gnulib

Prev: xdr_cback_data Up: Glibc rpcsvc/nis_callback.h Top: Top

12.59.2. xdr_obj_p

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: xdr_cback_data Up: Glibc rpcsvc/nis_callback.h Top: Top


Glibc rpcsvc/yp.h -- GNU Gnulib

Next: Glibc rpcsvc/yp_prot.h Prev: Glibc rpcsvc/nis_callback.h Up: Glibc Function Substitutes Top: Top

12.60. Glibc <rpcsvc/yp.h>

Menu

  • xdr_domainname
  • xdr_keydat
  • xdr_mapname
  • xdr_peername
  • xdr_valdat
  • xdr_ypbind_binding
  • xdr_ypbind_resp
  • xdr_ypbind_resptype
  • xdr_ypbind_setdom
  • xdr_ypmap_parms
  • xdr_ypmaplist
  • xdr_yppush_status
  • xdr_yppushresp_xfr
  • xdr_ypreq_key
  • xdr_ypreq_nokey
  • xdr_ypreq_xfr
  • xdr_ypresp_all
  • xdr_ypresp_key_val
  • xdr_ypresp_maplist
  • xdr_ypresp_master
  • xdr_ypresp_order
  • xdr_ypresp_val
  • xdr_ypresp_xfr
  • xdr_ypstat
  • xdr_ypxfrstat

    • Next: Glibc rpcsvc/yp_prot.h Prev: Glibc rpcsvc/nis_callback.h Up: Glibc Function Substitutes Top: Top


xdr_domainname -- GNU Gnulib

Next: xdr_keydat Up: Glibc rpcsvc/yp.h Top: Top

12.60.1. xdr_domainname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_keydat Up: Glibc rpcsvc/yp.h Top: Top


xdr_keydat -- GNU Gnulib

Next: xdr_mapname Prev: xdr_domainname Up: Glibc rpcsvc/yp.h Top: Top

12.60.2. xdr_keydat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_mapname Prev: xdr_domainname Up: Glibc rpcsvc/yp.h Top: Top


xdr_mapname -- GNU Gnulib

Next: xdr_peername Prev: xdr_keydat Up: Glibc rpcsvc/yp.h Top: Top

12.60.3. xdr_mapname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_peername Prev: xdr_keydat Up: Glibc rpcsvc/yp.h Top: Top


xdr_peername -- GNU Gnulib

Next: xdr_valdat Prev: xdr_mapname Up: Glibc rpcsvc/yp.h Top: Top

12.60.4. xdr_peername

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_valdat Prev: xdr_mapname Up: Glibc rpcsvc/yp.h Top: Top


xdr_valdat -- GNU Gnulib

Next: xdr_ypbind_binding Prev: xdr_peername Up: Glibc rpcsvc/yp.h Top: Top

12.60.5. xdr_valdat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypbind_binding Prev: xdr_peername Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypbind_binding -- GNU Gnulib

Next: xdr_ypbind_resp Prev: xdr_valdat Up: Glibc rpcsvc/yp.h Top: Top

12.60.6. xdr_ypbind_binding

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypbind_resp Prev: xdr_valdat Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypbind_resp -- GNU Gnulib

Next: xdr_ypbind_resptype Prev: xdr_ypbind_binding Up: Glibc rpcsvc/yp.h Top: Top

12.60.7. xdr_ypbind_resp

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypbind_resptype Prev: xdr_ypbind_binding Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypbind_resptype -- GNU Gnulib

Next: xdr_ypbind_setdom Prev: xdr_ypbind_resp Up: Glibc rpcsvc/yp.h Top: Top

12.60.8. xdr_ypbind_resptype

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypbind_setdom Prev: xdr_ypbind_resp Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypbind_setdom -- GNU Gnulib

Next: xdr_ypmap_parms Prev: xdr_ypbind_resptype Up: Glibc rpcsvc/yp.h Top: Top

12.60.9. xdr_ypbind_setdom

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypmap_parms Prev: xdr_ypbind_resptype Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypmap_parms -- GNU Gnulib

Next: xdr_ypmaplist Prev: xdr_ypbind_setdom Up: Glibc rpcsvc/yp.h Top: Top

12.60.10. xdr_ypmap_parms

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypmaplist Prev: xdr_ypbind_setdom Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypmaplist -- GNU Gnulib

Next: xdr_yppush_status Prev: xdr_ypmap_parms Up: Glibc rpcsvc/yp.h Top: Top

12.60.11. xdr_ypmaplist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_yppush_status Prev: xdr_ypmap_parms Up: Glibc rpcsvc/yp.h Top: Top


xdr_yppush_status -- GNU Gnulib

Next: xdr_yppushresp_xfr Prev: xdr_ypmaplist Up: Glibc rpcsvc/yp.h Top: Top

12.60.12. xdr_yppush_status

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_yppushresp_xfr Prev: xdr_ypmaplist Up: Glibc rpcsvc/yp.h Top: Top


xdr_yppushresp_xfr -- GNU Gnulib

Next: xdr_ypreq_key Prev: xdr_yppush_status Up: Glibc rpcsvc/yp.h Top: Top

12.60.13. xdr_yppushresp_xfr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypreq_key Prev: xdr_yppush_status Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypreq_key -- GNU Gnulib

Next: xdr_ypreq_nokey Prev: xdr_yppushresp_xfr Up: Glibc rpcsvc/yp.h Top: Top

12.60.14. xdr_ypreq_key

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypreq_nokey Prev: xdr_yppushresp_xfr Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypreq_nokey -- GNU Gnulib

Next: xdr_ypreq_xfr Prev: xdr_ypreq_key Up: Glibc rpcsvc/yp.h Top: Top

12.60.15. xdr_ypreq_nokey

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypreq_xfr Prev: xdr_ypreq_key Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypreq_xfr -- GNU Gnulib

Next: xdr_ypresp_all Prev: xdr_ypreq_nokey Up: Glibc rpcsvc/yp.h Top: Top

12.60.16. xdr_ypreq_xfr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_all Prev: xdr_ypreq_nokey Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_all -- GNU Gnulib

Next: xdr_ypresp_key_val Prev: xdr_ypreq_xfr Up: Glibc rpcsvc/yp.h Top: Top

12.60.17. xdr_ypresp_all

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_key_val Prev: xdr_ypreq_xfr Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_key_val -- GNU Gnulib

Next: xdr_ypresp_maplist Prev: xdr_ypresp_all Up: Glibc rpcsvc/yp.h Top: Top

12.60.18. xdr_ypresp_key_val

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_maplist Prev: xdr_ypresp_all Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_maplist -- GNU Gnulib

Next: xdr_ypresp_master Prev: xdr_ypresp_key_val Up: Glibc rpcsvc/yp.h Top: Top

12.60.19. xdr_ypresp_maplist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_master Prev: xdr_ypresp_key_val Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_master -- GNU Gnulib

Next: xdr_ypresp_order Prev: xdr_ypresp_maplist Up: Glibc rpcsvc/yp.h Top: Top

12.60.20. xdr_ypresp_master

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_order Prev: xdr_ypresp_maplist Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_order -- GNU Gnulib

Next: xdr_ypresp_val Prev: xdr_ypresp_master Up: Glibc rpcsvc/yp.h Top: Top

12.60.21. xdr_ypresp_order

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_val Prev: xdr_ypresp_master Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_val -- GNU Gnulib

Next: xdr_ypresp_xfr Prev: xdr_ypresp_order Up: Glibc rpcsvc/yp.h Top: Top

12.60.22. xdr_ypresp_val

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypresp_xfr Prev: xdr_ypresp_order Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypresp_xfr -- GNU Gnulib

Next: xdr_ypstat Prev: xdr_ypresp_val Up: Glibc rpcsvc/yp.h Top: Top

12.60.23. xdr_ypresp_xfr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypstat Prev: xdr_ypresp_val Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypstat -- GNU Gnulib

Next: xdr_ypxfrstat Prev: xdr_ypresp_xfr Up: Glibc rpcsvc/yp.h Top: Top

12.60.24. xdr_ypstat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypxfrstat Prev: xdr_ypresp_xfr Up: Glibc rpcsvc/yp.h Top: Top


xdr_ypxfrstat -- GNU Gnulib

Prev: xdr_ypstat Up: Glibc rpcsvc/yp.h Top: Top

12.60.25. xdr_ypxfrstat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: xdr_ypstat Up: Glibc rpcsvc/yp.h Top: Top


Glibc rpcsvc/yp_prot.h -- GNU Gnulib

Next: Glibc rpcsvc/ypclnt.h Prev: Glibc rpcsvc/yp.h Up: Glibc Function Substitutes Top: Top

12.61. Glibc <rpcsvc/yp_prot.h>

Menu

  • xdr_ypall


xdr_ypall -- GNU Gnulib

Up: Glibc rpcsvc/yp_prot.h Top: Top

12.61.1. xdr_ypall

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc rpcsvc/yp_prot.h Top: Top


Glibc rpcsvc/ypclnt.h -- GNU Gnulib

Next: Glibc rpcsvc/ypupd.h Prev: Glibc rpcsvc/yp_prot.h Up: Glibc Function Substitutes Top: Top

12.62. Glibc <rpcsvc/ypclnt.h>

Menu

  • yp_all
  • yp_bind
  • yp_first
  • yp_get_default_domain
  • yp_master
  • yp_match
  • yp_next
  • yp_order
  • yp_unbind
  • yp_update
  • ypbinderr_string
  • yperr_string
  • ypprot_err

    • Next: Glibc rpcsvc/ypupd.h Prev: Glibc rpcsvc/yp_prot.h Up: Glibc Function Substitutes Top: Top


yp_all -- GNU Gnulib

Next: yp_bind Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.1. yp_all

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_bind Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_bind -- GNU Gnulib

Next: yp_first Prev: yp_all Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.2. yp_bind

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_first Prev: yp_all Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_first -- GNU Gnulib

Next: yp_get_default_domain Prev: yp_bind Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.3. yp_first

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_get_default_domain Prev: yp_bind Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_get_default_domain -- GNU Gnulib

Next: yp_master Prev: yp_first Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.4. yp_get_default_domain

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_master Prev: yp_first Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_master -- GNU Gnulib

Next: yp_match Prev: yp_get_default_domain Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.5. yp_master

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_match Prev: yp_get_default_domain Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_match -- GNU Gnulib

Next: yp_next Prev: yp_master Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.6. yp_match

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_next Prev: yp_master Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_next -- GNU Gnulib

Next: yp_order Prev: yp_match Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.7. yp_next

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_order Prev: yp_match Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_order -- GNU Gnulib

Next: yp_unbind Prev: yp_next Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.8. yp_order

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_unbind Prev: yp_next Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_unbind -- GNU Gnulib

Next: yp_update Prev: yp_order Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.9. yp_unbind

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yp_update Prev: yp_order Up: Glibc rpcsvc/ypclnt.h Top: Top


yp_update -- GNU Gnulib

Next: ypbinderr_string Prev: yp_unbind Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.10. yp_update

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ypbinderr_string Prev: yp_unbind Up: Glibc rpcsvc/ypclnt.h Top: Top


ypbinderr_string -- GNU Gnulib

Next: yperr_string Prev: yp_update Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.11. ypbinderr_string

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: yperr_string Prev: yp_update Up: Glibc rpcsvc/ypclnt.h Top: Top


yperr_string -- GNU Gnulib

Next: ypprot_err Prev: ypbinderr_string Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.12. yperr_string

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ypprot_err Prev: ypbinderr_string Up: Glibc rpcsvc/ypclnt.h Top: Top


ypprot_err -- GNU Gnulib

Prev: yperr_string Up: Glibc rpcsvc/ypclnt.h Top: Top

12.62.13. ypprot_err

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: yperr_string Up: Glibc rpcsvc/ypclnt.h Top: Top


Glibc rpcsvc/ypupd.h -- GNU Gnulib

Next: Glibc sched.h Prev: Glibc rpcsvc/ypclnt.h Up: Glibc Function Substitutes Top: Top

12.63. Glibc <rpcsvc/ypupd.h>

Menu

  • xdr_yp_buf
  • xdr_ypdelete_args
  • xdr_ypupdate_args


xdr_yp_buf -- GNU Gnulib

Next: xdr_ypdelete_args Up: Glibc rpcsvc/ypupd.h Top: Top

12.63.1. xdr_yp_buf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypdelete_args Up: Glibc rpcsvc/ypupd.h Top: Top


xdr_ypdelete_args -- GNU Gnulib

Next: xdr_ypupdate_args Prev: xdr_yp_buf Up: Glibc rpcsvc/ypupd.h Top: Top

12.63.2. xdr_ypdelete_args

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: xdr_ypupdate_args Prev: xdr_yp_buf Up: Glibc rpcsvc/ypupd.h Top: Top


xdr_ypupdate_args -- GNU Gnulib

Prev: xdr_ypdelete_args Up: Glibc rpcsvc/ypupd.h Top: Top

12.63.3. xdr_ypupdate_args

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: xdr_ypdelete_args Up: Glibc rpcsvc/ypupd.h Top: Top


Glibc sched.h -- GNU Gnulib

Next: Glibc search.h Prev: Glibc rpcsvc/ypupd.h Up: Glibc Function Substitutes Top: Top

12.64. Glibc Extensions to <sched.h>

Menu

  • clone
  • sched_getaffinity
  • sched_setaffinity
  • setns


clone -- GNU Gnulib

Next: sched_getaffinity Up: Glibc sched.h Top: Top

12.64.1. clone

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_getaffinity Up: Glibc sched.h Top: Top


sched_getaffinity -- GNU Gnulib

Next: sched_setaffinity Prev: clone Up: Glibc sched.h Top: Top

12.64.2. sched_getaffinity

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sched_setaffinity Prev: clone Up: Glibc sched.h Top: Top


sched_setaffinity -- GNU Gnulib

Next: setns Prev: sched_getaffinity Up: Glibc sched.h Top: Top

12.64.3. sched_setaffinity

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setns Prev: sched_getaffinity Up: Glibc sched.h Top: Top


setns -- GNU Gnulib

Prev: sched_setaffinity Up: Glibc sched.h Top: Top

12.64.4. setns

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: sched_setaffinity Up: Glibc sched.h Top: Top


Glibc search.h -- GNU Gnulib

Next: Glibc selinux/selinux.h Prev: Glibc sched.h Up: Glibc Function Substitutes Top: Top

12.65. Glibc Extensions to <search.h>

Menu

  • hcreate_r
  • hdestroy_r
  • hsearch_r
  • tdestroy


hcreate_r -- GNU Gnulib

Next: hdestroy_r Up: Glibc search.h Top: Top

12.65.1. hcreate_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: hdestroy_r Up: Glibc search.h Top: Top


hdestroy_r -- GNU Gnulib

Next: hsearch_r Prev: hcreate_r Up: Glibc search.h Top: Top

12.65.2. hdestroy_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: hsearch_r Prev: hcreate_r Up: Glibc search.h Top: Top


hsearch_r -- GNU Gnulib

Next: tdestroy Prev: hdestroy_r Up: Glibc search.h Top: Top

12.65.3. hsearch_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: tdestroy Prev: hdestroy_r Up: Glibc search.h Top: Top


tdestroy -- GNU Gnulib

Prev: hsearch_r Up: Glibc search.h Top: Top

12.65.4. tdestroy

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.0, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: hsearch_r Up: Glibc search.h Top: Top


Glibc selinux/selinux.h -- GNU Gnulib

Next: Glibc shadow.h Prev: Glibc search.h Up: Glibc Function Substitutes Top: Top

12.66. Glibc Extensions to <selinux/selinux.h>

Menu

  • fgetfilecon
  • getfilecon
  • lgetfilecon
    • Gnulib module: selinux-h

    Portability problems fixed by Gnulib:

    • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS. On those platforms, this module provides a stub that always sets errno to ENOTSUP and returns `-1'.
    • On systems with SELinux support, this module provides a wrapper for the \fn\ function that insulates the caller from API-nonconforming behavior. Without this wrapper, \fn\ can return `0' and set the context pointer to NULL, and in another scenario can return `10' and set the context pointer to `unlabeled'. This wrapper returns `-1' in each case and sets errno to ENOTSUP and ENODATA respectively. While the conditions that can provoke such behavior are rare, the average caller does not handle them because the possibility of such behavior is not documented.
    Portability problems not fixed by Gnulib:

    Next: Glibc shadow.h Prev: Glibc search.h Up: Glibc Function Substitutes Top: Top


fgetfilecon -- GNU Gnulib

Next: getfilecon Up: Glibc selinux/selinux.h Top: Top

12.66.1. fgetfilecon

@getfileconDesc{fgetfilecon}


getfilecon -- GNU Gnulib

Next: lgetfilecon Prev: fgetfilecon Up: Glibc selinux/selinux.h Top: Top

12.66.2. getfilecon

@getfileconDesc{getfilecon}


lgetfilecon -- GNU Gnulib

Prev: getfilecon Up: Glibc selinux/selinux.h Top: Top

12.66.3. lgetfilecon

@getfileconDesc{lgetfilecon}


Glibc shadow.h -- GNU Gnulib

Next: Glibc signal.h Prev: Glibc selinux/selinux.h Up: Glibc Function Substitutes Top: Top

12.67. Glibc <shadow.h>

Menu

  • endspent
  • fgetspent
  • fgetspent_r
  • getspent
  • getspent_r
  • getspnam
  • getspnam_r
  • lckpwdf
  • putspent
  • setspent
  • sgetspent
  • sgetspent_r
  • ulckpwdf

    • Next: Glibc signal.h Prev: Glibc selinux/selinux.h Up: Glibc Function Substitutes Top: Top


endspent -- GNU Gnulib

Next: fgetspent Up: Glibc shadow.h Top: Top

12.67.1. endspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetspent Up: Glibc shadow.h Top: Top


fgetspent -- GNU Gnulib

Next: fgetspent_r Prev: endspent Up: Glibc shadow.h Top: Top

12.67.2. fgetspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgetspent_r Prev: endspent Up: Glibc shadow.h Top: Top


fgetspent_r -- GNU Gnulib

Next: getspent Prev: fgetspent Up: Glibc shadow.h Top: Top

12.67.3. fgetspent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getspent Prev: fgetspent Up: Glibc shadow.h Top: Top


getspent -- GNU Gnulib

Next: getspent_r Prev: fgetspent_r Up: Glibc shadow.h Top: Top

12.67.4. getspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getspent_r Prev: fgetspent_r Up: Glibc shadow.h Top: Top


getspent_r -- GNU Gnulib

Next: getspnam Prev: getspent Up: Glibc shadow.h Top: Top

12.67.5. getspent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getspnam Prev: getspent Up: Glibc shadow.h Top: Top


getspnam -- GNU Gnulib

Next: getspnam_r Prev: getspent_r Up: Glibc shadow.h Top: Top

12.67.6. getspnam

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getspnam_r Prev: getspent_r Up: Glibc shadow.h Top: Top


getspnam_r -- GNU Gnulib

Next: lckpwdf Prev: getspnam Up: Glibc shadow.h Top: Top

12.67.7. getspnam_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 5.3, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: lckpwdf Prev: getspnam Up: Glibc shadow.h Top: Top


lckpwdf -- GNU Gnulib

Next: putspent Prev: getspnam_r Up: Glibc shadow.h Top: Top

12.67.8. lckpwdf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: putspent Prev: getspnam_r Up: Glibc shadow.h Top: Top


putspent -- GNU Gnulib

Next: setspent Prev: lckpwdf Up: Glibc shadow.h Top: Top

12.67.9. putspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setspent Prev: lckpwdf Up: Glibc shadow.h Top: Top


setspent -- GNU Gnulib

Next: sgetspent Prev: putspent Up: Glibc shadow.h Top: Top

12.67.10. setspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sgetspent Prev: putspent Up: Glibc shadow.h Top: Top


sgetspent -- GNU Gnulib

Next: sgetspent_r Prev: setspent Up: Glibc shadow.h Top: Top

12.67.11. sgetspent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sgetspent_r Prev: setspent Up: Glibc shadow.h Top: Top


sgetspent_r -- GNU Gnulib

Next: ulckpwdf Prev: sgetspent Up: Glibc shadow.h Top: Top

12.67.12. sgetspent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ulckpwdf Prev: sgetspent Up: Glibc shadow.h Top: Top


ulckpwdf -- GNU Gnulib

Prev: sgetspent_r Up: Glibc shadow.h Top: Top

12.67.13. ulckpwdf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: sgetspent_r Up: Glibc shadow.h Top: Top


Glibc signal.h -- GNU Gnulib

Next: Glibc stdio.h Prev: Glibc shadow.h Up: Glibc Function Substitutes Top: Top

12.68. Glibc Extensions to <signal.h>

Menu

  • gsignal
  • sigandset
  • sigblock
  • siggetmask
  • sigisemptyset
  • sigorset
  • sigreturn
  • sigsetmask
  • sigstack
  • sigvec
  • ssignal
  • sys_siglist
  • sysv_signal

    • Next: Glibc stdio.h Prev: Glibc shadow.h Up: Glibc Function Substitutes Top: Top


gsignal -- GNU Gnulib

Next: sigandset Up: Glibc signal.h Top: Top

12.68.1. gsignal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: sigandset Up: Glibc signal.h Top: Top


sigandset -- GNU Gnulib

Next: sigblock Prev: gsignal Up: Glibc signal.h Top: Top

12.68.2. sigandset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigblock Prev: gsignal Up: Glibc signal.h Top: Top


sigblock -- GNU Gnulib

Next: siggetmask Prev: sigandset Up: Glibc signal.h Top: Top

12.68.3. sigblock

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: siggetmask Prev: sigandset Up: Glibc signal.h Top: Top


siggetmask -- GNU Gnulib

Next: sigisemptyset Prev: sigblock Up: Glibc signal.h Top: Top

12.68.4. siggetmask

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigisemptyset Prev: sigblock Up: Glibc signal.h Top: Top


sigisemptyset -- GNU Gnulib

Next: sigorset Prev: siggetmask Up: Glibc signal.h Top: Top

12.68.5. sigisemptyset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigorset Prev: siggetmask Up: Glibc signal.h Top: Top


sigorset -- GNU Gnulib

Next: sigreturn Prev: sigisemptyset Up: Glibc signal.h Top: Top

12.68.6. sigorset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigreturn Prev: sigisemptyset Up: Glibc signal.h Top: Top


sigreturn -- GNU Gnulib

Next: sigsetmask Prev: sigorset Up: Glibc signal.h Top: Top

12.68.7. sigreturn

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigsetmask Prev: sigorset Up: Glibc signal.h Top: Top


sigsetmask -- GNU Gnulib

Next: sigstack Prev: sigreturn Up: Glibc signal.h Top: Top

12.68.8. sigsetmask

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: sigstack Prev: sigreturn Up: Glibc signal.h Top: Top


sigstack -- GNU Gnulib

Next: sigvec Prev: sigsetmask Up: Glibc signal.h Top: Top

12.68.9. sigstack

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sigvec Prev: sigsetmask Up: Glibc signal.h Top: Top


sigvec -- GNU Gnulib

Next: ssignal Prev: sigstack Up: Glibc signal.h Top: Top

12.68.10. sigvec

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, BeOS.

Next: ssignal Prev: sigstack Up: Glibc signal.h Top: Top


ssignal -- GNU Gnulib

Next: sys_siglist Prev: sigvec Up: Glibc signal.h Top: Top

12.68.11. ssignal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: sys_siglist Prev: sigvec Up: Glibc signal.h Top: Top


sys_siglist -- GNU Gnulib

Next: sysv_signal Prev: ssignal Up: Glibc signal.h Top: Top

12.68.12. sys_siglist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This constant is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5.

Next: sysv_signal Prev: ssignal Up: Glibc signal.h Top: Top


sysv_signal -- GNU Gnulib

Prev: sys_siglist Up: Glibc signal.h Top: Top

12.68.13. sysv_signal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Prev: sys_siglist Up: Glibc signal.h Top: Top


Glibc stdio.h -- GNU Gnulib

Next: Glibc stdlib.h Prev: Glibc signal.h Up: Glibc Function Substitutes Top: Top

12.69. Glibc Extensions to <stdio.h>

Menu

  • asprintf
  • cuserid
  • clearerr_unlocked
  • fcloseall
  • feof_unlocked
  • ferror_unlocked
  • fflush_unlocked
  • fgetc_unlocked
  • fgets_unlocked
  • fileno_unlocked
  • fopencookie
  • fputc_unlocked
  • fputs_unlocked
  • fread_unlocked
  • fwrite_unlocked
  • getw
  • putw
  • setbuffer
  • setlinebuf
  • sys_errlist
  • sys_nerr
  • tmpnam_r
  • vasprintf

    • Next: Glibc stdlib.h Prev: Glibc signal.h Up: Glibc Function Substitutes Top: Top


asprintf -- GNU Gnulib

Next: cuserid Up: Glibc stdio.h Top: Top

12.69.1. asprintf

Gnulib module: vasprintf or vasprintf-posix

Portability problems fixed by either Gnulib module vasprintf or vasprintf-posix:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5.
Portability problems fixed by Gnulib module vasprintf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: Cygwin 1.5.24, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: Solaris 11.0.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, Solaris 11.3, Cygwin 1.5.x, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, Cygwin 1.5.x, BeOS.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Solaris 11.0, Cygwin 1.5.x.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: BeOS.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems not fixed by Gnulib:

Next: cuserid Up: Glibc stdio.h Top: Top


cuserid -- GNU Gnulib

Next: clearerr_unlocked Prev: asprintf Up: Glibc stdio.h Top: Top

12.69.2. cuserid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, mingw, MSVC 14.

Next: clearerr_unlocked Prev: asprintf Up: Glibc stdio.h Top: Top


clearerr_unlocked -- GNU Gnulib

Next: fcloseall Prev: cuserid Up: Glibc stdio.h Top: Top

12.69.3. clearerr_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fcloseall Prev: cuserid Up: Glibc stdio.h Top: Top


fcloseall -- GNU Gnulib

Next: feof_unlocked Prev: clearerr_unlocked Up: Glibc stdio.h Top: Top

12.69.4. fcloseall

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, Interix 3.5.

Next: feof_unlocked Prev: clearerr_unlocked Up: Glibc stdio.h Top: Top


feof_unlocked -- GNU Gnulib

Next: ferror_unlocked Prev: fcloseall Up: Glibc stdio.h Top: Top

12.69.5. feof_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: ferror_unlocked Prev: fcloseall Up: Glibc stdio.h Top: Top


ferror_unlocked -- GNU Gnulib

Next: fflush_unlocked Prev: feof_unlocked Up: Glibc stdio.h Top: Top

12.69.6. ferror_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fflush_unlocked Prev: feof_unlocked Up: Glibc stdio.h Top: Top


fflush_unlocked -- GNU Gnulib

Next: fgetc_unlocked Prev: ferror_unlocked Up: Glibc stdio.h Top: Top

12.69.7. fflush_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fgetc_unlocked Prev: ferror_unlocked Up: Glibc stdio.h Top: Top


fgetc_unlocked -- GNU Gnulib

Next: fgets_unlocked Prev: fflush_unlocked Up: Glibc stdio.h Top: Top

12.69.8. fgetc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fgets_unlocked Prev: fflush_unlocked Up: Glibc stdio.h Top: Top


fgets_unlocked -- GNU Gnulib

Next: fileno_unlocked Prev: fgetc_unlocked Up: Glibc stdio.h Top: Top

12.69.9. fgets_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fileno_unlocked Prev: fgetc_unlocked Up: Glibc stdio.h Top: Top


fileno_unlocked -- GNU Gnulib

Next: fopencookie Prev: fgets_unlocked Up: Glibc stdio.h Top: Top

12.69.10. fileno_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fopencookie Prev: fgets_unlocked Up: Glibc stdio.h Top: Top


fopencookie -- GNU Gnulib

Next: fputc_unlocked Prev: fileno_unlocked Up: Glibc stdio.h Top: Top

12.69.11. fopencookie

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fputc_unlocked Prev: fileno_unlocked Up: Glibc stdio.h Top: Top


fputc_unlocked -- GNU Gnulib

Next: fputs_unlocked Prev: fopencookie Up: Glibc stdio.h Top: Top

12.69.12. fputc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fputs_unlocked Prev: fopencookie Up: Glibc stdio.h Top: Top


fputs_unlocked -- GNU Gnulib

Next: fread_unlocked Prev: fputc_unlocked Up: Glibc stdio.h Top: Top

12.69.13. fputs_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fread_unlocked Prev: fputc_unlocked Up: Glibc stdio.h Top: Top


fread_unlocked -- GNU Gnulib

Next: fwrite_unlocked Prev: fputs_unlocked Up: Glibc stdio.h Top: Top

12.69.14. fread_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fwrite_unlocked Prev: fputs_unlocked Up: Glibc stdio.h Top: Top


fwrite_unlocked -- GNU Gnulib

Next: getw Prev: fread_unlocked Up: Glibc stdio.h Top: Top

12.69.15. fwrite_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: getw Prev: fread_unlocked Up: Glibc stdio.h Top: Top


getw -- GNU Gnulib

Next: putw Prev: fwrite_unlocked Up: Glibc stdio.h Top: Top

12.69.16. getw

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: putw Prev: fwrite_unlocked Up: Glibc stdio.h Top: Top


putw -- GNU Gnulib

Next: setbuffer Prev: getw Up: Glibc stdio.h Top: Top

12.69.17. putw

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: BeOS.

Next: setbuffer Prev: getw Up: Glibc stdio.h Top: Top


setbuffer -- GNU Gnulib

Next: setlinebuf Prev: putw Up: Glibc stdio.h Top: Top

12.69.18. setbuffer

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, mingw, MSVC 14.

Next: setlinebuf Prev: putw Up: Glibc stdio.h Top: Top


setlinebuf -- GNU Gnulib

Next: sys_errlist Prev: setbuffer Up: Glibc stdio.h Top: Top

12.69.19. setlinebuf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11.23, mingw, MSVC 14.

Next: sys_errlist Prev: setbuffer Up: Glibc stdio.h Top: Top


sys_errlist -- GNU Gnulib

Next: sys_nerr Prev: setlinebuf Up: Glibc stdio.h Top: Top

12.69.20. sys_errlist

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Minix 3.1.8, Mac OS X 10.5, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, Interix 3.5, BeOS.

Next: sys_nerr Prev: setlinebuf Up: Glibc stdio.h Top: Top


sys_nerr -- GNU Gnulib

Next: tmpnam_r Prev: sys_errlist Up: Glibc stdio.h Top: Top

12.69.21. sys_nerr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This variable is missing on some platforms: Mac OS X 10.5, Minix 3.1.8, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, Interix 3.5, BeOS.

Next: tmpnam_r Prev: sys_errlist Up: Glibc stdio.h Top: Top


tmpnam_r -- GNU Gnulib

Next: vasprintf Prev: sys_nerr Up: Glibc stdio.h Top: Top

12.69.22. tmpnam_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: vasprintf Prev: sys_nerr Up: Glibc stdio.h Top: Top


vasprintf -- GNU Gnulib

Prev: tmpnam_r Up: Glibc stdio.h Top: Top

12.69.23. vasprintf

Gnulib module: vasprintf or vasprintf-posix

Portability problems fixed by either Gnulib module vasprintf or vasprintf-posix:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5.
Portability problems fixed by Gnulib module vasprintf-posix:
  • This function does not support size specifiers as in C99 (hh, ll, j, t, z) on some platforms: Cygwin 1.5.24, BeOS.
  • printf of `long double' numbers is unsupported on some platforms: BeOS.
  • printf "%f", "%e", "%g" of Infinity and NaN yields an incorrect result on some platforms: Solaris 11.0.
  • This function does not support the `a' and `A' directives on some platforms: glibc-2.3.6, Mac OS X 10.5, NetBSD 5.0, OpenBSD 4.0, Solaris 11.3, Cygwin 1.5.x, BeOS.
  • This function does not support the `F' directive on some platforms: NetBSD 3.0, Cygwin 1.5.x, BeOS.
  • This function does not support the `ls' directive on some platforms: OpenBSD 4.0, Cygwin 1.5.x, Haiku.
  • This function does not support precisions in the `ls' directive correctly on some platforms: Solaris 11.3.
  • This function does not support format directives that access arguments in an arbitrary order, such as "%2$s", on some platforms: NetBSD 3.0, BeOS.
  • This function doesn't support the ' flag on some platforms: NetBSD 3.0, Cygwin 1.5.24.
  • This function does not round the argument of the `a' directive correctly on some platforms: Mac OS X 10.12, FreeBSD 6.1.
  • printf "%010f" of NaN and Infinity yields an incorrect result (padded with zeroes) on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Solaris 11.0, Cygwin 1.5.x.
  • This function does not support precisions larger than 512 or 1024 in integer, floating-point and pointer output on some platforms: BeOS.
  • This function can crash in out-of-memory conditions on some platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0.
Portability problems not fixed by Gnulib:

Prev: tmpnam_r Up: Glibc stdio.h Top: Top


Glibc stdlib.h -- GNU Gnulib

Next: Glibc string.h Prev: Glibc stdio.h Up: Glibc Function Substitutes Top: Top

12.70. Glibc Extensions to <stdlib.h>

Menu

  • canonicalize_file_name
  • cfree
  • clearenv
  • drand48_r
  • ecvt_r
  • erand48_r
  • fcvt_r
  • getloadavg
  • getpt
  • initstate_r
  • jrand48_r
  • lcong48_r
  • lrand48_r
  • mkostemp
  • mkostemps
  • mrand48_r
  • mkstemps
  • nrand48_r
  • on_exit
  • ptsname_r
  • qecvt
  • qecvt_r
  • qfcvt
  • qfcvt_r
  • qgcvt
  • qsort_r
  • random_r
  • rpmatch
  • secure_getenv
  • seed48_r
  • setstate_r
  • srand48_r
  • srandom_r
  • strtod_l
  • strtof_l
  • strtol_l
  • strtold_l
  • strtoll_l
  • strtoq
  • strtoul_l
  • strtoull_l
  • strtouq
  • valloc

    • Next: Glibc string.h Prev: Glibc stdio.h Up: Glibc Function Substitutes Top: Top


canonicalize_file_name -- GNU Gnulib

Next: cfree Up: Glibc stdlib.h Top: Top

12.70.1. canonicalize_file_name

Gnulib module: canonicalize-lgpl

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function fails to detect trailing slashes on non-directories on some platforms: glibc 2.3.5.
Portability problems not fixed by Gnulib:

Next: cfree Up: Glibc stdlib.h Top: Top


cfree -- GNU Gnulib

Next: clearenv Prev: canonicalize_file_name Up: Glibc stdlib.h Top: Top

12.70.2. cfree

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: clearenv Prev: canonicalize_file_name Up: Glibc stdlib.h Top: Top


clearenv -- GNU Gnulib

Next: drand48_r Prev: cfree Up: Glibc stdlib.h Top: Top

12.70.3. clearenv

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, IRIX 6.5, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: drand48_r Prev: cfree Up: Glibc stdlib.h Top: Top


drand48_r -- GNU Gnulib

Next: ecvt_r Prev: clearenv Up: Glibc stdlib.h Top: Top

12.70.4. drand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: ecvt_r Prev: clearenv Up: Glibc stdlib.h Top: Top


ecvt_r -- GNU Gnulib

Next: erand48_r Prev: drand48_r Up: Glibc stdlib.h Top: Top

12.70.5. ecvt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: erand48_r Prev: drand48_r Up: Glibc stdlib.h Top: Top


erand48_r -- GNU Gnulib

Next: fcvt_r Prev: ecvt_r Up: Glibc stdlib.h Top: Top

12.70.6. erand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: fcvt_r Prev: ecvt_r Up: Glibc stdlib.h Top: Top


fcvt_r -- GNU Gnulib

Next: getloadavg Prev: erand48_r Up: Glibc stdlib.h Top: Top

12.70.7. fcvt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: getloadavg Prev: erand48_r Up: Glibc stdlib.h Top: Top


getloadavg -- GNU Gnulib

Next: getpt Prev: fcvt_r Up: Glibc stdlib.h Top: Top

12.70.8. getloadavg

Gnulib module: getloadavg

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 2.6, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is declared in <sys/loadavg.h>, not <stdlib.h>, on some platforms: Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: getpt Prev: fcvt_r Up: Glibc stdlib.h Top: Top


getpt -- GNU Gnulib

Next: initstate_r Prev: getloadavg Up: Glibc stdlib.h Top: Top

12.70.9. getpt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: initstate_r Prev: getloadavg Up: Glibc stdlib.h Top: Top


initstate_r -- GNU Gnulib

Next: jrand48_r Prev: getpt Up: Glibc stdlib.h Top: Top

12.70.10. initstate_r

Gnulib module: random_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.
  • This function has an incompatible declaration on some platforms: AIX 7.1, OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: jrand48_r Prev: getpt Up: Glibc stdlib.h Top: Top


jrand48_r -- GNU Gnulib

Next: lcong48_r Prev: initstate_r Up: Glibc stdlib.h Top: Top

12.70.11. jrand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: lcong48_r Prev: initstate_r Up: Glibc stdlib.h Top: Top


lcong48_r -- GNU Gnulib

Next: lrand48_r Prev: jrand48_r Up: Glibc stdlib.h Top: Top

12.70.12. lcong48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: lrand48_r Prev: jrand48_r Up: Glibc stdlib.h Top: Top


lrand48_r -- GNU Gnulib

Next: mkostemp Prev: lcong48_r Up: Glibc stdlib.h Top: Top

12.70.13. lrand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: mkostemp Prev: lcong48_r Up: Glibc stdlib.h Top: Top


mkostemp -- GNU Gnulib

Next: mkostemps Prev: lrand48_r Up: Glibc stdlib.h Top: Top

12.70.14. mkostemp

Gnulib module: mkostemp

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.5, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, mkostemp may not work correctly to create files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
The gnulib module clean-temp can create temporary files that will not be left behind after signals such as SIGINT.

Next: mkostemps Prev: lrand48_r Up: Glibc stdlib.h Top: Top


mkostemps -- GNU Gnulib

Next: mrand48_r Prev: mkostemp Up: Glibc stdlib.h Top: Top

12.70.15. mkostemps

Gnulib module: mkostemps

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: glibc 2.10, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.5, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, mkostemps may not work correctly to create files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
The gnulib module clean-temp can create temporary files that will not be left behind after signals such as SIGINT.

Next: mrand48_r Prev: mkostemp Up: Glibc stdlib.h Top: Top


mrand48_r -- GNU Gnulib

Next: mkstemps Prev: mkostemps Up: Glibc stdlib.h Top: Top

12.70.16. mrand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: mkstemps Prev: mkostemps Up: Glibc stdlib.h Top: Top


mkstemps -- GNU Gnulib

Next: nrand48_r Prev: mrand48_r Up: Glibc stdlib.h Top: Top

12.70.17. mkstemps

Gnulib module: mkstemps

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: glibc 2.10, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is declared in <unistd.h> instead of <stdlib.h> on some platforms: Mac OS X 10.5.
  • On platforms where off_t is a 32-bit type, mkstemps may not work correctly to create files larger than 2 GB. (Cf. AC_SYS_LARGEFILE.)
Portability problems not fixed by Gnulib:
The gnulib module clean-temp can create temporary files that will not be left behind after signals such as SIGINT.

Next: nrand48_r Prev: mrand48_r Up: Glibc stdlib.h Top: Top


nrand48_r -- GNU Gnulib

Next: on_exit Prev: mkstemps Up: Glibc stdlib.h Top: Top

12.70.18. nrand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: on_exit Prev: mkstemps Up: Glibc stdlib.h Top: Top


on_exit -- GNU Gnulib

Next: ptsname_r Prev: nrand48_r Up: Glibc stdlib.h Top: Top

12.70.19. on_exit

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ptsname_r Prev: nrand48_r Up: Glibc stdlib.h Top: Top


ptsname_r -- GNU Gnulib

Next: qecvt Prev: on_exit Up: Glibc stdlib.h Top: Top

12.70.20. ptsname_r

Gnulib module: ptsname_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, BeOS.
  • This function is not declared unless _REENTRANT is defined, on some platforms: OSF/1 5.1.
  • This function has an incompatible declaration on some platforms: OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: qecvt Prev: on_exit Up: Glibc stdlib.h Top: Top


qecvt -- GNU Gnulib

Next: qecvt_r Prev: ptsname_r Up: Glibc stdlib.h Top: Top

12.70.21. qecvt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: qecvt_r Prev: ptsname_r Up: Glibc stdlib.h Top: Top


qecvt_r -- GNU Gnulib

Next: qfcvt Prev: qecvt Up: Glibc stdlib.h Top: Top

12.70.22. qecvt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: qfcvt Prev: qecvt Up: Glibc stdlib.h Top: Top


qfcvt -- GNU Gnulib

Next: qfcvt_r Prev: qecvt_r Up: Glibc stdlib.h Top: Top

12.70.23. qfcvt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: qfcvt_r Prev: qecvt_r Up: Glibc stdlib.h Top: Top


qfcvt_r -- GNU Gnulib

Next: qgcvt Prev: qfcvt Up: Glibc stdlib.h Top: Top

12.70.24. qfcvt_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: qgcvt Prev: qfcvt Up: Glibc stdlib.h Top: Top


qgcvt -- GNU Gnulib

Next: qsort_r Prev: qfcvt_r Up: Glibc stdlib.h Top: Top

12.70.25. qgcvt

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: qsort_r Prev: qfcvt_r Up: Glibc stdlib.h Top: Top


qsort_r -- GNU Gnulib

Next: random_r Prev: qgcvt Up: Glibc stdlib.h Top: Top

12.70.26. qsort_r

Gnulib module: ---

Portability problems fixed by Gnulib:

  • This function has an incompatible API on some platforms: FreeBSD 10.
  • This function is missing on some platforms: glibc 2.7, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: random_r Prev: qgcvt Up: Glibc stdlib.h Top: Top


random_r -- GNU Gnulib

Next: rpmatch Prev: qsort_r Up: Glibc stdlib.h Top: Top

12.70.27. random_r

Gnulib module: random_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.
  • This function has an incompatible declaration on some platforms: AIX 7.1, OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: rpmatch Prev: qsort_r Up: Glibc stdlib.h Top: Top


rpmatch -- GNU Gnulib

Next: secure_getenv Prev: random_r Up: Glibc stdlib.h Top: Top

12.70.28. rpmatch

Gnulib module: rpmatch

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: secure_getenv Prev: random_r Up: Glibc stdlib.h Top: Top


secure_getenv -- GNU Gnulib

Next: seed48_r Prev: rpmatch Up: Glibc stdlib.h Top: Top

12.70.29. secure_getenv

Gnulib module: secure_getenv

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.16, OS X 10.8, FreeBSD 9.1, NetBSD 6.0.1, OpenBSD 5.2, Minix 3.2.0, AIX 7.1, HP-UX 11, IRIX 6.5, Solaris 11, Cygwin, mingw, MSVC 14, Interix 6.1, BeOS.
Portability problems not fixed by Gnulib:

Next: seed48_r Prev: rpmatch Up: Glibc stdlib.h Top: Top


seed48_r -- GNU Gnulib

Next: setstate_r Prev: secure_getenv Up: Glibc stdlib.h Top: Top

12.70.30. seed48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: setstate_r Prev: secure_getenv Up: Glibc stdlib.h Top: Top


setstate_r -- GNU Gnulib

Next: srand48_r Prev: seed48_r Up: Glibc stdlib.h Top: Top

12.70.31. setstate_r

Gnulib module: random_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.
  • This function has an incompatible declaration on some platforms: AIX 7.1, OSF/1 5.1.
Portability problems not fixed by Gnulib:

Next: srand48_r Prev: seed48_r Up: Glibc stdlib.h Top: Top


srand48_r -- GNU Gnulib

Next: srandom_r Prev: setstate_r Up: Glibc stdlib.h Top: Top

12.70.32. srand48_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: srandom_r Prev: setstate_r Up: Glibc stdlib.h Top: Top


srandom_r -- GNU Gnulib

Next: strtod_l Prev: srand48_r Up: Glibc stdlib.h Top: Top

12.70.33. srandom_r

Gnulib module: random_r

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5.
Portability problems not fixed by Gnulib:

Next: strtod_l Prev: srand48_r Up: Glibc stdlib.h Top: Top


strtod_l -- GNU Gnulib

Next: strtof_l Prev: srandom_r Up: Glibc stdlib.h Top: Top

12.70.34. strtod_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtof_l Prev: srandom_r Up: Glibc stdlib.h Top: Top


strtof_l -- GNU Gnulib

Next: strtol_l Prev: strtod_l Up: Glibc stdlib.h Top: Top

12.70.35. strtof_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtol_l Prev: strtod_l Up: Glibc stdlib.h Top: Top


strtol_l -- GNU Gnulib

Next: strtold_l Prev: strtof_l Up: Glibc stdlib.h Top: Top

12.70.36. strtol_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtold_l Prev: strtof_l Up: Glibc stdlib.h Top: Top


strtold_l -- GNU Gnulib

Next: strtoll_l Prev: strtol_l Up: Glibc stdlib.h Top: Top

12.70.37. strtold_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtoll_l Prev: strtol_l Up: Glibc stdlib.h Top: Top


strtoll_l -- GNU Gnulib

Next: strtoq Prev: strtold_l Up: Glibc stdlib.h Top: Top

12.70.38. strtoll_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtoq Prev: strtold_l Up: Glibc stdlib.h Top: Top


strtoq -- GNU Gnulib

Next: strtoul_l Prev: strtoll_l Up: Glibc stdlib.h Top: Top

12.70.39. strtoq

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14.

Next: strtoul_l Prev: strtoll_l Up: Glibc stdlib.h Top: Top


strtoul_l -- GNU Gnulib

Next: strtoull_l Prev: strtoq Up: Glibc stdlib.h Top: Top

12.70.40. strtoul_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtoull_l Prev: strtoq Up: Glibc stdlib.h Top: Top


strtoull_l -- GNU Gnulib

Next: strtouq Prev: strtoul_l Up: Glibc stdlib.h Top: Top

12.70.41. strtoull_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strtouq Prev: strtoul_l Up: Glibc stdlib.h Top: Top


strtouq -- GNU Gnulib

Next: valloc Prev: strtoull_l Up: Glibc stdlib.h Top: Top

12.70.42. strtouq

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14.

Next: valloc Prev: strtoull_l Up: Glibc stdlib.h Top: Top


valloc -- GNU Gnulib

Prev: strtouq Up: Glibc stdlib.h Top: Top

12.70.43. valloc

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5.

Prev: strtouq Up: Glibc stdlib.h Top: Top


Glibc string.h -- GNU Gnulib

Next: Glibc sys/capability.h Prev: Glibc stdlib.h Up: Glibc Function Substitutes Top: Top

12.71. Glibc Extensions to <string.h>

Menu

  • explicit_bzero
  • ffsl
  • ffsll
  • memfrob
  • memmem
  • mempcpy
  • memrchr
  • rawmemchr
  • strcasestr
  • strchrnul
  • strfry
  • strsep
  • strverscmp

    • Next: Glibc sys/capability.h Prev: Glibc stdlib.h Up: Glibc Function Substitutes Top: Top


explicit_bzero -- GNU Gnulib

Next: ffsl Up: Glibc string.h Top: Top

12.71.1. explicit_bzero

Gnulib module: explicit_bzero

The explicit_bzero function is an approximation to what is needed, and does not suffice in general to erase information. Although calling explicit_bzero should clear the memory in question, the information that was in memory may still be available elsewhere on the machine. Proper implementation of information erasure requires support from levels below C code.

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: glibc 2.24, FreeBSD 10, NetBSD 7.1, OpenBSD 5.4, macOS 10.12, Solaris 11.3, and many other systems.
Portability problems not fixed by Gnulib:
  • Although the module's implementation should clear the memory on platforms compatible with GCC and on platforms using traditional linkers, it may not clear the memory on non-GCC platforms that use whole-program optimization.

Next: ffsl Up: Glibc string.h Top: Top


ffsl -- GNU Gnulib

Next: ffsll Prev: explicit_bzero Up: Glibc string.h Top: Top

12.71.2. ffsl

Gnulib module: ffsl

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 5.2.1, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: ffsll Prev: explicit_bzero Up: Glibc string.h Top: Top


ffsll -- GNU Gnulib

Next: memfrob Prev: ffsl Up: Glibc string.h Top: Top

12.71.3. ffsll

Gnulib module: ffsll

Portability problems fixed by Gnulib:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: memfrob Prev: ffsl Up: Glibc string.h Top: Top


memfrob -- GNU Gnulib

Next: memmem Prev: ffsll Up: Glibc string.h Top: Top

12.71.4. memfrob

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: memmem Prev: ffsll Up: Glibc string.h Top: Top


memmem -- GNU Gnulib

Next: mempcpy Prev: memfrob Up: Glibc string.h Top: Top

12.71.5. memmem

Gnulib module: memmem or memmem-simple

Both modules implement the same replacement for the memmem function with the memmem module providing a replacement on more platforms where the existing memmem function has a quadratic worst-case complexity.

Portability problems fixed by either Gnulib module memmem-simple or memmem:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 5.2.1, OpenBSD 4.0, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has reversed arguments on some older platforms: Linux libc 5.0.9
  • This function can trigger false positives for long periodic needles on some platforms: glibc 2.12, Cygwin 1.7.7.

  • This function returns incorrect values in some cases, such as when given an empty needle: glibc <= 2.0, Solaris 11.3, Cygwin 1.5.x.
Performance problems fixed by Gnulib module memmem:
  • This function has quadratic instead of linear worst-case complexity on some platforms: glibc 2.8, FreeBSD 6.2, NetBSD 5.0, AIX 5.1, Solaris 11.3, Cygwin 1.5.x. Note for small needles the replacement may be slower.
Portability problems not fixed by Gnulib:

Next: mempcpy Prev: memfrob Up: Glibc string.h Top: Top


mempcpy -- GNU Gnulib

Next: memrchr Prev: memmem Up: Glibc string.h Top: Top

12.71.6. mempcpy

Gnulib module: mempcpy

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: memrchr Prev: memmem Up: Glibc string.h Top: Top


memrchr -- GNU Gnulib

Next: rawmemchr Prev: mempcpy Up: Glibc string.h Top: Top

12.71.7. memrchr

Gnulib module: memrchr

Portability problems fixed by Gnulib:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: rawmemchr Prev: mempcpy Up: Glibc string.h Top: Top


rawmemchr -- GNU Gnulib

Next: strcasestr Prev: memrchr Up: Glibc string.h Top: Top

12.71.8. rawmemchr

Gnulib module: rawmemchr

Portability problems fixed by Gnulib:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: strcasestr Prev: memrchr Up: Glibc string.h Top: Top


strcasestr -- GNU Gnulib

Next: strchrnul Prev: rawmemchr Up: Glibc string.h Top: Top

12.71.9. strcasestr

Gnulib module: strcasestr or strcasestr-simple

Portability problems fixed by either Gnulib module strcasestr-simple or strcasestr:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.5.x, mingw, MSVC 14, BeOS.

  • This function can trigger memchr bugs on some platforms: glibc 2.10.

  • This function can trigger false positives for long periodic needles on some platforms: glibc 2.12, Cygwin 1.7.7.
Portability problems fixed by Gnulib module strcasestr:
  • This function has quadratic instead of linear worst-case complexity on some platforms: glibc 2.8, FreeBSD 6.2, NetBSD 5.0, OpenBSD 4.0, Solaris 11.3.
Portability problems not fixed by Gnulib:

Next: strchrnul Prev: rawmemchr Up: Glibc string.h Top: Top


strchrnul -- GNU Gnulib

Next: strfry Prev: strcasestr Up: Glibc string.h Top: Top

12.71.10. strchrnul

Gnulib module: strchrnul

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.7.8, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function crashes when no occurrence is found on some platforms: Cygwin 1.7.9.
Portability problems not fixed by Gnulib:

Next: strfry Prev: strcasestr Up: Glibc string.h Top: Top


strfry -- GNU Gnulib

Next: strsep Prev: strchrnul Up: Glibc string.h Top: Top

12.71.11. strfry

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: strsep Prev: strchrnul Up: Glibc string.h Top: Top


strsep -- GNU Gnulib

Next: strverscmp Prev: strfry Up: Glibc string.h Top: Top

12.71.12. strsep

Gnulib module: strsep

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, mingw, MSVC 14, BeOS.
Portability problems not fixed by Gnulib:

Next: strverscmp Prev: strfry Up: Glibc string.h Top: Top


strverscmp -- GNU Gnulib

Prev: strsep Up: Glibc string.h Top: Top

12.71.13. strverscmp

Gnulib module: strverscmp

Portability problems fixed by Gnulib:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Prev: strsep Up: Glibc string.h Top: Top


Glibc sys/capability.h -- GNU Gnulib

Next: Glibc sys/epoll.h Prev: Glibc string.h Up: Glibc Function Substitutes Top: Top

12.72. Glibc <sys/capability.h>

Menu

  • capget
  • capset


capget -- GNU Gnulib

Next: capset Up: Glibc sys/capability.h Top: Top

12.72.1. capget

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: capset Up: Glibc sys/capability.h Top: Top


capset -- GNU Gnulib

Prev: capget Up: Glibc sys/capability.h Top: Top

12.72.2. capset

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: capget Up: Glibc sys/capability.h Top: Top


Glibc sys/epoll.h -- GNU Gnulib

Next: Glibc sys/fanotify.h Prev: Glibc sys/capability.h Up: Glibc Function Substitutes Top: Top

12.73. Glibc <sys/epoll.h>

Menu

  • epoll_create
  • epoll_ctl
  • epoll_wait


epoll_create -- GNU Gnulib

Next: epoll_ctl Up: Glibc sys/epoll.h Top: Top

12.73.1. epoll_create

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: epoll_ctl Up: Glibc sys/epoll.h Top: Top


epoll_ctl -- GNU Gnulib

Next: epoll_wait Prev: epoll_create Up: Glibc sys/epoll.h Top: Top

12.73.2. epoll_ctl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: epoll_wait Prev: epoll_create Up: Glibc sys/epoll.h Top: Top


epoll_wait -- GNU Gnulib

Prev: epoll_ctl Up: Glibc sys/epoll.h Top: Top

12.73.3. epoll_wait

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: epoll_ctl Up: Glibc sys/epoll.h Top: Top


Glibc sys/fanotify.h -- GNU Gnulib

Next: Glibc sys/file.h Prev: Glibc sys/epoll.h Up: Glibc Function Substitutes Top: Top

12.74. Glibc <sys/fanotify.h>

Menu

  • fanotify_init
  • fanotify_mark


fanotify_init -- GNU Gnulib

Next: fanotify_mark Up: Glibc sys/fanotify.h Top: Top

12.74.1. fanotify_init

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.12, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fanotify_mark Up: Glibc sys/fanotify.h Top: Top


fanotify_mark -- GNU Gnulib

Prev: fanotify_init Up: Glibc sys/fanotify.h Top: Top

12.74.2. fanotify_mark

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.12, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: fanotify_init Up: Glibc sys/fanotify.h Top: Top


Glibc sys/file.h -- GNU Gnulib

Next: Glibc sys/fsuid.h Prev: Glibc sys/fanotify.h Up: Glibc Function Substitutes Top: Top

12.75. Glibc <sys/file.h>

Menu

  • flock


flock -- GNU Gnulib

Up: Glibc sys/file.h Top: Top

12.75.1. flock

Gnulib module: flock

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: mingw, MSVC 14
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11.23, Solaris 11.3, BeOS.

Up: Glibc sys/file.h Top: Top


Glibc sys/fsuid.h -- GNU Gnulib

Next: Glibc sys/gmon.h Prev: Glibc sys/file.h Up: Glibc Function Substitutes Top: Top

12.76. Glibc <sys/fsuid.h>

Menu

  • setfsgid
  • setfsuid


setfsgid -- GNU Gnulib

Next: setfsuid Up: Glibc sys/fsuid.h Top: Top

12.76.1. setfsgid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setfsuid Up: Glibc sys/fsuid.h Top: Top


setfsuid -- GNU Gnulib

Prev: setfsgid Up: Glibc sys/fsuid.h Top: Top

12.76.2. setfsuid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: setfsgid Up: Glibc sys/fsuid.h Top: Top


Glibc sys/gmon.h -- GNU Gnulib

Next: Glibc sys/io.h and sys/perm.h Prev: Glibc sys/fsuid.h Up: Glibc Function Substitutes Top: Top

12.77. Glibc <sys/gmon.h>

Menu

  • monstartup


monstartup -- GNU Gnulib

Up: Glibc sys/gmon.h Top: Top

12.77.1. monstartup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/gmon.h Top: Top


Glibc sys/io.h and sys/perm.h -- GNU Gnulib

Next: Glibc sys/kdaemon.h Prev: Glibc sys/gmon.h Up: Glibc Function Substitutes Top: Top

12.78. Glibc <sys/io.h>, <sys/perm.h>

Menu

  • ioperm
  • iopl

    • Next: Glibc sys/kdaemon.h Prev: Glibc sys/gmon.h Up: Glibc Function Substitutes Top: Top


ioperm -- GNU Gnulib

Next: iopl Up: Glibc sys/io.h and sys/perm.h Top: Top

12.78.1. ioperm

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: iopl Up: Glibc sys/io.h and sys/perm.h Top: Top


iopl -- GNU Gnulib

Prev: ioperm Up: Glibc sys/io.h and sys/perm.h Top: Top

12.78.2. iopl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ioperm Up: Glibc sys/io.h and sys/perm.h Top: Top


Glibc sys/kdaemon.h -- GNU Gnulib

Next: Glibc sys/klog.h Prev: Glibc sys/io.h and sys/perm.h Up: Glibc Function Substitutes Top: Top

12.79. Glibc <sys/kdaemon.h>

Menu

  • bdflush


bdflush -- GNU Gnulib

Up: Glibc sys/kdaemon.h Top: Top

12.79.1. bdflush

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/kdaemon.h Top: Top


Glibc sys/klog.h -- GNU Gnulib

Next: Glibc sys/mman.h Prev: Glibc sys/kdaemon.h Up: Glibc Function Substitutes Top: Top

12.80. Glibc <sys/klog.h>

Menu

  • klogctl


klogctl -- GNU Gnulib

Up: Glibc sys/klog.h Top: Top

12.80.1. klogctl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/klog.h Top: Top


Glibc sys/mman.h -- GNU Gnulib

Next: Glibc sys/mount.h Prev: Glibc sys/klog.h Up: Glibc Function Substitutes Top: Top

12.81. Glibc Extensions to <sys/mman.h>

Menu

  • madvise
  • mincore
  • mremap
  • remap_file_pages


madvise -- GNU Gnulib

Next: mincore Up: Glibc sys/mman.h Top: Top

12.81.1. madvise

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin 1.7.7, mingw, MSVC 14, BeOS.

Next: mincore Up: Glibc sys/mman.h Top: Top


mincore -- GNU Gnulib

Next: mremap Prev: madvise Up: Glibc sys/mman.h Top: Top

12.81.2. mincore

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: mremap Prev: madvise Up: Glibc sys/mman.h Top: Top


mremap -- GNU Gnulib

Next: remap_file_pages Prev: mincore Up: Glibc sys/mman.h Top: Top

12.81.3. mremap

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: remap_file_pages Prev: mincore Up: Glibc sys/mman.h Top: Top


remap_file_pages -- GNU Gnulib

Prev: mremap Up: Glibc sys/mman.h Top: Top

12.81.4. remap_file_pages

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: mremap Up: Glibc sys/mman.h Top: Top


Glibc sys/mount.h -- GNU Gnulib

Next: Glibc sys/personality.h Prev: Glibc sys/mman.h Up: Glibc Function Substitutes Top: Top

12.82. Glibc <sys/mount.h>

Menu

  • mount
  • umount
  • umount2


mount -- GNU Gnulib

Next: umount Up: Glibc sys/mount.h Top: Top

12.82.1. mount

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, Interix 3.5.

Next: umount Up: Glibc sys/mount.h Top: Top


umount -- GNU Gnulib

Next: umount2 Prev: mount Up: Glibc sys/mount.h Top: Top

12.82.2. umount

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, AIX 5.1, mingw, MSVC 14, Interix 3.5, BeOS.

Next: umount2 Prev: mount Up: Glibc sys/mount.h Top: Top


umount2 -- GNU Gnulib

Prev: umount Up: Glibc sys/mount.h Top: Top

12.82.3. umount2

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.23, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: umount Up: Glibc sys/mount.h Top: Top


Glibc sys/personality.h -- GNU Gnulib

Next: Glibc sys/prctl.h Prev: Glibc sys/mount.h Up: Glibc Function Substitutes Top: Top

12.83. Glibc <sys/personality.h>

Menu

  • personality


personality -- GNU Gnulib

Up: Glibc sys/personality.h Top: Top

12.83.1. personality

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/personality.h Top: Top


Glibc sys/prctl.h -- GNU Gnulib

Next: Glibc sys/profil.h Prev: Glibc sys/personality.h Up: Glibc Function Substitutes Top: Top

12.84. Glibc <sys/prctl.h>

Menu

  • prctl


prctl -- GNU Gnulib

Up: Glibc sys/prctl.h Top: Top

12.84.1. prctl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/prctl.h Top: Top


Glibc sys/profil.h -- GNU Gnulib

Next: Glibc sys/ptrace.h Prev: Glibc sys/prctl.h Up: Glibc Function Substitutes Top: Top

12.85. Glibc <sys/profil.h>

Menu

  • sprofil


sprofil -- GNU Gnulib

Up: Glibc sys/profil.h Top: Top

12.85.1. sprofil

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.11, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/profil.h Top: Top


Glibc sys/ptrace.h -- GNU Gnulib

Next: Glibc sys/quota.h Prev: Glibc sys/profil.h Up: Glibc Function Substitutes Top: Top

12.86. Glibc <sys/ptrace.h>

Menu

  • ptrace


ptrace -- GNU Gnulib

Up: Glibc sys/ptrace.h Top: Top

12.86.1. ptrace

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/ptrace.h Top: Top


Glibc sys/quota.h -- GNU Gnulib

Next: Glibc sys/reboot.h Prev: Glibc sys/ptrace.h Up: Glibc Function Substitutes Top: Top

12.87. Glibc <sys/quota.h>

Menu

  • quotactl


quotactl -- GNU Gnulib

Up: Glibc sys/quota.h Top: Top

12.87.1. quotactl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/quota.h Top: Top


Glibc sys/reboot.h -- GNU Gnulib

Next: Glibc sys/resource.h Prev: Glibc sys/quota.h Up: Glibc Function Substitutes Top: Top

12.88. Glibc <sys/reboot.h>

Menu

  • reboot


reboot -- GNU Gnulib

Up: Glibc sys/reboot.h Top: Top

12.88.1. reboot

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/reboot.h Top: Top


Glibc sys/resource.h -- GNU Gnulib

Next: Glibc sys/sem.h Prev: Glibc sys/reboot.h Up: Glibc Function Substitutes Top: Top

12.89. Glibc Extensions to <sys/resource.h>

Menu

  • prlimit


prlimit -- GNU Gnulib

Up: Glibc sys/resource.h Top: Top

12.89.1. prlimit

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.12, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/resource.h Top: Top


Glibc sys/sem.h -- GNU Gnulib

Next: Glibc sys/sendfile.h Prev: Glibc sys/resource.h Up: Glibc Function Substitutes Top: Top

12.90. Glibc Extensions to <sys/sem.h>

Menu

  • semtimedop


semtimedop -- GNU Gnulib

Up: Glibc sys/sem.h Top: Top

12.90.1. semtimedop

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11.11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/sem.h Top: Top


Glibc sys/sendfile.h -- GNU Gnulib

Next: Glibc sys/socket.h Prev: Glibc sys/sem.h Up: Glibc Function Substitutes Top: Top

12.91. Glibc <sys/sendfile.h>

Menu

  • sendfile


sendfile -- GNU Gnulib

Up: Glibc sys/sendfile.h Top: Top

12.91.1. sendfile

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 4.0, Solaris 11 2010-11, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Up: Glibc sys/sendfile.h Top: Top


Glibc sys/socket.h -- GNU Gnulib

Next: Glibc sys/stat.h Prev: Glibc sys/sendfile.h Up: Glibc Function Substitutes Top: Top

12.92. Glibc Extensions to <sys/socket.h>

Menu

  • accept4
  • isfdtype
  • recvmmsg
  • sendmmsg


accept4 -- GNU Gnulib

Next: isfdtype Up: Glibc sys/socket.h Top: Top

12.92.1. accept4

Gnulib module: accept4

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not atomic; this matters in multi-threaded programs that spawn child processes.
Portability problems not fixed by Gnulib:
  • SOCK_CLOEXEC and SOCK_NONBLOCK may not be defined as they're also significant to the socket() function.

Next: isfdtype Up: Glibc sys/socket.h Top: Top


isfdtype -- GNU Gnulib

Next: recvmmsg Prev: accept4 Up: Glibc sys/socket.h Top: Top

12.92.2. isfdtype

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 4.0, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: recvmmsg Prev: accept4 Up: Glibc sys/socket.h Top: Top


recvmmsg -- GNU Gnulib

Next: sendmmsg Prev: isfdtype Up: Glibc sys/socket.h Top: Top

12.92.3. recvmmsg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sendmmsg Prev: isfdtype Up: Glibc sys/socket.h Top: Top


sendmmsg -- GNU Gnulib

Prev: recvmmsg Up: Glibc sys/socket.h Top: Top

12.92.4. sendmmsg

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: recvmmsg Up: Glibc sys/socket.h Top: Top


Glibc sys/stat.h -- GNU Gnulib

Next: Glibc sys/statfs.h Prev: Glibc sys/socket.h Up: Glibc Function Substitutes Top: Top

12.93. Glibc Extensions to <sys/stat.h>

Menu

  • lchmod


lchmod -- GNU Gnulib

Up: Glibc sys/stat.h Top: Top

12.93.1. lchmod

Gnulib module: lchmod

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Up: Glibc sys/stat.h Top: Top


Glibc sys/statfs.h -- GNU Gnulib

Next: Glibc sys/swap.h Prev: Glibc sys/stat.h Up: Glibc Function Substitutes Top: Top

12.94. Glibc <sys/statfs.h>

Menu

  • fstatfs
  • statfs


fstatfs -- GNU Gnulib

Next: statfs Up: Glibc sys/statfs.h Top: Top

12.94.1. fstatfs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where f_blocks in `struct statfs' is a 32-bit value, this function may not work correctly on files systems larger than 4 TiB. The fix is to use the AC_SYS_LARGEFILE macro. This affects Mac OS X.

Next: statfs Up: Glibc sys/statfs.h Top: Top


statfs -- GNU Gnulib

Prev: fstatfs Up: Glibc sys/statfs.h Top: Top

12.94.2. statfs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where f_blocks in `struct statfs' is a 32-bit value, this function may not work correctly on files systems larger than 4 TiB. The fix is to use the AC_SYS_LARGEFILE macro. This affects Mac OS X.

Prev: fstatfs Up: Glibc sys/statfs.h Top: Top


Glibc sys/swap.h -- GNU Gnulib

Next: Glibc sys/sysctl.h Prev: Glibc sys/statfs.h Up: Glibc Function Substitutes Top: Top

12.95. Glibc <sys/swap.h>

Menu

  • swapoff
  • swapon


swapoff -- GNU Gnulib

Next: swapon Up: Glibc sys/swap.h Top: Top

12.95.1. swapoff

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: swapon Up: Glibc sys/swap.h Top: Top


swapon -- GNU Gnulib

Prev: swapoff Up: Glibc sys/swap.h Top: Top

12.95.2. swapon

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: OpenBSD 3.8, Minix 3.1.8, AIX 5.1, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: swapoff Up: Glibc sys/swap.h Top: Top


Glibc sys/sysctl.h -- GNU Gnulib

Next: Glibc sys/sysinfo.h Prev: Glibc sys/swap.h Up: Glibc Function Substitutes Top: Top

12.96. Glibc <sys/sysctl.h>

Menu

  • sysctl


sysctl -- GNU Gnulib

Up: Glibc sys/sysctl.h Top: Top

12.96.1. sysctl

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 5.3, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/sysctl.h Top: Top


Glibc sys/sysinfo.h -- GNU Gnulib

Next: Glibc sys/syslog.h Prev: Glibc sys/sysctl.h Up: Glibc Function Substitutes Top: Top

12.97. Glibc <sys/sysinfo.h>

Menu

  • get_avphys_pages
  • get_nprocs
  • get_nprocs_conf
  • get_phys_pages
  • sysinfo


get_avphys_pages -- GNU Gnulib

Next: get_nprocs Up: Glibc sys/sysinfo.h Top: Top

12.97.1. get_avphys_pages

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.

Next: get_nprocs Up: Glibc sys/sysinfo.h Top: Top


get_nprocs -- GNU Gnulib

Next: get_nprocs_conf Prev: get_avphys_pages Up: Glibc sys/sysinfo.h Top: Top

12.97.2. get_nprocs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.
Gnulib provides the module nproc that performs a similar function but is portable to more systems.

Next: get_nprocs_conf Prev: get_avphys_pages Up: Glibc sys/sysinfo.h Top: Top


get_nprocs_conf -- GNU Gnulib

Next: get_phys_pages Prev: get_nprocs Up: Glibc sys/sysinfo.h Top: Top

12.97.3. get_nprocs_conf

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 10, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.

Next: get_phys_pages Prev: get_nprocs Up: Glibc sys/sysinfo.h Top: Top


get_phys_pages -- GNU Gnulib

Next: sysinfo Prev: get_nprocs_conf Up: Glibc sys/sysinfo.h Top: Top

12.97.4. get_phys_pages

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sysinfo Prev: get_nprocs_conf Up: Glibc sys/sysinfo.h Top: Top


sysinfo -- GNU Gnulib

Prev: get_phys_pages Up: Glibc sys/sysinfo.h Top: Top

12.97.5. sysinfo

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: get_phys_pages Up: Glibc sys/sysinfo.h Top: Top


Glibc sys/syslog.h -- GNU Gnulib

Next: Glibc sys/sysmacros.h Prev: Glibc sys/sysinfo.h Up: Glibc Function Substitutes Top: Top

12.98. Glibc <sys/syslog.h>

Menu

  • vsyslog


vsyslog -- GNU Gnulib

Up: Glibc sys/syslog.h Top: Top

12.98.1. vsyslog

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, mingw, MSVC 14, BeOS.

Up: Glibc sys/syslog.h Top: Top


Glibc sys/sysmacros.h -- GNU Gnulib

Next: Glibc sys/time.h Prev: Glibc sys/syslog.h Up: Glibc Function Substitutes Top: Top

12.99. Glibc <sys/sysmacros.h>

Menu

  • gnu_dev_major
  • gnu_dev_makedev
  • gnu_dev_minor


gnu_dev_major -- GNU Gnulib

Next: gnu_dev_makedev Up: Glibc sys/sysmacros.h Top: Top

12.99.1. gnu_dev_major

Gnulib module: ---

Portability problems fixed by Gnulib:

  • The AC_HEADER_MAJOR macro in Autoconf 2.69 and earlier fails to set MAJOR_IN_SYSMACROS when it detects namespace pollution in sys/types.h; which in turn provokes deprecation warnings in glibc 2.25.
Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gnu_dev_makedev Up: Glibc sys/sysmacros.h Top: Top


gnu_dev_makedev -- GNU Gnulib

Next: gnu_dev_minor Prev: gnu_dev_major Up: Glibc sys/sysmacros.h Top: Top

12.99.2. gnu_dev_makedev

Gnulib module: ---

Portability problems fixed by Gnulib:

  • The AC_HEADER_MAJOR macro in Autoconf 2.69 and earlier fails to set MAJOR_IN_SYSMACROS when it detects namespace pollution in sys/types.h; which in turn provokes deprecation warnings in glibc 2.25.
Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: gnu_dev_minor Prev: gnu_dev_major Up: Glibc sys/sysmacros.h Top: Top


gnu_dev_minor -- GNU Gnulib

Prev: gnu_dev_makedev Up: Glibc sys/sysmacros.h Top: Top

12.99.3. gnu_dev_minor

Gnulib module: ---

Portability problems fixed by Gnulib:

  • The AC_HEADER_MAJOR macro in Autoconf 2.69 and earlier fails to set MAJOR_IN_SYSMACROS when it detects namespace pollution in sys/types.h; which in turn provokes deprecation warnings in glibc 2.25.
Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: gnu_dev_makedev Up: Glibc sys/sysmacros.h Top: Top


Glibc sys/time.h -- GNU Gnulib

Next: Glibc sys/timex.h Prev: Glibc sys/sysmacros.h Up: Glibc Function Substitutes Top: Top

12.100. Glibc Extensions to <sys/time.h>

Menu

  • adjtime
  • futimes
  • futimesat
  • lutimes
  • settimeofday


adjtime -- GNU Gnulib

Next: futimes Up: Glibc sys/time.h Top: Top

12.100.1. adjtime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: futimes Up: Glibc sys/time.h Top: Top


futimes -- GNU Gnulib

Next: futimesat Prev: adjtime Up: Glibc sys/time.h Top: Top

12.100.2. futimes

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function cannot set full timestamp resolution. Use futimens(fd,times) instead.

Next: futimesat Prev: adjtime Up: Glibc sys/time.h Top: Top


futimesat -- GNU Gnulib

Next: lutimes Prev: futimes Up: Glibc sys/time.h Top: Top

12.100.3. futimesat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.3.6, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 8, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • On some platforms, this function mis-handles trailing slash: Solaris 9.
  • This function cannot set full timestamp resolution. Use file ? utimensat(fd,file,times,0) : futimens(fd,times), or the gnulib module fdutimensat, instead.

Next: lutimes Prev: futimes Up: Glibc sys/time.h Top: Top


lutimes -- GNU Gnulib

Next: settimeofday Prev: futimesat Up: Glibc sys/time.h Top: Top

12.100.4. lutimes

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function cannot set full timestamp resolution. Use utimensat(AT_FDCWD,file,times,AT_SYMLINK_NOFOLLOW), or the gnulib module utimens, instead.
  • The mere act of using lstat modifies the access time of symlinks on some platforms, so lutimes can only effectively change modification time: Cygwin.

Next: settimeofday Prev: futimesat Up: Glibc sys/time.h Top: Top


settimeofday -- GNU Gnulib

Prev: lutimes Up: Glibc sys/time.h Top: Top

12.100.5. settimeofday

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Prev: lutimes Up: Glibc sys/time.h Top: Top


Glibc sys/timex.h -- GNU Gnulib

Next: Glibc sys/uio.h Prev: Glibc sys/time.h Up: Glibc Function Substitutes Top: Top

12.101. Glibc <sys/timex.h>

Menu

  • adjtimex
  • ntp_adjtime
  • ntp_gettime
  • ntp_gettimex


adjtimex -- GNU Gnulib

Next: ntp_adjtime Up: Glibc sys/timex.h Top: Top

12.101.1. adjtimex

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ntp_adjtime Up: Glibc sys/timex.h Top: Top


ntp_adjtime -- GNU Gnulib

Next: ntp_gettime Prev: adjtimex Up: Glibc sys/timex.h Top: Top

12.101.2. ntp_adjtime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ntp_gettime Prev: adjtimex Up: Glibc sys/timex.h Top: Top


ntp_gettime -- GNU Gnulib

Next: ntp_gettimex Prev: ntp_adjtime Up: Glibc sys/timex.h Top: Top

12.101.3. ntp_gettime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: ntp_gettimex Prev: ntp_adjtime Up: Glibc sys/timex.h Top: Top


ntp_gettimex -- GNU Gnulib

Prev: ntp_gettime Up: Glibc sys/timex.h Top: Top

12.101.4. ntp_gettimex

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.11, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ntp_gettime Up: Glibc sys/timex.h Top: Top


Glibc sys/uio.h -- GNU Gnulib

Next: Glibc sys/ustat.h Prev: Glibc sys/timex.h Up: Glibc Function Substitutes Top: Top

12.102. Glibc Extensions to <sys/uio.h>

Menu

  • preadv
  • process_vm_readv
  • process_vm_writev
  • pwritev


preadv -- GNU Gnulib

Next: process_vm_readv Up: Glibc sys/uio.h Top: Top

12.102.1. preadv

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 5.2.1, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Next: process_vm_readv Up: Glibc sys/uio.h Top: Top


process_vm_readv -- GNU Gnulib

Next: process_vm_writev Prev: preadv Up: Glibc sys/uio.h Top: Top

12.102.2. process_vm_readv

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.14, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: process_vm_writev Prev: preadv Up: Glibc sys/uio.h Top: Top


process_vm_writev -- GNU Gnulib

Next: pwritev Prev: process_vm_readv Up: Glibc sys/uio.h Top: Top

12.102.3. process_vm_writev

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.14, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pwritev Prev: process_vm_readv Up: Glibc sys/uio.h Top: Top


pwritev -- GNU Gnulib

Prev: process_vm_writev Up: Glibc sys/uio.h Top: Top

12.102.4. pwritev

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: glibc 2.9, Mac OS X 10.5, FreeBSD 5.2.1, Minix 3.1.8, AIX 5.2, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On platforms where off_t is a 32-bit type, this function may not work correctly on files larger than 2 GB. The fix is to use the AC_SYS_LARGEFILE macro.

Prev: process_vm_writev Up: Glibc sys/uio.h Top: Top


Glibc sys/ustat.h -- GNU Gnulib

Next: Glibc sys/vlimit.h Prev: Glibc sys/uio.h Up: Glibc Function Substitutes Top: Top

12.103. Glibc <sys/ustat.h>

Menu

  • ustat


ustat -- GNU Gnulib

Up: Glibc sys/ustat.h Top: Top

12.103.1. ustat

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/ustat.h Top: Top


Glibc sys/vlimit.h -- GNU Gnulib

Next: Glibc sys/vm86.h Prev: Glibc sys/ustat.h Up: Glibc Function Substitutes Top: Top

12.104. Glibc <sys/vlimit.h>

Menu

  • vlimit


vlimit -- GNU Gnulib

Up: Glibc sys/vlimit.h Top: Top

12.104.1. vlimit

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/vlimit.h Top: Top


Glibc sys/vm86.h -- GNU Gnulib

Next: Glibc sys/vtimes.h Prev: Glibc sys/vlimit.h Up: Glibc Function Substitutes Top: Top

12.105. Glibc <sys/vm86.h>

Menu

  • vm86


vm86 -- GNU Gnulib

Up: Glibc sys/vm86.h Top: Top

12.105.1. vm86

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/vm86.h Top: Top


Glibc sys/vtimes.h -- GNU Gnulib

Next: Glibc sys/wait.h Prev: Glibc sys/vm86.h Up: Glibc Function Substitutes Top: Top

12.106. Glibc <sys/vtimes.h>

Menu

  • vtimes


vtimes -- GNU Gnulib

Up: Glibc sys/vtimes.h Top: Top

12.106.1. vtimes

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Up: Glibc sys/vtimes.h Top: Top


Glibc sys/wait.h -- GNU Gnulib

Next: Glibc sys/xattr.h Prev: Glibc sys/vtimes.h Up: Glibc Function Substitutes Top: Top

12.107. Glibc Extensions to <sys/wait.h>

Menu

  • wait3
  • wait4


wait3 -- GNU Gnulib

Next: wait4 Up: Glibc sys/wait.h Top: Top

12.107.1. wait3

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: wait4 Up: Glibc sys/wait.h Top: Top


wait4 -- GNU Gnulib

Prev: wait3 Up: Glibc sys/wait.h Top: Top

12.107.2. wait4

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, HP-UX 11.11, IRIX 6.5, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: wait3 Up: Glibc sys/wait.h Top: Top


Glibc sys/xattr.h -- GNU Gnulib

Next: Glibc termios.h Prev: Glibc sys/wait.h Up: Glibc Function Substitutes Top: Top

12.108. Glibc <sys/xattr.h>

Menu

  • fgetxattr
  • flistxattr
  • fremovexattr
  • fsetxattr
  • getxattr
  • lgetxattr
  • listxattr
  • llistxattr
  • lremovexattr
  • lsetxattr
  • removexattr
  • setxattr

    • Next: Glibc termios.h Prev: Glibc sys/wait.h Up: Glibc Function Substitutes Top: Top


fgetxattr -- GNU Gnulib

Next: flistxattr Up: Glibc sys/xattr.h Top: Top

12.108.1. fgetxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has extra offset and options parameters: Mac OS X 10.4

Next: flistxattr Up: Glibc sys/xattr.h Top: Top


flistxattr -- GNU Gnulib

Next: fremovexattr Prev: fgetxattr Up: Glibc sys/xattr.h Top: Top

12.108.2. flistxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fremovexattr Prev: fgetxattr Up: Glibc sys/xattr.h Top: Top


fremovexattr -- GNU Gnulib

Next: fsetxattr Prev: flistxattr Up: Glibc sys/xattr.h Top: Top

12.108.3. fremovexattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: fsetxattr Prev: flistxattr Up: Glibc sys/xattr.h Top: Top


fsetxattr -- GNU Gnulib

Next: getxattr Prev: fremovexattr Up: Glibc sys/xattr.h Top: Top

12.108.4. fsetxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getxattr Prev: fremovexattr Up: Glibc sys/xattr.h Top: Top


getxattr -- GNU Gnulib

Next: lgetxattr Prev: fsetxattr Up: Glibc sys/xattr.h Top: Top

12.108.5. getxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function has extra offset and options parameters: Mac OS X 10.4

Next: lgetxattr Prev: fsetxattr Up: Glibc sys/xattr.h Top: Top


lgetxattr -- GNU Gnulib

Next: listxattr Prev: getxattr Up: Glibc sys/xattr.h Top: Top

12.108.6. lgetxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: listxattr Prev: getxattr Up: Glibc sys/xattr.h Top: Top


listxattr -- GNU Gnulib

Next: llistxattr Prev: lgetxattr Up: Glibc sys/xattr.h Top: Top

12.108.7. listxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: llistxattr Prev: lgetxattr Up: Glibc sys/xattr.h Top: Top


llistxattr -- GNU Gnulib

Next: lremovexattr Prev: listxattr Up: Glibc sys/xattr.h Top: Top

12.108.8. llistxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: lremovexattr Prev: listxattr Up: Glibc sys/xattr.h Top: Top


lremovexattr -- GNU Gnulib

Next: lsetxattr Prev: llistxattr Up: Glibc sys/xattr.h Top: Top

12.108.9. lremovexattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: lsetxattr Prev: llistxattr Up: Glibc sys/xattr.h Top: Top


lsetxattr -- GNU Gnulib

Next: removexattr Prev: lremovexattr Up: Glibc sys/xattr.h Top: Top

12.108.10. lsetxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: removexattr Prev: lremovexattr Up: Glibc sys/xattr.h Top: Top


removexattr -- GNU Gnulib

Next: setxattr Prev: lsetxattr Up: Glibc sys/xattr.h Top: Top

12.108.11. removexattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setxattr Prev: lsetxattr Up: Glibc sys/xattr.h Top: Top


setxattr -- GNU Gnulib

Prev: removexattr Up: Glibc sys/xattr.h Top: Top

12.108.12. setxattr

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: removexattr Up: Glibc sys/xattr.h Top: Top


Glibc termios.h -- GNU Gnulib

Next: Glibc time.h Prev: Glibc sys/xattr.h Up: Glibc Function Substitutes Top: Top

12.109. Glibc Extensions to <termios.h>

Menu

  • cfmakeraw
  • cfsetspeed


cfmakeraw -- GNU Gnulib

Next: cfsetspeed Up: Glibc termios.h Top: Top

12.109.1. cfmakeraw

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: cfsetspeed Up: Glibc termios.h Top: Top


cfsetspeed -- GNU Gnulib

Prev: cfmakeraw Up: Glibc termios.h Top: Top

12.109.2. cfsetspeed

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: cfmakeraw Up: Glibc termios.h Top: Top


Glibc time.h -- GNU Gnulib

Next: Glibc ttyent.h Prev: Glibc termios.h Up: Glibc Function Substitutes Top: Top

12.110. Glibc Extensions to <time.h>

Menu

  • clock_adjtime
  • dysize
  • getdate_r
  • stime
  • strptime_l
  • timegm
  • timelocal
  • timespec_get

    • Next: Glibc ttyent.h Prev: Glibc termios.h Up: Glibc Function Substitutes Top: Top


clock_adjtime -- GNU Gnulib

Next: dysize Up: Glibc time.h Top: Top

12.110.1. clock_adjtime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: dysize Up: Glibc time.h Top: Top


dysize -- GNU Gnulib

Next: getdate_r Prev: clock_adjtime Up: Glibc time.h Top: Top

12.110.2. dysize

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getdate_r Prev: clock_adjtime Up: Glibc time.h Top: Top


getdate_r -- GNU Gnulib

Next: stime Prev: dysize Up: Glibc time.h Top: Top

12.110.3. getdate_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: stime Prev: dysize Up: Glibc time.h Top: Top


stime -- GNU Gnulib

Next: strptime_l Prev: getdate_r Up: Glibc time.h Top: Top

12.110.4. stime

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Cygwin, mingw, MSVC 14, Interix 3.5.

Next: strptime_l Prev: getdate_r Up: Glibc time.h Top: Top


strptime_l -- GNU Gnulib

Next: timegm Prev: stime Up: Glibc time.h Top: Top

12.110.5. strptime_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: timegm Prev: stime Up: Glibc time.h Top: Top


timegm -- GNU Gnulib

Next: timelocal Prev: strptime_l Up: Glibc time.h Top: Top

12.110.6. timegm

Gnulib module: timegm

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: timelocal Prev: strptime_l Up: Glibc time.h Top: Top


timelocal -- GNU Gnulib

Next: timespec_get Prev: timegm Up: Glibc time.h Top: Top

12.110.7. timelocal

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, mingw, MSVC 14, Interix 3.5.

Next: timespec_get Prev: timegm Up: Glibc time.h Top: Top


timespec_get -- GNU Gnulib

Prev: timelocal Up: Glibc time.h Top: Top

12.110.8. timespec_get

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.15, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: timelocal Up: Glibc time.h Top: Top


Glibc ttyent.h -- GNU Gnulib

Next: Glibc unistd.h Prev: Glibc time.h Up: Glibc Function Substitutes Top: Top

12.111. Glibc <ttyent.h>

Menu

  • endttyent
  • getttyent
  • getttynam
  • setttyent


endttyent -- GNU Gnulib

Next: getttyent Up: Glibc ttyent.h Top: Top

12.111.1. endttyent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getttyent Up: Glibc ttyent.h Top: Top


getttyent -- GNU Gnulib

Next: getttynam Prev: endttyent Up: Glibc ttyent.h Top: Top

12.111.2. getttyent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getttynam Prev: endttyent Up: Glibc ttyent.h Top: Top


getttynam -- GNU Gnulib

Next: setttyent Prev: getttyent Up: Glibc ttyent.h Top: Top

12.111.3. getttynam

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setttyent Prev: getttyent Up: Glibc ttyent.h Top: Top


setttyent -- GNU Gnulib

Prev: getttynam Up: Glibc ttyent.h Top: Top

12.111.4. setttyent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: getttynam Up: Glibc ttyent.h Top: Top


Glibc unistd.h -- GNU Gnulib

Next: Glibc utmp.h Prev: Glibc ttyent.h Up: Glibc Function Substitutes Top: Top

12.112. Glibc Extensions to <unistd.h>

Menu

  • acct
  • brk
  • chroot
  • daemon
  • dup3
  • endusershell
  • euidaccess
  • execvpe
  • get_current_dir_name
  • getdomainname
  • getdtablesize
  • getpagesize
  • getpass
  • getresgid
  • getresuid
  • getusershell
  • group_member
  • pipe2
  • profil
  • revoke
  • sbrk
  • setlogin
  • setdomainname
  • sethostid
  • sethostname
  • setresgid
  • setresuid
  • setusershell
  • syncfs
  • syscall
  • ttyslot
  • vhangup

    • Next: Glibc utmp.h Prev: Glibc ttyent.h Up: Glibc Function Substitutes Top: Top


acct -- GNU Gnulib

Next: brk Up: Glibc unistd.h Top: Top

12.112.1. acct

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: brk Up: Glibc unistd.h Top: Top


brk -- GNU Gnulib

Next: chroot Prev: acct Up: Glibc unistd.h Top: Top

12.112.2. brk

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, Cygwin, mingw, MSVC 14.

Next: chroot Prev: acct Up: Glibc unistd.h Top: Top


chroot -- GNU Gnulib

Next: daemon Prev: brk Up: Glibc unistd.h Top: Top

12.112.3. chroot

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, mingw, MSVC 14, BeOS.

Next: daemon Prev: brk Up: Glibc unistd.h Top: Top


daemon -- GNU Gnulib

Next: dup3 Prev: chroot Up: Glibc unistd.h Top: Top

12.112.4. daemon

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, mingw, MSVC 14, BeOS.

Next: dup3 Prev: chroot Up: Glibc unistd.h Top: Top


dup3 -- GNU Gnulib

Next: endusershell Prev: daemon Up: Glibc unistd.h Top: Top

12.112.5. dup3

Gnulib module: dup3

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS.

  • This function can crash on some platforms: Cygwin 1.7.25.
Portability problems not fixed by Gnulib:

Next: endusershell Prev: daemon Up: Glibc unistd.h Top: Top


endusershell -- GNU Gnulib

Next: euidaccess Prev: dup3 Up: Glibc unistd.h Top: Top

12.112.6. endusershell

Gnulib module: getusershell

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is missing a declaration on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:

Next: euidaccess Prev: dup3 Up: Glibc unistd.h Top: Top


euidaccess -- GNU Gnulib

Next: execvpe Prev: endusershell Up: Glibc unistd.h Top: Top

12.112.7. euidaccess

Gnulib module: euidaccess

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:
Other problems of this function:
  • There is an inherent race between calling this function and performing some action based on the results; you should think twice before trusting this function, especially in a set-uid or set-gid program.
  • This function does not have an option for not following symbolic links (like stat versus lstat). If you need this option, use the Gnulib module faccessat with the AT_EACCESS flag.

Next: execvpe Prev: endusershell Up: Glibc unistd.h Top: Top


execvpe -- GNU Gnulib

Next: get_current_dir_name Prev: euidaccess Up: Glibc unistd.h Top: Top

12.112.8. execvpe

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: glibc 2.10, Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.5.x, mingw, Interix 3.5, BeOS.

Next: get_current_dir_name Prev: euidaccess Up: Glibc unistd.h Top: Top


get_current_dir_name -- GNU Gnulib

Next: getdomainname Prev: execvpe Up: Glibc unistd.h Top: Top

12.112.9. get_current_dir_name

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.9, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getdomainname Prev: execvpe Up: Glibc unistd.h Top: Top


getdomainname -- GNU Gnulib

Next: getdtablesize Prev: get_current_dir_name Up: Glibc unistd.h Top: Top

12.112.10. getdomainname

Gnulib module: getdomainname

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is declared in netdb.h, not in unistd.h, on some platforms: AIX 7.1.
  • This function is declared in netdb.h and in sys/socket.h, not in unistd.h, on some platforms: OSF/1 5.1.
  • The second argument is of type int, not size_t, on some platforms: Mac OS X 10.5, FreeBSD 6.4, AIX 7.1, IRIX 6.5.
Portability problems not fixed by Gnulib:

Next: getdtablesize Prev: get_current_dir_name Up: Glibc unistd.h Top: Top


getdtablesize -- GNU Gnulib

Next: getpagesize Prev: getdomainname Up: Glibc unistd.h Top: Top

12.112.11. getdtablesize

SUSv2 specification: http://pubs.opengroup.org/onlinepubs/7908799/xsh/getdtablesize.html

Gnulib module: getdtablesize

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Android LP64, mingw, MSVC 14.

  • This function is not declared on some platforms: Android LP32.

  • This function does not represent the true RLIMIT_NOFILE soft limit on some platforms: Android LP32, Cygwin 1.7.25.
Portability problems not fixed by Gnulib:
  • On OpenVMS, this function returns the maximum number of open file descriptors in a process. The possible values of file descriptors are not constrained by this function.

Next: getpagesize Prev: getdomainname Up: Glibc unistd.h Top: Top


getpagesize -- GNU Gnulib

Next: getpass Prev: getdtablesize Up: Glibc unistd.h Top: Top

12.112.12. getpagesize

Gnulib module: getpagesize

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: MSVC 14, BeOS.
  • This function is broken on some platforms: mingw.
Portability problems not fixed by Gnulib:

Next: getpass Prev: getdtablesize Up: Glibc unistd.h Top: Top


getpass -- GNU Gnulib

Next: getresgid Prev: getpagesize Up: Glibc unistd.h Top: Top

12.112.13. getpass

Gnulib module: getpass or getpass-gnu

Portability problems fixed by either Gnulib module getpass or getpass-gnu:

  • This function is missing on some platforms: mingw, MSVC 14, BeOS.
Portability problems fixed by Gnulib module getpass-gnu:
  • The returned password is truncated to PASS_MAX characters on some platforms: Mac OS X 10.5 (128), FreeBSD 6.2 (128), NetBSD 3.0 (128), OpenBSD 4.0 (128), AIX 5.1 (32), HP-UX 11 (8), IRIX 6.5 (32), OSF/1 5.1 (80), Solaris 11 2010-11 (8, even less than PASS_MAX), Cygwin (128). The gnulib implementation returns the password untruncated.
Portability problems not fixed by Gnulib:

Next: getresgid Prev: getpagesize Up: Glibc unistd.h Top: Top


getresgid -- GNU Gnulib

Next: getresuid Prev: getpass Up: Glibc unistd.h Top: Top

12.112.14. getresgid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11.00, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getresuid Prev: getpass Up: Glibc unistd.h Top: Top


getresuid -- GNU Gnulib

Next: getusershell Prev: getresgid Up: Glibc unistd.h Top: Top

12.112.15. getresuid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, AIX 5.1, HP-UX 11.00, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getusershell Prev: getresgid Up: Glibc unistd.h Top: Top


getusershell -- GNU Gnulib

Next: group_member Prev: getresuid Up: Glibc unistd.h Top: Top

12.112.16. getusershell

Gnulib module: getusershell

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is missing a declaration on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:

Next: group_member Prev: getresuid Up: Glibc unistd.h Top: Top


group_member -- GNU Gnulib

Next: pipe2 Prev: getusershell Up: Glibc unistd.h Top: Top

12.112.17. group_member

Gnulib module: group-member

Portability problems fixed by Gnulib:

  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
Portability problems not fixed by Gnulib:

Next: pipe2 Prev: getusershell Up: Glibc unistd.h Top: Top


pipe2 -- GNU Gnulib

Next: profil Prev: group_member Up: Glibc unistd.h Top: Top

12.112.18. pipe2

Gnulib module: pipe2

Portability problems fixed by Gnulib:

  • This function is missing on many non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin 1.7.1, mingw, MSVC 14, Interix 3.5, BeOS. But the replacement function is not atomic; this matters in multi-threaded programs that spawn child processes.
Portability problems not fixed by Gnulib:
  • This function crashes rather than failing with EMFILE if no resources are left on some platforms: Cygwin 1.7.9.
Note: This function portably supports the O_NONBLOCK flag only if the gnulib module nonblocking is also used.

Next: profil Prev: group_member Up: Glibc unistd.h Top: Top


profil -- GNU Gnulib

Next: revoke Prev: pipe2 Up: Glibc unistd.h Top: Top

12.112.19. profil

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: revoke Prev: pipe2 Up: Glibc unistd.h Top: Top


revoke -- GNU Gnulib

Next: sbrk Prev: profil Up: Glibc unistd.h Top: Top

12.112.20. revoke

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sbrk Prev: profil Up: Glibc unistd.h Top: Top


sbrk -- GNU Gnulib

Next: setlogin Prev: revoke Up: Glibc unistd.h Top: Top

12.112.21. sbrk

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: AIX 5.1, mingw, MSVC 14.

Next: setlogin Prev: revoke Up: Glibc unistd.h Top: Top


setlogin -- GNU Gnulib

Next: setdomainname Prev: sbrk Up: Glibc unistd.h Top: Top

12.112.22. setlogin

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setdomainname Prev: sbrk Up: Glibc unistd.h Top: Top


setdomainname -- GNU Gnulib

Next: sethostid Prev: setlogin Up: Glibc unistd.h Top: Top

12.112.23. setdomainname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sethostid Prev: setlogin Up: Glibc unistd.h Top: Top


sethostid -- GNU Gnulib

Next: sethostname Prev: setdomainname Up: Glibc unistd.h Top: Top

12.112.24. sethostid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: sethostname Prev: setdomainname Up: Glibc unistd.h Top: Top


sethostname -- GNU Gnulib

Next: setresgid Prev: sethostid Up: Glibc unistd.h Top: Top

12.112.25. sethostname

Gnulib module: sethostname

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS. Note that the Gnulib replacement may fail with ENOSYS on some platforms.
  • This function is not declared on some platforms: AIX 7.1, OSF/1 5.1, Solaris 10.
Portability problems not fixed by Gnulib:
  • The first parameter is char * instead of const char * on some platforms: Solaris 11 2010-11.
  • The second parameter is int instead of size_t on some platforms: Mac OS X 10.12, Solaris 11 2010-11.

Next: setresgid Prev: sethostid Up: Glibc unistd.h Top: Top


setresgid -- GNU Gnulib

Next: setresuid Prev: sethostname Up: Glibc unistd.h Top: Top

12.112.26. setresgid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setresuid Prev: sethostname Up: Glibc unistd.h Top: Top


setresuid -- GNU Gnulib

Next: setusershell Prev: setresgid Up: Glibc unistd.h Top: Top

12.112.27. setresuid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, NetBSD 5.0, Minix 3.1.8, AIX 5.1, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setusershell Prev: setresgid Up: Glibc unistd.h Top: Top


setusershell -- GNU Gnulib

Next: syncfs Prev: setresuid Up: Glibc unistd.h Top: Top

12.112.28. setusershell

Gnulib module: getusershell

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 4.3.2, IRIX 6.5, mingw, MSVC 14, Interix 3.5, BeOS.
  • This function is missing a declaration on some platforms: Solaris 9.
Portability problems not fixed by Gnulib:

Next: syncfs Prev: setresuid Up: Glibc unistd.h Top: Top


syncfs -- GNU Gnulib

Next: syscall Prev: setusershell Up: Glibc unistd.h Top: Top

12.112.29. syncfs

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: glibc 2.13, Mac OS X 10.5, FreeBSD 6.4, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: syscall Prev: setusershell Up: Glibc unistd.h Top: Top


syscall -- GNU Gnulib

Next: ttyslot Prev: syncfs Up: Glibc unistd.h Top: Top

12.112.30. syscall

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, Cygwin, mingw, MSVC 14, BeOS.

Next: ttyslot Prev: syncfs Up: Glibc unistd.h Top: Top


ttyslot -- GNU Gnulib

Next: vhangup Prev: syscall Up: Glibc unistd.h Top: Top

12.112.31. ttyslot

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14, BeOS.

Next: vhangup Prev: syscall Up: Glibc unistd.h Top: Top


vhangup -- GNU Gnulib

Prev: ttyslot Up: Glibc unistd.h Top: Top

12.112.32. vhangup

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, OSF/1 5.1, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: ttyslot Up: Glibc unistd.h Top: Top


Glibc utmp.h -- GNU Gnulib

Next: Glibc utmpx.h Prev: Glibc unistd.h Up: Glibc Function Substitutes Top: Top

12.113. Glibc <utmp.h>

Menu

  • endutent
  • getutent
  • getutent_r
  • getutid
  • getutid_r
  • getutline
  • getutline_r
  • pututline
  • setutent
  • updwtmp
  • utmpname
  • login
  • login_tty

    • Next: Glibc utmpx.h Prev: Glibc unistd.h Up: Glibc Function Substitutes Top: Top


endutent -- GNU Gnulib

Next: getutent Up: Glibc utmp.h Top: Top

12.113.1. endutent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutent Up: Glibc utmp.h Top: Top


getutent -- GNU Gnulib

Next: getutent_r Prev: endutent Up: Glibc utmp.h Top: Top

12.113.2. getutent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutent_r Prev: endutent Up: Glibc utmp.h Top: Top


getutent_r -- GNU Gnulib

Next: getutid Prev: getutent Up: Glibc utmp.h Top: Top

12.113.3. getutent_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutid Prev: getutent Up: Glibc utmp.h Top: Top


getutid -- GNU Gnulib

Next: getutid_r Prev: getutent_r Up: Glibc utmp.h Top: Top

12.113.4. getutid

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutid_r Prev: getutent_r Up: Glibc utmp.h Top: Top


getutid_r -- GNU Gnulib

Next: getutline Prev: getutid Up: Glibc utmp.h Top: Top

12.113.5. getutid_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutline Prev: getutid Up: Glibc utmp.h Top: Top


getutline -- GNU Gnulib

Next: getutline_r Prev: getutid_r Up: Glibc utmp.h Top: Top

12.113.6. getutline

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutline_r Prev: getutid_r Up: Glibc utmp.h Top: Top


getutline_r -- GNU Gnulib

Next: pututline Prev: getutline Up: Glibc utmp.h Top: Top

12.113.7. getutline_r

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: pututline Prev: getutline Up: Glibc utmp.h Top: Top


pututline -- GNU Gnulib

Next: setutent Prev: getutline_r Up: Glibc utmp.h Top: Top

12.113.8. pututline

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: setutent Prev: getutline_r Up: Glibc utmp.h Top: Top


setutent -- GNU Gnulib

Next: updwtmp Prev: pututline Up: Glibc utmp.h Top: Top

12.113.9. setutent

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: updwtmp Prev: pututline Up: Glibc utmp.h Top: Top


updwtmp -- GNU Gnulib

Next: utmpname Prev: setutent Up: Glibc utmp.h Top: Top

12.113.10. updwtmp

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 4.3.2, HP-UX 11, OSF/1 5.1, mingw, MSVC 14, Interix 3.5, BeOS.

Next: utmpname Prev: setutent Up: Glibc utmp.h Top: Top


utmpname -- GNU Gnulib

Next: login Prev: updwtmp Up: Glibc utmp.h Top: Top

12.113.11. utmpname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, mingw, MSVC 14, Interix 3.5, BeOS.

Next: login Prev: updwtmp Up: Glibc utmp.h Top: Top


login -- GNU Gnulib

Next: login_tty Prev: utmpname Up: Glibc utmp.h Top: Top

12.113.12. login

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many non-glibc platforms: FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 7.1, HP-UX 11.31, IRIX 6.5, Solaris 11.3, mingw, MSVC 14, BeOS.

Next: login_tty Prev: utmpname Up: Glibc utmp.h Top: Top


login_tty -- GNU Gnulib

Prev: login Up: Glibc utmp.h Top: Top

12.113.13. login_tty

Gnulib module: login_tty

Portability problems fixed by Gnulib:

  • This function is missing on some platforms: Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3.
  • This function requires linking with -lutil on some platforms: glibc 2.3.6, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8. It is available without link options on other platforms: Mac OS X 10.5, OSF/1 5.1, Cygwin, Interix 3.5.
Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: mingw, MSVC 14.
  • This function is declared in <utmp.h> on glibc, Cygwin, in <util.h> on Mac OS X 10.5, NetBSD 5.0, OpenBSD 3.8, in <libutil.h> on FreeBSD 6.0, Haiku, and not declared at all on OSF/1 5.1, Interix 3.5. Also note that <sys/types.h> is a prerequisite of <utmp.h> on FreeBSD 8.0, OpenBSD 4.6 and of <libutil.h> on FreeBSD 8.0.

Prev: login Up: Glibc utmp.h Top: Top


Glibc utmpx.h -- GNU Gnulib

Next: Glibc wchar.h Prev: Glibc utmp.h Up: Glibc Function Substitutes Top: Top

12.114. Glibc Extensions to <utmpx.h>

Menu

  • getutmp
  • getutmpx
  • updwtmpx
  • utmpxname


getutmp -- GNU Gnulib

Next: getutmpx Up: Glibc utmpx.h Top: Top

12.114.1. getutmp

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: getutmpx Up: Glibc utmpx.h Top: Top


getutmpx -- GNU Gnulib

Next: updwtmpx Prev: getutmp Up: Glibc utmpx.h Top: Top

12.114.2. getutmpx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.

Next: updwtmpx Prev: getutmp Up: Glibc utmpx.h Top: Top


updwtmpx -- GNU Gnulib

Next: utmpxname Prev: getutmpx Up: Glibc utmpx.h Top: Top

12.114.3. updwtmpx

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, Cygwin 1.5.x, mingw, MSVC 14, Interix 3.5, BeOS.

Next: utmpxname Prev: getutmpx Up: Glibc utmpx.h Top: Top


utmpxname -- GNU Gnulib

Prev: updwtmpx Up: Glibc utmpx.h Top: Top

12.114.4. utmpxname

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.4, FreeBSD 6.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, OSF/1 5.1, mingw, MSVC 14, Interix 3.5, BeOS.

Prev: updwtmpx Up: Glibc utmpx.h Top: Top


Glibc wchar.h -- GNU Gnulib

Prev: Glibc utmpx.h Up: Glibc Function Substitutes Top: Top

12.115. Glibc Extensions to <wchar.h>

Menu

  • fgetwc_unlocked
  • fgetws_unlocked
  • fputwc_unlocked
  • fputws_unlocked
  • getwc_unlocked
  • getwchar_unlocked
  • putwc_unlocked
  • putwchar_unlocked
  • wcschrnul
  • wcsftime_l
  • wcstod_l
  • wcstof_l
  • wcstol_l
  • wcstold_l
  • wcstoll_l
  • wcstoq
  • wcstoul_l
  • wcstoull_l
  • wcstouq
  • wmempcpy

    • Prev: Glibc utmpx.h Up: Glibc Function Substitutes Top: Top


fgetwc_unlocked -- GNU Gnulib

Next: fgetws_unlocked Up: Glibc wchar.h Top: Top

12.115.1. fgetwc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fgetws_unlocked Up: Glibc wchar.h Top: Top


fgetws_unlocked -- GNU Gnulib

Next: fputwc_unlocked Prev: fgetwc_unlocked Up: Glibc wchar.h Top: Top

12.115.2. fgetws_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fputwc_unlocked Prev: fgetwc_unlocked Up: Glibc wchar.h Top: Top


fputwc_unlocked -- GNU Gnulib

Next: fputws_unlocked Prev: fgetws_unlocked Up: Glibc wchar.h Top: Top

12.115.3. fputwc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: fputws_unlocked Prev: fgetws_unlocked Up: Glibc wchar.h Top: Top


fputws_unlocked -- GNU Gnulib

Next: getwc_unlocked Prev: fputwc_unlocked Up: Glibc wchar.h Top: Top

12.115.4. fputws_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: getwc_unlocked Prev: fputwc_unlocked Up: Glibc wchar.h Top: Top


getwc_unlocked -- GNU Gnulib

Next: getwchar_unlocked Prev: fputws_unlocked Up: Glibc wchar.h Top: Top

12.115.5. getwc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: getwchar_unlocked Prev: fputws_unlocked Up: Glibc wchar.h Top: Top


getwchar_unlocked -- GNU Gnulib

Next: putwc_unlocked Prev: getwc_unlocked Up: Glibc wchar.h Top: Top

12.115.6. getwchar_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: putwc_unlocked Prev: getwc_unlocked Up: Glibc wchar.h Top: Top


putwc_unlocked -- GNU Gnulib

Next: putwchar_unlocked Prev: getwchar_unlocked Up: Glibc wchar.h Top: Top

12.115.7. putwc_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on some platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: putwchar_unlocked Prev: getwchar_unlocked Up: Glibc wchar.h Top: Top


putwchar_unlocked -- GNU Gnulib

Next: wcschrnul Prev: putwc_unlocked Up: Glibc wchar.h Top: Top

12.115.8. putwchar_unlocked

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcschrnul Prev: putwc_unlocked Up: Glibc wchar.h Top: Top


wcschrnul -- GNU Gnulib

Next: wcsftime_l Prev: putwchar_unlocked Up: Glibc wchar.h Top: Top

12.115.9. wcschrnul

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcsftime_l Prev: putwchar_unlocked Up: Glibc wchar.h Top: Top


wcsftime_l -- GNU Gnulib

Next: wcstod_l Prev: wcschrnul Up: Glibc wchar.h Top: Top

12.115.10. wcsftime_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstod_l Prev: wcschrnul Up: Glibc wchar.h Top: Top


wcstod_l -- GNU Gnulib

Next: wcstof_l Prev: wcsftime_l Up: Glibc wchar.h Top: Top

12.115.11. wcstod_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstof_l Prev: wcsftime_l Up: Glibc wchar.h Top: Top


wcstof_l -- GNU Gnulib

Next: wcstol_l Prev: wcstod_l Up: Glibc wchar.h Top: Top

12.115.12. wcstof_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstol_l Prev: wcstod_l Up: Glibc wchar.h Top: Top


wcstol_l -- GNU Gnulib

Next: wcstold_l Prev: wcstof_l Up: Glibc wchar.h Top: Top

12.115.13. wcstol_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstold_l Prev: wcstof_l Up: Glibc wchar.h Top: Top


wcstold_l -- GNU Gnulib

Next: wcstoll_l Prev: wcstol_l Up: Glibc wchar.h Top: Top

12.115.14. wcstold_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoll_l Prev: wcstol_l Up: Glibc wchar.h Top: Top


wcstoll_l -- GNU Gnulib

Next: wcstoq Prev: wcstold_l Up: Glibc wchar.h Top: Top

12.115.15. wcstoll_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoq Prev: wcstold_l Up: Glibc wchar.h Top: Top


wcstoq -- GNU Gnulib

Next: wcstoul_l Prev: wcstoll_l Up: Glibc wchar.h Top: Top

12.115.16. wcstoq

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoul_l Prev: wcstoll_l Up: Glibc wchar.h Top: Top


wcstoul_l -- GNU Gnulib

Next: wcstoull_l Prev: wcstoq Up: Glibc wchar.h Top: Top

12.115.17. wcstoul_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstoull_l Prev: wcstoq Up: Glibc wchar.h Top: Top


wcstoull_l -- GNU Gnulib

Next: wcstouq Prev: wcstoul_l Up: Glibc wchar.h Top: Top

12.115.18. wcstoull_l

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on many platforms: Mac OS X 10.3, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wcstouq Prev: wcstoul_l Up: Glibc wchar.h Top: Top


wcstouq -- GNU Gnulib

Next: wmempcpy Prev: wcstoull_l Up: Glibc wchar.h Top: Top

12.115.19. wcstouq

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Next: wmempcpy Prev: wcstoull_l Up: Glibc wchar.h Top: Top


wmempcpy -- GNU Gnulib

Prev: wcstouq Up: Glibc wchar.h Top: Top

12.115.20. wmempcpy

Gnulib module: ---

Portability problems fixed by Gnulib:

Portability problems not fixed by Gnulib:
  • This function is missing on all non-glibc platforms: Mac OS X 10.5, FreeBSD 6.0, NetBSD 5.0, OpenBSD 3.8, Minix 3.1.8, AIX 5.1, HP-UX 11, IRIX 6.5, OSF/1 5.1, Solaris 11.3, Cygwin, mingw, MSVC 14, Interix 3.5, BeOS.
  • On AIX and Windows platforms, wchar_t is a 16-bit type and therefore cannot accommodate all Unicode characters.

Prev: wcstouq Up: Glibc wchar.h Top: Top


Native Windows Support -- GNU Gnulib

Next: Particular Modules Prev: Glibc Function Substitutes Top: Top

13. Native Windows Support

There are three ways to create binaries that run on Microsoft Windows:
  • Native binaries, built using the MinGW tool chain.
  • Native binaries, built using the MSVC (MS Visual C/C++) tool chain.
  • Binaries for the Cygwin environment.
This chapter deals with the MinGW and MSVC platforms, commonly called ``native Windows'' platforms. Cygwin, on the other hand, is close enough to POSIX that it can be treated like any other Unix-like platform.

Menu

  • Libtool and Windows
  • Large File Support
  • Inode numbers on Windows
  • Precise file timestamps on Windows
  • Avoiding the year 2038 problem
  • Windows sockets
  • Native Windows Support without MSVC Support

    • Next: Particular Modules Prev: Glibc Function Substitutes Top: Top


Libtool and Windows -- GNU Gnulib

Next: Large File Support Up: Native Windows Support Top: Top

13.1. Libtool and Windows

If you want it to be possible to compile your program for a native Windows platform and you use Libtool, you need to use the win32-dll option of LT_INIT. In other words, put:

LT_INIT([win32-dll])
in your configure.ac. This sets the correct names for the OBJDUMP, DLLTOOL, and AS tools for the build.

If you are building a library, you will also need to pass -no-undefined to make sure Libtool produces a DLL for your library. From a Makefile.am:

libgsasl_la_LDFLAGS += -no-undefined

Next: Large File Support Up: Native Windows Support Top: Top


Large File Support -- GNU Gnulib

Next: Inode numbers on Windows Prev: Libtool and Windows Up: Native Windows Support Top: Top

13.2. Large File Support

The module provides support for files larger than 2 GB. To this effect, it ensures that off_t is a 64-bit integer type at least on the following platforms: glibc, Mac OS X, FreeBSD, NetBSD, OpenBSD, AIX, HP-UX, IRIX, OSF/1, Solaris, Cygwin, mingw, MSVC.


Inode numbers on Windows -- GNU Gnulib

Next: Precise file timestamps on Windows Prev: Large File Support Up: Native Windows Support Top: Top

13.3. Inode numbers on Windows

The module `windows-stat-inodes' ensures that, on native Windows platforms, struct stat contains st_dev, st_ino fields that are able to distinguish different inodes.

Note: Such values can only be provided for most files on the file system. For a few files (such as inaccessible files), st_dev and st_ino are set to 0. Therefore, you should test whether st_dev != 0 && st_ino != 0, before going to make inferences based on the file identity based on st_dev and st_ino.

Next: Precise file timestamps on Windows Prev: Large File Support Up: Native Windows Support Top: Top


Precise file timestamps on Windows -- GNU Gnulib

Next: Avoiding the year 2038 problem Prev: Inode numbers on Windows Up: Native Windows Support Top: Top

13.4. Precise file timestamps on Windows

The module `windows-stat-timespec' ensures that, on native Windows platforms, struct stat contains st_atim, st_mtim, st_ctim fields of type struct timespec, providing 100 ns resolution for the timestamps of files.

Note: On some types of file systems, the timestamp resolution is limited by the file system. For example, on FAT file systems, st_mtim only has a resolution of 2 seconds. For more details, see https://msdn.microsoft.com/en-us/library/ms724290.aspx.

Next: Avoiding the year 2038 problem Prev: Inode numbers on Windows Up: Native Windows Support Top: Top


Avoiding the year 2038 problem -- GNU Gnulib

Next: Windows sockets Prev: Precise file timestamps on Windows Up: Native Windows Support Top: Top

13.5. Avoiding the year 2038 problem

The ``year 2038 problem'' denotes unpredictable behaviour of programs that will likely occur in the year 2038, for programs that use a 32-bit `time_t' type. See https://en.wikipedia.org/wiki/Year_2038_problem for details.

The gnulib module `year2038' attempts to avoid this problem, by ensuring that time_t is a 64-bit type.

Next: Windows sockets Prev: Precise file timestamps on Windows Up: Native Windows Support Top: Top


Windows sockets -- GNU Gnulib

Prev: Avoiding the year 2038 problem Up: Native Windows Support Top: Top

13.6. Windows sockets

One of the portability problems for native Windows are sockets and networking functions.

13.6.1. Getaddrinfo and WINVER

This was written for the getaddrinfo module, but may be applicable to other functions too.

The getaddrinfo function exists in ws2tcpip.h and -lws2_32 on Windows XP. The function declaration is present if WINVER >= 0x0501. Windows 2000 does not have getaddrinfo in its WS2_32.DLL.

Thus, if you want to assume Windows XP or later, you can add AC_DEFINE([WINVER], [0x0501]) to avoid compiling the (partial) getaddrinfo implementation.

If you want to support Windows 2000, don't do anything. The replacement function will open WS2_32.DLL during run-time to see if there is a getaddrinfo function available, and use it when available.

Prev: Avoiding the year 2038 problem Up: Native Windows Support Top: Top


Native Windows Support without MSVC Support -- GNU Gnulib

Up: Native Windows Support Top: Top

13.7. Native Windows Support without MSVC Support

If your package does not desire to have MSVC support, that is, if MinGW shall be the only native Windows platform that you wish to get support for from Gnulib, and you wish to minimize the number of files imported from Gnulib accordingly, you can do so by passing the options `--avoid=msvc-inval --avoid=msvc-nothrow' to gnulib-tool.

Up: Native Windows Support Top: Top


Particular Modules -- GNU Gnulib

Next: Regular expressions Prev: Native Windows Support Top: Top

14. Particular Modules

Menu

  • alloca
  • alloca-opt
  • Safe Allocation Macros
  • Compile-time Assertions
  • Integer Properties
  • extern inline
  • String Functions in C Locale
  • Quoting
  • error and progname
  • gcd
  • Library version handling
  • Supporting Relocation
  • func
  • stat-size


alloca -- GNU Gnulib

Next: alloca-opt Up: Particular Modules Top: Top

14.1. alloca

The alloca module provides for a function alloca which allocates memory on the stack, where the system allows it. A memory block allocated with alloca exists only until the function that calls alloca returns or exits abruptly.

There are a few systems where this is not possible: HP-UX systems, and some other platforms when the C++ compiler is used. On these platforms the alloca module provides a malloc based emulation. This emulation will not free a memory block immediately when the calling function returns, but rather will wait until the next alloca call from a function with the same or a shorter stack length. Thus, in some cases, a few memory blocks will be kept although they are not needed any more.

The user can #include <alloca.h> and use alloca on all platforms. Note that the #include <alloca.h> must be the first one after the autoconf-generated config.h, for AIX 3 compatibility. Thanks to IBM for this nice restriction!

Note that GCC 3.1 and 3.2 can inline functions that call alloca. When this happens, the memory blocks allocated with alloca will not be freed until the end of the calling function. If this calling function runs a loop calling the function that uses alloca, the program easily gets a stack overflow and crashes. To protect against this compiler behaviour, you can mark the function that uses alloca with the following attribute:

#ifdef __GNUC__
__attribute__ ((__noinline__))
#endif
An alternative to this module is the `alloca-opt' module.

Next: alloca-opt Up: Particular Modules Top: Top


alloca-opt -- GNU Gnulib

Next: Safe Allocation Macros Prev: alloca Up: Particular Modules Top: Top

14.2. alloca-opt

The alloca-opt module provides for a function alloca which allocates memory on the stack, where the system allows it. A memory block allocated with alloca exists only until the function that calls alloca returns or exits abruptly.

There are a few systems where this is not possible: HP-UX systems, and some other platforms when the C++ compiler is used. On these platforms the alloca-opt module provides no replacement, just a preprocessor macro HAVE_ALLOCA.

The user can #include <alloca.h> on all platforms, and use alloca on those platforms where the preprocessor macro HAVE_ALLOCA evaluates to true. If HAVE_ALLOCA is false, the code should use a heap-based memory allocation based on malloc or (in C++) new. Note that the #include <alloca.h> must be the first one after the autoconf-generated config.h, for AIX 3 compatibility. Thanks to IBM for this nice restriction!

Note that GCC 3.1 and 3.2 can inline functions that call alloca. When this happens, the memory blocks allocated with alloca will not be freed until the end of the calling function. If this calling function runs a loop calling the function that uses alloca, the program easily gets a stack overflow and crashes. To protect against this compiler behaviour, you can mark the function that uses alloca with the following attribute:

#ifdef __GNUC__
__attribute__ ((__noinline__))
#endif

Next: Safe Allocation Macros Prev: alloca Up: Particular Modules Top: Top


Safe Allocation Macros -- GNU Gnulib

Next: Compile-time Assertions Prev: alloca-opt Up: Particular Modules Top: Top

14.3. Safe Allocation Macros

The standard C library malloc/realloc/calloc/free APIs are prone to a number of common coding errors. The safe-alloc module provides macros that make it easier to avoid many of them. It still uses the standard C allocation functions behind the scenes.

Some of the memory allocation mistakes that are commonly made are

  • passing the incorrect number of bytes to malloc, especially when allocating an array,
  • fail to check the return value of malloc and realloc for errors,
  • forget to fully initialize memory just allocated with malloc,
  • duplicate calls to free by forgetting to set the pointer variable to NULL,
  • leaking memory in calls to realloc when that call fails.
The safe-alloc module addresses these problems in the following way:

  • It defines macros that wrap around the standard C allocation functions. That makes it possible to use the compiler's knowledge of the size of objects for allocation; it also allows setting pointers passed in as arguments when appropriate.
  • It uses return values only for a success/failure error condition flag, and annotates them with GCC's __warn_unused_result__ attribute.
  • It uses calloc instead of malloc.
int ALLOC (ptr)
Allocate sizeof(*ptr) bytes of memory and store the address of allocated memory in ptr. Fill the newly allocated memory with zeros.

Returns -1 on failure, 0 on success.

int ALLOC_N (ptr, count)
Allocate an array of count elements, each sizeof(*ptr) bytes long, and store the address of allocated memory in ptr. Fill the newly allocated memory with zeros.

Returns -1 on failure, 0 on success.

int ALLOC_N_UNINITIALIZED (ptr, count)
Allocate an array of count elements, each sizeof(*ptr) bytes long, and store the address of allocated memory in ptr. The allocated memory is not initialized.

Returns -1 on failure, 0 on success.

int REALLOC_N (ptr, count)
Reallocate the memory pointed to by ptr to be big enough to hold at least count elements, each sizeof(*ptr) bytes long, and store the address of allocated memory in ptr. If reallocation fails, the ptr variable is not modified.

Returns -1 on failure, 0 on success.

void FREE (ptr)
Free the memory stored in ptr and set ptr to NULL.

Next: Compile-time Assertions Prev: alloca-opt Up: Particular Modules Top: Top


Compile-time Assertions -- GNU Gnulib

Next: Integer Properties Prev: Safe Allocation Macros Up: Particular Modules Top: Top

14.4. Compile-time Assertions

This module provides a header file verify.h that defines macros related to compile-time verification.

Two of these macros are verify (V) and verify_expr (V, EXPR). Both accept an integer constant expression argument V and verify that it is nonzero. If not, a compile-time error results.

These two macros implement compile-time tests, as opposed to the standard assert macro which supports only runtime tests. Since the tests occur at compile-time, they are more reliable, and they require no runtime overhead.

verify (V); is a declaration; it can occur outside of functions. In contrast, verify_expr (V, EXPR) is an expression that returns the value of EXPR; it can be used in macros that expand to expressions. If EXPR is an integer constant expression, then verify_expr (V, EXPR) is also an integer constant expression. Although EXPR and verify_expr (V, EXPR) are guaranteed to have the same side effects and value and type (after integer promotion), they need not have the same type if EXPR's type is an integer that is narrower than int or unsigned int.

V should be an integer constant expression in the sense of the C standard. Its leaf operands should be integer, enumeration, or character constants; or sizeof expressions that return constants; or floating constants that are the immediate operands of casts. Outside a sizeof subexpression, V should not contain any assignments, function calls, comma operators, casts to non-integer types, or subexpressions whose values are outside the representable ranges for their types. If V is not an integer constant expression, then a compiler might reject a usage like `verify (V);' even when V is nonzero.

Although the standard assert macro is a runtime test, C11 specifies a builtin _Static_assert (V, STRING-LITERAL), its assert.h header has a similar macro named static_assert, and C++11 has a similar static_assert builtin. These builtins and macros differ from verify in two major ways. First, they can also be used within a struct or union specifier, in place of an ordinary member declaration. Second, they require the programmer to specify a compile-time diagnostic as a string literal.

The verify.h header defines one more macro, assume (E), which expands to an expression of type void that causes the compiler to assume that E yields a nonzero value. E should be a scalar expression, and should not have side effects; it may or may not be evaluated. The behavior is undefined if E would yield zero. The main use of assume is optimization, as the compiler may be able to generate better code if it assumes E. For best results, E should be simple enough that a compiler can determine that it has no side effects: if E calls an external function or accesses volatile storage the compiler may not be able to optimize E away and assume (E) may therefore slow down the program.

Here are some example uses of these macros.

#include <verify.h>

#include <limits.h>
#include <time.h>

/* Verify that time_t is an integer type.  */
verify ((time_t) 1.5 == 1);

/* Verify that time_t is no smaller than int.  */
verify (sizeof (int) <= sizeof (time_t));

/* Verify that time_t is signed.  */
verify ((time_t) -1 < 0);

/* Verify that time_t uses two's complement representation.  */
verify (~ (time_t) -1 == 0);

/* Return the maximum value of the integer type T,
   verifying that T is an unsigned integer type.
   The cast to (T) is outside the call to verify_expr
   so that the result is of type T
   even when T is narrower than unsigned int.  */
#define MAX_UNSIGNED_VAL(t) \
   ((T) verify_expr (0 < (T) -1, -1))

/* Return T divided by CHAR_MAX + 1, where behavior is
   undefined if T < 0.  In the common case where CHAR_MAX
   is 127 the compiler can therefore implement the division
   by shifting T right 7 bits, an optimization that would
   not be valid if T were negative.  */
time_t
time_index (time_t t)
{
  assume (0 <= t);
  return t / (CHAR_MAX + 1);
}

Next: Integer Properties Prev: Safe Allocation Macros Up: Particular Modules Top: Top


Integer Properties -- GNU Gnulib

Next: extern inline Prev: Compile-time Assertions Up: Particular Modules Top: Top

14.5. Integer Properties

The intprops module consists of an include file <intprops.h> that defines several macros useful for testing properties of integer types.

Integer overflow is a common source of problems in programs written in C and other languages. In some cases, such as signed integer arithmetic in C programs, the resulting behavior is undefined, and practical platforms do not always behave as if integers wrap around reliably. In other cases, such as unsigned integer arithmetic in C, the resulting behavior is well-defined, but programs may still misbehave badly after overflow occurs.

Many techniques have been proposed to attack these problems. These include precondition testing, wraparound behavior where signed integer arithmetic is guaranteed to be modular, saturation semantics where overflow reliably yields an extreme value, undefined behavior sanitizers where overflow is guaranteed to trap, and various static analysis techniques.

Gnulib supports wraparound arithmetic and precondition testing, as these are relatively easy to support portably and efficiently. There are two families of precondition tests: the first, for integer types, is easier to use, while the second, for integer ranges, has a simple and straightforward portable implementation.

Menu

  • Arithmetic Type Properties Determining properties of arithmetic types.
  • Integer Bounds Bounds on integer values and representations.
  • Wraparound Arithmetic Well-defined behavior on signed overflow.
  • Integer Type Overflow General integer overflow checking.
  • Integer Range Overflow Integer overflow checking if bounds are known.

    • Next: extern inline Prev: Compile-time Assertions Up: Particular Modules Top: Top


Arithmetic Type Properties -- GNU Gnulib

Next: Integer Bounds Up: Integer Properties Top: Top

14.5.1. Arithmetic Type Properties

TYPE_IS_INTEGER (t) is an arithmetic constant expression that is 1 if the arithmetic type t is an integer type. _Bool counts as an integer type.

TYPE_SIGNED (t) is an arithmetic constant expression that is 1 if the real type t is a signed integer type or a floating type. If t is an integer type, TYPE_SIGNED (t) is an integer constant expression.

EXPR_SIGNED (e) is 1 if the real expression e has a signed integer type or a floating type. If e is an integer constant expression or an arithmetic constant expression, EXPR_SIGNED (e) is likewise. Although e is evaluated, if e is free of side effects then EXPR_SIGNED (e) is typically optimized to a constant.

Example usage:

#include <intprops.h>
#include <time.h>

enum
{
  time_t_is_signed_integer =
    TYPE_IS_INTEGER (time_t) && TYPE_SIGNED (time_t)
};

int
CLOCKS_PER_SEC_is_signed (void)
{
  return EXPR_SIGNED (CLOCKS_PER_SEC);
}

Next: Integer Bounds Up: Integer Properties Top: Top


Integer Bounds -- GNU Gnulib

Next: Wraparound Arithmetic Prev: Arithmetic Type Properties Up: Integer Properties Top: Top

14.5.2. Integer Bounds

INT_BUFSIZE_BOUND (t) is an integer constant expression that is a bound on the size of the string representing an integer type or expression t in decimal notation, including the terminating null character and any leading - character. For example, if INT_STRLEN_BOUND (int) is 12, any value of type int can be represented in 12 bytes or less, including the terminating null. The bound is not necessarily tight.

Example usage:

#include <intprops.h>
#include <stdio.h>
int
int_strlen (int i)
{
  char buf[INT_BUFSIZE_BOUND (int)];
  return sprintf (buf, "%d", i);
}
INT_STRLEN_BOUND (t) is an integer constant expression that is a bound on the length of the string representing an integer type or expression t in decimal notation, including any leading - character. This is one less than INT_BUFSIZE_BOUND (t).

TYPE_MINIMUM (t) and TYPE_MAXIMUM (t) are integer constant expressions equal to the minimum and maximum values of the integer type t. These expressions are of the type t (or more precisely, the type t after integer promotions).

Example usage:

#include <stdint.h>
#include <sys/types.h>
#include <intprops.h>
int
in_off_t_range (intmax_t a)
{
  return TYPE_MINIMUM (off_t) <= a && a <= TYPE_MAXIMUM (off_t);
}

Next: Wraparound Arithmetic Prev: Arithmetic Type Properties Up: Integer Properties Top: Top


Wraparound Arithmetic -- GNU Gnulib

Next: Integer Type Overflow Prev: Integer Bounds Up: Integer Properties Top: Top

14.5.3. Wraparound Arithmetic with Signed Integers

Signed integer arithmetic has undefined behavior on overflow in C. Although almost all modern computers use two's complement signed arithmetic that is well-defined to wrap around, C compilers routinely optimize assuming that signed integer overflow cannot occur, which means that a C program cannot easily get at the underlying machine arithmetic. For example, on a typical machine with 32-bit two's complement int the expression INT_MAX + 1 does not necessarily yield INT_MIN, because the compiler may do calculations with a 64-bit register, or may generate code that traps on signed integer overflow.

The following macros work around this problem by storing the wraparound value, i.e., the low-order bits of the correct answer, and by returning an overflow indication. For example, if i is of type int, INT_ADD_WRAPV (INT_MAX, 1, &i) sets i to INT_MIN and returns 1 on a two's complement machine. On newer platforms, these macros are typically more efficient than the overflow-checking macros. See Integer Type Overflow.

Example usage:

#include <intprops.h>
#include <stdio.h>

/* Print the low order bits of A * B,
   reporting whether overflow occurred.  */
void
print_product (long int a, long int b)
{
  long int r;
  int overflow = INT_MULTIPLY_WRAPV (a, b, &r);
  printf ("result is %ld (%s)\n", r,
          (overflow
           ? "after overflow"
           : "no overflow"));
}
These macros have the following restrictions:

  • Their first two arguments must be integer expressions.

  • Their last argument must be a non-null pointer to a signed integer. To calculate a wraparound unsigned integer you can use ordinary C arithmetic; to tell whether it overflowed, you can use the overflow-checking macros.

  • They may evaluate their arguments zero or multiple times, so the arguments should not have side effects.

  • They are not necessarily constant expressions, even if all their arguments are constant expressions.
INT_ADD_WRAPV (a, b, r)
Store the low-order bits of the sum of a and b into *r. Return true if overflow occurred, false if the low-order bits are the mathematically-correct sum. See above for restrictions.

INT_SUBTRACT_WRAPV (a, b, r)
Store the low-order bits of the difference between a and b into *r. Return true if overflow occurred, false if the low-order bits are the mathematically-correct difference. See above for restrictions.

INT_MULTIPLY_WRAPV (a, b, r)
Store the low-order bits of the product of a and b into *r. Return true if overflow occurred, false if the low-order bits are the mathematically-correct product. See above for restrictions.

Next: Integer Type Overflow Prev: Integer Bounds Up: Integer Properties Top: Top


Integer Type Overflow -- GNU Gnulib

Next: Integer Range Overflow Prev: Wraparound Arithmetic Up: Integer Properties Top: Top

14.5.4. Integer Type Overflow

Although unsigned integer arithmetic wraps around modulo a power of two, signed integer arithmetic has undefined behavior on overflow in C. Almost all modern computers use two's complement signed arithmetic that is well-defined to wrap around, but C compilers routinely optimize based on the assumption that signed integer overflow cannot occur, which means that a C program cannot easily get at the underlying machine behavior. For example, the signed integer expression (a + b < b) != (a < 0) is not a reliable test for whether a + b overflows, because a compiler can assume that signed overflow cannot occur and treat the entire expression as if it were false.

These macros yield 1 if the corresponding C operators might not yield numerically correct answers due to arithmetic overflow of an integer type. They work correctly on all known practical hosts, and do not rely on undefined behavior due to signed arithmetic overflow. They are integer constant expressions if their arguments are. They are typically easier to use than the integer range overflow macros (see Integer Range Overflow), and they support more operations and evaluation contexts than the wraparound macros (see Wraparound Arithmetic).

Example usage:

#include <intprops.h>
#include <limits.h>
#include <stdio.h>

/* Print A * B if in range, an overflow
   indicator otherwise.  */
void
print_product (long int a, long int b)
{
  if (INT_MULTIPLY_OVERFLOW (a, b))
    printf ("multiply would overflow");
  else
    printf ("product is %ld", a * b);
}

/* Does the product of two ints always fit
   in a long int?  */
enum {
  INT_PRODUCTS_FIT_IN_LONG
    = ! (INT_MULTIPLY_OVERFLOW
         ((long int) INT_MIN, INT_MIN))
};
These macros have the following restrictions:

  • Their arguments must be integer expressions.

  • They may evaluate their arguments zero or multiple times, so the arguments should not have side effects.
These macros are tuned for their last argument being a constant.

INT_ADD_OVERFLOW (a, b)
Yield 1 if a + b would overflow. See above for restrictions.

INT_SUBTRACT_OVERFLOW (a, b)
Yield 1 if a - b would overflow. See above for restrictions.

INT_NEGATE_OVERFLOW (a)
Yields 1 if -a would overflow. See above for restrictions.

INT_MULTIPLY_OVERFLOW (a, b)
Yield 1 if a * b would overflow. See above for restrictions.

INT_DIVIDE_OVERFLOW (a, b)
Yields 1 if a / b would overflow. See above for restrictions. Division overflow can happen on two's complement hosts when dividing the most negative integer by -1. This macro does not check for division by zero.

INT_REMAINDER_OVERFLOW (a, b)
Yield 1 if a % b would overflow. See above for restrictions. Remainder overflow can happen on two's complement hosts when dividing the most negative integer by -1; although the mathematical result is always 0, in practice some implementations trap, so this counts as an overflow. This macro does not check for division by zero.

INT_LEFT_SHIFT_OVERFLOW (a, b)
Yield 1 if a << b would overflow. See above for restrictions. The C standard says that behavior is undefined for shifts unless 0@leq{}b<w where w is a's word width, and that when a is negative then a << b has undefined behavior, but this macro does not check these other restrictions.

Next: Integer Range Overflow Prev: Wraparound Arithmetic Up: Integer Properties Top: Top


Integer Range Overflow -- GNU Gnulib

Prev: Integer Type Overflow Up: Integer Properties Top: Top

14.5.5. Integer Range Overflow

These macros yield 1 if the corresponding C operators might not yield numerically correct answers due to arithmetic overflow. They do not rely on undefined or implementation-defined behavior. They are integer constant expressions if their arguments are. Their implementations are simple and straightforward, but they are typically harder to use than the integer type overflow macros. See Integer Type Overflow.

Although the implementation of these macros is similar to that suggested in Seacord R, The CERT C Secure Coding Standard (2009, revised 2011), in its two sections ``https://www.securecoding.cert.org/confluence/display/c/INT30-C.+Ensure+that+unsigned+integer+operations+do+not+wrap, INT30-C. Ensure that unsigned integer operations do not wrap'' and ``https://www.securecoding.cert.org/confluence/display/c/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow, INT32-C. Ensure that operations on signed integers do not result in overflow'', Gnulib's implementation was derived independently of CERT's suggestions.

Example usage:

#include <intprops.h>
#include <limits.h>
#include <stdio.h>

void
print_product (long int a, long int b)
{
  if (INT_MULTIPLY_RANGE_OVERFLOW (a, b, LONG_MIN, LONG_MAX))
    printf ("multiply would overflow");
  else
    printf ("product is %ld", a * b);
}

/* Does the product of two ints always fit
   in a long int?  */
enum {
  INT_PRODUCTS_FIT_IN_LONG
    = ! (INT_MULTIPLY_RANGE_OVERFLOW
         ((long int) INT_MIN, (long int) INT_MIN,
          LONG_MIN, LONG_MAX))
};
These macros have the following restrictions:

  • Their arguments must be integer expressions.

  • They may evaluate their arguments zero or multiple times, so the arguments should not have side effects.

  • The arithmetic arguments (including the min and max arguments) must be of the same integer type after the usual arithmetic conversions, and the type must have minimum value min and maximum max. Unsigned values should use a zero min of the proper type, for example, (unsigned int) 0.
These macros are tuned for constant min and max. For commutative operations such as a + b, they are also tuned for constant b.

INT_ADD_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a + b would overflow in [min,max] integer arithmetic. See above for restrictions.

INT_SUBTRACT_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a - b would overflow in [min,max] integer arithmetic. See above for restrictions.

INT_NEGATE_RANGE_OVERFLOW (a, min, max)
Yield 1 if -a would overflow in [min,max] integer arithmetic. See above for restrictions.

INT_MULTIPLY_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a * b would overflow in [min,max] integer arithmetic. See above for restrictions.

INT_DIVIDE_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a / b would overflow in [min,max] integer arithmetic. See above for restrictions. Division overflow can happen on two's complement hosts when dividing the most negative integer by -1. This macro does not check for division by zero.

INT_REMAINDER_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a % b would overflow in [min,max] integer arithmetic. See above for restrictions. Remainder overflow can happen on two's complement hosts when dividing the most negative integer by -1; although the mathematical result is always 0, in practice some implementations trap, so this counts as an overflow. This macro does not check for division by zero.

INT_LEFT_SHIFT_RANGE_OVERFLOW (a, b, min, max)
Yield 1 if a << b would overflow in [min,max] integer arithmetic. See above for restrictions. Here, min and max are for a only, and b need not be of the same type as the other arguments. The C standard says that behavior is undefined for shifts unless 0@leq{}b<w where w is a's word width, and that when a is negative then a << b has undefined behavior, but this macro does not check these other restrictions.

Prev: Integer Type Overflow Up: Integer Properties Top: Top


extern inline -- GNU Gnulib

Next: String Functions in C Locale Prev: Integer Properties Up: Particular Modules Top: Top

14.6. Extern inline functions

The extern-inline module supports the use of C99-style extern inline functions so that the code still runs on compilers that do not support this feature correctly.

C code ordinarily should not use inline. Typically it is better to let the compiler figure out whether to inline, as compilers are pretty good about optimization nowadays. In this sense, inline is like register, another keyword that is typically no longer needed.

Functions defined (not merely declared) in headers are an exception, as avoiding inline would commonly cause problems for these functions. Suppose aaa.h defines the function aaa_fun, and aaa.c, bbb.c and ccc.c all include aaa.h. If code is intended to portable to non-C99 compilers, aaa_fun cannot be declared with the C99 inline keyword. This problem cannot be worked around by making aaa_fun an ordinary function, as it would be defined three times with external linkage and the definitions would clash. Although aaa_fun could be a static function, with separate compilation if aaa_fun is not inlined its code will appear in the executable three times.

To avoid this code bloat, aaa.h can do this:

/* aaa.h */
/* #include any other headers here */
#ifndef _GL_INLINE_HEADER_BEGIN
 #error "Please include config.h first."
#endif
_GL_INLINE_HEADER_BEGIN
#ifndef AAA_INLINE
# define AAA_INLINE _GL_INLINE
#endif
...
AAA_INLINE int
aaa_fun (int i)
{
  return i + 1;
}
...
_GL_INLINE_HEADER_END
and aaa.c can do this:

/* aaa.c */
#include <config.h>
#define AAA_INLINE _GL_EXTERN_INLINE
#include <aaa.h>
whereas bbb.c and ccc.c can include aaa.h in the usual way. C99 compilers expand AAA_INLINE to C99-style inline usage, where aaa_fun is declared extern inline in aaa.c and plain inline in other modules. Non-C99 compilers that are compatible with GCC use GCC-specific syntax to accomplish the same ends. Other non-C99 compilers use static inline so they suffer from code bloat, but they are not mainline platforms and will die out eventually.

_GL_INLINE is a portable alternative to C99 plain inline.

_GL_EXTERN_INLINE is a portable alternative to C99 extern inline.

Invoke _GL_INLINE_HEADER_BEGIN before all uses of _GL_INLINE in an include file. This suppresses some bogus warnings in GCC versions before 5.1. If an include file includes other files, it is better to invoke this macro after including the other files.

Invoke _GL_INLINE_HEADER_END after all uses of _GL_INLINE in an include file.

Next: String Functions in C Locale Prev: Integer Properties Up: Particular Modules Top: Top


String Functions in C Locale -- GNU Gnulib

Next: Quoting Prev: extern inline Up: Particular Modules Top: Top

14.7. Character and String Functions in C Locale

The functions in this section are similar to the generic string functions from the standard C library, except that
  • They behave as if the locale was set to the "C" locale, even when the locale is different, and/or
  • They are specially optimized for the case where all characters are plain ASCII characters.
Menu

  • c-ctype
  • c-strcase
  • c-strcaseeq
  • c-strcasestr
  • c-strstr
  • c-strtod
  • c-strtold

    • Next: Quoting Prev: extern inline Up: Particular Modules Top: Top


c-ctype -- GNU Gnulib

Next: c-strcase Up: String Functions in C Locale Top: Top

14.7.1. c-ctype

The c-ctype module contains functions operating on single-byte characters, like the functions in <ctype.h>, that operate as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The functions are:

extern bool c_isascii (int c);

extern bool c_isalnum (int c);
extern bool c_isalpha (int c);
extern bool c_isblank (int c);
extern bool c_iscntrl (int c);
extern bool c_isdigit (int c);
extern bool c_islower (int c);
extern bool c_isgraph (int c);
extern bool c_isprint (int c);
extern bool c_ispunct (int c);
extern bool c_isspace (int c);
extern bool c_isupper (int c);
extern bool c_isxdigit (int c);

extern int c_tolower (int c);
extern int c_toupper (int c);
These functions assign properties only to ASCII characters.

The c argument can be a char or unsigned char value, whereas the corresponding functions in <ctype.h> take an argument that is actually an unsigned char value.

The c_is* functions return `bool', where the corresponding functions in <ctype.h> return `int' for historical reasons.

Note: The <ctype.h> functions support only unibyte locales.

Next: c-strcase Up: String Functions in C Locale Top: Top


c-strcase -- GNU Gnulib

Next: c-strcaseeq Prev: c-ctype Up: String Functions in C Locale Top: Top

14.7.2. c-strcase

The c-strcase module contains case-insensitive string comparison functions operating on single-byte character strings, like the functions in <strings.h>, that operate as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The functions are:

extern int c_strcasecmp (const char *s1, const char *s2);
extern int c_strncasecmp (const char *s1, const char *s2, size_t n);
For case conversion here, only ASCII characters are considered to be upper case or lower case.

Note: The functions strcasecmp, strncasecmp from <strings.h> support only unibyte locales; for multibyte locales, you need the functions mbscasecmp, mbsncasecmp, mbspcasecmp.

Next: c-strcaseeq Prev: c-ctype Up: String Functions in C Locale Top: Top


c-strcaseeq -- GNU Gnulib

Next: c-strcasestr Prev: c-strcase Up: String Functions in C Locale Top: Top

14.7.3. c-strcaseeq

The c-strcaseeq module contains an optimized case-insensitive string comparison function operating on single-byte character strings, that operate as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The functions is actually implemented as a macro:

extern int STRCASEEQ (const char *s1, const char *s2,
                      int s20, int s21, int s22, int s23, int s24, int s25,
                      int s26, int s27, int s28);
s2 should be a short literal ASCII string, and s20, s21, ... the individual characters of s2.

For case conversion here, only ASCII characters are considered to be upper case or lower case.

Next: c-strcasestr Prev: c-strcase Up: String Functions in C Locale Top: Top


c-strcasestr -- GNU Gnulib

Next: c-strstr Prev: c-strcaseeq Up: String Functions in C Locale Top: Top

14.7.4. c-strcasestr

The c-strcasestr module contains a case-insensitive string search function operating on single-byte character strings, that operate as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The function is:

extern char *c_strcasestr (const char *haystack, const char *needle);
For case conversion here, only ASCII characters are considered to be upper case or lower case.

Note: The function strcasestr from <string.h> supports only unibyte locales; for multibyte locales, you need the function mbscasestr.

Next: c-strstr Prev: c-strcaseeq Up: String Functions in C Locale Top: Top


c-strstr -- GNU Gnulib

Next: c-strtod Prev: c-strcasestr Up: String Functions in C Locale Top: Top

14.7.5. c-strstr

The c-strstr module contains a substring search function operating on single-byte character strings, that operate as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The function is:

extern char *c_strstr (const char *haystack, const char *needle);
Note: The function strstr from <string.h> supports only unibyte locales; for multibyte locales, you need the function mbsstr.

Next: c-strtod Prev: c-strcasestr Up: String Functions in C Locale Top: Top


c-strtod -- GNU Gnulib

Next: c-strtold Prev: c-strstr Up: String Functions in C Locale Top: Top

14.7.6. c-strtod

The c-strtod module contains a string to number (`double') conversion function operating on single-byte character strings, that operates as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The function is:

extern double c_strtod (const char *string, char **endp);
In particular, only a period `.' is accepted as decimal point, even when the current locale's notion of decimal point is a comma `,', and no characters outside the basic character set are accepted.

On platforms without strtod_l, this function is not safe for use in multi-threaded applications since it calls setlocale.

Next: c-strtold Prev: c-strstr Up: String Functions in C Locale Top: Top


c-strtold -- GNU Gnulib

Prev: c-strtod Up: String Functions in C Locale Top: Top

14.7.7. c-strtold

The c-strtold module contains a string to number (`long double') conversion function operating on single-byte character strings, that operates as if the locale encoding was ASCII. (The "C" locale on many systems has the locale encoding "ASCII".)

The function is:

extern long double c_strtold (const char *string, char **endp);
In particular, only a period `.' is accepted as decimal point, even when the current locale's notion of decimal point is a comma `,'.

Prev: c-strtod Up: String Functions in C Locale Top: Top


Quoting -- GNU Gnulib

Next: error and progname Prev: String Functions in C Locale Up: Particular Modules Top: Top

14.8. Quoting

Gnulib provides `quote' and `quotearg' modules to help with quoting text, such as file names, in messages to the user. Here's an example of using `quote':

#include <quote.h>
 ...
  error (0, errno, _("cannot change owner of %s"), quote (fname));
This differs from

  error (0, errno, _("cannot change owner of '%s'"), fname);
in that quote escapes unusual characters in fname, e.g., `'' and control characters like `\n'.

However, a caveat: quote reuses the storage that it returns. Hence if you need more than one thing quoted at the same time, you need to use quote_n.

Also, the quote module is not suited for multithreaded applications. In that case, you have to use quotearg_alloc, defined in the `quotearg' module, which is decidedly less convenient.

Next: error and progname Prev: String Functions in C Locale Up: Particular Modules Top: Top


error and progname -- GNU Gnulib

Next: gcd Prev: Quoting Up: Particular Modules Top: Top

14.9. error and progname

The error function uses the program_name variable, but does not depend on the progname module. Why? Because error is released under the LGPL, whereas progname is GPL. RMS does not want additional baggage accompanying the error module, so an LGPL user must provide their own replacement program_name, and a GPL user should manually specify using the progname module.

Additionally, using the progname module is not something that can be done implicitly. It requires that every main function be modified to set program_name as one of its first actions.

Next: gcd Prev: Quoting Up: Particular Modules Top: Top


gcd -- GNU Gnulib

Next: Library version handling Prev: error and progname Up: Particular Modules Top: Top

14.10. gcd: greatest common divisor

The gcd function returns the greatest common divisor of two numbers a > 0 and b > 0. It is the caller's responsibility to ensure that the arguments are non-zero.

If you need a gcd function for an integer type larger than `unsigned long', you can include the gcd.c implementation file with parametrization. The parameters are:

  • WORD_T Define this to the unsigned integer type that you need this function for.

  • GCD Define this to the name of the function to be created.
The created function has the prototype
WORD_T GCD (WORD_T a, WORD_T b);
If you need the least common multiple of two numbers, it can be computed like this: lcm(a,b) = (a / gcd(a,b)) * b or lcm(a,b) = a * (b / gcd(a,b)). Avoid the formula lcm(a,b) = (a * b) / gcd(a,b) because---although mathematically correct---it can yield a wrong result, due to integer overflow.

In some applications it is useful to have a function taking the gcd of two signed numbers. In this case, the gcd function result is usually normalized to be non-negative (so that two gcd results can be compared in magnitude or compared against 1, etc.). Note that in this case the prototype of the function has to be

unsigned long gcd (long a, long b);
and not
long gcd (long a, long b);
because gcd(LONG_MIN,LONG_MIN) = -LONG_MIN = LONG_MAX + 1 does not fit into a signed `long'.

Next: Library version handling Prev: error and progname Up: Particular Modules Top: Top


Library version handling -- GNU Gnulib

Next: Supporting Relocation Prev: gcd Up: Particular Modules Top: Top

14.11. Library version handling

The module `check-version' can be useful when your gnulib application is a system library. You will typically wrap the call to the check_version function through a library API, your library header file may contain:

#define STRINGPREP_VERSION "0.5.18"
...
  extern const char *stringprep_check_version (const char *req_version);
To avoid ELF symbol collisions with other libraries that use the `check-version' module, add to config.h through a AC_DEFINE something like:

AC_DEFINE(check_version, stringprep_check_version,
          [Rename check_version.])
The stringprep_check_version function will thus be implemented by the check_version module.

There are two uses of the interface. The first is a way to provide for applications to find out the version number of the library it uses. The application may contain diagnostic code such as:

  printf ("Stringprep version: header %s library %s",
          STRINGPREP_VERSION,
          stringprep_check_version (NULL));
Separating the library and header file version can be useful when searching for version mismatch related problems.

The second uses is as a rudimentary test of proper library version, by making sure the application get a library version that is the same, or newer, than the header file used when building the application. This doesn't catch all problems, libraries may change backwards incompatibly in later versions, but enable applications to require a certain minimum version before it may proceed.

Typical uses look like:

       /* Check version of libgcrypt. */
       if (!gcry_check_version (GCRYPT_VERSION))
         die ("version mismatch\n");

Next: Supporting Relocation Prev: gcd Up: Particular Modules Top: Top


Supporting Relocation -- GNU Gnulib

Next: func Prev: Library version handling Up: Particular Modules Top: Top

14.12. Supporting Relocation

It has been a pain for many users of GNU packages for a long time that packages are not relocatable. It means a user cannot copy a program, installed by another user on the same machine, to his home directory, and have it work correctly (including i18n). So many users need to go through configure; make; make install with all its dependencies, options, and hurdles.

Red Hat, Debian, and other binary distributions solve the ``ease of installation'' problem, but they hardwire path names, usually to /usr or /usr/local. This means that users need root privileges to install a binary package, and prevents installing two different versions of the same binary package.

A relocatable program can be moved or copied to a different location on the file system. It is possible to make symlinks to the installed and moved programs, and invoke them through the symlink. It is possible to do the same thing with a hard link only if the hard link file is in the same directory as the real program.

The relocatable-prog module aims to ease the process of making a GNU program relocatable. It helps overcome two obstacles. First, it aids with relocating the hard-coded references to absolute file names that GNU programs often contain. These references must be fixed up at runtime if a program is to be successfully relocated. The relocatable-prog module provides a function relocate that does this job.

Second, the loader must be able to find shared libraries linked to relocatable executables or referenced by other shared libraries linked to relocatable executables. The relocatable-prog module helps out here in a platform-specific way:

  • On GNU/Linux, it adds a linker option (@option{-rpath}) that causes the dynamic linker to search for libraries in a directory relative to the location of the invoked executable.

  • On other Unix systems, it installs a wrapper executable. The wrapper sets the environment variable that controls shared library searching (usually @env{LD_LIBRARY_PATH}) and then invokes the real executable.

  • On Windows, the executable's own directory is searched for libraries, so installing shared libraries into the executable's directory is sufficient.
You can make your program relocatable by following these steps:

  1. Import the relocatable-prog module. For libraries, use the relocatable-lib or relocatable-lib-lgpl module.

  2. In every program, add to main as the first statement (even before setting the locale or doing anything related to libintl):

    set_program_name (argv[0]);
    The prototype for this function is in progname.h.

  3. If you want your code to be portable to platforms that do not support automatic initialization, call set_relocation_prefix.

  4. Everywhere where you use a constant pathname from installation-time, wrap it in relocate so it gets translated to the run-time situation. Example:

    bindtextdomain (PACKAGE, LOCALEDIR);
    becomes:

    bindtextdomain (PACKAGE, relocate (LOCALEDIR));
    The prototype for this function is in relocatable.h.

    There is also a variant of this function, named relocate2, that makes it easy to reclaim the memory allocated by the call.

  5. The set_program_name function can also configure some additional libraries to relocate files that they access, by defining corresponding C preprocessor symbols to 1. The libraries for which this is supported and the corresponding preprocessor symbols are:

    libcharset
    DEPENDS_ON_LIBCHARSET

    libiconv
    DEPENDS_ON_LIBICONV

    libintl
    DEPENDS_ON_LIBINTL
    Defining the symbol for a library makes every program in the package depend on that library, whether the program really uses the library or not, so this feature should be used with some caution.

  6. If your package installs shell scripts, also import the relocatable-script module. Then, near the beginning of each shell script that your package installs, add the following:

    @relocatable_sh@
if test "@RELOCATABLE@" = yes; then
  exec_prefix="@exec_prefix@"
  bindir="@bindir@"
  orig_installdir="$bindir" # see Makefile.am's *_SCRIPTS variables
  func_find_curr_installdir # determine curr_installdir
  func_find_prefixes
  relocate () {
    echo "$1/" \
    | sed -e "s%^${orig_installprefix}/%${curr_installprefix}/%" \
    | sed -e 's,/$,,'
  }
else
  relocate () {
    echo "$1"
  }
fi

# Get some relocated directory names.
sysconfdir=`relocate "@sysconfdir@"`
some_datadir=`relocate "@datadir@/something"`
    You must adapt the definition of orig_installdir, depending on where the script gets installed. Also, at the end, instead of sysconfdir and some_datadir, transform those variables that you need.

  7. If your package installs Perl scripts, also import the relocatable-perl module. Then, near the beginning of each Perl script that your package installs, add the following:

    @relocatable_pl@
if ("@RELOCATABLE@" eq "yes") {
  my $exec_prefix = "@exec_prefix@";
  my $orig_installdir = "@bindir@"; # see Makefile.am's *_SCRIPTS variables
  my ($orig_installprefix, $curr_installprefix) = find_prefixes($orig_installdir, find_curr_installdir());
  sub relocate { # the subroutine is defined whether or not the enclosing block is executed
    my ($dir) = @_;
    if ("@RELOCATABLE@" eq "yes") {
      $dir =~ s%^$orig_installprefix/%$curr_installprefix/%;
      $dir =~ s,/$,,;
    }
    return $dir;
  }
}

# Get some relocated directory names.
# (The gnulib module 'configmake' can help with this.)
$sysconfdir = relocate("@sysconfdir@");
$some_datadir = relocate(@datadir@/something");
    You must adapt the definition of $orig_installdir, depending on where the script gets installed. Also, at the end, instead of sysconfdir and some_datadir, transform those variables that you need.

  8. In your Makefile.am, for every program @command{foo} that gets installed in, say, $(bindir), you add:

    foo_CPPFLAGS = -DINSTALLDIR=\"$(bindir)\"
if RELOCATABLE_VIA_LD
foo_LDFLAGS = `$(RELOCATABLE_LDFLAGS) $(bindir)`
endif
    Also in Makefile.am, for each library libfoo, you add:

    libfoo_la_CPPFLAGS = -DIN_LIBRARY
    (Adjust the suffix la as necessary if you are not using libtool.)

  9. You may also need to add a couple of variable assignments to your configure.ac.

    If your package (or any package you rely on, e.g. gettext-runtime) will be relocated together with a set of installed shared libraries, then set RELOCATABLE_LIBRARY_PATH to a colon-separated list of those libraries' directories, e.g.

    RELOCATABLE_LIBRARY_PATH='$(libdir)'
    If your config.h is not in $(top_builddir), then set RELOCATABLE_CONFIG_H_DIR to its directory, e.g.
    RELOCATABLE_CONFIG_H_DIR='$(top_builddir)/src'

Next: func Prev: Library version handling Up: Particular Modules Top: Top


func -- GNU Gnulib

Next: stat-size Prev: Supporting Relocation Up: Particular Modules Top: Top

14.13. func

The func module makes sure that you can use the predefined identifier __func__ as defined by C99 in your code.

A small example is:

#include <config.h>
#include <stdio.h> /* for printf */

int main (void)
{
    printf ("%s: hello world\n", __func__);
}
Note that sizeof cannot be applied to __func__: On SunPRO C compiler, sizeof __func__ evaluates to 0.

Next: stat-size Prev: Supporting Relocation Up: Particular Modules Top: Top


stat-size -- GNU Gnulib

Prev: func Up: Particular Modules Top: Top

14.14. stat-size

The stat-size module provides a small number of macros intended for interpreting the file size information in an instance of struct stat.

On POSIX systems, the st_blocks member of struct stat contains the number of disk blocks occupied by a file. The ST_NBLOCKS macro is used to estimate this quantity on systems which don't actually have st_blocks. Each of these blocks contains ST_NBLOCKSIZE bytes.

The value of ST_NBLOCKSIZE is often quite small, small enough that performing I/O in chunks that size would be inefficient. ST_BLKSIZE is the I/O block size recommended for I/O to this file. This is not guaranteed to give optimum performance, but it should be reasonably efficient.

Prev: func Up: Particular Modules Top: Top


Regular expressions -- GNU Gnulib

Next: Overview Prev: Particular Modules Top: Top

15. Regular expressions

Menu

  • Overview
  • Regular Expression Syntax
  • Common Operators
  • GNU Operators
  • GNU Emacs Operators
  • What Gets Matched?
  • Programming with Regex
  • Regular expression syntaxes


Overview -- GNU Gnulib

Next: Regular Expression Syntax Prev: Regular expressions Top: Top

16. Overview

A regular expression (or regexp, or pattern) is a text string that describes some (mathematical) set of strings. A regexp r matches a string s if s is in the set of strings described by r.

Using the Regex library, you can:

  • see if a string matches a specified pattern as a whole, and

  • search within a string for a substring matching a specified pattern.

Some regular expressions match only one string, i.e., the set they describe has only one member. For example, the regular expression `foo' matches the string `foo' and no others. Other regular expressions match more than one string, i.e., the set they describe has more than one member. For example, the regular expression `f*' matches the set of strings made up of any number (including zero) of `f's. As you can see, some characters in regular expressions match themselves (such as `f') and some don't (such as `*'); the ones that don't match themselves instead let you specify patterns that describe many different strings.

To either match or search for a regular expression with the Regex library functions, you must first compile it with a Regex pattern compiling function. A compiled pattern is a regular expression converted to the internal format used by the library functions. Once you've compiled a pattern, you can use it for matching or searching any number of times.

The Regex library is used by including regex.h. Regex provides three groups of functions with which you can operate on regular expressions. One group---the GNU group---is more powerful but not completely compatible with the other two, namely the POSIX and Berkeley Unix groups; its interface was designed specifically for GNU.

We wrote this chapter with programmers in mind, not users of programs---such as Emacs---that use Regex. We describe the Regex library in its entirety, not how to write regular expressions that a particular program understands.

Next: Regular Expression Syntax Prev: Regular expressions Top: Top


Regular Expression Syntax -- GNU Gnulib

Next: Common Operators Prev: Overview Top: Top

17. Regular Expression Syntax

Characters are things you can type. Operators are things in a regular expression that match one or more characters. You compose regular expressions from operators, which in turn you specify using one or more characters.

Most characters represent what we call the match-self operator, i.e., they match themselves; we call these characters ordinary. Other characters represent either all or parts of fancier operators; e.g., `.' represents what we call the match-any-character operator (which, no surprise, matches (almost) any character); we call these characters special. Two different things determine what characters represent what operators:

  1. the regular expression syntax your program has told the Regex library to recognize, and

  2. the context of the character in the regular expression.
In the following sections, we describe these things in more detail.

Menu

  • Syntax Bits
  • Predefined Syntaxes
  • Collating Elements vs. Characters
  • The Backslash Character

    • Next: Common Operators Prev: Overview Top: Top


Syntax Bits -- GNU Gnulib

Next: Predefined Syntaxes Up: Regular Expression Syntax Top: Top

17.1. Syntax Bits

In any particular syntax for regular expressions, some characters are always special, others are sometimes special, and others are never special. The particular syntax that Regex recognizes for a given regular expression depends on the current syntax (as set by re_set_syntax) when the pattern buffer of that regular expression was compiled.

You get a pattern buffer by compiling a regular expression. See GNU Pattern Buffers, for more information on pattern buffers. See GNU Regular Expression Compiling, and BSD Regular Expression Compiling, for more information on compiling.

Regex considers the current syntax to be a collection of bits; we refer to these bits as syntax bits. In most cases, they affect what characters represent what operators. We describe the meanings of the operators to which we refer in Common Operators, GNU Operators, and GNU Emacs Operators.

For reference, here is the complete list of syntax bits, in alphabetical order:

RE_BACKSLASH_ESCAPE_IN_LISTS
If this bit is set, then `\' inside a list (see List Operators quotes (makes ordinary, if it's special) the following character; if this bit isn't set, then `\' is an ordinary character inside lists. (See The Backslash Character, for what `\' does outside of lists.)

RE_BK_PLUS_QM
If this bit is set, then `\+' represents the match-one-or-more operator and `\?' represents the match-zero-or-more operator; if this bit isn't set, then `+' represents the match-one-or-more operator and `?' represents the match-zero-or-one operator. This bit is irrelevant if RE_LIMITED_OPS is set.

RE_CHAR_CLASSES
If this bit is set, then you can use character classes in lists; if this bit isn't set, then you can't.

RE_CONTEXT_INDEP_ANCHORS
If this bit is set, then `^' and `$' are special anywhere outside a list; if this bit isn't set, then these characters are special only in certain contexts. See Match-beginning-of-line Operator, and Match-end-of-line Operator.

RE_CONTEXT_INDEP_OPS
If this bit is set, then certain characters are special anywhere outside a list; if this bit isn't set, then those characters are special only in some contexts and are ordinary elsewhere. Specifically, if this bit isn't set then `*', and (if the syntax bit RE_LIMITED_OPS isn't set) `+' and `?' (or `\+' and `\?', depending on the syntax bit RE_BK_PLUS_QM) represent repetition operators only if they're not first in a regular expression or just after an open-group or alternation operator. The same holds for `{' (or `\{', depending on the syntax bit RE_NO_BK_BRACES) if it is the beginning of a valid interval and the syntax bit RE_INTERVALS is set.

RE_CONTEXT_INVALID_DUP
If this bit is set, then an open-interval operator cannot occur at the start of a regular expression, or immediately after an alternation, open-group or close-interval operator.

RE_CONTEXT_INVALID_OPS
If this bit is set, then repetition and alternation operators can't be in certain positions within a regular expression. Specifically, the regular expression is invalid if it has:

  • a repetition operator first in the regular expression or just after a match-beginning-of-line, open-group, or alternation operator; or

  • an alternation operator first or last in the regular expression, just before a match-end-of-line operator, or just after an alternation or open-group operator.

If this bit isn't set, then you can put the characters representing the repetition and alternation characters anywhere in a regular expression. Whether or not they will in fact be operators in certain positions depends on other syntax bits.

RE_DEBUG
If this bit is set, and the regex library was compiled with -DDEBUG, then internal debugging is turned on; if unset, then it is turned off.

RE_DOT_NEWLINE
If this bit is set, then the match-any-character operator matches a newline; if this bit isn't set, then it doesn't.

RE_DOT_NOT_NULL
If this bit is set, then the match-any-character operator doesn't match a null character; if this bit isn't set, then it does.

RE_HAT_LISTS_NOT_NEWLINE
If this bit is set, nonmatching lists `[^...]' do not match newline; if not set, they do.

RE_ICASE
If this bit is set, then ignore case when matching; otherwise, case is significant.

RE_INTERVALS
If this bit is set, then Regex recognizes interval operators; if this bit isn't set, then it doesn't.

RE_INVALID_INTERVAL_ORD
If this bit is set, a syntactically invalid interval is treated as a string of ordinary characters. For example, the extended regular expression `a{1' is treated as `a\{1'.

RE_LIMITED_OPS
If this bit is set, then Regex doesn't recognize the match-one-or-more, match-zero-or-one or alternation operators; if this bit isn't set, then it does.

RE_NEWLINE_ALT
If this bit is set, then newline represents the alternation operator; if this bit isn't set, then newline is ordinary.

RE_NO_BK_BRACES
If this bit is set, then `{' represents the open-interval operator and `}' represents the close-interval operator; if this bit isn't set, then `\{' represents the open-interval operator and `\}' represents the close-interval operator. This bit is relevant only if RE_INTERVALS is set.

RE_NO_BK_PARENS
If this bit is set, then `(' represents the open-group operator and `)' represents the close-group operator; if this bit isn't set, then `\(' represents the open-group operator and `\)' represents the close-group operator.

RE_NO_BK_REFS
If this bit is set, then Regex doesn't recognize `\'digit as the back reference operator; if this bit isn't set, then it does.

RE_NO_BK_VBAR
If this bit is set, then `|' represents the alternation operator; if this bit isn't set, then `\|' represents the alternation operator. This bit is irrelevant if RE_LIMITED_OPS is set.

RE_NO_EMPTY_RANGES
If this bit is set, then a regular expression with a range whose ending point collates lower than its starting point is invalid; if this bit isn't set, then Regex considers such a range to be empty.

RE_NO_GNU_OPS
If this bit is set, GNU regex operators are not recognized; otherwise, they are.

RE_NO_POSIX_BACKTRACKING
If this bit is set, succeed as soon as we match the whole pattern, without further backtracking. This means that a match may not be the leftmost longest; see What Gets Matched? for what this means.

RE_NO_SUB
If this bit is set, then no_sub will be set to one during re_compile_pattern. This causes matching and searching routines not to record substring match information.

RE_UNMATCHED_RIGHT_PAREN_ORD
If this bit is set and the regular expression has no matching open-group operator, then Regex considers what would otherwise be a close-group operator (based on how RE_NO_BK_PARENS is set) to match `)'.

Next: Predefined Syntaxes Up: Regular Expression Syntax Top: Top


Predefined Syntaxes -- GNU Gnulib

Next: Collating Elements vs. Characters Prev: Syntax Bits Up: Regular Expression Syntax Top: Top

17.2. Predefined Syntaxes

If you're programming with Regex, you can set a pattern buffer's (see GNU Pattern Buffers) syntax either to an arbitrary combination of syntax bits (see Syntax Bits) or else to the configurations defined by Regex. These configurations define the syntaxes used by certain programs---GNU Emacs, POSIX Awk, traditional Awk, Grep, Egrep---in addition to syntaxes for POSIX basic and extended regular expressions.

The predefined syntaxes---taken directly from regex.h---are:

#define RE_SYNTAX_EMACS 0

#define RE_SYNTAX_AWK                                                   \
  (RE_BACKSLASH_ESCAPE_IN_LISTS | RE_DOT_NOT_NULL                       \
   | RE_NO_BK_PARENS            | RE_NO_BK_REFS                         \
   | RE_NO_BK_VBAR               | RE_NO_EMPTY_RANGES                   \
   | RE_UNMATCHED_RIGHT_PAREN_ORD)

#define RE_SYNTAX_POSIX_AWK                                             \
  (RE_SYNTAX_POSIX_EXTENDED | RE_BACKSLASH_ESCAPE_IN_LISTS)

#define RE_SYNTAX_GREP                                                  \
  (RE_BK_PLUS_QM              | RE_CHAR_CLASSES                         \
   | RE_HAT_LISTS_NOT_NEWLINE | RE_INTERVALS                            \
   | RE_NEWLINE_ALT)

#define RE_SYNTAX_EGREP                                                 \
  (RE_CHAR_CLASSES        | RE_CONTEXT_INDEP_ANCHORS                    \
   | RE_CONTEXT_INDEP_OPS | RE_HAT_LISTS_NOT_NEWLINE                    \
   | RE_NEWLINE_ALT       | RE_NO_BK_PARENS                             \
   | RE_NO_BK_VBAR)

#define RE_SYNTAX_POSIX_EGREP                                           \
  (RE_SYNTAX_EGREP | RE_INTERVALS | RE_NO_BK_BRACES)

/* P1003.2/D11.2, section 4.20.7.1, lines 5078ff.  */
#define RE_SYNTAX_ED RE_SYNTAX_POSIX_BASIC

#define RE_SYNTAX_SED RE_SYNTAX_POSIX_BASIC

/* Syntax bits common to both basic and extended POSIX regex syntax.  */
#define _RE_SYNTAX_POSIX_COMMON                                         \
  (RE_CHAR_CLASSES | RE_DOT_NEWLINE      | RE_DOT_NOT_NULL              \
   | RE_INTERVALS  | RE_NO_EMPTY_RANGES)

#define RE_SYNTAX_POSIX_BASIC                                           \
  (_RE_SYNTAX_POSIX_COMMON | RE_BK_PLUS_QM)

/* Differs from ..._POSIX_BASIC only in that RE_BK_PLUS_QM becomes
   RE_LIMITED_OPS, i.e., \? \+ \| are not recognized.  Actually, this
   isn't minimal, since other operators, such as \`, aren't disabled.  */
#define RE_SYNTAX_POSIX_MINIMAL_BASIC                                   \
  (_RE_SYNTAX_POSIX_COMMON | RE_LIMITED_OPS)

#define RE_SYNTAX_POSIX_EXTENDED                                        \
  (_RE_SYNTAX_POSIX_COMMON | RE_CONTEXT_INDEP_ANCHORS                   \
   | RE_CONTEXT_INDEP_OPS  | RE_NO_BK_BRACES                            \
   | RE_NO_BK_PARENS       | RE_NO_BK_VBAR                              \
   | RE_UNMATCHED_RIGHT_PAREN_ORD)

/* Differs from ..._POSIX_EXTENDED in that RE_CONTEXT_INVALID_OPS
   replaces RE_CONTEXT_INDEP_OPS and RE_NO_BK_REFS is added.  */
#define RE_SYNTAX_POSIX_MINIMAL_EXTENDED                                \
  (_RE_SYNTAX_POSIX_COMMON  | RE_CONTEXT_INDEP_ANCHORS                  \
   | RE_CONTEXT_INVALID_OPS | RE_NO_BK_BRACES                           \
   | RE_NO_BK_PARENS        | RE_NO_BK_REFS                             \
   | RE_NO_BK_VBAR          | RE_UNMATCHED_RIGHT_PAREN_ORD)

Next: Collating Elements vs. Characters Prev: Syntax Bits Up: Regular Expression Syntax Top: Top


Collating Elements vs. Characters -- GNU Gnulib

Next: The Backslash Character Prev: Predefined Syntaxes Up: Regular Expression Syntax Top: Top

17.3. Collating Elements vs. Characters

POSIX generalizes the notion of a character to that of a collating element. It defines a collating element to be ``a sequence of one or more bytes defined in the current collating sequence as a unit of collation.''

This generalizes the notion of a character in two ways. First, a single character can map into two or more collating elements. For example, the German ``es-zet'' collates as the collating element `s' followed by another collating element `s'. Second, two or more characters can map into one collating element. For example, the Spanish `ll' collates after `l' and before `m'.

Since POSIX's ``collating element'' preserves the essential idea of a ``character,'' we use the latter, more familiar, term in this document.

Next: The Backslash Character Prev: Predefined Syntaxes Up: Regular Expression Syntax Top: Top


The Backslash Character -- GNU Gnulib

Prev: Collating Elements vs. Characters Up: Regular Expression Syntax Top: Top

17.4. The Backslash Character

The `\' character has one of four different meanings, depending on the context in which you use it and what syntax bits are set (see Syntax Bits). It can: 1) stand for itself, 2) quote the next character, 3) introduce an operator, or 4) do nothing.

  1. It stands for itself inside a list (see List Operators) if the syntax bit RE_BACKSLASH_ESCAPE_IN_LISTS is not set. For example, `[\]' would match `\'.

  2. It quotes (makes ordinary, if it's special) the next character when you use it either:

    • outside a list,(1) or

    • inside a list and the syntax bit RE_BACKSLASH_ESCAPE_IN_LISTS is set.

  3. It introduces an operator when followed by certain ordinary characters---sometimes only when certain syntax bits are set. See the cases RE_BK_PLUS_QM, RE_NO_BK_BRACES, RE_NO_BK_VAR, RE_NO_BK_PARENS, RE_NO_BK_REF in Syntax Bits. Also:

    • `\b' represents the match-word-boundary operator (see Match-word-boundary Operator).

    • `\B' represents the match-within-word operator (see Match-within-word Operator).

    • `\<' represents the match-beginning-of-word operator * (see Match-beginning-of-word Operator).

    • `\>' represents the match-end-of-word operator (see Match-end-of-word Operator).

    • `\w' represents the match-word-constituent operator (see Match-word-constituent Operator).

    • `\W' represents the match-non-word-constituent operator (see Match-non-word-constituent Operator).

    • `\`' represents the match-beginning-of-buffer operator and `\'' represents the match-end-of-buffer operator (see Buffer Operators).

    • If Regex was compiled with the C preprocessor symbol emacs defined, then `\sclass' represents the match-syntactic-class operator and `\Sclass' represents the match-not-syntactic-class operator (see Syntactic Class Operators).

  4. In all other cases, Regex ignores `\'. For example, `\n' matches `n'.

Footnotes

(1) Sometimes you don't have to explicitly quote special characters to make them ordinary. For instance, most characters lose any special meaning inside a list (see List Operators). In addition, if the syntax bits RE_CONTEXT_INVALID_OPS and RE_CONTEXT_INDEP_OPS aren't set, then (for historical reasons) the matcher considers special characters ordinary if they are in contexts where the operations they represent make no sense; for example, then the match-zero-or-more operator (represented by `*') matches itself in the regular expression `*foo' because there is no preceding expression on which it can operate. It is poor practice, however, to depend on this behavior; if you want a special character to be ordinary outside a list, it's better to always quote it, regardless.

Prev: Collating Elements vs. Characters Up: Regular Expression Syntax Top: Top


Common Operators -- GNU Gnulib

Next: GNU Operators Prev: Regular Expression Syntax Top: Top

18. Common Operators

You compose regular expressions from operators. In the following sections, we describe the regular expression operators specified by POSIX; GNU also uses these. Most operators have more than one representation as characters. See Regular Expression Syntax, for what characters represent what operators under what circumstances.

For most operators that can be represented in two ways, one representation is a single character and the other is that character preceded by `\'. For example, either `(' or `\(' represents the open-group operator. Which one does depends on the setting of a syntax bit, in this case RE_NO_BK_PARENS. Why is this so? Historical reasons dictate some of the varying representations, while POSIX dictates others.

Finally, almost all characters lose any special meaning inside a list (see List Operators).

Menu

  • Match-self Operator Ordinary characters.
  • Match-any-character Operator .
  • Concatenation Operator Juxtaposition.
  • Repetition Operators * + ? {}
  • Alternation Operator |
  • List Operators [...] [^...]
  • Grouping Operators (...)
  • Back-reference Operator \digit
  • Anchoring Operators ^ $

    • Next: GNU Operators Prev: Regular Expression Syntax Top: Top


Match-self Operator -- GNU Gnulib

Next: Match-any-character Operator Up: Common Operators Top: Top

18.1. The Match-self Operator (ordinary character)

This operator matches the character itself. All ordinary characters (see Regular Expression Syntax) represent this operator. For example, `f' is always an ordinary character, so the regular expression `f' matches only the string `f'. In particular, it does not match the string `ff'.

Next: Match-any-character Operator Up: Common Operators Top: Top


Match-any-character Operator -- GNU Gnulib

Next: Concatenation Operator Prev: Match-self Operator Up: Common Operators Top: Top

18.2. The Match-any-character Operator (.)

This operator matches any single printing or nonprinting character except it won't match a:

newline
if the syntax bit RE_DOT_NEWLINE isn't set.

null
if the syntax bit RE_DOT_NOT_NULL is set.

The `.' (period) character represents this operator. For example, `a.b' matches any three-character string beginning with `a' and ending with `b'.

Next: Concatenation Operator Prev: Match-self Operator Up: Common Operators Top: Top


Concatenation Operator -- GNU Gnulib

Next: Repetition Operators Prev: Match-any-character Operator Up: Common Operators Top: Top

18.3. The Concatenation Operator

This operator concatenates two regular expressions a and b. No character represents this operator; you simply put b after a. The result is a regular expression that will match a string if a matches its first part and b matches the rest. For example, `xy' (two match-self operators) matches `xy'.

Next: Repetition Operators Prev: Match-any-character Operator Up: Common Operators Top: Top


Repetition Operators -- GNU Gnulib

Next: Alternation Operator Prev: Concatenation Operator Up: Common Operators Top: Top

18.4. Repetition Operators

Repetition operators repeat the preceding regular expression a specified number of times.

Menu

  • Match-zero-or-more Operator *
  • Match-one-or-more Operator +
  • Match-zero-or-one Operator ?
  • Interval Operators {}

    • Next: Alternation Operator Prev: Concatenation Operator Up: Common Operators Top: Top


Match-zero-or-more Operator -- GNU Gnulib

Next: Match-one-or-more Operator Up: Repetition Operators Top: Top

18.4.1. The Match-zero-or-more Operator (*)

This operator repeats the smallest possible preceding regular expression as many times as necessary (including zero) to match the pattern. `*' represents this operator. For example, `o*' matches any string made up of zero or more `o's. Since this operator operates on the smallest preceding regular expression, `fo*' has a repeating `o', not a repeating `fo'. So, `fo*' matches `f', `fo', `foo', and so on.

Since the match-zero-or-more operator is a suffix operator, it may be useless as such when no regular expression precedes it. This is the case when it:

  • is first in a regular expression, or

  • follows a match-beginning-of-line, open-group, or alternation operator.

Three different things can happen in these cases:

  1. If the syntax bit RE_CONTEXT_INVALID_OPS is set, then the regular expression is invalid.

  2. If RE_CONTEXT_INVALID_OPS isn't set, but RE_CONTEXT_INDEP_OPS is, then `*' represents the match-zero-or-more operator (which then operates on the empty string).

  3. Otherwise, `*' is ordinary.

The matcher processes a match-zero-or-more operator by first matching as many repetitions of the smallest preceding regular expression as it can. Then it continues to match the rest of the pattern.

If it can't match the rest of the pattern, it backtracks (as many times as necessary), each time discarding one of the matches until it can either match the entire pattern or be certain that it cannot get a match. For example, when matching `ca*ar' against `caaar', the matcher first matches all three `a's of the string with the `a*' of the regular expression. However, it cannot then match the final `ar' of the regular expression against the final `r' of the string. So it backtracks, discarding the match of the last `a' in the string. It can then match the remaining `ar'.

Next: Match-one-or-more Operator Up: Repetition Operators Top: Top


Match-one-or-more Operator -- GNU Gnulib

Next: Match-zero-or-one Operator Prev: Match-zero-or-more Operator Up: Repetition Operators Top: Top

18.4.2. The Match-one-or-more Operator (+ or \+)

If the syntax bit RE_LIMITED_OPS is set, then Regex doesn't recognize this operator. Otherwise, if the syntax bit RE_BK_PLUS_QM isn't set, then `+' represents this operator; if it is, then `\+' does.

This operator is similar to the match-zero-or-more operator except that it repeats the preceding regular expression at least once; see Match-zero-or-more Operator, for what it operates on, how some syntax bits affect it, and how Regex backtracks to match it.

For example, supposing that `+' represents the match-one-or-more operator; then `ca+r' matches, e.g., `car' and `caaaar', but not `cr'.

Next: Match-zero-or-one Operator Prev: Match-zero-or-more Operator Up: Repetition Operators Top: Top


Match-zero-or-one Operator -- GNU Gnulib

Next: Interval Operators Prev: Match-one-or-more Operator Up: Repetition Operators Top: Top

18.4.3. The Match-zero-or-one Operator (? or \?)

If the syntax bit RE_LIMITED_OPS is set, then Regex doesn't recognize this operator. Otherwise, if the syntax bit RE_BK_PLUS_QM isn't set, then `?' represents this operator; if it is, then `\?' does.

This operator is similar to the match-zero-or-more operator except that it repeats the preceding regular expression once or not at all; see Match-zero-or-more Operator, to see what it operates on, how some syntax bits affect it, and how Regex backtracks to match it.

For example, supposing that `?' represents the match-zero-or-one operator; then `ca?r' matches both `car' and `cr', but nothing else.

Next: Interval Operators Prev: Match-one-or-more Operator Up: Repetition Operators Top: Top


Interval Operators -- GNU Gnulib

Prev: Match-zero-or-one Operator Up: Repetition Operators Top: Top

18.4.4. Interval Operators ({ ... } or \{ ... \})

If the syntax bit RE_INTERVALS is set, then Regex recognizes interval expressions. They repeat the smallest possible preceding regular expression a specified number of times.

If the syntax bit RE_NO_BK_BRACES is set, `{' represents the open-interval operator and `}' represents the close-interval operator ; otherwise, `\{' and `\}' do.

Specifically, supposing that `{' and `}' represent the open-interval and close-interval operators; then:

{count}
matches exactly count occurrences of the preceding regular expression.

{min,}
matches min or more occurrences of the preceding regular expression.

{min, max}
matches at least min but no more than max occurrences of the preceding regular expression.

The interval expression (but not necessarily the regular expression that contains it) is invalid if:

  • min is greater than max, or

  • any of count, min, or max are outside the range zero to RE_DUP_MAX (which symbol regex.h defines).

If the interval expression is invalid and the syntax bit RE_NO_BK_BRACES is set, then Regex considers all the characters in the would-be interval to be ordinary. If that bit isn't set, then the regular expression is invalid.

If the interval expression is valid but there is no preceding regular expression on which to operate, then if the syntax bit RE_CONTEXT_INVALID_OPS is set, the regular expression is invalid. If that bit isn't set, then Regex considers all the characters---other than backslashes, which it ignores---in the would-be interval to be ordinary.

Prev: Match-zero-or-one Operator Up: Repetition Operators Top: Top


Alternation Operator -- GNU Gnulib

Next: List Operators Prev: Repetition Operators Up: Common Operators Top: Top

18.5. The Alternation Operator (| or \|)

If the syntax bit RE_LIMITED_OPS is set, then Regex doesn't recognize this operator. Otherwise, if the syntax bit RE_NO_BK_VBAR is set, then `|' represents this operator; otherwise, `\|' does.

Alternatives match one of a choice of regular expressions: if you put the character(s) representing the alternation operator between any two regular expressions a and b, the result matches the union of the strings that a and b match. For example, supposing that `|' is the alternation operator, then `foo|bar|quux' would match any of `foo', `bar' or `quux'.

The alternation operator operates on the largest possible surrounding regular expressions. (Put another way, it has the lowest precedence of any regular expression operator.) Thus, the only way you can delimit its arguments is to use grouping. For example, if `(' and `)' are the open and close-group operators, then `fo(o|b)ar' would match either `fooar' or `fobar'. (`foo|bar' would match `foo' or `bar'.)

The matcher usually tries all combinations of alternatives so as to match the longest possible string. For example, when matching `(fooq|foo)*(qbarquux|bar)' against `fooqbarquux', it cannot take, say, the first (``depth-first'') combination it could match, since then it would be content to match just `fooqbar'.

Note that since the default behavior is to return the leftmost longest match, when more than one of a series of alternatives matches the actual match will be the longest matching alternative, not necessarily the first in the list.

Next: List Operators Prev: Repetition Operators Up: Common Operators Top: Top


List Operators -- GNU Gnulib

Next: Grouping Operators Prev: Alternation Operator Up: Common Operators Top: Top

18.6. List Operators ([ ... ] and [^ ... ])

Lists, also called bracket expressions, are a set of one or more items. An item is a character, a collating symbol, an equivalence class expression, a character class expression, or a range expression. The syntax bits affect which kinds of items you can put in a list. We explain the last four items in subsections below. Empty lists are invalid.

A matching list matches a single character represented by one of the list items. You form a matching list by enclosing one or more items within an open-matching-list operator (represented by `[') and a close-list operator (represented by `]').

For example, `[ab]' matches either `a' or `b'. `[ad]*' matches the empty string and any string composed of just `a's and `d's in any order. Regex considers invalid a regular expression with a `[' but no matching `]'.

Nonmatching lists are similar to matching lists except that they match a single character not represented by one of the list items. You use an open-nonmatching-list operator (represented by `[^'(1)) instead of an open-matching-list operator to start a nonmatching list.

For example, `[^ab]' matches any character except `a' or `b'.

If the syntax bit RE_HAT_LISTS_NOT_NEWLINE is set, then nonmatching lists do not match a newline.

Most characters lose any special meaning inside a list. The special characters inside a list follow.

`]'
ends the list if it's not the first list item. So, if you want to make the `]' character a list item, you must put it first.

`\'
quotes the next character if the syntax bit RE_BACKSLASH_ESCAPE_IN_LISTS is set.

`[.'
represents the open-collating-symbol operator (see Collating Symbol Operators).

`.]'
represents the close-collating-symbol operator.

`[='
represents the open-equivalence-class operator (see Equivalence Class Operators).

`=]'
represents the close-equivalence-class operator.

`[:'
represents the open-character-class operator (see Character Class Operators) if the syntax bit RE_CHAR_CLASSES is set and what follows is a valid character class expression.

`:]'
represents the close-character-class operator if the syntax bit RE_CHAR_CLASSES is set and what precedes it is an open-character-class operator followed by a valid character class name.

`-'
represents the range operator (see Range Operator) if it's not first or last in a list or the ending point of a range.

All other characters are ordinary. For example, `[.*]' matches `.' and `*'.

Menu

  • Collating Symbol Operators [.elem.]
  • Equivalence Class Operators [=class=]
  • Character Class Operators [:class:]
  • Range Operator start-end

    • Footnotes

    (1) Regex therefore doesn't consider the `^' to be the first character in the list. If you put a `^' character first in (what you think is) a matching list, you'll turn it into a nonmatching list.

    Next: Grouping Operators Prev: Alternation Operator Up: Common Operators Top: Top


Collating Symbol Operators -- GNU Gnulib

Next: Equivalence Class Operators Up: List Operators Top: Top

18.6.1. Collating Symbol Operators ([. ... .])

Collating symbols can be represented inside lists. You form a collating symbol by putting a collating element between an open-collating-symbol operator and a close-collating-symbol operator. `[.' represents the open-collating-symbol operator and `.]' represents the close-collating-symbol operator. For example, if `ll' is a collating element, then `[[.ll.]]' would match `ll'.

Next: Equivalence Class Operators Up: List Operators Top: Top


Equivalence Class Operators -- GNU Gnulib

Next: Character Class Operators Prev: Collating Symbol Operators Up: List Operators Top: Top

18.6.2. Equivalence Class Operators ([= ... =])

Regex recognizes equivalence class expressions inside lists. A equivalence class expression is a set of collating elements which all belong to the same equivalence class. You form an equivalence class expression by putting a collating element between an open-equivalence-class operator and a close-equivalence-class operator. `[=' represents the open-equivalence-class operator and `=]' represents the close-equivalence-class operator. For example, if `a' and `A' were an equivalence class, then both `[[=a=]]' and `[[=A=]]' would match both `a' and `A'. If the collating element in an equivalence class expression isn't part of an equivalence class, then the matcher considers the equivalence class expression to be a collating symbol.

Next: Character Class Operators Prev: Collating Symbol Operators Up: List Operators Top: Top


Character Class Operators -- GNU Gnulib

Next: Range Operator Prev: Equivalence Class Operators Up: List Operators Top: Top

18.6.3. Character Class Operators ([: ... :])

If the syntax bit RE_CHAR_CLASSES is set, then Regex recognizes character class expressions inside lists. A character class expression matches one character from a given class. You form a character class expression by putting a character class name between an open-character-class operator (represented by `[:') and a close-character-class operator (represented by `:]'). The character class names and their meanings are:

alnum
letters and digits

alpha
letters

blank
system-dependent; for GNU, a space or tab

cntrl
control characters (in the ASCII encoding, code 0177 and codes less than 040)

digit
digits

graph
same as print except omits space

lower
lowercase letters

print
printable characters (in the ASCII encoding, space tilde---codes 040 through 0176)

punct
neither control nor alphanumeric characters

space
space, carriage return, newline, vertical tab, and form feed

upper
uppercase letters

xdigit
hexadecimal digits: 0--9, a--f, A--F

These correspond to the definitions in the C library's <ctype.h> facility. For example, `[:alpha:]' corresponds to the standard facility isalpha. Regex recognizes character class expressions only inside of lists; so `[[:alpha:]]' matches any letter, but `[:alpha:]' outside of a bracket expression and not followed by a repetition operator matches just itself.

Next: Range Operator Prev: Equivalence Class Operators Up: List Operators Top: Top


Range Operator -- GNU Gnulib

Prev: Character Class Operators Up: List Operators Top: Top

18.6.4. The Range Operator (-)

Regex recognizes range expressions inside a list. They represent those characters that fall between two elements in the current collating sequence. You form a range expression by putting a range operator between two of any of the following: characters, collating elements, collating symbols, and equivalence class expressions. The starting point of the range and the ending point of the range don't have to be the same kind of item, e.g., the starting point could be a collating element and the ending point could be an equivalence class expression. If a range's ending point is an equivalence class, then all the collating elements in that class will be in the range.(1) `-' represents the range operator. For example, `a-f' within a list represents all the characters from `a' through `f' inclusively.

If the syntax bit RE_NO_EMPTY_RANGES is set, then if the range's ending point collates less than its starting point, the range (and the regular expression containing it) is invalid. For example, the regular expression `[z-a]' would be invalid. If this bit isn't set, then Regex considers such a range to be empty.

Since `-' represents the range operator, if you want to make a `-' character itself a list item, you must do one of the following:

  • Put the `-' either first or last in the list.

  • Include a range whose starting point collates strictly lower than `-' and whose ending point collates equal or higher. Unless a range is the first item in a list, a `-' can't be its starting point, but can be its ending point. That is because Regex considers `-' to be the range operator unless it is preceded by another `-'. For example, in the ASCII encoding, `)', `*', `+', `,', `-', `.', and `/' are contiguous characters in the collating sequence. You might think that `[)-+--/]' has two ranges: `)-+' and `--/'. Rather, it has the ranges `)-+' and `+--', plus the character `/', so it matches, e.g., `,', not `.'.

  • Put a range whose starting point is `-' first in the list.

For example, `[-a-z]' matches a lowercase letter or a hyphen (in English, in ASCII).

Footnotes

(1) You can't use a character class for the starting or ending point of a range, since a character class is not a single character.

Prev: Character Class Operators Up: List Operators Top: Top


Grouping Operators -- GNU Gnulib

Next: Back-reference Operator Prev: List Operators Up: Common Operators Top: Top

18.7. Grouping Operators (( ... ) or \( ... \))

A group, also known as a subexpression, consists of an open-group operator, any number of other operators, and a close-group operator. Regex treats this sequence as a unit, just as mathematics and programming languages treat a parenthesized expression as a unit.

Therefore, using groups, you can:

  • delimit the argument(s) to an alternation operator (see Alternation Operator) or a repetition operator (see Repetition Operators).

  • keep track of the indices of the substring that matched a given group. See Using Registers, for a precise explanation. This lets you:

    • use the back-reference operator (see Back-reference Operator).

    • use registers (see Using Registers).

If the syntax bit RE_NO_BK_PARENS is set, then `(' represents the open-group operator and `)' represents the close-group operator; otherwise, `\(' and `\)' do.

If the syntax bit RE_UNMATCHED_RIGHT_PAREN_ORD is set and a close-group operator has no matching open-group operator, then Regex considers it to match `)'.

Next: Back-reference Operator Prev: List Operators Up: Common Operators Top: Top


Back-reference Operator -- GNU Gnulib

Next: Anchoring Operators Prev: Grouping Operators Up: Common Operators Top: Top

18.8. The Back-reference Operator (\digit)

If the syntax bit RE_NO_BK_REF isn't set, then Regex recognizes back references. A back reference matches a specified preceding group. The back reference operator is represented by `\digit' anywhere after the end of a regular expression's digit-th group (see Grouping Operators).

digit must be between `1' and `9'. The matcher assigns numbers 1 through 9 to the first nine groups it encounters. By using one of `\1' through `\9' after the corresponding group's close-group operator, you can match a substring identical to the one that the group does.

Back references match according to the following (in all examples below, `(' represents the open-group, `)' the close-group, `{' the open-interval and `}' the close-interval operator):

  • If the group matches a substring, the back reference matches an identical substring. For example, `(a)\1' matches `aa' and `(bana)na\1bo\1' matches `bananabanabobana'. Likewise, `(.*)\1' matches any (newline-free if the syntax bit RE_DOT_NEWLINE isn't set) string that is composed of two identical halves; the `(.*)' matches the first half and the `\1' matches the second half.

  • If the group matches more than once (as it might if followed by, e.g., a repetition operator), then the back reference matches the substring the group last matched. For example, `((a*)b)*\1\2' matches `aabababa'; first group 1 (the outer one) matches `aab' and group 2 (the inner one) matches `aa'. Then group 1 matches `ab' and group 2 matches `a'. So, `\1' matches `ab' and `\2' matches `a'.

  • If the group doesn't participate in a match, i.e., it is part of an alternative not taken or a repetition operator allows zero repetitions of it, then the back reference makes the whole match fail. For example, `(one()|two())-and-(three\2|four\3)' matches `one-and-three' and `two-and-four', but not `one-and-four' or `two-and-three'. For example, if the pattern matches `one-and-', then its group 2 matches the empty string and its group 3 doesn't participate in the match. So, if it then matches `four', then when it tries to back reference group 3---which it will attempt to do because `\3' follows the `four'---the match will fail because group 3 didn't participate in the match.

You can use a back reference as an argument to a repetition operator. For example, `(a(b))\2*' matches `a' followed by two or more `b's. Similarly, `(a(b))\2{3}' matches `abbbb'.

If there is no preceding digit-th subexpression, the regular expression is invalid.

Next: Anchoring Operators Prev: Grouping Operators Up: Common Operators Top: Top


Anchoring Operators -- GNU Gnulib

Prev: Back-reference Operator Up: Common Operators Top: Top

18.9. Anchoring Operators

These operators can constrain a pattern to match only at the beginning or end of the entire string or at the beginning or end of a line.

Menu

  • Match-beginning-of-line Operator ^
  • Match-end-of-line Operator $


Match-beginning-of-line Operator -- GNU Gnulib

Next: Match-end-of-line Operator Up: Anchoring Operators Top: Top

18.9.1. The Match-beginning-of-line Operator (^)

This operator can match the empty string either at the beginning of the string or after a newline character. Thus, it is said to anchor the pattern to the beginning of a line.

In the cases following, `^' represents this operator. (Otherwise, `^' is ordinary.)

  • It (the `^') is first in the pattern, as in `^foo'.

  • The syntax bit RE_CONTEXT_INDEP_ANCHORS is set, and it is outside a bracket expression.

  • It follows an open-group or alternation operator, as in `a\(^b\)' and `a\|^b'. See Grouping Operators, and Alternation Operator.

These rules imply that some valid patterns containing `^' cannot be matched; for example, `foo^bar' if RE_CONTEXT_INDEP_ANCHORS is set.

If the not_bol field is set in the pattern buffer (see GNU Pattern Buffers), then `^' fails to match at the beginning of the string. This lets you match against pieces of a line, as you would need to if, say, searching for repeated instances of a given pattern in a line; it would work correctly for patterns both with and without match-beginning-of-line operators.

Next: Match-end-of-line Operator Up: Anchoring Operators Top: Top


Match-end-of-line Operator -- GNU Gnulib

Prev: Match-beginning-of-line Operator Up: Anchoring Operators Top: Top

18.9.2. The Match-end-of-line Operator ($)

This operator can match the empty string either at the end of the string or before a newline character in the string. Thus, it is said to anchor the pattern to the end of a line.

It is always represented by `$'. For example, `foo$' usually matches, e.g., `foo' and, e.g., the first three characters of `foo\nbar'.

Its interaction with the syntax bits and pattern buffer fields is exactly the dual of `^''s; see the previous section. (That is, ```^''' becomes ```$''', ``beginning'' becomes ``end'', ``next'' becomes ``previous'', ``after'' becomes ``before'', and ``not_bol'' becomes ``not_eol''.)

Prev: Match-beginning-of-line Operator Up: Anchoring Operators Top: Top


GNU Operators -- GNU Gnulib

Next: GNU Emacs Operators Prev: Common Operators Top: Top

19. GNU Operators

Following are operators that GNU defines (and POSIX doesn't).

Menu

  • Word Operators
  • Buffer Operators


Word Operators -- GNU Gnulib

Next: Buffer Operators Up: GNU Operators Top: Top

19.1. Word Operators

The operators in this section require Regex to recognize parts of words. Regex uses a syntax table to determine whether or not a character is part of a word, i.e., whether or not it is word-constituent.

Menu

  • Non-Emacs Syntax Tables
  • Match-word-boundary Operator \b
  • Match-within-word Operator \B
  • Match-beginning-of-word Operator \<
  • Match-end-of-word Operator \>
  • Match-word-constituent Operator \w
  • Match-non-word-constituent Operator \W

    • Next: Buffer Operators Up: GNU Operators Top: Top


Non-Emacs Syntax Tables -- GNU Gnulib

Next: Match-word-boundary Operator Up: Word Operators Top: Top

19.1.1. Non-Emacs Syntax Tables

A syntax table is an array indexed by the characters in your character set. In the ASCII encoding, therefore, a syntax table has 256 elements. Regex always uses a char * variable re_syntax_table as its syntax table. In some cases, it initializes this variable and in others it expects you to initialize it.

  • If Regex is compiled with the preprocessor symbols emacs and SYNTAX_TABLE both undefined, then Regex allocates re_syntax_table and initializes an element i either to Sword (which it defines) if i is a letter, number, or `_', or to zero if it's not.

  • If Regex is compiled with emacs undefined but SYNTAX_TABLE defined, then Regex expects you to define a char * variable re_syntax_table to be a valid syntax table.

  • See Emacs Syntax Tables, for what happens when Regex is compiled with the preprocessor symbol emacs defined.

Next: Match-word-boundary Operator Up: Word Operators Top: Top


Match-word-boundary Operator -- GNU Gnulib

Next: Match-within-word Operator Prev: Non-Emacs Syntax Tables Up: Word Operators Top: Top

19.1.2. The Match-word-boundary Operator (\b)

This operator (represented by `\b') matches the empty string at either the beginning or the end of a word. For example, `\brat\b' matches the separate word `rat'.

Next: Match-within-word Operator Prev: Non-Emacs Syntax Tables Up: Word Operators Top: Top


Match-within-word Operator -- GNU Gnulib

Next: Match-beginning-of-word Operator Prev: Match-word-boundary Operator Up: Word Operators Top: Top

19.1.3. The Match-within-word Operator (\B)

This operator (represented by `\B') matches the empty string within a word. For example, `c\Brat\Be' matches `crate', but `dirty \Brat' doesn't match `dirty rat'.

Next: Match-beginning-of-word Operator Prev: Match-word-boundary Operator Up: Word Operators Top: Top


Match-beginning-of-word Operator -- GNU Gnulib

Next: Match-end-of-word Operator Prev: Match-within-word Operator Up: Word Operators Top: Top

19.1.4. The Match-beginning-of-word Operator (\<)

This operator (represented by `\<') matches the empty string at the beginning of a word.


Match-end-of-word Operator -- GNU Gnulib

Next: Match-word-constituent Operator Prev: Match-beginning-of-word Operator Up: Word Operators Top: Top

19.1.5. The Match-end-of-word Operator (\>)

This operator (represented by `\>') matches the empty string at the end of a word.


Match-word-constituent Operator -- GNU Gnulib

Next: Match-non-word-constituent Operator Prev: Match-end-of-word Operator Up: Word Operators Top: Top

19.1.6. The Match-word-constituent Operator (\w)

This operator (represented by `\w') matches any word-constituent character.


Match-non-word-constituent Operator -- GNU Gnulib

Prev: Match-word-constituent Operator Up: Word Operators Top: Top

19.1.7. The Match-non-word-constituent Operator (\W)

This operator (represented by `\W') matches any character that is not word-constituent.


Buffer Operators -- GNU Gnulib

Prev: Word Operators Up: GNU Operators Top: Top

19.2. Buffer Operators

Following are operators which work on buffers. In Emacs, a buffer is, naturally, an Emacs buffer. For other programs, Regex considers the entire string to be matched as the buffer.

Menu

  • Match-beginning-of-buffer Operator \`
  • Match-end-of-buffer Operator \'

    • Prev: Word Operators Up: GNU Operators Top: Top


Match-beginning-of-buffer Operator -- GNU Gnulib

Next: Match-end-of-buffer Operator Up: Buffer Operators Top: Top

19.2.1. The Match-beginning-of-buffer Operator (\`)

This operator (represented by `\`') matches the empty string at the beginning of the buffer.


Match-end-of-buffer Operator -- GNU Gnulib

Prev: Match-beginning-of-buffer Operator Up: Buffer Operators Top: Top

19.2.2. The Match-end-of-buffer Operator (\')

This operator (represented by `\'') matches the empty string at the end of the buffer.


GNU Emacs Operators -- GNU Gnulib

Next: What Gets Matched? Prev: GNU Operators Top: Top

20. GNU Emacs Operators

Following are operators that GNU defines (and POSIX doesn't) that you can use only when Regex is compiled with the preprocessor symbol emacs defined.

Menu

  • Syntactic Class Operators


Syntactic Class Operators -- GNU Gnulib

Up: GNU Emacs Operators Top: Top

20.1. Syntactic Class Operators

The operators in this section require Regex to recognize the syntactic classes of characters. Regex uses a syntax table to determine this.

Menu

  • Emacs Syntax Tables
  • Match-syntactic-class Operator \sCLASS
  • Match-not-syntactic-class Operator \SCLASS


Emacs Syntax Tables -- GNU Gnulib

Next: Match-syntactic-class Operator Up: Syntactic Class Operators Top: Top

20.1.1. Emacs Syntax Tables

A syntax table is an array indexed by the characters in your character set. In the ASCII encoding, therefore, a syntax table has 256 elements.

If Regex is compiled with the preprocessor symbol emacs defined, then Regex expects you to define and initialize the variable re_syntax_table to be an Emacs syntax table. Emacs' syntax tables are more complicated than Regex's own (see Non-Emacs Syntax Tables). See Syntax, for a description of Emacs' syntax tables.

Next: Match-syntactic-class Operator Up: Syntactic Class Operators Top: Top


Match-syntactic-class Operator -- GNU Gnulib

Next: Match-not-syntactic-class Operator Prev: Emacs Syntax Tables Up: Syntactic Class Operators Top: Top

20.1.2. The Match-syntactic-class Operator (\s class)

This operator matches any character whose syntactic class is represented by a specified character. `\sclass' represents this operator where class is the character representing the syntactic class you want. For example, `w' represents the syntactic class of word-constituent characters, so `\sw' matches any word-constituent character.

Next: Match-not-syntactic-class Operator Prev: Emacs Syntax Tables Up: Syntactic Class Operators Top: Top


Match-not-syntactic-class Operator -- GNU Gnulib

Prev: Match-syntactic-class Operator Up: Syntactic Class Operators Top: Top

20.1.3. The Match-not-syntactic-class Operator (\S class)

This operator is similar to the match-syntactic-class operator except that it matches any character whose syntactic class is not represented by the specified character. `\Sclass' represents this operator. For example, `w' represents the syntactic class of word-constituent characters, so `\Sw' matches any character that is not word-constituent.

Prev: Match-syntactic-class Operator Up: Syntactic Class Operators Top: Top


What Gets Matched? -- GNU Gnulib

Next: Programming with Regex Prev: GNU Emacs Operators Top: Top

21. What Gets Matched?

Regex usually matches strings according to the ``leftmost longest'' rule; that is, it chooses the longest of the leftmost matches. This does not mean that for a regular expression containing subexpressions that it simply chooses the longest match for each subexpression, left to right; the overall match must also be the longest possible one.

For example, `(ac*)(c*d[ac]*)\1' matches `acdacaaa', not `acdac', as it would if it were to choose the longest match for the first subexpression.

Next: Programming with Regex Prev: GNU Emacs Operators Top: Top


Programming with Regex -- GNU Gnulib

Next: Build Infrastructure Modules Prev: What Gets Matched? Top: Top

22. Programming with Regex

Here we describe how you use the Regex data structures and functions in C programs. Regex has three interfaces: one designed for GNU, one compatible with POSIX (as specified by POSIX, draft 1003.2/D11.2), and one compatible with Berkeley Unix. The POSIX interface is not documented here; see the documentation of GNU libc, or the POSIX man pages. The Berkeley Unix interface is documented here for convenience, since its documentation is not otherwise readily available on GNU systems.

Menu

  • GNU Regex Functions
  • BSD Regex Functions

    • Next: Build Infrastructure Modules Prev: What Gets Matched? Top: Top


GNU Regex Functions -- GNU Gnulib

Next: BSD Regex Functions Up: Programming with Regex Top: Top

22.1. GNU Regex Functions

If you're writing code that doesn't need to be compatible with either POSIX or Berkeley Unix, you can use these functions. They provide more options than the other interfaces.

Menu

  • GNU Pattern Buffers The re_pattern_buffer type.
  • GNU Regular Expression Compiling re_compile_pattern ()
  • GNU Matching re_match ()
  • GNU Searching re_search ()
  • Matching/Searching with Split Data re_match_2 (), re_search_2 ()
  • Searching with Fastmaps re_compile_fastmap ()
  • GNU Translate Tables The translate field.
  • Using Registers The re_registers type and related fns.
  • Freeing GNU Pattern Buffers regfree ()

    • Next: BSD Regex Functions Up: Programming with Regex Top: Top


GNU Pattern Buffers -- GNU Gnulib

Next: GNU Regular Expression Compiling Up: GNU Regex Functions Top: Top

22.1.1. GNU Pattern Buffers

To compile, match, or search for a given regular expression, you must supply a pattern buffer. A pattern buffer holds one compiled regular expression.(1)

You can have several different pattern buffers simultaneously, each holding a compiled pattern for a different regular expression.

regex.h defines the pattern buffer struct with the following public fields:

  unsigned char *buffer;
  unsigned long allocated;
  char *fastmap;
  char *translate;
  size_t re_nsub;
  unsigned no_sub : 1;
  unsigned not_bol : 1;
  unsigned not_eol : 1;

Footnotes

(1) Regular expressions are also referred to as ``patterns,'' hence the name ``pattern buffer.''

Next: GNU Regular Expression Compiling Up: GNU Regex Functions Top: Top


GNU Regular Expression Compiling -- GNU Gnulib

Next: GNU Matching Prev: GNU Pattern Buffers Up: GNU Regex Functions Top: Top

22.1.2. GNU Regular Expression Compiling

In GNU, you can both match and search for a given regular expression. To do either, you must first compile it in a pattern buffer (see GNU Pattern Buffers).

Regular expressions match according to the syntax with which they were compiled; with GNU, you indicate what syntax you want by setting the variable re_syntax_options (declared in regex.h) before calling the compiling function, re_compile_pattern (see below). See Syntax Bits, and Predefined Syntaxes.

You can change the value of re_syntax_options at any time. Usually, however, you set its value once and then never change it.

re_compile_pattern takes a pattern buffer as an argument. You must initialize the following fields:

translate initialization
translate
Initialize this to point to a translate table if you want one, or to zero if you don't. We explain translate tables in GNU Translate Tables.

fastmap
Initialize this to nonzero if you want a fastmap, or to zero if you don't.

buffer
allocated
If you want re_compile_pattern to allocate memory for the compiled pattern, set both of these to zero. If you have an existing block of memory (allocated with malloc) you want Regex to use, set buffer to its address and allocated to its size (in bytes).

re_compile_pattern uses realloc to extend the space for the compiled pattern as necessary.

To compile a pattern buffer, use:

char *
re_compile_pattern (const char *regex, const int regex_size,
                    struct re_pattern_buffer *pattern_buffer)
regex is the regular expression's address, regex_size is its length, and pattern_buffer is the pattern buffer's address.

If re_compile_pattern successfully compiles the regular expression, it returns zero and sets *pattern_buffer to the compiled pattern. It sets the pattern buffer's fields as follows:

buffer
to the compiled pattern.

syntax
to the current value of re_syntax_options.

re_nsub
to the number of subexpressions in regex.

If re_compile_pattern can't compile regex, it returns an error string corresponding to a POSIX error code.

Next: GNU Matching Prev: GNU Pattern Buffers Up: GNU Regex Functions Top: Top


GNU Matching -- GNU Gnulib

Next: GNU Searching Prev: GNU Regular Expression Compiling Up: GNU Regex Functions Top: Top

22.1.3. GNU Matching

Matching the GNU way means trying to match as much of a string as possible starting at a position within it you specify. Once you've compiled a pattern into a pattern buffer (see GNU Regular Expression Compiling), you can ask the matcher to match that pattern against a string using:

int
re_match (struct re_pattern_buffer *pattern_buffer,
          const char *string, const int size,
          const int start, struct re_registers *regs)
pattern_buffer is the address of a pattern buffer containing a compiled pattern. string is the string you want to match; it can contain newline and null characters. size is the length of that string. start is the string index at which you want to begin matching; the first character of string is at index zero. See Using Registers, for an explanation of regs; you can safely pass zero.

re_match matches the regular expression in pattern_buffer against the string string according to the syntax of pattern_buffer. (See GNU Regular Expression Compiling, for how to set it.) The function returns @math{-1} if the compiled pattern does not match any part of string and @math{-2} if an internal error happens; otherwise, it returns how many (possibly zero) characters of string the pattern matched.

An example: suppose pattern_buffer points to a pattern buffer containing the compiled pattern for `a*', and string points to `aaaaab' (whereupon size should be 6). Then if start is 2, re_match returns 3, i.e., `a*' would have matched the last three `a's in string. If start is 0, re_match returns 5, i.e., `a*' would have matched all the `a's in string. If start is either 5 or 6, it returns zero.

If start is not between zero and size, then re_match returns @math{-1}.

Next: GNU Searching Prev: GNU Regular Expression Compiling Up: GNU Regex Functions Top: Top


GNU Searching -- GNU Gnulib

Next: Matching/Searching with Split Data Prev: GNU Matching Up: GNU Regex Functions Top: Top

22.1.4. GNU Searching

Searching means trying to match starting at successive positions within a string. The function re_search does this.

Before calling re_search, you must compile your regular expression. See GNU Regular Expression Compiling.

Here is the function declaration:

int
re_search (struct re_pattern_buffer *pattern_buffer,
           const char *string, const int size,
           const int start, const int range,
           struct re_registers *regs)
whose arguments are the same as those to re_match (see GNU Matching) except that the two arguments start and range replace re_match's argument start.

If range is positive, then re_search attempts a match starting first at index start, then at @math{start + 1} if that fails, and so on, up to @math{start + range}; if range is negative, then it attempts a match starting first at index start, then at @math{start -1} if that fails, and so on.

If start is not between zero and size, then re_search returns @math{-1}. When range is positive, re_search adjusts range so that @math{start + range - 1} is between zero and size, if necessary; that way it won't search outside of string. Similarly, when range is negative, re_search adjusts range so that @math{start + range + 1} is between zero and size, if necessary.

If the fastmap field of pattern_buffer is zero, re_search matches starting at consecutive positions; otherwise, it uses fastmap to make the search more efficient. See Searching with Fastmaps.

If no match is found, re_search returns @math{-1}. If a match is found, it returns the index where the match began. If an internal error happens, it returns @math{-2}.

Next: Matching/Searching with Split Data Prev: GNU Matching Up: GNU Regex Functions Top: Top


Matching/Searching with Split Data -- GNU Gnulib

Next: Searching with Fastmaps Prev: GNU Searching Up: GNU Regex Functions Top: Top

22.1.5. Matching and Searching with Split Data

Using the functions re_match_2 and re_search_2, you can match or search in data that is divided into two strings.

The function:

int
re_match_2 (struct re_pattern_buffer *buffer,
            const char *string1, const int size1,
            const char *string2, const int size2,
            const int start,
            struct re_registers *regs,
            const int stop)
is similar to re_match (see GNU Matching) except that you pass two data strings and sizes, and an index stop beyond which you don't want the matcher to try matching. As with re_match, if it succeeds, re_match_2 returns how many characters of string it matched. Regard string1 and string2 as concatenated when you set the arguments start and stop and use the contents of regs; re_match_2 never returns a value larger than @math{size1 + size2}.

The function:

int
re_search_2 (struct re_pattern_buffer *buffer,
             const char *string1, const int size1,
             const char *string2, const int size2,
             const int start, const int range,
             struct re_registers *regs,
             const int stop)
is similarly related to re_search.

Next: Searching with Fastmaps Prev: GNU Searching Up: GNU Regex Functions Top: Top


Searching with Fastmaps -- GNU Gnulib

Next: GNU Translate Tables Prev: Matching/Searching with Split Data Up: GNU Regex Functions Top: Top

22.1.6. Searching with Fastmaps

If you're searching through a long string, you should use a fastmap. Without one, the searcher tries to match at consecutive positions in the string. Generally, most of the characters in the string could not start a match. It takes much longer to try matching at a given position in the string than it does to check in a table whether or not the character at that position could start a match. A fastmap is such a table.

More specifically, a fastmap is an array indexed by the characters in your character set. Under the ASCII encoding, therefore, a fastmap has 256 elements. If you want the searcher to use a fastmap with a given pattern buffer, you must allocate the array and assign the array's address to the pattern buffer's fastmap field. You either can compile the fastmap yourself or have re_search do it for you; when fastmap is nonzero, it automatically compiles a fastmap the first time you search using a particular compiled pattern.

By setting the buffer's fastmap field before calling re_compile_pattern, you can reuse a buffer data structure across multiple searches with different patterns, and allocate the fastmap only once. Nonetheless, the fastmap must be recompiled each time the buffer has a new pattern compiled into it.

To compile a fastmap yourself, use:

int
re_compile_fastmap (struct re_pattern_buffer *pattern_buffer)
pattern_buffer is the address of a pattern buffer. If the character c could start a match for the pattern, re_compile_fastmap makes pattern_buffer->fastmap[c] nonzero. It returns @math{0} if it can compile a fastmap and @math{-2} if there is an internal error. For example, if `|' is the alternation operator and pattern_buffer holds the compiled pattern for `a|b', then re_compile_fastmap sets fastmap['a'] and fastmap['b'] (and no others).

re_search uses a fastmap as it moves along in the string: it checks the string's characters until it finds one that's in the fastmap. Then it tries matching at that character. If the match fails, it repeats the process. So, by using a fastmap, re_search doesn't waste time trying to match at positions in the string that couldn't start a match.

If you don't want re_search to use a fastmap, store zero in the fastmap field of the pattern buffer before calling re_search.

Once you've initialized a pattern buffer's fastmap field, you need never do so again---even if you compile a new pattern in it---provided the way the field is set still reflects whether or not you want a fastmap. re_search will still either do nothing if fastmap is null or, if it isn't, compile a new fastmap for the new pattern.

Next: GNU Translate Tables Prev: Matching/Searching with Split Data Up: GNU Regex Functions Top: Top


GNU Translate Tables -- GNU Gnulib

Next: Using Registers Prev: Searching with Fastmaps Up: GNU Regex Functions Top: Top

22.1.7. GNU Translate Tables

If you set the translate field of a pattern buffer to a translate table, then the GNU Regex functions to which you've passed that pattern buffer use it to apply a simple transformation to all the regular expression and string characters at which they look.

A translate table is an array indexed by the characters in your character set. Under the ASCII encoding, therefore, a translate table has 256 elements. The array's elements are also characters in your character set. When the Regex functions see a character c, they use translate[c] in its place, with one exception: the character after a `\' is not translated. (This ensures that, the operators, e.g., `\B' and `\b', are always distinguishable.)

For example, a table that maps all lowercase letters to the corresponding uppercase ones would cause the matcher to ignore differences in case.(1) Such a table would map all characters except lowercase letters to themselves, and lowercase letters to the corresponding uppercase ones. Under the ASCII encoding, here's how you could initialize such a table (we'll call it case_fold):

for (i = 0; i < 256; i++)
  case_fold[i] = i;
for (i = 'a'; i <= 'z'; i++)
  case_fold[i] = i - ('a' - 'A');
You tell Regex to use a translate table on a given pattern buffer by assigning that table's address to the translate field of that buffer. If you don't want Regex to do any translation, put zero into this field. You'll get weird results if you change the table's contents anytime between compiling the pattern buffer, compiling its fastmap, and matching or searching with the pattern buffer.

Footnotes

(1) A table that maps all uppercase letters to the corresponding lowercase ones would work just as well for this purpose.

Next: Using Registers Prev: Searching with Fastmaps Up: GNU Regex Functions Top: Top


Using Registers -- GNU Gnulib

Next: Freeing GNU Pattern Buffers Prev: GNU Translate Tables Up: GNU Regex Functions Top: Top

22.1.8. Using Registers

A group in a regular expression can match a (possibly empty) substring of the string that regular expression as a whole matched. The matcher remembers the beginning and end of the substring matched by each group.

To find out what they matched, pass a nonzero regs argument to a GNU matching or searching function (see GNU Matching and GNU Searching), i.e., the address of a structure of this type, as defined in regex.h:

struct re_registers
{
  unsigned num_regs;
  regoff_t *start;
  regoff_t *end;
};
Except for (possibly) the num_regs'th element (see below), the ith element of the start and end arrays records information about the ith group in the pattern. (They're declared as C pointers, but this is only because not all C compilers accept zero-length arrays; conceptually, it is simplest to think of them as arrays.)

The start and end arrays are allocated in one of two ways. The simplest and perhaps most useful is to let the matcher (re)allocate enough space to record information for all the groups in the regular expression. If re_set_registers is not called before searching or matching, then the matcher allocates two arrays each of @math{1 + re_nsub} elements (re_nsub is another field in the pattern buffer; see GNU Pattern Buffers). The extra element is set to @math{-1}. Then on subsequent calls with the same pattern buffer and regs arguments, the matcher reallocates more space if necessary.

The function:

void
re_set_registers (struct re_pattern_buffer *buffer,
                  struct re_registers *regs,
                  size_t num_regs,
                  regoff_t *starts, regoff_t *ends)
sets regs to hold num_regs registers, storing them in starts and ends. Subsequent matches using buffer and regs will use this memory for recording register information. starts and ends must be allocated with malloc, and must each be at least @math{num_regs * sizeof (regoff_t)} bytes long.

If num_regs is zero, then subsequent matches should allocate their own register data.

Unless this function is called, the first search or match using buffer will allocate its own register data, without freeing the old data.

The following examples illustrate the information recorded in the re_registers structure. (In all of them, `(' represents the open-group and `)' the close-group operator. The first character in the string string is at index 0.)

  • If the regular expression has an i-th group that matches a substring of string, then the function sets regs->start[i] to the index in string where the substring matched by the i-th group begins, and regs->end[i] to the index just beyond that substring's end. The function sets regs->start[0] and regs->end[0] to analogous information about the entire pattern.

    For example, when you match `((a)(b))' against `ab', you get:

    • 0 in regs->start[0] and 2 in regs->end[0]

    • 0 in regs->start[1] and 2 in regs->end[1]

    • 0 in regs->start[2] and 1 in regs->end[2]

    • 1 in regs->start[3] and 2 in regs->end[3]
  • If a group matches more than once (as it might if followed by, e.g., a repetition operator), then the function reports the information about what the group last matched.

    For example, when you match the pattern `(a)*' against the string `aa', you get:

    • 0 in regs->start[0] and 2 in regs->end[0]

    • 1 in regs->start[1] and 2 in regs->end[1]
  • If the i-th group does not participate in a successful match, e.g., it is an alternative not taken or a repetition operator allows zero repetitions of it, then the function sets regs->start[i] and regs->end[i] to @math{-1}.

    For example, when you match the pattern `(a)*b' against the string `b', you get:

    • 0 in regs->start[0] and 1 in regs->end[0]

    • @math{-1} in regs->start[1] and @math{-1} in regs->end[1]
  • If the i-th group matches a zero-length string, then the function sets regs->start[i] and regs->end[i] to the index just beyond that zero-length string.

    For example, when you match the pattern `(a*)b' against the string `b', you get:

    • 0 in regs->start[0] and 1 in regs->end[0]

    • 0 in regs->start[1] and 0 in regs->end[1]
  • If an i-th group contains a j-th group in turn not contained within any other group within group i and the function reports a match of the i-th group, then it records in regs->start[j] and regs->end[j] the last match (if it matched) of the j-th group.

    For example, when you match the pattern `((a*)b)*' against the string `abb', group 2 last matches the empty string, so you get what it previously matched:

    • 0 in regs->start[0] and 3 in regs->end[0]

    • 2 in regs->start[1] and 3 in regs->end[1]

    • 2 in regs->start[2] and 2 in regs->end[2]
    When you match the pattern `((a)*b)*' against the string `abb', group 2 doesn't participate in the last match, so you get:

    • 0 in regs->start[0] and 3 in regs->end[0]

    • 2 in regs->start[1] and 3 in regs->end[1]

    • 0 in regs->start[2] and 1 in regs->end[2]
  • If an i-th group contains a j-th group in turn not contained within any other group within group i and the function sets regs->start[i] and regs->end[i] to @math{-1}, then it also sets regs->start[j] and regs->end[j] to @math{-1}.

    For example, when you match the pattern `((a)*b)*c' against the string `c', you get:

    • 0 in regs->start[0] and 1 in regs->end[0]

    • @math{-1} in regs->start[1] and @math{-1} in regs->end[1]

    • @math{-1} in regs->start[2] and @math{-1} in regs->end[2]

Next: Freeing GNU Pattern Buffers Prev: GNU Translate Tables Up: GNU Regex Functions Top: Top


Freeing GNU Pattern Buffers -- GNU Gnulib

Prev: Using Registers Up: GNU Regex Functions Top: Top

22.1.9. Freeing GNU Pattern Buffers

To free any allocated fields of a pattern buffer, use the POSIX function regfree:

void
regfree (regex_t *preg)
preg is the pattern buffer whose allocated fields you want freed; this works because since the type regex_t---the type for POSIX pattern buffers---is equivalent to the type re_pattern_buffer.

regfree also sets preg's allocated field to zero. After a buffer has been freed, it must have a regular expression compiled in it before passing it to a matching or searching function.

Prev: Using Registers Up: GNU Regex Functions Top: Top


BSD Regex Functions -- GNU Gnulib

Next: Regular expression syntaxes Prev: GNU Regex Functions Up: Programming with Regex Top: Top

22.2. BSD Regex Functions

If you're writing code that has to be Berkeley Unix compatible, you'll need to use these functions whose interfaces are the same as those in Berkeley Unix.

Menu

  • BSD Regular Expression Compiling re_comp ()
  • BSD Searching re_exec ()


BSD Regular Expression Compiling -- GNU Gnulib

Next: BSD Searching Up: BSD Regex Functions Top: Top

22.2.1. BSD Regular Expression Compiling

With Berkeley Unix, you can only search for a given regular expression; you can't match one. To search for it, you must first compile it. Before you compile it, you must indicate the regular expression syntax you want it compiled according to by setting the variable re_syntax_options (declared in regex.h to some syntax (see Regular Expression Syntax).

To compile a regular expression use:

char *
re_comp (char *regex)
regex is the address of a null-terminated regular expression. re_comp uses an internal pattern buffer, so you can use only the most recently compiled pattern buffer. This means that if you want to use a given regular expression that you've already compiled---but it isn't the latest one you've compiled---you'll have to recompile it. If you call re_comp with the null string (not the empty string) as the argument, it doesn't change the contents of the pattern buffer.

If re_comp successfully compiles the regular expression, it returns zero. If it can't compile the regular expression, it returns an error string. re_comp's error messages are identical to those of re_compile_pattern (see GNU Regular Expression Compiling).

Next: BSD Searching Up: BSD Regex Functions Top: Top


BSD Searching -- GNU Gnulib

Prev: BSD Regular Expression Compiling Up: BSD Regex Functions Top: Top

22.2.2. BSD Searching

Searching the Berkeley Unix way means searching in a string starting at its first character and trying successive positions within it to find a match. Once you've compiled a pattern using re_comp (see BSD Regular Expression Compiling), you can ask Regex to search for that pattern in a string using:

int
re_exec (char *string)
string is the address of the null-terminated string in which you want to search.

re_exec returns either 1 for success or 0 for failure. It automatically uses a GNU fastmap (see Searching with Fastmaps).

Prev: BSD Regular Expression Compiling Up: BSD Regex Functions Top: Top


Regular expression syntaxes -- GNU Gnulib

Prev: BSD Regex Functions Up: Programming with Regex Top: Top

22.3. Regular expression syntaxes

Gnulib supports many different types of regular expressions; although the underlying features are the same or identical, the syntax used varies. The descriptions given here for the different types are generated automatically.

Menu

  • awk regular expression syntax
  • egrep regular expression syntax
  • ed regular expression syntax
  • emacs regular expression syntax
  • gnu-awk regular expression syntax
  • grep regular expression syntax
  • posix-awk regular expression syntax
  • posix-basic regular expression syntax
  • posix-egrep regular expression syntax
  • posix-extended regular expression syntax
  • posix-minimal-basic regular expression syntax
  • sed regular expression syntax

    • Prev: BSD Regex Functions Up: Programming with Regex Top: Top


awk regular expression syntax -- GNU Gnulib

Next: egrep regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.1. `awk' regular expression syntax

The character `.' matches any single character except the null character.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' can be used to quote the following character. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are not supported and so `\w', `\W', `\<', `\>', `\b', `\B', `\`', and `\'' match `w', `W', `<', `>', `b', `B', ``', and `'' respectively.

Grouping is performed with parentheses `()'. An unmatched `)' matches just itself. A backslash followed by a digit matches that digit.

The alternation operator is `|'.

The characters `^' and `$' always represent the beginning and end of a string respectively, except within square brackets. Within brackets, `^' can be used to invert the membership of the character class being specified.

`*', `+' and `?' are special at any point in a regular expression except:

  1. At the beginning of a regular expression
  2. After an open-group, signified by `('
  3. After the alternation operator `|'
The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: egrep regular expression syntax Up: Regular expression syntaxes Top: Top


egrep regular expression syntax -- GNU Gnulib

Next: ed regular expression syntax Prev: awk regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.2. `egrep' regular expression syntax

The character `.' matches any single character.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' is taken literally. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with parentheses `()'. An unmatched `)' matches just itself. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `('.

The alternation operator is `|'.

The characters `^' and `$' always represent the beginning and end of a string respectively, except within square brackets. Within brackets, `^' can be used to invert the membership of the character class being specified.

The characters `*', `+' and `?' are special anywhere in a regular expression.

Intervals are specified by `{' and `}'. Invalid intervals are treated as literals, for example `a{1' is treated as `a\{1'

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: ed regular expression syntax Prev: awk regular expression syntax Up: Regular expression syntaxes Top: Top


ed regular expression syntax -- GNU Gnulib

Next: emacs regular expression syntax Prev: egrep regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.3. `ed' regular expression syntax

The character `.' matches any single character except the null character.

`\+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`\?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`+ and ?'
match themselves.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' is taken literally. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with backslashes followed by parentheses `\(', `\)'. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `\('.

The alternation operator is `\|'.

The character `^' only represents the beginning of a string when it appears:

  1. At the beginning of a regular expression

  2. After an open-group, signified by `\('

  3. After the alternation operator `\|'
The character `$' only represents the end of a string when it appears:
  1. At the end of a regular expression
  2. Before a close-group, signified by `\)'
  3. Before the alternation operator `\|'
`\*', `\+' and `\?' are special at any point in a regular expression except:
  1. At the beginning of a regular expression
  2. After an open-group, signified by `\('
  3. After the alternation operator `\|'
Intervals are specified by `\{' and `\}'. Invalid intervals such as `a\{1z' are not accepted.

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: emacs regular expression syntax Prev: egrep regular expression syntax Up: Regular expression syntaxes Top: Top


emacs regular expression syntax -- GNU Gnulib

Next: gnu-awk regular expression syntax Prev: ed regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.4. `emacs' regular expression syntax

The character `.' matches any single character except newline.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are ignored. Within square brackets, `\' is taken literally. Character classes are not supported, so for example you would need to use `[0-9]' instead of `[[:digit:]]'.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with backslashes followed by parentheses `\(', `\)'. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `\('.

The alternation operator is `\|'.

The character `^' only represents the beginning of a string when it appears:

  1. At the beginning of a regular expression

  2. After an open-group, signified by `\('

  3. After the alternation operator `\|'
The character `$' only represents the end of a string when it appears:
  1. At the end of a regular expression
  2. Before a close-group, signified by `\)'
  3. Before the alternation operator `\|'
`*', `+' and `?' are special at any point in a regular expression except:
  1. At the beginning of a regular expression
  2. After an open-group, signified by `\('
  3. After the alternation operator `\|'
The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: gnu-awk regular expression syntax Prev: ed regular expression syntax Up: Regular expression syntaxes Top: Top


gnu-awk regular expression syntax -- GNU Gnulib

Next: grep regular expression syntax Prev: emacs regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.5. `gnu-awk' regular expression syntax

The character `.' matches any single character.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' can be used to quote the following character. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with parentheses `()'. An unmatched `)' matches just itself. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `('.

The alternation operator is `|'.

The characters `^' and `$' always represent the beginning and end of a string respectively, except within square brackets. Within brackets, `^' can be used to invert the membership of the character class being specified.

`*', `+' and `?' are special at any point in a regular expression except:

  1. At the beginning of a regular expression
  2. After an open-group, signified by `('
  3. After the alternation operator `|'
Intervals are specified by `{' and `}'. Invalid intervals are treated as literals, for example `a{1' is treated as `a\{1'

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: grep regular expression syntax Prev: emacs regular expression syntax Up: Regular expression syntaxes Top: Top


grep regular expression syntax -- GNU Gnulib

Next: posix-awk regular expression syntax Prev: gnu-awk regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.6. `grep' regular expression syntax

The character `.' matches any single character.

`\+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`\?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`+ and ?'
match themselves.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' is taken literally. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with backslashes followed by parentheses `\(', `\)'. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `\('.

The alternation operator is `\|'.

The character `^' only represents the beginning of a string when it appears:

  1. At the beginning of a regular expression

  2. After an open-group, signified by `\('

  3. After a newline
  4. After the alternation operator `\|'
The character `$' only represents the end of a string when it appears:
  1. At the end of a regular expression
  2. Before a close-group, signified by `\)'
  3. Before a newline
  4. Before the alternation operator `\|'
`\*', `\+' and `\?' are special at any point in a regular expression except:
  1. At the beginning of a regular expression
  2. After an open-group, signified by `\('
  3. After a newline
  4. After the alternation operator `\|'
Intervals are specified by `\{' and `\}'. Invalid intervals such as `a\{1z' are not accepted.

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: posix-awk regular expression syntax Prev: gnu-awk regular expression syntax Up: Regular expression syntaxes Top: Top


posix-awk regular expression syntax -- GNU Gnulib

Next: posix-basic regular expression syntax Prev: grep regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.7. `posix-awk' regular expression syntax

The character `.' matches any single character except the null character.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' can be used to quote the following character. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are not supported and so `\w', `\W', `\<', `\>', `\b', `\B', `\`', and `\'' match `w', `W', `<', `>', `b', `B', ``', and `'' respectively.

Grouping is performed with parentheses `()'. An unmatched `)' matches just itself. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `('.

The alternation operator is `|'.

The characters `^' and `$' always represent the beginning and end of a string respectively, except within square brackets. Within brackets, `^' can be used to invert the membership of the character class being specified.

`*', `+' and `?' are special at any point in a regular expression except the following places, where they are not allowed:

  1. At the beginning of a regular expression
  2. After an open-group, signified by `('
  3. After the alternation operator `|'
Intervals are specified by `{' and `}'. Invalid intervals are treated as literals, for example `a{1' is treated as `a\{1'

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: posix-basic regular expression syntax Prev: grep regular expression syntax Up: Regular expression syntaxes Top: Top


posix-basic regular expression syntax -- GNU Gnulib

Next: posix-egrep regular expression syntax Prev: posix-awk regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.8. `posix-basic' regular expression syntax

This is a synonym for ed.


posix-egrep regular expression syntax -- GNU Gnulib

Next: posix-extended regular expression syntax Prev: posix-basic regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.9. `posix-egrep' regular expression syntax

This is a synonym for egrep.


posix-extended regular expression syntax -- GNU Gnulib

Next: posix-minimal-basic regular expression syntax Prev: posix-egrep regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.10. `posix-extended' regular expression syntax

The character `.' matches any single character except the null character.

`+'
indicates that the regular expression should match one or more occurrences of the previous atom or regexp.
`?'
indicates that the regular expression should match zero or one occurrence of the previous atom or regexp.
`\+'
matches a `+'
`\?'
matches a `?'.
Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' is taken literally. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with parentheses `()'. An unmatched `)' matches just itself. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `('.

The alternation operator is `|'.

The characters `^' and `$' always represent the beginning and end of a string respectively, except within square brackets. Within brackets, `^' can be used to invert the membership of the character class being specified.

`*', `+' and `?' are special at any point in a regular expression except the following places, where they are not allowed:

  1. At the beginning of a regular expression
  2. After an open-group, signified by `('
  3. After the alternation operator `|'
Intervals are specified by `{' and `}'. Invalid intervals such as `a{1z' are not accepted.

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: posix-minimal-basic regular expression syntax Prev: posix-egrep regular expression syntax Up: Regular expression syntaxes Top: Top


posix-minimal-basic regular expression syntax -- GNU Gnulib

Next: sed regular expression syntax Prev: posix-extended regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.11. `posix-minimal-basic' regular expression syntax

The character `.' matches any single character except the null character.

Bracket expressions are used to match ranges of characters. Bracket expressions where the range is backward, for example `[z-a]', are invalid. Within square brackets, `\' is taken literally. Character classes are supported; for example `[[:digit:]]' will match a single decimal digit.

GNU extensions are supported:

  1. `\w' matches a character within a word
  2. `\W' matches a character which is not within a word
  3. `\<' matches the beginning of a word
  4. `\>' matches the end of a word
  5. `\b' matches a word boundary
  6. `\B' matches characters which are not a word boundary
  7. `\`' matches the beginning of the whole input
  8. `\'' matches the end of the whole input
Grouping is performed with backslashes followed by parentheses `\(', `\)'. A backslash followed by a digit acts as a back-reference and matches the same thing as the previous grouped expression indicated by that number. For example `\2' matches the second group expression. The order of group expressions is determined by the position of their opening parenthesis `\('.

The character `^' only represents the beginning of a string when it appears:

  1. At the beginning of a regular expression

  2. After an open-group, signified by `\('

The character `$' only represents the end of a string when it appears:
  1. At the end of a regular expression
  2. Before a close-group, signified by `\)'
Intervals are specified by `\{' and `\}'. Invalid intervals such as `a\{1z' are not accepted.

The longest possible match is returned; this applies to the regular expression as a whole and (subject to this constraint) to subexpressions within groups.

Next: sed regular expression syntax Prev: posix-extended regular expression syntax Up: Regular expression syntaxes Top: Top


sed regular expression syntax -- GNU Gnulib

Prev: posix-minimal-basic regular expression syntax Up: Regular expression syntaxes Top: Top

22.3.12. `sed' regular expression syntax

This is a synonym for ed.


Build Infrastructure Modules -- GNU Gnulib

Next: GNU Free Documentation License Prev: Programming with Regex Top: Top

23. Build Infrastructure Modules

Gnulib has a couple of modules that don't provide code, but rather extend the GNU Build System. That is, they are convenience facilities for use with GNU Automake (in particular).

Menu

  • Searching for Libraries
  • Exported Symbols of Shared Libraries
  • LD Version Scripts
  • Visual Studio Compatibility
  • configmake
  • warnings
  • manywarnings


Searching for Libraries -- GNU Gnulib

Up: Build Infrastructure Modules Top: Top

23.1. Searching for Libraries

The following macros check for the presence or location of certain C, C++, or Fortran library archive files.

Simple Library Tests

The macros AC_CHECK_LIB, AC_SEARCH_LIBS from GNU Autoconf check for the presence of certain C, C++, or Fortran library archive files. The libraries are looked up in the default linker path---a system dependent list of directories, that usually contains the /usr/lib directory---and those directories given by -L options in the LDFLAGS variable.

Locating Libraries

The following macros, defined in the Gnulib module havelib, search for the location of certain C, C++, or Fortran library archive files and make the found location available to the compilation process and to further Autoconf tests.

AC_LIB_LINKFLAGS(name, [dependencies])
Searches for lib<name> and the libraries corresponding to explicit and implicit dependencies. Sets and AC_SUBSTs the LIB<NAME> and LTLIB<NAME> variables (with <NAME> in upper case) and augments the CPPFLAGS variable by -I options.

This macro should be used when lib<name> is expected to be found.

AC_LIB_HAVE_LINKFLAGS(name, [dependencies], [includes], [testcode], [missing-message])
Searches for lib<name> and the libraries corresponding to explicit and implicit dependencies, together with the specified include files and the ability to compile and link the specified testcode. The missing-message defaults to no and may contain additional hints for the user. If found, it sets and AC_SUBSTs HAVE_LIB<NAME>=yes and the LIB<NAME> and LTLIB<NAME> variables (with <NAME> in upper case) and augments the CPPFLAGS variable by -I options, and #defines HAVE_LIB<NAME> to 1. Otherwise, it sets and AC_SUBSTs HAVE_LIB<NAME>=no and LIB<NAME> and LTLIB<NAME> to empty.
These macros assume that when a library is installed in some_directory/lib, its include files are installed in some_directory/include.

The complexities that AC_LIB_LINKFLAGS and AC_LIB_HAVE_LINKFLAGS deal with are the following:

  • The library is not necessarily already in the search path (CPPFLAGS for the include file search path, LDFLAGS for the library search path). The macro provides a `--with-lib<name>' option. The user of the `configure' script can use this option to indicate the location of the library and its include files. If not provided, the --prefix directory is searched as well.

  • The library is not necessarily already in the run time library search path. To avoid the need for setting an environment variable like LD_LIBRARY_PATH, the macro adds the appropriate run time search path options to the LIB<NAME> variable. This works on most systems. It can also be inhibited: The user of `configure' can use the --disable-rpath option to force an installation that doesn't contain hardcoded library search paths but instead may require the use of an environment variable like LD_LIBRARY_PATH.
The macros also set a variable LTLIB<NAME>, that should be used when linking with libtool. Both LTLIB<NAME> and LIB<NAME> contain essentially the same option, but where LIB<NAME> contains platform dependent flags like `-Wl,-rpath', LTLIB<NAME> contains platform independent flags like `-R'.

Example of using AC_LIB_LINKFLAGS

Suppose you want to use libz, the compression library.

  1. In configure.ac you add the line

      AC_CONFIG_AUX_DIR([build-aux])
  AC_LIB_LINKFLAGS([z])
    Note that since the AC_LIB_LINKFLAGS invocation modifies the CPPFLAGS, it should precede all tests that check for header files, declarations, structures or types.

  2. To the package's build-aux directory you add the file config.rpath, also part of the Gnulib havelib module. (gnulib-tool will usually do this for you automatically.)

  3. In Makefile.in you add @LIBZ@ to the link command line of your program. Or, if you are using Automake, you add $(LIBZ) to the LDADD variable that corresponds to your program.

Dependencies

The dependencies list is a space separated list of library names that libname is known to depend upon. Example: If libfooy depends on libfoox, and libfooz depends on libfoox and libfooy, you can write:

AC_LIB_LINKFLAGS([foox])
AC_LIB_LINKFLAGS([fooy], [foox])
AC_LIB_LINKFLAGS([fooz], [foox fooy])
Explicit dependencies are necessary if you cannot assume that a .la file, created by libtool, is installed. If you can assume that libfooy.la is installed by libtool (and has not been omitted by the package distributor!), you can omit the explicit dependency and just write

AC_LIB_LINKFLAGS([fooy])
This way, you don't need to know in advance which libraries the needed library depends upon.

Static vs. shared

The macros find the libraries regardless whether they are installed as shared or static libraries.

CPPFLAGS vs. LDFLAGS

The macros determine the directories that should be added to the compiler preprocessor's search path and to the linker's search path. For the compiler preprocessor, -I options with the necessary directories are added to the CPPFLAGS variable, for use by the whole package. For the linker, appropriate options are added to the LIB<NAME> and LTLIB<NAME> variables, for use during linking by those programs and libraries that need the dependency on lib<name>. You need to use the value of LIB<NAME> or LTLIB<NAME> in the Makefiles. LTLIB<NAME> is for use with libtool, whereas LIB<NAME> is for when libtool is not involved in linking.

The macros do not check whether the include files and the library found match. If you want to verify this at configure time, one technique is to have a version number in the include files and a version number in the library, like this:

  #define LIBNAME_VERSION 10203
  extern int libname_version; /* initialized to LIBNAME_VERSION */
and use a test like
  AC_TRY_RUN([int main () { return libname_version != LIBNAME_VERSION; }])

Bi-arch systems

A bi-arch system is one where
  • the processor has a 32-bit execution mode and a 64-bit execution mode (for example, x86_64, ia64, sparc64, powerpc64), and
  • 32-bit mode libraries and executables and 64-bit mode libraries are both installed, and
  • 32-bit mode libraries and object files cannot be mixed with 64-bit mode ones.
On several types of such systems, for historical reasons, the 32-bit libraries are installed in prefix/lib, whereas the 64-bit libraries are installed in
  • prefix/lib64 on many glibc systems,
  • prefix/lib/64 on Solaris systems.
On such systems, in 64-bit mode, @command{configure} will search for the libraries in prefix/lib64 or prefix/lib/64, respectively, not in prefix/lib. A user can adhere to these system-wide conventions by using the `--libdir' option when installing packages. When a user has already installed packages in 64-bit mode using the GNU default `--libdir=prefix/lib', he can make this directory adhere to the system-wide convention by placing a symbolic link:
On glibc systems:
ln -s lib prefix/lib64
On Solaris systems:
ln -s . prefix/lib/64

Up: Build Infrastructure Modules Top: Top


Exported Symbols of Shared Libraries -- GNU Gnulib

Next: LD Version Scripts Up: Build Infrastructure Modules Top: Top

23.2. Controlling the Exported Symbols of Shared Libraries

The lib-symbol-visibility module allows precise control of the symbols exported by a shared library. This is useful because

  • It prevents abuse of undocumented APIs of your library. Symbols that are not exported from the library cannot be used. This eliminates the problem that when the maintainer of the library changes internals of the library, maintainers of other projects cry ``breakage''. Instead, these maintainers are forced to negotiate the desired API from the maintainer of the library.

  • It reduces the risk of symbol collision between your library and other libraries. For example, the symbol `readline' is defined in several libraries, most of which don't have the same semantics and the same calling convention as the GNU readline library.

  • It reduces the startup time of programs linked to the library. This is because the dynamic loader has less symbols to process.

  • It allows the compiler to generate better code. Within a shared library, a call to a function that is a global symbol costs a ``call'' instruction to a code location in the so-called PLT (procedure linkage table) which contains a ``jump'' instruction to the actual function's code. (This is needed so that the function can be overridden, for example by a function with the same name in the executable or in a shared library interposed with LD_PRELOAD.) Whereas a call to a function for which the compiler can assume that it is in the same shared library is just a direct ``call'' instructions. Similarly for variables: A reference to a global variable fetches a pointer in the so-called GOT (global offset table); this is a pointer to the variable's memory. So the code to access it is two memory load instructions. Whereas for a variable which is known to reside in the same shared library, it is just a direct memory access: one memory load instruction.
There are traditionally three ways to specify the exported symbols of a shared library.

  • The programmer specifies the list of symbols to be exported when the shared library is created. Usually a command-line option is passed to the linker, with the name of a file containing the symbols.

    The upside of this approach is flexibility: it allows the same code to be used in different libraries with different export lists. The downsides are: 1. it's a lot of maintenance overhead when the symbol list is platform dependent, 2. it doesn't work well with C++, due to name mangling.

  • The programmer specifies a ``hidden'' attribute for every variable and function that shall not be exported.

    The drawbacks of this approach are: Symbols are still exported from the library by default. It's a lot of maintenance work to mark every non- exported variable and function. But usually the exported API is quite small, compared to the internal API of the library. And it's the wrong paradigm: It doesn't force thinking when introducing new exported API.

  • The programmer specifies a ``hidden'' attribute for all files that make up the shared library, and an ``exported'' attribute for those symbols in these files that shall be exported.

    This is perfect: It burdens the maintainer only for exported API, not for library-internal API. And it keeps the annotations in the source code.

GNU libtool's @option{-export-symbols} option implements the first approach.

This gnulib module implements the third approach. For this it relies on GNU GCC 4.0 or newer, namely on its `-fvisibility=hidden' command-line option and the ``visibility'' attribute. (The ``visibility'' attribute was already supported in GCC 3.4, but without the command line option, introduced in GCC 4.0, the third approach could not be used.)

More explanations on this subject can be found in https://gcc.gnu.org/wiki/Visibility, which contains more details on the GCC features and additional advice for C++ libraries, and in Ulrich Drepper's paper https://www.akkadia.org/drepper/dsohowto.pdf, which also explains other tricks for reducing the startup time impact of shared libraries.

The gnulib autoconf macro gl_VISIBILITY tests for GCC 4.0 or newer. It defines a Makefile variable @CFLAG_VISIBILITY@ containing `-fvisibility=hidden' or nothing. It also defines as a C macro and as a substituted variable: @HAVE_VISIBILITY@. Its value is 1 when symbol visibility control is supported, and 0 otherwise.

To use this module in a library, say libfoo, you will do these steps:

  1. Add @CFLAG_VISIBILITY@ or (in a Makefile.am) $(CFLAG_VISIBILITY) to the CFLAGS for the compilation of the sources that make up the library.

  2. Add a C macro definition, say `-DBUILDING_LIBFOO', to the CPPFLAGS for the compilation of the sources that make up the library.

  3. Define a macro specific to your library like this.
    #if BUILDING_LIBFOO && HAVE_VISIBILITY
#define LIBFOO_DLL_EXPORTED __attribute__((__visibility__("default")))
#else
#define LIBFOO_DLL_EXPORTED
#endif
    This macro should be enabled in all public header files of your library.

  4. Annotate all variable, function and class declarations in all public header files of your library with `LIBFOO_DLL_EXPORTED'. This annotation can occur at different locations: between the `extern' and the type or return type, or just before the entity being declared, or after the entire declarator. My preference is to put it right after `extern', so that the declarations in the header files remain halfway readable.
Note that the precise control of the exported symbols will not work with other compilers than GCC >= 4.0, and will not work on systems where the assembler or linker lack the support of ``hidden'' visibility. Therefore, it's good if, in order to reduce the risk of collisions with symbols in other libraries, you continue to use a prefix specific to your library for all non-static variables and functions and for all C++ classes in your library.

Note about other compilers: MSVC support can be added easily, by extending the definition of the macro mentioned above, to something like this:

#if BUILDING_LIBFOO && HAVE_VISIBILITY
#define LIBFOO_DLL_EXPORTED __attribute__((__visibility__("default")))
#elif BUILDING_LIBFOO && defined _MSC_VER
#define LIBFOO_DLL_EXPORTED __declspec(dllexport)
#elif defined _MSC_VER
#define LIBFOO_DLL_EXPORTED __declspec(dllimport)
#else
#define LIBFOO_DLL_EXPORTED
#endif

Next: LD Version Scripts Up: Build Infrastructure Modules Top: Top


LD Version Scripts -- GNU Gnulib

Next: Visual Studio Compatibility Prev: Exported Symbols of Shared Libraries Up: Build Infrastructure Modules Top: Top

23.3. LD Version Scripts

The lib-symbol-versions module can be used to add shared library versioning support. Currently, only GNU LD and the Solaris linker supports this.

Version scripts provides information that can be used by GNU/Linux distribution packaging tools. For example, Debian has a tool dpkg-shlibdeps that can determine the minimal required version of each dependency (by looking at the symbol list) and stuff the information into the Debian specific packaging files.

For more information and other uses of version scripts, see Ulrich Drepper's paper https://www.akkadia.org/drepper/dsohowto.pdf

You use the module by importing it to your library, and then add the following lines to the Makefile.am that builds the library:

if HAVE_LD_VERSION_SCRIPT
libfoo_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libfoo.map
endif
The version script file format is documented in the GNU LD manual, but a small example would be:

LIBFOO_1.0 {
  global:
    libfoo_init; libfoo_doit; libfoo_done;

  local:
    *;
};
If you target platforms that do not support linker scripts (i.e., all platforms that doesn't use GNU LD) you may want to consider a more portable but less powerful alternative: libtool -export-symbols. It will hide internal symbols from your library, but will not add ELF versioning symbols. Your usage would then be something like:

if HAVE_LD_VERSION_SCRIPT
libfoo_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libfoo.map
else
libfoo_la_LDFLAGS += -export-symbols $(srcdir)/libfoo.sym
endif
See the Libtool manual for the file syntax, but a small example would be:

libfoo_init
libfoo_doit
libfoo_done
To avoid the need for a *.sym file if your symbols are easily expressed using a regular expression, you may use -export-symbols-regex:

if HAVE_LD_VERSION_SCRIPT
libfoo_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libfoo.map
else
libfoo_la_LDFLAGS += -export-symbols-regex '^libfoo_.*'
endif
For more discussions about symbol visibility, rather than shared library versioning, see the visibility module (see Exported Symbols of Shared Libraries).

Next: Visual Studio Compatibility Prev: Exported Symbols of Shared Libraries Up: Build Infrastructure Modules Top: Top


Visual Studio Compatibility -- GNU Gnulib

Next: configmake Prev: LD Version Scripts Up: Build Infrastructure Modules Top: Top

23.4. Visual Studio Compatibility

The lib-msvc-compat module detects whether the linker supports --output-def when building a library. That parameter is used to generate a DEF file for a shared library (DLL). DEF files are useful for developers that use Visual Studio to develop programs that links to your library. See the GNU LD manual for more information.

There are other ways to create a DEF file, but we believe they are all sub-optimal to using --output-def during the build process. The variants we have considered include:

  • Use DUMPBIN /EXPORTS. This is explained in https://support.microsoft.com/kb/131313/en-us. The tool does not generate DEF files directly, so its output needs to be post processed manually:
    $ { echo EXPORTS; \
    dumpbin /EXPORTS libfoo-0.dll | tail -n+20 | awk '{ print $4 }'; \
  } > libfoo-0.def
$ lib /def:libfoo-0.def
  • Use IMPDEF. There is a tool called IMPDEF that can generate DEF files. However, it is not part of a standard Visual Studio installation. Further, it is documented as being an unreliable process.

  • Use DLLTOOL. The dlltool is part of the MinGW suite, and thus not part of a standard Visual Studio installation. The documentation for the IMPDEF tool claims that DLLTOOL is the wrong tool for this job. Finally, DLLTOOL does not generate DEF files directly, so it requires post-processing of the output.

If you are using libtool to build your shared library, here is how to use this module. Import lib-msvc-compat to your project, and then add the following lines to the Makefile.am that builds the library:

if HAVE_LD_OUTPUT_DEF
libfoo_la_LDFLAGS += -Wl,--output-def,libfoo-$(DLL_VERSION).def
defexecdir = $(bindir)
defexec_DATA = libfoo-$(DLL_VERSION).def
DISTCLEANFILES += $(defexec_DATA)
endif
The DLL_VERSION variable needs to be defined. It should be the shared library version number used in the DLL filename. For Windows targets you compute this value from the values you pass to Libtool's -version-info. Assuming you have variables LT_CURRENT and LT_AGE defined for the CURRENT and AGE libtool version integers, you compute DLL_VERSION as follows:

DLL_VERSION=`expr ${LT_CURRENT} - ${LT_AGE}`
AC_SUBST(DLL_VERSION)

Next: configmake Prev: LD Version Scripts Up: Build Infrastructure Modules Top: Top


configmake -- GNU Gnulib

Next: warnings Prev: Visual Studio Compatibility Up: Build Infrastructure Modules Top: Top

23.5. configmake

The configmake module builds a C include file named configmake.h containing the usual installation directory values; for example, those specified by --prefix or --libdir to configure. Each variable is given a #define with an all-uppercase macro name, such as PREFIX and LIBDIR. (Automake cannot create this file directly because the user might override directory values at make time.)

Specifically, the module retrieves values of the variables through configure followed by make, not directly through configure, so that a user who sets some of these variables consistently on the make command line gets correct results.

One advantage of this approach, compared to the classical approach of adding -DLIBDIR=\"$(libdir)\" etc. to AM_CPPFLAGS, is that it protects against the use of undefined variables. That is, if, say, $(libdir) is not set in the Makefile, LIBDIR is not defined by this module, and code using LIBDIR gives a compilation error.

Another advantage is that make output is shorter.

For the complete list of variables which are #defined this way, see the file gnulib/modules/configmake, or inspect your resulting gnulib Makefile.

Next: warnings Prev: Visual Studio Compatibility Up: Build Infrastructure Modules Top: Top


warnings -- GNU Gnulib

Next: manywarnings Prev: configmake Up: Build Infrastructure Modules Top: Top

23.6. warnings

The warnings module allows to regularly build a package with more GCC warnings than the default warnings emitted by GCC.

It provides the following functionality:

  • You can select some warning options, such as `-Wall', to be enabled whenever building with a GCC version that supports these options. The user can choose to override these warning options by providing the opposite options in the CFLAGS variable at configuration time.

  • You can make these warnings apply to selected directories only. In projects where subprojects are maintained by different people, or where parts of the source code are imported from external sources (for example from gnulib), it is useful to apply different warning options to different directories.

  • It lets you use `-Werror' at `make distcheck' time, to verify that on the maintainer's system, no warnings remain. (Note that use of `-Werror' in CFLAGS does not work in general, because it may break autoconfiguration.)

  • Similarly, it lets you use `-Werror' when the builder runs @command{configure} with an option such as @option{--enable-gcc-warnings}.
To use this module, you need the following:

  1. In configure.ac, use for example
    gl_WARN_ADD([-Wall], [WARN_CFLAGS])
gl_WARN_ADD([-Wpointer-arith], [WARN_CFLAGS])
  2. In the directories which shall use WARN_CFLAGS, use it in the definition of AM_CFLAGS, like this:
    AM_CFLAGS = $(WARN_CFLAGS)
    Note that the AM_CFLAGS is used in combination with CFLAGS and before CFLAGS in build rules emitted by Automake. This allows the user to provide CFLAGS that override the WARN_CFLAGS.
`gl_WARN_ADD([-Werror])' is intended for developers, and should be avoided in contexts where it would affect ordinary installation builds. The warnings emitted by GCC depend, to some extent, on the contents of the system header files, on the size and signedness of built-in types, etc. Use of `-Werror' would cause frustration to all users on platforms that the maintainer has not tested before the release. It is better if `-Werror' is off by default, and is enabled only by developers. For example, `-Werror' could affect `make distcheck' or `configure --enable-gcc-warnings' as mentioned above.

Next: manywarnings Prev: configmake Up: Build Infrastructure Modules Top: Top


manywarnings -- GNU Gnulib

Prev: warnings Up: Build Infrastructure Modules Top: Top

23.7. manywarnings

The manywarnings module allows you to enable as many GCC warnings as possible for your package. The purpose is to protect against introducing new code that triggers warnings that weren't already triggered by the existing code base.

An example use of the module is as follows:

gl_MANYWARN_ALL_GCC([warnings])
# Set up the list of the pointless, undesired warnings.
nw=
nw="$nw -Wsystem-headers"       # Don't let system headers trigger warnings
nw="$nw -Wundef"                # All compiler preprocessors support #if UNDEF
nw="$nw -Wtraditional"          # All compilers nowadays support ANSI C
nw="$nw -Wconversion"           # These warnings usually don't point to mistakes.
nw="$nw -Wsign-conversion"      # Likewise.
# Enable all GCC warnings not in this list.
gl_MANYWARN_COMPLEMENT([warnings], [$warnings], [$nw])
for w in $warnings; do
  gl_WARN_ADD([$w])
done
This module is meant to be used by developers who are not very experienced regarding the various GCC warning options. In the beginning you will set the list of undesired warnings (`nw' in the example above) to empty, and compile the package with all possible warnings enabled. The GCC option -fdiagnostics-show-option, available in GCC 4.1 or newer, helps understanding which warnings originated from which option. Then you will go through the list of warnings. You will likely deactivate warnings that occur often and don't point to mistakes in the code, by adding them to the `nw' variable, then reconfiguring and recompiling. When warnings point to real mistakes and bugs in the code, you will of course not disable them.

There are also many GCC warning options which usually don't point to mistakes in the code; these warnings enforce a certain programming style. It is a project management decision whether you want your code to follow any of these styles. Note that some of these programming styles are conflicting. You cannot have them all; you have to choose among them.

When a new version of GCC is released, you can add the new warning options that it introduces into the gl_MANYWARN_ALL_GCC macro (and submit your modification to the Gnulib maintainers :-)), and enjoy the benefits of the new warnings, while adding the undesired ones to the `nw' variable.

Prev: warnings Up: Build Infrastructure Modules Top: Top


GNU Free Documentation License -- GNU Gnulib

Next: Index Prev: Build Infrastructure Modules Top: Top

GNU Free Documentation License

Version 1.3, 3 November 2008

Copyright © 2000, 2001, 2002, 2007, 2008 Free Software Foundation, Inc.
https://fsf.org/

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.
  • 0. PREAMBLE

    The purpose of this License is to make a manual, textbook, or other functional and useful document free in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

    This License is a kind of ``copyleft'', which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

    We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

  • 1. APPLICABILITY AND DEFINITIONS

    This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The ``Document'', below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as ``you''. You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

    A ``Modified Version'' of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

    A ``Secondary Section'' is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

    The ``Invariant Sections'' are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

    The ``Cover Texts'' are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

    A ``Transparent'' copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not ``Transparent'' is called ``Opaque''.

    Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

    The ``Title Page'' means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, ``Title Page'' means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

    The ``publisher'' means any person or entity that distributes copies of the Document to the public.

    A section ``Entitled XYZ'' means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as ``Acknowledgements'', ``Dedications'', ``Endorsements'', or ``History''.) To ``Preserve the Title'' of such a section when you modify the Document means that it remains a section ``Entitled XYZ'' according to this definition.

    The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

  • 2. VERBATIM COPYING

    You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

    You may also lend copies, under the same conditions stated above, and you may publicly display copies.

  • 3. COPYING IN QUANTITY

    If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

    If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

    If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

    It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

  • 4. MODIFICATIONS

    You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

    • A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.

    • B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.

    • C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

    • D. Preserve all the copyright notices of the Document.

    • E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

    • F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.

    • G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.

    • H. Include an unaltered copy of this License.

    • I. Preserve the section Entitled ``History'', Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled ``History'' in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

    • J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the ``History'' section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

    • K. For any section Entitled ``Acknowledgements'' or ``Dedications'', Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.

    • L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.

    • M. Delete any section Entitled ``Endorsements''. Such a section may not be included in the Modified Version.

    • N. Do not retitle any existing section to be Entitled ``Endorsements'' or to conflict in title with any Invariant Section.

    • O. Preserve any Warranty Disclaimers.
    If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

    You may add a section Entitled ``Endorsements'', provided it contains nothing but endorsements of your Modified Version by various parties---for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

    You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

    The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

  • COMBINING DOCUMENTS

    You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

    The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

    In the combination, you must combine any sections Entitled ``History'' in the various original documents, forming one section Entitled ``History''; likewise combine any sections Entitled ``Acknowledgements'', and any sections Entitled ``Dedications''. You must delete all sections Entitled ``Endorsements.''

  • COLLECTIONS OF DOCUMENTS

    You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

    You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

  • AGGREGATION WITH INDEPENDENT WORKS

    A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an ``aggregate'' if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

    If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

  • TRANSLATION

    Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

    If a section in the Document is Entitled ``Acknowledgements'', ``Dedications'', or ``History'', the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

  • TERMINATION

    You may not copy, modify, sublicense, or distribute the Document except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense, or distribute it is void, and will automatically terminate your rights under this License.

    However, if you cease all violation of this License, then your license from a particular copyright holder is reinstated (a) provisionally, unless and until the copyright holder explicitly and finally terminates your license, and (b) permanently, if the copyright holder fails to notify you of the violation by some reasonable means prior to 60 days after the cessation.

    Moreover, your license from a particular copyright holder is reinstated permanently if the copyright holder notifies you of the violation by some reasonable means, this is the first time you have received notice of violation of this License (for any work) from that copyright holder, and you cure the violation prior to 30 days after your receipt of the notice.

    Termination of your rights under this section does not terminate the licenses of parties who have received copies or rights from you under this License. If your rights have been terminated and not permanently reinstated, receipt of a copy of some or all of the same material does not give you any rights to use it.

  • FUTURE REVISIONS OF THIS LICENSE

    The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See https://www.gnu.org/licenses/.

    Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License ``or any later version'' applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation. If the Document specifies that a proxy can decide which future versions of this License can be used, that proxy's public statement of acceptance of a version permanently authorizes you to choose that version for the Document.

  • RELICENSING

    ``Massive Multiauthor Collaboration Site'' (or ``MMC Site'') means any World Wide Web server that publishes copyrightable works and also provides prominent facilities for anybody to edit those works. A public wiki that anybody can edit is an example of such a server. A ``Massive Multiauthor Collaboration'' (or ``MMC'') contained in the site means any set of copyrightable works thus published on the MMC site.

    ``CC-BY-SA'' means the Creative Commons Attribution-Share Alike 3.0 license published by Creative Commons Corporation, a not-for-profit corporation with a principal place of business in San Francisco, California, as well as future copyleft versions of that license published by that same organization.

    ``Incorporate'' means to publish or republish a Document, in whole or in part, as part of another Document.

    An MMC is ``eligible for relicensing'' if it is licensed under this License, and if all works that were first published under this License somewhere other than this MMC, and subsequently incorporated in whole or in part into the MMC, (1) had no cover texts or invariant sections, and (2) were thus incorporated prior to November 1, 2008.

    The operator of an MMC Site may republish an MMC contained in the site under CC-BY-SA on the same site at any time before August 1, 2009, provided the MMC is eligible for relicensing.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

  Copyright (C)  year  your name.
  Permission is granted to copy, distribute and/or modify this document
  under the terms of the GNU Free Documentation License, Version 1.3
  or any later version published by the Free Software Foundation;
  with no Invariant Sections, no Front-Cover Texts, and no Back-Cover
  Texts.  A copy of the license is included in the section entitled ``GNU
  Free Documentation License''.
If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the ``with...Texts.'' line with this:

    with the Invariant Sections being list their titles, with
    the Front-Cover Texts being list, and with the Back-Cover Texts
    being list.
If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.

Next: Index Prev: Build Infrastructure Modules Top: Top